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Introduction

A dobe Photoshop is one of the most important computer programs of
our age. It’s made photo editing a commonplace thing, something for
the everyperson. Still, Photoshop can be a scary thing (especially that first
purchase price!), comprising a jungle of menus and palettes and tools and
options and shortcuts as well as a bewildering array of add-ons and plug-ins.
And that’s why you're holding this book in your hands. And why I wrote it.
And why Wiley published it.

You want to make sense of Photoshop — or, at the very least, be able to work
competently and efficiently in the program, accomplishing those tasks that
need to get done. You want a reference that discusses how things work and
what things do, not in a technogeek or encyclopedic manner, but rather as an
experienced friend might explain something to you. Although step-by-step
explanations are okay if they show how something works, you don’t need rote
recipes that don’t apply to the work you do. You don’t mind discovering tricks,
as long as they can be applied to your images and artwork in a productive,
meaningful manner. You're in the right place!

About This Book

This is a For Dummies book, and as such, it was produced with an eye toward
you and your needs. From Day One, the goal has been to put into your hands
the book that makes Photoshop understandable and useable. You won't find
a technical explanation of every option for every tool in every situation, but
rather a concise explanation of those parts of Photoshop you're most likely
to need. If you happen to be a medical researcher working toward a cure for
cancer, your Photoshop requirements might be substantially more specific
than you’ll find here. But for the overwhelming majority of the people who
have access to Adobe Photoshop CS3, this book provides the background
needed to get your work done with Photoshop.

As I updated this book, I intentionally tried to strike a balance between the
types of images with which you’re most likely to work and those visually
stimulating (yet far less common) images of unusual subjects from faraway
places. At no point in this book does flavor override foundation. When you
need to see a practical example, that’s what [ show you. [ included a number
of images from PhotoSpin.com, my favorite subscription stock art source.
But, again, [ worked to ensure that each piece of artwork illustrates a tech-
nique and does so in a meaningful, nondistracting way for you.
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You'll see that I used mostly Apple computers in producing this book. That’s
simply a matter of choice and convenience. You'll also see (if you look
closely) that I shoot mostly with Canon cameras and use Epson printers.
That doesn’t mean that you shouldn’t shoot with Nikon, Sony, or Fuji, or that
you shouldn’t print with HP or Canon. If that’s what you have, if it’s the equip-
ment with which you’re comfortable, if it fulfills your needs, stick with it!

One additional note: If you're brand new to digital imaging and computers,
this probably isn’t the best place to start. I do indeed make certain assump-
tions about your level of computer knowledge (and, to a lesser degree, your
knowledge of digital imaging). But if you know your File=>Open from your
File>Close and can find your lens cap with both hands, read Chapter 1, and
you’ll have no problem with Photoshop CS3 For Dummies.

About the cover images

The image on the front of Photoshop CS3 For
Dummies represents some of the key concepts
of digital image manipulation. The flower photo
forms the “floor” of the “room.” Photographs are
the base upon which most Photoshop work is
built. The photo you open into Photoshop is the
foundation upon which you build creatively. The
blend from grayscale to color represents both
the progression of photography itself over the
years and the advances within Photoshop. (I dis-
cuss the Black & White palette a little later on.)

The “room” itself represents the “box” within
which you might find yourself thinking. It is
indeed possible to do great creative work while
thinking “inside the box.” But with Photoshop,
there's always the chance to think outside the
box, as you can see to the right where
Photoshop’s palettes provide an escape from
walls confining creativity. The mountains
beyond represent the heights to which we can
aspire. They're also (in contrast to most of the
rest of the elements in the cover image) virtually
unchanged in Photoshop — the natural and the
“true” among all the creative and artistic bits.

The grid that forms two of the walls does dual
duty. It not only represents alignment and order,
things Photoshop does very well, but with the
glow effect, it also represents the many and

varied electronic ways in which you can display
and distribute your artwork — the digital gal-
leries of the 21st Century. (The grid itself comes
from the very powerful Vanishing Point filter.)

Another of Photoshop’s important features,
Photomerge, is showcased by the panorama of
the glacier, which represents the environment.
Digital photography is much more environmentally
friendly than the film-and-darkroom photography
of past generations. The glacier also represents
global warming. Just a few short years ago,
according to the captain of the ship from which
we viewed the glacier, spectators considered
themselves very lucky to get a chance to see
“calving,” the separation (and resulting splash)
of a large piece of the glacier. While we were
present, calving occurred roughly every three
to five minutes. Someday in the not-too-distant
future, all that remains of that glacier might be
photographs, such as those from which the
panorama was created.

The image of the man viewing the panorama
represents your audiences. Much of what we
do should be about the people who view the
images. Whether you’re a portrait photographer
or a fine art photographer, whether a commer-
cial artist or a layout specialist, it's often all
about the audience. As a computer-generated




character, he also stands for (pun intended) the
3D features of Photoshop CS3 Extended. His
shadow climbs the wall realistically, something
that's easy to simulate in Photoshop with a layer
mask, a gradient, and a blur filter.

A new feature in Photoshop CS3, the Black &
White adjustment, provides incredible control
over the conversion from color to grayscale.
A great new feature, it's featured prominently.
The shape of the palette? It represents the abil-
ity to squeeze every last bit of artistic excel-
lence from the conversion process.

Tools remain the heart and soul of Photoshop,
and so Photoshop’s Toolbox is also featured in
the foreground. The ability to effect change to
parts of an image, rather than working only
globally, is what makes Photoshop so much
more powerful than the lesser image-editing

programs available. And note that the wonder-
ful new Quick Selection tool is itself being
selected.

The somewhat-threatening eyes to the left
represent the other “outside the box” — the
sometimes harmful or dishonest uses of photo
manipulation. Hopefully, as you work with the
power of Photoshop, you can resist any such
temptations. . . .

On the back cover, to the left, you see a photo
of a totem from Alaska, as well as a zoomed-in
view showing the individual pixels of which the
photo is comprised. In the center is a “before”
and “after” of one of the techniques you can
use to dress up your artwork. On the rightis a
portion of a digital airbrush painting, represent-
ing all the things beyond photography that you
can do in Photoshop.

How This Book Is Organized

Photoshop CS3 For Dummies is primarily a reference book. As such, you can
check the Table of Contents or the index for a specific subject, flip to those
pages, and get the information you need. You can also start at the beginning
and read cover to cover (just to make sure you don’t miss a single tip, tech-
nique, or joke). To give you an indication of the type of information in each
chapter, I organized the book into parts. Here’s a quick look at what sort of

content you can find in each part.

Part I: Breezing through Basic Training

The first set of chapters presents the basic operation of Photoshop, what you

need to know to get around in the program, and the core process of getting
images into Photoshop and back out again. If you're new to digital imaging,
and particularly unfamiliar with Photoshop, make sure to read Chapter 1

Introduction

through Chapter 3. If you've worked with Photoshop or another image-editing
program and aren’t quite sure about the concept of resolution or which file
formats are best for which purposes, don’t overlook Chapter 2. Chapter 4 is
the meat and potatoes of Photoshop: scanning and downloading images from
cameras, cropping to fit specific print and frame sizes, and printing or post-
ing your images on the Web. All in one nice, tidy package.
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Part 1I: Easy Enhancements for Digital Images

In Chapters 5 through 9, you discover ideas and techniques for improving the
appearance of your images. You read about fonality (the lightness and dark-
ness of the image), color correction (making the image’s color look natural),
and making selections to isolate individual parts of your image for correction.
Part I also includes a full chapter on the Raw file format for digital cameras —
what it is, why it’s important, and how to determine whether it’s right for you.
At the end of this part, I include a chapter on the most common problems in
digital photos: red-eye, wrinkles, and unwanted objects and people. And, yes,
that chapter includes what to do about those problems, too!

Part I1I: Creating “Art” in Photoshop

The chapters in Part Il take a walk on the creative side. Although not every-
one wants to use Photoshop as a digital painting program, everyone should
understand how to get around in the complex and daunting Brushes palette.
Compositing images (making one picture from two or more), adding text
(whether a simple copyright notice or an entire page), using paths, and
adding layer styles are all valuable skills for just about all folks who work
with Photoshop, even if they don’t consider their work to be art.

Part 1U: Power Photoshop

The two chapters in Part [V are more specialized than the rest of the book.
If you don’t work in a production environment (even cropping to the same
dimensions regularly can count as production), you might not need to use
Actions in Photoshop. But there’s far more to Chapter 16 than just Actions
and scripting! It also shows you how you can create an on-screen presenta-
tion that anyone can view, automatically generate a single page with small
thumbnail images of all your photos, and save paper by printing multiple
images on a single sheet. Chapter 17 is a brief introduction to those features
found only in Photoshop CS3 Extended. If you have Photoshop CS3 rather
than Photoshop CS3 Extended, you might be interested in the highly techni-
cal, very complex scientific, technical, video, and 3D features. Or not.

Part U: The Part of Tens

The final part of this book, The Part of Tens, was both the easiest and most
difficult section to prepare. It was easy because, well, the chapters are short.
It was incredibly tough because it’s so hard to narrow any Photoshop-related
list to just ten items. Photoshop is such a beautifully complex and deep pro-
gram that [ had a very hard time (as you'll read) restricting myself to just ten
favorite tips and tricks, just ten reasons a Wacom tablet can be your best friend,
and just ten reasons to own a digital camera. But I did it (more or less —
beware of hidden tips and tricks)!
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Conventions Used in This Book

To save some space and maintain clarity, | use an arrow symbol as shorthand
for Photoshop menu commands. [ could write this:

Move the cursor onto the word Image at the top of your screen and press
the mouse button. Continuing to press the mouse button, move the cursor
downward to the word Adjustments. Still pressing the mouse button, move
the cursor to the right and downward onto the words Shadow/Highlight.
Release the mouse button.

But it makes more sense to write this:
Choose Shadow/Highlight from the Image=>Adjustments menu.

Or even to use this:
Choose the Image=>Adjustments->Shadow/Highlight command.

You'll also note that I include keyboard shortcuts (when applicable) for both

Mac and Windows. Generally the shortcuts are together, with Mac always

first, and look like this:

Move the selection to a separate layer with the shortcut 3+Shift+J/
Ctrl+Shift+].

Icons Used in This Book

ERTURE

3

You'll see icons in the margins as you read this book, icons that indicate
something special. Here, without further ado, is the gallery:

This icon tells you I'm introducing a new feature, something just added to the
program with Photoshop CS3. If you're brand new to Photoshop yourself, you
can ignore this icon — it’s all new to you. If you're an experienced Photoshop
user, take note. Please note that in Chapter 17, just about everything is new,
and I decided that you really didn’t need to see this icon next to just about
every paragraph.

When | have a little secret or shortcut to share with you — something that
can make your life easier, smoother, more convenient — you see the Tip icon.

5
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WING/

This icon doesn’t appear very often, but when it does, read carefully! I
reserve the Warning icon for those things that can really mess up your day —
things that can cause you to lose work by ruining your file or messing up
Photoshop. If there were to be a quiz afterward, every Warning would be in
the essay section!

The Remember icon shows you good-to-know stuff, things that are applicable
in a number of different places in Photoshop, or things that can make your
Photoshop life easier.

You might notice this icon in a place or two in the book. It’s not common
because I exclude most of the highly technical background info: you know, the
boring techno-geek concepts behind Photoshop.

How to Use This Book

This is a reference book, not a lesson-based workbook or a tips-and-tricks
cookbook. When you have a question about how something in Photoshop
works, flip to the Table of Contents or the index to find your spot. You cer-
tainly can read the chapters in order, cover to cover, to make sure that you
get the most out of it. Nonetheless, keep this book handy while you work in
Photoshop. (Reading cover to cover not only ensures that you find out the
most about Photoshop, but it guarantees that you don’t miss a single cartoon
or joke.)

Unless you're borrowing a friend’s copy or you checked this book out of the
library, I suggest you get comfortable with the thought of sticky notes and
bent page corners. Photoshop is a very complex program — no one knows
everything about Photoshop. And many concepts and techniques in
Photoshop are hard to remember, especially if you don’t use them often.
Bookmark those pages so they're easy to find next time because you're sure
to be coming back time and again to Photoshop CS3 For Dummies.
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A solid understanding of certain basic concepts
and techniques makes learning Photoshop
much easier. Heck, it’s difficult to understand a
discussion of feathered selections when you don’t
know pixels from a hole in the ground, right?

In Chapter 1, I introduce you to Adobe Photoshop.
Chapter 2 focuses on the basic concepts of digital
imaging and offers a look at the primary file for-
mats in which you save Photoshop images. Even if
you’re upgrading to CS3, spend a little time with
Chapter 3, which presents the new Photoshop
interface. Finally, Chapter 4 covers bringing
images into Photoshop from digital cameras or
scanners, organizing those files, and basic output
through printing or a Web site.
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Welcome to Photoshop!

In This Chapter

What Photoshop does very well, kind of well, and just sort of, well . . .
What you need to know to work with Photoshop
What you need to know about installing Photoshop

A dobe Photoshop is, without question, the leading image-editing program
in the world. Photoshop has even become somewhat of a cultural icon.
[t’s not uncommon to hear Photoshop used as a verb (“That picture is obvi-
ously Photoshopped!”), and you’ll even see references to Photoshop in the
daily comics and cartoon strips. And now you’re part of this whole gigantic
phenomenon called Photoshop.

Whether you're new to Photoshop, upgrading from Photoshop CS2 or earlier,
or transitioning from Elements to the full version of Photoshop CS3
or Photoshop CS3 Extended, you're in for some treats.
Photoshop CS3 has some intriguing new capabilities
that enable you to do more, and more easily, than
ever. Before I take you on this journey through the
intricacies of Photoshop, [ want to introduce you to
Photoshop in a more general way. In this chapter, I
tell you what Photoshop is designed to do, what it
can do (although not as capably as job-specific soft-
ware), and what you can get it to do if you try really,
really hard. I also review some basic computer oper-
ation concepts and point out a couple of places
where Photoshop is a little different than most other
programs. At the end of the chapter, | have a few tips
for you on installing Photoshop to ensure that it runs
properly.
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Exploring Adobe Photoshop

Photoshop is used for an incredible range of projects, from editing and cor-
recting digital photos to preparing images for magazines and newspapers to
creating graphics for the Web. You can also find Photoshop in the forensics
departments of law-enforcement agencies, scientific labs and research facili-
ties, and dental and medical offices, as well as in classrooms, offices, studios,
and homes around the world. As the Help Desk Director for the National
Association of Photoshop Professionals (NAPP), I solve problems and provide
solutions for Photoshop users from every corner of the computer graphics
field and from every corner of the world. People are doing some pretty amaz-
ing things with Photoshop, many of which are so far from the program’s
original roots that it boggles the mind!

What Photoshop is designed to do

Adobe Photoshop is an image-editing program. It’s designed to help you edit
images — digital or digitized images, photographs, and otherwise. This is the
core purpose of Photoshop. Over the years, Photoshop has grown and devel-
oped, adding features that supplement its basic operations. But at its heart,
Photoshop is an image editor. At its most basic, Photoshop’s workflow goes
something like this: You take a picture, you edit the picture, and you print the
picture (as illustrated in Figure 1-1).

Figure 1-1: Basic Photoshop: Take photo, edit photo, print photo. Drink coffee (optional).

Whether captured with a digital camera, scanned into the computer, or cre-
ated from scratch in Photoshop, your artwork consists of tiny squares of
color, which are picture elements called pixels. (Pixels and the nature of
digital imaging are explored in depth in Chapter 2.) Photoshop is all about
changing and adjusting the colors of those pixels — collectively, in groups, or
one at a time — to make your artwork look precisely how you want it to look.
(Photoshop, by the way, has no Good Taste or Quality Art filter. It’s up to you
to decide what suits your artistic or personal vision and what meets your
professional requirements.) Some very common Photoshop image-editing tasks
are shown in Figure 1-2: namely, correcting red-eye and minimizing wrinkles
(both discussed in Chapter 9); and compositing images (see Chapter 10).
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Astronaut image courtesy of NASA
Figure 1-2: Some common Photoshop tasks.

New in Photoshop CS3 is the powerful Black and White adjustment (found in
the Imager>Adjustments menu). Used to convert the appearance of a color
image to that of a black and white (or grayscale) photo, it lets you blend the
content of the various component colors to achieve a perfect grayscale
image. As you can see in Figure 1-3, you also have the option of creating a
sepia or tinted version of the image.

Figure 1-3: The Black and White adjustment gives incredible control over grayscale and tinted
conversions.

11
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Photoshop CS3 and Photoshop CS3 Extended

Although there have been different versions of
“Photoshop” for years (Photoshop versus
Photoshop LE versus Photoshop Elements), this
is the first time that Adobe has marketed two dif-
ferent versions of Photoshop itself. Photoshop
CS3 and Photoshop CS3 Extended both have all
of Photoshop’s powerful image-editing, vector-
drawing, painting, and type capabilities.
Photoshop CS3 Extended also includes some
very specialized, highly technical features for
use in science, research, and video editing, and
for use with 3D modeling programs. (These fea-
tures are introduced in Chapter 17.)

So, if you have Photoshop CS3 rather than
Photoshop CS3 Extended, should you feel
cheated or like a second-class citizen? Nope!
Unless you specifically need those extended
features, there’s no real reason to purchase
them. But what if you got Photoshop CS3
Extended as part of a Creative Suite or Adobe
Bundle package of software — did you pay for

something you don’t need? Well, sort-of-yeah-
but-not-really. The folks who're really paying
extra for the extended features are those who
purchase Photoshop CS3 Extended as a stand-
alone program. The additional cost they pay
funds the research and development of the
extended features.

Sowhy didn't | getto choose between Photoshop
CS3 and Photoshop CS3 Extended when | ordered
my Bundle or Suite? Buying software shouldn't
be as complicated as, say, ordering a cup of
coffee. (Caf, de-caf, half-caf? Latte, espresso,
cappuccino? White, brown, or raw sugar? Cream,
half-and-half, milk, or skim? Small, medium,
large, super, or el grosso maxmo?) It could get
quite confusing. Imagine trying to wade through
all of the thousands of products if Adobe mar-
keted every possible combination as a separate
Bundle or Suite or Studio! You'd spend so much
time trying to find your perfect bundle, you'd
never get to use the software.

Over the past few updates, Photoshop has developed some rather powerful
illustration capabilities to go with its digital-imaging power. Although Photoshop
is still no substitute for Adobe Illustrator, Photoshop certainly can serve you
well for smaller illustration projects. (Keep in mind that Photoshop is a raster
art program — it works with pixels — and vector artwork is only simulated in
Photoshop.) Photoshop also has a very capable brush engine, which makes it
feasible to paint efficiently on your digital canvas. Figure 1-4 shows a compar-
ison of raster artwork (the digital photo, left), vector artwork (the illustration,
center), and digital painting (right). The three types of artwork can appear in
a single image, too. (Simulating vector artwork with Photoshop’s shape layers
is presented in Chapter 11, and you can read about painting with Photoshop
in Chapter 14.)

Photoshop CS3 includes some basic features for creating Web graphics,
including slicing and animations (but Web work is best done in a true Web-
development program, such as Dreamweaver). Photoshop even includes
special Web Photo Gallery features to help you create an entire Web site to
display your artwork, and a PDF Presentation feature to prepare on-screen
presentations, complete with transition effects between slides. (Read about
Web Photo Gallery and PDF Presentation in Chapter 16.)



Chapter 1: Welcome to Photoshop! 73

Figure 1-4: You can use Photoshop with raster images, vector artwork, and even to paint.

Other things you can do with Photoshop

Although Photoshop isn’t a page layout or illustration program, you certainly
can produce simple brochures, posters, greeting cards, and the like using
only Photoshop. (See Figure 1-5.) One of the features that sets Photoshop
apart from basic image editors is its powerful type engine, which can add,
edit, format, and stylize text as capably as many word-processing programs.
Photoshop even has a spell-check feature — not bad for a program that’s
designed to work with photos, eh?
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Figure 1-5: You can use Photoshop to create cards, posters, and brochures.
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Photoshop CS3 takes yet another giant step with the introduction of Smart
Filters. Smart Filters, which are applied to Photoshop’s Smart Objects, are
the long-awaited answer to the prayers of many in the creative world:
re-editable filters! In the past, you applied a filter to a copy of an image and,
if you changed your mind about what settings to use, you had to undo all
subsequent work or (gasp!) start from scratch. Smart Filters enable you to
change your mind and simply re-open the filter’s dialog box and apply differ-
ent settings to change your image enhancements or special effects. What a
time (and project) saver! (Smart Filters are discussed in Chapter 15; Smart
Objects are introduced in Chapter 10.)

Even if you don’t have the high-end video features found in Photoshop CS3
Extended, you can certainly supplement your video-editing program with
Photoshop CS3 (even if Photoshop can’t open and play movies you capture
with your video camera). From Adobe Premiere (or other professional video
programs), you can export a series of frames in the FilmStrip format, which
you can open and edit in Photoshop.

If you don’t have specialized software

Admittedly, Photoshop CS3 just plain can’t do some things. It won’t make you
a good cup of coffee. It can’t press your trousers. It doesn’t vacuum under the
couch. It isn’t even a substitute for iTunes, Microsoft Excel, or Netscape
Navigator — it just doesn’t do those things.

However, there are a number of things for which Photoshop isn’t designed
that you can do in a pinch. If you don’t have InDesign, you can still lay

out the pages of a newsletter, magazine, or even a book, one page at a time.
(With PDF Presentation, you can even generate a multipage PDF document
from your individual pages.) If you don’t have Dreamweaver or GoLive,
you can use Photoshop to create a Web site, one page at a time, sliced

and optimized and even with animated GIFs. You also have tools that

you can use to simulate 3D in Photoshop CS3, such as Vanishing Point

(see Chapter 10).

Page layout in Photoshop isn’t particularly difficult for a one-page piece or
even a trifold brochure. Photoshop has a quite-capable type engine, consider-
ing the program is designed to push pixels rather than play with paragraphs.
Photoshop even shows you a sample of each typeface in the Font menu.
Choose from five sizes of preview (shown in Figure 1-6) in Photoshop’s
Preferences=>Type menu. However, you can’t link Photoshop’s type contain-
ers, so a substantial addition or subtraction at the top of the first column
requires manually recomposing all following columns. After all, among the
biggest advantages of a dedicated page layout program are the continuity
(using a master page or layout) and flow from page to page. If you work with
layout regularly, use InDesign.
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Figure 1-6: Now in Photoshop CS3: Five sample font sizes!

Dreamweaver is a state-of-the-art Web design tool, with good interoperability
with Photoshop. However, if you don’t have Dreamweaver and you desperately
need to create a Web page, Photoshop comes to your rescue. After laying out
your page and creating your slices, use the Save for Web & Devices command to
generate an HTML document (your Web page) and a folder filled with the images
that form the page (see Figure 1-7). One of the advantages to creating a Web page
in Dreamweaver rather than Photoshop is HTML text. (Using Photoshop, all the
text on your Web pages is saved as graphic files. HTML text not only produces
smaller Web pages for faster download, but it’s resizable in the Web browser.)
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Figure 1-7: You can create an entire Web page in Photoshop.
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Viewing Photoshop’s Parts and Processes

\NG/
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In many respects, Photoshop CS3 is just another computer program — you
launch the program, open files, save files, and quit the program quite normally.
Many common functions have common keyboard shortcuts. You enlarge,
shrink, minimize, and close windows as you do in other programs.

Reviewing basic computer operations

Chapter 3 looks at Photoshop-specific aspects of working with floating
palettes, menus and submenus, and tools from the Options bar, but I want
to take just a little time to review some fundamental computer concepts.

Launching Photoshop

You can launch Photoshop (start the program) by double-clicking an image
file or through the Applications folder (Mac) or the Start menu (Windows).
Mac users can drag the Photoshop program icon (the actual program itself)
to the Dock to make it available for one-click startup. You can find the file
named Adobe Photoshop CS3 inside the Adobe Photoshop CS3 folder, inside
the main Applications folder. (Chapter 3 shows you the Photoshop interface
and how to get around in the program.)

Never open an image into Photoshop from removable media (CD, DVD, your
digital camera or its Flash card, Zip disks, jump drives, and the like) or from
a network drive. Always copy the file to a local hard drive, open from that
drive, save back to the drive, and then copy the file to its next destination.
You can open from internal hard drives or external hard drives, but to
avoid the risk of losing your work (or the entire image file) because of a
problem reading from or writing to removable media always copy to a local
hard drive.

Working with images

Within Photoshop, you work with individual image files. Each image is
recorded on the hard drive in a specific file format. Photoshop opens just
about any image consisting of pixels as well as some file formats that do not.
(File formats are discussed in Chapter 2.) Remember that to change a file’s
format, you open the file in Photoshop and use the Save As command to
create a new file. And, although theoretically not always necessary on the
Mac, I suggest that you always include the file extension at the end of the
filename. If Photoshop won’t open an image, it might be in a file format that
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Photoshop can’t read. It cannot, for example, open an Excel spreadsheet or a
Microsoft Word DOC file because those aren’t image formats — and Photoshop
is, as you know, an image-editing program. If you have a brand-new digital
camera and Photoshop won’t open its Raw images, check for an update to
the Adobe Camera Raw plug-in at

www . adobe . com/products/photoshop/cameraraw.html

You will find installation instructions for the update there. (Make sure to read
and follow the installation instructions exactly.)

Saving your files
You must use the Save or Save As command to preserve changes to your

images. And after you save and close an image, those changes are irre-
versible. When working with an important image, consider these three tips:

1~ Work on a copy of the image file. Unless you’re working with a digital
photo in the Raw format (discussed in Chapter 7), make a copy of your
image file as a backup before changing it in Photoshop. The backup
ensures that should something go horribly wrong, you can start over.
(You never actually change a Raw photo — Photoshop can’t rewrite the
original file — so you’re always, in effect, working on a copy.)

»* Open as a Smart Object. Rather than choosing File=>Open, make it a
habit to choose Files>Open As Smart Object. When working with Smart
Objects, you can scale or transform multiple times without continually
degrading the image quality, and you can work with Smart Filters, too!

1~ Save your work as PSD, too. Especially if your image has layers, save it
in Photoshop’s PSD file format (complete with all the layers) before
using Save As to create a final

copy in another format. If you Mok Fiotoshop
don’t save a copy with layers, 112100 before cosingy T Socument
going back to make one little
change can cost hours of work. e o) G
If you attempt to close an image pmmr——
or quit Photoshop without saving A @ i M i B
your work first, you get a gentle o st gl el
reminder asking whether you want (T

to save, close without saving, or
cancel the close/quit (as shown in Figure 1-8: Photoshop reminds you if you
Figure 1-8). haven't saved changes to an image.
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Keyboard shortcuts

Keyboard shortcuts are customizable in Photoshop (check out Chapter 3),
but some of the basic shortcuts are the same as those you use in other
programs. You open, copy, paste, save, close, and quit just as you do in
Microsoft Word, your e-mail program, and just about any other software.

I suggest that you keep these shortcuts unchanged, even if you do some
other shortcut customization.

Photoshop’s incredible selective Undo

Here’s one major difference between Photoshop and other programs. Almost
all programs have some form of Undo, enabling you to reverse the most
recent command or action (or mistake). Like many programs, Photoshop
uses the 88+Z/Ctrl+Z shortcut for Undo/Redo and the 88+Option+Z/Ctrl+
Alt+Z shortcut for Step Backward, which allows you to undo a series of
steps (but remember that you can change those shortcuts, as described in
Chapter 3). Photoshop also has, however, a couple of great features that let
you partially undo.

Painting to undo with the History Brush

You can use Photoshop’s History Brush to partially undo just about any filter,
adjustment, or tool by painting. You select the History Brush, choose a his-
tory state (a stage in the image development) to which you want to revert,
and then paint over areas of the image that you want to change back to the
earlier state.

You can undo as far back in the editing process as you want, with a

couple of limitations: The History palette (where you select the state to
which you want to revert) holds only a limited number of history states.

In the Photoshop Preferencesr>General pane, you can specify how many
states you want Photoshop to remember (to a maximum of 1,000). Keep in
mind that storing lots of history states takes up computer memory that you
might need for processing filters and adjustments. That can slow things
down. The default of 20 history states is good for most projects, but when
using painting tools or other procedures that involve lots of repetitive steps
(such as touching up with the Dodge, Burn, or Clone Stamp tools), a larger
number (perhaps as high as 60) is generally a better idea.

The second limitation is pixel dimensions. If you make changes to the image’s
actual size (in pixels) with the Crop tool or the Image Size or Canvas Size
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commands, you cannot revert to prior steps with the History Brush. You can
choose as a source any history state that comes after the image’s pixel
dimensions change but none that come before.

Here’s one example of using the History Brush as a creative tool. You open a
copy of a photograph in Photoshop. You edit as necessary. You use the Black
and White adjustment on the image to make it appear to be grayscale. In the
History palette, you click in the left column next to the step immediately
prior to Black and White to designate that as the source state, the appearance
of the image to which you want to revert. You select the History Brush and
paint over specific areas of the image to return them to the original (color)
appearance (see Figure 1-9). There you have it — a grayscale image with
areas of color, compliments of the History Brush!
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Figure 1-9: Painting to undo with the History Brush.
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Reducing to undo with the Fade command

Immediately after applying a filter or adjustment or using most of Photoshop’s
tools, you can choose Edit>Fade and change the opacity or blending mode with
which the previous step was performed. You might, for example, apply a sharp-
ening filter and then choose Edit=>Fade Unsharp Mask to change the blending
mode from Normal to
Luminosity. (Sharpening
only the luminosity of
your image, whether
with this technique or
in the Lab color mode,
prevents unwanted
color shifts along edges
in your images. Color
modes are discussed in
Chapter 6.) Or you
might apply the Motion
Blur filter and then
choose Edit=>Fade
Motion Blur (yes, the
name of the command
actually changes for

Fade
you) to reduce the
opacity of the blur to Dpacky s x e
75%. That gives you the Cancel
appearance of a back- wode: (Mo 19  reoew
and-forth motion while
leaving the subject
more readily recogniz-  Figure 1-10: Compare the original blur with a reduction using
able (see Figure 1-10).  the Fade command.

Installing Photoshop: Need to know

If you haven’t yet installed Photoshop CS3 (or the Adobe Creative Suite), here
are a few points to keep in mind:

+~ Install only into the default location. Photoshop is a resource-intensive
program. Installing it into the default location ([harddrive]=>Applications
on a Mac and C: \Program Files for Windows) ensures that it has
access to the operating system and hardware as necessary. Installing
into any other location or attempting to run Photoshop across a net-
work can lead to frustrating problems and loss of work in progress.
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1~ Disable all spyware and antivirus software before installing. Antivirus
software can intercept certain installation procedures, deeming them to
be hazardous to your computer’s health. That can lead to malfunctions,
crashes, lost work, frustration, and what I like to call Computer Flying
Across Room Syndrome. If you use antivirus software (and if you use
Windows, you'd better!), turn it off before installing any program, espe-
cially one as complex as Photoshop. You might find the antivirus pro-
gram’s icon in the Windows taskbar; or you might need to go to the Start
menu, use All Programs to locate the antivirus software, and disable it.
On Mac, check the Dock. And don’t forget to restart your antivirus
software afterward! If you already installed Photoshop and antivirus
software was running at the time, I urge you to uninstall and reinstall.
(Reinsert the Photoshop CS3 CD and launch the installer to use the
built-in uninstall feature.)

1~ If you use autobackup software, shut it down, too. Never run autobackup
software when installing software. Like antivirus software, it can also
lead to problems by interfering with the installer.

1 Connect to the Internet and activate right away. It’s best to run the
Photoshop installer while your computer is connected to the Internet.
That enables Photoshop’s activation process to happen right away,
making sure you can get started as soon as the installer finishes.

1~ If you have third-party plug-ins, install them elsewhere. Third-party
plug-ins — those filters and other Photoshop add-ons that you buy from
companies other than Adobe — can be installed into a folder outside
the Photoshop folder. You can then make an alias (Mac) or shortcut
(Windows) to that folder and drag the alias/shortcut to Photoshop’s
Plug-Ins folder. (If you have a multibutton mouse, right-click the folder to
create an alias/shortcut; Control+click if you're still using a one-button
mouse.) Why install outside the Photoshop folder? Should you ever
need to (gasp/) reinstall Photoshop, you won’t need to reinstall all your
third-party plug-ins. Just create a new alias/shortcut and move it into
Photoshop’s new Plug-Ins folder.

1 Check for plug-in updates. Go to the manufacturer’s Web site for each of
your third-party plug-ins and check for updates. This is especially impor-
tant if you're using an Intel-based Mac. Unless the plug-ins have been
updated (“Universal”), they won’t run. There’s a workaround, however.
In the Finder, go to [harddrive]=>Applications=>Adobe Photoshop CS3.
Right-click or Control+click on the program icon and choose Get Info. In the
Get Info window, select the option Open Using Rosetta. Photoshop will run
more slowly, but you’ll have your unupdated third-party plug-ins available.
When the plug-ins are finally updated (or you decide speed is more impor-
tant), reopen Get Info and deselect the Open using Rosetta check box.

21
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1~ If you have lots of plug-ins, create sets. Plug-ins require RAM (com-
puter memory that Photoshop uses to process your editing commands).
If you have lots of plug-ins, consider dividing them into groups accord-
ing to how and when you use them. Sort (or install) them into separate
folders. (Hint: Plug-ins that you use in many situations can be installed
into multiple folders.) When you need to load a specific set, do so
through the Photoshop Preferences=>Plug-Ins pane by designating a
second plug-ins folder and relaunching Photoshop.

1~ If you love fonts, use a font-management utility. If you have hundreds
of fonts (over the years, I've somehow managed to collect upward of
4,000 fonts), use a font-management utility to create sets of fonts accord-
ing to style and activate only those sets that you need at any given time.
Too many active fonts can choke the Photoshop type engine, slowing
performance. The Mac OS has Font Book built right in, or you can use
the excellent Suitcase Fusion from Extensis (www.extensis.com).
Extensis also offers Suitcase for Windows.



Knowing Just Enough
about Digital Images

In This Chapter

Understanding digital images
Discovering resolution

The many file formats of Photoshop

In the early days of photography, some less-advanced cultures viewed a
photo with great suspicion and even fear. Was that an actual person,
trapped in the paper? Did taking a photo steal a person’s soul? You know that
a camera doesn’t trap anyone inside the paper — and you can be pretty sure
about the stolen soul issue — but how much does the average shooter know
about digital images? And how much do you need to know about
digital images to work effectively in Photoshop?

The answers to those two questions are, “Not as much
as he/she should” and “Not as much as you might
fear.” In this chapter, I give you some basic informa-
tion about how digital images exist in Photoshop, a
real understanding of that critical term resolution,
and an overview of the different ways that you can
save your images. But most important, [ help you
understand the very nature of digital images by
explaining the world of pixels.

Welcome to the Philosophy Chapter!
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What Exactly Is a Digital Image?

Whether you take a picture with a digital camera or use a scanner to bring a
photo (or other artwork) into Photoshop, you are digitizing the image. That is,
digit not as in a finger or toe but as in a number. Computers do everything —
absolutely everything — by processing numbers, and the basic language of
computers is binary code. Whether it’s a photo of a Tahitian sunset, a client’s
name in a database, or the latest box score on the Internet, your computer
works on it in binary code. In a nutshell, binary code uses a series of zeros and
ones (that’s where the numbers part comes into play) to record information.
(In Photoshop, the actual number of zeros and ones used to record information
about each pixel in your image — 8 or 16 or 32 — is a critical concept for color,
as you can see in Chapter 6.) Binary code might look like this:

00100101 01010011 00011011 11010100 11101000 11000110
10101001 10010011 11010101 01011010 00101100 11101110

This example, of course, would be complete gibberish to a computer — if
those two lines turn out to be the launch code for some missile, it’s just a
coincidence.

So what does binary code have to do
with the wedding photos that you
took this weekend or the masterpiece
you must print for your thesis pro-
ject? An image in Photoshop consists
of tiny squares of color called pixels
(pixel is short for picture element), as
you can see in the close-up to the
right in Figure 2-1. The computer
records and processes each pixel in
binary code. These pixels replicate a
photo the same way that tiles in a Figure 2-1: That's not really Hugo the Bulldog;
mosaic reproduce a painting. it's a bunch of tiny, colored squares.

A tile in a mosaic isn’t face or sky or grass; rather, it’s beige or blue or green.
The tiles individually have no relationship to the image as a whole; rather,
they require an association with the surrounding tiles to give them purpose,
to make them part of the picture. Without the rest of the tiles, a single tile has
no meaning.

Likewise, a single pixel in a digital image is simply a square of color. It doesn’t
become a meaningful part of your digital image until it’s surrounded by
other pixels of the same or different color, creating a unified whole — a
comprehensible picture. How you manipulate those pixels, from the time you
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capture the image digitally until you output the image to paper or the Web,
determines how successfully your pixels will represent your image, your art-
work, your dream.

The True Nature of Pixels
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Here are some basic truths about pixels that you really need to know. Although
reading this section probably can’t improve your love life, let you speak to
the dead, or give you the winning lottery number, it can help you understand
what’s happening to your image as you work with it in Photoshop.

1~ Each pixel is independent. You might think that you see a car or a circle
or a tree or Uncle Bob in an image, but the image is actually only a
bunch of little colored squares. Although you can read about various
ways to work with groups of pixels throughout this book, each pixel
exists unto itself.

1~ Each pixel is square (except on TV). Really! Each pixel in a digital image
is square except when you’re creating images for television, which uses
nonsquare pixels. (That’s a rather specialized field, which I very briefly
address in Chapter 3.) It’s important that you understand the square-
ness of pixels because you sometimes have to deal with those pointy
little corners.

1~ Each pixel can be
exactly one color. ® ) £ 12 BighiStPark-0J.p3d @
That color can T
change as you edit or
alter the image, but
each pixel consists
entirely of a single
color — there’s no
such thing as a two-
tone pixel. Figure 2-2,
at 3,200 percent
zoom, shows each
pixel distinctly.

Unlike earlier ver-

sions of Photoshop, - . .
Photoshop CS3 can Figure 2-2: Each pixel is monotone, containing a single color

zoom in to 3,200 per- throughout the pixel.

cent. (The old limit

was 1,600 percent.) And, if you’re working on a Mac or use Windows
Vista, you can show or hide the pixel grid, the fine lines separating the
individual pixels when zoomed in, in the View>Show menu.
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1~ Smaller is better (generally speaking). The smaller each pixel, the
better the detail in an image. (However, when preparing images for the
Web, you need smaller images that invariably have less detail.) If you
capture an image of a dog in a park with 2 million pixels and capture the
same shot with only 30,000 pixels, it’s pretty obvious which image will
better show the individual blades of grass and the fur. Take a look at
Figure 2-3 for an example of this critical concept.

Smaller pixels also help hide those nasty corners of pixels that are some-
times visible along curves and diagonal lines. When the corners of pixels
are noticeable and degrade the image, you call it a bad case of the jaggies.

1~ Pixels are aligned in a raster. The term raster appears regularly when
you discuss images created from pixels. Raster, in this case, refers to the
nice orderly rows and columns in which pixels appear. Each image has a
certain number of rows of pixels, and each row is a certain number of
pixels wide — the columns. Within the raster, the pixels perfectly align
side to side and top to bottom.

Figure 2-3: More pixels (top) mean better detail.
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1 Every picture created with pixels is rectangular. Some images might
appear to be round, or star-shaped, or missing a hole from the middle, but
they aren’t unless you print them out and grab your scissors. The image
file itself is rectangular, even if it appears round. There are actually pixels
in those seemingly empty areas; the pixels are, however, transparent.

How Many Pixels Can Dance
on the Head of a Pin?

You hear the term resolution a lot when working with digital images. Digital
cameras have so-many megapixels of resolution, inkjet printers have so-much
by so-much resolution; to work in Photoshop CS3, your monitor must have a
resolution of at least 1,024 x 768 pixels; when printing your images, you must
use 300 pixels per inch (ppi) as your resolution (wrong!), but your Web images
must have a resolution of 72 ppi (again wrong!); and don’t forget your New
Year’s resolution!

Resolution revelations

In this wonderful world of digital imaging, you see resolution used in four
basic ways:

1~ Image resolution: /mage resolution is the size of your image’s individual
pixels when you print. I go into greater detail about this concept in the
upcoming section, “Picking an image resolution.”

1~ Camera resolution: Digital cameras capture each image in a specific
number of pixels. Check your camera’s user guide or open one of the
images in Photoshop and choose Imager>Image Size. Take a look at the
number of pixels that your camera records for the width and for the
height. Multiply the numbers together, divide by one million, and round
off the result. (If you're in the camera maker’s marketing department,
make sure that you round up.) That’s the megapixel (MP) rating for the
camera. Use it as a general guideline when shopping. If you create Web
graphics or snapshot-size prints, 3 or 4 MP is fine. For large prints, you
need at least 6 MP.

1 Monitor resolution: Monitor resolution determines how many pixels are
visible on-screen. Whether you use a Mac or a PC, you set the monitor
resolution at the system level (as shown in Figure 2-4). When you use a
higher monitor resolution, you get a larger workspace, but each pixel is
smaller, which might make some jobs tougher. Experiment to find a mon-
itor resolution that works just right for you.

27
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e Mac: Click the blue Apple menu in the upper-left corner of the
screen and choose System Preferences. Then click Displays. (Some
Apple monitors have a button on the bezel that automatically
opens the window for you.)

e Windows: Choose Start>Control Panel and then double-click
Display. Click the Settings tab to see what monitor resolutions
are available.

1~ Printer resolution: Unlike the three preceding terms, printer resolution
doesn’t involve pixels. Rather, a printer resolution tells you how many
tiny droplets of ink are sprayed on the paper. Remember that it takes
several droplets to reproduce a single image pixel — you certainly don’t
need an image resolution anywhere close to the printer’s resolution!
(See the following section for more on this.)
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Figure 2-4: Set a Mac's resolution through the System Preferences (left), a PC’s resolution
through the Control Panel (right).

Resolving image resolution

Image resolution is nothing more than an instruction to a printing device about
how large to reproduce each pixel. On-screen, when working in Photoshop,
your image has no resolution at all. An image that’s 3,000 pixels wide and
2,400 pixels tall looks and acts exactly the same in Photoshop whether you
have the image resolution at 300 ppi or 72 ppi. Same number of pixels, right?
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You can always check — or change — a picture’s resolution by choosing
Photoshop Imager>Image Size. The Image Size dialog box (which you can see
in Figure 2-5) has two separate but related sets of information about your
image. At the top, you see information about the actual image itself, in the
Pixel Dimensions area. Below, in the Document Size area, you see instructions
for a printing device — that “size” pertains only to printing and has no
impact on what you do in Photoshop.

Image Siie

PFixel Dimensions: 20.6M FT}
Width: 3000 ponels Tﬂ] Cancel
e
MHeight: | 2400 pinels ? v
Document Size.
Width: |10 inches 18
Je
Height: |8 inches _m
Resolution: 300 unl:fn:h_@
# scale Styles
QCnmtum Proportions
@ Resample knage

Bicubic (best for smooth gradients)

Figure 2-5: At the top, real information about your image. Below, simply printing instructions.

You'll find it very handy to change the pixel dimensions and the print size at
the same time in the Image Size dialog box. And, much to the delight of math-
challenged folks, the Image Size feature does most of the calculations. For
example, with the Constrain Proportions option selected, you enter a new
Width and Photoshop calculates the new Height automatically!
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Changing the size of your artwork with the Imaqe Size command

You have a number of ways to change
the size of your photos and other art.
In Chapter 4, I introduce you to
cropping (chopping off part of the
artwork to make it fit a certain size
or to improve its overall appearance
and impact). You can use Photoshop’s
Image Size command to change the
image dimensions or printing instruc-
tions without altering the composition,
which is the visual arrangement of
the image or artwork. All the content
of the original image is there, just at
a different size. Of course, as you can
see in Figure 2-6, if you reduce the
size of an image too much, some

of that original content can become
virtually unrecognizable.

If you know the specific pixel dimen-
sions that you need for the final
image — say for a Web page — you
can simply type a new number in one
of the upper fields in the Image Size
dialog box and click OK. In most
cases, you select all three check
boxes at the bottom of the dialog box,
enter your desired print width or
height (letting Photoshop calculate
the other dimension), enter your
desired print resolution, and click OK.
Of course, you probably want a little
more control over the process, don’t
you? Figure 2-7 gives you a closer look
at the Image Size dialog box.

LEERT

Figure 2-6: Asthe smaller image shows,
reducing an image too much isn’t good.
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Figure 2-7: Your choices can have a
substantial impact on the appearance of your
final image.

In the lower part of the Image Size dialog box, you have three decisions to
make. The first is rather easy: If you're resizing an image that uses layer
styles (see Chapter 12), you want to select the Scale Styles check box to pre-
serve the image’s appearance as it shrinks or grows. In a nutshell, layer styles
(such as shadows, glows, and bevels) are applied to a layer at a specific size.
You can scale the image without changing those sizes, or you can scale the
image and change the style sizes proportionally. Not scaling layer styles

can dramatically alter the appearance of a resized image, as you can see in
Figure 2-8. A slight bevel combined with a small drop shadow produces a
subtle 3D effect in the original (upper) image. Below, when the image is
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scaled down to f% the original size without scaling the effects, your chips
change to chumps, and the artwork is ruined.

Figure 2-8: Scaling an image without scaling its layer styles can ruin your image.

The middle check box, Constrain (L3 LATEE L
Proportions, should almost always
remain selected. Some exceptions
might come up, but you normally
want to preserve an image’s aspect
ratio (the relationship between height
and width) when resizing to prevent
distorting the image. Figure 2-9 shows
you what can happen when you scale
one dimension without constraining
the image’s proportions.

Figure 2-9: Resizing an image without
constraining proportions. Interesting, yes, but

The third check box, Resample useful?

Image, is the one that most often

requires the attention of that gray matter within your skull. Not only do you
need to decide whether you want to resample the image (change its pixel
dimensions), but you also need to decide how you want to resample. Refer to
Figure 2-7 to see that you have five different ways to calculate the change
(called resampling algorithms).
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Before I talk about those choices, Image Size

let me explain what happens when Pixel Dimensions: 16.0M P
the Resample Image box is left Widtk 3072 pixels Cancel
deselected. The top portion of the Height 2044 pixels =
Image Size dialog box becomes Document Size

unavailable — you can no longer wieth: [12.8 nches %)

make changes in the Pixel eight: 8.533 inches 18} ]u
Dimensions fields (as you see in Resolution: (240 pineissinch 78

Figure 2-10). The information is there,

but it won’t change. When you clear SRR
the Resample Image check box, you
protect the original pixels, preventing
any change to the image itself.

Figure 2-10: Clear the Resample Image check
So what's left? When using Image Size  box to change print size, not pixel dimensions.
without resampling, you're simply
changing the instructions recorded in the image for your printing device.
When you enter one dimension, either width or height, Photoshop does the
math and fills in both the other dimension and the new resolution.

Take a look at Figure 2-11. I cleared Image Size

the Resample Image check box and Pixel Dimensions: 16.0M —
entered 10 and inches for my new Width 1072 pixels e
print width in order to print this Height 2043 pixels e
image to a letter-size (8.5 x 11 inches) Document Size

sheet of paper. Photoshop fills in the wiéth. |10 nches %)

new height (6.667 inches) and a new eight: (6,667 inches 78] ];
resolution (307.2 ppi). But what if | Resolution: (307.2 pineissinch 78

want an 8 x 10 print? If [ enter 8 and
inches for the height, Photoshop
recalculates the width to 12 inches
and enters a resolution of 256 ppi. If [
want a true 8 x 10, [ have to crop
some of the image because a digital  Figure 2-11: Enter a value, and Photoshop
photo and an 8 x 10 have different recalculates the fields automatically.
aspect ratios. (You can read more

about that in Chapter 4.)

_ Resample Image

Okay then, back to the subject of resampling! When you resample an image
(change the pixel dimensions), Photoshop takes the image and maps it to the
new size, attempting to preserve the image’s appearance as much as possible
at the new size, using the new number of pixels. Of course, if you take an
image that’s more than 3,000 pixels wide and resample it to 300 pixels wide,
you’re going to lose some of the detail. (Remember what happened to Hugo
the Bulldog earlier in this chapter in Figure 2-3!)
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To resample or to crop: That is the question

—

To better understand the difference between
resampling an image and cropping an image, con-
sider this situation:

1. A painter paints a picture. He or she paints it
at whatever size he or she thinks is appropri-
ate. (Or, perhaps, on the only piece of canvas
he or she can afford on that particular day.)

2. A patron likes the artwork, but the painting
is too large for the frame that works best
with the dining room table. Yeah, patrons can
be like that, can’t they?

3. The patron asks the artist to make the paint-
ing fit the frame.

4. The artist decides between cropping and
resampling. He or she can grab a pair of scis-
sors and cut off some of the painting (crop-
ping) or re-create the painting from scratch at
a smaller size. Thankfully, Photoshop does the
“repainting” for you, using Image Size with its
resampling algorithms.

5. The artist charges the patron for the extra
work. (Don't forget this final, crucial step!)

Cropping cuts away part of the image to meet a target size. Resampling retains all the image but
shrinks or enlarges it to meet the target size.

Choosing a resampling method

After you decide to change the pixel dimensions of your image via the Image
Size command, you need to select one of the five resampling algorithms (take
another peek at Figure 2-7). Table 2-1 sums up my advice on choosing the
right one.

<P If you’ll be resizing a number of images in the same way, either upsampling or
downsampling, open Photoshop’s Preferences=>General and select the opti-
mal resampling method in the Image Interpolation menu. That algorithm then
becomes the default in Image Size, saving you the trouble of changing the
algorithm each time.
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égN\BER Keep in mind that the resampling method that you select in the Preferences
& is also used for the Edit=>Transform commands, which you use to scale,
rotate, and otherwise alter individual elements within your artwork. (You can
read about the Transform commands in Chapter 10.)

Table 2-1 Selecting a Resampling Algorithm
Algorithm  Use It For Results

Name

Nearest Artwork containing large areas of Maintains pixel color

Neighbor  solid color like a pie chart or a simple
logo; avoid using with photos

Bilinear Artwork having horizontal and vertical Maintains the sharpness
lines and blocks of your edges of
color, such as Web page buttons;
avoid using with photos

Bicubic General-purpose resampling for minor  Calculates the average of
changes in image size surrounding pixels when
generating a new pixel
Bicubic Increasing the size of photographic Gives the most pleasing
Smoother  images or artwork with gradients and  result when increasing the
gradual shifts in color number of pixels (upsampling)
Bicubic For reducing the number of pixelsina  Maintains the crispness
Sharper photo (downsampling), also can be of your image

used when upsampling beyond 200%

Picking an image resolution

After you have the concept of resampling under your belt, how do you know
what size you should be resampling to? How many pixels do you need? Here
are your general guidelines:

1+~ Photos for your inkjet printer:
Inkjet printers are stochastic
printing devices: That is, they
use a series of droplets to repli-
cate each pixel in your image, as
shown in Figure 2-12. In theory,
the optimal image resolution is
f¥% of the printer’s rated resolu-
tion. For example, a printer
rated at 720 ppi works best Figure 2-12: The close-up shows inkjet printer
with images at 240 ppi. For a droplets.
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1,440 ppi printer, the formula calls for an image resolution of 480 ppi
(and that goes for the 2,880 x 1,440 printers, too). However, most folks
find that regardless of the printer’s rating, they never need an image res-
olution higher than 300 ppi.

1~ Web images: Ignore resolution. Ignore the entire Document Size area of
the Image Size dialog box. Consider only the image’s pixel dimensions.
Determine what area of the Web page the image will occupy and then
resize to exactly those pixel dimensions.

1~ Page layout programs and commercial printing: If your image is to be
placed into a page layout program’s document and sent to a commercial
printing facility, you need to know the line screen frequency (the resolu-
tion, so to speak) of the printing press on which the job will be run. Ask
the print shop or the person handling the page layout. Your image reso-
lution should be either exactly 1.5 times or exactly twice the line screen
frequency. (You shouldn’t notice any difference in the final printed prod-
uct with either resolution.)

1~ PowerPoint presentations and word processing documents: Generally
speaking, 72 ppi is appropriate for images that you place into a presenta-
tion or Word document. You should resize to the exact dimensions of the
area on the page or slide that the image fills.

File Formats: Which Do Vou Need ?

After working with your image in s s
Photoshop, you need to save the Save i (M. 1132 99 8
changes. Choosing File>Save updates i »
the current file on your hard drive, P £l
maintaining the current file format CT T B @
when possible. If you added a feature a

to the file that isn’t supported by the e e e i 9900
original file format, Photoshop auto- LT R

matically opens the Save As dialog box o)
and shows you which features are not
supported by the selected file format.
In Figure 2-13, the lower part of the
Save As dialog box shows you the
yellow warning triangles that identify
options being used in the image that are not available when saving as a JPEG.

Figure 2-13: Photoshop shows you which
image features are not available in your
selected file format.

You can go ahead and save the image in that format, but your file will no longer
contain those unsupported features. In the example shown in Figure 2-13, I

can click the Save button and create a JPEG file, but that JPEG won’t have the
alpha channel (a saved selection), the spot channel (a custom printing color),
or the annotations (sort of electronic sticky notes you add to images with the
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Notes and Audio Annotation tools); and it will be flattened to a single layer.
If I want to retain those features in the file,  need to choose a different file
format, such as Photoshop’s own PSD format. (Read more about alpha chan-
nels in Chapter 8 and about spot channels in Chapter 6.)

No matter which of the file formats you choose, if you add layers, type,
adjustment layers, channels, or paths to your image, keep the original as an
unflattened/unmerged (all the layers are preserved) Photoshop (PSD) or
layered TIFF file. In the future, should you ever need to make changes to the
image or duplicate an effect in the image, you won’t need to start from scratch.

Formats for digital photos

If you print your images yourself at home or the office, you can stick with the
original format or use the PSD Photoshop format. If you send the photos to
the local camera shop (or discount store) for printing, stick with JPEG — or,
if they accept it, TIFF. Here are the pros and cons of the major formats that

you should consider for photos:

1~ PSD: Photoshop’s native file format is great for saving your images with
the most flexibility. Because the PSD format supports all of Photoshop’s
features, you don’t need to flatten your images — and keeping your
layers lets you make changes later. If your file size is very large (4MB or
larger), make a TIFF or JPEG copy before printing, flattening all the
layers. Don’t send PSD files to the local shop for prints.

v~ TIFF: Although the TIFF file
format (as you use it in Photo-
shop) can save your layers and
most other Photoshop features,
make sure to choose Layersw
Flatten Image before sending
files out for printing. Layered
TIFF files generally are compati-
ble only with programs in the
Creative Suite. If you don'’t flat-
ten the image prior to saving as
TIFF or if you elect to include
layers when saving as TIFF,
Photoshop presents you with a
gentle reminder, as shown in
Figure 2-14.

1 JPG: JPEG, as it’s called, is actu-
ally a file-compression scheme
rather than a file format, but

image Comprei tion P
) NONE
LO% Cangel
ar
PG
W S Adobe Mhatashop
& interleaved (RGERGE) ; ” =
Per Channel (RRGLDS) m :‘:.ﬂﬂ'w Lavers will increate
Byte Ovcer
By PC .
& Macintosh Sl o)
— Sk Image Pyvamid _ Don't show again

Layer Comprassion
) ALE ifaster saves, begoer filesd
2P talowsr saver. umaler flex)
Discard Layers and Save a Copy

Figure 2-14: Flatten layers before saving a TIFF
for use in other programs.

that’s not important. What is important is that JPEG throws away some
of your image data when it saves the file. Save important images in
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PSD or TIFF and use JPEG only for copies. When should you use JPEG?
When sending images to a photo lab that doesn’t accept TIFF files and
when sending images (perhaps by e-mail or on CD) to people who don’t
have Photoshop. Unlike PSD and TIFF, you can open JPEG images in a Web
browser and print from there — and so can Granny, and Cousin Jim, and
that overseas soldier you adopted. When saving JPEGs, the lower the
Quality setting you choose in the JPEG Options dialog box, the smaller
the file but also the more damage to the image. I discuss saving as JPEG
in more detail in the sidebar, “Resaving images in the JPEG format.”

1~ PDF: It’s easy to overlook Adobe’s PDF format when talking about photos,
but you should consider using this format. Although the local photo lab
probably won'’t accept it, it’s a great format for sharing your pictures
with folks who don’t have Photoshop. Unlike JPEG, your images won’t be
degraded when saving as PDF; and like JPEG, just about anyone with a
computer can view the files. (Adobe Reader, which you can use with PDFs,
is found on just about every computer now, just like Web browsers for
JPEG.) Keep in mind, however, that PDF files are larger than JPEGs.

1~ Large Document Format (PSB): Really, really, really big pictures — over
30,000 pixels wide or long or both — need to be saved in the PSB file
format. Will you ever need this format? Consider that 30,000 pixels at a
photo-quality resolution of 300 ppi is 100 inches long. At a resolution of
85 ppi, more appropriate for a long banner to hang in a hallway, you're
talking about artwork that stretches almost 30 feet! Can your printer do
that? If not, you probably don’t need the PSB file format.

You could theoretically use a number of other available formats, such as DCS,
PNG, and Photoshop Raw, but there’s no real need with the more common
and more versatile formats about which you just read.

If you're working with photos from your digital camera and you want to save
them as JPEG but that format isn’t available in the Save As dialog box, con-
vert the image to 8-bit color with Imager>Moder>8-Bits/Channel. If you shot
the image in Raw (or TIFF) and need to save as JPEG, you’ll have to convert
to 8-bit color because JPEG doesn’t support 16-bit color.

Formats for Web graphics

Generally speaking, you use Photoshop’s Save for Web & Devices command
rather than Save As to generate copies of your images for use on a Web site
or for use with cellphones, PDAs, and other such devices. Here are the three
file formats that you need for the Web:

1 JPG: Use JPEG for photos. Remember to resize the photo so that it fits
on a Web page. When selecting a Quality setting, you need to balance
image appearance with file size. A smaller file downloads (and displays
in a Web browser) faster, but a larger file generally looks better. If you
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WNG/

reduce the Quality setting until just before the [ o3| o
image doesn’t look great, you’ve hit the sweet
spot — the compromise between file size and
image quality.

1+~ GIF: GIF is more appropriate for items like @l@tf yi
Web buttons and banners (such as those :|'|F.! =
shown in Figure 2-15) than it is for photos. EEV ergreens|

If you save a photo that’s more than perhaps g
100 x 100 pixels in size, you might see some
degradation of the image quality as similar S s
colors become one color. When you save an niinutrition!
image as GIF, it can contain no more than e -y o
256 distinct colors. JPEG and the other UM Muﬁdjﬁ'f
common file formats can have thousands i
of different colors.

1 PNG: PNG comes in two types: PNG-8 (which
is a substitute for GIF) and PNG-24 (which is 3| 1 [
a substitute for JPEG). PNG has a couple of Eontactus;
advantages for Web designers, such as sup- (11| |
port for transparency, but not all Web .
browsers can display PNG graphics. Generally Figure 2-15: Use GIF for Web
speaking, it’s safer to use JPEG and GIF. interface items.

BE |

Formats for commercial printing

You're the Photoshop master of your office. Everyone knows that you under-
stand everything about digital images. So you're the right person to create
the company’s new brochure. Except you're a photographer. Or you're a Web
designer. Or you're actually pretty new to Photoshop. And you don’t have a
clue about preparing images for a commercial printing press.

Here’s what you need to know about file formats for those CMYK (cyan/
magenta/yellow/black) color images that you're sending to the print shop:

v~ TIFF: TIFF is generally a solid choice. Use TIFF for photographic images
that don’t contain any type layers.

1~ EPS: Choose EPS if your image has type. Don’t flatten or merge the type
layers before using Save As to create the EPS. In the EPS options, make
sure to select the Include Vector Data check box to ensure that your
type prints perfectly.

If you reopen an EPS file in Photoshop, your type layers get merged.
Don’t! Instead, make sure to save your original file as PSD and, should
you need to make changes, open the PSD and create a new EPS file when
you're done editing.

1~ PDF: PDF offers the same disadvantage (don’t reopen in Photoshop) as
the EPS file format. But it also offers support for spot color channels,
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alpha channels, and paths — options not supported by EPS. (Spot chan-
nels are used with custom colors, and alpha channels store information
about transparency in the image.) If your file uses any of these features,
choose PDF over EPS, if your print shop accepts PDFs.

When saving as PDF, the PDF Options dialog box offers you Preserve
Photoshop Editing Capabilities. If you select the option, the PDF file will
reopen in Photoshop CS3 with layers and editable type. However, this
option isn’t compatible with Photoshop CS and earlier, and it can cause
problems in a page-layout program other than InDesign.

1~ PSD: Use PSD only if you're adding the image file to a project in Adobe

InDesign. Don’t send PSD files to a print shop.

1 DCS: DCS 2.0 is a variation of the EPS file format that supports spot

color channels and alpha channels. Use it primarily with QuarkXPress.

Resaving images in the JPEG format

JPEG uses a lossy compression scheme: That
is, as part of the compression process, it actu-
ally permanently throws away some data when
you save your image. The lower the Quality set-
ting, the more image degradation. Take a look at
the figure here. The original image is on the
left. In the middle is the same image saved in
JPEG format with high quality and then on the
right with low quality. See what | mean by
degradation?

If you save by using JPEG a second time, even
more data is thrown away. Every time you save,
your image quality suffers. Yes, indeed, you
might sometimes need to open a JPEG image,
make some changes, and save as JPEG again
(perhaps for the Web, perhaps to share with
non-Photoshop friends and family). To minimize
damage to the image, either use the highest set-
ting (12) for the Quality setting or (if you know it)
the exact same setting used last in Photoshop.

M A M § © P5003008.6f @ 300K MG.... |

©1997 PhotoSpin, PhotoSpin image #PS003008
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Formats for PowerPoint and Word

If the final destination of your image is PowerPoint or Microsoft Word, use the
PNG file format. If your image has areas of transparency in it, PNG is definitely
the way to go. (Read about the two types of PNG files in “Formats for Web
graphics,” earlier in this chapter.)

And what about all that neat clip art that you have on your hard drive?

How do you use those images when Photoshop won’t open the vector-based
WMF and EMF clip art files? Here’s how you get clip art into Photoshop, quick
and easy:

1.

Open a new document in Microsoft Word (or a comparable word pro-
cessing program).

. Add the clip art.

In Word, choose Insert=>Picturer>Clip Art (or your word processor’s com-
parable command). Click directly on the artwork and drag the lower-right
corner to resize it to the dimensions that you need in Photoshop. (The art-
work comes into Photoshop at 300 ppi.)

. Choose Edit=>Copy.

This copies the image to the Clipboard (the computer’s memory) in Word.

4. Switch to your Photoshop document.
5. Choose Edit~>Paste.

You have your clip art, ready to use in Photoshop! Use the Edit~
Transform commands to scale, rotate, and otherwise fit the clip art into
your design. (See Figure 2-16.)

anp Srochure.psd @ 12.5% (Layer 1, RGB/8)

FROM CLIPART TO CAMERA

Figure 2-16: Copy vector artwork from Word and paste into Photoshop.
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Taking the Chef's Tour of Your
Photoshop Kitchen

In This Chapter

Understanding the general guidelines for working in Photoshop
Working more efficiently with customization

Determining your preferences and color settings
Troubleshooting Photoshop

Iknow you’re hungry to dive right in and start mixing up some master-
pieces, but before you fire up the stove, look around the kitchen. Get to
know your spoons from your ladles, your pots from your pans, figure out how
to turn on the blender . . . that sort of thing.

In this chapter, rather than going through all the Photoshop
CS3 menus, palettes, and tools (which would take several
hundred very boring pages), I show you some basic
operational concepts. (But don’t worry — you can

read about how to use specific commands and tools )
throughout the book, in the chapters most appropri- .t
ate for them.) Here you discover such things as how
to spot which menu commands have dialog boxes,
what the little symbol in the upper-right corner of a
palette does, and which tools don’t use the Options
bar. You also read about customizing your Photoshop
environment for faster and more efficient work. Next |
show you how to set up Photoshop’s Preferences and
Color Settings. And to wrap up the chapter — perhaps the
most important section in this entire book — I explain what to
do when Photoshop doesn’t seem to be working properly.
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Food for Thought: How Things Work

3

A good understanding of certain fundamental operations and features in
Photoshop provides you with the background that you need in order to
follow the recipes or get creative and whip up some delicious artwork.

And don’t forget about Photoshop’s Tool Tips. If you don’t know what some-
thing or some option does, park your cursor over it for a couple of seconds,
and Photoshop provides its information in a little box.

Ordering from the menus

When you’re working in Photoshop, you see a horizontal list of menus spread
across the very top (Mac) or near the top (Windows) of the screen: File,

Edit, Image, Layer, Select, Filter, View, Window, and Help. (If you also see the
Analysis menu, you have Photoshop CS3 Extended.) On the Mac, the program
also has a menu named Photoshop, just to the left of the File menu.

As with most programs you use, you @ PMhowshop file  Edic [[EEEEN Loyer Selea filr  View  Window Help
b -

Mode

click the name of a menu to reveal Adusmerts

its commands. For both Mac and Pyt

Windows, you can click and hold s S

down the mouse button until you're s R

over the command you want; or, TTT—— o
you can click and release, move the e e

cursor, and then click again. Some
commands, such as Crop and Reveal
All, are executed immediately after
you choose them. When a command
name in the menu is followed by Figure 3-1: Some commands have submenus,
an ellipsis (. . .) — the Apply Image and some have dialog boxes.

command shown in Figure 3-1, for

example — you know that a dialog box will open so that you can input vari-
ables and make decisions. A triangle to the right of a command name, such as
what you see next to Rotate Canvas, indicates a submenu. If you click the
command name, another menu appears to the right. The cryptic set of sym-
bols to the right of the Image Size command is the keyboard shortcut for
opening the command’s dialog box. (I show you how to assign keyboard
shortcuts later, in the section “Sugar and spice, shortcuts are nice.”)

Flip Camvvas Horizonial
Flp Caveas Vertical

As you read in the upcoming section, “Clearing the table: Custom work-
spaces,” Photoshop CS3 menus are customizable — you don’t have to see
commands that you never use. You can also color-code your menu com-
mands, making it easier to spot those that you need regularly.
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When a specific command appears grayed out in the menu (in gray type rather
than black), that command isn’t available. Some commands, such as Reveal All
in Figure 3-1, are available only under specific circumstances, such as part of
the image being hidden with the Crop tool. When working with Photoshop’s
creative filters, you'll find that many aren’t available unless you're working with
an 8-bit RGB (red/green/blue) image. (Color modes and bit depth are discussed
in Chapter 6; filters are explored in Chapter 15.)

Your platter full of palettes

Photoshop, like the other programs of the Adobe Creative Suite, uses floating
palettes. The palettes, many of which you see along the right edge of your
screen, always appear on top of (float over) your image window. The image
window will never hide your palettes. (Palettes, however, can hide other
palettes.) The Options bar across the top of the work area and the Toolbox,
or toolbar, along the left edge of the screen are also palettes.

Palettes contain Photoshop features that you might need to access regularly
enough that using a menu command is inconvenient. (I can’t imagine having
to mouse to a menu command every time [ want to change tools or select a
specific layer!) You don’t always need to have your palettes visible. In Photo-
shop, press the Tab key to hide all the palettes or press Shift+Tab to hide all
but the Toolbox and the Options bar. With fewer palettes visible, you provide
more room for your image. You can selectively hide and show palettes via the
Window menu.

New in Photoshop CS3 are expanding/collapsing palette docks (which replace
the Palette Well). As shown to the right in Figure 3-2, clicking the double-
arrow button at the top of a stack of palettes collapses that stack to a tidy
group of icons. While the Navigator, Color, and Layers palettes are fully visi-
ble, the History, Actions, Tool Presets, Brushes, Clone Source, Character,
Paragraph, and Layer Comps palettes all together occupy only a tiny fraction
of the screen. In the insert in the middle of Figure 3-2, you can see that even
when a palette is collapsed, it’s easily accessible with a single click.

By clicking and dragging a palette’s tab when the palette isn’t collapsed, you
can move it to another grouping or pull it out of its grouping and away from
the edge of the screen. You might, for example, want to drag the new Clone
Source palette away from its buddies to make it more easily accessible while
performing a complex clone operation. (The Clone Source palette is used
with the Clone Stamp tool. You can specify up to four different source loca-
tions and easily switch among them.)
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Figure 3-2: Nesting and collapsing palettes opens up the work area.
Many of the palettes are resizable. ey >
Like an image window, you drag the B s W
lower-right corner of the palette to Source 3
expand or contract it. Almost all the = oo Source 4
Photoshop palettes have a palette xfoe B, M
menu, from which you select various ¥iS e ape &
options. (The Toolbox and Options e 28 o— show Overlay
bar don’t have menus.) You open the e :‘"‘;fn“ét'?:"“
palette menu by clicking the small — b ie kL

button in the upper-right corner of the
palette, as shown in Figure 3-3. The
palette menu contains such options

as thumbnail size (for example, the
Layers, Channels, and Paths palettes);
how to display items in the palette (Swatches, Styles, and Brushes among
others); or even the size and content of the palette (Info and Histogram).

Figure 3-3: Access a palette’s menu by
clicking the button below the X. (Clicking the X
closes the palette group.)



A\

3

Chapter 3: Taking the Chef’s Tour of Your Photoshop Kitchen 4 5

You might have noticed in Figure 3-2 that the Photoshop Toolbox is now one
tall skinny column along the left edge of the screen to free up even more work-
space. If you prefer the traditional two-column Toolbox, click the Expand/
Collapse button (the double arrow) at the top of the column.

The content of some palettes changes automatically as you work with your
image. Add a layer, and the Layers palette shows a new layer. Save a selec-
tion, and the Channels palette shows a new alpha channel. If you drag

a shape tool, the Layers palette gets

a new layer, and the Paths palette Présat Minager

shows the layer’s vector mask. Preset Type m b
You control some other palettes by sl cases w »
loading and deleting content through *1212 ol P

the palette menus or with the A F e -

Edit=>Preset Manager command. cTaTE Teos ks

Use the Preset Manager (as shown
in Figure 3-4) to save sets of your
custom bits and pieces as well as
to load and delete items from the Figure 3-4: Use the Preset Manager to control
palettes. the content of a number of palettes.

In addition to the content of the Brushes, Swatches, Styles, and Tool Presets
palettes, you use the Preset Manager with a number of pickers. Pickers are
sort of mini-palettes, available only with certain tools or features. The
Gradient and Custom Shape pickers are accessed through the Options bar
when those tools are in use. The Pattern picker is found in the Fill dialog box,
the Layer Style dialog box, and (with some tools) in the Options bar. The
Contour picker is used with six of the effects in the Layer Style dialog box.

When you create custom layer styles, brushes, gradients, and the like, use
the Preset Manager to protect your work. Create sets of the items and save
those sets with the Preset Manager. Then remember to save copies of the
sets someplace on your hard drive outside the Photoshop folder so that
you don’t accidentally delete them if you ever (oh, no!) have to reinstall
Photoshop. Remember that new content of your palettes is stored only in
Photoshop’s Preferences file (introduced later in this chapter) until you
create and save sets.

The tools of your trade

You control the behavior of Photoshop’s tools through the Options bar.
With the exception of a few path-related tools (Direct Selection, Add Anchor
Point, Delete Anchor Point, and Convert Point), every tool in Photoshop has
options. The Options bar changes as you switch tools. In some cases, the
Options bar changes while you work with the tool. In the case of the Crop
tool, as shown in Figure 3-5, you have one set of options before you drag the
tool and another set after establishing the bounding box.
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Figure 3-5: The Options bar changes when you have an active crop marquee.

The behavior of some tools changes when you add one or more modifier
keys (88, Shift, and Option for the Mac; Ctrl, Shift, and Alt for Windows).
As an example of how modifier keys can affect tool behavior, consider the
Rectangular Marquee and Elliptical Marquee tools:

1+ Hold down the Shift key while dragging. Normally the marquee selec-
tion tools are freeform — you drag however you like. When you hold
down the Shift key while dragging, on the other hand, you constrain the
proportions of the selection to a square or circle (rather than a rectan-
gle or ellipse).

1 Hold down the Option/Alt key while dragging. When you hold down
the Option/Alt key while dragging a marquee selection tool, the selection
is centered on the point where you first clicked. Rather than being a
corner of a selection, that starting point is the center of the selection.

+~ Hold down the Shift and Option/Alt keys while dragging. You can
select from the center while constraining proportions by using the Shift
and Option/Alt keys together.
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1~ Use the Shift key to add to
an existing selection. If you
already have an active selection
in your image, Shift+dragging a
selection tool adds to that selec-
tion. (Press Shift before you
click and drag.)

1~ Use the Option/Alt key to sub-
tract from an existing selec-
tion. When you have an existing
selection and you hold down . ) )
the Option/Alt key, you can drag Figure 3-6: Use the Option/Alt key with a
to subtract from the selection.  Selection tool to subtract from a selection.
Note in Figure 3-6 that the selec-
tion tool’s cursor shows a small minus sign when subtracting from a
selection.

1 “Double-clutch” with the Shift or Option/Alt key. You can even con-
strain proportions or select from the center and add to or subtract from
a selection. Press the Shift key (to add to the existing selection) or the
Option/Alt key (to subtract from the existing selection). Click and start
dragging the marquee selection tool. While continuing to hold down the
mouse button, release the modifier key and press and hold Shift (to con-
strain proportions), Option/Alt (to center the selection), or both; then
continue to drag your selection tool. You might want to use this tech-
nique, for example, when creating a donut-shaped selection. Drag the ini-
tial circular selection and then subtract a smaller circular selection from
the center of the initial circle.

Don’t be afraid to experiment with modifier keys while working with tools.
After all, you always have the Undo command (88+Z/Ctrl+Z) at hand!

Get Cookin’ with Customization

Customizing Photoshop not only helps you work faster and more efficiently,
but it can also help you work more precisely and prevent tragic errors.
Consider using a Crop tool preset to create a 5 x 7 print at 300 pixels per inch
(ppi). Such a preset will always produce exactly those dimensions, every
single time. Setting up the Crop tool each time you need a 5 x 7 at 300 ppi
doesn’t only waste time, but it also opens the door for time-consuming or
project-wrecking typos. (“Oops! I guess [ made a mistake — this image is

5 x 7 at only 30 pixels per inch!”)

b7
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Clearing the table: Custom workspaces

One of the easiest ways to work more efficiently is to see your image better.
Generally speaking, bigger is better, so the more room you have on the moni-
tor to display your artwork, the better you can zoom in and do precise work.
The easiest way to gain workspace? Press the Tab key to hide Photoshop’s
palettes. Pressing Shift+Tab hides all the palettes except the Options bar and
the Toolbox.

Keep in mind that you should always use 100% zoom when evaluating your
image for banding or moiré and when applying filters. Any other zoom factor
is a simulation of the image’s appearance.

You can also drag the palettes that you need regularly to a custom group of
palettes. To move a palette, drag it by the tab and “nest” it with other palettes.
And don'’t forget that the major palettes have keyboard shortcuts assigned to
show and hide. Although keyboard shortcuts are customizable (as you can
read later in this chapter), here are the primary palettes’ assigned F keys, the
function keys that appear at the top of your keyboard:

1 Actions: Option/Alt+F9
1+~ Brushes: F5

1~ Color: F6

1~ Info: F8

~ Layers: F7

Any palettes nested with the palette that you show/hide are also shown and
hidden. And don’t forget that you can always restore all palettes to their
default locations by choosing Window=>Workspacer>Reset Palette Locations.

The most efficient way to customize your work area is to create and save
specialized workspaces. To arrange the palettes exactly as you need them
for a particular job you do regularly, choose Window=>Workspacer>Save
Workspace (in the Windows menu, visible palettes are indicated with a check
mark), and name the workspace for that type of job. Then you can make a
specialized workspace for each type of work you do. For example, perhaps
when you do color correction, you need to see the Histogram palette (in the
expanded view), the Info palette, and the Channels palette. Arrange those
palettes how you need them and then hide the rest, saving the workspace
named as My Color Correction. Or, perhaps when you create illustrations in
Photoshop, you need to see the Layers and Paths palettes at the same time.
Drag one out of the group to separate it, position them both where conve-
nient, and save the workspace as lllustration.
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To access a saved workspace, choose
Window=>Workspace and select it
from the list at the bottom of the
menu, as shown in Figure 3-7. You can
see some preset custom workspaces
in the menu, as well.

You can also save the current state of
the customizable keyboard shortcuts
and menus in your workspace.
Although streamlining the menus for
the specific work you're doing is a
great idea, it’s probably not such a
great idea to have more than one set
of custom keyboard shortcuts. The
time it takes to remember which
shortcuts go with the current work-
space (or to undo a mistake caused
by the wrong shortcut) is time
wasted.
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Figure 3-7: Select a workspace from the menu

to instantly rearrange your palettes.

To customize Photoshop’s menus, choose Edit=>Menus, which opens the
Keyboard Shortcuts and Menus dialog box. (Alternatively, choose Edit=>
Keyboard Shortcuts and click the Menus tab.) Here you can find every menu
command listed. You also have the option of hiding a command or assigning
a custom color to make it easier to identify in the menu. You might, for exam-
ple, hide the artistic filters that you never use, and color-code the others
according to how you like or use them (see Figure 3-8).
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Figure 3-8: You can hide menu commands and color-code the visible commands.
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In addition to the application menu commands (from the menus at the top
of the screen), you can switch the Menus For pop-up to Palette menus and
customize those menus, too. Don’t forget to save your customized menu
arrangements with the button directly to the right of the Settings pop-up.
Your saved menu set will appear in that Settings pop-up for easy access.

Sugar and spice, shortcuts are nice

The Photoshop keyboard shortcuts can save a bunch of time. Rather than
mousing to the Toolbox to select the Brush tool, just press the B key. To
open the Levels dialog box, press 38+L/Ctrl+L instead of mousing to the
Image menu, down to the Adjustments submenu, and then over and down
to Levels.

Photoshop CS3 has customizable keyboard shortcuts. Because the default set
of shortcuts is pretty standard — not only throughout the Adobe Creative
Suite but also with other major programs — you’re probably best served by
making only a few changes. Open Keyboard Shortcuts (shown in Figure 3-9)
through the Edit menu to make one major change and then any changes for
personal preferences. Change 88+Z/Ctrl+Z to use Step Backward. In most pro-
grams, pressing 3+Z/Ctrl+Z keeps undoing — reverting through a series of
previous actions in the program. In Photoshop, however, that shortcut tog-
gles an Undo/Redo function; that is, press once to undo and press a second
time to reverse the undo. Bah! Make Photoshop conform to the undo-undo-
undo behavior common to other programs. In Keyboard Shortcuts, under
Edit, change 8+Z/Ctrl+Z to Step Backward and then use 8 +Option+Z/Ctrl+
Alt+Z to toggle between Undo and Redo.

Kayboard Shortcuts and Menus
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Figure 3-9: Assign custom keyboard shortcuts to speed your work.
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Spoons can’t chop: Creating tool presets

One of the keys to efficient, accurate work in Photoshop is using the right
tool for the job. The Patch tool, for example, copies texture only. If you need
to cover a spot on a client’s face, changing both texture and color, you need
the Clone Stamp tool rather than the Patch tool. (You can read about how the
tools work throughout this book.)

You can ensure that you're using not only the correct tool but also the cor-
rect settings for that tool by creating tool presets, which store your settings
from the Options bar. You can then select the preset tool (and, of course,
that’s where the catchy name comes from) from the Tool Presets palette or
from the left end of the Options bar, as shown in Figure 3-10.
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Figure 3-10: Tool presets help you work faster and more accurately.

Although just about any tool is a good candidate for tool presets, some are just
plain naturals. Consider, if you will, the Crop tool. As [ explain in Chapter 4,

a photo from a high-end digital camera has an aspect ratio (relationship
between width and height of the image) of 2:3, and common print and frame
aspect ratios include 4:5 for 8 x 10 prints; 5:7 and 13:19 for large prints.
(Some lower-cost cameras shoot in different aspect ratios.) You'll often find
aneed to crop an image to a specific size to meet your printing requirements.
And, don’t forget resolution — printing in the correct size at the wrong reso-
lution is simply a waste of paper and ink! Set up a number of Crop tool pre-
sets for your typical print sizes and relax, knowing that you’ll always be
cropping correctly.

51
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Another logical candidate for tool presets is the Type tool. When you consider
all the options for the Type tool in not only the Options bar but also in the
Character and Paragraph palettes, you have quite a bit to select and track.
To ensure consistent text from project to project, consider creating tool pre-
sets for each project, including (as appropriate) headline and body text,
special effects and accent type, and even your copyright information.

Using the Preset Manager (opened through the Edit menu), you can drag the
tools presets up and down to rearrange them. Sort them in a logical order or
move the presets you use most often to the top of the palette. The changes
are for both the Tool Presets palette and the picker at the left end of the
Options bar.

Season to Taste: The Photoshop Settings

\

The program-level Preferences and the Color Settings flavor all your work in
Photoshop. The options that you choose in Photoshop’s Preferences (or
simply the Prefs) control many facets of the program’s basic behavior.
Choices made in the Color Settings dialog box determine how your work
looks, both on-screen and in print. And when you get down to brass tacks,
that’s what it’s all about — the appearance of your artwork.

Standing orders: Setting the Preferences

Photoshop’s Preferences file stores a whole lot of information about how you
use the program. Whether you prefer to measure in inches or pixels, how you
like the grid and guides displayed, what size thumbnails you prefer in your
palettes, which font you used last — all sorts of data is maintained in the
Prefs. Much of the info in the
Preferences is picked up automati-
cally as you work (such as the size
and color mode of the last new docu-
ment you created, whether the
Character palette was visible when
you last shut down the program, and
which tool options were selected in
the Options bar), but you must
actively select a number of options
in the Preferences dialog box, as Figure 3-11: Use Photoshop's Preferences to
shown in Figure 3-11. establish many program behaviors.

Your custom styles, brushes, Actions, and the like are recorded only in
Photoshop’s Preferences until you actually save them to your hard drive.
That makes them vulnerable to accidental loss. Use the Actions palette menu
command Save Action to save sets of Actions (not individual Actions) and use



&ATURE

Chapter 3: Taking the Chef’s Tour of Your Photoshop Kitchen 53

the Preset Manager (under the Edit menu) to save sets of your other bits and
pieces. And make sure to save them in a safe location outside the Photoshop
folder — you wouldn’t want to accidentally delete your custom items if you
should ever have to (oh, no!) reinstall Photoshop, would you?

Open the Prefs on a Mac with the keyboard shortcut 8+K or choose
Photoshop=Preferences to select one of the ten specific subsets of Preferences
to change. The shortcut for Windows users is Ctrl+K, and the Preferences sub-
menu is under the Edit menu. The default settings are perfectly acceptable
(after all, they are the defaults for a reason), but the following sections cover
some changes to the Prefs to consider, listed by the section of the Preferences
dialog box in which you find them.

Preferencesc>General

If you’ll be doing a lot of resizing and scaling in Photoshop, consider changing
the Image Interpolation method. Use Bicubic Smoother if you’ll be increasing
pixel dimensions regularly; select Bicubic Sharper when downsizing. If you
work on a monitor set to a resolution of 1,024 x 768 pixels, consider changing
the UI (user interface) Font Size to Small. That shrinks palettes and gives you
a little more room to work.

If you use Adobe Bridge regularly, select the check box to launch the program
automatically. (I introduce Bridge in Chapter 4.) Also consider whether you
want to automatically save the history log with each file, in a text file, or not
at all. (The history log tracks all the changes you make to a file; however, as
metadata, it does increase the file size. Read a metadata history log by choos-
ing File>File Info.)

Also note the button named Reset All Warning Dialogs at the bottom of the
General pane. Many of Photoshop’s handy reminder messages include a
Don’t Show Again option. If you someday decide that you do indeed need to
start seeing one or more of those reminders again, open the Prefs and click
this button.

Preferencesc>lnterface
New in Photoshop CS3 is the Interface pane of the Preferences:

1~ Use Grayscale Toolbar Icon: The first option simply changes the
Photoshop logo at the top of the Toolbox from blue to gray (yawn!).

1 Show Channels in Color: When only one channel is active in the
Channels palette, it normally shows as a grayscale representation of the
image. If you prefer to have the active channel appear in its own color,
select this option. [ do suggest to you, however, that after you get com-
fortable working with individual channels, the default grayscale is more
accurate and easier to see.
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1~ Show Menu Colors: As | discuss earlier in this chapter, you can assign
colors to specific commands in the Photoshop menus. That might make
it easier for you to quickly spot and select often-used commands. Use
this option to disable the color coding without having to deselect each
assigned color.

1~ Show Tool Tips: Pause the cursor over just about any tool or option in
Photoshop and a little yellow box appears, telling you what that feature
does. This is a great feature while you’re learning about Photoshop, but
might be distracting after you master the program. Disable the Tool Tips
if you decide you no longer need or want to see them.

1~ Auto-Collapse Icon Palettes: If you prefer an uncluttered workplace,
here’s a great option for you! When selected, palettes in icon mode
(click the upper bar of a group of palettes) collapse to buttons. To
open a palette, you click its button. When Auto-Collapse is selected,
the selected palette automatically closes when you click elsewhere in
Photoshop. If you need to keep a specific palette open while you work
(perhaps Histogram or Info), drag it out of its group and away from the
edge of the screen, and it will stay open until you close it.

1~ Remember Palette Locations: Photoshop, by default, remembers the
visibility and location on-screen of all palettes when you quit the pro-
gram. The next time you open the program, the palettes are just where
you left them. If you find that you often leave palettes scattered willy-
nilly all over the screen and must choose Window=>Workspacer>Reset
Palette Locations before you can get any serious work done, consider
deselecting this option. (You might also want to deselect the option on
shared machines and in school or lab environments where the default
appearance of Photoshop is desired each time the program is started.)

Preferencesc>File Handling

Image previews add a little to the file size, but in most cases, you want to
include the preview. On Macs, you have the option of including a file extension
or not (or having Photoshop ask you each and every time). Even if you don’t
plan on sharing files with a Windows machine, I strongly recommend that

you always include the file extension in the filename by selecting the Always
option. Likewise, I suggest that you always maximize PSD and PSB file compati-
bility. This ensures that your Photoshop CS3 files can be opened (with as many
features intact as possible) in earlier versions of the program and that they’ll
function properly with other programs in the Creative Suite. If you're in a work
group situation (with two or more people working on a single project), I urge
you to use Version Cue, part of the Creative Suite, to manage work files. It’s a
truly great way to avoid singing the “Which Version Is Current?” blues.

New in Photoshop CS3 is the option to open JPEG and TIFF files in Adobe
Camera Raw. Although it’s no substitute for actually shooting in a Raw file
format, this is a huge step forward! By using Camera Raw with JPEG files,
you record adjustments to the file’s metadata rather than making changes to
the actual pixel color values. This gives you the flexibility of returning to the
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original file (as long as you use Save As from Photoshop) and changing those
adjustments without degrading the image quality. (Camera Raw is the subject
of Chapter 7.)

Preferencescy Performance

Another new pane in the Photoshop CS3 Preferences, Performance consoli-
dates in one pane various options that had been scattered in various places.

1 Memory Usage: Under most circumstances, the Photoshop memory allo-
cation should remain set to 70%. If you have 4GB of RAM or more, you
can likely increase the Photoshop memory usage to 80 or 85%. If you have
a very small amount of installed RAM (say, 512MB) and the operating
system is struggling to run, reduce the maximum memory usage to 50%.

1 Scratch Disks: P
«  Performance L“—i“

PhOtOShop’S SCFatCh " = ! mu—-ummm History & Cathe = “"m_'
disks are hard drive s izt ey 8B

Let Photshop e 1020 | W (0%

space used to sup- i
port the memory. Use

only internal hard :
drives as scratch |2 41
disks — never an .
external drive, a net-
work drive, or remov-
able media! If you
have multiple internal
hard drives, consider Figure 3-12: Use only internal hard drives for scratch disks.
a dedicated partition

(perhaps 15GB) on the second drive — not the drive on which the operat-
ing system is installed. Name the partition Scratch and use it exclusively
as a scratch disk for Photoshop (and perhaps Adobe Illustrator). If you
have a couple of extra internal drives, each can have a scratch partition,
as shown in Figure 3-12. (On a Windows computer, you might see a mes-
sage warning you that the scratch disk and the Windows paging file, which
serves the same basic purpose at the system level, are on the same drive.
If you have only one internal hard drive, ignore the message.)

To select a drive or partition to use as a scratch disk, click in the box to
the left of the drive. To specify the order in which Photoshop should use
multiple scratch disks, select a drive and use the arrow buttons to the
right (see Figure 3-12) to move it up or down in the list.

1~ History States: This field determines how many entries (up to 1,000)
appear in the History palette. Storing more history states provides more
flexibility, but at a cost — storing too many history states uses up all
your available memory and slows Photoshop to a crawl. Generally
speaking, 20 or 30 is a good number. If, however, you do a lot of opera-
tions that use what I call “little clicks,” such as painting or dodging/
burning with short strokes, that History Palette fills up quickly. For such
operations, a setting of perhaps 50 or even 60 is more appropriate.

55
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1~ Cache Levels: The image cache stores low-resolution copies of your
image to speed on-screen display at various zoom levels. Although this
process speeds up screen redraw, the price is accuracy. Unless your
video card has trouble driving your monitor at your selected resolution
and color depth, you might be better served by Cache Levels: 1. That
gives the most accurate picture of your work. (But remember to make
critical decisions at 100% zoom, where one image pixel equals one
screen pixel.)

1 GPU Settings: This area displays information about your computer’s
video card. If you have Photoshop CS3 Extended, depending on your
video card, you may have an option to enable 3D acceleration.

Preferencesc> Cursors

Photoshop CS3 offers you a couple of ways to display cursors for painting
tools. You can show the tool icon (Standard), a small crosshair (Precise), or
a representation of the tool’s brush tip, indicating the size and shape of the
brush (Brush Size). With soft-edged brushes, the brush size cursor shows
where the tool will be applied at 50% strength or higher. Alternatively, select
the Full Size Brush Tip option, which always shows the full extent of the
brush tip, regardless of the Hardness setting.

You also have the option of adding

a crosshair in the middle of either
brush-size cursor. The crosshair
option is great for keeping a brush
centered along an edge or path, and
it just about eliminates the need for
the Precise cursor option. As you can
see in Figure 3-13, when working with
a soft brush, showing all the pixels
that are changed even a little (to the  Figure 3-13: When working with a low
right) might not give you an accurate Hardness setting, Normal Brush Tip is
view of your work. (The Normal usually best.

Brush Tip cursor is shown at the top

center and with the Show Crosshair in Brush Tip option to the lower left.)

When you're sure that you have a brush-size cursor selected in the Preferences
but Photoshop shows you the precise cursor, check the CapsLock key. Pressing
CapsLock toggles the painting cursors between precise and brush size.

Preferencesc> Transparency & Gamut

If you find the gray-and-white checkerboard pattern distracting in images
with transparency, you can set Grid Size to None, which gives you a plain
white background in transparent areas of your artwork. If you work in gray-
scale regularly, you might want to change the color of the transparency grid
to something that contrasts with your image; perhaps pale blue and pale
yellow.
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Preferences—oUnits & Rulers

If you create Web graphics rather than print images, you probably want to
change the unit of measure from Inches to Pixels. Keep in mind that you can
change the unit of measure on the fly by right-clicking (multibutton mouse)
or Control+clicking (single-button mouse) the rulers in your image (which
you show and hide with the shortcut 38+R/Ctrl+R). If you regularly print at a
resolution other than 300 ppi, you might also want to adjust the default reso-
lution for print-size new documents.

Preferencesc>Guides, Grid & Slices
Photoshop CS3 offers Smart Guides, which appear and disappear automati-
cally as you drag the content of one

layer into and out of alignment with -m

the content of other layers. Smart
Guides (magenta in color by default), links
show when the content of the layer -
you’re dragging aligns perfectly with
the edges or center of other layers’ Figure 3-14: The magenta guides show how
content. See Figure 3-14. the layer aligns with other layers.

The one thing you might want to change in this pane of the Preferences is
the Show Slice Numbers option. The slice numbers appear in the upper-left
corner of each slice when you’re subdividing Web graphics. Unless you
intend to edit the images individually later, you probably don’t need to know
which slice is which, so slice numbers are generally not necessary. Clear the
check box to remove the distractions.

Preferences—> Plug-Ins

If you have third-party plug-ins, filters, and such that you purchased sepa-
rately for use in Photoshop, consider using a second folder for the plug-ins,
outside the Photoshop folder, and designate that folder as the Additional
Plug-Ins Folder in the Preferences. Having your extra plug-ins outside the
Photoshop folder means you won’t have to reinstall them if you have to
replace Photoshop. If any of those plug-ins date to Photoshop 5 — and still
work — you might need to enter the Photoshop 5 serial number as a legacy
so that the plug-ins recognize the new version.

Preferencesc> Type

Photoshop CS3 has a pane in the Preferences that you can use to select some
type-related options. Photoshop shows the font menu in each font’s name in
the actual typeface, and you can specify the size of that preview here.
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Ensuring consistency: Color Settings

If one term strikes fear deep in the heart of a typical Photoshop user, it’s
color management. Few aspects of the program are so misunderstood.
Yet without wise color management decisions, your images won'’t print
accurately. For most Photoshop users, color management can be imple-
mented with a few key choices in the Editz>Color Settings dialog box
(shown in Figure 3-15), which can then be saved for future use:

1~ Select an RGB working space. Open the Color Settings dialog box (under
the Edit menu) and select your RGB working space — the color space in
which you edit and create. If you primarily create Web graphics, send your
images to a photo lab for printing, or print with an inkjet printer that uses
only four ink colors (cyan, magenta, yellow, and black), choose sRGB as
your color space. If you print to an inkjet printer that uses six or more
inks or you prepare artwork that will be converted to a CMYK color space,
choose Adobe RGB. If you have hardware and software to create a custom
profile for your computer’s monitor, use that profile.

Figure 3-15: Choose wisely in the Color Settings dialog box for optimal printing.

1~ Elect to convert images to your working space. In the Color Manage-
ment Policies area of the Color Settings dialog box, choose RGB: Convert
to Working RGB. This ensures that the images you see on-screen actually
use your working profile.
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» Turn off the mismatch warnings. Clear the check boxes for those
annoying and time-wasting warnings that pop up on-screen any time
you open an image with a profile other than your working space. You're
intentionally converting to your working space — you don’t need to reaf-
firm the decision every time.

1 CMYK and Grayscale settings: CMYK (cyan/magenta/yellow/black)
color mode is used exclusively with images intended for output on com-
mercial printing presses and some color laser printers. (Don’t be fooled
by the inks you purchase for your inkjet printer — the printer’s driver
expects to convert from RGB, so sending CMYK color to an inkjet will
produce substandard output.) Likewise, you'll use Grayscale very rarely.
If, in fact, you have an inkjet printer that is capable of printing grayscale
(such as the magnificent Epson R2400), you still want to have an RGB
image and let the printer’s print driver handle the grayscale conversion.
If, however, you are preparing an image for output on a commercial
press (in CMYK or Grayscale color mode), speak directly with the
person who will place the image into the page layout or with the print
shop to find out what settings to use for that particular job.

When it’s time to print, you’ll get the most accurate and pleasing color prints
when you let Photoshop (rather than the printer) control color. In the Print
dialog box’s Color Management section, choose Document to keep the source
space as your working space. In the Options area, choose Color Handling:
Photoshop Manages Colors and select the printer’s own profile for the paper
on which you’re printing as the Printer Profile. Use Relative Colorimetric as
the rending intent and leave the Black Point Compensation check box marked.
After you click the Print button, you see the printer’s Print dialog box. Make
sure that the printer’s color management is set to Off.

The preceding guidelines are appropriate for most, but not all, Photoshop users.
You might fall into a special category. If you exclusively create Web graphics,
in the Color Settings dialog box, choose Settings: Color Management Off. In
the Save For Web dialog box, to the upper right of the preview area, choose
Uncompensated Color. When saving images in the JPEG file format, don’t embed
ICC profiles. (ICC profiles make specific adjustments to the appearance of your
images to compensate for vagaries of the hardware. [ discuss color profiles in
Chapter 4.) When you eliminate color profiles from the equation, you're creating
Web graphics that any Web browser can show properly (or, more accurately,
“as properly as the viewer’s uncalibrated monitor can display”).

If color in your images needs to be absolutely perfect because merely accu-
rate won’t do, consider purchasing hardware and software to calibrate and
profile all the devices in your workflow. GretagMacBeth and X-Rite (www .
gretagmacbeth.com), ColorVision (www.colorvision.com), and Pantone
(www .pantone. com) are three sources to explore.
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When Good Programs Go Bad: Fixing Photoshop

Sometimes things happen. Bad things. Tools don’t work right. Simple com-
mands take ages to execute. Photoshop (gasp!) crashes! Don’t give up, and
please don’t toss the machine through the window. (Hey, I might be walking

past at the time.) Start with the easy fixes and work your way up as necessary.

1~ Check the palettes and selection. If a tool isn’'t working as expected or

isn’t working at all, check whether you're inadvertently preventing it
from doing its job. See whether you have an active selection elsewhere
in the image or press 38+D/Ctrl+D to deselect. Look at the Layers palette:
Are you working on the correct layer? Is the layer itself active or is a
layer mask? Check the Channels palette: Are the color channels active?
At the left end of the Options bar, right-click (multibutton mouse) or
Control+click (single-button mouse) the tool icon and select Reset Tool.
Open a flattened 8-bit RGB image and try the tool or technique in that
image. If it works there, the problem isn’t Photoshop but rather the spe-
cific image. Check the Imager>Mode menu to ensure you have an appro-
priate color mode and bit depth.

1~ Reset Photoshop’s Preferences file to the defaults. Before replacing the

Prefs, open Photoshop’s Preset Manager (through the Edit menu) and
save any custom styles, gradients, brushes, and so forth. Save them in a
safe place, outside the Photoshop folder. Open the Actions palette and
save any sets of custom Actions with the palette menu Save Actions
command. (Remember that you must click a set of Actions — not an
individual Action — to use Save Actions.) Open the Preferences and
Color Settings and make notes about any special settings you're using.
Quit Photoshop and restart the program with the 38+Option+Shift keys
pressed (Mac); or, immediately after launching the program in Windows,
press and hold the Ctrl+Alt+Shift keys. When asked whether you want to
delete the Settings file, release the modifier keys and confirm the dele-
tion; then allow Photoshop to finish starting. Reset your Preferences and
Color Settings and reload your custom bits and pieces.

1~ Reinstall Photoshop. If replacing the Prefs doesn’t solve the problem,

try reinstalling Photoshop. Save all your custom items (as described ear-
lier) and then uninstall Photoshop. Insert the Photoshop CD and launch
the installer, then opt to uninstall. After uninstalling, restart your com-
puter (not always necessary, but a good practice) and reinstall.

If reinstalling Photoshop doesn’t solve the problem, the source might be at

the operating system level or perhaps a hardware problem. Call in the big
guns by contacting Adobe tech support:

www . adobe . com/support/phonenumbers/main.html



Getting Images into
and out of Photoshop

In This Chapter

Mommy, where do pictures come from?

Keeping track of your images

Putting pictures on paper

Sharing your work

ou could, theoretically, open a new empty Photoshop file, paint in it,

save the file, and drive from house to house to show the artwork on
your computer to friends and family. However, you have lots of ways to share
your images that are much easier. You can print them, post them on
your Web site, or even e-mail them. And e-mailing an image file
across the country is much more convenient (and, of
course, more eco-friendly) than driving hither and yon
with your computer in the trunk.

In this chapter, | show you how to get images into
Photoshop from your digital camera and your scan-
ner and then how to keep those images organized

on your hard drive and CDs/DVDs. I discuss the
basics of printing your images on inkjet printers

(and alternatives) and tell you some things you need
to know to make sure you get the prints you expect. |
also explain how to use Photoshop’s automation to
create Web sites of your images as well as how to pre-
pare images for sending by e-mail.
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Bringing Images into Photoshop

Artwork in Photoshop originates in one of three ways:

» You open an image with either the operating system’s Open dialog box
or, if you have the full Creative Suite, the Adobe Open dialog box (as
shown in Figure 4-1). To switch between versions of the dialog box, click
the button in the lower-left corner.

1 You import an image (typically through a scanning device).

1 You create an image from scratch by choosing File>New.
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Figure 4-1: With Creative Suite installed, you can switch between
the OS and Adobe versions of the Open dialog box.
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You can open an image into Photoshop by choosing File=>Open, through
Adobe Bridge, or by double-clicking the image file. If you double-click a file
and Photoshop doesn’t launch or the wrong program launches, you need to
associate the file format with Photoshop:
1~ Adobe Bridge file association

a. Open Bridge’s Preferences with the shortcut 38+K/Ctrl+K.

b. In the column to the left, click File Type Associations.

c. In the lower right, click the Reset to Default Associations button.

1 Mac file association

a. In the Mac Finder, Control+click (one-button mouse) or right-click
(multibutton mouse) a file of the type that you want to open in
Photoshop.

b. From the contextual menu, choose Get Info.

c. In the Get Info dialog box, expand the Opens With area, choose
Photoshop CS3 from the pop-up menu, and click Change All.

d. (Optional) Repeat for any additional file formats.

If you double-click a file and Photoshop launches but the image
doesn’t open, you've likely made a change to the Mac OS and need
to reinstall Photoshop.

1 Windows file association

a. In Windows Explorer/My Computer, right-click a file of the type
that you want to change.

b. From the contextual menu, choose Properties.

c. To the right of Open With, click the Change button, choose
Photoshop CS3, and click OK.

d. Click OK again to close the Properties dialog box.

e. (Optional) Repeat for any additional file formats.

Downloading from your digital camera

You can use the software that comes with your digital camera to transfer
photographs from it to your computer’s hard drive. Or, if you have the hard-
ware, you can remove your camera’s memory card, memory stick, or other
media from the camera and use a card reader, which is a small device
designed to read camera storage media. Transferring via the Mac Finder or
Windows Explorer is generally much faster than and usually just as reliable
as transferring using the camera manufacturer’s software.

Chapter 4: Getting Images into and out of Photoshop
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Never open an image into Photoshop directly from a camera, Flash card, or
CD/DVD. Doing so can slow down your work, and you also risk losing your
work if Photoshop isn’t able to immediately and efficiently read the original
file while you work. And, of course, you can’t save from Photoshop back to
most removable media, so you need to create a new file (on a writable drive),
anyway. Open images from a network drive only when working with Adobe’s
Version Cue, the Adobe Creative Suite’s project management software.

After the images are safely stored on Embedded Protée Wymatch

your local hard drive (or a high- The document WC40048C” bas an embedded coorsrobe
speed external hard drive), you can e

open them in Photoshop by using Working: Adobe RGH (199K)

one of the three methods that | What would you Bee to do?

describe earlier in the chapter. R T
Depending on your color settings, ST SOOI RO o N e
you might see a warning that the Carcel ) (ORI

image’s color profile and the profile
that you selected as your RGB work-
ing space don’t match. Photoshop Figure 4-2: When color profiles don’t match,
asks you what you want to do (see  you have to make a choice.

Figure 4-2). Generally speaking, you

want to convert to your working space so that you see the most accurate
color on your monitor. You might want to preserve the embedded profile if
you’ll be returning the image to the originating computer after looking at or
working on it. The third option disregards all color profiles and works with
uncorrected color. This is a good choice when working with images that
you’ll later use with a non-color-managed program, such as a Web browser or
presentation program. (Without color management, you see the image as it
will appear in the other program.) You can disable the color mismatch warn-
ings in Photoshop’s Color Settings dialog box.

When opening an image that includes text, you might also get a message
warning you that the type layers need to be updated. Generally speaking, you
want to update them unless the image contains fonts that aren’t available on
your computer.

Scanning prints

You place a photo (face down) on the glass of your scanner. You push a
button. It automatically appears on your computer screen. That’s scanning at
its most basic. If your scanner’s software installed a Photoshop-compatible
plug-in into the Import/Export folder inside Photoshop’s Plug-Ins folder, you
can scan from within Photoshop. (The Filec>Import menu will show your
scanner by name.)
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Purchasing commercial images

Some projects require images that you can't run
out and shoot yourself. Say, for example, that
you're preparing a poster or brochure about a ski
trip to Japan. In your office or studio. In the
United States. In July. Pretty tough to shoot what
you need, eh? Turn to stock photography. You
can purchase or license stock images (photos,
illustrations, video, and even audio) from a wide
variety of sources, including Internet-based ser-
vices and collections on CD/DVD. In fact, | use
images from PhotoSpin.com in a variety of
places in this book. Through Adobe Bridge (you
can read about this elsewhere in this chapter),
you can access stock images from a couple
dozen major suppliers, all in one place.

When you consider using stock images, keep in
mind the difference between royalty-free and

rights-managed images. Royalty-free images
are yours to use as you see fit (within the terms
of your agreement— no resale as stock photos,
no defamatory or pornographic use, and so on).
You can use the images when you need them,
as often as you need them. Rights-managed
images, on the other hand, are licensed for a
specific use, in specific media, for a specified
time. Rights-managed artwork does have one
advantage over royalty free: Because usage is
controlled, you can license exclusive rights to
the image for that period of time so that the
image you use won't appear in some competi-
tor’s advertising at the same time. Royalty-free
images, on the other hand, are available to
anyone who pays for them, and usage is not
controlled.

Determining scan resolution

Before scanning an image, you need to make some decisions:

1 How you want to use the image

1 What its final size will be

1 What resolution you need

By determining how many pixels you need beforehand, you eliminate the

need to resize the image in Photoshop (and the resulting image degradation).

Many scanner interface windows let you input the final size and resolution

you need right in the scan window. If you find the need to calculate scan reso-

lution manually, here’s how:

1. Determine the required pixel dimensions.

e For print: If you’ll be printing the image, determine the size at
which you want to print (in inches) and the resolution at which
you want to print (typically 300 ppi [pixels per inch] is a good
choice). Multiply the print width and height by the resolution to
determine pixel dimensions.

e For the Web: If the image is destined for your Web site, determine

how much of your page the image will occupy (in pixels).
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2. Measure the original.

Before placing it on the scanner’s glass, measure the original image. If
you'’re using only part of the image, measure that part. (Be careful not to
scratch the original with your ruler!)

3. Do the math.

Divide your required pixel dimensions (Step 1) by the physical dimen-
sions of the original (Step 2). The result is your scan resolution. (If you
get different numbers for the width and height, use the larger and expect
to do some cropping in Photoshop.)

Many flatbed scanners (scanners designed for use with documents and
photos) have transparency adapters that let you scan film and slides. However,
if you have a lot of negatives or slides to scan or if the best possible quality is
required, consider a dedicated film scanner from Nikon, Minolta, or Kodak.

Preventing moiré patterns

Unless you spent thousands of dollars on your scanner, you probably want to
forget about the scanner software’s color and tonal correction capabilities —
Photoshop gives you more control. However, here is one thing that scanner
software does much better than Photoshop, and it’s a capability that you
should use when appropriate: moiré (pronounced, roughly, mwah-RAY)
reduction. A moiré pattern is a visible rosette pattern created by the pattern
of dots placed by the printing press to reproduce color.

When you need to scan a color image
or artwork that comes from a book,
magazine, or newspaper (or other
material printed on an offset printing
press, such as product packaging or
signs), you want to use the scanner’s

software to reduce moiré. When you
let the scanner know the pattern is
there, the scanner’s software com-
pensates for the pattern and smoothes the scanned image (as you can see in
Figure 4-3).

Figure 4-3: Scanning without (left) and with the
scanner’s moiré reduction option.

The moiré reduction feature in your scanner’s software might not be immedi-
ately recognizable. It might be labeled Descreening, or it could be a choice
between Color (Photo) and Color (Document). As always, refer to your hard-
ware’s User Guide for specific guidance.

If rescanning is out of the question and you have a moiré pattern to reduce in
Photoshop, blur the image enough to disguise the problem, and then paint
with the History Brush to restore areas of critical detail in the image.
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Here’s an important announcement from The Department of an Ounce of
Prevention is Worth a Pound of Cure: A minute or two spent cleaning the scan-
ner could save hours of touch-up in Photoshop. Before doing any scanning,
use a can of compressed air to make sure that the scanner’s glass is clean
and free of dust. Likewise, check the inside of the scanner’s lid. (What good is
it to clean the glass if dust from the lid is going to contaminate it again as
soon as you close it?) If necessary, eliminate fingerprints or smears with
appropriate glass cleaner. (Check the scanner’s User Guide for cleaning
instructions and be careful when using liquid glass cleaner with an electrical
device! I like to use the same premoistened wipes I use for my eyeglasses.)

You can use a burst of compressed air on the original image, too, before plac-
ing it on the glass. Just be careful — hold the can of air some distance away
from the photo and spray at an angle so that you don’t damage it.

Keeping Your Images Organized

Because digital photography doesn’t have a per-shot cost (as does shooting
film), people certainly have a tendency to shoot more. And more. And more.
Experimental shots, this-might-be-interesting shots, special effects shots, and
(at least in my case) the same shot over and over and over again. They build
up on your hard drive.

It’s pretty easy to stay organized after you choose a system. The hard part is
actually deleting those digital photos that you really don’t need to keep —
you know, out-of-focus, shot at a bad angle, Aunt Betsy’s eyes were closed
and mouth was open, the 400th shot of the dogs sleeping all curled up, the
401st shot of the dogs sleeping all curled up, and the like. It takes discipline!
(Or an optical drive that can burn CDs and/or DVDs.)

Creating a folder structure

I generally recommend using a subject-based organization scheme, such as
the one shown in Figure 4-4. For example, inside the main folder named
DigitalPhotos, you might have subfolders named Vacations, Work-Related,
Holidays_2007, and FamilyPortraits. (Notice that none of the folder names
use empty spaces or characters other than letters, numbers, a dash, and an
underscore — that minimizes the possibility that Photoshop or another pro-
gram won'’t be able to find a file.) Within the Vacations subfolder, you might
have more subfolders with names such as DisneyWorld_2006, Paris-
Spring_2007, and Paris-Autumn_2006.
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Figure 4-4: Organize with subfolders.

<® Don’t overload your folders! If you find that your computer is slowing down
when it tries to display the content of a folder, you have too many files in the
folder. Create a second folder of the same name and add -01 and -02 to the
folder names. Generally speaking, 200MB is probably as large as you want in
a single folder.

You can use your computer’s CD/DVD drive (if it has the capability) to burn
folders of images to disc. This not only provides you with a reliable backup
(assuming you store the discs correctly and handle them carefully), but it can
free up space on your hard drive. Your folder/subfolder structure can also be
used when creating your discs.

Using Adobe Bridge

Adobe Bridge, the asset-management program for Photoshop and the Creative
Suite, is installed at the same time you install Photoshop CS3 or the Creative
Suite. Bridge has its own folder on your hard drive, inside the Applications
folder on the Mac and in C: \Program Files for Windows. You can open
Bridge independently, or you can use the Photoshop File>Browse command to
launch Bridge, which you see in Figure 4-5. If you choose Preferences=>General
in Photoshop, you can elect to have Bridge launch automatically whenever you
start Photoshop.
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Figure 4-5: Adobe Bridge is a separate program for managing and organizing your image files.

Here are a few tips for working with Adobe Bridge:

1~ Use keywords and categories. Using the Keywords tab in the lower-
right of the Bridge window (as shown in Figure 4-6), you can assign
keywords and categories to images. Keywords and categories are
descriptive terms that you assign to individual images. Down the road,
you can use the File=>Find command to find all images with a specific
assigned keyword.

1 Select multiple images in Bridge. You can have multiple images active
by clicking and Shift+clicking (or 8+clicking/Ctrl+clicking) on the image
previews. You might want to select multiple images and then assign the
same keywords to all the selected images at once.

1~ Use labels, ratings, and filters. Under the Label menu (which you see in
Figure 4-7), you can assign a star rating to each image and assign colors to
organize by subject or project. Use the Viewr>Sort menu to arrange images
in the thumbnails area of Bridge according to either the label or the rating.
In the lower-left of the default workspace you find the Filter tab. Use that

\\J
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feature to locate specific files by ' Metadata | Keywords -
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1~ Add folders to the Favorites.
You invariably will visit some
folders on a regular basis.
Choose Filem>Add to Favorites
to get back to that folder faster
and more easily. In the upper-
left corner of the Bridge

TSN |

window, click the Favorites tab L E;warla vill
for one.click access. Keep in Ll erman Village
|| Mew York

mind, too, that you can add a e
folder to the Favorites while Paris

working on a specific project, |_|South Bend

and then choose FilesobRemove ||| |Other Kevwords
from Favorites when the project
is finished.

»~ Change your view and work- Figure 4-6: Assign keywords and categories to
space. Use the View menu to help Organize (and |0cate) images.
customize what the Bridge
window shows, and use tghe m Tools Window Help
Windowr>Workspace menu to determine how Ne Rating %0
it is displayed. You might find that Compact Reject
Mode fits your needs better in some circum- * x1
stances than does Full Mode. And don’t *k x2
overlook Bridge’s Slideshow feature — ::: X : i
it can be a great way to show off your work! ¢ Fehkhk x5
Remember, too, that you can streamline your Decrease Rating X,
view of a folder’s content with stacks. Select Increase Rating .
similar images or variations on the same shot
and use Bridge’s menu command Stack= v No Label
Group as Stack. All of the selected images are :::w ::
piled into one spot as a single thumbnail, with Green %8
a number in the upper-left corner to indicate Blue E
how many images are stacked together. Drag Purple

the slider above the thumbnail to see each
image in the stack; unstack with the

Stacke>Ungroup from Stack command. Figure 4-7: Use star ratings
. o ) and labels as reminders and
1 Zoom with the Loupe. Click in the Preview to sort your images.

(in the upper-right corner of the default work-
space) to zoom in. Drag the cursor to inspect the preview up close and
personal.
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Renaming image files easily

All right, then, you’ve arranged a hierarchy of folders and subfolders. You've
sorted your images into those folders. You've assigned ranks and labels to
the images. However, you still have no idea which is which in the File>Open
Recent menu. Filenames such as CRW_1907.crw and PB270091 . jpg don’t
tell you much about the image content, do they? Use Bridge’s Tools=>Batch
Rename command (as shown in Figure 4-8) to assign more meaningful (and
informative) names to your files. Select content from each field from the
pop-up menu or type in a field. Click the + button to the right to add more
elements or variables to each name.

Bateh Rarame
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B Rararva wn nina bolder Cancal
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Copy to other fokder
M Filanamas

Tant T owneworid
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O W el o remsmd

Figure 4-8: Use Batch Rename to assign informative names to files.

So that each of your original images gets a unique name, you must include a
variable when using Batch Rename. (If you did try to rename all the images in
a folder to say, picture. jpg, you would end up with only one image file in
the destination folder — each would overwrite the previous.) Therefore,
when using Batch Rename, you must choose one of the variables for one of
the fields via the pop-up menu, be it the original document name or a
sequence number/letter.

Also keep in mind that you shouldn’t type a period (.) into any field. That
character should be used only before the file extension. And, as a wonderful
keep-us-from-creating-problems-for-ourselves improvement, Batch Rename
automatically adds the file extension for you.

Printing Your Images

In the very recent past, the subject of printing images from Photoshop
required a huge number of pages. Thankfully, improvements in hardware and
software make printing much easier. Monitors are well calibrated out of the
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box, printers reproduce color more accurately, and inks and papers last for
decades. Yes, things have come a long way in a short time. But before you
click the Print button, you should make sure that your image is ready to
print. Will it fit properly on the page and in the frame? Are the pixels small
enough that they blend evenly into the overall picture? Will the colors you
envision be the colors that appear on paper?

Cropping to a specific aspect ratio

Aspect ratio is the relationship between the width and height of your image. An
image in landscape aspect ratio is wider than it is tall, and an image in portrait
aspect ratio is taller than it is wide.
Although digital cameras capture in
a variety of aspect ratios, including
3:4 and 4:5, SLR (single lens reflex)
cameras typically use a 2:3 aspect
ratio: One side is 1.5 times the size
of the adjoining sides. Typical

print (and picture frame) sizes

are 8 x 10 inches (a 4:5 aspect

ratio), 5 x 7 inches (5:7), 4 x 6 inches
(2:3), and 3 x 5 inches (3:5). In

Figure 4-9, the 2:3 aspect ratio is out-
lined in green, 5:7 is shown in yellow, Figure 4-9: Different print sizes encompass
and 4:5 is red. different amounts of your image.

Although an 8 x 10 print is physically larger than a 4 x 6 print, it actually
prints less of your original image because it must be cropped. The 4 x 6 print,
with a 2:3 aspect ratio, includes all the original image; the 8 x 10 print (with
its 4:5 aspect ratio) is missing 2 full inches of the image’s longer dimension.
To print 8 inches wide and retain the entire image, you’d be printing at 8 x 12.

In Photoshop, you can change the aspect ratio of your image with the Canvas
Size command (if one dimension is already correctly sized), the Crop tool, or
the Rectangular Marquee tool with the Imager>Crop command. The Crop tool
can resample your image to the exact print dimensions and resolution in one
step, but you generally need to use the Image Size command when changing
aspect ratio with Canvas Size or the Rectangular Marquee.

With the Crop tool selected, you can enter specific dimensions and a target
resolution on the Options bar. Drag the tool, position and adjust the bound-
ing box, and then press Return/Enter to execute the crop. Whatever is within
the bounding box is resampled to the exact size that you specify on the
Options bar. (Remember to click the Clear button on the Options bar after-
ward to restore the Crop tool to its normal behavior.)
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When cropping, Photoshop uses the resampling algorithm that you specify in
Preferences~>General as the Image Interpolation method. For best results,
choose Bicubic Smoother when increasing an image’s size and Bicubic Sharper
when decreasing the size.

When creating a cropping selection
with the Rectangular Marquee tool,
you can change the tool’s Style pop-
up menu (on the Options bar) from
Normal to Fixed Ratio or Fixed Size.
Generally speaking, use Fixed Ratio
(as shown in Figure 4-10) and drag
the marquee to encompass that part
of the image you want to retain.
When the selection marquee is how
and where you want it, choose
Image=>Crop.

/e resunmaNNe -l B
Sl

Figure 4-10: Use the Fixed Ratio option for a

Keep in mind that the Image:>Crop specific width-height relationship.

command doesn’t resample the
image — you’ve just changed the aspect ratio so far — so you need to also
choose Imager>Image Size (which is discussed in Chapter 2).

Remembering resolution

Chapter 2 presents you with an in-depth look at resolution as it pertains to
digital imaging. As a quick refresher, keep these points in mind when thinking
about printing your images:

1~ Images themselves have no resolution. Whether in your camera, on
your hard drive, or open in Photoshop, your images consist only of tiny
colored squares called pixels. The image looks and acts the same within
Photoshop, regardless of resolution. An image 3,000 x 2,000 pixels at
300 ppi is handled in Photoshop exactly as an image 3,000 x 2,000 pixels
at 72 ppi.

1~ Resolution is an instruction to a printing device. The resolution value
that you assign to an image in your digital camera or in Photoshop’s
Image Size dialog box is recorded with the image strictly as an instruc-
tion to the output device.

1~ Resolution measures the size of individual pixels. A resolution of 300
ppi really means that each pixel will print at a size exactly f%uw of an inch
square. Likewise, 72 ppi equates to each pixel printing at f%: of an inch
square. Some folks might find this reasoning uncomfortable (although
they can deny neither the mathematics nor the logic). Should you run

/3
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across such an individual, feel free to ask this question: “What if an
image’s resolution is 300 pixels per inch, but the image is only 299 pixels
wide?” Then smile and buy the next round of beverages.

1~ Web images use only pixel dimensions. Web browsers aren’t capable of
reading the resolution information embedded in your simple graphics by
Photoshop. Each image is displayed in the Web browser strictly accord-
ing to the number of pixels in the image.

Controlling color using Print with Preview

In the past few years, reproducing accurate color from monitor to printer has
become much easier. Although the process of color management still strikes
fear into the hearts of many, the actual need for complex hardware and soft-
ware to control color is greatly reduced. Why? Simply because computer
manufacturers recognized that we, the consumers, wanted better color.
(Okay, maybe it was all the video gamers who got the attention.) Monitors
ship from the factory calibrated and accurate. Printers use smaller droplets
and better inks. Software does a better job of communicating color.

For most Photoshop users, accurate color is important. After spending hours
tweaking an image’s appearance on-screen, surely you want the print to look
exactly like the monitor. Here’s how to get that great color:

1. When you’re ready to output your image, choose File=>Print in
Photoshop.

A large, one-stop-shopping Print dialog box opens (see Figure 4-11).

Cancel Daore o )

Figure 4-11: Photoshop CS3's Print dialog box is comparable to the old
Print with Preview option.
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Check your color (Mac only)

The Mac OS includes a great little program
called DigitalColor Meter. You'll find it in the
Utilities folder (choose ApplicationscoUtilities).
Open DigitalColor Meter and position the
window in the lower center of your screen.
Open Photoshop. Drag the Swatches palette to

Displays. On the Color tab, select Adobe RGB
as the system-level color profile and then
close System Preferences. In Photoshop’s Color
Settings dialog box, select Adobe RGB as the
RGB Working Space. Open DigitalColor Meter
again and test that Swatches palette once more.

the center of the screen, above DigitalColor
Meter. (If necessary, use the Swatches palette
menu command Reset Swatches to make the
default swatches visible in the palette.) Move
the cursor onto the first swatch. If your selected
monitor profile is accurate and your monitor is
working properly, DigitalColor Meter will show
RGB values of 255/0/0 (see the figure here). Try
the next five swatches. You should see Yellow:
255/255/0; Green: 0/255/0; Cyan: 0/255/255; Blue:
0/0/255; and Magenta: 255/0/255.

If you have an Apple Cinema Display or an Apple
Studio Display and DigitalColor Meter tells you
something’s not quite right, try the simple solu-
tion. Open Apple’s System Preferences and click

Ageatame Sire

2. Select your printer and the number of copies you want to print.
3. Click the Page Setup button to specify your page size.
4. Set up color management.

e [n the Color Management section of the dialog box, make sure that
the Print option is set to Document rather than Proof. Choose your
options.

¢ In the Color Handling pop-up menu, select Photoshop Manages
Colors.

e In the Printer Profile pop-up menu, choose the printer’s profile for
the paper on which you’re printing.

¢ For Rendering Intent, choose Relative Colorimetric and select the
Black Point Compensation check box.

Optional: In the upper right, click the Color Management button and
switch the pop-up menu to Output. In this area, you can — if desired —
add such printable options as crop marks, labels and descriptions,
backgrounds, and borders.
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5. When you’re ready, click the Print button.

Clicking the Print button closes the dialog box and moves you to the
printer’s own Print dialog box.

6. Disable the printer’s color management.

Because you’re doing all your color management in Photoshop, you want
to disable all printer-level color management in the printer’s own Print
dialog box. (Check your printer’s User Guide for specific instructions.)

7. Print.

Clicking the Print button in the printer’s dialog box sends the image to
the printer and starts the actual process of putting ink on paper.

Don’t forget that Photoshop CS3 offers you a couple of different ways to save
paper (and time and money) by printing multiple images on a single sheet of
paper. See Chapter 16 for information on Picture Package and Contact Sheet.

Considering color management solutions

If your prints don’t match your monitor, first evaluate your monitor’s set-
tings. Open an image with known color values (you know what the image
should look like) in a non-color-managed program. You might, for example,
open Microsoft Word and choose Inserte>Picture>From File to add the image
Ducky. tif from the Samples folder (inside the Photoshop folder) to a blank
document. Use the monitor’s controls to make that image look the best possi-
ble, and then print. If the image prints accurately, great — you’re all set.

If the monitor looks great but the print is strange, first try cleaning and cali-
brating the print head. And take another look at the Print dialog box to make
sure that you're selecting the proper paper and color settings. (Again, refer to
the User Guide for your printer for specific instructions.)

If your work (or play) requires extreme color fidelity, a number of companies
offer hardware and software that regulate color. You can create custom profiles
for monitors, printers, and even scanners and digital cameras. Although not
inexpensive, skillful handling (in accordance with the User Guides!) not only
results in better prints, but also reduces the amount of aw-shucks wasted
paper and ink from bad output. If you fall into this category, explore the current
offerings from GretagMacBeth and X-Rite (www.gretagmacbeth. com) or
ColorVision (www.colorvision.com).

Keep in mind that all the color management hardware and software in the
world doesn’t do you a bit of good if you're not controlling your environment.
If your work requires perfect color — not good, but perfect — you need to
take some additional steps. In the office or studio, you need to regulate ambi-
ent light so that you have a consistent color-viewing situation, day in and day
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out, rain or shine, summer and winter. If you have windows, you need shades
or drapes that you can close before doing color-critical work. The walls visi-
ble behind the monitor and the immediate work area should be neutral in
color. (And that means no brightly colored sticky notes on the bezel of your
monitor!) You probably need a hood for your monitor and perhaps a D50 (or
D65) viewing station in which to evaluate your prints under optimal lighting
conditions.

Printing alternatives

Odds are that you use an inkjet printer to put your photos on paper. Although
inkjet printers are the most popular and perhaps the most practical, you do
have alternatives. If, for example, your work consists of brochures and flyers
rather than photos, a color laser printer might better fit your needs. The initial
cost is generally higher than all
except wide-format inkjets, but the
cost per page is much lower. Color

Prine

Printer | Phaser 7508

laser printers generally don’t print :,:T,,r =
photographs as well as a mid- to high- Featur sers: s3T5

end inkjet, and the prints aren’t e ?‘
archival (they won't last for a whole Colee e, Commarcia prass =
lot of years without fading), but such & image smooting

Output Ordar: | Face U ¢!

prints might be just fine for sharing
snapshots among friends and family.
The print options for a color laser
printer (such as the Print dialog box D (fmio) Clwintor ) (o Coeel ) (EEEED
you see in Figure 4-12) differ from an
inkjet’s options. Check the User Guide

for the specific printer to set up your Figure 4-12: Color laser printer options differ
job correctly. from those for inkjet printers.

Dye sublimation printers use rolls of film impregnated with dyes to repro-
duce prints. Prices range from under $200 to several thousand dollars. The
quality and longevity of the prints is generally tied to the price.

Here’s another output alternative available to virtually all Photoshop users.
Burn your images in JPEG format (highest quality, 300 ppi) onto a CD and
take the CD to the local photo lab. Alternatively, use an online service with
which you upload your JPEGs to the service’s Web service to order prints.
You'll get back glossy or matte prints at the size(s) requested. And the cost
per print can be substantially less than using your inkjet printer. The local
photo lab is often a great alternative for stacks of vacation photos and family
reunion shots that need to be sent to a whole passel of kin.

Unless your inkjet printer is specifically designed to generate grayscale
images, you might want to use the photo lab for such prints. Inkjet printers
designed with grayscale in mind output using black ink plus a supplemental
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light-black or gray ink to increase the tonal range and ensure adequate detail
in your shadows. Inkjets that aren’t designed to print grayscale can either

print using only black ink (which severely limits the detail and tonal range),
or they use rich black (black ink supplemented with the additional color

placed near each other, not on top of each other, which leads to the visible
lab for output.

inks), which invariably leads to some color tint or color cast in the suppos-
tinting of a grayscale image when printed on an inkjet using colored inks.

edly neutral grayscale images. It’s the nature of the beast — ink droplets are

Check the User Guide for your printer: If it doesn’t provide specific guidance

for printing grayscale, send your black-and-white images to the local photo
Sharing Your Images

Creating a PDF

Presentation

Photoshop offers a number of nifty ways to make it easy to share your images

with others. You can simply send a folder of JPEG files to a friend or client
with instructions to double-click each one to view the images. However, there
are certainly more elegant ways to showcase your talents.

Portable Document Format (PDF),
the native file format of Adobe

POF Fresentation

S
Acrobat, has become an incredibly
useful and near-universal format. It’s
hard to find a computer that doesn’t
have Adobe Reader (free software to
open and view PDF files), and that
helps make PDF a wonderful format

Carcel

Browie

images.

for sharing or distributing your

You can choose Filec>Automater>
PDF Presentation in Photoshop to
open the PDF Presentation dialog
box (as shown in Figure 4-13). From
there, you can quickly and easily

Qutput Dptions
Save 4%
Background:  White

=

Muiti-Page Decument ) Presentation
inchose. & Filename _ Extension

— Title

— Description
& Authos

g Copynight
_ baF info

— Annotations

and printing).

create both on-screen presentations
(complete with fancy transitions

between images) and multipage PDF
documents (suitable for distribution

Font Siae. 1

T

H
Prasemation Dptions

& Advarice Ewery |3

Seconds
_ Loop after Lact Page

Transivion:  Wipe Leh

Figure 4-13: PDFis a great format for sharing
images as presentations and multipage
documents.
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To create a PDF presentation or multipage PDF in Photoshop, take the follow-
ing steps:

1. If the files you want to use aren’t already open in Photoshop, click the
Browse button. You can click and then Shift+click to select a series
of images or 3 +click (Mac)/Ctrl+click (Windows) to select individual
images.

Hint: You must select the images; you can’t select only the folder.

After you click the Open button, the filenames appear in the PDF
Presentation window. Drag filenames up or down to reorder them.

2. In the Output Options area, you can elect to create an on-screen pre-
sentation or a multipage document.

Determine which elements of the images’ metadata — if any — you want
to be displayed.

3. Select how you want the presentation to play.

You can have the presentation automatically switch images after a given
number of seconds (or opt for manual slide advance), you can have the
presentation automatically rewind and begin playing again (loop), and
you can pick transitions between images. Do your audience a favor and
pick a single transition and stick with it — preferably one simple transi-
tion, such as Wipe Left or Wipe Right. Those too-busy transitions are the
21st-century version of PowerPoint clip art — fun to play with, but dis-
tracting to your audience.

4. Click the Save button.

You see the Save dialog box, from which you pick a location and a name
and then click another Save button.

5. In the Save Adobe PDF dialog box, make things simple for yourself
and choose Smallest File Size or High Quality Print from the Adobe
PDF Preset pop-up menu at the top.

If you're creating a presentation or want to create a multipage PDF from
which the recipient can’t print full-size images, choose Smallest File Size.
For a multipage document from which you do want your friends or
clients to print great images, use High Quality Print.

6. The only other area of the dialog box that you really need to consider
is Security.

You can assign a password to the file that the recipient needs to open
and view the presentation or multipage PDF document. Alternatively,
you can require no password to open the file but rather assign a pass-
word for printing or changing the file.

7. Finally, at the end of the road, click the Save PDF button to actually
generate the final file.
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If you want to create a PDF file that’s small enough to e-mail, you'll want to
work with small copies of your image files, perhaps no taller and wider than
500 pixels. You can use the Batch command (discussed in Chapter 16) to
automate the process of creating small copies by using the Image Size com-
mand (which itself is covered in Chapter 2).

Collecting thumbnails

in a contact sheet

In the old Dark(room) Ages, photo-
graphers regularly made a record of
which images were on which film
strips by exposing those strips on a
piece of photographic paper, thus
creating a contact sheet. The contact
sheet serves the same purpose as
thumbnails or previews in Bridge or
the Open dialog box or thumbnail
images on a Web page — they show
which image is which. Hard copy
contact sheets (or JPEG copies) are
useful to present to a client or send
to friends as a quick summary of
your latest work. Photoshop can
automate the process for you with
Contact Sheet II (see Figure 4-14).

Contact Shaet 1
Source Image == ool
Use:  Folder ~
Chooua. Y T T .

¥ include Al Sublolders

Doumnt
usis | nches =
Width: 2
Height: |10
Resohution: 300 pads/imch 75

Mode  RGE Coor 5

# Hatten AN Layens

Thusnbinshi
Pace: across A, T8 f Use Auto-Spacing
Columny: %
Rows: £
_ Rotate For Bedt Fil

# Use Filerume As Caption
ror. RIS 1o Sice 12 60 7)
Hehetica

e Times

Figure 4-14: If you need a printed record of
your images, consider Contact Sheet II.

Here’s how you use Contact Sheet I to create pages of thumbnail images:

1. Choose Filer>Automater>Contact Sheet II.

The Contact Sheet Il dialog box appears.

2. Select a source folder from the Use drop-down list in the Source

Images area.

(Optional) If you want to include the images in any subfolders that might
be within that folder, select the Include All Subfolders check box.

3. Using the Units, Width, and Height options in the Document area,

describe your document.

Input the printable area of your page — not the paper size.

4. Select a resolution.

[ recommend 300 pixels per inch (ppi) if printing and 72 ppi if you'll be
e-mailing the contact sheets or slicing them for your Web site.
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5. Use the Mode drop-down list box to select a color mode (RGB unless
printing to a color laser printer).

6. Select the thumbnail layout.

Choose the number of rows and columns, decide whether to fill row by
row or column by column, set the spacing between thumbnails (Auto-
Spacing is recommended), and opt to rotate or not rotate thumbnails.

7. Before clicking OK, take a look at the Flatten All Layers check box and
decide whether you want to flatten layers (which makes a smaller but
less versatile file).

Note in Figure 4-14 that you have some important information below the
Cancel button. Contact Sheet Il gives you a preview of the layout, tells you
how many pages (and images) you're going to generate, and it shows you
how large each image will be on the page. Keep an eye on this area when
making decisions in the Thumbnails section of the dialog box.

You can choose to have the images added to the page row by row (the
second image is to the right of the first) or column by column (the second
image is directly below the first). You also choose the number of rows and
columns, which determines the size of each individual image. You then need
to decide whether to use Auto-Spacing, to calculate the spacing between
images, and to rotate images. If your source folder has a mixture of landscape
and portrait images, rotating makes sure that each is exactly the same size —
although some will be sideways. If image orientation is more important than
having identical sizes, don’t use the Rotate for Best Fit option.

If your folder is filled with portrait-oriented images, you can certainly have
more columns than rows so that each image better fills the area allotted for
it. For example, when printing 20 portrait images, using 5 columns and 4 rows
produces larger printed images than using 4 columns and 5 rows.

Contact Sheet Il also lets you add the filename as a caption below each image,
which proves to be a very handy way of tracking your images. As you see in
Figure 4-14, your font choices are rather limited. (Make sure you use a font
size small enough to get the whole name within the width of the individual
images.) By default, the filename is in black.

E-mailing your images

Remember, too, that you can send images via e-mail. Keep in mind, however,
if you like these folks enough to send them your images, you probably want
to keep their friendship. And to that end, you want to be a responsible
e-mailer — you don’t want to send out an e-mail attachment so large that it
disrupts service for the recipient. (“Hi Marge. You know those images from
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your vacation that you e-mailed me on Tuesday? They're still trying to down-
load. Yeah, today is Saturday. Anyway, why don’t I drive up to Maine and look
at the snapshots — it’s probably faster than waiting for the e-mail.”)

As a general rule, your attached images should rarely if ever total more than
1MB in size (unless you verify through direct communication that everyone
on your To: list can handle large attachments). Each image should be no
more than 550 pixels tall so that it can be viewed in a Web browser on any
screen. You can certainly use your computer’s compression utility — Stufflt
(Mac) or WinZip (Windows) — to compress one or more images before send-
ing. But if you do compress your attached images, make sure to include
instructions to save the compressed file to the hard drive and double-click
to expand.
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“Hey— let’s put scanned photos of
ourselves through a ripple filter and see
if we can make ourselves look weird.”




Some photos can be printed straight from the
camera without ever seeing the light of
Photoshop. However, most images need at

least some adjustment, and many need a lot of
adjustment. Here’s where you discover how to
work magic on your images.

The range of brightness from black to white is crit-
ical for most images. In Chapter 5, you read how
to maximize and adjust that tonal range in your
photos and how to maximize your use of the
Histogram palette. And there’s more to a great
photo than shadows and highlights. Chapter 6
looks at adjusting the color in your images, making
them look as natural as possible. More and more
digital photographers are switching to the Raw file
format because of the control it provides over the
final image. Read Chapter 7 for the lowdown on
working with the Adobe Camera Raw plug-in.

Sometimes only part of an image needs to be
adjusted. The key to making precise adjustments,
as you can read in Chapter 8§, is to tell Photoshop
where to work with selections and masks. Chapter 9
examines many of the most common problems in
Photoshop (and what to do about them). You can
read about eliminating red-eye, reducing wrinkles,
whitening teeth, and minimizing digital noise.
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Adding Dark Shadows and
Sparkling Highlights

In This Chapter

Discovering tonality

Making the easy Auto repairs

Making adjustments with Levels and Curves
Using advanced tonality correction

It’s the difference between an Ansel Adams print and the snapshot of your
grandfather as a boy. It’s the difference between high-definition TV and the
local public access channel’s broadcast. It’s the difference between a Ferrari
and a minivan. It’s that thing — that special something — that tells you

that you're seeing the real deal, the genuine article, all that it
can be. And it’s something that you can do for your images.

When an image really pops — when it jumps off the
page at you — it’s generally because the shadows are
dark, the highlights are light, and the colors are rich.
I'm sure it’s no surprise to you that Photoshop can
handle the job. (That’s one of the reasons why you
bought the program, right?)

In this chapter, [ introduce you to the concept of
tonality, which is the range of brightness in your
image. [ also introduce to you the various commands
that Photoshop offers for you to adjust your image’s
tonality. A couple of tools even give you pinpoint control of
shadows and highlights. And along the way, I offer you a look
at the Histogram palette — what it tells you, what it doesn’t tell you,
and how to use it best.
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Adjusting Tonality to Make Your Images Pop

Most photos look better with a little
tweaking. For pictures that look good
to begin with, you might still want to
perk them up a little with a tonal
adjustment. Making the shadows a
little darker and the highlights a bit
lighter increases your image’s per-
ceived tonal range, which is sort of
the distance between black and white.
Take a look at Figure 5-1. It’s a pleas-
ant enough snapshot, with decent
composition and an interesting sub-
ject (very interesting when you get
to know her!). But it lacks pizzazz.

Figure 5-1: A nice snapshot, but not art.

With Photoshop, you can darken the
shadows and lighten the rest of the
image to make it more interesting.
By intensifying the difference between
what the eye sees as dark and what
the eye sees as light in the image,
you add some semblance of depth
to this simple picture. Comparing
Figure 5-1 with Figure 5-2, you can
see that one basic tonal adjustment
can also make the colors (such as
the shirt) seem richer and even pro-
duce a perceived increase in detail
or sharpness (the fur at the muzzle,
ear, nose, and eye).

Figure 5-2: One simple tonal adjustment
darkens, lightens, enriches color, and brings
out detail.

You might hear a number of words used for the same concept: the lightness
and darkness of your image. Tonality, luminosity, and even brightness can be
used virtually interchangeably when you’re talking about the general subject.
However, you generally use brightness when talking about specific pixels and
tonality when referring to the image as a whole.

Histograms Simplified

In most photographs of general subject matter, your eye sees the darkest
neutral (gray) tone as black and the lightest neutral as white. (If the darkest
color is obviously purple and the lightest a bright yellow, you probably
wouldn’t classify the photo’s subject as “general.”) In a given image, the
shadow under the shoe might be just a dark gray, and the shirt looks like it
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might need some bleach, but your eye (in cooperation with your mind) com-
pensates to some degree and lets you see black and white.

For a more accurate look at the tonal range of your image, Photoshop offers
the Histogram palette (found nested with the Navigator and Info palettes

in the upper-right corner of your screen), which displays the distribution

of the pixels in your image at various luminosity values. The darker pixels
(shadows) are stacked at the left end, the lighter pixels (highlights) are
stacked at the right end, and the rest of the brightness values (midtones) are
stacked between. The taller a column in the histogram, the more pixels at
that luminosity value. Figure 5-3 shows an image with what some folks would
call a near-perfect histogram distribution because of the beautiful bell curve
centered in the graph.

But don’t be seduced by a histogram distribution! Not every properly exposed
image has such a bell curve. Many perfect images have wildly different his-
tograms. The correct distribution in the histogram depends on two things:
the image content and the artistic aims of the artist.

Source: EII'LII'E Image

Figure 5-3: This image has a very even distribution of pixels through the midtones.

87
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Consider, if you will, an image that B0 0 = MG, 17041 @ 1115 RGA/ED

consists primarily of white pixels, per-

haps a beautiful Alpine snow scene or

an ugly creepy-crawly thing on porce-

lain (as you can see in Figure 5-4).

Either image has a histogram skewed s :

dramatically to the right — what you S O 3 '
call a high-key image. Nothing is .

wrong with the image (despite the

histogram); it just happens to have a
huge number of light-colored pixels.

Likewise, a low-key image has a pre-
ponderance of dark pixels, which
skews the histogram to the left. Just
about any night scene has a very
large number of very dark pixels,
pulling the distribution to the left in the histogram. But many night scenes
also include lights, which produce a spike at the far right end.

Figure 5-4: The histogram is skewed to the
right because of the many white pixels.
Or maybe it's trying to escape the spider.

\‘&MBER Keep in mind, too, that the heights of 222 = CRML1740.1 8 3115 A/ 160

& the individual columns in the his-
togram area are relative: The tallest
goes all the way to the top of the box,
and the others are scaled accord-
ingly. For example, an image on a
black background — say, a large black
background — might have so many
pixels in the left-most column that the
other columns in the image appear
tiny and almost unreadable, like the

histogram shown in Figure 5-5. Figure 5-5: Too many pixels in the left-most
column make the distribution for the midtones
N If the histogram is skewed to one end hard to see.

or the other, making it hard to read,

you can make a selection within the image and the histogram updates to
show information for only the selected area. (Read about making selections
in Chapter 8.) If the image has multiple layers or adjustment layers, the little
pop-up menu at the bottom of the Histogram palette (when in Expanded View
mode) enables you to specify what layer to calculate.

@‘“\NG! If you see a little warning triangle to the upper-right of the histogram data in
S the palette, you're not necessarily seeing accurate information. The histogram
is using information from the image cache rather than the image. Click the tri-
angle to update the histogram. And, if you choose Preferences->Performance,
you can set the Image Cache to 1 to ensure accurate on-screen display and
histograms.
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Sometimes a histogram seems to tell you _
absolutely nothing worthwhile. For example, take Cuasm | n =
the histogram in Figure 5-6. The image doesn’t
have a bell curve distribution, with a gentle sloping
to either side of the center peak. It’s not a high-key
image because the pixels aren’t mashed together
at the right. The image is somewhat low-key, but
the histogram doesn’t have a huge stack at the left
end. It does tell you, however, that there are three  Figure 5-6: The histogram
distinct ranges of tonality in which you find most ~ sometimes speaks to you in
of the image’s pixels. riddles.

Using the menu, opened with the button in the upper-right corner of the
Histogram palette, you can change the palette’s configuration. (So far in this
chapter, I show the Expanded View, which offers a little better look at the
graph than does the Compact View.) In this case, switching to the All Channels
View, which shows you a histogram for each color channel, helps solve

The Mystery of the WacRy Histogram, especially when seen with the image
itself, as shown in Figure 5-7. The image contains a large number of pixels of
a rather consistent color. If you mixed that color in the kitchen, the recipe
would call for one part red, two parts green, and four parts blue.

ann = IMG_0163.tif @ 25% RGB/87)

..

Figure 5-7: The All Channels View shows individual histograms for each color channel.
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Using

As you read later in this chapter (in the section “Level-headed you!”), you can
use the histogram to help avoid degrading your image while making adjust-
ments, and (as you read in Chapter 7) it’s very important for working with
the Camera Raw plug-in. But don’t forget about your eyeballs — you don’t
need the Histogram palette to spot a low-key or high-key image.

Photoshop’s Auto Corrections

Adjusting the tonality of your image can be as simple as selecting one of the
Auto commands from Photoshop’s Imager>Adjustments menu. With many
photos, the tonality (and even the color) jump to
just the right look for your image. No muss, no
fuss — just a great-looking picture with a single
command.

If you need to do something special with the
image (for example, create an unusual effect) or
if the image is in bad shape to begin with, the
Auto commands might not be your best bet.

But remember this: It never hurts to try an

Auto command first. At worst, you use the Undo
command, and you've wasted only a couple of
seconds and a pair of keystrokes.

From least sophisticated to most, here are your
three Auto correction choices:

1 Auto Contrast: Auto Contrast makes the dark
pixels darker and the light pixels lighter, and
it tries to avoid introducing any color shift
(an overall change in the color appearance).
The same adjustment is applied to all three
of your image’s color channels. You can use
Auto Contrast with an image in which the
colors already look good and you perhaps
just need a bit of a boost to the contrast.

- r\_ 0= ClassVase copy & J1E% RGE/A#)

<

1~ Auto Levels: Each of your image’s color
channels gets its own adjustment, maximiz-
ing the tonal range in the channel. If one of
the color channels has very little to con-
tribute to the original image, a color cast
(an unwanted tint, as shown in Figure 5-8)
might be introduced. Auto Levels is fine for
most images that look good already and Figure 5-8: The same photo, with
don’t need to have exact colors. and without an orange color cast.
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1 Auto Color: Rather than using a single brightest pixel and a single dark-
est pixel to determine what should be white and what should be black,
Auto Color averages a few pixels at each end. That averaging prevents
one single stray pixel from throwing off the calculation used to adjust
your image. Auto Color is great for most typical images. You might need
that Undo command, however, on some photos with very brightly col-
ored objects or images that have extreme color casts.

Levels and Curves and Vou
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Sometimes you need (or simply want) more control than what’s offered by
the Auto commands. You might have a more demanding problem or a more
expansive artistic vision. You might need to make major corrections or create
stupendous effects. Photoshop, not surprisingly, offers that sort of control
over your image. In fact (and also not surprisingly), you have several ways

at your disposal to manipulate the tonality of your images. Two of the

most commonly used are Levels and Curves, both found in the Image=
Adjustments menu.

Before I introduce you to those two commands, let me quickly explain

and dismiss a couple of other available options. Since the early days of
Photoshop, the Brightness/Contrast command has lurked among the
Image=>Adjustments commands. In fact, it was the image-adjustment com-
mand way back when. Now, however, the feature is somewhat lacking in
control and sophistication and is perhaps of most use when fine-tuning an
alpha channel or layer mask. (Alpha channels are discussed in Chapter 8, and
layer masks appear in Chapter 10.) In both alpha channels and layer masks,
you use a grayscale representation to identify specific areas of your image.
Brightness/Contrast is perfectly adequate for many adjustments that you
might make to those channels.

Also of limited use is the Equalize adjustment. It finds the lightest pixel in the
image and calls that white and also finds the darkest pixel and calls that
black. The rest of the pixels in the image are distributed between those
values, creating an extended tonal range. In practice, you'll find that the
adjustment results in extreme highlights and extreme shadows, with a

rather garish image overall as well as a lack of details in the midtones.

Always keep in mind that you don’t have to make changes to the entire image.
If only part of an image needs repair, make a selection of that area before open-
ing the particular adjustment dialog box you want to use. (Read about making
selections to isolate areas of your image in Chapter 8.) Say, for example, that
you take a beautiful photo of a room in your house — “beautiful” except that
the view out the window is far too bright. Isolate the window with a selection,
and then use one of your image-adjustment commands to tone it down.
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You can apply Levels, Curves, and Brightness/Contrast as adjustment layers.
Adjustment layers make the same changes to your images as the commands in
the Image=>Adjustments menu but are far more flexible. By double-clicking
the adjustment layer in the Layers palette, you can reopen the adjustment
dialog box and make changes to your settings. When you use an adjustment
layer, you can also restrict the effect of the adjustment to one or more layers
through layer clipping and layer sets. (See Chapter 8 for more information on
working with adjustment layers.) You can even delete an adjustment layer,
thus eliminating its effect on your image, by dragging it to the Trash icon at
the bottom of the Layers palette.

Level-headed you!

The Image>Adjustments>Levels command (88 +L/Ctrl+L) gives you control
over shadows, highlights, and your image’s overall tonality individually.
Using a slider with three controls, you adjust the picture both to suit your
eye, and with an eye on a histogram for reference. You even have numeric
fields in which you can type exact values, should you find the need.

To perform the basic Levels correction, spreading the image’s tonality over the
full range of values available, you simply drag the slider controls under the
histogram in the Levels dialog box inward until they’re under the point where
the histogram begins to rise in a mountain shape. Ignore those little flat tails
that extend outward — they represent individual stray pixels — and drag the
little pointers under columns that are at least a few pixels tall. The histogram
in the Levels dialog box (as shown in Figure 5-9) is for reference as you make
changes. Note, however, that while you work in Levels, the Histogram palette
updates, showing you the “after” in black, with the “before” histogram in color.

Lavals

. om

Input Levels

Cancel

Aute
Ogtions, .
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Figure 5-9: Compare the Levels histogram and the Histogram palette.
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Defining white and black

The Options button in the Levels (and Curves)
dialog box opens a door through which you
might never need to walk. However, should your
path lead you to that door, | want you to know
what lies behind. Neither pit nor tiger awaits
you, only the possibility of controlling your high-
lights and shadows — or making a total mess of
your image, of course. (Adobe does a good job
of hiding those it-could-cost-me-a-fortune-if-1-
screw-it-up features.) The Options button gives
you control over the behavior of the Auto button
(in both Levels and Curves), but | suggest that
you leave the defaults alone. Even more impor-
tant, the Options button lets you define what
colors Photoshop should use for the lightest
pixels and for the darkest pixels. That's right,
white and black are not always the same.

Generally speaking, if you print to an inkjet, you
want the full tonal range of the printer, so you

should leave white and black set to the
extremes, as far apart as possible. However, if
you're creating gallery prints, you might want to
change the definition of “white” from RGB
255/255/255 to RGB 245/245/245 to ensure that
you produce 100 percent ink coverage, with no
paper showing through in the highlights.

If you must make changes to your highlight and
shadow values, perhaps in response to a request
from a print shop, open Levels (or Curves), click
the Options button, click the highlight (white)
color swatch to open the Color Picker, and then
input the suggested values. Click OK and then
repeat for the shadow swatch. Make sure to
click the buttons that retain the values as your
defaults as you OK your way back out of all
those dialog boxes.

Dragging the middle slider to the right moves the bulk of the histogram

A\

toward the left, indicating that the overall appearance of the image is slightly
darker. Dragging the middle slider to the left lightens the overall image.

Also note the lower Output Levels slider in Figure 5-9. You generally use that
only when preparing an image for a commercial printing press that requires
you to compress the image’s tonal range. Otherwise, ignore that slider and its
two fields except for special effects. And make a mental note of that pop-up
menu at the top of the Levels dialog box — you can apply Levels to each
color channel of your image individually, changing this tonal adjustment tool
to a color-correction feature. (Fixing the color in your image is covered in
Chapter 6.)

When you’re working in Levels (or just about any dialog box), remember that
holding down the Option/Alt key changes the Cancel button to Reset. When you
click Reset, all values in the dialog box are restored to the defaults, letting
you start over without having to cancel and reselect the command.

Earlier in this chapter, [ mention that you can use the Histogram palette to
avoid introducing problems into the image. Note in Figure 5-9 that the
Histogram palette shows slight gaps appearing among the darker columns in
front. Technically called posterization, these gaps represent tonal values that
are being squished together into a single value. The pixels at one brightness
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level are being shifted to the next higher or the next lower value, leaving that
empty column in the Histogram. Is this a problem? No, as long as you don’t
see wide gaps, representing a number of consecutive tonal values not in use.
(Extensive posterization ruins the subtle transitions between colors in your
image.) And that’s why you want to keep an eye on the Histogram palette —
to make sure you’re not creating wide gaps in the histogram and noticeable
posterization in your image.

Here is an easy way to minimize that posterization, one that lets you make
your Levels adjustment but keep a pretty histogram. Immediately after using
Levels, choose Edit~>Fade Levels and change the blending mode from Normal
to Luminosity. As you see in Figure 5-10, the posterization goes away with a
minimal change in the effect of the Levels adjustment. Remember that the
Fade command is available only immediately after applying an adjustment
(or filter or tool) — you can’t even use the Save command between.

(Read more about the Fade command in Chapter 15.)

L L

Figure 5-10: Change the Levels adjustment blending mode to Luminosity with the Fade dialog box.

Tonal corrections with the eyedroppers

The Levels dialog box (and the Curves dialog box, too) offers another way to
make tonal corrections to your image — sort of a half-automated technique,
using the three eyedroppers in the lower-right corner of the dialog box. Open
your image, open the Levels dialog box, and correct both tonality and color
in your image with three little clicks:

1. Click the left eyedropper on something that should be black.

This might be a shadow, a piece of clothing, or the tire of a car.
Generally, you click something in the image that’s already quite dark.
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2. Click the right eyedropper on something that should be white.

A cloud, the bride’s dress, perhaps an eye . . . all are likely targets for the
highlight eyedropper. You usually click something that’s already quite light.

3. Click the middle eyedropper on something that should be gray.

Click something that should be neutral in color. It doesn’t have to be
midgray, just something that should be neutral. This reduces or elimi-
nates any unwanted color cast in the image. If you don’t like the result,
click somewhere else in the image. Keep clicking until the colors in the
image look right.

In Figure 5-11, the shadow under the bridge, the splash of water, and the
weathered wood of the bridge itself provide excellent targets for the three
eyedroppers.

oy
Caneel
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Figure 5-11: Use the eyedroppers in Levels to set the black and white points; then neutralize
your image’s colors.

Adjusting your curves without dieting

One step up from Levels in complexity, and about five steps ahead in terms

of image control, is Image~>Adjustments=>Curves (88+M/Ctrl+M). The Curves
dialog box got a makeover for Photoshop CS3, adding a number of display
options, as well as a pair of slider controls (similar to the left and right sliders
in Levels) to easily control the endpoints of your shadows and highlights.
The curve line itself gives you control over various parts of the tonal range
independently. Curves also offers eyedroppers for tonal and color correction.
They’re used the same way you use the eyedroppers in Levels.
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At the very beginning of this chapter,
I show you how a simple tonal
adjustment can add some drama,
some interest to a rather bland
image. Figure 5-12 shows you the
simple Curves adjustment that I
applied to that image. Dragging the
curve downward in the shadows
makes them darker, dragging
upward for the highlights makes
them brighter. The midtones (that
section of the tonal range between
shadows and highlights) also gets
lightened a bit in this adjustment.

gt
us HL 2T show Cappwg

When you first open the Curves B o ot i

Show Ampunt of @ Light 105 5%} .
momenims . IS

dialog box, you see a graph with a
diagonal line running from an anchor
point in the lower left to another in
the upper right. You can click and Figure 5-12: Remember little Stella from the
drag that line up or down (not side-  peginning of the chapter?

ways) to add anchor points and

make changes in the curve (and in your image). By default, the shadows

are in the lower left, so dragging down darkens, and dragging up lightens.

(In the Curves Display Options area, switching from Light to Pigment/Ink will
reverse the shadows/highlights. Use this option when preparing CMYK
images for page-layout programs.) You can add more than a dozen anchor
points to the curve — although you generally need only between one and
three new points.

Most snapshots can benefit from a slight tweak in Curves. Click at the
intersection of the first vertical and horizontal gridlines in the lower left
(the quarter tones) and drag down slightly. The Input field should read 64,
and the Output field should be somewhere between 55 and 60 for a shot that
looks pretty good to start. Next, click at the intersection of the grid lines in
the upper right (the three-quarter tones) and drag up slightly. The Input field
should show 192, and the Output field can be anywhere from 195 to 205.
This is called a basic S-curve.

Both the Curves and Levels dialog boxes offer you the Load and Save options.
(In Levels, you see prominent Load and Save buttons, whereas in Curves, you
click the menu button to the right of the Preset menu.) If there’s a correction
that you’ll use more than once or a correction that needs to be precise time
after time, use Save. Then, later, you can click Load to apply that adjustment
to another image. If, for example, you used the wrong setting in your camera
while taking a series of shots all under the same lighting conditions, they
probably all need the same correction. Make the adjustment once, save it,
and then apply it to the other images with the Load button.



If you want to correct a specific area
in the image, hold down the mouse
button and move the cursor into the
image window (where it appears as
the Eyedropper tool). You'll see a
circle on the curve (like the one near
the middle of the curve in Figure 5-13),
telling you where those pixels fall in
the tonal range. To add an anchor
point there, 38+click/Ctrl+click in the
image window (in the window to the
left in this example). Also note that
Curve Display Options can be hidden
to shrink the Curves dialog box.

When your curve has multiple anchor
points, the active anchor point shows
as a filled-in square. Deselected
anchor points are hollow squares.
For precision, you can use the arrow
keys to move the active anchor point,
or you can type specific values in the
Input field (starting position for the
anchor point) and Output field (where
you want the anchor point to go).

Option+click/Alt+click in the grid area
to toggle between a 4 x 4 grid and a
10 x 10 grid. And, rather than clicking
and dragging on the curve, you can
activate the Pencil tool (shown in
Figure 5-14) and draw your curve by
hand. When hand-drawing your curve,
the Smooth button is available, too,
to ensure that the transitions in your
tonal adjustments aren’t too severe.

Grabbing Even More Control
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©2003 PhotoSpin, PhotoSpin image #0990129
Figure 5-13: Hold down the mouse button

with the cursor over the image to see that

point on the curve.
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Figure 5-14: You can increase the number of
grid lines: handy when drawing a curve.

The Imager>Adjustments menu in Photoshop CS3 includes a couple more
extremely powerful ways to work with tonality in your images. You can use the
Shadow/Highlight adjustment to isolate and change whatever range of dark
and light pixels you want. By specifying what range of tonal values that you
want to be considered dark or light, you control how broadly or narrowly your
change is applied. The Exposure feature lets you change the overall tonality of
the image, as if you'd taken the photo with a different camera setting. And don’t
forget about making spot corrections with the Dodge and Burn tools!
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The Shadow/Highlight and Exposure adjustments are not the same as
working with Raw images in the Camera Raw plug-in (see Chapter 7).

Camera Raw works with unprocessed image data, the so-called digital
negative. Using Photoshop’s Adjustment commands, you're working with
image data that has already been manipulated in the camera, in Photoshop,
or both. When working with unprocessed data in Camera Raw, you truly have
control over the exposure, the shadows, the highlights, and much more.

The Shadow/Highlight adjustment is not available as an adjustment layer.
Changes that you make with the Shadow/Highlight feature are a permanent
part of your image.

Using Shadow/Highlight

The Shadow/Highlight adjustment is designed to rescue two specific sorts

of images — you’ve seen them (and maybe taken them): The background is
perfectly exposed, and the person in the foreground is in horrible shadow.
Or, equally bad, the background looks great, but the subject is washed out by
a strong flash. (See both examples in Figure 5-15.) By controlling the shadows
and highlights separately from the rest of the image, this feature helps you
restore more balance to the image.
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Figure 5-15: Shadow/Highlight does a rather good job with these very common problems.

The default settings in Shadow/Highlight are intended to repair backlighting
problems, as you see on the left in Figure 5-15. When the foreground lacks
detail because of flash (as you can see in the top dog image on the right),
minimize changes to the shadows and drag the Highlights slider to the right.
And, as shown in Figure 5-16, with Show More Options selected, Shadows/
Highlights gives you incredible control over images that have problems at
both ends of the tonal range.
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Figure 5-16: Some images need help for both shadows and highlights.

In the Shadows/Highlights dialog box, the Shadows slider lightens the darker
areas of your image, and the Highlights slider darkens the lighter areas.
Generally, you'll use one slider or the other to fix a specific problem in an
image, but you can use both if you need to lighten shadows and tone down
highlights in the same image.

When you enable the Show More Options check box, Shadow/Highlight
has a rather intimidating set of controls. Not to worry! It’s actually pretty
simple:

1 Amount: For both Shadows and Highlights, the Amount slider is how
much of a correction you're making. This is the nuts and bolts of the
Shadow/Highlight adjustment. For a backlit subject, you'll use the
Shadows slider a lot and not the Highlights slider. When working with a
washed-out subject, you’ll probably move the Shadows slider to 0% and
work with the Highlights slider.

1~ Tonal Width: Use the Tonal Width sliders to specify how much of the
image’s tonal range you want to include as shadows or highlights. If you
drag either Tonal Width slider to 100%, you’re working on the entire
tonal range of the image — not a particularly appropriate job for
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Shadow/Highlight (use Curves instead). The default of 50% is rather too
high most of the time. Instead, start your adjustment with a range of per-
haps 20% and fine-tune from there.

1~ Radius: You adjust the Radius sliders to tell Shadow/Highlight which
pixels should be identified as being in the shadow or highlight. With too
low of a Radius setting, an individual black pixel stuck in the middle of a
light area in your image might get classified as a shadow area. Too high
of a setting has a tendency to apply the adjustment to the entire image.
Generally speaking, start with a Radius of perhaps 10 pixels for very
small images and 30 pixels for large digital photos. After adjusting your
Amount and Tonal Width sliders, move the Radius slider back and forth
while watching some of the smaller patches of shadow or highlight
(whichever you're correcting) to make sure that those areas are being
included in the adjustment.

1 Color Correction/Brightness: This slider changes its name to match
your image’s color mode. When working with a color image, you see
Color Correction. When you apply Shadow/Highlight to a grayscale
image, the slider’s name changes to Brightness. Don’t bother with
this slider until you make your Amount adjustment. In a color image,
lightening the shadows or darkening the highlights shows the actual
color of the pixels in those areas. Use this slider to increase (drag to
the right) or decrease (drag to the left) the saturation of those pixels.
Remember that Color Correction works only on the pixels that you iden-
tify with the Tonal Width and Radius sliders. (If you set both sets of
Tonal Width and Radius sliders to 0%, Color Correction has no effect on
the image at all.) When you correct a grayscale image, on the other
hand, the Brightness slider affects all pixels except those that are
already pure white or pure black.

1~ Midtone Contrast: You can increase or decrease the contrast through-
out the image with the Midtone Contrast slider. Much like clicking in the
middle of the curve in the Curves dialog box and dragging up or down,
you adjust the whole range of your image, including the shadows and
highlights. When the overall appearance of your image needs improve-
ment, start with Midtone Contrast and then work with your shadows
and highlights individually.

1 Clip: Most of the time, you don’t want to change the clipping values.
Clipping takes pixels that are almost black and forces them to pure black,
or it takes pixels that are almost white and forces them to pure white.
Clipping your shadows or highlights reduces those subtle differences in
color that provide the detail in the shadows and highlights. When would
you want to clip shadows or highlights? When you don’t care about
detail in those areas of your image and need more contrast through the
midtones.
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Changing exposure after the fact

Photoshop also offers the Exposure feature in the Imager>Adjustments menu.
It simulates how the image would have looked if you changed the exposure
setting on your camera before clicking the shutter. Think of it as an across-
the-board adjustment of tonality in the image or within a selection in the
image. As you can see in Figure 5-17, even a minor adjustment can have a
major impact on the image!

Earlier in this chapter, | mention that sometimes you want to apply an adjust-
ment to only part of an image. The windows in Figure 5-17 certainly qualify!
To best repair this image, [ made a selection of the windows, improved their
exposure, inverted the selection (select the areas of the image other than the
windows), and corrected the room separately. (Chapter 8 has all the info on
making selections.)

B OO interor-001.5f @ 12.5% (RCBJ 164)

Figure 5-17: With the Exposure adjustment, a little change goes a long way!
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The Exposure dialog box offers a couple of additional controls, too. The
Offset and Gamma Correction sliders are designed primarily to work with
very high-bit images (the special 32-bit/channel high dynamic range images),
and you likely will find them too sensitive to be of much use for most images.

Exposure is a rather specialized tool, and you probably won'’t find it nearly as
user friendly or effective as Curves and Shadow/Highlight. If you do actually
work with 32-bit/channel images, take it for a test drive; you might decide
that it fills a need.

Using Photoshop’s toning tools

You have a couple more ways to work with tonality in Photoshop — the
toning tools. These two brush-using tools let you paint corrections on your
image, giving you incredible control over the appearance. Select the Burn
tool to darken or the Dodge tool to lighten. Select a brush tip in the Options
bar and drag the tool in your image to apply the correction. (You can read
about controlling the brush-using tools and that incredibly complex Brushes
palette in Chapter 14.) In Figure 5-18, you see the Burn tool darkening a spe-
cific area of the fence on the right.

Brush: | 5'_ vlI Ranga:  Midtones -:] Exposure: |20 i |_l’ '}(f——-'
) | by 79 T 3. i :

IMC_O1B3.1If @ 12.5% (RC... | @ @ @ T IMG_0183.tif @ 50% (RGB...

Figure 5-18: “Painting” the fence with the Burn tool. Where is Tom Sawyer when | need him?
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The Dodge tool is great for minimizing *# - ¢ = om ®owze
(without removing) shadows in an D = Sl
image. You'll find it particularly =

useful for reducing wrinkles in faces ¥

and other such jobs that require ;’

lightening specific areas of an image. :

Figure 5-19 compares the original z B

(left) with a working copy in which S

I'm using the Dodge tool to reduce -

the appearance of the wrinkles. ¥ -

By reducing rather than eliminating N

those wrinkles completely, [ retain the

character of the man’s face as well ©2001 PhotoSpin, PhotoSpin image #0550013
as prevent that phony, just-out-of- Figure 5-19: Use the Dodge tool to minimize
plastic-surgery look. wrinkles without removing them.

For most of the work that you do with the Dodge and Burn tools, the default
Exposure setting of 50% is way too strong. In the Options bar, reduce the
Exposure to about 15-20% for most work. And unless you’re specifically
working on lightening shadows or toning down highlights, set the tools’
Range to Midtones in the Options bar.
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Making Color Look Natural

In This Chapter

Seeing reds, greens, and in-betweens
Sailing with the Photoshop color-correction armada

Fixing flesh tones

In the end (and the middle and the beginning), your image in Photoshop is
nothing but little squares of color. Each square — each pixel — can be
exactly one color. Which color for which square is up to you. I'll say it again:
There is no car or circle or tree or Uncle Bob in your Photoshop image — just
a bunch of little squares of color.

In this chapter, [ explain how those squares of color are formulated, how
Photoshop works with those formulations, and — most important — how
you can manipulate the colors of those squares. Toward the end of

the chapter, you read about one of the biggest color-related
challenges in Photoshop: achieving accurate skin color.

What Is Color in Photoshop?

Photoshop works with digital images (including digi-
tal photos, images that have been digitized with a
scanner, and artwork that you create from scratch in
Photoshop). The digits are the computer code used
to record the image’s information. The number of
pixels, the color of each pixel, and any associated
information are all recorded in a series of zeros and ones
on your hard drive. Color, therefore, is nothing more than
numbers — at least as far as Photoshop is concerned. For you
and me, however, color is far more than binary code on a hard
drive. It’s the image, the artwork, the message. The artwork is color, and
color is the artwork, pixel by pixel.
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Color modes, models, and depths

Photoshop records the color of each pixel in your image in any of several dif-
ferent ways. Every pixel in any given image has all color recorded in a single
color mode, which is the actual color format for the image file. While working
with your image, however, you can define specific colors in any of a variety of
color models, which are sort of the formulas or recipes with which you mix
color. And an image can have only one color depth, which is the limitation on
the number of colors in an image.

Before I get into too many details, you need to understand one of the basic
concepts of color: gamut. Consider gamut to be the range of colors that can
be theoretically reproduced in a specific color mode or with a specific color
profile. A wide gamut, therefore, has many more colors available than does a
limited gamut. Those extra colors are generally the brighter, more vibrant
colors . .. the ones that make an image come alive. The red/green/blue (RGB)
color mode generally offers you a wider range of colors than does cyan/
magenta/yellow/black (CMYK). See, for example, the comparison in Figure 6-1.
And keep in mind that the specific color profile (the working space that you
select; see Chapter 4), also has an impact on the colors in your image.

Figure 6-1: A wide-gamutimage (on the left) and the same picture with a smaller gamut.
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Which color mode should you choose?

If you’ll be printing to an inkjet printer or posting your image on the Web, you
need RGB color mode. (Despite the CMYK inks that you load into your inkjet
printer, the printer’s software expects and must receive RGB color data.) If
you’re prepping an image for inclusion in a page-layout document destined
for a commercial offset press, you need CMYK. You select the image’s color
mode from the Imager>Mode menu. That’s the simple summary. Here’s a bit
more detail, presented in the order in which you're likely to need the various
color modes:

1 RGB: RGB is the color mode for digital photos, computer monitors, the
World Wide Web, and inkjet printers. All colors are recorded as propor-
tions of the three component colors, red, green, and blue. RGB color is
recorded in the three color channels (described a bit later in this chap-
ter). RGB is an additive color mode — that is, the more of each compo-
nent color you add, the closer you get to white.

» CMYK: CMYK is used primarily
for printing on a commercial
offset press, but you might need
it for a color laser printer or a
high-end inkjet printer with
which you use a RIP (raster
image processor, which is a
specialized bit of hardware or
software that lets your inkjet
pretend it’s a printing press).
CMYK is the color mode of mag-
azines, books, and other mass-
produced printed material, such
as the example in Figure 6-2.
CMYK is a subtractive color
mode — that is, the less of each component color you have, the closer
you are to white.

Figure 6-2: You typically use CMYK images for
bulk-print materials.

1 Grayscale: When most people talk about a black-and-white photo, they
really mean grayscale. The image does contain black and white but also
a wide range of grays in between. You might use grayscale mode for
Web-based images or for prints. Keep in mind that unless your inkjet
printer is designed to reproduce grayscale images with black and gray
inks (or black and light-black inks), you probably won’t be happy with
grayscale output. Using just one black ink doesn’t reproduce the full
range of grays in the image. Using the color inks adds a tint to the image.
You do have an alternative for grayscale images: Send them to the local
photo lab for printing.

1~ Indexed Color: Using a color table, or a list of up to 256 specific colors,
Indexed Color mode is for the Web. You save GIF and perhaps PNG-8
images in Indexed Color, but only those file formats require such a limited
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number of colors. Things like buttons on your Web page, which need only
a couple of colors, should be created as GIFs using Indexed Color mode.
That keeps the file size down, reducing the amount of space the image
requires on your Web server and also speeding the download time (how
long it takes for the image to appear on your site-visitor’s monitor).

1~ Lab: Also known as L*a*b and CIELAB (and pronounced either lab, as
the dog or a research facility, or verbally spelled out, as el-ay-be), this is
a color mode that you might use when producing certain special effects
or using certain techniques in Photoshop, but it’s not one in which you’ll
save your final artwork. The three channels in a (or “an”) Lab image are

e Lightness, which records the brightness of each pixel
¢ a, which records the color of the pixel on a green-to-red axis
¢ b, which records each pixel’s color value on a blue-to-yellow axis

You shouldn’t print Lab images on an inkjet or post them on your Web
site. You might see (not in this book!) a tip that you should convert your
RGB or CMYK images to Lab mode before using one of Photoshop’s
Sharpen filters. Bah! Apply the Unsharp Mask filter, choose Edit=>Fade
Unsharp Mask, and change the blending mode from Normal to Luminosity.
Same result, less work, and less potential for degradation of your image.

* Duotone: Duotone (including tritone and quadtone) is a very specialized
color mode, exclusively for commercial printing, that uses only two (or
three or four) inks spread throughout your image. Although that might
sound good for an inkjet printer, in fact, Duotone is not an acceptable
color mode for inkjets. Duotone images require that specific premixed
inks are poured into the presses, which isn’t something that you can do
to your inkjet.

1 Multichannel: Like Duotone, the Multichannel color mode is restricted
to commercial printing because it depends on specific premixed colors
of ink that are applied to the paper. Unlike Duotone, in which the inks
are generally spread across the page, Multichannel images use certain
inks in certain areas. You might need Multichannel mode when creating
a logo for a client.

1~ Bitmap: Bitmap color mode is
true black and white (as you see
in Figure 6-3). Each pixel is
either black or white. The place-
ment of the black and white
pixels produces shading, but
the image doesn’t really have
any gray pixels. You might use
Bitmap mode to create images
for some wireless devices, use
on the Web, or commercial

print, but that’s about it. Figure 6-3: Bitmap images contain only black
and white pixels; no grays, no colors.
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Converting between color modes or gamuts (done with the Imager®Mode
menu) can reduce the quality of your image by compressing different colors
into a single color value. You would not, for example, want to convert from
RGB (which has a comparatively large number of colors available) to CMYK
(with a more restricted color gamut) and then back to RGB. After colors are
compressed by a conversion, you can’t restore their original values by con-
verting back to a wider gamut.

Does a color model make a difference?

Although the image itself has a single
*E  Grayscale Slider

color mode, you can use any of the & s———
available color models when defining 1l ¢ s = HSB Sliders

i - D pem— Iy CMYK Sliders
a color in Photoshop. Say, for exam £y e

ple, that you're preparing to use the — M s . Color Sliders
Brush tool to paint some artistic ele-
ments for your latest project. The

Copy Color as HTML

project is in RGB mode because * EE:,?;:L::,,,
you'll be printing it with your inkjet Grayscale Ramp
printer. You can use the Color palette b haraiassichd

to define your foreground color any Make Ramp Web Safe

way you please — RGB, CMYK,
Grayscale, Lab, or even HSB (hue/
saturation/brightness, which isn’t
available as a color mode, just a
color model). It doesn’t matter how
you set up the Color palette, which you do through the palette’s menu, as
shown in Figure 6-4. When you add the color to your image, Photoshop uses
the nearest RGB (or CMYK) equivalent.

Figure 6-4: Choose your preferred color model
from the Color palette menu.

Notice that the Color palette menu in Figure 6-4 doesn’t list Duotone or
Multichannel. Those are color modes only, not color models. A couple of
other things to note about working with the Color palette: The warning trian-
gle visible in Figure 6-4 in the lower-left corner of the palette indicates that
the selected color is outside the CMYK color gamut. (Clicking the swatch to
the right would select the nearest equivalent color. If, that is, you were actu-
ally working in CMYK mode.) Also note that the background swatch is
selected in the palette, highlighted with a black outline — click the fore-
ground swatch to make changes to the foreground color.

Why should you worry about color depth?

Color depth is the actual number of different colors that you have available.
(Remember that each pixel can be only one color at any time.) When you
work in 8-bit/channel color, simply called 8-bit color, each of the component
colors is recorded with exactly 8 bits of information in the computer file.
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(At the beginning of this chapter, | mention digits. These are the actual
numbers — the zeros and ones recorded on the hard drive to track each pixel’s
color.) In an 8-bit RGB image, each pixel’s color is recorded with three strings of
eight characters. When you work with 16-bit/channel, or 16-bit color, each of the
component colors is recorded with 16 characters. The larger numbers mean
more possible ways to record each color, which means more possible varia-
tions of color, as well as files that take up more space on your hard drive.

What that means to you, in practical terms, is possibly a better-looking image
when working in 16-bit color. You’ll have smoother transitions between
colors throughout your image, no banding in gradients (those annoying areas
in a gradient where you can actually see one color stop and the next color
start), and no splotchy shadows. Posterization, which I explain in Chapter 5,
is the degradation of your image’s appearance when similar colors are forced
to the same color, making transitions between colors more abrupt. Many
tonal and color corrections that produce posterization in your 8-bit images
won’t harm a 16-bit image in the least. Take a look at Figure 6-5. To the left, a
Levels adjustment is increasing a 16-bit image’s tonal range. When the same
adjustment is applied to an 8-bit version of the image, some rather substan-
tial posterization becomes visible in the Histogram palette (represented by
the gaps in the black postadjustment histogram).

1
11}

1
11}

Histogram Histogram

Channel: | RGB = . Channal: ' RGB |- 5

Source:  Entire Image = Source:  Entire Image

Figure 6-5: Compare the Histogram palettes to see posterization (right).

So, should you use 16-bit color all the time? No. You can’t post a 16-bit image
on the Web, and 16-bit color is rarely used for CMYK images. Digital photos
taken in JPEG format are 8-bit because that file format doesn’t support 16-bit
color. And with most inkjet printers, you won’t see any improvement in the
final print. You might, however, see a dramatic increase in printing time
because there’s twice as much image data to process.

If you shoot in 16-bit color, whether TIFF or Raw, it makes sense to process the
image in 16-bit color. When the image is perfect, you might want to convert a
copy of the file to 8bit color for printing (Image->Moder>8-Bits/Channel). You
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might find some situations in which you’ll convert an 8-bit image to 16-bit.
Switching from 8-bit to 16-bit doesn’t help you avoid posterization, but it might
reduce banding if you add a sizable gradient.

One other note on color depth: Photoshop can work with 32-bit/channel
images. These monstrous files are called high dynamic range (HDR) images
and are typically constructed by combining different exposures of the same
photo. In Photoshop, you can work with a pair of exposures in the Merge to
HDR feature (presented in Chapter 10). You probably will never be called
upon to create an HDR image for any of the esoteric 3D or video programs
that use them, but you might find some benefit in combining multiple expo-
sures of a difficult shot. Afterward, so that you have a file of reasonable size
and access to more of Photoshop’s features, use the Imager>Mode menu to
convert to 16-bit color or even 8-bit color.

Recording color in your image

All your image’s color data is saved in the Channels palette. When you’re
working with RGB or CMYK images, each color channel holds information for
one of the component colors (red/green/blue or cyan/magenta/yellow/black).
Each channel is a grayscale version of the image as a whole, using shades of
gray, from white to black, to indicate where that channel’s color appears (and
how strongly) in the image. In RGB images, the lighter the pixel in a channel,
the more of that color. When you work with a CMYK image, the light-dark in a
channel is reversed, with darker areas showing where more of that color is
applied.

Color Adjustments in Photoshop

Sometimes you have an image that needs some help in the color department.
It might have been shot with an incorrect camera setting, it might have a
color cast (an unwanted tint of a specific color), or it might just be dull and
dingy. Photoshop provides you with an incredible array of commands and
tools to make the colors in your images look just right. You’ll hear the term
color correction being tossed about, but not all images have incorrect color.
Some have very good color that can be great color. Instead of color correction,
I like to think in terms of color improvement. And just about every image can
use a little tweaking to improve its color.

How do you know when the color is right? Your primary tool for the job is in
your head. Literally. Make your decisions based primarily on what your eyes
tell you. Sure, you can check the Info palette and the Histogram palette to
make sure that your shadows are black and your highlights are white, but
adjust your images until they look good to you — until you’re satisfied with
the color.
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“Here, Spot!” What is a spot color?

Spot colors in your image are printed by using
premixed inks of exactly that color. (I'm talking
commercial printing press here, not your run-of-
the-mill inkjet printer.) To properly prepare a spot
color for press, it needs to be in its own spot
channel, which is a separate color channel in
which you show where and how the ink will be
applied. (Channels in your image are eventually
used to create the actual printing plates that pick
up ink and put it on paper.) Because spot chan-
nels are used with CMYK images, dark repre-
sents more. Where you need the spot color at
100% strength, paint directly in the spot channel
with black. In areas where you want only a light
tint of the spot color, use a light gray.

You create your spot channel by selecting the
Spot Channel command from the Channels
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palette menu. Click the color swatch in the New
Spot Channel dialog box to open the color
libraries. (If you see the regular Color Picker,
click the Color Libraries button.) Select the
appropriate book (collection of colors; see the
figure here) for your project; then select your
color. Click OK in the New Spot Channel dialog
box to accept the color, do not change the name
of the spot channel, and then click OK. You can
now paint or copy/paste into that new channel.

When saving images with spot channels, you
can use the PSD file format (if the image will be
placed into an InDesign document), PDF, TIFF, or
DCS 2.0. Check with the person handling the
layout or the print shop to see which is required.
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That little bomb symbol to the left of this paragraph is a little scary, but it does
get your attention, doesn’t it? This isn’t a your-computer-will-blow-up sort of

warning but more of a you-don’t-want-to-waste-your-time-and-effort warning.
Do your tonal adjustments before you start working with the image’s colors.
Go through the procedures in Chapter 5 first and then use the techniques

here. Why? If you get perfect hue and saturation and then start making tonal
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adjustments, you're likely to knock your colors out of whack again. And, of
course, there’s also the possibility that adjusting your image’s tonality will
make the colors look perfect!

Watching the Histogram and Info palettes

As you work with your various color adjustments in Photoshop, a couple of
palettes can help you track the changes you're making. The Info and Histogram
palettes are, by default, nested in the upper-right corner of your screen. (You
can also show or hide them through Photoshop’s Window menu.) You might
want to drag one or the other out of the nested set so that both are visible at the
same time. (Click the palette’s tab and drag it away.) Keeping an eye on your
Info and Histogram palettes while you're dragging sliders and entering num-
bers into various fields can help you spot potential problems as they develop.

The Histogram is useful for tracking changes in the distribution of pixels

at various tonal ranges. You can read more about it in Chapter 5. The Info
palette, while you've got an adjustment dialog box open, shows you “before”
and “after” color values. Wherever you move the cursor in the image window
(it will appear as the Eyedropper tool), the Info palette shows you the result of
the adjustment — the consequences of your action, so to speak. You can also
hold down the Shift key to change to the Color Sampler tool. Clicking in the
image with the Color Sampler adds up to four markers in the image. The color
values under those markers appear in the Info palette and, like the cursor loca-
tion, show before/after values as you're making changes (see Figure 6-6).
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Figure 6-6: Each of the crosshairs in the image is tracked in the Info palette.
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Choosing color-adjustment commands
Photoshop offers over a dozen differ- g

ent commands that you can use to Mode v

improve the appearance of your | Adjustments - _» [EERTSS xL
images, all of which are easily Dipicne... :::";:‘;':m oy
accessed through the Image=> 2‘:.‘2':.1?;‘.?5 Auto Callor X8
Adjustments menu (as you see in o i T ob
Figure 6-7). Some have specialized s SN Bighomsicomest
purposes, and some are extremely Pixel Aspect Ratlo. ' pocy g white... OB
versatile, but all are worth under- e " :"’“‘T‘"” " :ﬂ
standing so that you choose the Trim... Banc Color.. =
most appropriate feature for the v mpe g
problem staring at you from the Channel Mixer...
screen. Most (but not all) of the by
commands that I discuss here can Shadow/Highlight...

be added to your images as an oot
adjustment layer, which gives you st Ll
added flexibility. (Adjustment Threshold...

layers are discussed in detail in P

Chapter 8) Variations....

Levels Figure 6-7: Photoshop's flexibility is truly

The Levels adjustment, which is dis- evidentin the Image=>Adjustments menu.
cussed in detail in Chapter 5, uses

three slider controls to individually adjust the shadows, highlights, and
overall tonality of your image. It’s generally used to control the brightness/
darkness of the image by making changes to the RGB (or CMYK) channel,
but it can be used for color correction by adjusting the color channels
individually.

Auto Levels/Auto Contrast/Auto Color

The three “auto” adjustments are one-click solutions to many image prob-
lems. Auto Color, the most powerful of the three, is perhaps the simplest
way to improve both color and fonality (the darkness of the shadows and
the brightness of the highlights). Select the command, and Photoshop auto-
matically finds the lightest and darkest pixels in the image. Then, on a
channel-by-channel basis, it redistributes the values of the remaining pixels.
For more information on Auto Color and the related Auto Contrast and Auto
Levels commands, take a look at Chapter 5.
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Curves

The Curves command is also dis-
cussed at length in Chapter 5.
However, for color correction (rather
than tonal adjustment), you want to
work on each channel individually,
choosing each in turn from the
pop-up menu at the top of the Curves
dialog box (see Figure 6-8).

Although working on each channel
with Curves can be very effective, it
can also be rather time-consuming,
with lots of flipping back and forth
among the channels as one adjust-
ment makes another channel correc-
tion look like a bad decision. While it
may be inconvenient, Curves is a
very powerful color-correction tool.

Note, in Figure 6-8, the Preset pop-up
menu at the top of the Curves dialog
box. In that menu you’ll find some
ready-made Curves adjustments
that — if they don’t solve the prob-
lem immediately — give you some
pretty good starting points. In addi-
tion to color-correction presets such
as Darker, Lighter, Increase Contrast,
and Strong Contrast, you’ll find spe-
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Figure 6-8: Correct each channel individually
with Curves to adjust color in your image.

cial effects like Cross Process (developing film in the wrong chemicals —
intentionally) and Color Negative (which, unfortunately, creates the appear-
ance of a scanned negative rather than removing the orange from an actual

scanned negative).

Color Balance

The Color Balance command (as shown in Figure 6-9) presents you with three

sliders that you use to make changes to the balance between your color
opposites. If the image is too blue, you drag the third slider away from Blue
and toward Yellow. (And this is a great way to remember which colors are

opposite pairs!)
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Color Balance
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Figure 6-9: Color Balance gives you direct control over opposites.

You can control the highlights, midtones, and shadows of your image individ-
ually by using radio buttons at the bottom of the Color Balance dialog box.
And, in almost all cases, you’ll want to leave the Preserve Luminosity check
box marked so that the brightness of the individual pixels is retained.

You can also use Color Balance to throw an image out of whack for special
effects or (getting back to the adjustment’s roots) compensating for a color
cast being introduced by the printing device.

Brightness/Contrast

The Brightness/Contrast adjustment works with the tonality of an image rather
than color. While making adjustments to the tonal range may improve the over-
all appearance of your photo, don’t rely on this feature for color adjustment.
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Black & White

New in Photoshop CS3, the Black &
White adjustment creates outstanding
grayscale copies of your color images.
This new feature provides even more
control than using Channel Mixer with
the Monochrome box checked. As
you can see in Figure 6-10, you can
control the amount of each major
range of color used to create the
grayscale copy. In this particular
example, the original consists primar-
ily of greens and browns, so the top
three sliders are key. Reducing Red
and increasing Yellow both lighten
the browns and greens and increase
contrast among the brown tones.

Note the Tint check box near the
bottom of the dialog box. With Tint
selected, you can easily create sepia or
Duotone looks for your images. If you’ll S EEEEE__————=
be printing on an inkjet printer (rather

than sending the file to your photo Stack and White

lab), be sure to use a Black & White Preset; { Custom o —ok—)
adjustment layer rather than the menu Reds g ol Canal
command. Your inkjet printer may o Aso
introduce an unwanted color shift. If e — 10 1% o e

s0, you can reopen the adjustment Geeens m 125 |x
layer and work with the Hue and -

Saturation sliders to compensate. e —T
Blues H X %
Hue/Saturation e "

Often overlooked and rarely exploited
to the fullest, Hue/Saturation is a very
powerful tool. Using the three sliders -
together, you can adjust the hue to
eliminate a color cast, increase satu-
ration so that your colors appear
richer and more vibrant, and adjust
lightness to improve your image’s
tonality. (See Figure 6-11.) Keep

in mind that when you adjust some-
thing that’s very dark, start with the
Lightness slider so that you can evaluate the other changes (Hue and
Saturation) properly. Remember, too, that you can apply Hue/Saturation (like a

_ Tint

Figure 6-10: Black & White enables you to
determine grayscale tones by mixing color
values.
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number of other adjustments) to a specific range of colors in the image,
selected in the pop-up menu at the top of the dialog box.

Hue/Saturation
&l

[T

= - Colonize
SIS Sprevaw

Figure 6-11: Hue/Saturation can cure three problems at once.

Desaturate

The Photoshop Desaturate command creates a grayscale representation of a
color image without changing the color mode. However, with no dialog box or
adjustments, it doesn’t offer the control you get by using Black & White.

Match Color

Now this is a feature to savor! There you are, adding Cousin Joe to the family
reunion photo because he wasn’t bailed out in time, and you see that the
lighting is all kinds of different and he sticks out like a sore thumb (or bum).
Or you return from a major shoot only to find that something wasn’t set cor-
rectly in the camera, and all your images have a nasty color cast.

Match Color lets you adjust one image to another (and you can even use selec-
tions to identify areas to adjust or areas of the images to use as the basis for
adjustment), but keep in mind that you get better results with images that are
already rather similar. You can also fix one shot and use that shot as a standard
by which others are corrected. (Like most image adjustments, you can record a
change in an Action and use Photoshop’s Batch command to apply that adjust-
ment to a series of images. Read more about Actions in Chapter 16.) Take a
look at Figure 6-12 to see the Match Color dialog box.
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Figure 6-12: The targetimage’s original colors are visible in the small window to the
upper right.

Because the Match Color dialog box is such a powerful tool, it’s worth taking
at look at what’s going on there:

1~ Ignore Selection when Applying Adjustment: If you have an active
selection in the target layer or image (for calculating the adjustment, see
the upcoming bullet on that) and you want the adjustment to be applied
to the entire target, select this check box. If the box is left clear, the
adjustment is applied only within the selection. Note that you can use
selections to apply Match Color to only a portion of your image, such as
flesh tones, or you can adjust sections of the image one at a time.

1 Luminance: After the preview shows in your image window, you can
tone down or brighten up the target area with the Luminance slider.

1~ Color Intensity: Think of this slider as a saturation adjustment.
1~ Fade: Using Fade lets you blend the adjustment, reducing its intensity.

1~ Neutralize: If a color cast is introduced by the adjustment, selecting
the Neutralize check box might eliminate it.
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1~ Use Selection in Source to Calculate Colors: You can make a selection
in the image to which you're trying to match (the source) and use the
colors within that selection as the basis for the Match Color calculation.

1~ Use Selection in Target to Calculate Adjustment: You can make another
selection in the target layer or image that presents Match Color with a
sample of those pixels to use for calculating the adjustment.

1~ Source: The Source pop-up menu lists all the open images that can be
used as a basis for adjustment. Only images of the same color mode and
color depth get listed. Think of source as the image whose colors you're
trying to match. (The selected image or the active layer within an image
is what you're adjusting.)

~ Layer: When a multilayer image is selected in the Source pop-up menu,
you can designate which layer (or a merged copy of the layers) is the
actual source.

1 Load Statistics/Save Statistics: If you're doing a series of images and you
want to speed things up, click the Save Statistics button to record the
adjustment you're making and then use the Load Statistics button with
other images.

In Figure 6-12, an area of water is selected in the target image and a compara-
ble area of water is selected in the source image. (The selection in the source
image is visible in Figure 6-12 for illustrative purposes only — a selection in
an inactive image window isn’t normally visible.) With the two selections, |
tell Match Color to adjust the target image based on the difference between
the water color in the two images. Using selections prevents any skewing of
the adjustment that would be caused by the colors in the sail (source image)
and the trees (target image). But with the Ignore Selection when Applying
Adjustment check box enabled as well, I make sure the entire target image is
adjusted, not just the areas within the selection.

Replace Color

Sort of a cross between the Select=>Color Range command (see Chapter 8)
and the Hue/Saturation adjustment, Replace Color is a great tool for swap-
ping out one color for another. It’s truly great in a production environment
where, for example, a certain blouse is available in several colors. Shoot one
color and then use Replace Color to produce the additional product shots.

The Replace Color dialog box, as shown in Figure 6-13, has two separate
parts: Selection and Replacement. Click with the left eyedropper in either the
preview area or in the image windows and adjust the Fuzziness slider (how
much variation counts as “selected”) to make your initial selection. Use the
middle eyedropper to add colors or shades of your initial color, and use the
right eyedropper to subtract from the selection. Choose only variations of
one color. Then drag those Hue, Saturation, and Lightness sliders in the
Replacement section of the dialog box to produce your new look.
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Replace Color
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Figure 6-13: Make a selection and change the selection’s hue, saturation, and lightness.

<® Rather than switching eyedroppers back and forth, use the left eyedropper
and the Shift key (to add) or the Option/Alt key (to subtract). You can also
hold down the Shift key and drag through an area to select all the colors in
the area. If you accidentally select some colors you don’t want, release the
Shift key and click once to start over.

Selective Color

Although designed to help you compensate for the vagaries of printing
presses, Selective Color can do other great things for you! The command’s
dialog box, shown in Figure 6-14, has a pop-up menu that offers the six basic
colors of Photoshop, as well as Whites, Neutrals, and Blacks. You select
which range of colors to adjust and then drag the sliders. You can work on
one set of colors, switch to another and make adjustments, switch to another,
and so on without having to click OK in between. For example, you can adjust
the reds in the image and leave the blues untouched, or you can adjust the
reds and then tweak the blues without having to exit the dialog box.
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Figure 6-14: Tweaking the Neutrals can adjust the overall appearance of an image.

When you have reasonably small adjustments to make, select the Relative
radio button at the bottom. If you have substantial changes — rather radical
alterations — select the Absolute radio button.

Channel Mixer

Designed to repair a defective channel in an image, Channel Mixer lets you
use sliders to replace some or all of the intensity of one color channel with
content from the others. Should you come across an image with damage in
one channel, you can certainly use the Channel Mixer adjustment to work on
it (with some degree of success). You reduce the value of the target channel
by dragging the slider to the left. You then drag one or both of the other slid-
ers toward the right. Generally speaking, you want to add an amount (com-
bined between the two other channels) just about equal to what you subtract
from the target channel.

If you drag a slider to the left past 0 (zero), you invert the content of the
channel. You can produce some incredible (and incredibly weird) effects
with this technique, partially inverting one or two channels. When you get a
chance, give it a try. Using the Monochrome check box in Channel Mixer
gives you an alternative to Black & White for a controlled grayscale effect.

Gradient Map

More creative than corrective, the Gradient Map feature re-creates your
image by using a gradient. The leftmost color stop (the anchor points where
a gradient color is assigned) in the gradient is mapped to the shadows, the
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rightmost to the highlights, and any color stops in between are appropriately
assigned to the rest of the tonal range. In Figure 6-15, you can see how a two-
color gradient (upper left) lacks detail compared with the four-color gradient
being created for the lower image.
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Figure 6-15: Using more colors in your gradient produces more detail.

Generally speaking, you use darker colors for the color stops on the left
and lighter colors for the color stops on the right (although you can create
extremely interesting effects by mixing things up). Using a black-to-white
gradient produces a grayscale image.

To edit the gradient, simply click directly on the sample gradient in the
Gradient Map dialog box. Click to add color stops, drag to move color stops,
and click the color swatch near the bottom to change the color of the selected
stop. (You can find more detailed information on creating and working with
gradients in Chapter 14.)
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Photo Filter

The Photoshop Photo Filter is actually an image adjustment rather than a
filter. The filter in the name refers to those actual photographic filters that
you screw onto the end of a lens. This adjustment is a great way to correct
problems with temperature in an image — that perceived warmth or coldness
of an image. When the camera takes a picture under unexpected lighting con-
ditions, a color problem is apparent. (Say, for example, that the camera is set
to Daylight when shooting indoors.) When an image is too blue, it’s too cool;
conversely, an image that’s orangey is too warm. (Remember that these are
the perceptual evaluations — blue light is technically hotter than yellow or
red light.)

In Photo Filter, you select a preset filter from a pop-up menu or select a color
of your choice. As you can see in Figure 6-16, both preset filters and custom
colors can be effective in neutralizing a color cast. (You could, of course, also
use these filters to add a color cast . . . if you wanted to, that is.)

Photo Filter Photo Filter

‘oo o =
@ Filmer Warming Filer (81) 781
il TR nietlinl Lok Cancel
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—_ A
o Preverve Lummosity  Preserve Lunvnosioy

Figure 6-16: Neutralize a color cast with a filter of the opposite color in Photo Filter.
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Shadow/Highlight

The Shadow/Highlight adjustment is discussed at length in Chapter 5 as a
tonal-correction tool, the job for which it was designed. However, keep in
mind that the Shadow/Highlight dialog box also includes the Color Correction
slider. After you lighten shadows or tone down highlights, you can increase
or decrease the saturation of the colors in the adjusted areas of your image
with the Color Correction slider.

Exposure

The Exposure adjustment, discussed in Chapter 5, is a tonal adjustment that
simulates a change in the camera’s exposure setting when taking a photo.

Invert

Again, more creative than corrective, the Invert command (no dialog box)
simply reverses the colors in your image or the selected area. Although
inverting areas of an image (like desaturating) can draw attention to the sub-
ject of the image, it’s an edgier technique and generally requires touch-up
after inverting. You'll find that any specular highlight — a pure-white area
(mainly reflections) — becomes a distracting black spot.

Equalize

When you select the Equalize adjustment, Photoshop finds the darkest
pixel in the image and maps it to black, maps the lightest pixel to white, and
distributes the rest of the tonal values between. You can pretty much skip
Equalize — use Auto Color instead.

Threshold

Threshold converts each pixel to either black or white (no colors, no grays).
You adjust the border between black and white with a slider or by entering a
value in the Threshold Level box. For an eye-catching special effect, open a
color image and make a selection of the background (or the subject!) and
apply Threshold, mixing color and black and white.

Sometimes, when adjusting color in an image, you need to find the darkest
and lightest pixels in an image (for use with the eyedroppers in the Curves
dialog box, for example). Open Threshold, drag the slider all the way to the
left, then slowly back to the right. The first black spot you see is the darkest
in the image. Add a color sampler (so you can find the spot again) by
Shift+clicking in the image. Drag the slider all the way to the right and then
slowly back to the left to find and mark the lightest pixels. After placing your
color samplers, click Cancel.
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Posterize

The Posterize command forces your
image’s broad range of colors into a
few selected colors (as shown in
Figure 6-17). You automatically get
black and white, and then a limited
number of additional colors, based
on the content of the original. You
pick the number of colors that you
want to use, and Photoshop picks
which colors to use. You can use as
few as two colors (plus black and
white) or as many as 255, which
pretty much gives you your original
image. Posterize can create a rather
pleasing rendering of a photo with
very few colors.

QWP When experimenting with Posterize,
click in the Levels field and use
the up- and down-arrow keys to
preview different numbers of colors.
Start low and work your way up.
If you see something that you like,
you can stop or you can keep going
and come back to that number
later — the image will look exactly
the same when you try that number
again.

Working with Variations

The Variations feature, which you
find in the Image=>Adjustments

menu, is a semi-automated way to
make color and tonal adjustments Levels:[s | € 0k )
to your images. You open the ————
image, open Variations, and then
click which version looks better. ™ Preview
(See Figure 6-18.)

Posterize

( Cancel )
=

Figure 6-17: Reduce colors with Posterize for a
special effect.
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Figure 6-18: You use Variations to click your way to a perfect picture.

Much like getting new eyeglasses, using Variations is a matter of “Which
looks better, this or this?” When you click one of the images, it moves to the
Current Pick position, and a new set of variations is automatically generated.
The blue areas that you see in some of the options in Figure 6-18 indicate
areas where colors will be clipped — forced into black in the shadows or to
white in the highlights — which results in a loss of detail in the image. You
can disable that feature by clearing the Show Clipping check box in the upper
right. Also note that you can adjust the shadows, midtones, and highlights
independently, and you can also control (to some degree) the amount of vari-
ation from sample to sample.

Start with the Fine/Coarse slider set somewhere in the middle and get reason-
ably close to a great image, correcting midtones, shadows, highlights, and
then saturation. Now drag that slider to the Fine setting and zero in on a per-
fect image.

127
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Manual corrections in individual channels

Sometimes different areas of an image require different corrections or adjust-
ments. You can, for example, “paint” corrections into specific areas of a
channel by using the toning tools in Photoshop’s Toolbox. The image in
Figure 6-19 has a distinct problem (okay, well, maybe a few problems). In

the lower left is a light-green blob that needs to be eliminated if there’s any
chance of salvaging this photo. By using the Burn tool on one channel at a
time, you can darken that specific area of each channel — each channel
according to its needs.

On the left, you can see the distinct light area in the thumbnail of each chan-
nel. On the right, after using the Burn tool, those lighter areas are gone,

and so is the, the . . . what could it have been? Was it perhaps swamp gas?
Ectoplasm? A UFO? Anyway, it’s gone now, and the tabloids won’t pay mil-
lions of dollars for the photo.
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Figure 6-19: The problem is only in one area of each channel, but you can fix it manually.
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In addition to the Burn tool, you can use the Dodge, Blur, Sharpen, and
Smudge tools. You can use the Brush tool and paint with black, white, or
gray. You can use Levels or Curves on an individual channel or even a selec-
tion within one or more channels. When fine-tuning (or salvaging) an image,
don’t be afraid to work in one channel at a time, perfecting that channel’s
contribution to the overall image.

Take another look at the two Channels palettes shown in Figure 6-19. Obviously
that’s a composite image because there’s only one Channels palette in Photo-
shop, right? On the right, the Green channel is active (you can tell because
it’s highlighted), and only the Green channel is visible (only it shows the eye-
ball icon to the left). The other channels are invisible, and you see only the
grayscale representation from the Green channel in the image window. On the
left, however, only the Red channel is active, but all the channels are visible.
Any change I make to that image in that state is applied only to the Red chan-
nel. But because all channels are visible, I can see the overall impact on my
image.

Sometimes you want only one channel visible, such as when you’re trying to
balance the tonal range throughout the channel, for example. But most of the
time, you want to see what’s going on in the image as a whole. Click the one
channel (or Shift+click two channels) in which you need to work. Then click
in the left column next to the composite channel at the top to make all chan-
nels visible.

The People Factor: Flesh Tone Formulas

One of the toughest and yet most important jobs in Photoshop is making sure
that skin looks right. People come in a wide variety of colors and shades and
tints, and all people vary in color in different places on their bodies and at
different times of the year. (The top and bottom of your forearm are likely dif-
ferent colors, and the difference is generally much greater in summer than in
winter.) There are even some exceptions to those broad generalities. Making
skin tones look great is often a major, yet often critical, challenge.

When you have skin in your image, it’s generally part of the focus of the
image — the person whom you’re photographing. And even when a person
isn’t the subject of the image, skin attracts attention in the image. The

eye naturally goes to people in just about any image (perhaps not first, but
eventually).

You'll also find that unnatural variations in skin color are very noticeable.
Consider how often you think to yourself that someone looks a little pale, or
flushed, or sunburned, or tanned, or just plain sick. You're making that judg-
ment call based to a large degree on the appearance of the skin.

129
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Keeping in mind that the numbers shown in Figure 6-20 are general guidelines
and that real people vary quite a bit, I've prepared for you some target values
for skin tones. Use these formulas loosely when using the techniques in this
chapter to adjust the color in your images, keeping in mind the individual
you photographed and the lighting at the time.

Flesh Tone Formulas

Pale Caucasian  Dark Caucasian Afro-American Asian

Highlights| ¢4 - M:17 - Y:15-K0 | C11-M35-Y:42-K0 | C5-M:14-Y:22-K0 | C3-M:11-Y:13-K0

Midtones| C14-M35-Y:35-K0 | C14-M:38-Y:49-K:0 C:23-M:50-Y:63-K5 | C12-M:35-Y:42-K0

Figure 6-20: These are guidelines only, not absolute values!

Note that the numbers are CMYK, even for use with RGB images. Open the
Info palette menu, choose Palette Options, and set the Second Color Readout
to CMYK. Remember, too, that you can use the Color Sampler tool to add
placeholders in the image, monitoring the changes that you're making in the
Info palette. Set the color sampler readings to CMYK in the Info palette itself
by clicking the eyedropper symbol to the left of the color mode listed for
each sampler.

Promise me that you’ll keep in mind that these numbers are for reference
only? Your individual image determines what the correct adjustment should
be. You can use these numbers as a starting point, but trust your eyes and
evaluate your image as you work.



The Adobe Camera Raw Plug-In

In This Chapter

Taking advantage of the Raw file format

Evaluating your Raw capabilities

Using the Camera Raw plug-in

Understanding the Raw Facts

Flere was a time, not so long ago in people years (but a couple of genera-
tions ago in computer years), when capturing digital photos in the Raw
file format required you to spend tens of thousands of dollars. The wonderful
thing about the Raw file format is that you use it to record images to save
unprocessed image data, which gives you incredible control over the final
appearance of your image. These days, however, cameras that cost only a few
hundred dollars can capture images “in the Raw.” If you don’t have a Raw-
capable camera now, after reading this chapter, you might decide that you
need to have Raw capability.

In this chapter, I explain how Raw differs from other image
file formats and why those differences can be important.
I show you how to determine whether you have what
you need to capture in Raw and whether Photoshop
CS3’s Adobe Camera Raw 4 plug-in is capable of han-
dling your camera’s image files. Most of the rest of
the chapter looks at the Camera Raw interface and
what all those sliders do for you and your image.

The Raw file format at its heart is nothing but unprocessed
image data. It comes in a number of variations — one or sev-
eral for each camera manufacturer, it seems. Each has its own file
extension (such as .crw, .cr2, or .nef), and many have their own special
features that are totally incompatible with each other. And those camera
manufacturers love to tinker with their proprietary formats, changing them
regularly. But each of the formats, at the basic level, is Raw. (Check your
camera’s User Guide to see whether it’s capable of recording image data in a
format other than JPEG or TIFF. If so, it’s probably a variation of Raw.)
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The DNG file format

In late 2004, Adobe Systems, Inc., announced a new open standard (anybody can use it without
licensing fees) for Raw photos. The DNG, or digital negative, file format adheres to the basic Raw

formulation but does allow for growth. The aim is to
ensure that years from now, you'll still be able to
open and process the images you shot yesterday.
(Unfortunately, changes in camera-specific versions
of Raw already make some early Raw photos inac-
cessible by today's software — and that's just the tip
of the iceberg!) Adobe promises to continue sup-
port for backward-compatible DNG file processing
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that you keep the original Raw files, justin case.)

Thankfully, Adobe updates the Camera Raw plug-in for Photoshop (as shown
in Figure 7-1) on a regular basis, adding the capability to work with the newest
cameras shortly after they’re available. (Plug-ins, like Camera Raw and most
of Photoshop’s filters, extend the program’s capabilities. Updating your
plug-ins regularly ensures you have the greatest capabilities.) Be warned,
however, that purchasing a new camera model the day it comes on the market
might mean using the camera’s own software for a while until Camera Raw is
updated.

What's the big deal about Raw?

Cameras that record images using the Raw format save unprocessed image
data. When recording as TIFF or JPEG, the camera manipulates the image data,
processing it in a variety of ways. So what’s the big deal with preprocessing —
Raw — image data? Assuming that you're as hungry for food as for knowledge,
I'll use a cooking analogy.

Say you purchase frozen lasagna and heat it up in your microwave oven.

It probably tastes good and fulfills your needs (“Food!”). However, the chef
who designed this prepared meal and the good folks who churn it out use a
specific recipe designed to appeal to a large number of people, hopefully
offending very few. When you reheat your lasagna in the microwave, you have




Chapter 7: The Adobe Camera Raw Plug-In ’33

some choices. For example, you decide how warm to make it (generally fol-
lowing the package’s reheating instructions). Or, you can add some salt and
pepper to season to taste, or perhaps dump on the hot sauce.

What you can’t do with that frozen lasagna is take out some of the salt or fat
in it from the recipe designed by the chef and prepared by the good folks.
You can’t substitute olive oil for butter. You can’t cut back on the garlic a bit
(just in case your date goes well). You're pretty much restricted by what the
original chef and his good folks prepared. Sure, you could pour a half-bottle
of blue food coloring over it, creating a special effect, but you're not likely
to turn that microwavable lasagna into a gourmet dinner. So if you're just
hungry and your demands aren’t too severe, no problem — shoot JPEG

(the digital photo equivalent of a microwave meal).

The gourmet dinner is what Raw is all about! If you consider yourself a
gourmet chef of the camera, creating art from virtually nothing, Raw is the
format for you. Avoid the limitations put on your image editing by prepro-
cessing and dive right in with the greatest flexibility. (And you don’t even
have to go down to the Farmers’ Market for fresh tomatoes.)
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Figure 7-1: The impressive Camera Raw window, explained fully in this chapter.
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Working in Raw

There’s one critical difference between working with Raw images and working
with JPEGs or TIFFs: You never actually make changes to the Raw file. Instead,
you record your adjustments in the image’s metadata (nonimage data
recorded with the image data) or in a sidecar file (a separate file in which
Photoshop records any information that can’t be recorded in the metadata).
Because adjustments are recorded separately rather than applied to the
images, the original image data remains unchanged, waiting for you to create
again and again, all from the same unprocessed, undegraded image data.

Sidecar files have the same name as the image file, but they use the . xmp file
extension. Keep each sidecar file in the same folder as the image with which
it is associated. If you move the image file without taking the sidecar file
along for the ride, the information stored in the sidecar file won’t be available
when you reopen the image file.

When capturing in Raw, you can basically ignore all the camera’s settings
other than aperture, shutter speed, ISO, and (of course) focus. Everything
else can be adjusted in the Camera Raw plug-in. However, because Raw
devotes significantly more resources to recording highlights than shadows,
it’s not a bad idea to concentrate on those highlights when shooting. When
the highlights are great to start with, you can reallocate some of the image’s
tonal range to the deprived shadows, thus reducing unwanted digital noise
and increasing detail.

Keep in mind that in addition to the Photoshop CS3 Camera Raw plug-in, you
also have available the software that came with your camera. (And you might
even have additional software packages available, such as Aperture from Apple
and Adobe Lightroom, depending on what camera make and model you use.)
Which package is best? As usual, “best” is a relative term. For example, Nikon’s
proprietary software does a great job with sharpness when processing .nef
files, but it lacks some of Camera Raw’s features. If sharpness is your overrid-
ing requirement, you might prefer the Nikon software. (Remember that your
Raw file can’t be processed by both the camera’s software and then by
Camera Raw, but you can process the data with either and then further

refine your image in Photoshop itself.)

Photoshop’s Save As dialog box offers you the option of the Photoshop Raw
file format. Photoshop Raw is not compatible with the Camera Raw plug-in
and does not provide you with the benefits of using the Raw format with
your digital camera. It is, however, necessary for certain high-end graphics
and animation programs into which someone, somewhere, sometimes places
images from Photoshop.
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Do You Have What It Takes?

To capture images in the Raw format requires only a camera that shoots Raw.
To work with those images in Photoshop, however, you need both a camera
and software that can process the Raw files. To work with images in the
Camera Raw plug-in, you need a camera on the supported cameras list for
Camera Raw — and, of course, Photoshop with Camera Raw. Adobe updates
the Camera Raw plug-in regularly to ensure compatibility with the latest cam-
eras as well as with the latest nit-picky changes that camera manufacturers
have made to their proprietary versions of Raw. Check for the latest Camera
Raw update and list of supported cameras here (and don’t forget to read the
installation instructions very carefully):

www . adobe . com/products/photoshop/cameraraw.html

Working with images in the Raw format requires one other thing that you
might not have: additional time. Opening the Camera Raw plug-in, making the
necessary adjustments to your image, and then transferring the image into
Photoshop all take time. Granted, making changes in Camera Raw eliminates
the need for many of the adjustments that you’d be making in Photoshop, but
working in Camera Raw could seem to be slower. (Actually, depending on
your system, Camera Raw might speed things up because tonal adjustment,
color correction, sharpening, and noise reduction are all in one place —
there’s no waiting for adjustments and filters to be applied and then for the
next dialog box to open.)

Camera Raw with JPEG and TIFF

New with Camera Raw 4 is the capability to
work with JPEG and TIFF in the Camera Raw
dialog box. Although not a substitute for shoot-
ing Raw (JPEG and TIFFimage data has already
been processed by the camera), it's a huge step
forward in terms of flexibility. When you do your
initial processing in Camera Raw, the adjust-
ments are recorded as instructions in the file
metadata rather than actually making changes
to the pixels in your image. You can later go
back and make changes to those adjustments —
the changes are applied to the original pixel data

fresh and clean rather than making changes to
changes.

To open a JPEG or TIFF File in Camera Raw,
choose File>0pen, select the file, and then at the
bottom of the Open dialog box, change the Format
pop-up menu (Mac) or the Files of Type menu
(Windows) from JPEG or TIFF to Camera Raw and
click the Open button. If you want to use Camera
Raw for JPEG files regularly, go to the Photoshop
Preferences>File Handling and select the option
Prefer Adobe Camera Raw for JPEG Files.
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Working in the Camera Raw Plug-In
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The cornerstone of Photoshop’s Raw capability is the Camera Raw plug-in.
Although you can open an image from Adobe Bridge, the file-management
program installed with Photoshop (see Chapter 4), directly into Photoshop,
doing so assumes that you want to use the adjustments already recorded in
the image’s metadata. After an image is open in Photoshop itself, you manipu-
late the pixels directly, rather than manipulating the metadata. When you
work in the Camera Raw plug-in, you never change the image itself, only the
adjustments recorded in the file’s metadata (or in a sidecar file).

As shown earlier in Figure 7-1, the Camera Raw window is filled with tools
and sliders. Even though you might not work with all the Camera Raw fea-
tures, here’s the lowdown on the features there.

Tools and preview options
In the upper-left corner of the Camera = — = —
Raw wirll)gow are several new tools B[ /e 4] 8| [=E[2]7]
at your command (as shown in

Figure 7-2). In addition to the Zoom, Figure 7-2: Camera Raw 4 introduces two new
Hand, White Balance, Color Sampler, tools for retouching and red eye removal.
Crop, and Straighten tools, Adobe

Camera Raw 4 adds a Retouch tool that combines the capabilities of the
Clone Stamp and the Healing Brush, a Red Eye Removal tool, and to the left of
the Rotate buttons, a button to open the Camera Raw Preferences.

The Zoom and Hand tools function as you would expect — they zoom in and
out and reposition a zoomed-in image in the window. Click with the White
Balance tool on something in the image that should be gray (not something
that is already gray, but that should be gray) to automatically adjust the
Temperature and Tint sliders. It’s a one-click way to neutralize any color cast
and correct the color balance. If you get an unexpected result, click elsewhere.
And, of course, afterward you can still tweak the Temperature and Tint sliders
as desired.

—

When you add color samplers e i T
(a maximum of nine) to the image —Q"UZ@ (B4l £]] | =][2]C]

preview area (click with the Color nelm | 28 e
Sampler tool), their values are dis- £.205 B 20l ——

played below the tools, as you see in

Figure 7-3. When you haven’t added Figure 7-3: Color samplers let you monitor
color samplers, that area is collapsed, color in specific locations of the image while
leaving more room for the preview you work.

area. Color samplers in Camera Raw

function the same as they do in Photoshop (see Chapter 6). Color samplers
are visible earlier in Figure 7-1 as numbered targets in the preview area,
strategically located in three locations on the blimp and one in the sky.
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You can use the Color Sampler tool to drag existing color samplers to new
locations or delete them by Option/Alt+clicking on the sampler. With any but
the Retouch and Red Eye Removal tools active, the Clear Samplers button
will delete all existing color samplers. Remember, too, that the position of the
cursor can function as an additional color sampler — the RGB values are
shown below the histogram.

Color samplers are great for making sure that you don’t blow out your highlights
(make them pure white) or clog your shadows (turn them pure black). Click with
the Color Sampler tool to add a color sampler to both a highlight area and a
shadow area, and then place your remaining color samplers in strategic areas.
(Ilike to place a color sampler in an area of the image that should be neutral,
preferably midgray, and a color sampler in the most critical area of the
image’s subject.)

Click and hold down the mouse
button to select an aspect ratio

R[] =2]e]

(relationship between width and Sl
height) for the Crop tool, as shown lto1l
in Figure 7-4. Drag the Crop tool to v2to3
create a bounding box, which will 3to4
automatically adjust to Landscape 4105
or Portrait orientation as you drag. i
You can then adjust the size of the Custom...
bounding box by dragging its anchor

. . Clear Crop
points. You can also rotate an image T

while cropping: Position the tool just

outside the bounding box and drag )

to rotate. If you drag the Straighten Figure 7-4:' The Crop tool can ensure perfect
tool along a line in the image that aspectratio.

should be horizontal or vertical, per-

haps the intersection of two walls or the horizon, a crop bounding box is cre-
ated with that alignment.

When you have the Crop tool’s bounding box just right and you've finished
adjusting the image’s appearance, click the Open or Done button. Should you
change your mind about cropping, click the Crop tool, hold down the mouse
button to show the menu, and select Clear Crop. Or you can eliminate the
bounding box by pressing Delete (Mac) or Backspace (Windows).

The new Retouch tool gives you the ability to make minor corrections right in
the Camera Raw dialog box. As shown in Figure 7-5, it offers capabilities simi-
lar to the Healing Brush and the Clone Stamp. However, the Retouch tool’s
behavior is quite different. To use the Retouch tool, follow these steps:

Chapter 7: The Adobe Camera Raw Plug-In 73 7
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1. Click the area you want to heal NIl e
or clone over.

2. Drag to expand the tool’s
diameter.

You can also set the diameter
using the Radius slider.

3. Position the source (green) and
destination (red) circles.

When you release the mouse
button after setting the tool’s
diameter, a pair of circles
appears. Click within the green )
circle and drag it over the ele- Figure 7-5: Camera Raw's Retouch tool offers
ment from which you want to both healing and cloning modes.

clone or heal. You can also drag

the red circle to fine-tune the location of the destination. You can click
the edge of either circle and drag to resize them both (or use the Radius

slider).

4. Repeat, accept, or clear. NE A Pl R
Clicking outside the circles Pl Size a7 Darken Q@
accepts the change and starts - b

the next healing/cloning
process. Changing tools and
continuing with your adjust-
ments accepts the changes.
Clicking the Clear All button

(just to the left of Camera Raw’s

histogram) deletes the changes Figure 7-6: Minimize the haunted red eye
you made with the Retouch tool. effectrightin Camera Raw.

Also new in Camera Raw 4 is the Red Eye Reduction tool. It automatically
tries to hunt down and eliminate any suspicious red-eye in your image. You
might need to adjust the Pupil Size and Darken sliders (see Figure 7-6) to fine-
tune the adjustment.

To the right of the tools are Camera Raw’s buttons to rotate (in 90-degree
increments in either direction) and a new button to quickly open Camera
Raw’s Preferences, which are shown in Figure 7-7. (Well, it’s no faster than
using the keyboard shortcut 8+K/Ctrl+K, but it is handy.)

In Figure 7-7, I show some changes to the Preferences that you might want to
consider:
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1~ Save settings in sidecar files. Okay, so this one is already the default,
but it’s a good one. When Camera Raw can’t record data directly to the
image file’s metadata, you can either save everything in one central
location — which means you lose everything if that database is damaged
or lost — or each image you adjust can have its own . xmp file to hold
your adjustments.

1~ Sharpen previews only. The sharpening controls in Camera Raw aren’t
nearly as sophisticated as what you find in Photoshop itself. Do your
sharpening in Photoshop after adjusting in Camera Raw.

1~ Set defaults for each camera. If you shoot with more than one camera
(and remember that Camera Raw can now work with JPEG images, as
explained in the “Camera Raw with JPEG and TIFF” sidebar in this chapter),
use separate defaults for each of them. Saving a new camera default is dis-
cussed later in this chapter, in the “Workflow options and presets” section.

1~ Update DNG previews. If you work with Adobe’s DNG Converter and
make DNG copies of your images, doesn’t it make sense that you’d want
the latest adjustments reflected in the file’s preview? (The JPEG preview
is used by your computer’s operating system and other programs that
can’t read DNG files.) And those previews might as well be full size, eh?

Camera Raw Preferances (Veruon 4 s 1760

Conaral - —
Canvira Raw databaie [ ]
sare image sewings . [EITEIRET LU RN: | Cancel

Apoly sharpening 12: | 7 All images E|

Defaul image Setting)

— Apply 4uto tone djuilmeits

! Apply auto grayscale mix whin Conveiting 1o grivcale
“ Make defaults specific 1o cammra tenal number

— Make defauks specific 1o camara 5O etting

Canviia R Cachu

Maximum e 1.0 [+ Purge Cache

Select Location W s R [Lisvary /€ bt /Adiobe Carvera Ram.

DNC File Handling
_ lgnede sidecar “amg” Hles

!‘.'wm embedded INLG reviews: | ¢ Medium Sice

Figure 7-7: Camera Raw has its own set of Preferences.
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The histogram

Because of the unprocessed nature =
of Raw images, the histogram you
see in the top-right corner of the

Camera Raw window (also shown
in Figure 7-8) is generally far more ,
important than the Histogram palette _

in Photoshop itself. By keeping an

- . R: 216 ffl6 1/25s
eye on the histogram while you G: 214
B 215 150 100 55-200@55 mm

adjust sliders, you can ensure that

you're not blowing out the highlights

(when the very right end of the his-  Figure 7-8: Use the histogram to make sure
togram starts crawling up the edge)  you don't wreck your highlights and shadows.

or clogging the shadows (the left

edge gets too tall). The RGB values that you see just above the histogram rep-
resent the values of the pixel directly under the cursor when the cursor is in

the preview area of the window.

The histogram in Camera Raw shows you not only the distribution of tonal
values but also the distribution by channel. In Figure 7-8, you can see that the
Blue channel has a lot of dark pixels: The blue column climbs the left edge of
the histogram. This could indicate any of a number of situations. However,
because you also see a generally good distribution of blue throughout the
histogram (in part shown by the areas of white, which indicate that all three
channels have comparable values), you can be pretty sure that the column of
blue to the left simply indicates a lot of bright yellow in the image. (Blue and
yellow are color opposites in RGB.) As always, remember that what you see
in the preview area — what your eyes tell you — trumps any information

from a histogram.

To toggle a preview of any “clipping” in your image, click the triangles in the
upper-left (shadows) and upper-right (highlights) of the histogram. Anyplace
where the shadows are being forced to pure black, losing detail that you could
retain, you see a solid blue overlay. Anywhere that the highlights are being
blown out to pure white, again losing valuable detail, you see a solid red over-
lay. (Fix this clipping problem using the Exposure, Blacks, Brightness, and

Fill Light sliders, as explained later in this chapter.) You can hide these gamut
warnings by again clicking the triangles. The triangles change color to tell you
what’s wrong or which colors are causing the problem. You might want to
hide the overlays when creating special effects. (I readily admit that I often
intentionally clog shadows and blow out highlights to produce special effects

and to focus attention on the subject of my photos.)

The preview area

As shown earlier in Figure 7-1, the bulk of the Camera Raw window is filled
with the image preview, giving you the best possible view of your work.
Remember that you can drag the lower-right corner of the Camera Raw
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window to resize it. The preview area benefits/suffers from the changes that
you make as you enlarge/shrink the window. To the lower left are a pop-up
menu with preset zoom factors as well as a pair of buttons to zoom in or out.
(Don'’t forget about the Zoom tool!)

Above the top-right corner of the preview area is the Preview check box,
which you can toggle off and on to see the difference between the current
adjustments and the original (or earlier adjustments made in Camera Raw).
To the right of the Preview check box is a handy new button that expands
Camera Raw to Full Screen mode. The only Camera Raw-related information
that disappears is the name of the camera from which the images came.
Note to Mac users: In Full Screen mode, you may not have access to the
hidden Dock. Simply click the button again to toggle back to Normal mode.
(Pressing the F key also toggles to and from Full Screen mode.)

Workflow options and presets

Just below the preview area in Camera Raw is a line of information in blue.
That tells you the current color space, color depth, pixel dimensions, and res-
olution. Click that line to open the Workflow Options dialog box, visible in
Figure 7-9.

il Qpelons

Space.  ProPhots KGE

‘ roboancs T
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& Ooen in Photoshop as Smart Dbiects

Figure 7-9: Make decisions about the processed image in the Workflow Options area.
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In the Camera Raw window in Figure 7-9, notice the thumbnails stacked to the
left. Select multiple Raw images in the Photoshop File=>Open dialog box or in
Bridge and they will all open in Camera Raw together. Click a thumbnail to
work on that particular image. If you open images that all need a similar cor-
rection, adjust one and then click the Select All and Synchronize buttons in
the upper-left corner.

Here are your workflow options:

1~ Space: Camera Raw offers only four color spaces — Adobe RGB,
ColorMatch RGB, ProPhoto RGB, and sRGB. Color spaces (read about
them in Chapter 6) determine which colors are available in an image.

Using the ProPhoto RGB color space gives you the widest gamut (the
largest number of possible colors), which minimizes the chance of
colors getting squished into each other as you work with your image.

If your image has extreme colors, use ProPhoto and 16-bit color in
Camera Raw, and then, if your printer can’t handle Pro Photo as a color
space, choose Edit>Convert to Profile to change to your required
profile (Adobe RGB for inkjet printers or sRGB for images being sent

to a photo lab). Select Relative Colorimetric as the rending intent.

1~ Depth: Because a greater color depth means more possible variations
in color, generally you want to select 16-bit color and either keep the
image in that color depth or switch to 8-bit color later in Photoshop by
choosing Imager>Moder>8-Bits/Channel. Use 8-bit color for any image
that must be saved in JPEG format (including Web images), for CMYK
(cyan/magenta/yellow/black) images, or when the file size overwhelms
your printer. You might also opt for 8-bit color if storage space is limited.
(Chapter 6 includes a detailed explanation of color depth.)

1~ Size: You can choose from among six pixel dimensions for your image in
Camera Raw. The camera’s native pixel dimensions for the image is the
default, but you can also downsize to 50% or 67%, or upsize to 133%,
167%, or 200%. Camera Raw uses a variation of the Bicubic Sharper
algorithm for resampling (calculating the colors of the new pixels).

1~ Resolution: Resolution is simply an instruction to a printing device
about what size to make each pixel. It can be assigned in Camera Raw or
later in Photoshop’s Image Size dialog box (with Resample unselected).
If your camera embeds a resolution that Camera Raw can read, it will be
used. Generally speaking, 300 ppi is an appropriate resolution for images
that will be printed.

1 Open in Photoshop as Smart Objects: This new option enables you to
automatically open your Raw image into Photoshop as a Smart Object.
Smart Objects, which are discussed in Chapter 10, can be scaled and
transformed multiple times with minimal degradation of the image qual-
ity. And, new in Photoshop CS3, you can apply Smart Filters — re-editable
filters — to Smart Objects. (Smart Filters are introduced in Chapter 15.)
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On the subject of workflow, let me T ""llm..q. S
also suggest how you can save loads L m__B Camera R Detaus
of time when working with Camera ot Custom Sectings

Raw: Create your own defaults and
use saved settings. Figure 7-10 shows | wewe — an

the menu commands available to you. ey EXpOt Settings 10 XNP

(Not all commands are available all o n_|
the time.) The most important is per- | %= L] Losd sewins..
e ) e Semings...
haps Save New Camera Raw Defaults. ;‘,—— | e e
e ) Rest Camera Raw Defaults
Here’s my recommendation: T

Figure 7-10: Camera Raw permits you to save,
export, and import settings, as well as establish
custom default settings.

1. Open one of your typical
images.

Open an image that’s well
exposed and typical for what and how you shoot. Don’t open some wild
image that’s three-quarters wrecked and in need of emergency surgery.

2. Adjust the image to make it look the best possible.

The various adjustments are discussed in the following sections.
Make all the necessary adjustments, including noise reduction and
camera calibration if required.

3. Save as your new defaults.
Open the menu and select Save As New Camera Raw Defaults.

Now when you open one of your images into
Camera Raw, you'll already have a good correction

established and you’ll only need to tweak the set- RN
tings only a bit to adjust for the peculiarities and S —
vagaries of that particular shot. Whte Ratince: | A hat =
Nermpes stusy 5200
Remember, too, that you can save settings for -
each individual shoot by using the Save Settings Ao Detaul
command. Say, for example, that you shot on Expoure s024
location under difficult lighting circumstances. Jacory 0
Rather than adjusting each image, adjust one, il Lighe 0]
save the settings, and load (or apply) those set- Backs i
tings for each additional image from that shoot s 5
that needs to be processed. Contrast 5T
— Canvart b Cranicale
o Wisrarce 1%
The Basic pane e
When it comes to actually correcting your images =

in Camera Raw, the meat-and-potatoes portion is

the Basic pane. Click on the leftmost of the eight Figure 7-11: The Basic pane
buttons directly below the histogram area to open is where you do the bulk of
the Basic pane, which is shown in Figure 7-11. your image correction.
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Here are some general guidelines for working in the Basic pane (but remem-
ber that each image has its own particular requirements):

1~ Adjust the white point. Generally, you adjust the white point (the
Temperature and the Tint sliders) by clicking with the White Balance
tool (which looks like the Eyedropper tool, shown here in the margin) in
some area that should be neutral and close to white. If the image doesn’t
look right, click elsewhere or manually adjust the Temperature and Tint
sliders.

1 Adjust the Exposure. Drag the Exposure slider right or left to spread the
histogram across most of the space available. (Remember, these are gen-
eral guidelines for typical images, not “rules.”)

+~ Fine-tune the shadows and highlights. Use the Brightness and Blacks
sliders to spread the histogram toward the right and left ends. The new
Recovery slider can bring back some of the depth in the upper part
of the tonal range (bright areas, but not as bright as the highlights),
and the new Fill Light slider lightens the midtones. Both are great addi-
tions to Camera Raw!

1~ Fine-tune the contrast. Drag the Contrast slider to the right to increase
contrast or to the left to flatten out the image’s contrast.

1~ Tweak the colors. Using the new Vibrance slider in conjunction with
the Saturation slider, adjust the appearance of the color in your image.
Note, too, the Convert to Grayscale button. You can use that button or
the one in the HSL/Grayscale tab — they both change when you select
or deselect either.

Double-click any slider control to reset that slider to its default value.
This works not only for sliders in the Basic pane, but also for sliders
anywhere in Camera Raw.

As you work, the best adjustments are those that make the image look great
to you and meet your creative goals. The order of adjustments and the his-
togram suggestions here are not appropriate for all images. Let your artistic
sense be your guide.

Adjusting the tone curve

The second tab in Camera Raw, just to the right of the Basic tab, presents you
with a pair of ways to adjust the histogram using curves (see Figure 7-12).

On the Tone Curve tab, you have two more tabs: Parametric and Point.

The first thing to know about the Tone Curve adjustments is that they are in
addition to changes you make in the Basic tab. All changes are cumulative —
dragging sliders in the Parametric pane, for example, won’t change the sliders
on the Basic tab.

In the Parametric pane, you adjust four sliders to control various parts of the
tonal range. The three sliders immediately below the curve itself govern the
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pivot points around which the sliders bend the curve. The two outer sliders
govern what part of the tonal range is affected by the Shadows and Highlights
sliders, and the middle slider controls the relationship between the Darks
and Lights sliders.

The Point pane of the Tone Curve tab is quite similar to the Curves adjustment
in Photoshop: Click the curve to add an anchor point; drag up and down to
adjust that part of the tonal range. You can add up to 14 separate points to
the curve. Click an anchor point to make it active (it appears as a solid point
rather than hollow) and you can use the Input and Output fields to adjust the
point numerically, or use the arrow keys to change the point’s location.

So, you might ask yourself, “Should I use the Basic tab, the Tone Curve tab,
or both?” And the answer is “Yes. You should use the Basic tab. Or the Tone
Curve tab. Or both.” You might find that you’re more comfortable using one
curve or the other rather than the Blacks, Brightness, and Contrast sliders in
the Basic tab. Or you might find that for one particular image you want to
make large adjustments with one set of sliders and fine-tune with the other.

145

G R A EE e =

Tone Curve

&

A A= = e =S

Tone Curve

. Parametric |Point

[ [)
Highlights

 Parametric | Point

Curve:

Linear

+ Medium Contrast
Strong Contrast
Custom

K-

Lights

Darks

Shadaows

Input; 128 Output: 128

Figure 7-12: You make changes to tonality in the Tone Curve tab.
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Vibrance and Saturation

Both the Vibrance and the Saturation sliders in
Camera Raw adjust the intensity of colors in your
image. So, what's the difference? The Saturation
slider changes all color in the image, whereas
the Vibrance slider works its magic primarily on
those pixels that are least saturated. To see how
this works, open an image in Camera Raw and
adjust the sliders to make the image look great.
Drag the Saturation slider all the way to the left.
Grayscale, right? Move the Saturation slider all

the way to the right. Oversaturated, right? Drag
the Vibrance slider slowly to the right while
keeping an eye on areas of the image that are
close-to-but-not-quite gray. Watch how they
increase in saturation, gradually going from near
gray to almost colorful. Now here’s the coolest
trick of all: With Saturation still at +100, drag the
Vibrance slider all the way to the left, to —100.
Starting with an appropriate image, this can be
an extremely interesting effect.

But how do the adjustments compare? An increase of 10 in the Contrast
slider in the Basic tab is approximately comparable to a parametric curves
adjustment of Lights plus-4 and Darks minus-5. A parametric curve adjust-
ment of Highlights plus-15 and Shadows minus-15 is roughly comparable to
Blacks 5 and Brightness 4 on the Basic tab. You might find that using the
Blacks slider (in the Basic tab) has a heavier influence on the darkest shad-

ows and less influence on the midtones than working with the Shadows slider

in Parametric pane of Tone Curve. Likewise, you might find the Brightness
slider a bit more concentrated in the lightest highlights than the Highlights
slider. But most of all, you might find that using both sets of sliders gives you
incredible control over the tonal range in your image!
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The Detail pane

Three sliders on the Detail tab control sharpness and noise in your image.

I suggest that as soon as you click the Detail tab, you zoom in to 200% or
even 400% on an area of shadow in your image and drag the three sliders all
the way to the left, setting them to 0 (zero). Leave the Sharpness slider at 0;
do your sharpening in Photoshop’s Smart Sharpen (or Unsharp Mask) filter,
where you have a Radius slider to control how the sharpening is applied to
the image. (Remember, too, that you can click the Preferences button above
the preview to change the behavior of the Sharpness slider so that it sharp-
ens the preview only.)

Drag the Color Noise Reduction slider slowly to the right until all red/green/
blue specks in the shadows disappear. Next, drag the Luminance Smoothing
slider to the right until the bright specks in your shadows are reduced but
not so far to the right that detail in your image is damaged. Figure 7-13

shows a before-and-after comparison of an image shot at ISO 1600. (For most
cameras, any ISO setting above 400 is likely to produce a large amount of digi-
tal noise.)
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Figure 7-13: Reducing noise and smoothing luminance can greatly improve shadow areas.
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HSL, grayscale, and split toning

New in Adobe Camera Raw 4 is the HSL/Grayscale tab. Consisting of the four
tabs shown in Figure 7-14 (the fourth of which is available only when Convert
to Grayscale is selected), it gives you incredible control over specific color
ranges in your image. Need to perk up the reds in your image? Not a problem —
boost the Reds slider in Saturation and Luminance! Yellows a bit too garish?
Tone ’em down with the Yellows slider. Maybe the green grass looks a bit
yellow. Drag the Greens slider halfway to the right in the Hue tab.

With the Convert to Grayscale option selected, you control the contribution of
each range of color to the final grayscale image. Use the Basic tab’s Exposure,

Blacks, Brightness, and Contrast sliders to control the overall appearance of
the image.

The Saturation tab also enables you to create partial grayscale images quite
easily. Drag some sliders to the left to make those areas of color grayscale,
drag others to the right to enhance the remaining colors. Figure 7-15 shows
an excellent candidate for this partial-grayscale technique.
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Figure 7-14: You can adjust hue, saturation, and luminance individually for various parts of the
spectrum.
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Figure 7-15: Grayscale greenery contrasts nicely with highly saturated blooms.

The Split Toning tab is generally
used in conjunction with the
Convert to Grayscale options in the
Basic and HSL/Grayscale tabs.
(Although you can use it to make
adjustments to highlights or shad-
ows, you would generally remove or
introduce a color cast in the Basic
tab with the Temperature and Tint
sliders.) Think of split toning as
creating a sepia or Duotone version
of an image. As you can see in
Figure 7-16, you have separate con-
trols for adjusting the highlights and
shadows. Select a different hue for
each and adjust the saturation inde-
pendently. The Balance slider allows
you to control what part of the tonal
range is considered highlight or Figure 7-16: A photo of a bland building in front
shadow. of an overcast sky is improved with split toning.
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To create a sepia effect, start with a value of 40 in both of the Highlights fields
and perhaps +30 for Balance. Use a Shadow saturation value of 0 (and because
saturation is set to 0, it doesn’t matter what value you select for the Hue slider).
Remember, too, that you can select the same hue for both Highlights and
Shadows to create a monochrome effect.

Compensating with Lens Correction

Use the Lens tab’s controls (as shown in Figure 7-17) to compensate for cer-
tain undesirable characteristics of your lens. Zoom in on an area of angled
lines in an image — perhaps tree branches in front of a bright sky — and look
for colorful halos or fringes along edges. Use the Chromatic Aberration slid-
ers to minimize the fringe. Be patient and careful — often there will be one
precise pair of settings that eliminates the problem. (And keep in mind that
while refraction of light through water or ice isn’t the same as chromatic
aberration, these sliders are sometimes helpful in minimizing those colored
halos, as well.)

Lens Carrections

Chromatic Aberration

Fix Red/Cyan Fringe 0

Fix Blue/Yellow Fringe 0

Lens Wignetting

Amount 0

Midpoint

Lens Caorrections

Chrematic Aberration

Fix Red/Cyan Fringe -10

Fix Blue/Yellow Fringe +3

Lens Vignetting

Amount 0

Midpoint

Figure 7-17: Minimize colored fringe with the Chromatic Aberration sliders.



Use the Vignetting sliders to eliminate
darkness around the edges of the
image or, perhaps, to introduce either
darkness or lightness as a special
effect. When the Amount slider has a
value other than 0, the Midpoint slider
is active, which lets you set the diam-
eter of the vignette. In Figure 7-18, the
original image is shown at the top.
Below, you see what happens when
you drag the Amount slider to the
left for a dark effect and to the right
to lighten the corners of the shot,
smoothing the appearance of the sky.

Customizing camera
profiles and the
Presets tab

You might want to use the Calibrate
tab to compensate for what you per-
ceive to be regular and consistent
deviation in your particular camera’s
behavior. You might, under some cir-
cumstances, want to use the sliders
on the Camera Calibration tab (see
Figure 7-19) to reduce a color cast, an
unwanted color tint in the image.
Use very small adjustments!
Generally, though, you’ll skip the
Camera Calibration tab completely.

If your particular camera model

has had multiple profiles created,
you’ll see them listed in the pop-

up menu at the top. The image
open in Camera Raw when

Figure 7-19 was captured was last
updated for Adobe Camera Raw 2.4,
so the current profile is actually
selected, despite the fact that this is
Camera Raw 4.

Chapter 7: The Adobe Camera Raw Plug-In

Figure 7-18: Drag the Amount slider to left to
darken corners; to the right to lighten.
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Camera Profile
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Shadows
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Saturation 1]

Creen Primary
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Saturation i)

Blue Primary
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Figure 7-19: The Calibration sliders might be
useful for correcting a color cast.
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Camera Raw’s new Presets tab (the tab to the far right) simply stores a con-
venient list of your saved presets. Any time you use the Save Settings com-
mand from the menu to the right of the tabbed area, your preset is added to
the list for convenient one-click application. To use save settings, open an
image in Camera Raw, open the Presets pane, click the profile, and click Open
Image/Open Object or Done.

The Camera Raw buttons

In the lower-left and lower-right corners of Camera Raw are four buttons,
three of which have hidden features that you access by pressing the
Option/Alt key:

1~ Save Image . . ./Save Image: After making your adjustments, click the
Save Image . . . button to open the DNG Converter dialog box and save
a copy of the image as a DNG file. Option/Alt+click to bypass the DNG
Options dialog box and simply save the image as a DNG file. When you
close the Camera Raw window, the image is saved automatically.
(For more on the DNG file format and the DNG Options dialog box,
see the sidebar, “The DNG file format,” earlier in this chapter.)

» Open Image/Open Copy (or Open Object/Open Copy): After making
your adjustments, click Open to update the file’s metadata and open the
image in Photoshop itself. Holding down Option/Alt changes the button
to Open Copy, which opens the image without updating the metadata.
You might use Open Copy when creating a second version of the image
while preserving your exactingly precise original adjustments. (Remember
that a simple change in the Workflow Options — which you open by
clicking the blue information line under the preview — enables you to
automatically open an image from Camera Raw into Photoshop as a
Smart Object.)

1~ Cancel/Reset: Clicking Cancel closes the Camera Raw window without
making any changes to the image’s metadata. Holding down the
Option/Alt key changes the button to Reset, which restores the settings
seen when you first opened the image in Camera Raw.

1 Done: The Done button, with or without the Option/Alt key, simply
updates the image’s metadata with the adjustments you've made and
closes Camera Raw without opening the image.
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Fine-Tuning Your Fixes

In This Chapter
Telling Photoshop where to work with selections
Masking for layer visibility and to protect parts of your image

Keeping your options open with adjustment layers

Fere you are, repainting the bedroom — all by yourself, saving money,
being productive — and it’s time to do the windows. Now, you probably
don’t want to paint over the glass, right? Just the frame, the sash, the sill,
those little whatch-ya-call-its between the panes, right? There are several
ways you can avoid painting the glass. You can use a little brush and paint
very carefully. You can use a larger brush, paint faster, and scrape the excess
from the glass afterward. You can grab the masking tape, protect the glass,
and paint as sloppily as you like — when the tape comes off, the glass is
paintfree.

Those are unbelievably similar to the choices that you
have in Photoshop when you need to work on only a
part of your image. You can zoom in and use tools,
dragging the cursor over only those pixels that you
want to change (just like using a tiny paintbrush).
You can use the History Brush feature (which I intro-
duce in Chapter 1) to restore parts of the image to
the original state (like scraping the glass). You can
isolate the area of the image you want to change
with a selection (much like protecting the rest of the
image with tape).

In this chapter, you read about getting ready to make
changes to your image rather than actually making those
changes. You can isolate groups of pixels in your image in a
variety of ways. For example, you can select pixels that are in the

same part of the image (regardless of color), or you can select pixels that are
the same color (regardless of location in the image). This is power: the ability
to tell Photoshop exactly which pixels you want to alter. After you make that
selection, you can manipulate the pixels in a variety of ways — everything from
making color and tonal adjustments to working with Photoshop’s creative fil-
ters to simply copying them so you can paste them into another image.
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I discuss “taping the glass” first by making selections and then by using
masks — channels that actually store selection information. After that, I tell
you about working with adjustment layers, which are special layers that help
you apply certain color and tonal adjustments without actually changing any
pixels in the image. An adjustment layer even lets you restrict the change to
one or several layers in the image.

What Is a Selection?

When you make a selection in your image, you're simply isolating some of the
pixels, picking them (selecting them) so that you can do something to those
pixels without doing it to all the pixels in your image. Photoshop shows you
what part of the image is within the selection with a flashing dashed line.
(Now that you're part of the Photoshop Inner Circle, you call that selection
boundary the marching ants.)

Say, for example, that part of your image looks great, but part of the image
looks, well, just plain wrong. Figure 8-1 is an excellent example.

Figure 8-1: Sometimes only part of the image needs changes.
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By making a selection and applying an adjustment, I can make this image
look much, much better. Of course, you might choose to make a different
selection and apply a different adjustment, but you can see what I chose to
do in the lower left of Figure 8-2. By selecting the rails (in this case, with

the Polygon Lasso tool, which I explain later in this chapter), I isolate those
areas from the rest of the image, enabling me to change the color of those
pixels without changing anything else. (Rather than selecting and darkening
the rails to make them appear to be in front of a glow, I could have selected
the lighter area and created a uniform sky color. But this is visually more
interesting.)

The tonal and color adjustments that I discuss in Chapters 5 and 6 are often
applied to an image as a whole. You can, however, apply them to specific
areas of an image. Much of the rest of the work that you do in Photoshop is
not global in nature, but rather is done to only restricted areas of your image.
You use selections to do that restricting.

- LnirpingAtSunriie-1.0f @ 150K (RCa/8#)
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Figure 8-2: The selection (shown to the right) restricts the change to some parts of the image.
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You can also use selections for a variety of other jobs in Photoshop. One of the
most common is copying from one image and pasting into another. You can
see one example in Figure 8-3. The subject of one image (upper left) is selected.
You can see a close-up of the selection to the right. Choosing Edit=>Copy
copies the selected pixels to the Clipboard. You can then switch to another
image and use the Edit>Paste command to drop those pixels into a second
image (lower left). You can adjust the size by choosing Edit=>Transform=>Scale,
adjust the position by dragging with the Move tool, and perhaps add some
shadows by using the Brush tool. The job is ready for whatever nefarious
purpose you might have in mind!

Any pixel in your image can be selected, deselected, or partially selected.
For example, if you have a selection and fill it with red, the selected pixels
turn red, the deselected pixels don’t change, and the partially selected pixels
get a red tint. How much tint depends on the level of selection. (Photoshop
generally uses 8-bit grayscale for selections, so there are 256 different levels
of “selected.”)

ansd T Spider-AlphaChanneis.osd @ 100% (RGS/ 87
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Figure 8-3: Make a selection, copy, switch to another image, and paste.
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Feathering and Anti-Aliasing
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You need to keep in mind a couple of very important terms as you read
about the various tools and commands with which you make selections.
Both feathering and anti-aliasing make the edges of your selections softer by
using partially transparent or differently colored pixels. That, in turn, helps
blend whatever you’re doing to that selection into the rest of the image.

Don’t forget that all pixels in your image are square, aligned in neat, orderly
rows and columns. (That’s the raster in raster artwork.) When you create a
curve or diagonal in your artwork, the corners of the pixels stick out. Feathering
and anti-aliasing disguise that ragged edge. You can also use feathering to create
larger, softer selections with a faded edge. Generally speaking, use anti-aliasing
to keep edges looking neat and use feathering to create a soft, faded selection.

Nothing illustrates the power of feathering quite like a simple black-on-white
demonstration, as you see in Figure 8-4. In the upper left, | made an unfeath-
ered selection and filled it with black. To the upper right, the filled selection
is exactly the same size but has a 2-pixel feather. Below, [ used a 15-pixel
feather when making the selection.

2 Untisled -2 @ 200% (RCB/ B

Figure 8-4: A close-up look at no feathering, feathering, and /ots of feathering.
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Note that there’s feathering on both sides of the selection border. And don’t
be fooled by the amount that you enter in the Feather field on the Options
bar — that’s a general guideline, not a precise value. A 15-pixel feather for the
Elliptical Marquee tool might give you 50 or 60 partially transparent pixels,
half on either side of the selection border. Even a 1-pixel feather gives you a
selection with several “soft” pixels on either side.

Anti-aliasing is similar to feathering
in that it softens edges: It’s designed
to hide the corners of pixels along
curves and in diagonal lines. You use
anti-aliasing with type (as I explain in
Chapter 13). You'll often find that anti-
aliasing is all you need to keep the
edges of your selections pretty; feath-
ering isn’t required. Anti-aliasing is a
yes/no option, with no numeric field
to worry about. Figure 8-5 compares a
diagonal with no anti-aliasing, with
anti-aliasing, and with a 1-pixel feather.

T Uncifed-2 § B30N (Layer 1. ACHE

Figure 8-5: Anti-aliasing helps smooth the

At1l h
t 100 percent zoom (to the upper appearance of curves and diagonals.

left), the first line looks bumpy along
the edges (it has a case of the jaggies,
you would complain to a friend or co-worker). The lower line looks soft and
mushy, out of focus. And the middle line? To quote Goldilocks, “It’s just right!”
When zoomed to 600 percent, you can really see those jaggies and that soft-
ening. And in the middle, you see that the anti-aliasing uses light gray and
mid-gray pixels interspersed along the edge among the black pixels. At 100 per-
cent zoom (upper left), your eye is fooled into seeing a straight, black edge.

Generally speaking, use anti-aliasing with just about every selection (other
than rectangular or square), and use feathering when you want to really
soften the edges to create a special effect.

Making Your Selections with Tools

Photoshop offers you nine tools whose whole purpose in life is to help you
make selections. You also use those tools to alter your selections by adding
to, subtracting from, and intersecting with an existing selection. The nine
selection tools are divided into three groups:

» Four marquee tools

1 Three lasso tools

1 The Quick Selection tool and the Magic Wand
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Marquee selection tools

You have four marquee selection tools, although you’ll generally use only two
of them. Figure 8-6 shows the marquee selection tools, along with each tool’s
Options bar configuration.
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Figure 8-6: Marquee selection tools come in four flavors, two of which are tasty.

You drag the very useful Rectangular Marquee and Elliptical Marquee tools
to make selections. Click and drag in any direction to make your selection.
After you start dragging, hold down the Shift key (while still dragging) to
constrain proportions. When you constrain the proportions of a selection,
you create a square or circle rather than a rectangle or an ellipse. If you
start dragging a selection and press the Option (Mac)/Alt (Windows) key,
the selection centers itself on the point where you click. The Shift and
Option/Alt keys can be used together. Holding down the Shift key before
you click and drag adds the selection to any existing selection. Holding
down the Option/Alt key before dragging subtracts the new selection from
any existing selection.

The Single Row Marquee and Single Column Marquee tools are simply clicked
at the point where you want a 1-pixel selection, running from side to side or
from top to bottom. These tools create selections that extend the full width
or full height of your image. You might use these tools to create a gridlike
selection that you can fill with color. Or you might never use them at all.

Take another glance at the Options bars in Figure 8-6. The four buttons to the
left in the Options bar, which you can use with any of the tools, determine
how the tool interacts with an existing selection.
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1 New Selection: When you select the first button, any selection that you
make replaces an active selection (deselecting any previous selection).
If, with a selection tool, you click inside an active selection when
the first option is active, you can drag that selection in your image
without moving any pixels. When you haven’t already made a selection,
these tools always make a new selection, regardless of which button is

active.

1 Add To: When you have an active selection and need to add to that
selection, use the second button or simply press and hold down the

Shift key while dragging.

1~ Subtract From: When you have a selection and need to deselect part of
it, use the third button. Say, for example, that you make a round selec-
tion and want to chop out the middle to make a donut shape. Click the
third button and then drag within the original selection to deselect the

donut hole.

1~ Intersect With: You have a selection, but you want to keep only part of
the selection. You could set your selection tool to subtract from the
existing selection, or you could intersect with that original selection and
deselect a number of areas at once.

Controlled selections

Lurking within the Options bar Style drop-down
menu are two options worth noting: Fixed
Aspect Ratio and Fixed Size. Using the Fixed
Aspect Ratio option with the Rectangular
Marquee or the Elliptical Marquee tool forces
the selection to the height and width relation-
ship that you specify in the Options bar. This is
great for composing an image that you need at
a specific size, say to fit in a standard picture
frame. The selection tool won't resize the image
for you, but you can make the selection and
choose Image=>Crop and then choose Image=>
Image Size to resize to your required dimen-
sions and resolution. (Read about resizing and
cropping your images in Chapter 4.)

The Fixed Size option changes the behavior of
the tools. After you enter an exact width and
height in the Options bar, position the cursor in
the upper-left corner of the area that you want
to select and click once — the selection is cre-
ated to the lower right of that point. Don't worry
about being exact because you can drag the
selection marquee into position afterward.
(You'll want to have the leftmost of the four but-
tons on the Options bar selected to reposition
your selection.) And take a look at the button
between the Width and Height fields on the
Options bar: When you're using the Fixed
Aspect Ratio or Fixed Size styles, click that
button to swap the values in the two fields.




Chapter 8: Fine-Tuning Your Fixes

3

Figure 8-7 presents a visual explanation of how all four buttons work. On the
left, you see the selected option for the active marquee selection tool. Next is
an original selection. In the third column, you see another selection being
made (with the selection tool dragged from the lower right to the upper left).
Finally, on the right, you see the result of combining the two selections.

In the bottommost example, you could do a whole series of subtractions from
the existing selection to chop off the “points,” but using the intersect option
takes care of the job with a single drag.

While you’re dragging a selection with the Rectangular Marquee or the
Elliptical Marquee tool, you can hold down the mouse button and press and
hold the spacebar to reposition the marquee. When you have it where you
want it, release the spacebar and continue to drag.
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Figure 8-7: The buttons at the left on the Options bar control selection interaction.
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Take another look at the four views of the Options bar shown earlier in
Figure 8-6. Take note of these variations among them:

1~ Anti-aliasing isn’t available for the Rectangular Marquee tool. That’s
because all four edges of the selection will align perfectly with the edges
of the pixels — no need to disguise corners of pixels. (You can, of course,
soften the selection with feathering.)

1 Both the Rectangular Marquee and the Elliptical Marquee tools offer the
options of Normal (unconstrained, just drag as necessary), Fixed Aspect
Ratio (the relationship between width and height you specify in the
Options bar is maintained as you drag), and Fixed Size (just click in the
upper-left corner of your intended selection).

1 The Single Row Marquee and Single Column Marquee tools offer the four
buttons to determine how the tool will interact with an existing selection
and the Feather field. Although feathering a 1-pixel wide or tall selection
seems a little strange. . . .

Lasso selection tools

Three lasso selection tools are available in Photoshop CS3. On the Options bar,
all three of the lasso selection tools offer you the same basic features that you
find in the marquee selection tools, as you can see in Figure 8-8. You can add
to, subtract from, or intersect with an existing selection. You also have the
feathering and anti-aliasing options available. The Magnetic Lasso tool offers
three additional settings that help determine how it identifies edges as you drag.
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Figure 8-8: The basic options for the lasso selection tools match those for the marquee
selection tools.
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So what makes lasso tools different from a marquee tool? Read on to find out:

1~ Lasso tool: The Lasso tool is a true freeform tool; that is, you click and
drag it wherever you want the selection to go. You can drag around and
return to the starting point, or you can release the mouse button any-
where, and your selection is finished along a straight line from that point
to the spot where you start your selection. If you press and hold the
Option/Alt key while dragging, you’ll temporarily switch to the Polygon
Lasso tool.

1~ Polygon Lasso tool: Rather than dragging, you click-click-click to make
straight selection segments, at any angle, for any distance. When you
position the cursor directly over your starting point, a little circle
appears to the lower right of the cursor to indicate that you're back to
the start. Or simply double-click to finish the selection. If you press and
hold the Option/Alt key while dragging, you’ll temporarily switch to the
regular Lasso tool, which lets you drag your selection any way you want.
Using the Option/Alt key lets you switch back and forth between the
freeform drag of the Lasso tool and the perfectly straight selection bor-
ders of the Polygon Lasso tool.

1~ Magnetic Lasso tool: When you need to select around a subject that
has good contrast with its background, the Magnetic Lasso tool can
do a great job. The perfect candidate for this tool is a simple object
on a very plain background. You can, however, use it with just about
any image where the edges of the area you want to select differ sub-
stantially from the rest of the image. Click and drag the tool along the
edge of your subject. If the tool misses the edge, back up and drag along
the edge again. If the edge makes a sudden change in direction, click to
add an anchor point. If the tool places an anchor point in the wrong
spot, back up and then press Delete/Backspace to remove the point.
(By the way, if you have a Wacom pressure-sensitive tablet hooked up,
you can set the Magnetic Lasso tool to vary its width according to pen
pressure. Use the button just to the right of the Frequency field on the
Options bar.)

The Magnetic Lasso tool works by identifying the difference in color
along the edges, using all available color channels. From the Options
bar, use the Width field to tell the tool how wide of an area it can

look in to find an edge. The Edge Contrast field tells the tool how
much the edge must differ while searching. Use the Frequency field to
choose the number of anchor points the tool sets while outlining the
selection.
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The Quick Selection tool

New to Photoshop CS3 is the Quick 8 NI~ 08
Selection tool. Consider it to be sort |;

of a Magic-Wand-in-a-brush. You drag
the tool through an area of color and,
based on the color variations under
the brush and the brush size, the
tool automatically selects similar
colors in the surrounding area.

Keep in mind that you can adjust

the brush size as you work by using
the square bracket keys, [ and ].
(When working with a Wacom tablet,
this tool works great with brush

size set to pen pressure.) With just

a little practice, you’ll likely find the
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Quick Selection tool to be quite Figure 8-9: Drag through an area of color to
simple to use, even fOlj rather com-  select the pixels under the brush and nearby
pleX selections. (See Flgure 8-9) pixels of similar color.

The Magic Wand tool

The Magic Wand tool selects pixels similar in color to the pixel on which you
click with the tool. Like the other selection commands, you can add to, subtract
from, or intersect with an existing selection, and you can select anti-aliasing.
In Figure 8-10, you can see three additional options, unique among the selec-
tion tools. Tolerance determines how closely pixels must match your target
color to be included in the selection. When you enable the Contiguous check
box and then click a spot, only pixels connected to the spot by pixels of the
same color are selected. The Sample All Layers option lets you make a selec-
tion of similarly colored pixels on every visible layer in your image, not just
the currently active layer.

In Figure 8-10, you can see the result of clicking the same spot, using four
different Tolerance settings. In the upper left, the Magic Wand was set to
Tolerance: 10; in the upper right, Tolerance: 20; in the lower left, Tolerance:
50; and in the lower right, Tolerance: 100. You can see that the higher the
tolerance, the wider range of color selected. When you use a low Tolerance
setting, you select only those pixels in the image that are very similar to the
pixel on which you click. A high Tolerance setting gives you a much wider
range of color, which might or might not be appropriate for the selection
you're making.

Use a reasonably low Tolerance setting and Shift+drag the Magic Wand tool
or Shift+click in different places to select a range of colors. In the photo in
Figure 8-10, I would use a low Tolerance setting when Shift+clicking the
highlights in the blooms to avoid selecting the highlights on the leaves and
the fence.
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Figure 8-10: The lower the Tolerance, the fewer pixels in the selection.

Refine Selection Edge

If you look at the various pictures of
the Options bar earlier in this chap-
ter, you might notice the Refine Edge
button to the right. New in Photoshop
CS3, Refine Selection Edge (shown in
Figure 8-11) helps you fine-tune your
selections by adjusting the edges.

Here’s what you need to know about
each of the options in Refine
Selection Edge:

1~ Radius: When you’re trying to
select an area with soft or fuzzy
edges, increasing the Radius
value can help better define the
edge of the selected area of color.

1 Contrast: When soft or fuzzy
edges of an area of color pro-
duce a speckling of unwanted
color, increasing Contrast is in
order. When you boost the

Refine Selection Edge
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Figure 8-11: Refine Selection Edge reminds you

Contrast value. Refine Selection  What each feature offers in the Description area.
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Edge tries to exclude pixels whose color varies too much from the area
being selected.

1~ Smooth: Sometimes the edge of a selected area is too jagged to use.
Increasing the Smooth value a bit is like anti-aliasing the edge. Using
higher values starts rounding off corners.

1~ Feather: Like choosing Select>Modify=>Feather, increasing this value
softens the edges of the selection by blurring. Use Feather for an overall
softening of the edges; use Radius to fine-tune the selection when the
area being selected has fuzzy edges.

1~ Contract/Expand: Rather than simply contracting or expanding the
selection (as with Select->Modify=>Expand/Contract), think of this slider
as fine-tuning the adjustment you’re making in Refine Selection Edge.
If all of the other sliders are set to zero, Contract/Expand does nothing
to the selection.

P The row of buttons below Contract/Expand changes the preview in your
image window. Let me suggest that you get used to swapping around the pre-
view as you work. The left button shows you the selection border in your
image. The second button gives you the same red overlay that you see when
working in Quick Mask mode (discussed later in this chapter). The third and
fourth buttons are great for previewing any light or dark artifacts along the
edges. Use the button to the far right to get an excellent view of the softness
(feathering) of your selection edge.

Vour Selection Commands

You have 17 menu commands at your service when selecting pixels in your
artwork. Some, like those near the top of the Select menu, are rather simple
and aptly named. See Figure 8-12 for a list of the Select commands.

The primary selection commands

The commands near the top of the Select menu are features that you're likely
to use regularly. (Okay, maybe not the Reselect command.) Memorizing their
keyboard shortcuts is a timesaver.

1~ All (38+A/Ctrl+A): Choosing All does exactly what the name implies — it
makes a selection of all the pixels in your image on the active layer (or in
an active layer mask).



Chapter 8: Fine-Tuning Your Fixes ’ 6 7

1~ Deselect (88+D/Ctrl+D): Use the [

Deselect command to make All XA
sure that no pixels are selected. Deselect XD
This is a handy command when ssomip g
) y ) . Inverse axi
it seems that a filter or adjust-

ment command isn’t working.

There could be an unnoticed

selection in the image, prevent- Color Range...

ing the command from appearing

how — or where — you expect. Refine Edge... %R

Boroer...
»~ Reselect (88+Shift+D/ o :l"‘“:::
Ctrl+Shift+D): This is a great simitar s
little command for those times Transform Selection Feather... XD
when you’re making a complex P —
X . - - Load Selection...
selection, and a little slip acci- Sioe Salacrion-

dentally deselects. Just use
Reselect to restore the most

recent selection. Figure 8-12: Photoshop’s selection commands.

v~ Inverse (88+Shift+I/Ctrl+Shift+I):
The Inverse command reverses the selection. What was selected is dese-
lected, and what wasn’t selected becomes selected. (Don’t forget to
include the Shift key — without it, you invert the colors in your image
rather than your selection!)

The second section of the Select menu contains three commands (All Layers,
Deselect Layers, and Similar Layers) used not for pixels but rather with

the layers in your image. Use these commands with multilayer images.

(Read about using layers in your artwork in Chapter 10.)

The Color Range command

In its own little group, right in the middle of the Select menu, is the incredibly
powerful Color Range command. Check out those orange blooms from

Figure 8-9. Rather than dragging the Quick Selection tool or Shift+clicking
with the Magic Wand, you can select the orange quickly and easily with the
Color Range command. In Figure 8-13, I clicked and dragged through some
orange areas in the image with the middle Eyedropper tool. You can also
click once with the left eyedropper and use the other eyedroppers to add and
subtract colors from the selection. The Fuzziness slider near the top of the
dialog box determines how close a color must be to those through which you
dragged to be included in the selection.
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Color Range

Figure 8-13: The Color Range feature selects by color.

Here are a couple of ways that you can get a better look at your selection as
you create it. In Figure 8-14, you see the options available from the Selection
Preview menu. The Grayscale (upper left) and Black Matte (upper right)

do a good job of showing that the background will be partially selected if you
click OK. You can lower the Fuzziness or use the eyedropper on the right to
click in those areas of the fence that shouldn’t be selected. The White Matte
(lower left) does an excellent job of showing that the tips of some leaves
below the blooms will also be selected. (Ignore that and Option+drag/Alt+drag
with the Lasso tool later to deselect that area.) Because of the color of this
image’s subject, the red Quick Mask preview (lower right) is almost worthless
for this image, although it is often good with other images that don’t have red
and orange.

The pop-up menu at the top of the Color Range dialog box lets you pick
among the RGB (red/green/blue) and CMY (cyan/magenta/yellow) colors, as
well as the image’s highlights, midtones, or shadows, and even any out-of-
gamut colors in the image (colors that can’t be reproduced within the
selected color space). When you choose one of the presets from the top
menu, the Fuzziness slider isn’t available, limiting that feature’s value.
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Color Range

Select |/ Sampled Colors 18]

Fuzziness

Selection @ image
Y seiection Preview: TR

- Crayicain
Slack Matte

White Matte
Quick Mask

Figure 8-14: Color Range offers four ways to preview.

Selection modification commands

The next group of commands in the Select menu actually holds six separate
commands, including Refine Edges (discussed earlier in this chapter), and
the five Modify commands, each of which has a single numeric field:

1~ Border: Tucked away within the Modify submenu, the Border command
creates a selection of your chosen width centered on the marching ants
that you see as the original selection’s edges. The resulting selection can
be filled to create a border, or you may opt to delete the pixels within
the border to clean up the edges of the selected area of color.

1 Smooth: When you click with the Magic Wand to make a selection of an
area of color, you might see all kinds of tiny 1- or 2-pixel areas within the
selection that are not selected. Perhaps those few pixels were just a bit
out of the Tolerance range for the tool. No worry! Use the Smooth com-
mand and a 1- or 2-pixel radius to snatch up those stray, deselected
pixels. The Smooth command can also eliminate jagged edges along the
outside of your selection.
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1~ Expand: The Expand command moves the selection border outward a
specified number of pixels. Be careful, though, because if your original
selection includes sharp corners or points, using Expand rounds them
off. (In the Paths palette, convert your selection to a path, scale the
path, and convert the path back to a selection. See Chapter 11 for info
on paths.)

1~ Contract: The Contract command shrinks your selection by the amount
specified.

1~ Feather: Feathering, which I discuss earlier in this chapter, softens the
edges of a selection. Normally when cutting and pasting a selection or
moving a selection within an image, you want to feather a pixel or two.
Unlike earlier versions of Photoshop, the Feather command is now avail-
able after you choose Selectr>All.

As you make your way down the Select menu, you’ll come across the Grow and
Similar commands, which are somewhat like the Magic Wand with Contiguous
(Grow) and without Contiguous (Similar) selected on the Options bar. (In fact,
they use the Magic Wand'’s Tolerance setting.) Grow adds to your selection
any adjacent pixels of the appropriate color, and Similar looks throughout the
entire image for similarly colored pixels. Use Grow and Similar when your ini-
tial selection consists primarily of a single color. Using these commands with
a selection that contains lots of different colors generally results in most of
your image being selected.

Transforming the shape of selections

As you work with selections, you might find times when the selection capability
doesn’t match your need. For example, the Elliptical Marquee tool can certainly
make oval selections, but those ovals are either vertical or horizontal. What if
you need an oval selection at an angle? That’s where the Select>Transform
command comes into play. Make your initial selection, choose the Transform
Selection command, and then manipulate the selection to fit your needs, as
shown in Figure 8-15.

Here’s what you see in Figure 8-15:

1~ Top left: This is the original selection.

1~ Top center: Click an anchor point on any side of the bounding box and
drag to change the height or width of the selection.

1 Top right: Position the cursor outside the bounding box and drag to
rotate.

1~ Middle left: Drag any corner anchor point to manipulate the selection’s
width and height at the same time.

1~ Middle center: Hold down the Shift key while dragging a corner anchor
point to avoid distorting the selection while changing size.
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1 Middle right: Hold down the Option/Alt key while dragging a corner
anchor point, and you end up scaling the image based on that crosshair
in the center of the bounding box. (You can drag that crosshair anywhere,
even outside the bounding box, to change the point of transformation.)
You can use the Shift key with Option/Alt, too.

1 Bottom left: Hold down the 88/Ctrl key and drag any side anchor point
to skew.

1~ Bottom center: Hold down the 8/Ctrl key and drag a corner anchor
point to distort.

1~ Bottom right: If you 3/Ctrl+drag two or four corner anchor points, you
can add perspective to the selection. [ might, for example, fill this trans-
formed selection with color, move the selection, scale it down a bit, fill
again, and repeat a number of times to create a series of paw prints
marching into the distance.
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Figure 8-15: The many faces of transformations.
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The mask-related selection commands

At the bottom of the Select menu, you see a pair of commands that you use to
store your selections for future use and to actually reuse them. When you
save a selection, you create an alpha channel in the image. The alpha channel,
like a color channel, is a grayscale representation of the image. White areas

in the alpha channel represent areas that are selected when the channel is
loaded as a selection. Black areas in the channel show you deselected areas.
Gray represents feathering and other partially selected pixels.

[ discuss channels in greater depth in the next section of this chapter.

While you'’re exploring selection commands, the key points to remember are
that you can use the Save Selection command to save any selection as an
alpha channel, and then later you can use the Load Selection command to
reactivate the selection without having to re-create it from scratch.

Masks: Not Just for Halloween Anymore

In Photoshop, a mask is a channel (in the Channels palette) that stores informa-
tion about a selection or about layer visibility. When you talk about selections
saved as masks, you can refer to them as alpha channels. Any time you make
a complex selection, consider saving it as an alpha channel, just in case.

So what exactly counts as complex? That depends on how much time you
have on your hands. If it takes me more than a minute or two to do anything
in Photoshop, I want to save it. And what counts as just in case? You might
need to return to the image at some later date to make changes, you might
need to shut down for the day, or maybe you’ll even (fingers crossed against!)
have a crash. Save your selections, just in case. . . .

Saving and loading selections

Creating an alpha channel from a selection is as simple as choosing Selectw>
Save Selection and selecting a name for the new channel. If you have more than
one document of exactly the same pixel dimensions open in Photoshop, you
can select any of the available documents for the new channel. If you already
saved a selection as an alpha channel, you can elect to have the two selections
interact in a single channel. As you see in Figure 8-16, the Operation choices
parallel those that you find on the Options bar when working with selection
tools: You can replace the selected channel, add to the existing channel, sub-
tract from the existing channel, or intersect with that existing channel.

When you need to work with a saved selection, choose Selectr>Load Selection
or simply 88+click/Ctrl+click the alpha channel’s thumbnail in the Channels
palette — either activates the selection.
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Figure 8-16: When you already have an alpha channel, the new selection can modify it.

The Load Selection dialog box offers the same key features that you see for
Save Selection. (Refer to Figure 8-16.) When loading a selection, you can add
to, subtract from, or intersect with an active selection. You can also invert a
selection when loading by selecting the Invert check box. Using that check
box produces the same result as loading the selection and choosing
SelectevInverse, but it’s faster and easier.

Editing an alpha channel

Alpha channels, like color channels, are grayscale representations. As such,
you can edit them like you would any grayscale image. Click the channel in
the Channels palette to make it active and visible. You see it in the image
window as a grayscale (or black and white) representation of the saved
selection. If you want to see the image while you work on the channel, click
in the left column (the eyeball column) to the left of the RGB (or CMYK)
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channel. The alpha channel then appears as a red overlay on top of the
image. Figure 8-17 shows you what the screen looks like with just the alpha
channel visible (left) and how it appears when the alpha channel is active
and the RGB channel is also visible. Also take a look at the difference in the
Channels palette. See the eyeball column on the left?

Figure 8-17: You can see just the alpha channel itself (left) or as a red overlay (right).

Here are some of the things that you might want to do to an active alpha
channel:

1+~ Blur the alpha channel. Blurring an alpha channel (Filter=>Blur com-
mands) is much like feathering a selection — it softens the edges. One of
the big differences is that you can see a preview of the blur, which is
much better than guessing how much feathering you need.

1~ Sharpen the alpha channel. Sharpening a saved selection (Filter=
Sharpen commands) makes the edges cleaner and more precise.

1~ Paint in the alpha channel. Painting with the Brush tool using black,
white, and gray in the channel changes the selection. Paint with white
to add areas to the saved selection; paint with black to remove areas
from the selection; paint with shades of gray to partially select
areas of the image. You can edit an alpha channel with the Brush tool
very precisely, adding and eliminating stray pixels, as well as creating
precise edges.
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1~ Use levels or curves on the alpha channel. If the saved selection has
feathering or other areas of partial selection (grays in the alpha channel),
you can manipulate them with a Levels or Curves adjustment (from the
Image=>Adjustments menu). The Levels adjustment is particularly appro-
priate for controlling the feathering along an edge.

1~ Apply one or more filters to an alpha channel. Use artistic filters on a
saved selection to create special effects, such as borders and frames.
Chapter 15 covers filters.

Working in Quick Mask mode

Okay, so you want to make a selection, save it as an alpha channel, make the
alpha channel active, click the eyeball column to make the RGB channel visi-
ble so you can see what you're doing, paint in and apply filters to the alpha
channel, make the RGB channel active, load the alpha channel as a selection,
and, well, do something creative with it. Whew! How about an easier way to
do the same thing?

With Photoshop’s Quick Mask mode, you make a basic selection, press Q on
the keyboard to enter Quick Mask mode, edit the selection as if it were a
mask, and then press Q again. Heck, you don’t even have to start with a selec-
tion! In Quick Mask mode, your mask appears on-screen as a red overlay, just
like an alpha channel appears when the RGB channel is visible (as you can
see in Figure 8-17). Paint, apply filters or adjustments, or make selections —
anything you can do to a grayscale image, you can do in Quick Mask mode.

If you're more comfortable with the Brush tool than the Lasso tool, you might
want to use Quick Mask mode to make all your selections. You might find it
faster and easier to “paint” a selection in Quick Mask mode than to drag a
selection with a lasso tool or use the selection commands. Enter Quick Mask
mode, paint the mask, exit Quick Mask mode, and you have your selection.
You can also enter and exit Quick Mask mode by

clicking the button just below the color swatches m_m:': mo«n«n__ =
in the Toolbox. Double-clicking the button opens @ Masiad Ares ==y
the Quick Mask Options dialog box (as shown in Slocnd Saes cance
Figure 8-18). You can reverse the behavior of the —

overlay, making it show selected areas instead of . Opacty: [§0 |

the deselected areas, and you can change the
color and opacity of the overlay. (Hop back to
Figure 8-14 to see how hard it is to see the edges  Figure 8-18: You can change
of the orange blooms with the red overlay. the opacity and color of the
Changing the overlay to, say, blue would solve Quick Mask overlay.

that problem.)
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By default, you paint with black in Quick Mask mode over areas that you
don’t want selected, paint with white over areas that you do want selected,
and paint with shades of gray over areas that you want partially selected.

Adding masks to layers and Smart Objects

When your image has multiple layers (as I discuss in Chapter 10), including
Smart Objects, you can partially hide the content of the layer or Smart Object
with layer masks. Layer masks and alpha channels have much in common:
Layer masks are selections saved as channels, you can paint in the layer
mask, you can apply filters and adjustment to the layer mask, and so on.

Just keep in mind that a layer mask appears in the Channels palette only
when you select its layer in the Layers palette. (In the Layers palette, you’ll
see the layer mask thumbnail to the right of the layer’s thumbnail.) If you
want to edit a layer mask, click its thumbnail in the Layers palette and then
edit it as you would an alpha channel. Remember to click the layer thumbnail
afterward to reactivate the layer itself.

The easiest way to add a layer mask is to make a selection of the pixels that
you want visible on that layer and then click the Add Layer Mask button at
the bottom of the Layers palette (third button from the left). You can also
make a selection and choose Layer=>Layer Maskr>Reveal Selection or Layer=
Add Layer Maskr>Hide Selection. That menu also offers Reveal All and Hide
All as well as commands to disable (hide) or delete the layer mask. You can
also apply the layer mask, which deletes any hidden pixels on that layer.

Alayer named Background (in italics) in the Layers palette can’t have any
transparent areas, so you can’t add a layer mask. Not a problem! Simply
double-click the layer name in the Layers palette and rename the layer.
That converts it to a regular layer, which would be more than happy to
accept your layer mask.

In the Layers palette, a layer mask is linked to the layer — that is, if you drag
the layer, the mask moves right along with it. You can unlink/relink the mask
and layer by clicking the icon/space between their thumbnails in the Layers

palette.

A layer mask cannot be linked to a Smart Object. Not a problem! In the Layers
palette, create a new Group (layers and layer Groups are discussed in
Chapter 10) by clicking the New Group button. Move the Smart Object into
the Group. Add a layer mask to the Group (rather than to the Smart Object).
When you need to move both the Smart Object and the mask, click on the
Group and move the Group.
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Masking with vector paths

A layer or Smart Object can also be masked with a vector path. (Paths are
explained in Chapter 11.) Vector masks have very precise edges, and you

can edit them as a path with the Direct Selection tool. A layer (other than a
Background layer) can have both a regular pixel-based layer mask and a
vector mask. To show up in your artwork, pixels on that layer must be within
both the layer mask and the vector mask. When a layer has both a layer mask
and a vector mask, the vector mask thumbnail appears to the right in the
Layers palette.

Adjustment Layers: Controlling Changes

TUR
s&ﬂ\ 23

Ng,

Photoshop gives you the capability of making tonal and color adjustments that
you can later refine, change, or delete. Most of the adjustment commands (dis-
cussed in Chapters 5 and 6) are available as adjustment layers. An adjustment
layer applies the selected change to color or tonality just as the comparable
command would, but using an adjustment layer offers a few major advantages:

1 Adjustable adjustments: You can reopen an adjustment layer’s dialog
box at any time to change the settings.

1 Reversible adjustments: You can delete an adjustment layer, removing
the change from your image.

1~ Hidden adjustments: Click the eyeball column to the left of the adjust-
ment layer in the Layers palette to temporarily hide that change.

1~ Tweakable adjustments: You can change the opacity and blending mode
of adjustment layers to fine-tune the effect.

1~ Limitable adjustments: You can add layer masks and vector masks to
your adjustment layers to restrict their effect to only some of the pixels
below. And you can later edit the masks as necessary.

Because of the added flexibility, you'll generally want to use adjustment
layers rather than adjustment commands in your images. Of course, you still
need the Image~>Adjustments menu for those several commands that can’t
be added through an adjustment layer.

Just as adjustment layers provide the flexibility to change your mind, so too
does Photoshop CS3 now offer Smart Filters — when working with Smart
Objects, you can re-edit filters just as you change layer styles! You can
explore this long-awaited, incredibly powerful capability in Chapter 15.
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Adding an adjustment layer

You can add an adjustment layer through the menu at the bottom of the
Layers palette (click the fourth button from the left) and then move the
cursor to the type of adjustment layer that you want to add (as shown

in Figure 8-19) or through the Layer=>New Adjustment Layer submenu.

The choices are the same. When you select the particular adjustment that
you want to add from the bottom of the Layers palette, that specific adjust-
ment dialog box opens. (Selecting the adjustment through the Layers menu
presents you with the New Layer dialog box first.)

The top three options in the menu that you open from the Layers palette are
fill layers — layers completely filled with a color, gradient, or pattern. You can
add a new empty layer and choose Edit=Fill to do the same thing, or you can
add such a layer through the Layer~>New Fill Layer menu.

Solid Color...
Cradient....
Pattern...

Levels...

Curves...

Color Balance...
{Contrast...

Black & Whita...
Hue/Saturation...
Selective Color...
Channal Mixer...
Gradient Map....
Photo Filter...
Exposure...

Invert
Threshald...
Posteriza...

Figure 8-19: Adjustment layers can be added through the Layers palette.
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Limiting your adjustments

When your image has multiple layers and you want to apply an adjustment
layer to only one layer, the new adjustment layer must be clipped — restricted
to the one layer immediately below it in the Layers palette. (That’s the layer
that’s active when you add the adjustment layer.) You can clip it to the layer
below by Option+clicking/Alt+clicking the line between the two layers in the
Layers palette (which is also how you unclip a pair of layers). Figure 8-20
shows the difference between a clipped adjustment layer (left) and an
unclipped adjustment layer (right). When unclipped, the adjustment is
applied to all the layers below rather than to the one layer immediately
below. When adding an adjustment layer through the Layers menu, select
the option Use Previous Layer to Create Clipping Mask.

A R

Figure 8-20: Restrict an adjustment to one layer by clipping it to the layer.

On the left side of Figure 8-20, the Hue/Saturation adjustment is applied only to
the upper layer — the layer named Symbol. On the right, the adjustment layer
isn’t clipped, so it changes both the Symbol layer and the Background layer.

By the way, the thumbnail in the Layers palette shows the Symbol layer’s orig-
inal copper color prior to the addition of the Hue/Saturation adjustment layer.
Among the beauties of using adjustment layers is the joy you might feel when
the client says, “Yup, you were right — let’s go back to the original design.”

In the Layers palette on the left in Figure 8-20, you can see the so-called
“wedding rings” icon between the adjustment layer and the layer named
Symbol immediately below. That’s the icon that you see when Option+clicking/
Alt+clicking to clip (or unclip) layers.
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But what if you want an adjustment layer to change, say, three of the layers in
your image? Create a layer group from the layers (click the New Group button
at the bottom of the Layers palette and drag the layers into the Group icon in
the palette), add the adjustment layer within the group, and change the layer
group’s blending mode from Pass Through to Normal at the top of the Layers
palette. The adjustment layer, within the layer group and at the top of the
layer group, is applied to all your layers in the group and only the layers in
that group.

Because they're layers, you can use a layer mask to apply the adjustment
layer to only part of your layer. You'll find it easier to make a selection of the
area where you want the adjustment before selecting the adjustment layer —
the mask will be automatically created from the selection.



Common Problems
and Their Cures

In This Chapter

Perfecting portraits of people

Hushing the noise in your images

Editing your digital landscape

Sometimes you take perfect photos of imperfect people, and sometimes
you take imperfect photos of, well, imperfect people. (Even the top
models benefit from a little Photoshopping.) Although capturing absolute
reality is the goal of some artists and most photojournalists, the people in
your photos probably prefer to look as good as you (and Photoshop) can
make them look.

In this chapter, I present you with some basic techniques
for curing many of the most common problems that
you encounter as a photographer. I show you how to
remove that spooky red-eye effect that appears when
your camera’s flash reflects off the blood vessels in
the back of a subject’s eyes. I also show you tricks for
removing wrinkles, whitening teeth, and tightening
waistlines. Digital noise (those distracting red, green,
and blue pixels scattered in your image’s shadows)
is easy to minimize when you use the tricks here.

At the end of the chapter, | cover how to remove
some larger problems from images, such as distracting
objects and ex-boyfriends. Throughout this chapter, [ use
real-world examples — the types of photos with which
you’re most likely to work. (After all, you probably don’t get to
shoot beautiful models all the time.)
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Making People Prettier
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You can do lots of things in Photoshop to improve your images, but few are
appreciated as much as fixing a person’s photographed flaws (the appearance
kind, not their bad habits). Whether it’s a studio portrait or a snapshot, the
people in your images generally can benefit from a little touching up.

Although you can theoretically make almost anyone look truly beautiful and
glamorous using Photoshop, remember to balance improving with reality.
Always work on a copy of your image. I also recommend saving separate
copies at different stages during the editing process. The client might say
that he wants the braces removed from his teeth, but after you present the
finished product, he might just (gasp!) change his mind.

Getting the red out . . . digitally

When a subject looks directly into the camera and the camera-mounted flash
fires, the result is often red-eye. This result is caused when light (such as a
flash) bounces off the blood vessels
at the back of an eye, and it gives
the subject a spooky vampire look.
Among the many ways to minimize
this problem is with the Red Eye
tool. Zoom in and click once with
the tool to watch the red disappear,
leaving the natural highlights and a
perfect eye. As you see in Figure 9-1,
the default settings are good for typi- Figure 9-1: Click with the Red Eye tool to
cal cases of red-eye. replace red with natural-looking black.

LT B T LT .- v

The Red Eye tool finds red and not
green. For green-eye (in photos of ani-
mals), for too-bright white reflections
from eyes, and for those times when
you’re not happy with the perfor-
mance of the Red Eye tool, use the
Brush tool (as you see in Figure 9-2).
Set the foreground color to black; in
the Options bar, select the Luminosity Figure 9-2: When the Red Eye tool won't work,
blending mode and an Opacity of use the Brush tool.

about 50%. Use a brush diameter just

slightly larger than the pupil and a brush hardness of about 75%. Click

once and evaluate the result; if necessary, reduce the Opacity to 20% and
click again.
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Here’s one more red-eye/green-eye trick: Use the Sponge tool to desaturate,
followed by the Burn tool (Midtones, 25% exposure). You'll find the Sponge
tool nested in the Toolbox with the Dodge and Burn tools.

The digital fountain of youth

At the end of Chapter 5, [ show an example of using the Dodge tool to fade
wrinkles without removing them completely. Photoshop, being a complex
and capable animal, has lots of other ways to minimize or eliminate wrinkles.
Among the most powerful tools for this job are the Healing Brush, the Patch
tool, and the Clone Stamp.

Both the Healing Brush and the Patch tool work by copying texture from one
area to another. You can, for example, copy smooth skin onto a wrinkled area,
smoothing the wrinkles while retaining the area’s general tonality and color.
To work with the Healing Brush, Option+click (Mac)/Alt+click (Windows) the
area from which you want to copy; then click and drag over the area that you're
fixing. When you select the Aligned option from the Options bar, you maintain
the relationship between the point from which you’re healing and the area
over which you drag. No matter where you move the cursor, the source point
stays the same distance and direction. When repairing areas of a face, however,
you might find it easier to clear the Aligned check box. Every time you release
the mouse button, you start over from the same source point. By using short
strokes, you can heal from the same source area to any area of your image.

To work with the Patch tool, make a selection with the Patch tool (or using
any of Photoshop’s selection techniques) and then drag with the Patch tool.
Depending on which option you select from the Options bar, you can either
select and drag the damaged area to a good area (select Source from the
Options bar), or you can select a good area and drag to the damaged area
(select Destination). You can use both the Healing Brush and the Patch tool
to apply a predefined pattern, too. That can be handy for adding a texture
where one doesn’t already exist in your image.

Like the Healing Brush, you Option+click/Alt+click with the Clone Stamp to
set the area from which you’re copying and then paint over an area to make a
change. The Healing Brush copies texture, but the Clone Stamp copies pixels,
completely replacing the area over which you drag. (That is, of course, sub-
ject to the blending mode and opacity that you select from the Options bar.)
Like the Healing Brush, the Clone Stamp offers the Aligned option. Figure 9-3
shows a comparison of wrinkle reduction using the Clone Stamp (set to Normal
and 100 Opacity) and using the Healing Brush. (If you use the Clone Stamp to
repair skin, reduce the opacity and make sure to select a source area that has
similar skin color and lighting.)
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Figure 9-3: The Clone Stamp (lower left) covers wrinkles, whereas the Healing Brush (lower
right) melts them away.

Dieting digitally

You can certainly use the Clone —
Stamp tool to reduce a bit of a bulge

at the waistline or below an upper . .
arm, but you might find it easier ' 4
(and more natural looking) to make a

selection and rotate the outer edge

inward a bit. Take a look at Figure 9-4.

Although this subject hardly has Figure 9-4: Rotate a selection to pinch in a waist.
what you’d call a “spare tire,” that bit

of extra sticking out above her skirt isn’t particularly flattering. Make a selec-
tion with the Lasso tool that includes some of the background and some skin
(or shirt or dress). Copy the selection to a new layer with 38+J/Ctrl+J. Press
8+T/Ctrl+T to enter Free Transform (or choose Edit>Transform=>Rotate).
Drag the point of rotation (the little crosshair symbol in the middle of the
bounding box) to the top of the bounding box, and then position the cursor
slightly outside the bounding box and drag to rotate. When you’re satisfied,
press Return/Enter to accept the transformation and merge the layers with

8 +E/Ctrl+E. (With complex backgrounds, you might need to do a little
cloning to even things out.)
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When working with double chins, your best bet is usually to minimize rather
than eliminate. Putting a skinny neck under a fleshy face looks unnatural.
You can certainly tuck in the sides of the second chin a bit by using the
rotate method, but rely on the Burn tool to darken. By darkening the

excess flesh under the chin, you make it appear to be in shadow — and,
therefore, under the actual chin
(see Figure 9-5). Use the Dodge tool
(if necessary) to hide any creases or
wrinkles associated with the excess
chin. Redefine a natural-looking jaw
line and chin — but once again, ‘

remember that the result must not

only look natural, but it must also be Figure 9-5: Burning and dodging can reduce
acceptable to the client. even a very prominent double chin.

'

When working with the Burn and Dodge tools, don’t forget to reduce the
Exposure setting in the Options bar — 15% to 20% is plenty strong for this
type of work. You'll also want to juggle between Highlights and Midtones
(the Range setting in the Options bar) when creating an artificial shadow
on a double chin with the Burn tool. Zoom in when doing this sort of work
but also open a second window via Window=>Arrange=>New Window for
[filename] to keep an eye on the overall impact of your changes.

You can use the Filterc>Liquify feature to push, pull, twist, pucker, bloat,

and otherwise manipulate pixels into the shape and position you need.
There’s really nothing more powerful when it comes to reconfiguring a figure.
In Figure 9-6, you see how leveling off a beltline in Liquify is sometimes all
that’s needed to restore that trim-man-she-married look. And a little touch-up
with the Dodge and Burn tools can eliminate the wrinkles in the shirt, helping
improve the overall appearance of the image by reducing distraction.
(Chapter 15 has full info on using Liquify.)

Deglaring glasses

Although hindsight is usually 20/20, many people need spectacles.
Unfortunately, those eyeglasses can be a photographer’s nightmare!

The reflections off glass are usually specular highlights — that is, areas of
pure white with absolutely no detail in them. To properly evaluate flash
reflections in eyeglasses, open the Info palette and move the cursor through
the area. If you see a noticeable variation among the RGB values in the Info
palette, you might be able to restore the area with the Burn tool.

If the Info palette shows RGB values of 255/255/255 or close to it, the area has
no detail. Zoom in close and use the Clone Stamp tool to copy over the area
from another part of the image. In severe cases of glare, you might need to
copy from another photo of the same person. When possible (say, in a portrait
sitting), try to take one shot of the subject without eyeglasses, just in case.

185
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Liguily (BentLine.tif @ 20000

Figure 9-6: Use Liquify to make major adjustments to figures.

Whitening teeth

Teeth generally aren’t truly white (unless somebody has spent a lof of time
and money getting ready for a portfolio shoot). Instead, you see shades of
ivory and yellow in teeth, but they don’t necessarily have to be unattractive
or distracting shades of yellow. Use the Dodge tool to lighten teeth. From the
Options bar, set the tool to Midtones (not Highlights) and an Exposure of
perhaps 30% for front teeth. Paint over each tooth individually, making sure
that you don’t eliminate the shadows that differentiate the individual teeth.
Then switch to Shadows and lighten those molars visible in back. Don’t overdo
it — remember that folks who don’t make their living in Hollywood or on TV
generally don’t have snow-white

teeth. Figure 9-7 shows normal - o= -
people teeth, “improved” normal d ';....: o %
people teeth, and Hollywood teeth.

Balance your judgment with the Figure 9-7: Coffee, cigarettes, and caps; Dodge
client’s needs. tool digital correction; show-biz-white teeth.
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Reducing Noise in Your Images

Moving from the darkroom to digital can save you thousands of dollars in
film and processing costs (not to mention a reduction in environmental
degradation) but has added a new set of challenges to the art and business
of photography. Perhaps foremost among the problems presented by digital
photography is noise. Those pesky red, green, and blue (or light and dark)
specks in an image can ruin a digital photo. Noise is generally most promi-
nent in shadow areas and against dark colors in your images.

If your camera lets you select an ISO setting, you can help minimize digital
noise in your photos by using a low ISO. Sometimes you do need to shoot the
equivalent of faster film, such as at sporting events. However, when you have
a choice, use a low ISO to minimize noise. And using a tripod can help, too!

Decreasing digital noise

You'll find the Reduce Noise filter under the Filter=>Noise menu. As you see in
Figure 9-8, it does a very good job of neutralizing the random red, green, and
blue pixels while preserving detail in the image.

Aedule Noie

Cancel
— Praview
@ 2anc  Advanced

Settings: | Defasit - Bia

Srrength. &
rs

Freserve Details: 39 "
N

Reduce Color Noise: 67 »
.

Sharpen Details: 0 N
LS

= Remove JPEC Artifact

Figure 9-8: The Reduce Noise filter keeps your image sharp while eliminating RGB noise.
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Notice that Reduce Noise also offers a Remove JPEG Artifact option.

When saving in the JPEG file format, you compromise between image
quality and smaller file size. The smaller the file, the greater the likelihood
of compression damage to your image. That damage generally shows itself
as visible lines between blocks of pixels measuring eight pixels square.

You'll also find the Color Replacement tool very handy for noise reduction,
especially in areas of rather uniform color. Option+click/Alt+click right in the
area to set the foreground color; then simply paint away the digital noise.

As you move from area to area in your image, Option+click/Alt+click to pick
up a new foreground color.

Eliminating luminance noise

In addition to the red, green, and blue specks of digital noise, you might face
luminance noise, which is the bright
and dark specks sprinkled through-
out your photo. Photoshop’s Surface
Blur filter can handle luminance noise,
but you have more control over the
result when working with the Blur=>
Smart Blur filter. Unlike Surface Blur,
Smart Blur lets you enter fractions for
both the Radius and Threshold values
(as shown in Figure 9-9). Sometimes
the difference between a 1.5-pixel
blur and a 2-pixel blur is the salva- Figure 9-9: The Smart Blur filter is a good
tion of the fine detail in your image.  choice for luminance noise reduction.

Fooling Around with Mother Nature

Sometimes a very nice photo has something in it that you want gone. . . . a piece
of litter, telephone lines in the distance, a building that distracts from the com-
position, or perhaps a person whose memory you’d like to erase. Other times,
everything in the image is fine, but the image looks wrong because of the angle at
which it was taken. Photoshop offers you quite a variety of tools and techniques
for cutting out, copying over, cleaning up, and even correcting perspective.

Removing the unwanted from photos

Perhaps the easiest way to remove something from an image is to crop the
photo: that is, cut off that part of the picture. This technique is easy enough
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if that piece of litter or whatever happens to be at the edge of the image and
cropping won'’t ruin your composition. However, when you must cover up
rather than crop out, consider both cloning and copy/paste.

One of the keys to using the Clone Stamp tool is keeping an eye on your work.
Zoom in close so you can work precisely, but choose Windowr>Arranger>
New Window for [filename]. Keep that second window zoomed out and off
to the side so you can monitor your progress while you work. I also like to
keep a copy of the original image open for reference. You can make a copy
of the file with the Imager>Duplicate command or by clicking the left button
at the bottom of the History palette. In Figure 9-10, you see the original
image to the upper left, the zoomed-in work image below, and a zoomed-
out second window for the work image. (The Navigator palette shows you
what part of the zoomed-in image is visible.) The unwanted bicycle is easily
removed.

G _1447 copy @ 12 .55 (RGE /AN

Figure 9-10: Use the Clone Stamp to remove unwanted bits and pieces.



’ 90 Part ll: Easy Enhancements for Digital Images

Here are some tips for working effectively with the Clone Stamp tool:

1~ Work on a separate layer. Before cloning, click the New Layer button at
the bottom of the Layers palette and click the Sample All Layers button
on the Options bar. By cloning to the new layer, you protect yourself
from irreversible errors (you can always erase part of the upper layer),
and you can show/hide your work layer to check progress. If the image
already has multiple layers and you want to clone from only one, hide
the other layers in the Layers palette by clicking the eyeball icons in the
left column.

1~ If color or pattern is uniform, clone near. If, for example, you're remov-
ing a power line in a beautiful blue sky, clone from right above and below
the power line so that you get the best possible color match. For delicate
jobs or larger items, you can clone by halves — clone half from one side
and the other half from the other side.

1~ To avoid a recognizable pattern, clone far. In Figure 9-10, I cloned
over the bicycle handles in the lower-right corner of the image from a
variety of places to avoid creating any recognizable replicas of nearby
flowers or rocks. You should, however, try to clone from areas that are
approximately the same distance from the lens as the area over which
you're cloning. If you clone from the far distance into the foreground,
you’ll have a recognizable size mismatch and perhaps a focal difference,
as well.

1~ To copy areas or objects, use Aligned. In Figure 9-10, I copied patches
of wildflowers, grass, and rock. By using the Aligned option, the relation-
ship between the point from which I sampled and the point to which I
cloned remained constant when I released the mouse button. To pick a
new source point, I Option+clicked/Alt+clicked.

1~ To repeat a pattern or texture, don’t use Aligned. If you have a specific
object, texture, or pattern that you want to replicate in more than one
area, you can clear the Aligned check box on the Options bar. Every time
you release the mouse button, the source point returns to the exact spot
where you Option+clicked/Alt+clicked. You can copy the same part of
the image into as many different places as you choose.

 You can vary the tool’s opacity and blending mode. Generally speak-
ing, when you want to hide something in the image, use the Normal
blending mode and 100% opacity. However, you can also clone with
other blending modes and reduce opacity to subdue rather than hide
and, of course, for fun special effects.

1~ Adjust your brush size on the fly. Pressing the left and right brackets
keys (to the right of P on the standard English keyboard) decreases and
increases the brush diameter without having to open the Brushes palette.
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1 Check the brush’s hardness and spacing settings. To get the smoothest
result for general cloning, reduce the brush’s Hardness setting to about
25%, allowing edges to blend. There are times, however, when you’ll need
a more distinct edge to the brush, but you’ll rarely need to clone with a
brush set harder than perhaps 90%. In the full-size Brushes palette, I gen-
erally set the Spacing (in Brush Tip Shape) to 1% for cloning to ensure
the edge is as smooth as possible.

The Spot Healing Brush works much like the Healing Brush to repair and replace
texture. However, instead of designating a source point by Option+clicking/
Alt+clicking, the Spot Healing Brush samples from the immediate surrounding
area, which makes it perfect for repairing little irregularities in an area of
rather consistent texture. The Spot Healing Brush could, for example, do a
fine job with individual flowers and small rocks shown earlier in Figure 9-10,
but it’s not up to the task of hiding a bicycle or a steer.

Larger challenges sometime require more drastic measures, such as dupli-
cate layers and layer masks. Take a look at Figure 9-11. At the top left, you see
the “before” photo: at the top right, the “after” image. Below are images from
three key steps in the process.

©2002 PhotoSpin, PhotoSpin image #0800034
Figure 9-11: A new layer with a layer mask and — POOF — he’s gone!
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Here are the steps [ took to remove the boy from the group photo:

1. Decide what needs to go and how best to cover it.

In this case, the young man is no longer welcome in the group photo.
The easiest way to remove him (without using scissors and leaving an
empty hole) is to move the two young women on the right over to the left.

2. Make a selection of the area that you’ll use to cover.

[ used a large rectangular selection that included everything to the right
of the young man.

3. Copy to a new layer.
Use the keyboard shortcut 38+J/Ctrl+J to copy the selection to a new layer.
4. Position the new layer.

Use the Move tool to slide the new layer over the top of the area you
want to remove.

5. Add a layer mask.

Click the Add Layer Mask button at the bottom of the Layers palette and
then paint with black in the layer mask to hide areas of the upper layer.
As you can see in the lower left in Figure 9-11, the upper layer covers
areas of the lower layer that need to show (such as the man’s head), cre-
ating an unnatural shadow pattern. The layer mask in the lower-center
image exposes as much of the lower layer as possible, leaving the upper
layer visible only where necessary to show the two young women and
their shadows as well as to hide the people on the lower layer.

6. Look for and adjust anomalies.

In the lower center of Figure 9-11, you see that one woman’s foot should
be in the man’s shadow. | added a new layer, made a selection of the
area that should be in shadow, filled with the color of the toes that are
already in shadow, and then used the Multiply blending mode and the
Opacity slider to match the original shadow. (See the lower-right image
in Figure 9-11.)

7. Crop.

Glancing again at the lower-center image in Figure 9-11, you see the area
that needs to be cropped, off to the right. Using a rectangular selection
of everything [ want to save and the Image>Crop command, the alter-
ation is complete.

You can use a similar technique to move something in your image to a new
location. As shown in Figure 9-12, copy the entire image, reposition it, use a
layer mask to hide parts of the upper layer, and clone to remove anything

not needed on the exposed areas of the lower layer. In Figure 9-12, the back-
ground layer is copied and moved upward (after using the Imager>Canvas Size
command to expand the canvas), and a layer mask hides everything except



Chapter 9: Common Problems and Their Cures ’ 93

the boy, his racket, and the ball. On the lower layer, the boy is cloned out.
(The look of surprise from the boy in the red hat in the background is simply a
fortuitous coincidence that seems to add credibility to the adjusted image.)

Figure 9-12: One small step for Photoshop, one giant leap for mankind!

Eliminating the lean: Fixing perspective

When you take a photograph at an angle, perhaps shooting upward at a
building, you get foreshortening, with the distant part of the subject shrinking.
You can use the Photoshop Edit=>Transform=>Perspective command to fix
the problem. Make a selection, choose the Perspective command, and then
drag outward on a corner of the edge that’s too small (or inward on the
corner of an edge that’s too large). When the vertical and horizontal lines

in the image are straight, press the keyboard shortcut 38+T/Ctrl+T to enter
Free Transform mode. Make the subject a little taller, too. As you see in
Figure 9-13, fixing perspective properly also requires a height adjustment.
Press Return/Enter when finished.

You can also use Photoshop’s Crop tool to fix perspective. Mark the Perspective
check box on the Options bar before dragging a bounding box. For best results,
position the four corners of the bounding box on visible corners of something
in the image that should be rectangular or square; then drag the side handles
outward to expand the bounding box to encompass your image. Press
Return/Enter when you’re done. Figure 9-14 shows that the Crop tool does a
good job of adjusting the height to fit the perspective.
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Figure 9-13: Squaring an image with Perspective usually also requires a height adjustment.

8|ane CRW_2260.CRW @ 100% RC/®) ene CRW_2260.CRW @ L00% (RCE/S)

Figure 9-14: The Crop tool's Perspective option does a great job of fixing perspective.




Chapter 9: Common Problems and Their Cures ’ 95

Rotating images precisely

Buried under the Eyedropper in the Photoshop Toolbox is the little-known
Ruler tool (formerly known as the Measure tool). Generally, you use it in
conjunction with the Info palette to find distances and angles in your image.
You can also use it to make sure that you apply the exact amount of rotation
needed for your image. Select the Ruler tool, drag it along any line in your
image that should be vertical or horizontal and then choose Image=>Rotate
Canvas=>Arbitrary. The angle of the Ruler tool will already be waiting for you
in the dialog box, so you need only click OK to precisely rotate your image.

<® One final thought for this chapter: When you come across an image that
requires more fixing than you have time for, or one with such severe lumi-
nance noise that smoothing removes too much detail, or just a problem
photo in general, head for the Filter Gallery. It’s amazing how many flaws
you can hide with a few artistic effects. Creating an artistic rendering of an
image is often preferable to deleting a lousy photo. Blur away the noise and
add a canvas texture with the Texturizer filter. Blown out highlights? Try the
Colored Pencil filter. When faced with lemons, think of the Filter Gallery as
your own personal lemonade stand.
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hotoshop is far more than just a pixel-pushing

image editor. More than merely perfecting
excellent photography, you can create art in
Photoshop. Chapter 10 introduces you to
compositing (combining images into a piece of
artwork) and working with layers. You also see
the powerful Extract feature, which is a great
way to cut and paste from one image to another.
Chapter 11 introduces you to Photoshop’s shape
layers and vector paths, which are illustration tools
used to add specific elements.

In Chapter 12, I show you how to work with the
Styles palette and how to create your own custom
styles — and make sure you don’t lose them by mis-
take! Chapter 13 looks at the many tools, palettes,
and commands you have available in Photoshop to
add text and type. You find out about Photoshop’s
very powerful painting engine in Chapter 14.

To paint effectively in Photoshop, you need to
understand the extremely complex Brushes
palette and painting tools, all covered here.

Chapter 15 introduces you to those filters you
need on a near-daily basis and then shows you
how to work creatively in the Filter Gallery and
in Liquify.
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Combining Images

In This Chapter

Putting pieces together with layers

Integrating with blending modes and opacity
Cutting it out with Extract

Keeping it in perspective with Vanishing Point
Automating with Photomerge and Merge to HDR

A pharaoh’s head on a lion body. A lion with the head, talons, and wings
of an eagle. As evidenced by the sphinx and the mythological griffin,
compositing elements has been around a lot longer than Photoshop, but
Photoshop certainly makes it easier! Take part of one image, drop it onto
another image, and sell the composite to the tabloids for thousands of dol-
lars. (One of the more infamous misuses of Photoshop occurred
during the 2004 U.S. Presidential campaign, with the publication
of a fake photo of candidate John Kerry with actress and
antiwar activist Jane Fonda.) Photoshop offers you
incredible power — use it wisely!

In this chapter, | show you some basic techniques for
compositing (combining two or more images into a
single picture), how to use Extract to select part of
an image for compositing, the new Vanishing Point
feature, and then wrap up the chapter with a look at
a couple of automated features for combining images.

Compositing Images: 1 + 1 =1

You make a selection in one image, copy, switch to another image,
and paste. There you have it — the basic composite! Pretty simple, isn’t it?
Whether you're putting together two images or creating complex artwork
involving dozens of elements, the trick is making the composited image look
natural. The key techniques are blending the edges of your selections and
matching color among the elements.
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Understanding layers

When you put together images, you work with layers. Think of layers in
Photoshop as stackable elements, each of which holds part of your image.
Where an upper layer is transparent, the lower layers show through. Where
the upper layer has pixels that aren’t transparent, those pixels either block or
interact with pixels on the lower layer. (You control that interaction with
blending modes and opacity, explained later in this chapter.)

Take a look at Figure 10-1 (which reveals how Figure 13-2 is created). The Layers

palette shows the individual layers and their content. The individual elements
come together to create a single image.

ene T intoTheMusic.psd @ 16.7% (Man, RGB/8#)

Figure 10-1: Elements on different layers form a single image.
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You can manipulate the content of each layer independently — moving, resiz-
ing, erasing, painting, or adjusting color and tonality — to suit your needs and
artistic vision. Remember to click a layer in the Layers palette to make that
layer active for editing. You can link two or more layers so that they maintain
their positions relative to each other as you move them. (88/Ctrl+click to
select the layers; then click the Link button at the bottom of the Layers
palette — a Link symbol appears to the right of linked layers when active in
the Layers palette.) You might, for example, have a type layer that you want to
remain centered in a rectangle. If you link the two, you can move the rectan-
gle and type together without knocking them out of alignment.

The left column in the Layers palette, known as the eyeball column (for an
obvious reason) allows you to hide a layer, making the content of the layer
invisible. The pixels are still there; they’re just not visible. Click the eyeball
icon to hide the layer and then click the empty space in the left column to
make the layer visible again. You can hide and show adjustment layers, too,
which lets you see their impact on the image. (Read about adjustment layers
in Chapter 8.)

One key concept about layers is well illustrated in Figure 10-1. The higher a
layer is in the stacking order (the order of layers in the Palette from the top
down), the more “in front” it will be. The layers Clouds-Dark and Clouds-Light
are on top of everything in the image. The layer Man is in front of everything
except the clouds. Because of the stacking order, the man appears to be walk-
ing on top of the musical notes, and the notes appear to be on top of the
compact disc.

You can also create groups, which are two or more layers packaged together
in the Layers palette so that you can work with them together. As you can
see in the Layers palette in Figure 10-1, you can have nested groups: a group
within a group. The group named Background Items includes another group,
named Sun, as well as several layers that aren’t part of the Sun subgroup.

Why you should use Smart Objects

Introduced in the previous version of Photoshop, Smart Objects provide even
more flexibility in Photoshop CS3. When working with Smart Objects, you
preserve your editing options without risk to the image quality. For example,
you can transform a Smart Object as often as you like because each time you
rotate or scale or otherwise manipulate a Smart Object, Photoshop goes back
to the original pixels and resamples fresh. This prevents the sort of image
degradation you would see if you were to shrink and enlarge a regular layer’s
content numerous times.



2 02 Part lll: Creating “Art” in Photoshop

‘@T URe

S@
éu

Photoshop CS3 introduces one of the
most widely anticipated Photoshop
features ever: re-editable filters. For
the first time, you can apply a filter
to a selection in Photoshop and then
later go back and change the filter
settings or even remove the filter
entirely. But this feature is available
only when you’re working with Smart
Objects. Again, it goes back to
Photoshop’s ability to return to the
original source pixels when working
with Smart Objects. (Filters are dis-
cussed in Chapter 15.) In the Layers
palette, Smart Filters very much
resemble layer styles: You can click
an eyeball icon to temporarily hide a
filter’s effect, and you can double-
click the filter name to reopen the
dialog box so that you can make
changes (see Figure 10-2).

You can make a selection of part of a
Smart Object before applying a filter,
which creates a mask that restricts
the filter to certain areas of the
Smart Object (visible in Figure 10-2
as a mask thumbnail to the left of the
words “Smart Filter.”) Note, too, that
a Smart Object can have both Smart
Filters and a layer style.

When you choose Filew>Place, a
Smart Object is automatically cre-
ated. To create a Smart Object from
an existing layer (even a background
layer) choose Layer->Smart Objectsr>
Convert to Smart Object.

Figure 10-2: Filters applied to the Smart Object
are listed under Smart Filters.

Using the basic blending modes

The pop-up menu at the top-left corner of the Layers palette offers more than
two dozen different blending modes. A layer’s blending mode determines how
the pixels on that layer interact with the visible pixels on the layers below.

Because a layer named Background can’t have any layers below it, you can’t
change the blending mode of background layers. Convert a background layer
to a regular layer by changing the layer’s name in the Layers palette. Simply
double-click a layer name in the Layers palette and type to rename the layer.
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In Figure 10-3, the black-white and rainbow strips of gradients overlaid on the
garden photo below each use the blending mode shown by the text outline.
(You can see the original gradients in the Normal stripe.) Normal, Multiply,
Screen, Overlay, and Luminosity are the blending modes you’re most likely to
use regularly.
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Figure 10-3: Blending modes control the interaction between the gradients and the photo.

é\gN\BER When working with layer blending modes, always keep in mind that you

& can use the Layers palette’s Opacity and Fill sliders to help determine
the layer’s visibility and appearance. The Opacity slider controls the
visibility of the layer’s content and any layer style applied to the layer.
The Fill slider controls the visibility of the layer content without hiding any
layer style.

The Layers palette blending mode pop-up menu is divided into six sections,
based loosely on how the pixels on the upper layer affect the pixels on

the lower layer. Here’s a quick look at how you use the key layer blending
modes:

1 Normal: Photoshop picks Normal by default. Pixels on the upper layer
completely hide the pixels on the lower layers (subject, of course, to the
Opacity and the Fill settings). Use Normal to show the content of the
layer without any interaction with lower layers.
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1~ Multiply: The Multiply blending mode darkens where your upper layer
is dark and ignores white. Use Multiply when you want the upper layer
to darken but not obscure the lower layer and also for shadows and
dark glow effects.

1~ Screen: The Screen blending mode — the opposite of Multiply — uses
lighter pixels to lighten the pixels below. Use it for highlights and light-
colored glows.

1~ Overlay: Overlay works like a combination of Multiply and Screen. Use it
when you’re working with an upper layer that includes both dark and
light pixels that you want to interact with pixels on layers below.

1~ Soft Light: Soft Light is a subtle blending mode. Like Overlay, where your
upper layer’s pixels are dark, the lower layer is darkened; where they’re
light, the lower layer is lightened. Soft Light is like adding a diffused
spotlight to the lower layer — useful for adding a little drama to the
lower layer.

1~ Hard Light: The Hard Light blending mode is much like a more vivid
version of Soft Light. Use it to add a lot more drama to the lower layer.
Hard Light works well with colors that aren’t overwhelmingly bright.

1~ Difference: Where the upper layer (using the Difference blending mode)
and the lower layer are exactly the same, you see black. Where the two
layers are different, you see brightness or color. For example, use
Difference (temporarily) when trying to align two overlapping photos.
Set the upper layer to Difference, move the upper layer until the areas
of overlap show black, and then switch the upper layer’s blending mode
back to Normal.

1 Color: When the upper layer is
set to Color, the lower layer’s
brightness and saturation are
retained, and the upper layer’s
color is used. If you want to
create a color picture from a
grayscale picture, convert the
image to RGB (Image>Moder>
RGB), add a new layer, change
the upper layer’s blending mode
to Color, and paint on the upper
layer (as shown in Figure 10-4).

1 Luminosity: When the upper
layer is set to Luminosity, the
color and saturation of the
lower layer are retained, and the ©2004 PhotoSpin, PhotoSpin image #1410053
brightness (luminosity) of the Figure 10-4: Paint on a layer set to Color to
upper layer is applied. Because retain the detail of the layer below.
the luminosity (dark and light)
generally provides texture, use this blending mode to produce detail in
the lower layer.
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Photoshop CS3 also offers two pairs of blending modes that you might find
useful, but confusing. The Lighten and Lighter Color blending modes both
compare the pixel on the upper layer to the pixel directly below it on the
lower layer and choose the lighter color value. The Lighten blending mode
looks at each color channel. For example, if the upper pixel’s RGB values are
200/180/75 and the lower pixel’s RGB colors are 175/240/90, the resulting
color in your image is RGB 200/240/90 (the lighter — higher RGB value — of
each of the three channels). Using the Lighter Color blending mode for the
upper layer, on the other hand, would result in the lower layer’s color being
used — RGB 200/240/90 is lighter overall than RGB 200/180/75. While Lighten
looks at each channel independently, Lighter Color simply uses the overall
lightness. The Darken and Darker Color blending modes work similarly, but
choose the darker values.

Opacity, transparency, and layer masks

Blending modes help determine how pixels on an upper layer interact with
pixels on a lower layer, but those upper pixels have to be visible before they
can do any interacting at all. When looking at any pixel on a layer, you have
to consider four factors about transparency:

1 Whether the pixel has any color to start with
» The Opacity value

v The Fill value

1 Whether there’s a layer mask

When you add a layer and paint on it, for example,
you color some of the pixels yet leave other pixels
transparent. (Every layer in every image is com-
pletely filled with pixels, whether visible or not.)
If nothing is done to color some pixels, they
remain transparent, and the lower layers can

be seen through that part of your upper layer.

In Figure 10-5, the words upper layer are on a
separate layer above the layer containing the
words Lower Layer. Where the upper layer has
transparent pixels, the lower layer shows through.

Figure 10-5: Where you see
A layer named Background in the Layers palette the lower layer, the upper
can have no transparent pixels. layer is transparent.

Lowering the Opacity or the Fill slider in the Layers palette (or the Layer
Style dialog box) makes all visible pixels on the layer partially transparent:
The pixels on layers below can be seen through the upper layer’s pixels.
(The Opacity slider controls the pixels on the layer and any layer style; the
Fill slider works only on the pixels, not the layer style. In Chapter 12, you can
read about the Glass Type technique, which demonstrates the difference.)
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Chapter 8 discusses layer masks and vector masks. Remember that any pixel
inside the mask is visible, and any pixel outside the mask is transparent,
regardless of whether it has color. But, as you can guess, any transparent
pixels inside the mask remain transparent.

Creating clipping groups

This being Photoshop, here is yet another way to restrict the visibility of
pixels on an upper layer: clipping groups. Clipping an upper layer to the layer
below, in effect, creates a mask for the upper layer. The opacity of the pixels
on the lower layer is applied to the pixels on your upper layer. Where the
lower layer is transparent, the upper layer (regardless of original content)
becomes transparent. In the Layers palette, Option+click (Mac)/Alt+click
(Windows) the line between two layers to clip the upper layer to the lower.
When you hold down the Option/Alt key, the cursor turns into the wedding
rings icon, shown in Figure 10-6.

After you Option-+click/Alt+click the line between Layer 0 and the layer named
GARDENS, the upper layer is visible only within the text on the lower layer.
The upper layer is indented to the right in the Layers palette, with a downward-
pointing arrow, to let you know that it’s clipped to the layer below. Note that
the upper layer’s thumbnail in the Layers palette shows the entire layer, not
just the visible area. To unclip a layer, Option+click/Alt+click again on the line
between the two layers in the Layers palette. Also note in Figure 10-6 that the
layer style is applied to the lower layer rather than the upper layer.

Figure 10-6: Option+click or Alt+click the line between two layers to clip the upper to the lower.
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Photoshop lets you show the layer thumbnails in two ways. Normally, the
entire layer, including all areas of transparency, shows in the thumbnail.
Although that gives you a good indication of how large or small the particular
layer’s content is in the image, layers with little content have little to show in
the thumbnail. By using the Palette Options (from the Layers palette menu) or
Control+clicking/right-clicking the empty area below the layers in the palette,
you can elect to show a thumbnail that includes only nontransparent areas of
the layer. Little things fill the thumbnail, but they also appear out of propor-
tion to the other thumbnails. Your choice.

Making composited elements look natural

One of the keys to compositing two images is a slight fade to the edges of the
element you're adding to the original image. That fade, called feathering,
makes the edges of the image appear to fall off into the distance very slightly
rather than having a sharply defined edge that sticks out like a sore thumb.
(See Chapter 8 for full information on feathering.) You have a number of ways
to feather a selection, including the following:

1~ Use the Feathering field on the Options bar
before you use a selection tool.

1~ Use the Refine Edge button in the Options
bar or the Select=>Refine Edge command
after making your selection.

1 Choose Select>Modify~>Feather after you
make a selection.

1~ Apply a slight blur to a saved selection’s
alpha channel in the Layers palette (or to a
layer mask).

Matching color between two layers is also critical
for a natural appearance. Take a look at Chapter 6
for full information on Match Color and

Photoshop’s other color adjustment capabilities.

You also need to be aware of perspective and
scale. When an element in your composited
image seems to be too large or too small or
when it seems to be facing the wrong way or
standing on air, rely on the Edit~>Transform
commands. Although the Scale and Rotate com-
mands are self-explanatory, Figure 10-7 shows
visually how you can use the other Transform
commands, such as Skew, Perspective, and
Warp. Drag the bounding box anchor points to  Figure 10-7: Drag anchor points
transform the selected pixels. to transform.
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Selecting with Extract

WMBER
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The Edite>Transform=>Warp com-
mand adds a simple mesh over the
content of the layer or selection.
You click and drag the direction
lines for the corners of the mesh and
at the intersection of mesh lines

to distort your artwork. As you see
in Figure 10-8, the Warp distortion
gives you a level of control second
only to Photoshop’s Liquify feature
(discussed in Chapter 15). You can
also use Warp with paths and shape
layers.

Figure 10-8: Use the Warp transformation to
To copy something from one image distort layers or selections.

to another, you must first make a

selection. You can read a lot about making selections and creating masks
in Chapter 8, but one more Photoshop feature deserves attention: Filter=
Extract. Extract is great for making tough selections, such as flyaway hair
and various types of fringe. Here’s how to use Extract:

1. Use the Highlighter tool to trace along the edges you want to select.

Try to center the green highlighting on the edge, including all the fringe
and individual hairs within the green streak.

2. Click with the Fill tool (it looks like the Paint Bucket tool) inside the
highlighted edge, identifying the part of the image you’re extracting.

If the Fill tool fills the entire image, look for a break in your green high-

lighter line where the fill is leaking. The highlighting should go from edge
to edge or completely encircle the area you want to extract.

3. Click OK.
As you can see in Figure 10-9, Extract is also suitable for irregular horizons and

other such situations in which you might need to extract your foreground to
paste in front of a prettier background.

Here are a few tricks to clean up irregularities along the edge of your
extracted image:
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1~ Duplicate the layer. Drag the extracted layer to the New Layer button at
the bottom of the Layers palette a few times to duplicate it. Any semi-
transparent pixels along the edge become more opaque. When the edge
looks good, use the Layers palette menu command Merge Visible to
create a single layer.

1~ Paint with the History Brush. Use the History Brush to paint back areas
that should not have become transparent.

1~ Erase excess. If Extract misses the edge in places, you can grab the
Eraser tool and eliminate those areas manually.

Entract
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Figure 10-9: Identify what parts of the image to select, and let Extract do the work.

Vanishing Point

When combining images to create a scene, you might find a need to add tex-
ture or a pattern along what is supposed to be a three-dimensional object.
You might, for example, add a product box to a photo of a kitchen and

need to add a logo to the front of the box. Or maybe you will create a room,
perhaps in a castle high on a hill, and you’ll need to add a realistic stone
texture to the walls. Use the Vanishing Point feature to “map” a pattern to
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angled surfaces, such as walls, floors, buildings, and boxes. Vanishing Point,
using information that you provide, automatically determines the correct
angle, scale, and perspective. (Vanishing Point is rather complex, so for simple
jobs, you might want to stick with the Paste and Edit=>Transform commands.)

To use Vanishing Point, you follow a specific sequence of steps:

1. Copy your pattern.

Open whatever pattern file (or texture or color or logo or whatever)
you're going to add to the walls or sides in your image, make a selection,
and then choose Edit>Copy. You can now close the pattern file.

2. Make a selection in your working image.

Identify where you want the pattern to be applied. If you’re working with
walls, for example, make a selection that includes the walls but doesn’t
include windows and doors.

3. Open Vanishing Point (Filter->Vanishing Point).

The Vanishing Point window opens, displaying your image.

4. Create planes on your image in the Vanishing Point window.

a. Select the Create Plane tool (the second tool from the top on the

b.

left edge of the window).

Click on your image where you want to place the three corners of
your plane and then move the cursor to the fourth corner.

You see the plane extending along the last two sides.

. Click the fourth corner to create the plane.

If the plane is yellow or red rather than blue, it’s not aligned
properly. Drag the corners of the plane to realign them, using the
Edit Plane tool (the top tool on the left). Drag the side anchor
points outward to expand the plane’s mesh to cover the whole
wall or side.

. Create perpendicular planes by holding down the &/Ctrl key and

dragging the side anchor point at the point where the two planes
should meet. If the second plane should be at an angle other than
90 degrees to the first plane, Option+drag/Alt+drag one of the
anchor points to rotate the grid.

If the second plane’s angle is off a little, drag one of the corner
anchor points to adjust it. In Figure 10-10, you see two perpendicu-
lar planes.
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Figure 10-10: Use the Create Planes tool to identify surfaces.

5. Paste your pattern.
a. Press 8+V/Ctrl+V to paste your pattern into Vanishing Point.

Your pattern is pasted into the upper-left corner of the Vanishing
Point window.

b. Select the Marquee tool (third from the top) and drag the pattern
into your plane.

The pattern automatically adopts the orientation of the plane.
If necessary, press T on your keyboard and then rotate and scale
the pattern.

6. Replicate the pattern.

Unless your pattern is an exact fit, you need to replicate it to fill the
plane. With the Marquee tool selected, hold down the Option/Alt key.
Then click and drag in your pattern to replicate it. Repeat as necessary
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to fill the plane. As you see in Figure 10-11, you can replicate a relatively
small pattern to fill a large area.

If the lighting in your original image varies, set the Healing pop-up
menu (at the top of the window, only with the Marquee tool active) to
Luminance. That helps maintain the original lighting on the new pattern
or texture.

. Click OK to exit Vanishing Point and apply the pattern or texture to

your image.

After exiting Vanishing Point, you might need to do some touch-up work
on your image with the Clone Stamp tool (depending on how precise you
were when dragging). You might also, depending on the original image,
need to add a layer and paint some shadows or highlights to reproduce
the original lighting in the scene.

® Bm O Ca )

[STTTY TOETAPE S e e . Cancel

Figure 10-11: Option+drag or Alt+drag with the Marquee tool to copy your pasted selection.
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s&N\BEH In Figure 10-11, the pasted and replicated brick pattern doesn’t cover the
& door, window, or artwork because they were not selected prior to opening
Vanishing Point. Without that active selection when opening Vanishing Point,
it would have been much more difficult to properly align the pattern without
covering those areas.

Here are some tips for working with Vanishing Point:

1 Create accurate planes; then drag. Click in four corners of any identifi-
able area of your plane — perhaps a window — and drag the side anchor
points outward (or inward) to identify the whole plane.

1~ Use the X key to zoom. Pressing and holding the X key on your key-
board makes the preview area zoom to show the area where you’re
working. Release the X key to zoom back out.

1~ Press T to transform. After pasting your pattern, you can press T on
your keyboard and then scale and rotate your pasted pattern.

1~ Use the Shift key to drag in alignment. Hold down the Shift key while
Option+dragging/Alt+dragging to replicate your pattern. That keeps the
new part aligned to the old.

1 Duplicate elements in the image. Make a selection with the Marquee
tool and 88+Option+drag/Ctrl+Alt+drag to the area where you want to
place the copy.

1~ Paste over objects in Vanishing Point. Create your plane. Use the
Marquee tool to select an area that you want to replace, and then hold
down the 8/Ctrl key and drag to an area that you want to paste into the
marquee selection.

1 Clone in Vanishing Point. Define your plane, select the Stamp tool, and
Option+click/Alt+click at the source point. Release the Option/Alt key
and move the cursor to the point where you want to start cloning.
When the preview is properly aligned, click and drag to clone.

1~ Paint in perspective. With a plane identified, the Brush tool in
Vanishing Point shrinks or grows in accordance with your perspective
plane.

1 Work on an empty layer. You can add an empty layer in the Layers
palette before entering Vanishing Point. Your result is added to the new
layer, which lets you work with blending modes and opacity to merge
your pattern into the original.
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Putting Together Images Automatically

You have a couple of features in Photoshop that automatically combine two
or more images into a single image. You can combine overlapping images into
a panorama, or you can combine multiple exposures of the same shot into a
single, well-exposed image. You'll find both Photomerge (for panoramas) and
Merge to HDR (for high dynamic range combined exposure images) in the
Filew>Automate menu.

Creating panoramas with Photomerge

Sometimes a snapshot doesn’t adequately portray a scene. (It’s hard to cap-
ture the majesty of the Grand Canyon in a single frame.) For those situations,
take a series of images and combine them into one large panorama with
Photomerge.

The first step in using Photomerge successfully is taking appropriate photos.
Here are some tips:

1~ Use a properly leveled tripod. Use a tripod, making sure that the tripod
is steady and level so the individual photos align properly.

1~ Turn off auto-exposure. If you use your camera’s auto-exposure feature,
each image is actually exposed differently because of the lighting in that
frame. Instead, expose for the center (or most important) photo and use
the same settings for all shots.

1 Don’t use auto-focus with zoom lenses. Auto-focus can change the zoom
factor of the lens. Instead, set the lens to manual focus after using auto-
focus on your most important shot.

1~ Overlap by 25 percent. One-quarter of each shot (on each side) should
overlap so that Photomerge can properly align neighboring images.

When working with images that are properly exposed and have suitable
overlap, Photomerge is fully automated. You open Photomerge (visible in
Figure 10-12), select the images you want to use, select how you want the
component images to interact, click OK, sit back, and watch the magic as the
elements are put into order, aligned, and blended.

When creating a panorama of a room or some other scene that has a definite
this-point-is-farthest-from-the-camera vanishing point, use the Perspective
option. When you use the Perspective option, your panorama might appear
to be pinched in the middle. Choosing the Cylindrical option evens out the
top and bottom and the perceived distance (see Figure 10-13).
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Photomerge
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Figure 10-12: Photomerge aligns and blends your elements automatically.

Figure 10-13: Photomerge using the Perspective option (top) and the Cylindrical option (bottom).
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Combining exposures for HDR images

A rather specialized feature, the Merge to HDR command creates a composite
image of two or more exposures of the same shot, taking the best-exposed
parts of each. You might, for example, take two shots of a room, one exposed
for the room itself and another exposed to capture the detail of the scene
outside the window(s). You can use Merge to HDR take the best of both
images and create a single image. Here’s how:

1. Choose File=>Automater>Merge to HDR.
The Merge to HDR dialog box makes an appearance.

2. Select the images to use.

Make sure the Attempt to Automatically Align Source Images check box
is marked (as shown in Figure 10-14).

Merge to HDR
rce Fil —_—
Source Files P’ oK )
Choose twe or mare files from a set of exposures to
merge and create a High Dynamic Range image Cancel

Use: Files %
CRW_1755.CRW Browse.

CRW_1756 CRW
Remove

¥ Anemat 10 Automatically Align Source Images

Figure 10-14: Select the images to merge and then let Merge to HDR try
to align them.

3. Click OK to open Merge to HDR.

In the upper-right corner of the Merge to HDR window (shown in

Figure 10-15) is the Bit Depth option of creating a more common 16-bit
image or even a highly usable 8-bit image rather than the 32-bits/channel
HDR default. You can also adjust the image’s preview by dragging the Set
White Point Preview slider. Generally speaking, the slider belongs under
the right edge of the histogram, just where the histogram begins to rise.
Keep in mind that the slider only changes the appearance of the preview.
The entire tonal range is still saved and available in a 32-bit image. The
Image=>Adjustments>Exposure command is available in Photoshop to
adjust a 32-bit image, too.
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You can elect to save the response curve, the way in which the particular
images are combined, for future use. Click OK and the image is generated.

If you choose to use the 32-bits/channel option, you can save your image in
one of three file formats:
1 PSD (Photoshop)

1~ PSB (Photoshop’s Large Document format, if activated in Photoshop’s
Preferences)

1~ TIFF

Marge to HOR (305
Louroen Meiged Risa
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Figure 10-15: Merge to HDR creates a single image from multiple exposures.

Keep in mind that not a lot of programs use 32-bit/channel images, and even
your editing capabilities within Photoshop are limited. But ain’t it great to
know the capability is there, just in case someday you need it? Or even if you
never need it?

When shooting images for use with Merge to HDR, use a tripod and disable
auto-focus. Also, the only change to the camera’s settings between shots
should be shutter speed (exposure length). Generally speaking, you’ll want to
work with between two and seven stops of exposure. And keep in mind that
you need actual exposures, not different Exposure settings in Camera Raw.



2 ’8 Part lll: Creating “Art” in Photoshop




1199 7

Precision Edges with Vector Paths

In This Chapter

Understanding vector artwork

Creating objects with shape layers

Making a new path

Changing the shape of an existing path

Editing the shapes of type characters

M ost of the images with which you work in Photoshop — digital photos
and scanned artwork, layers on which you paint, and filled selections —
are created with pixels. There’s also another type of artwork: vector art, which
you create by defining a path (an outline) and adding color within that path.

That path has a very precise edge, enabling vectors (when printed appropri-
ately) to give you very crisp, clean lines in your artwork.

Typically, vector art consists of specific elements (objects)
that are uniform in color (although vector art can also
include gradients). You might have, for example, a red
triangle, a blue square, and a green circle as your logo
(boring!). These three solid-color objects are best
defined as vector artwork. Vectors, however, are not
appropriate for photographic images and other

such imagery that include subtle transitions among
colors.

In Photoshop, you have tools that create predefined
shapes; you have tools that create freeform shapes;
you have tools to edit the paths that define those shapes.
You also have a palette and a bunch of menu commands.
You can even bring in shapes from Adobe Illustrator and
create your own shapes, too. After reading this chapter, you’ll have
a solid understanding of all these bits and pieces. I even tell you where to find
dozens, or even hundreds, of custom shapes already on your computer —
absolutely free!
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Pixels, Paths, and You

\\3

The vast majority of the artwork with which you work (or play) in Photoshop
is raster artwork. Raster imagery consists of uniformly sized squares of color
(pixels), placed in rows and columns (the raster). Digital photos, scanned
images, and just about anything that you put on a layer in Photoshop consists
of pixels. While you edit the image, you're changing the color of the individ-
ual pixels, sometimes in subtle ways and sometimes in dramatic ways.

Vector artwork is a horse of another color. Rather than pixels, vector art consists
of a mathematically defined path to which you add color. In a dedicated vector
art program, such as Adobe Illustrator,
the path produces the shape of the
object, and you add color along the
path (stroke), within the path (fill),
or both to make the shape become an
object. Photoshop simulates vector
artwork using vector paths on shape
layers to hide parts of a layer, so you
can fill the “shape” but not add a
stroke to the path. (A shape layer is
filled with pixels of a specific color, or
which form a gradient or a pattern;
and a vector mask determines what
part of the layer is visible.) Remember
that you can use layer styles in con-
junction with shape layers to simulate
strokes and other effects.

Figure 11-1 shows a fine example of
vector artwork. Observe that each
element in the image consists of a ©PhotoSpin, PhotoSpin image #PI009008
single color. Each section of the Figure 11-1: Each elementin vector art has a
image is easily identifiable as an indi- gjngle specific color.

vidual object, consisting of a specific

color. (Remember, though, that vector objects can
be filled with gradients rather than color.)

Each element in the artwork is defined by its path,
which consists of a number of path segments.

In Figure 11-2, you see the path that defines the
woman’s hair. (You read about the anatomy

of a path later in this chapter, in the section
“Understanding paths.”)

When artwork is defined by pixels, the little square

corners of the individual pixels can be noticeable  Figure 11-2: Paths define the
along curves and diagonal lines. With vector art- outline of an object — the
work, the path is sharp, and the edges are well woman's hair in this case.
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defined. However, to truly get the best appearance from vector art or vector
type, the artwork must be printed to a PostScript-capable device, such as a
laser printer. PostScript is a page-description language that takes advantage of
the mathematical descriptions of vector art. When you print to an inkjet printer,
the vector art is converted to pixels. If you print to such a non-PostScript
device, use a high image resolution for best output — 300 pixels per inch
(ppi) is usually good.

A vector path can be scaled (changed in size) almost infinitely without losing
its appearance. A vector logo can be used for both a business card and a bill-
board without loss of quality because the path is mathematically scaled before
the stroke or fill is added. Raster art, on the other hand, can be severely
degraded by such scaling. For a simple demonstration of the difference
between scaling raster art and scaling vector art, see Figure 11-3.

Type in Photoshop is vector-based: That is, it’s created with paths. Objects in
Photoshop, such as circles and squares that you create with vector paths,

can also be scaled as vector artwork. The paths are recalculated to their new
size and retain their crisp, sharp edges.

Raster, fromm sinall o lage

Raster, from small to large

Raster, from large to small

Rawer, fromm lange w s,

Vector, from small to large

Vector, from small to large

Vector, from large to small

Vector, from large to small

Figure 11-3: Using text as an example shows the advantage of vector artwork when scaling.
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Easy Vectors: Using Shape Layers

If you made it through the preceding section, you're officially an expert on the
theory of vector graphics. It’s time to see how you can actually create these
little devils in your artwork. Keep in mind that a vector shape in Photoshop
actually consists of a shape layer with a path that defines what part of the
layer is visible and what part is hidden. The content of the layer — be it solid
color, pattern, or gradient — is visible within the path and hidden outside the
path. The easiest way to create a shape layer in Photoshop is with the aptly
named shape tools, which automatically create a color-filled layer with a vector
path that shows/hides the layer according to the shape selected. Could you
have it any easier? Just drag a tool and create a vector-based object!

Your basic shape tools

Rectangles, rectangles with rounded corners
(rounded rectangles), circles and ovals, multisided
polygons, straight lines and arrows, and a whole
boatload of special custom shapes are all at your
command with a simple click-drag. Select the appro-

n I:I Rectangle Tool
D Rounded Rectangle Tool

u |
priate tool in the Toolbox, select the appropriate 5 :;r"l :
foreground color, and click-drag to create your _ Line Tool ;
object. (The various shape tools are nested in the . [ Custom Shape Tool U
Toolbox, as shown in Figure 11-4.) Sounds simple, m ol ;
right? It is — no tricks. Here are some additional
features to make things even easier for you: Figure 11-4: The shape tools

are collected in one spotin
1~ Use the Shift key. Pressing the Shift key Photoshop’s Toolbox.

(both Mac and Windows) constrains proportions

(maintains the width-to-height ratio) while you drag. With the Shift key,
the Rectangle tool creates squares; the Ellipse tool creates circles; the
Polygon tool creates proportional polygons; the Line tool creates horizon-
tal or vertical lines (or lines at 45° angles). When using custom shapes,
pressing the Shift key ensures that the shape retains the width-to-height
ratio with which it was originally defined.

1 Use the Option (Mac) or Alt (Windows) key. The Option/Alt key creates
the object centered on the point at which you click. Without the Option/
Alt key, the object is created in whichever direction you drag.

1~ Use the Shift and Option/Alt key. Pressing the Shift and Option/Alt
together helps you create a proportionally constrained object, centered
on the point at which you click.

1~ Use the spacebar. While you're dragging a shape, keep the mouse
button down and press the spacebar. You can then drag to reposition
the object while you create it. Still keeping the mouse button down,
release the spacebar and finish dragging the object.
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1 Check the Options bar. When you switch from shape tool to shape tool,
the Options bar changes to fit your needs. For example, with the
Rounded Rectangle tool active, you choose the radius of the rounded
corners. The Polygon tool offers a simple field in which you choose
the number of sides for the shape. When you’re using the Line tool,
choose the thickness (weight) of the line in the Options bar. And click
the triangle to the right of the shape tool icons in the Options bar to add
arrowheads to the lines.

1~ Change the layer content. After you create a shape layer, you can
change the color of the layer to another color, to a gradient, or even to
a pattern. Use the menu command Layer=>Change Layer Content.

1~ Edit the vector path. As you can see later in this chapter (in the section
“Adding, deleting, and moving anchor points”), you can use the Direct
Selection tool to change the course of the path, altering the appearance of
the shape layer and, therefore, the shape of the object on the shape layer.

1~ Create work paths or pixel-filled shapes. Using the three buttons to the
left on the Options bar, you can elect to create shape layers, work paths,
or add pixels in the selected shape to your currently active layer.

You can easily spot a shape layer

in the Layers palette — especially
when the default layer name starts
with the word Shape. (You can, of
course, change the layer name by
double-clicking it in the Layers
palette.) You can see in the Layers
palette shown in Figure 11-5 that the
shape layer consists of a color-filled
layer (the thumbnail on the left) and
a vector layer mask (the thumbnail
on the right). That vector mask (a
heart-shaped path, in this case) is
also visible in the Paths palette when
the shape layer is selected in the
Layers palette. If you click the
Background layer in the Layers
palette, the Shape 1 Vector Mask in the Paths palette is hidden.

Figure 11-5: Dragging a shape tool creates a
color-filled layer with a path to define a shape.

The Custom Shape tool

Although the basic shape tools are great for circles and squares and lines and
arrows, you'll probably get the most use out of the Custom Shape tool. With this
tool selected, you click the triangle to the right of the sample shape on the
Options bar to open the Custom Shape Picker, as shown in Figure 11-6. The
Custom Shape Picker offers a number of ready-to-use shapes. When you click
the triangle in the upper-right corner, you can choose from a variety of other
sets of shapes listed at the bottom of the Custom Shape Picker menu.
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Figure 11-6: Load additional sets of custom shapes from the list at the bottom of the menu.

When you select a set of custom shapes from the menu (or use the Load
Shapes command to add a set of shapes not in the menu), you are asked
whether you want to add the new shapes to the current content of the palette
(Append), replace the current shapes (OK), or not add the shapes after all
(Cancel). When you load all the custom shape sets that come with Photoshop
CS3, you've got a pretty impressive group from which to choose!

More custom shapes — free!

The custom shapes already available in Photoshop cover a wide range, but
they might not fill all your needs. You can purchase commercial collections of
custom shapes from a couple of sources. You can create custom paths and
define shapes from them, too. But you've already got bunches of custom
shapes on your computer, just waiting for you to use them. Select Photoshop’s
Type tool and take a look in your Font menu. Check out the fonts already
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there with names like Wingdings, Webdings, Symbol, and Dingbats. These are
all examples of symbol fonts, which are fonts that have shapes and symbols
rather than letters and numbers. Many more typical fonts also have special
characters available when you use the Option/Alt key:.

Here’s how you can define a custom shape from a symbol:

1. Choose File=>New to open a new document.

The document can be virtually any size and can be either grayscale
or color.

2. Select the Type tool and pick a font.

With the Type tool active, choose a symbol font from either the

Options bar or the Character palette. The font size doesn’t matter much
because you're creating a vector-based shape that you can easily scale.
The foreground color doesn’t matter either, because shape tools rely on
the foreground color active at the time you create the shape.

3. Type a single symbol and then end the editing session.

Click the check mark button to the right on the Options bar, switch tools
in the Toolbox, or press 38+Return (Mac) or Ctrl+Enter (Windows) to end
the editing session. (The symbol visible in Figure 11-7 can be produced
by pressing the V key when using the font Webdings.)

4. Convert the type character to a shape layer.

With the type layer active in the Layers palette, use the menu command
Layer~>Typer>Convert to Shape.

5. Define a custom shape. m

Choose Edit=>Define Custom niield
Shape, give your new shape a —
name in the Shape Name dialog ﬂ il

box (shown in Figure 11-7), and
save it. Your new shape is added
to the Custom Shape palette, Figure 11-7: Name your new shape and
ready to use. click OK.

Cancel

Later in this chapter, after you master using the Pen tool, remember this sec-
tion. You can also define a custom shape from paths that you create with the
Pen tool — any shape at all!

Remember that your custom shapes aren’t truly saved until you use the Custom
Shape picker menu command Save Shapes (to save all the shapes in the palette
as a single set) or the Edit=>Preset Manager command (to save a set of selected
shapes). In the Preset Manager dialog box, 38+click/Ctrl+click each of your
custom shapes and then click the Save Set button to save them as a set (see
Figure 11-8). Until you take this step, the shapes exist only in Photoshop’s
Preferences file. If the Preferences become corrupt, you could lose all your
custom shapes. This holds true, too, for custom brushes, layer styles,
swatches, and the like — use the Preset Manager to save all your custom items.

Chapter 11: Precision Edges with Vector Paths 2 2 5
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Figure 11-8: Use the Preset Manager to save sets of your custom shapes.
P When saving custom shapes (or layer styles or brushes or any of your other

custom bits and pieces) with the Preset Manager, save them in a folder out-
side the Photoshop folder. That prevents accidental loss should you ever
need to (gasp!) reinstall Photoshop. Figure 11-8 shows one possible folder
structure for saving and organizing your custom bits and pieces.

Changing the appearance of the shape layer

After you use any one of the numerous shape tools in the Photoshop arsenal
to add a shape layer to your artwork, you have a number of ways that you
can enhance, adjust, and simply change its appearance:

1~ Add a layer style. Layer styles,
such as bevels, glows, and
shadows (applied through the
Layer=Layer Style menu),
can certainly spice up a shape
layer. Compare, for example, the
pair of shapes in Figure 11-9.
(Layer styles are presented in
Chapter 12.)

Figure 11-9: A simple layer style makes your
shape jump off the page.
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~ Change the layer content. Via the menu command Layer=>Change Layer
Content, you can select a different color, a gradient, or even a pattern to
fill the shape.

+~ Edit the path shape. Click a path with the Direct Selection tool and drag
to change the path’s shape. (This is discussed in more detail later in this
chapter.)

1~ Change the layer blending mode or opacity. By default, your shape
layer’s blending mode is Normal, and the Opacity is set to 100%. Your
shape layer blocks and hides the content of every layer below. By chang-
ing the blending mode or opacity, you can make your shape layer inter-
act with the layers below in interesting ways. Experiment with different
blending modes to find one that suits your artistic vision. (Blending
modes are covered in more detail in Chapter 10.)

Simulating a multicolor shape layer

Shape layers are typically filled with a single solid color, although you can
use a gradient or a pattern. Sometimes, however, you're better served with a
multicolor shape. Take a look at Figure 11-10 and compare the pair of shape
layers to the left with the same two shapes to the right.

Figure 11-10: Dressing up the shapes can make a world of difference.

In addition to the layer styles applied, layer masks hide parts of the more
elaborate pair of shapes on the right. Like the vector path that hides parts of
a shape layer, a layer mask determines what areas of the layer are visible. You
can use layer masks and vector masks together on a single layer, as you can
see for three of the four layers in Figure 11-11.
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Figure 11-11: Layer masks and vector masks work together to determine layer visibility.

Comparing the color in the left column in the Layers palette to the artwork
helps you identify what you see in Figure 11-11:

1~ Shape 1 copy: This is the top layer and would normally hide everything
on the layers below. The layer, as you can tell from the leftmost thumb-
nail in the Layers palette, is filled with green. The rightmost thumbnail
is the vector mask created by the Custom Shape tool. You can see the
shape’s path in that thumbnail. The middle thumbnail is the layer mask.
By painting with black in the layer mask, you can hide parts of the layer.
In this case, the right part of the shape layer is hidden.

1~ Shape 2 copy: Again, a pair of masks are used together. You can see that
the vector shape is an entire pair of scissors. The middle thumbnail
shows where the layer is hidden by a layer mask, leaving only the blades
of the scissors visible on the gray-filled layer.

1~ Shape 2: This layer requires only the vector path shape. The gray layer
just above hides what would be black scissors blades.

1~ Shape 1: The layers above partially hide the red shape layer. Notice how
because of the order of the layers in the Layers palette, the blades of the
scissors appear to be in front of the red part of the object and behind
the green part of the object.

Adding a layer mask to your shape layer is as easy as clicking the Add Layer
Mask button at the bottom of the Layers palette (third button from the left),
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and then painting with black to hide, white to show, and gray to partially
hide. You can also make a selection in your image and use the Layer=~Layer
Mask menu commands. You can add layer masks to any layer except those
named Background. (You can’t have transparent areas on a background layer,
but you can rename a background layer to convert it to a regular layer.)

Using Your Pen Tool to Create Paths

Even with all the custom shapes available, you might need to create a path
that’s unique to a specific image. For that, Photoshop offers the Pen tool and
its associated tools. Before you start creating paths willy-nilly, you can proba-
bly benefit from a little bit of background information about paths.

Understanding paths

As you click and click-drag, you place anchor points, which connect the path
segments that create your path. Path segments can be straight or curved. You
control those curves not with diet and exercise but rather with direction lines
and their control points. A straight path

segment is bordered on either end =
by corner anchor points, and a curved L
path segment is bordered by two

smooth anchor points or one of each ggg?f)? Control sAmngﬁéhr
type. As you can see in Figure 11-12, Points Gl Points
Photoshop helps you differentiate

between path segments and direction

lines by using squares (hollow and

filled) for anchor points and dia- Figure 11-12: Paths have square anchor points
mond shapes for control points. and diamond-shaped control points.

Only smooth anchor points have direction lines and control points. The angle

and length of the direction line determine the shape of the curve. When you

create a curved path segment between a corner anchor point and a smooth

anchor point, only the smooth point’s direction lines adjust the curve. When

you create a curved path segment between two smooth anchor points, both
<MBER points’ direction lines affect the curve.

Here’s another important way to classify paths in Photoshop:
1 An open path has two distinct and visible endpoints; think of it as a
pencil line or piece of string.
1~ A closed path has no beginning or end — like a circle or an unbroken

rubber band.

When you use a shape tool, you're creating closed paths. When you click-
click-click with the Pen tool, you create an open path — unless, that is, your
final click is back on the very first anchor point.
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Clicking and dragging your way
down the path of knowledge

All that theory about how paths work is fine, but you’ll get a better under-
standing by playing around with the Pen tool. Open a new document

(any size, resolution, and color mode will do) and select the Pen tool.

On the Options bar, click the middle
of the three buttons to the left (as
shown in Figure 11-13) so that the
tool creates work paths rather than
shape layers, and then start clicking

around. Randomly click in various Figure 11-13: Select the left button to create a
places in the image, adding new shape layer, or the middle button to create a
straight path segments as you go. work path.

Use the middle of the three buttons to the left in the Options bar when you
want to create a path. Use the leftmost of the three buttons when you need a
shape layer. The button on the right, for adding pixels to the current layer, is
used only with shape tools.

I'm sure Picasso would be proud, but it’s time to let go of your new artwork
and move on — press Delete (Mac) or Backspace (Windows) twice. The first
time deletes the most recent anchor point; the second time deletes the rest
of the path.

Now, in that same canvas, start click-dragging to create curved path seg-
ments. Watch how the distance and direction in which you drag control
the segment’s curve. Just because it’s fun, try a click-drag and, with the
mouse button held down, move the mouse around and around in a circle.
“Path Jump Rope”! Press Delete/Backspace twice to delete the path.

Now, to get a feel for how to control your curved path segments, try this:

1. Choose File=>New to open a new document.
2. Choose 1024 x 768 from the Preset: Web group.

A reasonable size to work with, it should fit on your screen at 100% zoom.
3. Show the Grid.

Press 8+’ (apostrophe; Mac) or Ctrl+’ (apostrophe; Windows) to show the
Grid in the image. The Grid makes it easier to control the Pen tool as you
drag. You can also show the Grid with the menu command Viewr>Showr>
Grid. In Photoshop’s Preferences=>Guides, Grid & Slices, the Grid shown
in Figure 11-14 is set to Gridline every: 1 inch and Subdivisions: 6.
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Figure 11-14: You don't need to be precise; just more or less follow the four patterns.

4. Select the Pen tool in the Toolbox.
5. Click and click-drag as shown in Figure 11-14.

Don’t worry about precision — you won’t be creating a work of art this
time. Click on the dots in numeric order; where you see a dashed line,
click-drag in that direction for approximately that distance.

You've just created four of the more useful scallops and curve sets! These sorts
of paths can be used in a variety of ways, including stroking, filling, and creating
selections (all of which I discuss later in this chapter) to create decorative
borders and artistic elements in your images.

You should know about a couple of other features of the Pen tool before you
move on. With the Pen tool active, take a look at the Options bar (or look at
Figure 11-15, which shows the Options bar).

§ GE0 [ YENE0I0ION SN s | GF EED
e

Figure 11-15: The Pen tool has a couple of tricks up its sleeve!
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When you have the Freeform Pen
option selected in the Options Bar,
you can click and drag around your [l
image, creating a path as you go. e
It’s much like painting with the Brush
tool or drawing lines with the Pencil
tool — wherever you drag the tool,
the path is created.

CNET - BEY - FEEERY T

The Freeform Pen offers the Magnetic
option, too. When you need to make
a path (or selection) around the out-
side of something of uniform color
in your image, using the Magnetic
option forces the path to look for
and follow edges. Take a look at
Figure 11-16, which shows an exam-
ple of an appropriate use for the
Freeform Pen and the Magnetic
option.

FUNE LBl reORNFN0 Na Tl

A closer look at the
Paths pa[ette Figure 11-16: Tracing a uniformly colored

objectis a great job for the Freeform Pen using

You can save, duplicate, convert, the Magnetic option.

stroke, fill, and delete paths via the

Paths palette (which, like all palettes, you can show and hide through the
Window menu). You can even create a path from a selection by using the
Paths palette. Without the Paths palette, your paths have no meaning or
future and probably won’t get into a good university or even a good collage.

Pick a path, any path

The Paths palette can hold as many paths as you could possibly want to add
to your artwork. You can also see the six buttons across the bottom of the
palette that you use to quickly and easily work with your paths. You can clas-
sify paths in the five different ways shown in Figure 11-17.

You might not use them all, but it’s good to know the five types of paths:

1 Work path: As you create a path, Photoshop generates a temporary
work path, which is not automatically saved. Unless you save your path,
it’s deleted as soon as you start to create another path or when you
close the file. To save a work path, simply double-click the name field in
the Paths palette and type a new name.
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Figure 11-17: The Paths palette is your key to organizing and controlling
vectors in your artwork.

1~ Saved path: Much like working in the Layers palette, you can double-
click the name of any path and rename it in the Paths palette. (You must
rename a work path in order to save the path for later use.) After you
give the path a name, it’s safe from accidental deletion.
1~ Clipping path: Clipping paths are used primarily with page layout pro-
grams, such as Adobe PageMaker and QuarkXPress. Much like how a

shape layer’s vector path determines what parts of the layer are visible,
a clipping path identifies what part of the image as a whole is visible.
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You won'’t need a clipping path when you work with Adobe InDesign —
simply create your image on a transparent background and place that
Photoshop file into an InDesign document. To create a clipping path,
first make your path, give it a name in the Paths palette (to save it), and
then use the Paths palette menu command Clipping Path.

1~ Shape layer path: When a shape layer is active in the Layers palette, its
vector mask path is visible in the Paths palette. If you want to customize a
shape layer’s path, you need to make the layer active first. When a shape
layer path is visible, you can drag it to the New Path button at the bottom
of the palette to create a duplicate. (It’s the second button from the right.)

1~ Vector mask path: When a regular layer has a vector mask assigned and
that layer is visible in the Layers palette, the layer’s mask path is visible
in the Paths palette.

When creating a clipping path, leave the Flatness field completely empty unless
your print shop specifically instructs you to use a specific value. The Flatness
value overrides the output device’s native setting for reproducing curves.
Using the wrong value can lead to disastrous (and expensive!) mistakes.

To activate a path in the Paths palette, click it. You can then see and edit the
path in the image window. With the exception of shape layer and vector mask
paths, the paths in the Paths palette are independent of any layer. You could
create a path with the Background layer active and then later use that path
as the basis for some artwork on, for example, Layer 3.

The Paths palette buttons

The six buttons across the bottom of the Paths palette (refer to Figure 11-17)
do more than just simple palette housekeeping. Use them to create artwork
from a path and to convert back and forth between paths and selections.

v~ Fill Path: Click a path in the Paths palette and then use this button to fill
the area inside the path with the foreground color. If you fill an open
path (a path with two distinct endpoints), Photoshop pretends that
there’s a straight path segment between the endpoints. The fill is added
to the active layer in the Layers palette. If a shape layer or a type layer
is selected in the Layers palette, the Fill Path button isn’t available.
You can see filled (and stroked) paths in Figure 11-18.

1~ Stroke Path: Click a path in the Paths palette and then use this button
to add a band of the foreground color along the course of the path.
Most often, you can think of it as painting the path itself with the
Brush tool. If you have a different brush-using tool active in the Toolbox
(Clone Stamp, Healing Brush, Dodge, Burn, Eraser, and so on), the path
is stroked with that tool. Like a fill, a stroke is added to the currently
active layer in the Layers palette. You can’t stroke a shape layer path.
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You can, however, duplicate such a path and stroke the copy on another
layer. Take a look at Figure 11-18 to see how stroking and filling differ.

1~ Selection from Path: When you have a path selected in the Paths palette,
you click this button, and voila! An instant — and very precise — selection
is at your disposal. You can create a selection from any path. If you want
to add feathering to the selection, use the Paths palette menu command
Make Selection rather than clicking the Selection from Path button.

1~ Path from Selection: You can create a work path from any selection
simply by clicking this button. If the path isn’t as accurate as you’d like,
or if it’s too complex because it’s trying to follow the corner of every
pixel, use the Paths palette menu command Make Work Path and adjust
the Tolerance setting to suit your needs.

1~ Create New Path: You'll likely use this button primarily to duplicate an
existing path. Drag any path to the button, and a copy is instantly avail-
able in the Paths palette. When you click this button, you’re not creating
(or replacing) a work path but rather starting a new saved path.

1~ Delete Path: Drag a path to the Delete Path button or click the path and
then click the button. Either way, the path is eliminated from the palette
and from your artwork.

Figure 11-18: Think about whether you want to stroke first (left) or fill first (right).

\‘&MBEH The order in which you stroke and fill a path can make a huge difference in
& the appearance of your artwork. The stroke is centered on the path, half
inside and half outside. The fill extends throughout the interior of the path.
If you stroke a path and then add a fill, the fill covers that part of your stroke
that’s inside the path. As you can see in Figure 11-18, that’s not always a bad
thing. (Both paths are visible for comparison purposes — normally only one
path is active at a time.)
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Keep in mind that Photoshop doesn’t really create vector objects. If you
stroke or fill a path and then edit the path itself, the stroke and fill don’t
move with the path — they stay right where they are, as pixels on a layer.
If you're used to working with vectors in Illustrator, this can be a nasty
surprise.

Sometimes the easiest and fastest way to create a complex path is to make a
selection and convert the selection to a path. You might, for example, click
once with the Magic Wand and then click the Selection from Path button at
the bottom of the Paths palette. Remember to rename the path to save it!

Customizing Any Path

Photoshop gives you a lot of control over your paths, not just when creating
them, but afterward, as well. After a path is created, you can edit the path
itself. While the path is active in the Paths palette, the Edit=>Transform Path
commands are available, giving you control over size, rotation, perspective,
skewing, and even distortion. But there’s also much finer control at your fin-
gertips. You can adjust anchor points, change curved path segments, add or
delete anchor points, and even combine multiple paths into compound paths,
in which one path cuts a hole in another. (Think donut.)

Adding, deleting, and moving anchor points

Photoshop provides you with a number of tools with which to edit paths,
although you might never use a couple of them. Consider, for example, the
Add Anchor Point and Delete Anchor Point tools shown in Figure 11-19.

Now take a look at the Option bar’s Auto Add/Delete option. With the Pen
tool active, you automatically switch to the Delete Anchor Point tool when
over an anchor point, and automatically switch to the Add Anchor Point tool
when the cursor is over a path segment. Smart tool, eh? The Convert Point
tool, on the other hand, can be invaluable . . . or valuable, at least. Click a
smooth anchor point to convert it to a corner anchor point. Click-drag a
corner anchor point to convert it to a smooth point.

Nested in the Toolbox with the Path Selection tool (which you use to select
and drag a path in its entirety), the Direct Selection tool lets you alter individ-
ual path segments, individual anchor points, and even the individual direc-
tion lines that control curved path segments.

When you click an anchor point with the Direct Selection tool, you can
drag it into a new position, altering the shape of the path. If it’s a smooth
anchor point, clicking it with the Direct Selection tool makes the point’s
direction lines visible (as well as those of immediately neighboring smooth
anchor points).
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Figure 11-19: Photoshop gives you every tool you need to edit vector paths.

The Direct Selection tool has no user-definable options on the Options bar.
It’s a pretty straightforward, no-nonsense tool that follows a few simple rules
of behavior (which you can see illustrated by pairs of “before” and “after”
paths in Figure 11-20):

1+~ Drag a path segment. Drag a path segment with two corner anchor
points, and you drag those points along with you. If the path segment
has one or two smooth points, you drag the segment (reshaping the
curve), but the anchor points remain firmly in place. Note in Figure 11-20
(upper left) that when you drag a curved path segment, the adjoining
direction lines change length, but they retain their original angles.

1+ Drag a corner anchor point. Click a corner anchor point and drag, and
the Direct Selection tool pulls the two adjoining path segments along
with it. As you can see in Figure 11-20 (upper center), the other two
anchor points (and the path segment between them) are unchanged.

1 Drag a smooth anchor point. When you drag a smooth anchor point, all
four of the direction lines associated with the path segments on either
side retain both their lengths and their angles. The direction lines don’t
change; only the curved path segments connected at the smooth anchor
point are altered. In Figure 11-20 (upper right), the path continues to
flow smoothly through the anchor point, even as the point moves.
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1 Drag a smooth point’s direction line. Dragging a direction line changes
the curves on either side of the anchor point so that the path still flows
smoothly through the point. (Remember that you click the control point
at the end of a direction line to drag it.) Figure 11-20 (lower left) illustrates
how the path segments on either side of the smooth point adjust as the
direction line is changed. However, paths don’t always flow smoothly
through a smooth anchor point — not if you use the following trick!

1~ Option+drag/Alt+drag a direction line. Hold down the Option/Alt key
and drag a smooth anchor point’s direction line, and you’ll break the
flow of the path through that point. With the Option/Alt key, you change
only the path segment on that side of the anchor point, leaving the
adjoining path segment unchanged. In Figure 11-20 (lower right), the
direction line on the left is being dragged without the Option/Alt key.
On the right, adding the modifier key preserves the appearance of the
adjoining path segment.
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Figure 11-20: The pairs of paths are shown in color for illustrative purposes only — paths
are generally black when active.

You can use the Shift key with the Direct Selection tool to ensure that you're
dragging in a straight line. You can also use the Shift key to select multiple
anchor points before you drag.

Combining paths

As you've probably noticed through the course of this chapter, some paths
are very simple (like the paths in the preceding figure), and some paths are
more complex (like the shapes shown earlier in Figure 11-11). Complex paths
are often compound paths: that is, paths that contain two or more paths
(called subpaths) that interact with each other. Think about a pair of circles,
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different sizes, centered on top of each other. What if the smaller circle cut a
hole in the middle of the larger circle, creating a wheel (or, depending on how
early you're reading this, a bagel)? Take a look at Figure 11-21.

=2 | Paths x_|

Figure 11-21: Two (or more) paths can interact with each other, creating
a compound path, consisting of two or more subpaths.

There are several ways in which two (or more) paths can interact.
Complete this sentence with terms from the following list: “The second

path can (fill in the blank) the original path.”

1~ Add to: The areas within the two subpaths are combined as if they were
within a single path.

1~ Subtract from: The second path is used like a cookie cutter to delete an
area from within the first path. (When you need to make a bagel, this is
the option!)

1~ Intersect with: Only the areas where the two subpaths overlap is retained.

1 Exclude from: All the area within both subpaths is retained except
where the two paths overlap.

239
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When any shape tool or the Pen tool is active, the Options bar presents you
with four buttons to determine the behavior of multiple paths. (The first path
that you create will always be just a normal path. The buttons don’t come into
play until you add additional subpaths.) Figure 11-22 shows you the buttons,
tells you which is which, and provides a simple graphic representation to
demonstrate the interaction. The upper-left path is the original, with the lower-
right path showing how each option controls the interaction between subpaths.
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Figure 11-22: The buttons control how a second path (and any subsequent paths) interact with
your original path.

Tweaking type for a custom font

I want to show you one more little thing you can do with vectors in Photoshop,
a last bit of fun before this chapter ends. Each individual character in a font
consists of paths. You can convert the type to shape layers (or work paths)
and change the appearance of the individual characters by editing their paths
with the Direct Selection tool.

1. Open a new document in Photoshop.
2. Select 800 x 600 from the Preset menu and then click OK.
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. Select the Horizontal Type tool in the Toolbox and set the font.

From the Options bar, choose Arial, set the font style to Bold, set the
font size to 72, choose Sharp for anti-aliasing, left-align, and click near
the lower left of your document.

Okay, in all honesty, you can use just about any settings you want — but
if you use these settings, your image will look a lot like mine.

. Type the word Billiards in your image.
. Press 3+Return/Ctrl+Enter to end the text-editing session.
. Choose Layer~>Type~>Convert to Shape.

This changes the type layer (editable text on its own layer) to a shape
layer (a layer filled with color, with only those areas within the vector
path visible in the artwork).

. Activate the Direct Selection tool.
. Edit the shapes of the Ls and the D to simulate billiard cues.

Drag the uppermost anchor points even farther upward to create cue
sticks.

See the result in Figure 11-23.

Figure 11-23: You can convert vector type to shape layers and edit the individual
character shapes with the Direct Selection tool.
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Dressing Up Images
with Layer Styles

In This Chapter

Understanding layer styles

Applying layer styles with the Styles palette
Creating your own styles

Preserving your custom layer style

In artwork and photography, you use shadows and highlights in your image
to produce the illusion of depth. Highlights and shadows lead the viewer
to imagine that a light is falling on parts of a 3D object. You can also use a
shadow or glow to make it appear that some distance exists between

one object in the image and another object behind it.
Photoshop’s built-in layer styles help you add shadows,
glows, and other effects almost instantly.

In this chapter, I explain how transparent areas on
layers enable lower layers to show through and

let your layer styles appear on those lower layers.
You get a good look at the Styles palette and

how you use it to store and apply layer styles,
including your very own custom styles. I then pre-
sent the all-important (for layer styles) Layer Style
dialog box and the various effects that you can add
with it. I also show you how to save (and protect) your
custom layer styles.
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What Are Layer Styles?
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A layer style comprises one or
more effects that surround or are
applied to all the pixels on your
layer. Effects that surround pixels
include strokes (thin or thick out-
lines of color), shadows (just like
the one this book is casting right
now on your desk or lap), and
glows (outlines of semitranspar-
ent color). Effects that are applied
to pixels include overlays of color,
patterns, or even gradients. But
Photoshop offers even more,
including the ever-popular

Bevel and Emboss effect, which
does a great job of giving the
content of your layer a 3D look.
And, of course, effects can be
used in combination; check out
Figure 12-1 for some examples.
You can add effects to layers in
several ways, including through
the Layer Style menu at the
bottom of the Layers palette, as
shown in Figure 12-2. I explain Figure 12-1: Strokes, shadows, overlays, and
each of the effects individually bevels are just some of the effects available.
later in this chapter in the section on creating your own custom layer styles.

Just so everyone is on the same sheet of music, when you refer to a drop
shadow or an outer glow or a color overlay or any one of the other items
shown in the menu in Figure 12-2, call it a layer effect or simply an effect.

After you apply an effect to a layer or save it in the Styles palette (which I dis-
cuss a bit later in this chapter), it becomes a layer style. A layer style can include
one effect or several effects. The
individual layer effects are built into
Photoshop, but you can add or delete
layer styles and even create your own.
By the way, Blending Options, at the
top of the list in Figure 12-2, isn’t
actually a layer effect, but rather it
governs how the colors of the pixels
on the selected layer interact with
pixels on layers below. The black dots
to the left of some effects listed in
Figure 12-2 indicate that those effects Figyre 12-2: You can add a layer style through
are already applied to the layer. the Layers palette.
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Some layer effects, such as drop shadows and outer glows, appear outside
the content of the layer. For those effects to be visible in your artwork, the
layer must have at least some area of transparent pixels. If the layer is filled
edge to edge, the effect has no place within the image to appear because the

glow or shadow would logically be
outside the image’s canvas. Take a
look at a couple of layer style exam-
ples in Figure 12-3.

In the sample on the left, you can
imagine that the shadow logically

also appears to the lower right of the

object as a whole (as it does in the
sample to the right). However, that’s
outside the image’s canvas, so that

the artwork.

B £ O O] Chiry.sd & 1000 iLavar 1, RER

B 1 O O Chawy copy.pad § LUK fLayer |

Figure 12-3: Some layer effects need
part of the shadow doesn’t appear in transparent areas on the layer, or they won't

appear.

Keep in mind that every layer in an image has the same number of pixels —
but some of those pixels can be transparent. When a layer has areas of
transparency, layers below in the image can show through. In the two
examples in Figure 12-3, the yellow background layer is visible, giving

the upper layer’s shadows a place to fall. (And remember that a layer named
Background can’t have areas of transparency. Convert it to a regular layer
by double-clicking the layer name in the Layers palette and renaming it.)
Chapter 10 is full of information on working with layers.

the Styles Palette

The Styles palette is, by default,
nested with the Color palette

and Swatches palette. Choose
Window=>Styles to make it visible.
This palette, which you see with its
menu open in Figure 12-4, is where
you find and store layer styles and is
the easiest way to apply a layer style
to your active layer.

To apply a layer style via the Styles
palette, make the target layer active
by clicking it in the Layers palette;
then click the style that you want to
apply. It’s truly that simple! To
remove a layer style from the active
layer, click the leftmost button at the
bottom of the Styles palette. You can
click the middle button to save a
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Save Styles..,
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Abstract Styles
Buttons
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Image Effects
Photographic Effects
Text Effects 2

Text Effects
Textures

Web Styles

Figure 12-4: The Styles palette holds your
preset and saved layer styles.
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custom layer style (which I explain later in this chapter), and you can drag a
layer style to the Trash icon on the right to delete it from the palette.

Take a look at the Styles palette menu, starting from the top and making your
way down to the bottom. The first command simply adds the style applied to
the active layer to the palette (like clicking the Create New Style button).
(Refer to Figure 12-4.)

In the second section of the menu, you can choose from five different ways to
view the content of the Styles palette. The Text Only, Small List, and Large
List options might come in handy after you create a bunch of custom styles
with names you recognize, but until you become familiar with the styles in the
palette, their names are pretty much meaningless. The Large Thumbnail option
gives you a better view of the effects in the style, but you see fewer styles at a
time in the palette than you can with the default Small Thumbnails view.

The Styles palette Preset Manager command opens the same Preset Manager
that you access through the Edit menu. Use the Preset Manager (discussed at
the end of this chapter) to save custom styles in sets on your hard drive to
protect them from accidental loss.

The next four commands in the Styles palette menu are what I call
“housekeeping commands” because you use them to control the content
of the palette:

1~ Reset Styles: The Reset Styles command returns the content of the
palette to its default. You have the option of adding the default set to the
current palette content with the Append button or replacing the current
content with the selected set by clicking OK.

1~ Load Styles: Use the Load Styles command to add custom styles from
your hard drive (or another location). You can even purchase prepared
sets of layer styles on CD. The set is added to the current content of the
palette automatically.

1~ Save Styles: The Save Styles command lets you save the current content
of the palette as a set of styles. All the layer styles in the palette at the
time are saved in the set.

1~ Replace Styles: Use the Replace Styles command to remove the current
content and then add the selected set.

At the bottom of the Styles palette menu, you can find a list of all the layer
style sets saved in Photoshop’s PresetsmStyles folder. When you select a set
from that list, you have the option once again of appending or replacing the
current content of the palette. (The list in your Styles palette menu might
differ from what’s shown in Figure 12-4.)
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Creating Custom Layer Styles

You create a custom layer style by applying one or more layer effects to your
active layer. (Once again, remember that you can’t apply layer effects or layer
styles to a layer named Background.) When you have the effects looking just
the way you want them, you can add that new style to the Styles palette and
even save it for sharing with friends and colleagues. Combining multiple layer
effects lets you create complex and beautiful layer styles that change simple

shapes and text into art.

Exploring the Layer Style menu

In addition to the pop-up menu at the [
bottom of the Layers palette (refer to ey »

7 Duplicare Layer...
Figure 12-2), you can apply layer Delete >
effects through the Layer->Layer Style Laver Properties...
menu. As you can see in Figure 12-5, Blanding Options...
the Layer Style menu has a few more v Drop Shadow...
commands than the menu at the it M e
bottom of the Layers palette. Change Layer Content » | lnner Glow.

Layer Content Options... + Bevel and Emboss...
Satin...

The ten items in the Layer Style menu LEpa Mg Color Overlay...

. s Vecor Mask Cradient Overlay...
below Blending Options are the Create Clipping Mask  XXG | , prvern overtay.
actual layer effects. A check mark to Smart Objexts » ¥ Stroke...
the left of the effect indicates that it’s el Copy Layer Style
currently applied to the active layer. i T :::":
The Copy Layer Style and Paste Layer RAsmize e
Style commands come in handy, but New Layer Based Siice Create Layers
if you're more mouse-oriented than Group Layers %G | Hide All Ellects

s ) . . . Scale Effects..
menu-oriented, you'll find it easier to Tl TR

add the style to the Styles palette

and click the style to apply it to other Fgigyre 12-5: You can use the Layer Style menu

layers. You can also Option/Alt+drag
a layer style from layer to layer in the

to apply layer effects and more.

Layers palette to duplicate it. Clear Layer Style is the equivalent of using the
leftmost button at the bottom of the Styles palette — it removes all layer
effects from the target layer. The four commands at the bottom of the menu

are worthy of a little special attention:

1 Global Light: A number of layer effects are applied at an angle. Drop
shadows, for example, simulate light coming from a specific angle
(which, of course, determines where in your artwork that shadow falls).
You use the Global Light command to set the default angle at which
your effects are applied. Generally speaking, you want the angle to be
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consistent from effect to effect and from layer to layer in your artwork.
There are exceptions, however, such as the situation shown in Figure 12-6.
In that artwork, the two type layers have shadows receding at different
angles to simulate a light source positioned immediately in front of and
close to the image. (As you can read in the next section of this chapter,
when you use layer effects that are applied at an angle, you have the
option of using or not using the angle in Global Light.)

1~ Create Layers: Sometimes you need to edit a layer effect — say, to control
where a drop shadow falls on the lower layers in the image. The Create
Layers command rasterizes each layer effect (adds it to the image as a
separate layer or layers containing pixels). You can then erase portions
of the new layers, apply artistic filters, or otherwise customize each effect
layer. Remember that after a layer style is rasterized with this command,
you can no longer edit it through the Layer Style dialog box, but the orig-
inal style (if you added it to the Styles palette) is still available.

1~ Hide All Effects: You can temporarily hide a layer style with the Hide
All Effects command. Alternatively (and more conveniently), you can
click the eyeball icon next to the layer style in the Layers palette to hide
the effects.

1~ Scale Effects: Use the Scale Effects command to uniformly make the
layer style larger or smaller.

Figure 12-6: Sometimes shadows in your artwork shouldn't all use the
Global Light setting.
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Exploring the Layer e ——
Style dialog box | =2 o
The first step in creating custom layer o SR Semar
styles is to become familiar with the e e — i

individual layer effects. Each of the . -
ten effects available in the Layer Style .
dialog box (see Figure 12-7) has its
own set of options. Most of the basic
default values are very good starting
points: You might need to change
only a color or perhaps adjust a Size,
Distance, or Opacity slider. You can,
of course, do lots and lots of cus-
tomizing for some of the effects.

Figure 12-7: The Layer Style dialog box has
separate options for each layer effect.

In the column to the left in the Layer Style dialog box, you can select a check
box to apply the effect, but you need to click the name of the effect to open that
effect’s options pane. In Figure 12-7, the check marks show that this particular
layer style includes a drop shadow, bevel, color overlay, pattern overlay, and
stroke. The options pane for Bevel and Emboss is visible, as you can tell by the
highlighting in the left column (not to mention the subtle Bevel and Emboss in
bold at the top-center of the dialog box). And in the far right of the Layer Style
dialog box, note the Preview check box (upper right, which shows what the
layer style will look like) and the small sample just below. That sample shows
how your style will look when applied to a square about 150 x 150 pixels.

As you read the descriptions of the various sets of options, keep in mind
some generalities about a few key options that you’ll see a number of times:

1 Color Selection: When you see a color swatch — a small rectangle or
square, usually near the Blending Mode option — you can click it to
open the Color Picker and select a different color.

1~ Noise: When you see the Noise slider, you can add a speckling effect to
help diffuse a glow or shadow.

1~ Contour: Glows, shadows, and the like can be applied linearly, with a
steady fade from visible to not visible. Or you can elect to have that transi-
tion vary with a nonlinear contour. Generally speaking, nonlinear contours
can be great for bevels, but linear is usually best for shadows and glows.

1~ Angle/Use Global Light: You can change the angle for several layer
effects by entering a specific angle in the numeric field or by dragging
in the circular Angle controller. If the Use Global Light check box is
selected, you change all the angles for that layer style.

249
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The key blending modes

Photoshop offers over two dozen different blend-
ing modes, many of which you see in the Layer
Style dialog box. You really need only a few on
a regular basis, although it's always fun to
experiment with the others, just in case one of
them gives you a cool effect.

The Multiply blending mode generally darkens.
When working with dark shadows or glows,
choose the Multiply blending mode so that the
layer effect darkens (but doesn't hide com-
pletely) the pixels on the layers below. The
Screen blending mode lightens. Use Screen
with light glows and other such effects. The
Overlay blending mode is a mix of Multiply and

Screen. When working with patterns that con-
tain both dark and light colors, you might opt for
Overlay as the blending mode.

Of course you should remember the Normal
blending mode, too! If you want a glow or
shadow to completely block whatever lies
below, choose Normal at 100% opacity. You
might also want to use Normal with a somewhat
lower opacity for a uniform coverage over both
dark and light pixels. And don’t be afraid to
experiment — run through the blending modes
(and opacity settings) to see whether you can
tweak that custom style just a little more.

Layer effects basics

In this section, [ explain the basics of each of the ten layer effects, showing
the options available in the Layer Style dialog box for that effect in an
insert, as well as one or more examples. And don’t forget to take a look at
the sidebar, “The key blending modes.” Later in this chapter, you can read
about the Opacity and the Fill sliders as well as some other advanced blend-

ing options.

Drop Shadow

A drop shadow is a great way to separate the content of one layer from the rest

of the image, as you can see by comparing the two versions of the artwork in
Figure 12-8. In effect, the content of the target layer is copied, converted to
black, and placed behind your layer. The blending mode and opacity deter-
mine how the shadow interacts with the layers below. You decide how much

to offset and blur the duplicate with the sliders. (Remember that this is a layer

style, so no second layer is actually added to your image.) You’'ll generally
want to leave the Contour option of your drop shadows set to the linear
default. Drop shadows are great with type layers!

Inner Shadow

You can do a couple of things with the Inner Shadow layer effect, as you can
see in Figure 12-9. Compare the two sets of options. On the left, a soft, light-
colored inner shadow using the Screen blending mode softens edges. On the
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right, a hard inner shadow, using a dark color and the Multiply blending
mode, produces a totally different look. The layer effect is applied to the red
shape on the upper layer.

[~ [rererar——0—

Figure 12-8: Drop shadows can visually separate the upper layer from the lower layer.
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Figure 12-9: Inner shadows can be soft or hard, light or dark.
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Outer Glow

The Outer Glow layer effect is much like a nondirectional shadow when
applied using a dark color. However, it also has a variety of uses with a light
color and the Screen blending mode. As you can see in Figure 12-10, it has
practical and whimsical uses. (Please remember that in real life, stars do not
appear between the horns of a crescent moon!)

In the Structure area at the top of the Outer Glow options, you can select the
blending mode and opacity, add noise if desired, and select between a color
(click the swatch to open the Color Picker) or a gradient (click the sample

to open the Gradient Editor). You define the size and fade of the glow in the
Elements area. The Technique pop-up menu offers both Softer and Precise —
try them both. And don’t overlook the options at the bottom, in the Quality
area. Although you use Jitter only with gradients to add some randomness,
the Range slider is an excellent way to control the distance at which your
glow is offset. And when you get a chance, play with different contours for an
Outer Glow effect.

Duter Clow Cuter Clow
Structure Structume
Pand Mode | Screen [C] Band Mot | Soeee ]
Oopacity - 75 L | Oasuity “ 7 %
Noie & ] X Koise & 0 x
L] | E‘. -] :
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Taceque | Somer  18) Tecnnigur | Sone )
Seraag = 17 L] Toread 0 ®
Kig = T dae - 0 i
Quality Quadlity
Conosr = Anti-piased Combou W Ast-adased
Kange - 0 Range - 50 %
Jrimr Q X [y 0 L

Figure 12-10: An Outer Glow layer effect is a multipurpose layer effect.
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Inner Glow

The Inner Glow effect offers you the same control as an Outer Glow, with the
impact of an Inner Shadow. As you can see in Figure 12-11, an Inner Glow can
be the base for a neon glow style. (Add an Outer Glow effect, perhaps a
Stroke effect, and there you go!)
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Figure 12-11: Inner Glow offers more control than Inner Shadow.

You can also develop some rather amazing styles by using the Inner Glow and
the Inner Shadow in combination. Using similar Size settings and varying the
colors and blending modes let you overlay a pair of effects in combination.
And when you play with Inner Glow and Inner Shadow in combination, don’t
overlook the Contour variations.

Bevel and Emboss

Perhaps the most fun of all the Photoshop layer effects, Bevel and Emboss is
a quick and easy way to add a 3D look to your artwork. You can apply a Bevel
and Emboss layer effect to text or to buttons for your Web site. You can also
use this effect to create more complex elements in your artwork, examples of
which appear in Figure 12-12.
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Figure 12-12: The Bevel and Emboss layer effect is very versatile.

When you feel the need and have the time to let your imagination frolic through
the fertile fields of Photoshop fun, filters are first, but the Bevel and Emboss
layer effect follows fruitfully. Take the time to play with the various settings in
the Bevel and Emboss pane of the Layer Style dialog box to see what they do.
Add a new layer, create a simple shape (perhaps with one of the shape tools),
select Bevel and Emboss from the pop-up menu at the bottom of the Layers
palette, and experiment — that’s a far more efficient way to get to know this
effect than reading technical explanations of each of the options. (One caveat:
You won'’t see any change in your layer with the Stroke Emboss style unless
you're also using the Stroke layer effect.) Don’t forget to play with the various
Gloss Contour presets!

As you read this book, keep an eye out for the Bevel and Emboss layer effect.
When you come across a bevel or emboss effect, such as those shown in
Figure 12-13, you might want to take a moment to remember your experimen-
tation and think about what settings I might have used.

Satin

The Satin layer effect uses the shape of the object to produce a wavelike
overlay. As you can see in Figure 12-14, it’s more effective with type and
complex shapes than it is with large, plain shapes.
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Figure 12-13: Many illustrations in this book use the Bevel and Emboss layer effect.
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Figure 12-14: The Satin layer effect is very effective with complex shapes.
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Color Overlay

The key to using the Color Overlay layer effect is the blending mode. (See the
sidebar, “The key blending modes.”) When you use Normal, in effect, you
paint all the pixels on the layer with the selected color. To blend the color
with the original artwork or other effects (such as pattern overlays), choose
an appropriate blending mode — Multiply with dark colors, Screen with light
colors — or simply experiment with blending modes. However, using the
Color Overlay layer effect with the Normal blending mode in a custom layer
style is a good way to ensure consistency in artwork, such as buttons and
banners for a Web site.

Although you’ll generally find Color Overlay most useful for simple shapes in
artwork and on Web pages, you can certainly use it for more exciting effects,
such as the effects shown in Figure 12-15. The original is in the upper left, and
each example shows the color and blending mode selected. Remember that
when you use a layer effect, you can later return and alter or remove that
change from your image.

Wend Mode: Color bun T3
Opacity. = T

Figure 12-15: Color Overlay can produce subtle or dramatic changes in your artwork.
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Gradient Overlay

Unlike the Gradient Map adjustment (see Chapter 6), which applies a gradi-
ent to your image according to the tonality of the original, the Gradient
Overlay effect simply slaps a gradient over the top of the layer content,
using the blending mode and opacity that you select. You also control the
shape of the gradient, the angle at which it’s applied, and the gradient’s scale
(see Figure 12-16).
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Figure 12-16: In keeping with its name, the Gradient Overlay effect overlays a gradient.

SMBER
@“‘ When working with gradients, you click the triangle to the right of the gradient

sample to open the Gradient palette. You directly click the gradient sample
itself to open the Gradient Editor.

Pattern Overlay

Like the Color Overlay layer effect, Pattern Overlay relies on the blending
mode and opacity settings to determine how the artwork (pattern) that it
overlays interacts with your original artwork. As you see in Figure 12-17,
you can scale the pattern, align it to the upper-left corner of your image
(with the Snap to Origin button), and link the pattern to your layer so that
the appearance of your artwork doesn’t change as you drag the layer into
position. Click the triangle to the right of the sample pattern to open the
Pattern palette and then select a pattern.



2 5 8 Part lll: Creating “Art” in Photoshop

3

Paitern Overlay
Pattern

CA \ : GRS

Scalg: mlr— e %

n
LI Bales

Pattern Overlay
Pattern
Blend Mode: Normal »
Opacity 100 %
Paitern

ﬂi al ( SrapwOrgin

Scalg. =0 (300 |%
¥ Link with Layer

Figure 12-17: The Pattern Overlay layer effect adds texture to your layer’s artwork.

Stroke

If you've read this chapter to this point, you've seen the Stroke layer effect
for several pages now. Each of the insets from the Layer Style dialog box in
the preceding figures has a one-pixel black Stroke layer effect applied. Adding
that tiny stroke helps set off the dialog box from the background.

Not only is Stroke a handy and practical production tool, but it’s a wonderful
creative effect, too, especially when you use it in conjunction with other layer
effects. For example, a stroke of a contrasting color is a great way to redefine
the edge of your object when working with an outer glow and an inner
shadow. (In the Stroke effect’s options, remember that you click the color
swatch to open the Color Picker.) A simple stroke can convert even the
plainest text into an eye-catching statement. And don’t forget that without
the Stroke effect, the Bevel and Emboss effect’s Stroke Emboss option does
nothing for your artwork. Figure 12-18 has a few examples.

Opacity, fill, and advanced blending

In the Blending Options area of the Layer Style dialog box and the upper-right
corner of the Layers palette, you see a pair of adjustments named Opacity
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and Fill, as shown in Figure 12-19. Both have an impact on the visibility of the
content of your layer.

Figure 12-18: The Stroke effect can stand alone or be used with other layer effects.

Layer Style
Blending Options [ —
Sxaies Gom::l Slanding o
Blending Options: Default Send Mode: [ ormal 0 Cancel

- Drop Shacow
= Inner Shadow IOM = ‘l ::m
= Outer Glow ) wd Slending
- Innes Clow Fill Opacity 100 %
= Bevel and Emboss Channels. IR WC W8 .

Z Contour Knockout: [None  18)

) Texture Blend interior Effects -AVerS 2
~ Satn gm Ciiooed Layers Nomsl |

T -
= Color Overtay :;‘,:.".3::‘:3'.'."3: LoacEIFFHE) | Atiox])
- Cragmnt Overiay Vector Mask Hides Ef
 Pattern Overiay = .
B senor: Gy 9)
ThisLiver 0 255
-
underiying Liver 0 255

Figure 12-19: The Opacity and Fill sliders control visibility of a layer.
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When you reduce the Opacity setting for the layer, you make the layer con-
tent and any layer style partially or completely transparent. Reducing the Fill
slider changes the opacity of the pixels on the layer but leaves any layer
effects fully visible. When might you want to use the Fill slider? The first thing
that comes to mind is when creating the ever-popular Glass Type technique,
which produces see-through text that’s perfect for your copyright notice on
any image:

1. Add some text to an image with the Type tool.

This is a wonderful trick for adding your copyright information to
sample images because everyone can see the image, but no one can use
it without your permission. Start by adding your copyright information
or perhaps the word Sample.

2. Apply a layer style to the type layer.

A bevel, a thin black stroke, and perhaps an inner shadow make
an excellent combination.
(Select the individual effects
as described earlier in this
chapter.)

3. Reduce the Fill slider to 0%.

Adjust Fill at the top of the

Layers palette or in the Layer
Style dialog box’s Blending

Options pane. You can click and Figure 12-20: Add a type layer, apply a layer
type in the Fill field, click the style, and then reduce the Fill setting to 0%.
arrow to the right of the field
and drag the slider, or simply

click the word Fill and drag to Advanced Blending
the left. The type layer disap- Fill Opacity: 100 |%
pears, but the layer effect Channels: ¥R M C @B
remains. Knockout: None )
. " Blend Interior Effects as Group
You can see all three steps in i Blend Clipped Layers as Group
Figure 12-20. ETransparency Shapes Layer
" Layer Mask Hides Effects
. . ] Vector Mask Hides Effects
The Blending Options pane of the -

Layer Style dialog box offers you

a number of other choices in the Figure 12-21: You find Advanced Blending
Advanced Blending area, as shown options on the Blending Options pane of the
in Figure 12-21. Layer Style dialog box.
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Other than the Fill Opacity slider, you’ll probably never change the Advanced
Blending options from their default settings, but you might be curious about
what they do. Here’s a short explanation of each:

1 Channels: Clear one or more of the color check boxes in the Advanced
Blending area to hide the layer’s content in that color channel. Clear the
R check box, for example, and you hide the target layer in the Red channel.

1 Knockout: You can use the content on the target layer to create trans-
parency on lower layers. The top layer becomes transparent as do the
layers below every place that the upper layer had visible pixels. (I think
of it as a “cookie cutter” effect.) If you want to restrict the effect, use the
Shallow option, and the knockout extends only to the lowest layer in
your layer group. The Deep option knocks out to the Background layer
(or to transparency if your image doesn’t have a background layer).

1~ Blend Interior Effects as Group: You can blend the Inner Glow, Satin,
and your overlay effects before the layer as a whole is blended with
lower layers. Use this option if it seems your layer effect’s blending
mode is being canceled out by the layer’s own blending mode.

1+~ Blend Clipped Layers as Group: If you have layers clipped together
(see Chapter 10), you can elect to use the base layer’s blending mode
for all the layers or let each layer interact independently. You generally
want to leave this check box selected.

1~ Transparency Shapes Layer: Another option that you’ll almost always
want active, Transparency Shapes Layer restricts the layer style to the vis-
ible pixels on the target layer. If, for example, you're working with a small
rounded rectangle and a Color Overlay layer effect, clearing the check
box fills the entire layer — not just the rounded rectangle — with color.

1~ Layer Mask Hides Effects: If the target layer’s visibility is controlled
with a layer mask (see Chapter 8), you can opt to have the layer style
hidden by the mask, too. You can also use a layer mask to hide just the
layer style with this option — say, when you need to make sure that
your drop shadow doesn’t fall where it shouldn’t. Simply create a layer
mask that hides those areas where you don’t want the style visible and
mark the Layer Mask Hides Effects check box.

1~ Vector Mask Hides Effects: This option uses a layer’s vector mask in
exactly the same way that the Layer Mask Hides Effects option uses a
layer mask. (Remember that a vector mask is a path that determines
which areas of a layer are visible — see Chapter 11 for information on
creating paths.)
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If you have an image with a plain white (or plain black) background, you can
make that background disappear with the Blend If sliders (see Figure 12-22).
In the Layers palette, double-click the layer name Background and rename the
layer. At the bottom of the Layers palette, click the second button from the
right to add a new layer. Move the new layer below the original layer. With
the original layer active, open the Blending Options pane of the Layer Style
dialog box and drag the upper-right Blend If slider control to the left until the
background disappears. As the white background disappears, the checkerboard
transparency grid becomes visible. Press 8+E (Mac)/Ctrl+E (Windows) to
merge the layers and retain the now-transparent background.

& O O ¥ © 0080064 MED.UF @ 33.3% MGB/EN 6 O O ¥ © 0080064 MED.Uf § 33.3% Wayer

©1998 PhotoSpin, PhotoSpin image #0080064
Figure 12-22: Make a white background disappear with the Blend If sliders.

Saving Your Layer Styles

Creating custom styles takes some time and effort. Saving the styles means
that you don’t have to spend time re-creating the style. Save your styles not
only in the Styles palette but also on your hard drive.

Adding styles to the Style palette

After you have your layer style looking just right, you can add it to the Styles
palette. From the Styles palette, you can apply your custom style to any layer
(except, of course, layers named Background) in any image with a single click.
You simply make the target layer active in the Layers palette by clicking it;
then click your custom style in the Styles palette.
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To add your style to the Styles palette, you must first create it. Select a layer
in the Layers palette, open the Layer Style dialog box, and select the layer
effects and options. After clicking OK in the Layer Style dialog box, click the
middle button at the bottom of the Styles palette (see Figure 12-23). Then, in
the New Style dialog box that appears, assign your custom style a name and
click OK. If desired, you can also elect to save the target layer’s blending
mode as part of the layer style.

Dom E
FERE =YX
[ 4 -J..:

New Style

B Mame: [Broken Blue P==""9
™ include Layer Effects
_ Include Layer Blending Options

Cancel

Figure 12-23: Click the button at the bottom of the Styles palette to save
your custom style.

Preserving your layer styles

Adding your custom styles to the Styles palette makes them available day in
and day out as you work with Photoshop. However, should you ever need to
replace the Preferences file (see Chapter 3) or reinstall the program, all your
custom styles are wiped from the Styles palette. To make sure that you don’t
accidentally lose your custom styles, create and save a set of styles, which
you can then reload into the palette whenever necessary.

The Styles palette menu offers the Save Styles command (refer to Figure 12-4),
which lets you save all the styles currently in the palette as a set. However,
for more control — to actually select which styles you want in your set — use
Photoshop’s Preset Manager (see Figure 12-24). You can open the Preset
Manager from either the Styles palette menu or through the Edit menu. (Make
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sure that you retain the .as1
extension in the filename so that
Photoshop recognizes the file as a
set of styles!)

As you can see in Figure 12-24, you
use Preset Manager to save many
kinds of custom bits and pieces. And
use it you should! Shift+click to
select a series of items or 38+click/
Ctrl+click to select individual items;
then click the Save Set button. Give
the set a name (again, with the .asl
file extension), pick a location, and
click OK.
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Figure 12-24: Use the Preset Manager to make
sure your custom styles are safe.

Saving sets of styles, brushes, custom shapes, and the like in the Photoshop
Presets folder adds those sets to the various palettes’ menus. That makes it
quite easy to load the set into the palette: Just choose the set from the
palette menu. However, you should also save a copy of the set someplace
safe, outside the Photoshop folder, so it doesn’t accidentally get deleted
when you upgrade or (horror!) reinstall.
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In This Chapter
Testing your type techniques

Creating paragraphs with type containers
Shaping up with Warp Text and type on a path

u n croquis vaut mieux qu’un long discours. Or, as folks often paraphrase
Napoleon, “A picture is worth a thousand words.” But sometimes in

your Photoshop artwork, nothing says Bob’s Hardware quite like the very
words Bob’s Hardware. A picture of a hammer and a picture of a nail —

perhaps toss in some nuts and bolts — all are great symbols for your client’s
logo. However, you also need to give Bob’s customers a name and - .
an address so they can actually spend some money, which
goes a long way toward helping Bob pay you.

For a program that’s designed to work with photo-
graphic images, Photoshop has incredibly powerful
text capabilities. Although it’s not a page-layout pro-
gram such as Adobe InDesign or a word-processing
program such as Microsoft Word, Photoshop can
certainly enable you to add lines or even para-
graphs of text to your images.

Photoshop offers you three categories of text:

1~ Point type is one or more lines of text, comparable
with the headlines in a newspaper or the text that you
add to, say, a Bob’s Hardware advertisement. Click with a
type tool to add point type.

1~ Paragraph type consists of multiple lines of text. Like in a word-
processing program, each new line is added whenever your typing
reaches the margin. Drag a type tool to create paragraph type.
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1~ Warp type and type on a path are typically single lines of type that are
bent, curved, or otherwise distorted as a special effect. Use the Option
bar’s Warp Text feature or click with a type tool on a path.

In this chapter, I discuss the tools and palettes that you use to add text to an
image, how to add paragraphs and columns of text (as you might use in a
brochure or booklet), and even how to make your type bend and twist along
paths.

Making a Word Worth a Thousand Pixels

To control your work with text, Photoshop offers you four tools, the Options
bar, the Character and Paragraph palettes, and several options in the
Preferences dialog box (both in the Type section, visible in Figure 13-1, and
in the Units & Rulers section). By default, the Character and Paragraph
palettes are hidden; because you can make the major type-related decisions
(such as font style and alignment) right from the Options bar, that’s generally
fine. You might need to show the palettes if you're doing some fine-tuning of
the text appearance. When you need the palettes, you can show them by
choosing Window=>Character or Window=>Paragraph, respectively, from

the menu bar or (with the Type tool active) by clicking the Palettes button
toward the right end of the Options bar.
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Figure 13-1: Photoshop gives you lots of tools for working with text.
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As you can see in Figure 13-1, the Font menu actually shows a preview sample
of the font styles so that you don’t need to memorize the appearance of all
your various type faces. And you can choose Preferences=>Type to select
from five different sizes for the font preview.

Type can be informative or decorative or both. You can use the type tools to
add paragraphs of text or a single character as an element of your artwork.
The text can be plain and unadorned or elaborately dressed up with layer
styles, such as drop shadows, glows, bevel effects, and other effects that

you apply to make the layer content fancier. (Layer styles are discussed in
Chapter 12.) However you use it, text can be a powerful element of both com-
munication and symbolism. Take a look at Figure 13-2, in which I use the Type
tool to add the binary code to the left and even the musical notes below.

Figure 13-2: You can also use type as symbolic or decorative elements.

But before you add any text to your artwork, you need to have a good handle
on the various type tools, palettes, menus, and options available to you. I
start with an introduction to Photoshop’s type tools.

267
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A type tool for every season, or reason

Photoshop offers four type tools — or, perhaps more accurately, two pairs of
type tools — that assist you with adding text to your images. The Horizontal
Type tool and the Vertical Type tool (the first pair) create type layers, which
show up as special layers in the Layers palette that enable you to later re-edit
the text that you put there. The Horizontal Type Mask tool and the Vertical
Type Mask tool (the second pair) make selections on the active layer, just as
if you had used the Rectangular Marquee or Lasso tools (as I describe in
Chapter 8).

In addition to that glorious advantage of being able to easily correct acciden-
tal misspellings, creating and using type layers offer a number of other advan-
tages. You can

1~ Apply layer styles to type layers to fancy them up. For example, try a
simple Inner Bevel or Drop Shadow effect to make the words leap from
the background.

1~ Adjust type layer blending modes and opacity. Doing this can help
you achieve a unique integration with the artwork’s other elements or
background.

 Produce extraordinarily crisp and clean type on the page. When print-
ing with a laser printer (or other PostScript device), the text on type
layers prints beautifully.

Until the image is flattened or the type layer is merged or rasterized (con-
verted to pixels), you can change any type attribute, such as the spelling,
font, layer styles, opacity, and blending modes as I show in Figure 13-3.

You automatically gain the advantage of using type layers when you use the
Horizontal Type or Vertical Type tools to add text to your images in Photo-
shop. (You can spot a type layer in the Layers palette easily. The layer shows
a T instead of a preview for the layer thumbnail.)

Whether you're adding a simple “© Peter Bauer” (yeah, okay, use your own
name if you want) to an image or a couple of columns of text to a brochure,
you’ll generally use the Horizontal Type or Vertical Type tools. But when, you
might ask, would you ever need to use the type mask tools? Perhaps never. If
you ever need a selection in the shape of your text, though, you can manage
that trick by adding a type layer and then 8 +clicking (Mac) or Ctrl+clicking
(Windows) the type layer’s thumbnail in the Layers palette. Voila/ You're pre-
sented with a text-shaped selection, and you still have an editable type layer
that you can hide and save, just in case.
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Figure 13-3: When you have type layers, you have the flexibility to make changes.

That, of course, doesn’t answer the questions of why you might want a text-
shaped selection in the first place, why type mask tools even exist, or why
the sky is blue. Although the third question is probably better answered in a
book named Skies For Dummies, here are a number of reasons to use a type
mask tool:

1~ Stroke: You can stroke a selection, which adds a line of color along the
path of the selection. With a type-shaped selection, this gives you a type-
shaped line of color. Stroke a selection with the menu command Edit=>
Stroke.

v~ Fill: You can fill that selection with color, a gradient, or even a pattern
with the Edit=>Fill command.

1~ Delete: You can delete that selection from an existing area of color, cre-
ating a type-shaped hole in the color or layer. [ chopped the words in
Figure 13-4 from the wrench-shaped sign with a text-shaped selection
made with the Horizontal Type Mask tool.
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Whether working with type layers or
creating type masks, you have the
option of using either horizontal or
vertical type. The difference between
type that is set vertically and the
more common horizontal type rotated
90 degrees is illustrated in Figure 13-5.
The figure also shows that when you
add text with a type mask tool, you
see the characters cut out of a red
overlay (top right in figure); when
done, you see the traditional march-

ing ants selection border (bottom Figure 13-5: Vertical type stacks the individual
right). Chapter 8 gives you more infor- characters. You can rotate horizontal type for a
mation on working with selections. different look.

You can select type options before adding text to the image, or you can
change your options afterward. When you make the type layer active in the
Layers palette — but haven’t yet selected any text in your image — any
changes that you make are applied to all the text on the layer. You can also
click and drag to select some of the text on the layer and make changes to
only those characters or words.
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When you’re done adding or editing text, you can end the editing session in
any of a number of ways:

1~ Click the check mark button (or the Cancel button) on the Options bar.
1 Switch to a different tool in the Toolbox.
1 Press 8+Return or Ctrl+Enter.

1~ 8+Shift+click or Ctrl+Shift+click to finish that type layer and start a new
type layer.

What are all those options?

Here you are, the proud owner of the world’s state-of-the-art image editor,
and now you're adding text, setting type, and pecking away on the keyboard.
You're faced with a lot of variables. Which options are you going to need now
and then? Which ones are you going to need all the time? Which ones can you
ignore altogether? Read on as I introduce you to the various text and type
variables, and toss in a few general guidelines on which options are most
(and least) frequently required.

Take a look at Figure 13-6, in which you can see (in all their glory) the most
commonly used text attributes, all of which are available to you from the
Options bar whenever a type tool is active.

Font Family
(click to open .
Tool Presets the font menu) Font Size
(click to open the (click to selct _
Tool Presets palette) or click-drag to scroll)  Align Left Warp Text
Align Right
TR X [ o) oz ) T v Ay e ) = L & [}
Orientation Font Style Anti-Aliasing Type-Color
(click to switch (click to select (click to select) (click to open
between horizontal from the styles the Color Picker)
and vertical type) available for the
selected font)
Align Center Palettes

(click to toggle

visibility of the

Character and
Paragraph palettes)

Figure 13-6: Use the Options bar to quickly and easily change the primary attributes of your text.
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You can change the following text attributes via the Options bar, which is
usually available at the top of your screen:

1~ Tool Presets: The Tool Presets palette enables you to select a prede-
fined set of options that you've already saved. Say, for example, that you
always use the same appearance for headlines in a recurring project and
a different appearance for the body type. Set up each as a preset and
then activate all the options with a single click. (See Chapter 3 for more
detailed information on tool presets.)

» Orientation: The Orientation
button toggles existing type
layers between horizontal and
vertical. Regardless of what
type is selected, the entire type
layer is flipped when you click
this button. (The button is
grayed out when no type layer
is active in the Layers palette.)

1~ Font menu: Click the triangle to
the right of the Font Family field
to open the Font menu, showing Tir| rrnie) (T)e
all your installed fonts in alpha- . e =]
betical order. You can also click
in the field itself and use the
arrow keys to switch fonts. If
you select some type with a
type tool first (as shown in
Figure 13-7), using an arrow key
automatically applies the change | o =

| Character X |
to the selected characters. If no b Janson bro [ = .

Light Samgple
characters are selected, you ke Rl s

change the entire type layer. T i -y

Figure 13-7: Select specific characters to
change or make no selection to change all.

atrics |l A i %
+~ Font Style: When a font has g::cibm = S"“"II
multiple styles built in, you IT |1e0% A semibold alic  Sample
can choose a variation of the A% |opt Cal Bu:j : Smplle
font from the Font Style menu. h,—|—' Apiiliie SeneHis
i T o ——
Styles include Regular (or Lokl 1
Roman), Bold, Semibold, Italic, english: usa |8 @[ smootn |3

Condensed, Light, and combi-
nations thereof (as you see in
Figure 13-8). Many fonts, how- Figure 13-8: Some fonts have many styles
ever, have no built-in styles. available.
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1~ Font Size: You can select a font size in three ways: by typing a number in
the Font Size field, by clicking the triangle to the right of the field and
selecting a font size from the pop-up menu that appears, or by clicking
the icon to the left of the Font Size field and then dragging left or right to
change the value in the field. Font size is generally measured in points
(1 point = f¥%: inch), but you can elect to use pixels or millimeters. Make
the units change in Photoshop’s Preferences (choose Preferences=>Units
& Rulers).

1~ Anti-Aliasing: Anti-aliasing softens the edges of each character so that it
appears smooth on-screen. As part of this process, anti-aliasing hides
the corners of the individual pixels with which the text is created. When
outputting to a laser printer or other PostScript device, anti-aliasing isn’t
required. It is, however, critical when printing to an inkjet or when pro-
ducing Web graphics. Generally, the choices here have little difference
among them (other than None, of course). Smooth is a good choice
unless your text begins to look blurry, in which case you should switch
to Crisp. Use the Strong option with very large type when the individual
character width must be preserved.

1~ Alignment: The three alignment choices on the Options bar determine
how lines of type are positioned relative to each other. The buttons do a
rather eloquent job of expressing themselves, wouldn’t you say? Note:
Don’t confuse the term alignment with justification, which straightens both
the left and right margins (and is selected in the Paragraph palette).

1~ Type Color: Click the color swatch on the Options bar to open the Color
Picker and select a type color. You can select a color before adding text,
or you can change the color of the text later. If you start by selecting a
type layer from the Layers palette, you’ll change all the characters on
that layer when you select a new color in the Color Picker. Alternatively,
use a type tool to select one or more characters for a color change, as
you can see in Figure 13-9.

1 Warp Text: Warp Text, which I discuss later in this chapter, bends the
line of type according to any number of preset shapes, each of which
can be customized with sliders. (The text in Figure 13-9 uses the Arc
Lower warp style.) Keep in mind, however, that the Warp Text feature
isn’t available when the Faux Bold style is applied through the Character
palette. (I talk about faux styles later in this chapter.)

Each character in a type layer can have its own attributes. Click and drag
over one or more characters with a type tool and then use the Options bar or
Character palette to change the text attributes. Color, font, style — just about
any attribute can be assigned.
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Figure 13-9: Select any individual character and change its font, color,
size, or any other attribute.

Like many word-processing programs, you can select an entire word in
Photoshop by double-clicking the word (with a type tool). Triple-click to
select the entire sentence. Quadruple-click to select the entire paragraph.
Click fives times very fast to select all the text.

Taking control of your text with palettes

For incredible control over the appearance of your text, use the Character
and Paragraph palettes. In addition to all the text attributes available on the
Options bar, the palettes provide a wide range of choices. With them, you can
customize the general appearance of the text or apply sophisticated typo-
graphic styling.

The Character and Paragraph palettes can be shown and hidden by using the
Palettes button on the Options bar or through the Window menu. By default,
the two palettes are nested together, so choosing Window=>Character or
Window=>Paragraph makes both palettes available.
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You can use the Character palette to Open palette menu
edit a single selected character, a
series of selected characters, or

the entire content of a type layer.
Figure 13-10 shows what you face
when “building character” using this Font Size Tracking
palette.

Font Style

Font Family Leading

Kerning

Unless you'’re a typographer, a
number of the fields in the Character
palette might require explanation:

| [Chargdcter X
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1 Leading: Leading (pronounced : —
LED-ding rather than LEED-ing) 4 [12 pr -
and which refers to the lead — —
strips of metal that typesetters
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of type) is the vertical space '
between lines of text. Generally, AZ lopt | - Color

you’ll leave Leading set to Auto. e gy
However, you can select one or [T|{T| PO |T|T.|||T|F
more lines of text (select the = : —
whole line) and change the
spacing. Adding more space
gives the text an airy, light
appearance. Reducing the lead-
ing tightens up the text, which
enables you to fit more lines in  Baseline shift Text color
the same area.

[ &
A ETHE T

0 [Merncs' el BW o
p‘-"i | —F |
X

am
|

Englifh: UEA '-",‘-! Az | Smooth

Faux styles Anti-Aliasing
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1~ Kerning: The space between

two characters is determined by Dictionary
the kerning built into a font. You
can, however, override that Figure 13-10: More choices than the Options

spacing. Click with a type tool bar!

between two letters and then

change the setting in the Kerning field to change the distance between
the letters. You might, for example, want to reduce the kerning between
a capital P and a lowercase o to tuck the second character protectively
under the overhang of the taller letter. This can produce a cleaner and
better-connected relationship between the two characters.

1~ Scaling: Vertical and horizontal scaling modifies the height and width of
the selected character(s). You'll find this useful primarily for customiz-
ing short bits of type rather than long chunks of text.
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1~ Baseline Shift: Produce subscript and superscript characters, such as
those used in H,O and e = mc?, with the Baseline Shift field. The Character
palette’s Baseline Shift option is best used in conjunction with a slight
reduction in the font size for the specific character(s).

1~ Faux Styles: Use faux styles to apply the appearance of a character
style, even when they’re not built into the font. From the left, as the but-
tons show (in Figure 13-10), the available faux styles are Bold, Italic, All
Caps, Small Caps, Superscript, Subscript, Underline, and Strikethrough.
Generally speaking, if a font offers a specific style in the Font Style menu,
you’ll use the font’s built-in style rather than the faux style.

1~ Dictionary: Photoshop has almost three-dozen dictionaries built in. And,
wonderfully or confusingly depending on your personal linguistic talents,
you can assign dictionaries on a word-by-word (or even character-by-
character) basis. You could, for example, insert a bon mot into the middle
of your text in the language of your choice, assign the appropriate lan-
guage dictionary, and not have that phrase trigger an alert when you run
a spell check (Edit=>Check Spelling).

Type warping isn’t available when Faux Bold is applied to any of the selected
characters. As warped as it might sound, that’s the only faux style that inter-
feres with Warp Text.

You'll probably find yourself using certain sets of options pretty regularly in
Photoshop. Luckily for you, you don’t need to make changes on the Options
bar and Character palette every time you want (for example) Arial Bold,

24 pt, Sharp anti-aliasing, 22 pt leading, and tracking +10. Set up the options
once and then click the Create New Tool Preset button in the palette at the
left end of the Options bar, as shown in Figure 13-11. The next time that you
want those specific text attributes, select the preset from that palette, and
you're ready to type!
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Figure 13-11: Tool presets can save you lots of time.
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The Paragraph palette is used, not Indent left margin
surprisingly, with paragraph type. o ]
The alignment options that you see Justification options

in the upper left of the Paragraph
palette in Figure 13-12 can be applied
to both point type and type on a
path, but you can usually access
your alignment options much more
easily from the Options bar.

Alignment options Indent right margin

e‘g\l\BER I use the term type container when |
& discuss the Paragraph palette and
paragraph type. Think of it as a rec-
tangular column of text, with the
words flowing from line to line, just ‘

as they do when you compose e-mail Hyphenate

or use a word processor. You drag a
type tool to create the rectangle, and ‘
then you type inside that rectangle.
In contrast, when you simply click a
type tool and start typing, you need Hyphenate

to press Return (Mac) or Enter paragraph type
(Windows) at the end of each line. Space before paragraph

Indent firstline | Space after paragraph

Figure 13-12: Most of this palette is only for

You can find specific information
paragraph type.

about some of these options later in
the chapter (when I discuss paragraph type), but here’s a quick look at the
other choices in the Paragraph palette:

1~ Justification: Unlike alignment, which balances lines of type based on a
point of origin (left, center, or right), justification equalizes both the left
and right margins of a paragraph of type. As you can see by the icons,
the difference among the four options is the last line in the paragraph.
That last line can be aligned left, centered, aligned right, or stretched to
fit from left to right (called full justification).

1+~ Indent Margins: Paragraphs of text can be indented from the left margin
or the right. Even if you have only a single word selected, the entire
paragraph is indented. Harkening back to that last term paper you wrote
(whenever that might have been), think in terms of a block quote. You
can also use negative numbers in the Indent Margin fields, which
extends the paragraph beyond the margin.

~ Indent First Line: You can indent the first line of your paragraphs (or
extend the first line to the left past the margin with a negative value)
without having to press the Tab key. The option can be set before you
start adding text and is applied to each paragraph.
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1~ Space Before/After: When your type container includes multiple para-
graphs, you can specify the distance that’s automatically added between
them. Rather than pressing the Return/Enter key an extra time between
paragraphs, set the spacing in the Paragraph palette.

1~ Hyphenation: If you're using justification rather than alignment, I recom-
mend keeping the Hyphenate check box marked. When words at the
ends of lines of justified type aren’t hyphenated, the spacing within the
lines can get rather messy. If you don’t like the look of hyphens along the
right margin, clear the Hyphenate check box.

\‘\Q,N\BER Keep in mind that after you drag a type tool to create a type container, you
& can have as many paragraphs as fit. When you reach the end of a paragraph,
press Return/Enter. A new paragraph is created within the type container.
Consider the type container to be a column of text, such as you'd see in a
newspaper, magazine, or newsletter.

The palette menus — even more options

Like most of Photoshop’s palettes, clicking the menu button in the upper-right
corner of the Character or Paragraph palette opens the Palette menu, which
holds a cornucopia of options you probably never need to see. (Consider this:
If it were a really important option, it would be easier to get to, wouldn'’t it?)

As you can see in Figure 13-13, not all menu options are available for all fonts.
Some of the options are merely command forms of the palette menus (such
as the faux styles), and other options are specific to Japanese fonts. A number
of the options apply only to OpenType fonts, which include a much larger
selection of glyphs (characters) than do other fonts.

Here are a few palette menu options with which you should be familiar:

1~ Fractional Widths: When selected, Photoshop uses this option to adjust
the spacing between letters on an individual basis. Will you or [ spot the
difference? Not with large type, but if you're creating small text (espe-
cially for the Web), clear this option. How small is small? Generally 10 pt
or smaller.

1~ System Layout: Unless you need to match the appearance of text in
TextEdit for Mac or Windows Notepad, leave this option deselected. When
might you need it? When designing interface items for a program or game.

1 No Break: When working with paragraph type, you can select one or
more words and choose No Break to prevent them from being hyphen-
ated. You might want to do this with words that are difficult to recognize
when split between two lines.

+» Roman Hanging Punctuation: Found on the Paragraph palette menu,
this option permits the smaller punctuation marks located at the left
and right margins of justified text to hang out past the margins. When
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commas and the like are outside the margin, the margin itself has a
cleaner look. Don’t use this option if your layout can’t handle text that
extends past the edges of your column.

1 Adobe Composer: This choice is actually quite simple: Single-Line
Composer looks at one line of type to determine hyphenation. Every-
Line Composer looks at the entire block of text, generally producing a
more pleasing appearance.

1~ Reset (palette name): If you're seeing some strange behavior from your
type tools, you might want to invoke the Reset Character and Reset
Paragraph commands. They restore the settings in their respective
palettes to the defaults, eliminating any errant setting that might be
causing the problem.

<P Remember that you can right-click (multibutton mouse) or Control+click
(one-button mouse) the tool icon at the left end of the Options bar and select
Reset Tool (or Reset All Tools) to immediately return to the tool’s default set-
tings. If the Type tool doesn’t seem to be working correctly, reset and then
reselect your options.
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Figure 13-13: Not all options are used with all fonts.
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Putting a picture in your text

Enough of that heavy stuff for now — time to take a look at one of the coolest
things that you can do with text. Here’s an easy way to create a text-shaped
picture, one that’s fully editable.

1. Using File=>Open, Adobe Bridge, or by double-clicking an image file,
open a photo in Photoshop.

2. If the Layers palette has a layer named Background, double-click the
layer name and rename the layer (as shown in Figure 13-14). If the
image has multiple layers, choose Layer->Merge Visible.

Q&N\BER
& You want to work with a single regular (not Background) layer for this
project. Background layers don’t support transparency, and no layers
can be placed below a Background layer.

Moew Layer
Mame: |Laver 0 ¢ o
Cancel
|
Mode: Normal %) opacny: 100 )%

Figure 13-14: Renaming a Background layer converts it to a regular layer.

3. Add your type with the Horizontal Type tool.

4. Click the type layer in the Layers palette and drag it below the image
layer.

5. In the Layers palette, Option+click (Mac) or Alt+click (Windows) the
line between the two layers.
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The two layers are joined together, as shown in Figure 13-15. When you
clip two layers, the lower layer serves as a mask for the upper layer. The
upper layer is visible only where the lower layer has pixels and adopts

the opacity of those lower-layer pixels.

i I A R

GARDENS

Figure 13-15: “Clip” the upper layer to the lower layer.

6. Finish the image with a layer style (applied to the lower layer) and
any other artwork that the project requires.

You can click the lower layer in the Layers palette and then click a favorite
layer style in the Styles palette. Or, of course, you can create a custom
layer style by choosing Layer=>Layer Style. In Figure 13-16, you see a
stroke, a bevel, and a slight outer glow applied to the GARDENS layer.

Figure 13-16: Add layer styles to the lower layer so that the effects are visible.

281
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Creating Paragraphs with Type Containers
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Although the vast majority of the text that you add to Photoshop artwork is
point type — that is, type that exists on just one or a couple of lines — you’ll
certainly find situations in which you need to use paragraph type in a type
container. The primary advantage of using paragraph type is word wrap.
While you type, the text automatically starts a new line every time it reaches
the margin.

“Why is that a big deal?” you might ask. “I don’t mind pressing the Return or
Enter key at the end of each line.” Ah, but consider the ever-present (when
you type like me) typographical error! What if the very first sentence of your
manual-Return paragraph is missing a word? To insert that word and main-
tain a visually pleasing right margin, you’d need to go back and redo every
line of type. With paragraph type, the content of each line automatically
adjusts as you insert that forgotten word.

The difference between point type to create a column of type and paragraph
type is comparable with the difference between a typewriter and a word
processor. (If you're old enough to remember Wite-Out and Liquid Paper,
raise your hand, but not for very long — I don’t want to tire you out.)

Adding a type container is simple. Click and drag with the Horizontal Type
tool (or, in some rare cases, you might want to use the Vertical Type tool),
and then start typing. The type automatically starts the next line as soon as
you press enough keys to reach the far margin. You can keep typing until you
fill the type container. Press Return or Enter whenever you want to start a
new paragraph within your type container.

You can also copy/paste text from a word-processing or text-editing program.
You can, for example, open a Microsoft Word document in Word, select the
text that you want by clicking and dragging, and then choose Edit=>Copy to
place the text into the computer’s memory (on the Clipboard). Switch to your
Photoshop document; select a font, font size, and other attributes; drag a
type container; and then choose Edit=>Paste (or the comparable keyboard
shortcut) to place your text inside the container. When the text you need
already exists, you not only save time by using copy/paste, but you also elim-
inate the possibility of introducing typos.

But what if you have more text than fits in the type container? Unlike Illustrator
and InDesign, you can’t link two type containers, enabling the excess text to
automatically move to the next container. Photoshop does, however, remind
you that your text doesn'’t fit by showing you a symbol in the lower-right
corner of the type container’s bounding box — the dashed line surrounding the
type container. As you can see in Figure 13-17, the lower-right anchor point of
the bounding box has a plus sign in it.
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Figure 13-17: A plus sign in the lower-right anchor point warns you that text doesn't fit in the
type container.

When you have more text than the type container can hold, you have a
number of options:

+~ Enlarge the type container. Click one of the bounding box’s anchor points
and drag to increase the size of the type container. Making a type container
a little bit wider often gives you an extra line or two of text at the bottom.

1~ Shrink the font. Select the text with a keyboard shortcut (88+A/Ctrl+A)
and select a smaller font size on the Options bar.

1~ Decrease the space between lines. Select the text and decrease the
leading — the amount of space between lines of type — in the Leading
field found in the upper right of the Character palette. By default (the
Auto setting in the Leading field), Photoshop uses an amount equal to
120 percent of the font size. You can often reduce the leading to 1 or 2 pt
larger than the font size before you start overlapping lowercase letters
with descenders (g, j, p, g, and y) and uppercase letters on the line below.

1~ Edit the text. Rephrase the text, using fewer words to convey the same
message. If you're not the author, however, this option might not be
available.
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Selecting alignment or justification

Photoshop gives you several options for controlling the appearance of your
margins. In the “Taking control of your text with palettes” section earlier in
this chapter, I outline a number of options that you can find on the Paragraph
palette menu. But let me go into more detail about a couple of options that
you have when adding paragraph type.

Perhaps the most important decision (other than font and font size) that you
make when preparing paragraph type is a choice of alignment or justification.
When text is aligned left, the left margin is perfectly straight, and the right
margin is ragged, with each line ending where it ends, without any relationship
to the lines of type above and below. A column of text that’s aligned right has a
clean right margin and a ragged left margin. If you choose center aligned, the
middle of each line of text is centered. Take a look at Figure 13-18 for a visual

comparison.
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graphic or other non-text
element them.
Do not, however, punish
your reader by usi
column after column
right-aligned text. | might
one of those readers.

Figure 13-18: Compare the left and right margins of each column of text.

Unlike alignment, justification gives you straight margins on both sides of the
column of text. The four justification options at the top of the Paragraph
palette differ only in how they treat the last line of a paragraph. As you can
see from the Paragraph palette buttons, the last line can be independently
aligned left, center, or right; or it can be fully justified, spreading the last line
from margin to margin. You shouldn’t use the fourth option unless that last
line (of every paragraph) is rather full because it looks rather strange when
just a couple of words are stretched edge to edge.
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Ready, BREAK! Hyphenating your text

When a word is too long to fit on the current line of text, either it can be
moved to the beginning of the next line (wrapped), or it can be broken into
two parts: one finishing the upper line and the other starting the next line
(hyphenated).

The hyphenation options are for the truly geeky, my-typography-is-my-life types.
The defaults are excellent and can suffice for all but the most precise layouts
(which you should be doing in InDesign or perhaps Illustrator, anyway).

If you want to fine-tune how hyphen- P e

ation is applied (or have far too o Hyphenation [
much time on your hands), select Words Longer Than: [§ ltiers Cancal
Hyphenate from the Paragraph After Firse: |2 Tetters

palette menu to open the options Before Last. 2 festers

shown in Figure 13-19. The Hyphen Limit: 2 hyphens
Hyphenation check box (upper left) Hyshenation Zese: 3 piea
activates/deactivates hyphenation. & yphenate Capitalized Words

The top three fields govern which
words to hyphenate and what limits
to place on the hyphenation. (Think  Figure 13-19: Default hyphenation values give
of the second and third fields as you good results and a pleasing appearance.
Hyphenate or cram into the line without

hyphenating.) The lower two fields control the appearance of the margin,
limiting the number of consecutive lines that can be hyphenated and the
maximum distance from that margin that a hyphen can be placed.

Shaping Up Vour Language with
Warp Text and Type on a Path

You can change the line along which your type flows either by using the Warp
Text feature or by typing on a path. Type warping uses predefined shapes

to which your type is formed (and can be used with both point and para-
graph type), and typing on a path uses a custom path (and is used only with
point type).

Warping type and placing type along a path are great ways to spice up your
message as long as you don’t overdo it and make the message illegible or dis-
tract from the overall appearance of your artwork. Warp Text is a quick and
easy way to bend text, and placing type on a path is a more complex — and
more controlled — technique.
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Applying the predefined warps

With a type layer active in the Layers palette and a type tool selected, click
the button to the right of the color swatch on the Options bar. That opens the
Warp Text dialog box, as shown in Figure 13-20, in which you choose both the
distortion you want to apply as well as the settings.

Warp Taxt

Sryle: [JArc 3

ook
@ Harizontal | Vertical Cancel
Band 50 %
Horizontal Diitartion 0 =

Vertical Distortion 0 L]

Figure 13-20: The illustration uses two separate type layers, each with its own Warp Text
settings.

Photoshop offers 15 different Warp Text presets, each of which you can cus-
tomize by dragging any of three sliders. Negative numbers can be used, too,
reversing the warp. You can also set the Bend slider to 0 and adjust the lower
two sliders to create the appearance of depth or perspective for a type layer,
but keep in mind that the Horizontal and Vertical buttons aren’t available for
some of the styles. Warp Text is one of Photoshop’s truly fun features. The
best way to become familiar with it is to open the dialog box and test-drive
each of the variations. And don’t forget to try the Horizontal and Vertical but-
tons when they’re available!
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Customizing the course with paths

You can use the shape tools or the Pen tool to create a custom path along
which you add your text. (You find full information about paths and shape
layers in Chapter 11.) To add type along a path, simply select the Horizontal
Type or Vertical Type tool, click the path, and type. The flow of the type from
the point on the path where you click is determined by the alignment option
that you select from the Options bar or the Paragraph palette. If the text is
left-aligned, characters are added to the right of the point where you click
(called the point of origin for the type). Left alignment is great when adding
type along an open path, such as the upper path in Figure 13-21. You might,
however, want to choose center alignment when adding type along the top of
an arc or circle, so you can click on the top of the arc and not worry about
dragging the type later to center it.

Figure 13-21: Text alignment determines where the text goes from the point where you click on
the path.

287



2 8 8 Part lll: Creating “Art” in Photoshop
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If you want type to go in two different directions — say, pointed upward
along both the top and the bottom of a circle — you need to create two sepa-
rate paths and two separate type layers, as shown in Figure 13-22.
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Figure 13-22: Sometimes you need to create two separate type layers, using two separate
paths, to achieve your artistic goals.

After you add your type to the path, you can press the 38/Ctrl key and reposi-
tion the type along the path by dragging. When you press and hold 8/Ctrl,
the type tool’s cursor changes to an I-beam cursor with a heavy black arrow
on either side, indicating which way you can drag the type. You see the type’s
point of origin as a hollow diamond on the path (not to be confused with the
hollow squares that represent the path’s anchor points). Figure 13-23 gives
you a zoomed-in look at the converted cursor and a comparison of the point
of origin diamond and the anchor point square. Note, too, that not only can
you drag type along a path, but you can also drag it across the path, flipping
over the type.

After flipping type across a path, you might need to adjust the tracking

(the space between characters), which is the second field from the top

on the right in the Character palette. And don’t be afraid to click in the type
and press the spacebar a few times to adjust the placement of words along
the path.
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Figure 13-23: When you drag the cursor across the path a short distance, type flips over.

Finding and Adding Fonts

You already have a nice selection of fonts installed on your computer. Some
are installed with the operating system (Windows or Mac), a number of fonts
may have been installed with the Adobe Creative Suite, and other programs
could have tossed more morsels into the stew. However, you might find that
the more you work with text, the more you crave additional fonts.
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Downloading and purchasing fonts

You can find many places on the Web to download free fonts. I must warn
you, though, that some free fonts are problematic and can cause instability.
In addition, don’t download any bitmap fonts, no matter how cool they look.
Always stick with PostScript fonts (True Type, Typel, and OpenType). In a
wholly nonpreferential, alphabetical order, here are a few of my favorite sites
for downloading reliable, free fonts:

» www.1001lfonts.com

¥ www.abstractfonts.com
¥ www . chank.com

¥ www . fonthead.com

» www.larabiefonts.com

A number of Web sites that don’t specialize in fonts also offer them. Stock
photo sites, clip art sites, and even general graphics-related sites often have
free fonts available. You can purchase collections of commercial fonts from a
wide variety of sources, including my two favorite font sources:

¥ www . adobe.com/type

» www . fonts.com

Although having lots of fonts can stretch your options, too many fonts can
lead to slowdowns and other problems. If you do find yourself someday with
a massive collection of fonts, none of which you could bear to part with, use
a font-management utility. The Mac OS has the built-in Font Book, and
Extensis (www.extensis.com) offers Suitcase Fusion (Mac, about $100) and
Suitcase (Windows, about $80).

If you download fonts from a Web site, be aware that the files might be com-
pressed. Compressing a downloadable file does several things:

1 Provides for a faster download: The smaller the file, the less time it takes
to travel through cyberspace from the Web server to your computer.

1~ Reduces storage: A compressed file takes up less space on the Web
server’s hard drive — and less space on yours, too! After installing the
font, move the compressed file to a safe place to save as a backup. And
consider burning your special font files to CD for security.

1~ Allows for secure transmittal: Files that are compressed are less likely
to become corrupted in transit and are also less likely to set off alarm
bells for your antivirus software.

How can you tell whether a file is compressed? Look at the file extension at
the end of the filename. If you see . zip (both platforms) or .sit or .sea
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(Mac only), you have a compressed file. Simply double-click the file to launch
the Stufflt (Mac) or WinZip (Windows) utility, which will expand the com-
pressed file, before attempting to install the font.

Installing (and vemoving) fonts: Mac

To make a font available to all programs (and to all users in a multiuser envi-
ronment), install it at the system level by copying the font file to the folder

[harddrive] .Library.Fonts

To restrict the font to a single user, perhaps for licensing reasons, install the
font into this folder:

[harddrive] .Users. [username] .Library.Fonts
Quit Photoshop (and any other font-using programs) before installing fonts.

To remove a font, quit all programs that use fonts, go to the appropriate Fonts
folder, and drag the font to the Trash. Why would you ever delete a font? You
might find that the font menu is too crowded, making it difficult to find the font
you need. You might have accidentally installed multiple versions of a single
font. The font itself might not work properly. Or, of course, it might just be a
truly ugly and worthless font that was installed with a collection.

Remember, too, that some programs install fonts into special folders so that
they don’t have to share them with all the other programs. But sharing is
nice, don’t you think? You can move many of the fonts from their secret
hiding places into the main Fonts folder to make them available to all pro-
grams. The Adobe Creative Suite, for example, installs fonts into the folder

[harddrive] .Library.Application Support.Adobe.Fonts

It's a family affair

Generally, folks toss off the term fontincorrectly.
To be precise, you should usually use the term
font family. For example, Times is a font family.
Arial is a font family. Myriad Pro is a font family.
Comparatively, Times New Roman Bold 24 ptis a
font, and Minion Pro Semibold Italic 24 ptis a font.

When does it actually matter? Well, you might
want to recognize the difference when shopping

for collections of fonts or perhaps for a laser
printer. One collection (or printer) might adver-
tise 2,500 Fonts! whereas another offers only
100. You can be pretty sure that one is refer-
ring to fonts and the other to font families. But
when you're just chatting, saying font is per-
fectly fine — now that we all understand the
difference.
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Do not move the fonts in the folder named Reqrd. (That’s a secret Adobe
code that means required.) If you move those fonts, Photoshop is likely to
become very, very unhappy and not play with you at all.

Installing (and removing) fonts: Windows

Certain fonts should never be moved, copied, deleted, or perhaps even thought
about after the sun goes down. These fonts are critical for the performance of
the operating system or a specific program. They can generally be recognized
by location (in a hidden folder in Windows, or a folder named Required) or by
an exceptionally cryptic filename with underscores and numbers. When in
doubt, err on the side of caution.

After you copy or download (and decompress, if necessary) your new font
file, quit all programs that use fonts (including Photoshop). Choose Start=>
Control Panel and then double-click Fonts in the Control Panel window to
access the Fonts dialog box. From the File menu, choose Install New Font. In
the Add Fonts dialog box, navigate to and select your new font file or files,
and then click OK. The font is added to the Fonts folder and made available
to all font-using programs.

To remove one or more fonts, open the Fonts dialog box from the Control
Panel, select the font(s), and choose Delete from the File menu. As when you
add a new font, close all font-using software before deleting fonts.

When you’re in the Fonts folder, take a look at the View menu. Try the List
Fonts by Similarity option. Select a font and watch how Windows rearranges
the content of the font list to show you which fonts are closest in appearance
(and which are extremely different, too). Oh, and by the way, you can double-
click any font in the list to open a preview of the font, which you can print to
create your own font book.
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Painting in Photoshop

In This Chapter

Adding color manually for complete control
Discovering tools with and without brushes
Traversing that amazing Brushes palette
Creating do-it-yourself brushes

’aainting. The word evokes images of brushes and palettes and color being
precisely applied to canvas. Or, perhaps, images of drop cloths, ladders,
rollers, and buckets — color being slopped on a wall and spread around. It
doesn’t generally bring to mind digital image editing. But painting certainly
has a place in your arsenal of Photoshop skills, even if you never create an
image from scratch.

In addition to painting landscapes and portraits (which you cer-
tainly can do in Photoshop, if you have the talent and train-
ing), you can use Photoshop’s painting tools for a variety
of other tasks. For example, you can paint to create
masks and layer masks, adjust tonality or sharpness in
specific areas, repair blemishes and other damage in
an image — even to create graphic elements and
special effects.

In this chapter, | concentrate on those editing-
related painting skills rather than fine art painting. I
introduce you to the basic concepts of painting in
Photoshop and also walk you through the basic brush-
related tools and the Brushes palette, concentrating on
those features that you most likely need (as well as a few
of the other, more artistic features). To wrap up the chapter, I
show you how to create custom brush tips and how to save them
for future use.
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Discovering Photoshop’s Painting Tools

ERTURE

Nothing in Photoshop gives you more precise control of color in your image
than using the Pencil tool with a 1-pixel brush. Remember that your image con-
sists of a whole lot of little colored squares (pixels) and that the color of those
individual squares is what produces the appearance of a tree or a sunset or
even good ol’ Uncle Bob. If you zoom in really close on an image, you can paint
pixel by pixel — you could even create an entire image, one pixel at a time!

Whether you're using a tiny brush
with the Pencil tool or a larger

one with the Brush tool, adding color
to your image with the painting tools
enables you to create beautiful or
whimsical imagery, such as what’s
shown in Figure 14-1 (with acknowl-
edgment to Picasso’s Woman with
Pears).

As you work in Photoshop, however,
you'll find many very important roles |
for the brush-using tools other than
creating imagery. From touching up
dust and scratches in a scan to
removing distant power lines from a
photo to perhaps adding wispy hairs
to soften the outline of a head, you
have lots of reasons to paint in
Photoshop (many of which you can
read about in Chapters 9 and 10).
When you’re capable and confident
using the Brush tool, you might even
find it the best way to make selec-
tions in your image. Selections with the Brush tool? That’s right — painting in
an alpha channel creates or refines a saved selection. (You can read about
alpha channels in Chapter 8.)

Original artwork © 2005 Peter Bauer
Figure 14-1: Painting with the Brush tool is yet
another way to create in Photoshop.

Photoshop CS3 adds a new brush-using tool that you can use to make selec-
tions directly. The Quick Selection tool, like the Magic Wand, selects areas

of similar color. However, instead of Shift+clicking in a variety of areas with

the Magic Wand to add to your initial selection, you simply drag the Quick
Selection tool. The brush diameter, selected in the Options bar, tells Photoshop
the size of the area you want to search for similarly colored pixels.

You have 18 tools that use brushes available in Photoshop. Here are just a
few of the things that you can do with these tools:
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1 Add color (Brush, Pencil)
1 Adjust tonality (Burn, Dodge)
1 Sharpen, blur, and smear (Sharpen, Blur, Smudge)

1 Correct color and texture (Healing Brush, Spot Healing Brush, Color
Replacement)

1 Select areas of similar color (Quick Selection)

1~ Copy/paste pixels (Clone Stamp)

In this section, I discuss the primary painting tools and introduce you to
some of the other brush-using tools. (Check Chapter 9 for additional informa-
tion on healing and cloning in your image.)

Painting with the Brush tool

You control where the Brush tool

works by selecting a brush tip of a e
particular size, shape, and hardness
(the fuzziness, or lack thereof, along
the edges of a round brush tip).
Remember, too, that you can use the
Brush and other painting tools to
create subtle changes in existing
colors. By selecting an appropriate
blending mode and opacity, you can
mix the painting color into the exist-
ing colors in your image. Make these
basic decisions from the Options
bar, shown for the Brush tool in
Figure 14-2.
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Figure 14-2: Make the primary decisions about
painting tool behavior from the Options bar.

As you see in Figure 14-2, the Options bar gives you access to a miniature
Brushes palette, from which you can pick a brush tip, change its size, and
adjust the hardness of the brush’s edges. (Only round brush tips use the
Hardness adjustment.) The five sample lines to the right show Hardness, from
0% to 100% in 25% increments, all using a 40-pixel brush. The Brush tool can
use any brush tip that you have in the Brushes palette — and, as you can read
later in this chapter, you can customize the brush tip in a variety of ways.

You're actually ready to paint in Photoshop already! Select a foreground
color, select the brush size that you want, decide how hard or fuzzy the
edges should be, change the blending mode and opacity (if desired), and
drag the tool in your image. (And, perhaps best of all, no turpentine needed
for cleaning up — just switch tools in the Toolbox.)
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As you work with the brush-using tools, always remember that the selected
brush tip is applied as a series of individual impressions, called instances.
Consider an instance to be a single impression of the brush tip, like tapping a
pen once on a piece of paper — it leaves a single dot. Take a look at the outer
borders in Figure 14-3. Changing the brush tip’s Spacing value (in the main
Brushes palette, opened through Photoshop’s Window menu) shows how
instances appear. In the upper left, the spacing is set to the default 25% and

a continuous line results. To the upper right, Spacing is set to 67%, and the
individual brush tip instances are visible as overlapping circles. To the lower
left, Spacing is set to 133% — this is a setting that you might use for a dotted
or dashed line — and each brush tip instance is visible individually.
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Figure 14-3: Changing the Spacing makes the individual brush tip instances visible.

If, when you open the main Brushes menu, you see a Brushes palette that
contains only brush tips, click the menu button in the upper-right corner of
the palette and select Expanded View from the top of the palette menu.

If you know you have the cursor set to show the brush tip, but you're seeing
the tiny little crosshairs instead, check the Caps Lock key on your keyboard.
Caps Lock toggles between precise and brush-size cursors for the brush-
using tools. (During the discussion of Photoshop’s Preferences in Chapter 3,
I showed a comparison of the three brush cursor options in Figure 3-13.)
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When you change the Brush tool’s Opacity setting on the Options bar, you
change the appearance of the stroke as a whole. Changing the Flow setting
(also on the Options bar), on the other hand, changes the amount of color
applied with each instance of the brush tip. When the flow is reduced and the
spacing is set to less than 100%, the overlapping area of each brush instance
appears darker (or lighter when painting with, for example, white on black).
One last option for the Brush tool deserves a quick look. To the right of the
Flow field is the Airbrush button. When the Airbrush is on (the button turns
dark), the Flow value takes on more meaning. As you paint with the Brush in
Airbrush mode with a reduced Flow setting, pausing the cursor with the
mouse button down allows color to build up (become more opaque) as if you
were using a real airbrush. You can use the Airbrush both as a traditional air-
brush artist and to simulate spray paint. You can see both in Figure 14-4.

Figure 14-4: Airbrushing and spray painting with the Airbrush option for the Brush tool.

Adding color with the Pencil tool

The Pencil tool differs from the Brush tool in one major respect: Regardless
of the Hardness setting in the Brushes palette, the Pencil tool always uses a
hardness value of 100%. With the Pencil tool active, the Options bar offers
the miniature Brushes palette, choice of blending mode and opacity, and the
somewhat-misnamed Auto Erase option. When selected, Auto Erase lets you
paint over areas of the current foreground color using the current background
color. Click an area of the foreground color, and the Pencil applies the back-
ground color. Click any color other than the foreground color, and the Pencil
applies the foreground color. But remember, you're not erasing, just painting
with the background color (even on layers with transparency).
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Removing color with the Eraser tool

The third of your primary painting tools is the Eraser. On a layer that sup-
ports transparency, the Eraser tool makes the pixels transparent. On a layer
named Background, the Eraser paints with the background color. On the
Options bar, the Eraser tool’s Mode menu doesn’t offer blending modes, but
rather three behavior choices. When you select Brush (the default), the
Options bar offers you the same Opacity, Flow, and Airbrush options as the
Brush tool. You can also select Pencil, which offers an Opacity slider, but no
Flow or Airbrush option (comparable to the actual Pencil tool). When Mode
is set to Block, you have a set-size square Eraser tool. Regardless of which
mode is selected, the Options bar offers one more important choice: To the
right of the Airbrush button, you’ll find the Erase to History check box. When
selected, the Eraser tool paints over the pixels like the History Brush (see the
sidebar “Selective Undo: The History Brush”), restoring the pixels to their
appearance at the selected state in the History palette.

A couple of variations on the Eraser tool are tucked away with it in the Tool-
box, too. The Background Eraser tool can, in fact, be used to remove a back-
ground from your image. However, it’s not limited to something in your image
that appears to be a background. Remember that digital images don’t really
have backgrounds and foregrounds or subjects — they just have collections
of tiny, colored squares. What does this mean for using the Background
Eraser? You can click and drag on any color in the image to erase areas of
that color. You can also elect to erase only the current background color and
designate the foreground color as protected so that it won’t be erased even if
you drag over it.

The Magic Eraser, like the Magic Wand selection tool (see Chapter 8), isn’t a
brush-using tool, but this is a logical place to tell you about it. Click a color
with the Magic Eraser tool, and that color is erased, either in a contiguous
area or throughout the image, depending on whether you have selected the
Contiguous option in the Options bar. And, like the Magic Wand, you can set
the tool to work on the active layer or all layers in the Options bar, and you
can also set a specific level of sensitivity (Tolerance). Here is the one differ-
ence between the two: The Magic Eraser is, in fact, a painting tool in that you
can set an opacity percentage, which partially erases the selected pixels.

Picking a color
If you want to apply a specific color to your image with a painting tool, you
have to be able to select that color, right? Photoshop provides you with a
number of ways to select a color:

1~ Click a saved color swatch in the Swatches palette.

+~ Enter numeric values or drag sliders in the Color palette.
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1 Click a color swatch at the bottom of the Toolbox or in the Color
palette to open the Color Picker.

1~ Select the Eyedropper tool and click any color already in your image.
Heck, click in your image with the Eyedropper tool, hold the mouse
button down, and drag to any color anywhere on your screen — that
color doesn’t even have to be in Photoshop!

In both the Toolbox and the Color palette, the foreground color is shown in the
swatch to the upper left, and the background swatch is partially hidden behind
it. Swap the foreground and background colors by pressing the X key on your
keyboard. Reset them to the default black and white by pressing the D key.

In Chapter 6, I introduce the Color Colox Picker Boregeonnd Colon
palette and the various ways you can

define color with it. Now take a look

at the Color palette’s big brother, the

Color Picker (see Figure 14-5). New in

Photoshop CS3, note the reminder

in the title bar of the Color Picker

window that tells you whether you’re

changing the foreground or back- R -
ground color. (If you find that you're i
changing the background color when
you want to change the foreground
color, exit the Color Picker, open

the Color palette, and click the fore-
ground swatch.) The best way to get a feel for the incredible versatility of the
Color Picker is to open it (click a color swatch at the bottom of the Toolbox
or in the Color palette) and click each of the buttons to the left of the numeric
fields. Each option changes how the Color Picker appears as well as how it
defines color.

-

Figure 14-5: Use the Color Picker to define
colors with precision.

The default Color Picker configuration uses the radio button to the left of the
H (Hue) field. It presents you with a vertical rainbow slider (the hue) and a
square area that defines saturation (left-right) and brightness (up-down).
Click or drag in the square area to the left and drag the slider up and down to
pick a color. (Compare the two swatches to the left of the Cancel button to
see the new color above the previously selected color.) If you click the button
to the left of the S field, the slider shows saturation, and hue and brightness
are defined in the square area to the left. Starting to see the pattern? Check
out the configuration for Brightness (B) as well as the RGB and Lab options.
And note that you can type numeric values to define a color as CMYK, but
there are no buttons to the left to reconfigure the Color Picker. Likewise, you
can type in the # (hexadecimal) field below the B field, but you can’t use it to
reconfigure the Color Picker. (Hexadecimal color definition is used with
HyperText Markup Language [HTML] code in Web pages.)
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Selective Undo: The History Brush

Photoshop’s History Brush is a rather interesting
tool — think of it as “Undo in a brush.” When
you use the Edit=>Step Backward command or
the oft-employed shortcut 38+Z (Mac)/Ctrl+Z
(Windows), you reverse everything you've just
done. In contrast, Photoshop's History Brush lets
you paint back areas of your image to a prior
state, leaving the rest of the image just as it is.
For example, you can help the subject of an
image stand out by blurring the background. One
of the simplest of the many ways to do this is to
blur the whole image and then paint back the
subject with the History Brush.

To select a history state to use with the History
Brush — that is, a stage in the image’s devel-
opment to which the tool will restore it — click
in the left column next to that state in the History
palette. (In the figure here, the selected history

state is named Duplicate Image.) Remember
that the History palette holds only a given
number of states, but you can create a snap-
shot, stored in the upper portion of the palette,
by clicking the middle button at the bottom of
the History palette. The snapshots are retained
as long as the image is open. Note: The snap-
shots are discarded when the image is closed,
whether you save it or not.

If you get a message that the History Brushisn't
available, take a look at the History palette. Did
you crop the image or use the Image Size com-
mand? Any change in the actual pixel dimen-
sions of the image invalidates any prior history
states for the History Brush. No worries! Simply
select a snapshot or history state in the palette
that comes afterthe change in image size.

Between the two color swatches in the top center and the buttons to the
right are a pair of little icons that aren’t always visible. (Check them out in
Figure 14-5 if they’re not currently showing in your Color Picker.) The top
warning triangle tells you that the current color can’t be reproduced within
your working CMYK color profile. Unless you're preparing artwork for com-
mercial offset press, ignore it — it has nothing to do with your inkjet printer,
for example. If, on the other hand, you are working on a press-destined pro-
ject, click the swatch just below the warning triangle to jump to the nearest

reproducible color.

The lower icon, a little cube symbol, lets you know that your current color
isn’t Web safe. Web-safe colors are the couple hundred colors that are exactly
the same in the base color scheme for both Mac and Windows. If visitors to
your Web site have their monitors — or PDAs — set to show only 256 colors,
everyone sees the same thing with Web-safe colors. Generally, you can safely
ignore the warning because the variation isn’t worth worrying about. (If you
do want to work with Web-safe colors, click the swatch below the warning
cube icon and then mark the Only Web Colors check box in the lower left.)

After you define a custom color with the numeric fields or by clicking in the
sample colors to the left, you can easily save the color to the Swatches
palette by clicking the Add to Swatches button. Should you need to reselect
that specific color later, or even when working on another image, it’s right

there in the Swatches palette, exactly as originally defined.




Also note the Color Libraries button.
Clicking that button swaps the Color
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Spot colors, which I explain in
Chapter 6, are special premixed inks
that can be specially requested when
preparing a job for a commercial
printing press. Adding a spot color
ensures that the color will appear

in the final product exactly as
expected. However, because they
generally require an extra pass through a press, adding spot colors increases
the cost of your printing. Spot colors can be used to define colors for non-
press jobs, but the color is converted to your working color mode and printed
with a mixture of your regular inks. Return to the Color Picker from Color
Libraries by clicking the Picker button.
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Figure 14-6: Choose custom spot colors in Color
Libraries.

Working with other brush-using tools

Photoshop has a double handful of additional tools that use brushes and the
Brushes palette to make changes to your images. You can see the tools and
their Options bar offerings in Figure 14-7, shown in the order (and groups) in
which they appear in the Toolbox.
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Figure 14-7: Photoshop has almost a dozen additional brush-using tools.
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These tools aren’t used to paint color in your artwork. Rather, they’re for
fine-tuning details and repairing your images:

1 Quick Selection tool: New in Photoshop CS3, think of the Quick
Selection tool as a brush form of the Magic Wand. Drag the tool through
an area and other areas of similar color are selected. The brush size
selected in the Options bar determines the distance within which
Photoshop looks for similar colors.

1~ Healing tools: The Spot Healing Brush and Healing Brush are designed
to repair texture, like smoothing wrinkles or adding the appearance of
canvas. With the Healing Brush, you designate a source point — an area
from which you want to copy texture — by Option/Alt+clicking and then
dragging over the target area. The Spot Healing Brush, on the other
hand, automatically samples the texture around an area and makes the
target area match its surroundings. Quite cool!

1~ Color Replacement tool: Nested with the Brush and Pencil, the Color
Replacement tool replaces the color over which you drag with the fore-
ground color. Remember that the Color Replacement tool alters only the
color, not luminosity, so painting with black over pink gives you gray
rather than black. From the Options bar, you can set the tool to change
luminosity rather than color to darken or lighten, or choose to match
hue or saturation.

1~ Stamp tools: The Clone Stamp tool, unlike the Color Replacement tool or
the Healing Brush, doesn’t copy an attribute (such as color or texture)
but actually copies pixels. It’s like having copy/paste in a brush.
Option/Alt+click a source area and then drag where you want to copy
those pixels. Powerful! The Pattern Stamp tool paints with a selected
pattern, using the blending mode and opacity that you designate in the
Options bar. The Pattern Stamp tool is sometimes a good way to add tex-
ture selectively.

1 Focus tools: The Blur and Sharpen tools do just what their names say,
but you'll likely find the default 50% Strength to be way too powerful for
most jobs. Selective sharpening can help bring out details and direct
attention in an image. Likewise, selective blurring can hide minor
defects and help direct the viewer’s eye toward areas of sharpness in the
image. You can use the Luminosity blending mode with the Blur and
Sharpen tools to minimize unwanted color artifacts while blurring or
sharpening.

Tucked in with the focus tools is the Smudge tool. Click and drag to smear
pixels along the path. (I find the Smudge tool especially useful for dragging
out wispy hairs from heads that appear perhaps too well defined.)

1~ Toning tools: The Dodge tool lightens, the Burn tool darkens — and if
you use the defaults, they do it too much! When using these tools to
adjust luminosity in your image, it’s best to start with an Exposure set-
ting of about 15% and paint carefully, perhaps repeatedly, rather than
making a huge change with Exposure set to 50%.
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You'll find the Sponge tool nested with the Dodge and Burn tools. Use it
to either increase or decrease saturation as you drag. (Decreasing satu-
ration with the Sponge tool is a great way to create an image that’s par-
tially grayscale.)

New in Photoshop CS3 is a button to the right in the Options bar for both the
Healing Brush and the Clone Stamp tool. When the Sample pop-up menu is
set to All Layers or the new Current & Below option, that button gives you
the option of ignoring adjustment layers. You might want to use this option if,
for example, you're cloning or healing from multiple layers below an adjust-
ment layer to a new layer that itself would be affected by the adjustment
layer. This prevents the adjustment from being applied twice.

Filling, stroking, and dumping to add color

You have several more ways to add color to your artwork, none of which use
brushes at all. You can, for example, make a selection and fill the selection
with color via the Edit=>Fill command, or you can add a band of color along
the edge of the selection with the Edit=>Stroke command (using the dialog
boxes shown to the right in Figure 14-8). You can also “dump” color into your
image with the Paint Bucket tool, nested below the Gradient tool in the
Toolbox. Use the Paint Bucket to fill an empty selection with color or to
replace the color on which you click with the foreground color.
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Figure 14-8: Photoshop offers several nonbrush ways to add color to your images.
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Don’t forget shape layers, either! They're a great way to add perfectly defined
areas of solid color to an image. (You can read about working with shape
layers in Chapter 11.)

Using gradients

You can add gradients, which are subtle blends of color, quite easily to your
artwork:

1. Make a selection.

Unless you make a selection first, the gradient fills your entire layer. If
you want the gradient to fill the entire layer, don’t make a selection first.

2. Select the Gradient tool.

Click the Gradient tool in the Toolbox. If you don't see it, look for it
nested with the Paint Bucket tool.

3. Select a gradient.

You can open the Gradient palette by clicking the triangle to the right of
the sample gradient on the Options bar (see Figure 14-9). You can also
click the sample gradient directly to open the Gradient Editor.

4. Choose a shape.

The five buttons to the right of the sample gradient on the Options bar
show you the shapes available for the Gradient tool. (From the left, the
buttons are Linear, Radial, Angle, Reflected, and Diamond.)

5. Choose additional options.

You can pick a blending mode and opacity, flip the colors in the gradient
with the Reverse option, choose Dither to help disguise the transitions
between colors, and select the Transparency option to preserve any
transparent areas on your layer.

6. Drag the Gradient tool.

Where you start and in which direction you drag ultimately determine
the appearance of the gradient.

The background gradient in Figure 14-9 uses the Angle Gradient option on
the Options bar and the custom gradient that you see in the Gradient Editor.
Notice in the Gradient Editor the opacity stops (above the sample being con-
structed) and color stops (below the sample). The stops — the squares with
points positioned along the sample gradient — determine the color or opac-
ity of the gradient at that particular point. By default, there’s a smooth and
even blend between neighboring stops, but you can adjust the blend by
dragging the small diamonds you see on either side of the opacity and color
stops. (Hint: The active stops use filled triangles instead of hollow triangles
with their little squares.)
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Click anywhere along the top (opacity) or bottom (color) of the gradient to
add a new stop. Drag stops to move them. Option/Alt+drag a stop to dupli-
cate it. Change the attributes of the selected stop with the options just below
in the Gradient Editor.

After designing your new gradient, remember to click the New button to add
it to the Gradient palette. But keep in mind that custom gradients aren’t
really saved until you use the Save button or the Preset Manager to create
sets on your hard drive. If you don’t save your custom gradients, they’ll be
gone if you need to reset Photoshop’s Preferences file (see Chapter 3).
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Figure 14-9: Control gradients with the Options bar, Gradient palette, and Gradient Editor.

Browsing the Brushes Palette
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Photoshop’s Brushes palette provides a bewildering array of options, sure to
confuse even the most diligent explorer. Thankfully, unless you intend to create
fine art paintings digitally, you can safely ignore a whole bunch of options.

You must have a brush-using tool active to access the Brushes palette.

If the active tool doesn’t use brushes, the entire palette is grayed out and
unavailable. If that’s the case, simply press B on the keyboard to activate the
Brush tool.
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An overview of options .
ew Brush Preset

The Brushes palette, like the Layer o i o
Style dialog box, has a column on the
left that lists options. Like the Layer v B
Style dialog box, you mark the check S T ] ""f Torowy,
box to activate the feature, but you el B EICTEIEE | el
have to click the name to open that HIRHAAAER | T
pane in the palette. (If you open the RCIEIEEL IR | Gy
Brushes palette and see only the e T SEIRALIE ] | [resiotiong
sample brush tips, open the palette =l LI T IRRIR | Bt
menu and select Expanded View.) e Bl a6 L RN asenessnnes
As you can see in Figure 14-10, the b W 1| Campraphe Mrunbes

= Dwop Shadow Brushes
Brushes palette menu offers a pretty O Medis rushes
normal selection of commands, e | S
. . . . . Nawral Brushes
including the variations in how to ara | oo Eheainanes
display the palette content, some Tk Hew srsbes
housekeeping commands for reset-
ting/loading/saving brushes, and a list
of brush sets at the bottom of the Figure 14-10: The Brushes palette and its
menu. menu — quite a handful!

And don’t overlook those little lock icons to the right of the various pane
names. Click the lock to preserve the settings in that pane while you switch
among brush tip presets. Any unlocked attributes revert to those with which
the brush tip was created. Locking, for example, Shape Dynamics retains
those settings even if you switch to a totally different brush tip.

Here, in order, are the panes and the options in those panes to which you
should pay attention:

1~ Brush Presets: Here’s where you pick the basic brush tip shape from the
brushes loaded in the palette. You can also resize the brush tip, but
that’s it. Note the lack of a check box in Figure 14-10. You don’t activate/
deactivate Brush Presets; you just pick a brush tip and size and then
move on.

1~ Brush Tip Shape: Also without a check box, Brush Tip Shape is the pane
in which you customize the selected brush tip. (Refer to the Brush Tip
Shape pane in Figure 14-3.) This is perhaps the most important part of
the Brushes palette. In this pane, you can select a brush tip, change its
size, alter the angle at which it’s applied, change the height-width rela-
tionship (Roundness) of the tip, and adjust the Spacing setting.

1~ Shape Dynamics: Dynamics in the Brushes palette add variation as you
drag a tool. Say you're working with a round brush tip and choose Size
Jitter. As you drag the brush tip, the brush tip instances (the individual
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marks left by the brush as you drag) will vary in diameter. The Shape
Dynamics pane offers Size Jitter, Angle Jitter, and Roundness Jitter. Each
of the “jitters” can be set to fade after a certain number of brush tip
instances or can be controlled with the stylus that you use with a Wacom
tablet. Angle can also be set to Direction, which forces the brush tip to
adjust the direction that you drag or the direction of the selection or path
you stroke. Use Shape Dynamics to add some variation and randomness
to your painting, as shown in Figure 14-11.

T — ]

[T "

A Cons | etsen

pEnERoEDEDD

)

[T ——

iy e [Ty

@% ﬂ@m@@w

Figure 14-11: Use jitter to add variation to the application of your selected
brush tip.

1~ Scattering: Scattering varies the number of brush tip instances as you
drag as well as their placement along the path you drag. Like the shape
dynamics, scattering can be set to fade or can be controlled with a
Wacom tablet.

1~ Texture: Use the Texture pane to add a pattern to the brush tip, as
shown in Figure 14-11. You can select from among the same patterns that
you use to fill a selection. Texture is most evident when Spacing for the
brush tip is set to at least 50%.

1 Dual Brush: Using a blending mode you select, the Dual Brush option
overlays a second brush tip. You could, for example, add an irregular
scatter brush to a round brush tip to break up the outline as you paint.

1 Color Dynamics: Using the Color Dynamics pane, you can vary the color
of your stroke as you drag. This comes in most handy for painting
images and scenes rather than, say, working on an alpha channel. Just as
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you might add jitter to the size, shape, and placement of a grass brush
while creating a meadow, you might also want to add some differences
in color as you drag. You could pick different shades of green for the
foreground and background colors and then also add jitter to the hue,
saturation, and brightness values as the foreground and background
colors are mixed while you drag.

1 Other Dynamics: Think of this pane as Opacity and Flow lJitter. You can
add variation to the opacity and flow settings from the Options bar as
you drag.

1 Other Options: At the bottom of the left column are five brush options
that don’t have separate panes in the Brushes palette. They're take-it-or-
leave-it options — either activated or not.

e Noise: Adding Noise to the brush stroke helps produce some tex-
ture and breaks up solid areas of color in your stroke.

e Wet Edges: Wet Edges simulates paint building up along the edges
of your stroke.

e Airbrush: The Airbrush check box simply duplicates the button on
the Options bar.

e Smoothing: Smoothing helps reduce sharp angles as you drag your
mouse or stylus. If the stroke you're painting should indeed have
jagged turns and angles, disable Smoothing.

e Protect Texture: The Protect Texture option ensures that all the
brushes with a defined texture use the same texture. Use this
option when you want to simulate painting on canvas, for example.

When creating a dashed line or stroking a path with a nonround brush tip, go
to the Shape Dynamics pane of the Brushes palette and set the Angle Jitter’s
Control pop-up menu to Direction. That enables the brush tip to rotate as
necessary to follow the twists and turns of the selection or path that it’s
stroking. (You'll generally want to leave Angle Jitter set to 0% so that the
stroke follows the selection or path precisely.)

Creating and saving custom brush tips

You can use any artwork as a custom brush tip — you can even make a brush
tip from your own face! With the artwork on a transparent or white back-
ground (you don’t even need to make a selection), choose Edit=>Define Brush
Preset. Type a name (see Figure 14-12) and click OK. Your new custom brush
is added to the Brushes palette. After you define a piece of artwork as a
brush, you can add that image to any project with a single click or drag.
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As soon as you define your custom
brush, open the Brushes palette,
select the new brush, and set Spacing
and any other options that you'll
generally want to use with the new
brush. Then from the Brushes palette
menu, choose the New Brush Preset
command and resave your custom
brush. Now when you select your
custom brush, you have your pre-
ferred settings all ready to go!

Keep in mind these things when
creating custom brushes:

1~ All brushes are grayscale.

Regardless of the color in the Figure 14-12: Define the new brush preset, set

artwork that you use to create o options in the Brushes palette, and resave.
your new brush, the brush itself

is saved as a grayscale representation of the art.

1 The maximum size for a brush is 2500 pixels. If you, for example, scan
your signature to use in a custom copyright notice for your images and
Define Brush Preset is grayed out, reduce the pixel dimensions with the
Image~>Image Size command.

~ Only one color is painted. Again, the brush is grayscale: It applies the
foreground color in tints to match the grays in the brush tip (unless, of
course, you use the Color Dynamics option in the Brushes palette).

+ Your art might need more contrast. You might want to convert a copy
of your original to grayscale to see whether it wouldn’t benefit from a
Levels adjustment to boost the contrast. Higher contrast often makes for
better brush tips.

1 Remember to save your custom brushes! Once again (and you’ll proba-
bly read this sort of reminder a few more times elsewhere in this book),
your custom brushes aren’t really saved until you use the Brushes palette
menu command Save Brushes to make a new set of all the brushes cur-
rently in the palette or until you choose Edit=>Preset Manager to make a
new set of only the brushes you select.



3 ’0 Part lll: Creating “Art” in Photoshop




Filters: The Fun Side of Photoshop

In This Chapter

Being productive with “fix it” filters

Getting artsy with creative filters

Adding wackiness (and precise correction) with Liquify
Taking a quick look at the specialized filters

Fe Photoshop Filter menu includes more than 100 commands that you
can use to fix, flatter, finesse, and freak out your photos. You can use
most of the filters on most of your artwork and some of the filters on some of
your artwork, and you probably won’t ever use quite a few of the filters.

In this chapter, I start you off with a discussion of the new Smart Filters feature,
something you should get used to using just about every time you apply a
filter. Next, you get a look at what I call the “production” filters: :
namely, the key filters you use to improve or repair your
images. Following that, I show you the basics of two of the
most fun features in all of Photoshop: the Filter Gallery
and Liquify. Not only are they fun, but you can use
them to do wondrous things to your artwork. [ wrap
up the chapter with a look at several other key filters.

Smart Filters: Your Creative
Insurance Policy

&ATURE Photoshop CS3 introduces re-editable filters, a feature

§ that’s been on the top of most users’ wish list since the
introduction of adjustment layers in Photoshop 4 (sequentlally, E‘ RN
Photoshop CS3 would be “Photoshop 10”). With Smart Filters, you

can apply one or more filters to a Smart Object (a specific sort of layer) and

later change your mind about what settings — or even what filters — to use.

Without reverting to a saved copy of the file or using the History palette.

Unlike adjustment layers, which are, in fact, separate layers in the image,
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Smart Filters work more like layer styles. They appear in the Layers palette
below the layer to which they’re applied and can be shown or hidden by
clicking an eyeball icon (see Figure 15-1). And, like layer styles, you can
reopen a Smart Filter by double-clicking it in the Layers palette.

As you can see in Figure 15-1, the layer Inside Passage-02 (the active layer,
highlighted in the Layers palette) has both layer effects and Smart Filters
applied. The type layer above has only layer effects, whereas the other two
Smart Objects, below in the Layers palette, have Smart Filters but no layer
effects. Clicking the triangle to the far right of a layer name expands and col-
lapses the list of effects and filters applied. Clicking the eyeball icon to the
left of an item hides it without removing it. You can delete a Smart Filter by
dragging it to the Trash icon (just as you can with layer effects), which
removes its effect from the layer. To reopen a filter’s dialog box to change
settings, simply double-click the filter name in the Layers palette.

e‘gN\BER Smart Filters can be applied only to Smart Objects (which are discussed in
& Chapter 10). Luckily, you can convert any pixel-based layer, even a back-
ground layer, to a Smart Object simply by selecting that layer in the Layers
palette and choosing Layer~>Smart Objects>Convert to Smart Object.
You can even select multiple layers in the Layers palette and create a single
Smart Object with that command. You can then apply a Smart Filter to all of
the layers in the Smart Object.

INETDEPASEAGE,

Figure 15-1: Smart Filters are more like layer styles than adjustment layers.
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Because you can easily remove or change Smart Filters, they provide you
with a special sort of creative license: the license to experiment and change
your mind. Because they are nondestructive (they don’t make permanent
changes to the pixels in your image), you can use Smart Filters without fear
of damaging your image. Of course that doesn’t mean you shouldn’t work on
a copy of your beautiful photo — it’s always better to safeguard the original
image file and work on a duplicate.

The Filters You Really Need

WBER

Photoshop has several filters that you can use on just about any image to
improve or finesse it. Most photos, for example, benefit from at least a little bit
of sharpening to improve the detail in the image. In some cases, you want to
decrease the visible detail in an image in areas to hide defects, or perhaps you
want to blur a background to draw more attention to the subject of your shot.
And Photoshop has a couple of filters that you'll find handy for correcting lens
distortion and reducing noise (specks of red, green, and blue) in digital photos.

Some filters aren’t available for images in CMYK (cyan/magenta/yellow/black)
color mode, and some aren’t available when you’re working in 16-bit color.

All the filters are available for 8-bit RGB and grayscale images. (No filters are
available for GIF or PNG-8 images, which use Indexed Color mode.) And keep
in mind that you can apply filters to specific areas of an image by making a
selection first. (See Chapter 8 for info on selections and masks.)

You can instantly reapply the last used filter exactly as it was applied with
the keyboard shortcut 38+F (Mac)/Ctrl+F (Windows). If you'd like to reopen
that last-used filter’s dialog box to change settings before reapplying, press
Option+8+F/Alt+Ctrl+F.

Sharpening to focus the eye

When looking at an image, your eye is naturally drawn to certain areas first.
You generally look at bright areas before dark areas and areas of detail before
smoother areas in the image. Compare, for example, the three photos in
Figure 15-2 (which were taken using different focal lengths and lens aper-
tures). Using Photoshop’s sharpen and blur filters enables you to control the
amount of detail throughout your image or in specific areas in order to con-
trol the areas to which you want to draw attention.

Photoshop offers five sharpen filters, three of which you can ignore. The
Sharpen, Sharpen More, and Sharpen Edges filters have no user-definable set-
tings and simply work in accordance with their names. Sure, they do a good
job, but you don’t have that all-important control over your images! Skip
them in favor of the it-takes-some-work-but-it’s-worth-it sharpening filters:
Unsharp Mask and Smart Sharpen.
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Figure 15-2: Blurry backgrounds help the subject stand out.

Unsharp Mask

The Unsharp Mask filter is, indeed, a sharpening filter, despite the name
(which comes from the blurry — unsharp — mask created from a copy of the
image and used in the sharpening). As you can see in Figure 15-3, Unsharp
Mask offers three sliders to adjust the appearance of your image.

In the upper left, you see the original image at 100% zoom. The middle image
shows the sharpening at 100% zoom. To the right is a 300% zoom in the pre-
view area of Unsharp Mask’s dialog box.

Radit: 3.0 Dinils
.

Threshold: |2 levehy

Figure 15-3: Despite its name, Unsharp Mask actually sharpens your image.
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P Always evaluate your filters at 100% zoom even if you need to shrink the
window to only a critical portion of the artwork. Zoomed-in or zoomed-out
views might not accurately reflect the changes that you're making because
the image isn’t displayed with one screen pixel representing one image pixel.
You can, of course, open a second view of the same image with the Window=>
Arrangec>New Window for [filename] command.

Unsharp Mask works by identifying lines of strong PR e
contrast — the edges of elements within your - o
image — and increases the contrast along those s |
edges. Along the border of a dark area and a light N o
area, Unsharp Mask uses a thin band of light anda | «

thin band of dark to create a light and dark halo
along the edges. That makes the edge appear much Figure 15-4: You adjust three
more defined. Here’s how Unsharp Mask’s sliders  sliders when sharpening with
(as shown in Figure 15-4) work to control the effect. Unsharp Mask.

» Amount: The Amount slider determines how much sharpening is actually
applied by controlling the brightness and darkness of the halo. An amount
of 50% is often suitable for small images that are already in pretty good
shape. Use 100% for general photos. Use larger values, up to 500%, for
special effects.

1~ Radius: Use the Radius slider to determine the width of the halo. You typ-
ically need a value as low as 1 pixel for small images and perhaps as high
as 7 for larger images that don’t have a lot of tiny detail.

1~ Threshold: The Threshold slider helps you avoid destroying your
image by oversharpening fine details. If the tiniest details in the image
get wide, bright halos, they can look garish and unnatural. The higher
the Threshold setting, the larger an area must be before sharpening is
applied. Typical Threshold settings are 2 for a small image and 5 or 7
for a large image.

Smart Sharpen

The Smart Sharpen filter provides you with an incredible amount of con-
trol over the sharpening process. Although it won’t (quite) be able to

give you a crisp image of that bank robber from the pixelated, blurry
surveillance camera (that happens only on TV), it will help you improve just
about any image. Those who photograph through microscopes and tele-
scopes might find this filter particularly useful. However, remember that
although you might improve an image, some blurs won’t be removed by
sharpening.
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Figure 15-5 shows how well Smart Sharpen works with an appropriate image.
In this image, the blurring is consistent throughout the subject of the shot,
and there is a reasonable amount of blur. Note in Figure 15-5 that when you
select the Advanced radio button, you get a pair of new tabs in the dialog
box: Shadow and Highlight. Use those tabs to control how strongly the effect
is applied in the darker and lighter parts of the tonal range.

—o—3
Cancel
W poen
Saic @ Advanced
Semingt:  Default -5.‘ & A
Srarpen  Shasdow “LHsghight .

Amount: 110 %
.

Radius: 7.5 Dimaly
.

Ramove: LensBler T80

# More Accurame

Figure 15-5: Smart Sharpen does a great job with appropriate images.

Smart Sharpen also enables you to specify any of three types of blurring that
can be plaguing your image: Gaussian Blur (a uniform blur), Lens Blur (areas
of blur beyond the focal distance of the lens), and Motion Blur (the subject or
camera moving while the shot was taken). If you don’t see distinct evidence
of lens blur or motion blur, stick with Gaussian blur.

Blurring images or selections

As you can see in Figure 15-2, blurred areas in an image attract less attention
than do the sharper parts of the photo. By making a selection, you can selec-
tively apply Photoshop’s blur filters. You can also use the blur filters to hide
flaws in an image, including dust, noise, and unwanted little bits and pieces in
the picture. You might also want to blur all or part of an image prior to using
some of the artistic filters available in the Filter Gallery (which I discuss later
in this chapter).

Photoshop provides you with almost a dozen different blur filters. Although
you’ll eventually develop a special fondness for one or two blur filters, it’s
good to know how each of them works. Table 15-1 gives a quick overview of
the available filters.
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Table 15-1 The Workings of Photoshop Filters
Filter Name  What It Does Tips on Using It
Average This filter looks at each of the ~ Changing the opacity or blending

pixels in the selection, deter-
mines the average color value,
and then assigns that color to
all the pixels in the selection,
producing an area of solid color.

mode with the Edit=>Fade Average
command afterward softens the
averaging to the point where it's
more useful.

Blur The Blur filter applies a slight ~ Apply the Blur filter and then
blur throughout the image or use the shortcut 38+F/Ctrl+F to
selection. reapply the filter numerous times

to make the effect stronger.

Blur More Blur More is simply a stronger
version of the basic Blur filter.

Box Blur The Box Blur filter blurs the In the Box Blur dialog box, you
image vertically and horizon- control the filter with a Radius
tally; you see the effect most slider.
noticeably in small highlights
that tend to bloom into squares.

Gaussian This filter produces a smoothly ~ Get more control over the blurring

Blur blurred version of your image effect by using a Radius slider that
without the distracting artifacts  lets you control the amount of
and lines you get by repeatedly  blurring.
applying the Blur More filter.

Lens Blur This filter simulates the effect ~ Use an alpha channel (a saved
in which the camera’s zoom selection) to determine where and
and aperture create a sharp how strongly the filter is applied.
foreground and a blurry For a look at the Lens Blur filter
background. in action, see Figure 15-6.

Motion Blur  This filter lets you choose any ~ Use it without a selection to pro-
angle and a wide range of duce the illusion that the camera
distances (measured in pixels)  (not the subject) was in motion.
to suggest motion for all or Make a selection and copy it to
part of an image. a new layer to blur just that part.

Radial Blur ~ Anincredibly powerful, yet With no preview available, you

incredibly flawed, tool that
blurs in a spinning motion
around a center pointin your
image or selection, or simulates
zooming in on that point.

have no idea what settings are
appropriate for your image
(and artistic vision) without trial
and error.

(continued)

317



3 ’8 Part lll: Creating “Art” in Photoshop

Table 15-1 (continued)
Filter Name What It Does

Tips on Using It

Shape Blur  Uses a Radius slider and one of
the shapes from your Shapes
palette as a pattern for the blur.

You can load additional shapes by
using the small black triangle at
the upper right of the shapes area.

Smart Blur ~ Controls the blur by recogniz-
ing edges (areas of extreme
difference along a line of pixels)
and blurring within those areas.

Use Smart Blur in Normal mode
to eliminate all fine detail in your
image, use it again in Edge Only
mode to trace edges in the image,
and then use the shortcut 88+l/
Ctrl+l to invert the image, which
produces a black-on-white sketch
of your original.

Surface This filter goes beyond Smart

Blur Blur in preserving edges.
Restrict the blur to large areas
of similar color in the image,
leaving the fine detail of the
image unblurred.

Much like working with the
Unsharp Mask filter, you use a
Radius slider to determine the
amount of change and a Threshold
slider to exempt some areas of
the image from the change.
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Figure 15-6: Lens Blur can use an alpha channel (mask) to control the blur.



Chapter 15: Filters: The Fun Side of Photoshop 3 ’ 9

The Edit=>Fade command

Immediately after applying just about any filter or adjustment command and after using many of
Photoshop's tools, you can adjust the effect with the Fade command, found under the Edit menu.
(Keep in mind that Fade is available only immediately after using a filter, adjustment, or tool. You can't
even use the Save command in between.)

With Fade, you can reduce the opacity of the previous command or tool, thus reducing its impact
on your image. You can also change the blending mode, which alters how the command or tool
interacts with pixel colors prior to your change. Say, for example, you paint a black stroke with the
Brush tool set to Normal and 100% opacity. Immediately afterward, you choose Edit Fade Brush. You
can then pick a new blending mode and/or reduce the opacity setting, which changes the painted
stroke to appear as if you'd selected the new settings in the Options bar before painting.

You can also apply the Unsharp Mask (or Smart Sharpen) filter and then choose Edit=>Fade Unsharp
Mask, as shown in the figure here. (Yes, the Fade command changes names automatically!) In the
Fade dialog box, changing the blending mode
from Normal to Luminosity ensures that your
Unsharp Mask filter doesn't alter the color of
pixels along edges. Using the Fade command this
way is the same as if you'd switched to Lab
color mode and sharpened only the L channel —
without having to switch color modes at all.

Note that the Edit=>Fade command isn't available
when you're working with Smart Filters. If you
need to fade the filter, you can first choose
Layer=>Smart Objects=>Rasterize and then apply
the filter. You lose the advantages of working with
Smart Objects and Smart Filters, but the Edit=>
Fade command will be available.

Using the Lens Correction filter

The Lens Correction filter (find it among the Distort filters) does a wonderful
job of cleaning up pin cushioning and barrel distortion (the outer edges of
your image appear to bend inward or outward, respectively). You'll see pin
cushioning when shooting with a telephoto lens at its max zoom and barrel
distortion at the lens’s lower magnification. Both are most obvious when the
photo has what should be straight lines at the edges. You can also use Lens
Correction to adjust the vertical or horizontal plane of an image. In Figure 15-7,
you see the Lens Correction window, a rather complex working environment.

Here’s what you have at your disposal in the Lens Correction window:
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Figure 15-7: Fix barrel distortion, pin cushioning, and perspective with Lens Correction.

In the upper-left corner of the window are five tools:

1~ Remove Distortion (top): Select this tool to drag in the preview area to
adjust the distortion factor.

1~ Straighten (second): This tool is simple: Click and drag along any line in
the image that should be straight, and the image is straightened!

He 1 Drag Grid (middle): Use this to reposition the grid overlay, aligning it
:T:' with the content of your image.

1 Hand and Zoom: The lower pair of tools should look familiar. The Hand
"l and Zoom tools function as they do anywhere in Photoshop: When the
image doesn'’t fit in the window, click and drag with the Hand tool to repo-
sition; click the Zoom tool to zoom in, or Option/Alt+click to zoom out.

You can also find

1 Remove Distortion slider: The Remove Distortion slider is the heart of
this filter. You use this to compensate for pin cushioning or barrel distor-
tion in the image. Drag it back and forth until your image’s vertical and
horizontal lines are straight throughout the image.
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1 Chromatic Aberration sliders: Sometimes a photograph shows dis-
torted color along fine angular lines, such as the branches of trees or
latticework. You can minimize these colored halos or fringes with the
Chromatic Aberration sliders. Generally speaking, you want to zoom in
close on a specific area of detail to make the adjustment.

1~ Vignette sliders: Drag the Amount slider to the left to add a dark vignette

(fading along the outer edges of the image) or to the right for a white
vignette. The Midpoint slider increases and decreases the amount of
shadowing or highlight along the edges.

1 Transform controls: Use the Vertical Perspective and Horizontal
Perspective sliders to make your image appear parallel to the viewer.
Much like using the perspective crop option or the Edit=>Transformr>
Perspective command, you're changing the perceived angle of the image
to the viewer.

1 Zoom and grid: Click the minus and plus buttons in the lower-left corner

to zoom out and in, or choose a preset zoom factor from the pop-up
menu. Click and drag on the Size field’s label (the actual word Size) to
resize the grid. Click the color swatch to change the color from the
default gray. (I liked bright yellow for the image in Figure 15-7.)

1~ Saving and loading settings: From the Lens Correction window’s menu
(to the right of the Settings pop-up menu), you can save settings and
load them later. Because you can name the settings, you can save a set
for each of your lenses, at each of their zoom factors, and apply the
same correction easily, time after time.

Although Lens Correction is designed to fix images, there’s no reason why
you couldn’t use it for special effects. For example, rather than using the
Perspective command, you can use the Vertical Perspective and Horizontal
Perspective sliders in Lens Correction, and perhaps add some barrel distor-
tion as you would with the Distorte>Pinch filter.

Cleaning up with Reduce Noise

Digital noise — those annoying red, green, and blue specks in your image —
can ruin an otherwise lovely picture. (To avoid noise, make sure that your
camera is set to shoot at the lowest ISO setting possible.) Photoshop also has
a filter for reducing (not necessarily eliminating) digital noise in your images.
Found in the Filter->Noise menu, Reduce Noise can do an excellent job of
minimizing the random red, green, and blue pixels in your image, as you can
see in Figure 15-8.

When you work with Raw images, do all your noise correction in the Camera
Raw plug-in (see Chapter 7). For images in formats other than Raw, use the
Reduce Noise filter.

Chapter 15: Filters: The Fun Side of Photoshop
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Figure 15-8: Reduce Noise neutralizes the red, green, and blue specks in a digital image.

Here are the steps that [ recommend when you use the Reduce Noise filter:

1. Set the details sliders to 0 (zero).

In the Reduce Noise dialog box, drag the Preserve Details and Sharpen
Details sliders all the way to the left. This eliminates any interference
with the actual noise reduction.

2. Reduce Color Noise.

Use the Reduce Color Noise slider to minimize the red, green, and blue
specks in your image. Drag the slider slowly to the right until the color
noise is gone.

3. Adjust Sharpen Details.

Increase the Sharpen Details slider 1% at a time until the color noise
returns; then back off 1%.

4. Adjust Preserve Details.

Drag the Preserve Details slider to the right until you have a good balance
between image detail and any luminance noise (bright and dark specks)
in the image. In Figure 15-8, the distant trees are unlighted, yet some of
their detail can be retained with Preserve Details.
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If you see noise of one color considerably longer than the others when drag-
ging the Reduce Color Noise slider, click the Advanced button near the top of
the dialog box and work with each channel individually, according to its needs.
Also note the Remove JPEG Artifact check box at the bottom of the window.
If your image is suffering from JPEG compression problems, selecting that
check box might help relieve the effects. (JPEG compression often results in
visible borders between 8 x 8 pixel squares within your image.) Remember,
too, that you can use the button to the right of the Settings pop-up menu to
save your correction for future use — it will be added to the Setting menu.

Getting Creative with the Filter Gallery

You can apply and combine many (but not all) of Photoshop’s creative filters
by choosing Filter=>Filter Gallery. This integrated window lets you use multi-
ple filters at the same time rather than guessing which settings will look good
with another filter applied later. Each filter remains live (you can change the
settings) until you click OK. Check out Figure 15-9.

Effects viewing pane Filter pane Filter settings

Texturizer (500 ‘
A =  x )

[

Hide effects Filter stack

New Effect Layer button  Trash

Figure 15-9: The expansive Filter Gallery interface.
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The basic workflow goes like this: Adjust a filter, add a new filter to the stack,
select the new filter in the middle pane, adjust the settings to the right, add a
new filter to the stack, and so on. If you adjust your first filter settings and
then click another filter in the middle column before adding another effect,
you replace the first filter rather than adding to it. (If you Option/Alt+click a
new filter, it will be added to the stack rather than replace the active filter in
the stack.) Here’s my step-by-step strategy for working in the Filter Gallery
window:

1. Prepare your image before entering the Filter Gallery.

Many of Photoshop’s creative filters work best when you prepare the
image (or parts of the image) first. You have a couple of key filters that
don’t appear in Filter Gallery:

e Smoothing detail: Because Photoshop’s art-related filters can con-
centrate on details in your image, too much fine detail can make
your filter effects crowded and cruddy. Before working with Ink
Outlines, for example, try eliminating the tiny little bits in your
image. You could try either Smart Blur or Surface Blur.

¢ Adding detail: Many of Photoshop’s filters don’t do anything if the
target area doesn’t have some texture or detail with which to work.
That’s where the Add Noise filter comes in handy, adding dark and
light specks to the smooth area. Use the Monochromatic and
Gaussian options, with an Amount setting from 10% to 15%.
After adding noise to the too-smooth area, consider using the
Blur=>Motion Blur filter or the Pixelater>Crystallize filter (to make
small specks bigger).

2. Don’t forget layers and blending modes.

Make a copy of your layer before entering the Filter Gallery so you
can later mess around with layer-blending modes and opacity to com-
bine the filtered version with the original, which can soften or even
enhance the effects you've applied. Remember, too, that you can con-
vert a layer to a Smart Object before applying filters so that the filters
will later be re-editable. (See the discussion of Smart Filters near the
beginning of this chapter.)

3. Add to the stack before selecting filters.

You make your initial filter selection and adjustment. Then, before you
switch to a different filter in the middle pane of the window, you need to
add a filter to the stack by clicking the New Effect Layer button in the
lower-right corner (to the left of the Trash icon).

4. Play with the stacking order.
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Drag filters up and down in the stack at the lower right to change their
order.

The order in which the filters are applied often makes a huge difference
in the final appearance of your image.

5. Use the eyeball column.

It’s a good idea sometimes to hide one or more effects in the stack while
you fine-tune a filter’s settings.

Filters are cumulative — changes that you make to one filter can them-
selves be changed by other filters in the stack.

Not all creative filters are available in the Filter Gallery. Remember that
Photoshop has dozens of filters that are available only through the Filter
menu, not through Filter Gallery. And don’t forget that many filters can be
used only with 8-bit RGB (red/green/blue) images. If you see a lot of grayed-out
filters in the menu (or if Filter Gallery itself is grayed out in the Filter menu),
choose Imager>?Mode and make sure that you're working in 8-bit color and
the RGB color mode.

Push, Pull, and Twist with Liquify

Although the Lens Correction filter has added another powerful correction
tool to your arsenal, you still want to sometimes fix a photograph’s perspec-
tive or barrel distortion with Liquify. Perhaps. But with Lens Correction now
available, Liquify can concentrate on its fun side.

[ know of nothing in Photoshop that can bring a smile faster and more easily
than creating some strange creature from a friend or loved one in Liquify. I will
readily admit that the glow produced by the praise of an art critic is gratify-
ing, but does it compare to, “More, Uncle Pete! Give me bigger ears!”? It would
certainly be a disservice to the Liquify feature to overlook its powerful image-
correction capabilities, so please remember that almost anything you can do
to emphasize or enhance an attribute can be done in reverse to minimize that
aspect of the image. Make someone short and wide? You can also make them
tall and thin. Creating a bulging nose? Create a slim and pert nose. It’s all pos-
sible with Liquify.

That having been said, examine Figure 15-10, which shows some rather dra-
matic changes. (But it should give you some idea of how useful Liquify can be
for more subtle tasks, like trimming tummies, toning arms and legs, thinning
noses, and other such work.)
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Figure 15-10: Liquify gives you unbelievable control over the pixels in your image.

Take a look at the tools arrayed along the left edge of the Liquify window.
Here’s what they do, starting at the top:

drag the Forward Warp tool to push the pixels around.

1 Reconstruct tool: Use the Reconstruct tool as your “undo.” (When in
Liquify, you can use 8+Z/Ctrl+Z, but it goes back only one step.) Drag
over areas that you want to restore to their original appearance.

3 1~ Twirl Clockwise tool: Click and hold the mouse button down or drag in
E‘ a circle to spin the pixels within the brush diameter. And if you want to
twirl counterclockwise, simply add the Option/Alt key.

1~ Pucker tool: The Pucker tool sucks pixels into the center of the brush.

% !I 1 Forward Warp tool: Much like Photoshop’s Smudge tool, you click and

'E:_E‘ You can click and hold or drag the Pucker tool. Holding down the Option/
Alt key toggles you to the Bloat tool.
= 1~ Bloat tool: The opposite of the Pucker tool, the Bloat tool pushes pixels
":::" out from the center. Holding down the Option/Alt key switches to the

Pucker tool.

1~ Push Left tool: As you drag the Push Left tool, pixels are shifted to the
E" left of the path along which you drag (not necessarily to your left). If you
drag up, the pixels are shifted to the left on the screen; drag down, and
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the pixels are shifted to the right. Use the Option/Alt key to reverse the
behavior and push pixels to the right of the path.

= 1 Mirror tool: As you drag the Mirror tool, whatever pixels are immedi-
] ately to the left of the cursor as you drag are flipped and pasted into the

brush along the path you drag. When dragging left to right, whatever is
directly above the cursor as you drag is flipped and copied into the brush.
For best results, use the Freeze Mask tool (see the upcoming bullet)

on the pixels that you want to copy before using the Mirror tool.
Holding down the Option/Alt key reverses the behavior, copying the
pixels to the right of the path as you drag.

1 Turbulence tool: The Turbulence tool is great for adding smooth distor-
tion along the path you drag. Think of it as making waves along the path.

Holding down the Option/Alt key switches the Turbulence tool to the
Reconstruct tool.

l:.j 1 Freeze Mask tool: One of the most important tools, the Freeze Mask tool
|: lets you protect areas of your image from change. Paint over an area

(you see a red mask) to freeze it — to keep it from changing.

1~ Thaw Mask tool: Unprotect areas with the Thaw Mask tool. It removes
[g the red overlay and lets you liquify the area again.

Ty 1~ Hand tool: As always, the Hand tool lets you reposition an image in the
N window when it doesn’t all fit. Just click and drag your image to move it

in the preview window.

1 Zoom tool: As you might suspect, the Zoom tool functions as it usually
"l does. Click to zoom in, Option/Alt+click to zoom out, and click and drag

to zoom in on a specific area.

To the right in the Liquify window are a number of variables and options. Brush
Size is the tool brush diameter; Brush Density is comparable with feathering
(lower is softer); and Brush Pressure controls the strength of the active tool.

The Reconstruct Options let you restore or partially restore your image to
the original appearance. The Reconstruct button is less like Step Backward or
Undo and more like Fade. Rather than reversing the liquification steps you've
already applied, it weakens them. The Mode pop-up menu offers several ways
to control how strictly the image is reconstructed. The mode that you select
is also used with the Reconstruct tool. (Revert is the most precise mode.)
The Restore All button returns your image to its pre-Liquify appearance.

If you're working on only one layer of your image and that layer has a layer
mask or transparent areas, or if you make a selection before entering the
Liquify feature, you can use the buttons in the Mask Options area to create
frozen areas (areas that are protected from change).

Near the bottom of the right side of the Liquify window (shown earlier in
Figure 15-10), you can see the View Options, which let you show and hide the
mesh: the actual distortion you're creating. Note the mesh size and color
options.
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Do I Need Those Other Filters?

Photoshop has dozens of filters, creative and productive, that you access
through the Filter menu rather than through the Filter Gallery. Some do strange
and wonderful things to your selection or image, and some just do strange
things that you might never need. You can find a description of each of the fil-
ters in Photoshop’s Help, but a couple of them are worth a bit of attention here.

Bending and bubbling

In the Filter=>Distort menu, you find ot
both the Shear and the Spherize filters, |- }' o

both of which are simpler alterna- _: 0
tives to Liquify for many projects. e
Use the Shear filter to bend a selec- Dok
tion back and forth, creating curves.

Use Spherize to create a bulging,

rounded image. Both Shear and

Spherize are easiest to control when

you make a selection of your target

and copy it to a new layer. And, as Figure 15-11: The Shear filter bends; the
you see in Figure 15-11, Shear works  gpherize filter bulges and pinches.
only vertically, so you might need to

rotate your image before and after the filter.

Creating clouds

Clouds make lovely, unobtrusive back-
grounds (as you see in Figure 5-12)
that can be scaled and transformed
to produce smoke or steam, and you
can even create marbling effects
from clouds. In the Filterz>Render
menu, you find Clouds and Difference
Clouds. Both filters use a mixture

of the foreground and background
colors to create a cloud pattern.

The Clouds filter replaces the con-
tent of the selection or layer (if any),
and Difference Clouds interacts with
the existing pixels (you can't use it Figure 15-12: The Clouds filter produces
on an empty layer) pretty much like ~ Pleasantbackgrounds.

Clouds using the Difference blending

mode. Apply Difference Clouds several times, perhaps as many as 20, to
create abstract backgrounds and marble patterns, or perhaps to simulate
microscope slides.
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his part is more specialized than the others in
the book. These two chapters cover features
of Photoshop that you might never need.

Chapter 16 shows you how to streamline some

of your work with Photoshop’s automation com-
mands. You also read about recording Actions and
get a quick look at using scripting to automate
Photoshop. Keep in mind that Chapter 16 also
includes information on printing multiple images
on a single sheet of paper — saving both time and
money!

If you purchased Photoshop as part of a “Suite” or
“Bundle” (integrated Adobe programs, designed to
work together), you might have Photoshop CS3
Extended, or you might have intentionally pur-
chased the Extended version. Chapter 17 takes a
look at the highly specialized tools for science,
medicine, research, rotoscoping, and 3D included
with Photoshop CS3 Extended. (If you have
Photoshop CS3 rather than Photoshop CS3
Extended, you can skip Chapter 17 altogether.

Or, perhaps, take a look at the complex and perhaps
confusing features that you'll likely never miss.)




Streamlining Your Work
In Photoshop

In This Chapter

Taking advantage of Photoshop’s built-in automation commands
Working with Actions

Using prerecorded scripts

A lot of the work that you do in Photoshop is fun — experimenting with
filters, applying creative adjustments, cloning over former in-laws,
that sort of thing. A bunch of your work, though, is likely to be repetitive,
mundane, and even downright boring. That’s where automation comes in.
If a task isn’t fun to do, if you need to speed things up, or if you need to
ensure that the exact same steps are taken time after time,
automation is for you.

I open the chapter with a look at some of Photoshop’s
major automation features — commands that help
you quickly and easily create presentations, contact
sheets, and even near-instant Web sites. Next, | show
you a couple of production-oriented commands that
let you print multiple images on a single sheet of
paper (and that can save a bunch of money!).

Next, you see how to play Photoshop’s Actions and
even record your own. The chapter wraps up with a
quick look at scripts, such as the very powerful Image
Processor. Scripts are sort of little computer programs
that you use to control your computer — Photoshop,
other programs, your printer, or even an operating system
itself.
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Portable Document Format (PDF), the
native file format of Adobe Acrobat, Browst
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Figure 16-2: PDF is a great format for sharing

multipage PDF in Photoshop, take the images as presentations or as documents.

following steps:
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1. If the files you want to use aren’t already open in Photoshop, click the
Browse button. You can click and then Shift+click to select a series
of images or $#+click (Mac)/Ctrl+click (Windows) to select individual
images.

Hint: You must select the images; you can’t select only the folder.

After you click the Open button, the filenames appear in the PDF
Presentation window. Drag filenames up or down to reorder them.

2. In the Output Options area, you can elect to create an on-screen pre-
sentation or a multipage document.

You can choose to have a white, gray, or black background and what file-
related information you want on each slide or page. Electing to include
the filename (and perhaps your copyright information) is a good idea
when sending images to someone who needs to know the image name,
say, to order prints and give you cash.

3. Select how you want the presentation to play.

You can have the presentation automatically switch images after a given
number of seconds (or opt for manual slide advance), you can have the
presentation automatically rewind and begin playing again (loop), or
you can pick transitions between images. Do your audience a favor and
pick a single transition and stick with it — preferably one simple transi-
tion, such as Wipe Left or Wipe Right. Those too-busy transitions are the
twenty-first-century version of PowerPoint clip art — fun to play with,
but distracting to your audience.

4. Click the Save button.

You see the Save dialog box, from which you pick a location and a name
and then click another Save button.

5. In the Save Adobe PDF dialog box, make things simple for yourself
and choose Smallest File Size or High Quality Print from the Adobe
PDF Preset pop-up menu at the top.

If you're creating a presentation or want to create a multipage PDF from
which the recipient can’t print full-size images, choose Smallest File Size.
For a multipage document from which you do want the client to print
great images, use High Quality Print.

6. The only other area of the dialog box that you really need to consider
is Security.

You can assign a password to the file that the recipient needs to open
and view the presentation or multipage PDF document. Alternatively,
you can require no password to open the file but rather assign a pass-
word for printing or changing the file.

7. At the end of the road, click the Save PDF button to actually generate
the final file.
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Do you ever get annoyed by the fact that Photoshop prints only one image at
a time? Are there times when you’d like to send a bunch of images to print at
the same time, perhaps overnight or while you're at lunch? Create a multi-
page PDF from the images and print through Adobe Reader or Acrobat.

Collecting thumbnails — —
in a contact sheet Eo et | SE=
W inchude A Subfolders L

In the old Dark(room) Ages, photog- R : EEE
raphers regularly made a record of ot B"‘"‘ L
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@ Use Filaname As Captian

Fort Courbad T Font Size 12 g9
contact sheets are useful to present Courier
. " helvetica
to a client. Photoshop can automate Times

the process for you with Filer>
Automater>Contact Sheet Il (see

Fi 16-3: If you need a printed record of
Figure 16-3). gure you Pr

your images, consider Contact Sheet Il.

1. Select a source folder from the Use drop-down list in the Source
Images area.

2. (Optional) If you want to include the images in any subfolders that might
be within that folder, select the Include All Subfolders check box.

3. Using the Units, Width, and Height options in the Document area,
describe your document, using the printable area of your page —
not the paper size.

4. Select a resolution.

[ recommend 300 pixels per inch (ppi) if printing and 72 ppi if you’ll be
slicing the image for your Web site.

5. Use the Mode drop-down list box to choose a color mode (RGB unless
printing to a color laser printer) and also decide whether you want to
flatten layers (which makes a smaller but less versatile file).
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After you make all the external decisions, you need to make some choices
about the layout and placement of the images on the page. Note in Figure 16-3
that you have some important information below the Cancel button. Contact
Sheet Il gives you a preview of the layout, tells you how many pages (and
images) you're going to generate, and shows you how large each image will
be on the page. Keep an eye on this area when making decisions in the
Thumbnails section of the dialog box.

You can choose to have the images eno A ContaciShees: 001 @ 1005 (€W, 1459, AE8/8)
added to the page row by row (the G <o R
second image is to the right of NWW
the first) or column by column

(the second image is directly below 1 e -

the first). You also choose the number
of rows and columns, which deter-
mines the size of each individual
image. You then need to decide
whether to use Auto-Spacing, to cal-
culate the spacing between images,
and whether to rotate images. If your
source folder has a mixture of land-
scape and portrait images, rotating
makes sure that each is exactly the
same size — although some will be
sideways. If image orientation is more
important than having identical sizes,
don’t use the Rotate For Best Fit
option. Take a look at the bottom row
in Figure 16-4 to see how an unrotated Figyre 16-4: To maintain image orientation,

image appears in a contact sheet. don't use the Rotate For Best Fit option.

If your folder is filled with portrait-oriented images, you can certainly have
more columns than rows so that each image better fills the area allotted for
it. For example, when printing 20 portrait images, using 5 columns and 4 rows
produces larger printed images than using 4 columns and 5 rows.

Contact Sheet Il also lets you add the filename as a caption below each image,
which proves to be a very handy way of tracking your images. As shown ear-
lier in Figure 16-3, your font choices are rather limited. (Make sure you use a
font size small enough to get the whole name within the width of the individ-
ual images.) By default, the filename is in black.
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One-step Web sites .
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takes only a few steps to create gor-
geous galleries to display your photos:

1.

. Select a template from the

Open Web Photo Gallery by
choosing Filew>Automate.

Figure 16-5: Use Web Photo Gallery to create
Styles menu. Web sites of your images.

You can choose from the Flash

templates (which are more dynamic, have more features, and are, well,
flashier), or you can choose an HTML template (which is compatible
with all Web browsers). If the selected template offers the option, you

can also include your e-mail address in the gallery.

. Select the images to use and a folder to hold the gallery.

Click the Choose button to navigate to and select a folder of images.
You can also include any subfolders within the selected folder. Click the
Destination button to select the folder into which the gallery will be saved.
(This should be an empty folder located on the hard drive.)

. Input the information you want to display.

Generally speaking, you’ll leave the General options at the defaults and
switch the Options pop-up menu to Banner. Customize the information
presented on the site. (Remember that the options vary, depending on
which template is selected.)

. Select your image options.

In the Options pop-up menu, select Large Images to set the options for
the primary pictures, and then switch to Thumbnails to determine how
the smaller version of the images will appear.

. Choose colors for the gallery.

Change the Options pop-up menu to Custom Colors to select the color
scheme for your gallery.

. Protect your images with security.

In the Security section of the options, you can elect to have your copy-
right information, the filename, or other information added to the images
to help prevent accidental (or intentional) misuse of your images.
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8. Click OK to generate the Gallery.

After you create your Web Photo Gallery, you upload it to a Web
server, a computer owned by your Internet Service Provider (ISP).
(Most Internet service agreements these days include space on the
servers for your personal home page.) Check with your ISP for specific
upload instructions — the process varies quite a bit from ISP to ISP.

If you'd like to share a gallery with friends or clients but you don’t have a
Web server, save the gallery to your hard drive, send the entire content of the
folder you choose as the destination, and instruct the recipient to open the
file named index.html using a Web browser’s File=>Open command.

Saving paper with Picture Package

Suppose you need to print a dozen images, each at 4 x 5 inches. Printing each
on a separate sheet of paper takes 12 sheets (oh, the cost!) and 12 print cycles.
Choose Filem>Automater>Picture Package (as shown in Figure 16-6) to put four
4 x 5 images on a single page, and you use three sheets of paper and wait
through only three print cycles. Um, let’s see, which do you want to do. . ..

Pcture Package
Source Images
Use: | Folder = —
= Cancel
Choose.. F3eTrer L snsariawe MSHC YD Gucatteesa Dogs Laatesan =

_ Include All Subloiders

Documaent
Page Size: | 8.0x10.0In I
Layeur | (4)4x5 )
Resolution: 300 pxsis/inch 1))
Mode: RGBS Color ]
_ Flatten Al Layars
Label
Content: ' Custom Text #
Custom Text: ©2005 Peter Buver
font Halwatica -
Font Size: 12t -
Color: | Custom.. 1l
Opacity: [100/¥) %
Position: _Souom Left ?“
Rotate: | Nose e Edit Layout....

Figure 16-6: Multiple images on a single page with Picture Package.
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More and more Web-related work is being done
in Flash, Fireworks, and Dreamweaver, and less
and less is being done in Photoshop. In response,
Photoshop CS3 scales back significantly on
Web-oriented features. (If you used ImageReady
frequently in earlier versions of Photoshop,
don't uninstall it — there’s no replacement in
Photoshop CS3.) Why? Simply because so few
people were using those features. And, quite
frankly, Photoshop didn’t do some Web tasks as
well as dedicated Wehb-development software.
You still have the Save for Web feature (now
integrated with Device Central, used to optimize
images for cell phones and other such devices),
and you can still create slices and even ani-
mated GIF files. But you won't find support for
rollover buttons, image maps, or other Web fea-
tures that Photoshop used to support. Do that
sort of work in a true Web-design and develop-
ment program.

Photoshop’s missing Web tools

You might still have need for Save for Web, even
if you're not creating Web pages and Web sites.
It's a very useful tool for shrinking file sizes down
in preparation for e-mailing. After reducing a
copy of your original to a manageable size with
Image=>Image Size (perhaps 600 x 450 pixels for
e-mail), choose Filec>Save for Web & Devices.
Inthe Save for Web window, you can click a tab
atthe top to compare up to three different vari-
ations to the original. Generally speaking, you'll
elect to save photos in the JPEG file format.
When making your decision, compromise
between the quality of the preview and the file
size listed below it. As you can see in the screen-
shot here, saving a photo at Maximum Quality
can still reduce the file size by two-thirds. If you
reduce the Quality slider to 60%, and the image
is almost as good-looking, yet less than one-
tenth the size of the original. Pretty great way to
shrink photos for e-mail, wouldn’t you say?

. Save For Web & Devices

Unbem Tuinde g Sre

Vg

Dewige Cantral,
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Picture Package creates zones on a sheet of paper and places copies of the
selected image, sized to fit within the area of the layout you select, in each
zone. You can click each of the zones to select a different image or leave
Picture Package set to print multiple copies of a single image.

Here are some tips for working efficiently with Picture Package:

1~ Pick the Page Size first. The layouts available are all based on the page
size. The Layout pop-up menu shows only layouts designed for the
selected dimensions.

For Page Size, use the printable area of the page (the area within your
printer’s minimum margins), not the paper size.

1 Click each zone to add an image. By default, Picture Package uses mul-
tiple copies of the same image in the Layout area. Click each of those
images to change the photo assigned to that spot.

1~ Create custom layouts. Click the Edit Layout button to create custom
arrangements to suit your needs. Click a zone and drag its bounding box
to resize and move, or work numerically for precise zones.

1 Check your resolution. If you intend to print your Picture Package page,
you probably want a resolution of 300 ppi or perhaps 240 ppi.

1~ Decide whether to flatten. If you don’t select the Flatten All Layers
check box, you can further manipulate the result, perhaps adding any
necessary adjustment layers to fine-tune a specific image. Maintaining
layers also lets you realign the images to make cutting them apart later
much easier. As you can see in Figure 16-6, the edges of the two images
on the left are not aligned, which will result in some extra work with the
paper cutter or scissors.

1~ Check your font size. Make sure that if you add a label, you use an
appropriate font size. If your label is too small, nobody can read it;
conversely, if it’s too large, you might disrupt the feel of the image.

1~ Consider using Contact Sheet. If you have a large number of images
to process, you might be better off using Contact Sheet Il because it
automatically generates multiple pages from a single folder.

Picture Package won'’t crop your images for you; it can’t make such artistic
decisions. Before opening Picture Package, make sure that you have copies of
your images that are in the correct aspect ratio (the relationship between
width and height) for the print size you want. Your digital camera, for exam-
ple, might capture using a 3:2 aspect ratio (the long side is 50% larger than
the small side). That image doesn’t fit properly in an 8 x 10 or a 5 x 7 zone in
Picture Package, although it will completely fill a 4 x 6 zone because 4 x 6 is
also a 3:2 aspect ratio — or, for clarity, a 2:3 aspect ratio. Cropping to a spe-
cific aspect ratio is discussed in Chapter 4.
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Ready, Set, Action!

In Photoshop, an Action is simply a recorded series of steps that you can play
back on another image to replicate an effect or technique. To choose a wild
example, say that every image in your new book about Photoshop needs to
be submitted at a size of exactly 1,024 x 768 pixels at 300 ppi, regardless of
content. Record an Action that uses the Image Size command to change
resolution and then use the Canvas Size command to expand the image to
1,024 x 768 pixels. Use that Action (play the Action) on each image before
submitting it. Better yet, wait until all the images for a chapter are ready and
then use the Batch command to play the Action automatically on each of them!

Actions and the Batch command not only streamline repetitive tasks; they
also ensure precision — that every
one of those images will be exactly

1,024 x 768 pixels, each and every T L g et nee

time. But Actions also have a el e

creative side to them. The lower part v isiae Duplicate

of the Action palette’s menu (see v ¥ g :‘:"

Figure 16-7) contains Action sets that o

you can load into the palette to pro- sty okl

duce frame and border effects, text W semed (2ot Insert Menu Rem...

effects, and more. (The content of et Calas sl T

your Actions palette menu might differ ~ e

from what’s shown in Figure 16-7.) gl » e T e

You can also purchase collections of LI EREIE st Al cistns

Actions from commercial sources. Reset Actions
Load Actions...

To work with an Action, open an i

image, select the Action in the it

Actions palette, and then click the Frames

Play button at the bottom of the :’:‘;‘:::'::“’

palette. As you can see in Figure 16-7, sampie Actions

the three buttons to the left use the Text Effects

near-universal symbols for Stop, i

Record, and Play. The three to the
right use the standard Adobe sym-
bols indicating New Set, New Action, Figure 16-7: The Actions palette menu includes
and Trash. sets of Actions you can load into the palette.

Any step in the Actions palette that doesn’t have a check mark in the left
column is skipped when you play the Action. Any step that has a symbol visi-
ble in the second column (the modal control column) pauses when you play
the Action. Click in the second column when you want the Action to wait for
you to do something. Perhaps you’ll click in that column next to a Crop step
so that you can adjust the Crop tool’s bounding box. You might click in the
second column next to an Image Size step so that you can input a specific
size or choose a resampling algorithm. After you make a change or input a
value for that step, press Return/Enter to continue playing the Action.
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P Notice the grayed-out Save Actions command in the palette’s menu in
Figure 16-7. Remember that you have to select a set of Actions in the palette,
not an individual Action, to use the Save Actions command. If you want to
save only one Action, create a new set and Option/Alt+drag the Action to
that set to copy it. You can also create a printable text file (. txt) of your
Actions set by holding down the 88+Option/Ctrl+Alt keys when selecting
Save Actions. Text versions of your Actions provide an easy reference for
what each Action (and step) does to an image.

If you get hooked on Actions, you'll also want to try Button Mode in the
Actions palette menu. Each Action appears in the palette as a color-coded
button. You don’t see the steps of the Action, so you don’t know whether an
individual step is being skipped, and you can’t change the modal control
column, but you might like the color-coding to sort your Actions.

Recording your own Actions

The real power of Actions comes to you when you record your own. Sure, the
sets of Actions included with Photoshop are great, and the commercial pack-
ages of Actions have some good stuff too, but it’s not your stuff. When you
record your own Actions, you record the steps that work for your images,
your workflow, and your artistic vision.

Actions can'’t float free in Photoshop’s

Actions palette: Each Action must be e e

part of a set of Actions. Before begin- ~im -

ning to record your Action, you can i Guasilosonnclom:

select an existing set or click the AT Tom e

fourth button at the bottom of the ' 1479

palette to create a new set. When you New Astion

have a set selected, you can then Name: [Create layer, add 1-px stroke | (URSCOMBND
click the New Action button (second ser. | Peae's Production Actions 18] (_Cancal
from right). Then, in the New Action Function Key. | F12 180 @ shift _ Command

dialog box (as shown in Figure 16-8), Color. | [Green B

assign a name (and color-code for

Button Mode and perhaps assign an

F-key combination) and click the Figure 16-8: After you click the New Action
Record button. From that point for- button, you see the New Action dialog box.

ward, just about everything you do in

Photoshop is recorded as part of the Action until you click the Stop button
at the bottom of the Actions palette. No worries, though — you can always
delete unwanted steps from a recorded Action by dragging them to the
Trash icon at the bottom of the Actions palette. And if you want to change
something in the Action, you can double-click a step and rerecord it.

“&N\BER You can record most of Photoshop’s commands and tools in an Action, but
& you can’t control anything outside of Photoshop. (For that you need scripting,
introduced later in this chapter.) You can’t, for example, use an Action to
print (controlling the printer’s own print driver), copy a filename from the
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Mac Finder or Windows Explorer, or open Illustrator and select a path to add
to your Photoshop document. Nor can you record the movement of the
cursor in your Actions, which generally rules out recording painting tools.

Here are some tips about recording your own custom Actions:

1~ Open a file first. Open the file in which you’re going to work before
you start recording the Action. Otherwise, the Open command
becomes part of the Action, and the Action will play on that specific file
every time you use it. You can, however, record the Open command
within an Action to open a second file — perhaps to copy something
from that file.

1~ Record the Close command after Save As. When you record the Save
As command in an Action, you're creating a new file on your hard drive.
Follow the Save As command with the Filem>Close command and elect
Don’t Save when prompted. That closes the original image.

1~ Use Percent as the unit of measure. If you need an element in your
artwork to be in the same spot regardless of file size or shape (like a
copyright notice in the lower-right corner), change the unit of measure
to Percent in Photoshop’s Preferences before recording the Action.

1 Record/insert menu commands. When you use a menu command while
recording your Action, the actual values that you enter into the dialog
box are recorded, too. If you'd rather select the values appropriate for
each individual image (perhaps for the Unsharp Mask filter), insert the
command rather than record it. When you reach that specific spot in
your process, use the Actions palette menu command Insert Menu Item
(refer to Figure 16-7). With the

dialog box open, mouse to and Inyart Menu Rerm

select the appropriate menu Fh0u Baret) Mo Selecied o)
command; then click OK to con- 1) 20 enct s smana i ot & akaey v g Ot i o Cnsed
tinue recording the Action. In

Figure 16-9, you see the Insert nyere Menu e

Menu Item dialog box when first — meres imsgeimae see oo
opened (before a command is T 78 eiers 2 s wofe solel o s Mooy ot Aovan. e

selected) and after [ used the
mouse to select the Image Size
command from Photoshop’s Figure 16-9: Using Insert Menu Item leaves a
Image menu. dialog box open when playing the Action.

» Record multiple versions of a step, but activate one. Say you want to
record an Action that does a lot of stuff to an image, including changing
the pixel dimensions with the Image Size command. However, you want
to use this Action with a variety of images that require two or three dif-
ferent final sizes. You can record as many Image Size commands as you
want in that one Action — just remember to deselect the left column in
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the Actions palette next to each of the Image Size steps except the one
you currently want to use. And you can record an Action within an
Action, too. Just play the second Action while recording the first.

1+~ Insert a message or warning. Use the Actions palette menu command

Insert Stop to send a message to anyone who plays your Action.

The message could be something like “You must have a type layer active
in the Layers palette before playing this Action” with buttons for Stop
and Continue. Or you could
phrase it more specifically:

“If you have not selected a

type layer in the Layers palette,
click Stop. If a type layer is
active in the Layers palette,
click Continue.” The more
precise the message, the less
confusion later. In Figure 16-10,
you see the Record Stop dialog
box, where you type your mes- sie0
sage when recording the Action,
as well as a look at how the mes-
sage appears when the Action is Figure 16-10: Insert a Stop to show a message
played back later. when the Action is played.

Racord Stop
Mesiage = ]
f you have not selected a type layer in the Layers Cancel

palette, click 5100. If a type laver is active in the
Layers palette, click Conginue.

# Wiow Continus

Agdobe PRotoihon

If you have not selected a type layer in the Layers paletie, click
Seop. If & tye Lwar |5 ACtive i the Livers oaleme, click
Continwe.

i Comtinue )

* Remember Conditional Mode Change and Fit Image. These two com-

mands in the Automate menu are designed to be recorded in an Action
that you might later use on a wide variety of images.

¢ Conditional Mode Change is

Conditional Mode Change

very handy when your Source Mode o
Action (or final result) ¥ samao ! C8 Color

depends on the image 33:‘::‘:' 33:’;:-:“ Caneal
being in a specific color {hmn;,:m, § mutnchannel

mode. When you record - -

Conditional Mode Change

in an Action, every image, Target Mode

regardless of its original Mode: | v Bzmap

color mode, is converted iy

to the target color mode indexed Color

(see Figure 16-11). Say, for P Conr

example, that you need to Lab Color

apply a certain filter in an e

Action, but that filter is
available only for RGB
images. If you record
Conditional Mode Change

Figure 16-11: Conditional Mode Change
converts every image to the target color mode.

before running the filter, the Action will play properly.

e Fit Image specifies a maximum width and height that the image
being processed must not exceed, regardless of size or shape —
great for batch-processing images for the Web. Fit Image maintains
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your images’ aspect ratios (to avoid dis- Fitimage
tortion) while ensuring that every image ~ o°''5" - @ee
processed will fit within the parameters Haghe: [ ety | R

you specify (see Figure 16-12).

1~ Always record an Action from a copy of your
image. Because the steps that you record in ~ Figure 16-12: Fit Image scales
the Action are actually executed on the open  allimages to fit within the
file, record your Action using a copy of the specified dimensions.
original image. That way, if something goes
wrong, your real image is protected.

Working with the Batch command

Photoshop’s Filer>Automater>Batch command plays back a single Action on a
number of files. You select an Action to play and also a folder of image files to
play it on; then you decide what you want to do with the files after the Action
finishes with them. You can leave the images open in Photoshop, save and
close them, or (much safer) save them to another folder, preserving the origi-
nals. Figure 16-13 shows the Batch dialog box and also the pop-up menu for the
fields in the File Naming area. (When you select a new folder as the Destination
in Batch, you must tell Photoshop how you want the new files to be named.)

Batch
Play =ty
Set | Pete's Production Actions 18]
e Cancal
Action: | 1024x768 1]
Source | Folder L]
Choose. Pasther Users .. DummasChapters Chagier-07 Pans Decumant Name
— Dvarride Action “Open” Commands otument name
# includa All Subloiders DIOCIRINA s
1 Digit Sarial Number
# Suporess File Open Dations Dialogs 2 Dight Seria) Namber
 Suppress Calor Profile Warnings 3 Digt Seria) Number
4 Diga Senal Namber
Destination: _ Folder ) Serial Latter @, B, €..)
Serial Latter 04, 0, C..)
Choose... | Pamther Users... .Chapter-07 Ch-07-Images memddyy tdates
_ Owerride Action “Save As™ Commands mmndd [date)
File Naming yyyymmadd (dare)
i o vy=mad [date)
Exampla: MyFile20050126001.9 = A
Decument Kame Ei + yyyymmadd (date) m * ddmmyy [daled
ddmm (date)
3 Dt Seral Namber ﬁf + e EOn ‘B - ¢ ©xsnsion
- m EXTENSION
E None
Starting serale: (1
Compatinity & Windows Vv 1 & Unix

Ervory: | Stop For Errors 18l

Figure 16-13: The Batch command is much simpler than it looks!
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You must remember three things when assigning filenames:

1+~ Include a variable. Something must change from filename to filename.
Select one of the top nine items in the pop-up menu (some version of the
document name or a serial number or a serial letter). It doesn’t have to
be in the first field, but one element of the filename must be different
from file to file.

1 Don’t use a period (.) in any field. You can type in any of the fields
(except the last one you use), but for compatibility, stick with letters,

NG/ numbers, underscores (_), and hyphens (-).
2 Absolutely do not use a period in the filename. The only period that can

be used in a filename is the one that’s automatically added immediately
before the file extension.

1~ The last element must be the file extension. In the last field you
use, you must choose either EXTENSION or extension from the
pop-up menu.

You have two other decisions of note in the Batch dialog box. When you elect
to suppress any Open commands in the Action, you protect yourself from
poorly recorded Actions that start by opening the image with which they
were recorded. However, if the Action depends on the content of a second
file, you don’t want to override that Open command. Generally, you want to
override any Save As commands recorded in the Action, relying instead on
the decisions that you make in the Batch dialog box to determine the fate

of the image.

Sticking to the Script

& roowoshop I Eon image Layer Select Filer View Windew Help

You can use AppleScript (Mac), 53:_-:. \EE
Visual Basic (Windows), and A s Ohje. k
JavaScript (both) with Photoshop. Device Centrl.,
Photoshop includes several very G x
useful scripts in the File>Scripts DrtmcceTa ML OE%
menu (see Figure 6-14). R o
:‘:.:’ Wab & Devicet. o II!"
Among the prerecorded scripts are ::; -
Exporn »
1+~ Image Processor: Designed to S X r———
convert Raw files to PSD, TIFF, Fit Info Cox | Lave Comonto MK
or JPEG, you can actually use sl DEP | Laper Compn 10 POF
Image Processor to convert i i b [ty
images in any file format Bkt

Photoshop can open.

1~ Export Layers to Files: This cre- Figure 16-14: Among Photoshop’s most
ates a separate image file from  powerful features is the ability to use scripts to
each layer in your image. automate your workflow.
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You can find more scripts on the Internet, including some at http://
share.studio.adobe.com. Select Scripts from the Adobe Photoshop
Download pop-up menu.

Scripts are much more powerful than Photoshop’s Actions because they can
control elements outside of Photoshop itself. AppleScripts and Visual Basic
scripts can even run multiple programs and play JavaScripts. If you're inter-
ested in scripting, go to the Photoshop folder on your hard drive and explore
the content of the Scripting Guide folder. You can find plenty of information
to get you started!
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Introducing Photoshop CS3
Extended

In This Chapter
Exploring Photoshop CS3 Extended
Working in 32-bit color
Stacking modes for Smart Objects
Getting an overview of 3D, video, and analytical features

Spelling out some new capabilities

ou might have purchased Photoshop CS3 and are wondering about the

features of Photoshop CS3 Extended. You might have received
Photoshop CS3 Extended as part of a bundle or the Adobe Creative
Suite 3 and aren’t sure whether you need these features.
You might be browsing in the bookstore, trying to determine
whether to purchase Photoshop CS3 or Photoshop CS3
Extended. (If this last scenario is the case, my advice
to you is this: Purchase this book first and then, with
any money you have left over, buy the version of
Photoshop that best fits your needs. Read about the
Extended features, and if you don’t need them, save
some money and buy Photoshop CS3. And then buy
lots more copies of this book to give to friends,
family, and co-workers.)

In this chapter, I introduce you to the various special
features of Photoshop CS3 Extended. This chapter won’t
get you fully up to speed on how to work with the features;
instead, it’s meant to quench your curiosity about the differ-
ence between Photoshop CS3 and Photoshop CS3 Extended. (For an
in-depth look at working with the special features of Photoshop CS3
Extended, see Photoshop CS3 Bible, Professional Edition, from Wiley.)
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Understanding Photoshop CS3 Extended

For years, Adobe has heard the pleas of researchers, scientists, and other
highly specialized users of Photoshop to include features that fulfill their
needs. Finally, Adobe has been able to provide the tools these specialists
need. But rather than just adding them into Photoshop CS3 and making
everyone pay the costs for developing these features that few will use,
Adobe packaged them as a separate, higher-priced version of the software.
“Let those who need the new features subsidize their costs!” was the deci-
sion. And, in my opinion, it was a fine decision. As I explain, these extended
features don’t really have a place in the workflow of most Photoshop users.

That doesn’t mean that if you do
have Photoshop CS3 Extended that
you’ll never use any of these features!
(“How do I know which version |
have?” Watch as Photoshop starts

to see which splash screen appears.
Take a look at the difference in

Figure 17-1.) Even if you didn’t specif-
ically purchase the Extended version
(it might have been part of a package
deal), you might someday decide to
work with 32-bit, high dynamic range
images. Or you might find a need to
calculate a height or a distance using
the measuring tools in Vanishing
Point. But unless you actually work
directly in one of the target fields

for the features of Photoshop CS3
Extended, you’re not likely to miss

the additional capabilities at all. Figure 17-1: Photoshop CS3 Standard and
Photoshop CS3 Extended splash screens.

Another clue that you're working in

Photoshop CS3 Extended is that you can see the Analysis menu, which holds
commands related to working with the new measuring capabilities (discussed
later in this chapter).

Painting and Layers in 32-Bit Color

One of the new features of Photoshop CS3 Extended that will appeal to some
photographers is the ability to work with layers and painting tools in 32-bit
color. With layers comes access to some blending modes. And, as you can
see in Figure 17-2, 32-bit images can even have adjustment layers. Okay, well,
some adjustment layers. . ..
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- Hmlmlwp File Edit m“khﬂ Filter Analysis ‘View Window Help @

New
Duplicate Layer...
Delare

Layer Properties...
Layer Style

New Fill Layer

Layer Mask
Vellor Mask
Creae Clipping Mask

Smart Objects

3D Layers

New Layer Based Slice
Group Layers

Hide Layers

Arrange

Figure 17-2: A 32-bitimage can contain layers.

Although you can now create a
32-bit/channel high dynamic range
image through the Files>New com-
mand, they're generally the product
of the Filer>Automater>Merge to
HDR feature. Shoot (with a tripod)
several exposures of the same scene,
changing only the shutter speed from
shot to shot (and don’t use auto-
focus), and then merge the entire
tonal range, from the darkest expo-
sure to the brightest, into a single
image.

Because you can now paint in 32-bit
color, you need a way to identify
colors with which to paint. If you
click the color swatch at the bottom
of the Toolbox, the new HDR Color
Picker opens (see Figure 17-3).

[ i8] ovem [iom

wecr: [E] 1 Tl " [an B

s B
- B
-1
[
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_ Melatrve To Document

Add To Swatches

Color Libraries |
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B 07743
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M x
75 |x
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Figure 17-3: A 32-bit painting requires 32-bit
color definition.
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Also, other tools are now available when working in 32-bit color, including the
Type, Patch, Sharpen, Blur, and Quick Selection tools. However, the toning
tools (Dodge, Burn, and Sponge) and some tools that rely on color (including
the Spot Healing Brush, Magic Wand, Color Replacement, and Magnetic
Lasso) aren’t suitable for use with 32-bit color. Still, the improved capabilities
for working with high dynamic range images make it feasible to actually be
productive using 32-bit color.

Smart Object Stack Modes

Working with Photoshop CS3 Extended, you can combine a number of images
into a single stack as a Smart Object. Within the pile of images, you can deter-
mine how the pixels in each interact with those in the others. Select several
related or contrasting images and add them as layers to a single image, select
the layers, and create a Smart Object by choosing Layer=>Smart Objects=
Convert to Smart Object. Return to the Layerz>Smart Object submenu and
take a look at the Stack Modes submenu that’s now available. These options
determine how the content on the layers within the Smart Object interact to
produce the appearance of the Smart Object itself. (Not quite the same, but
similar to the way layer-blending modes help determine the overall appear-
ance of your artwork.) You can find technical explanations of each option in
Photoshop’s Help, but [ show a couple of stacks as examples. On the left in
Figure 17-4, you see a combination of the layers (shown to the left as thumb-
nails) using the stack mode Summation, which pretty much adds up all the
lightness of each pixel in each channel, on each layer. To the right, several
images shot for use with Merge to HDR are combined in a Smart Object using
the stack mode Mean, which averages the values for each pixel in each chan-
nel. Not quite Merge to HDR, but with some planning and prep, it could be a
supplemental technique.

Figure 17-4: A couple of different uses for stack modes.
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Working with 3D Artwork

Photoshop CS3 Extended can retain the three-dimensional characteristics of
3D objects (in the file formats U3D, 3DS, and OBJ) through the use of 3D
Layers. Much like Smart Objects, 3D Layers can be manipulated in a variety
of ways without continually resampling and degrading the image quality:.
Add a 3D object to your artwork by choosing Layer=3D Layers=>New Layer
from 3D File or open a 3D file as a 3D layer by choosing Filec>Open.

With a 3D object selected in the 3

Layers palette, choose Layer=3D ot o
Layers=>Transform 3D Model (shown e

in Figure 17-5) to access the e
3D-related features in Photoshop CS3 e
Extended. You can, among other e -
things, reposition and rotate the 3D Coime ipping bk YR
object as if working in a 3D program.  &aie’ :

R
Raiterire L - A
The Options bar changes to provide — sweiemmse |]

access to the 3D features. At the left Nemabi b
end, you determine whether you AEATE

want to modify the object or the

“camera” that is showing the current Figure 17-5: Access 3D manipulation features
view. The six view buttons and the through the Layers palette.

View menu provide you with a vari-

ety of familiar (familiar if you work with 3D programs) tools to reposition the
object or camera. You can also save specific views and delete saved views.
Next in the Options bar is a button that enables you to adjust lighting and
rendering options (see Figure 17-6).

=TAJETEISTAT

You can also view cross sections in Photoshop by using the next button in
the Options bar. You can specify which axis and adjust the position and angle
of the “slice” with Offset and Tilt sliders (see Figure 17-7).

After you make changes to the 3D content, you're asked to confirm the new
appearance. After you have approved the new look, you can continue editing
your artwork normally. When you print the file, the current appearance of the
3D content is used for output.

If your 3D object has textures attached, you can edit those textures by
double-clicking the texture in the Layers palette. The texture opens as a new
image window, you make your changes, and you save. The 3D object is auto-
matically updated. (The process is comparable to updating a Smart Object.)
If the 3D content includes animation, you can use the four buttons to the
right in the Options bar (refer to Figure 17-6) to play and to select an individ-
ual frame of the animation to display.
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Figure 17-6: Lighting options to the left, rendering options to the right.
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Figure 17-7: You can show the innards of complex 3D objects with cross sections.



Editing Imported Video

Photoshop CS3 Extended supports
video layers — layers that contain
actual video that you can edit and
manipulate. (Obviously, you can’t
print an image with playable video
right on the page.) The Layer menu’s
Video Layers submenu offers a
number of commands for inserting
video clips, replacing existing clips,
and inserting, duplicating, and delet-
ing individual frames. But the heart
of video in Photoshop CS3 Extended
is the Animation (Timeline) palette
(see Figure 17-8).

One of the ways you can edit video in

Photoshop is to take advantage of
the enhanced cloning capabilities.
Select a frame from which to clone,
Option/Alt+click the element you
want to clone, advance to the frame
into which you want to clone, and
then click and drag to clone. Repeat
for each additional frame. To track
what and where you’re cloning, open
the Clone Source palette and select
the Show Overlay option. The source
frame appears as an overlay on the
destination frame (see Figure 17-9).

If the Layer=>Video Layers menu is
grayed out, open the Animation
palette’s menu and select Convert to
Timeline or click the button in the
lower-right corner of the Animation
palette to toggle from the palette’s
Frame Animation mode. Keep in
mind, however, that converting the
palette also converts any active
video clips. Converting a video clip
to frame-based animation uses only
the keyframes, not all frames. If you
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Figure 17-8: The Animation palette menu has
many commands for editing video.

Figure 17-9: Show Overlay is very handy when
cloning from frame to frame.
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Figure 17-10: You can import video as a
frame-based animation.

want to generate a frame-based animation using all frames, choose Filew>
Import=>Video Frames to Layers (see Figure 17-10).
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Measuring, Counting, and Analyzing Pixels

Designed for researchers and scientists, the new measuring capabilities in
Photoshop CS3 Extended are quite powerful. You can measure just about
anything and count the number of whatevers in a technical image, perhaps
from a microscope or telescope.

Measuring length, area, and more

If you know the exact size of any element in an image, you can then discover
just about anything you want to know about anything else in that image.
The key is to set the measurement scale, as shown in Figure 17-11.

" @ Pnowoshop Fike Edit image Laver Select Fier [EEENEIE view window Helo

28 nime v wane nom ne o SRR oo
Select Data Points >
RECOrd MEQSEMEnts UM o
+ Ruler Tool
Count Tool
Place Scale Marker...

Measurement Scale
Presets: | Custom N e —
Pixel Length: 21% Cancel
Logical Length: & Save Presal...

Logical Units. inches
215 pixels = 8.0000 inches

] The Ruler ool has been activated while this dialog is open.
£/ You may use it to measure the pixel length for use in your scale

T e ] "

Figure 17-11: Drag a known distance, set the measurement scale.
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In this example, we know the patient’s head is 8 inches front to back, and we
can see in the Options bar that the Ruler tool (nested in the Toolbox with the
Eyedropper) was Shift+dragged over 214.5 pixels. Rounding off, we can set
the scale to 215 pixels = 8 inches. Now, using any selection tool or the Ruler
tool, we can isolate any part of the image, click the Record Measurements
button in the Measurement Log palette (which you open, like any palette,
through the Window menu), and we find out more than we ever wanted to
know about that particular selection.

In addition to various sizes, the Measurement Log also records information
about the color or gray values in the image (see Figure 17-12). You can also
add the measurement scale to the image (as an editable layer group) with the
Analysis>Scale Marker command.
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Figure 17-12: The Measurement Log palette records so much info, it's shown here twice.
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After you have made and recorded all the various measurements you need,
you can select all the lines in the Measurement Log (or only a few) and click
the third button in the upper-right corner of the palette to export the data for
use in a spreadsheet program.

Photoshop CS3 Extended also offers measurement in perspective through
Vanishing Point. Suppose, for example, that for some reason or other you
need to calculate how much wallpaper to order for the room shown in
Figure 17-13. You know the height of the window (70 inches) and, using that
as your known measurement, you can have Photoshop calculate the height
and length of each wall.

Vanizhng Pownt

T B —o—

R e L L LT T Te—— Cancel

e - SR Tl

Figure 17-13: Measurements can also be made in perspective with Vanishing Point.

Counting crows or maybe avian flu

Nested with the Ruler tool and the Eyedroppers in the Toolbox is the

new Count tool. Zoom in and start clicking on whatever it is that you need to
count, whether it’s birds in the sky or viruses on a slide. Each item you click
is labeled with a number. If you want to record the count (shown in the
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Options bar and on-screen as the most recent number), click the Record
Measurements button in the Measurement Log (shown in Figure 17-14).
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Figure 17-14: Click on each item and Photoshop keeps a running tally for you.

Ignoring MATLAB, DICOM, and Other Initials

Photoshop CS3 Extended offers all of these interesting features for scientists,
researchers, and technicians, so it only makes sense that it should work with
some of the file formats they actually use and integrate with their software.
When you come across the term MATLAB in Photoshop CS3 Extended, recog-
nize it as a software environment (sort of like a programming language)

that speeds calculations and helps coordinate work in various technical
programs. Unless you actually work with MATLAB, say in a research lab,
there’s nothing else you really need to know. (If you're intrigued by the idea,
visit www . mathworks . com.)

Another set of initials in Photoshop CS3 Extended might be of interest:
DICOM (Digital Imaging and COmmunication in Medicine). If your doctor’s
office, hospital, or lab has sent you home with a CD that contains the results
of your CAT scan, MR, ultrasound, or X-rays, you can open the files and take
a look right in Photoshop. Copy the files to your hard drive. (Don’t open files
into Photoshop directly from CD or DVD.) Choose Filem>Open, and in the
Open dialog box, select the frames in which you’re interested and click Open.
In the following dialog box (shown in Figure 17-15), select the frames, elect to
open as layers in an image or in a grid pattern (N-Up), and open.
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Figure 17-15: Review medical imagery right in Photoshop CS3 Extended.



PartV
The Part of Tens

The 5th Wave By Rich Tennant

GRICHTENNANT




Don’t get nervous — this is The Part of Tens
and not The Part of Tense!

In Chapter 18, I present you with ten of my favorite
Photoshop tricks and techniques. Chapter 19 takes
a look at working with a Wacom drawing tablet —
other than a huge amount of RAM, perhaps your
best friend in the world of Photoshop. (Okay, other
than a huge amount of RAM and this book. . . .)
Chapter 20 provides you with ten reasons to shoot
digitally. If you already own and use a digital
camera, loan it to an analog colleague.




Pete’s Top Ten Favorite
Photoshop Tips and Tricks

In This Chapter

Playing with artistic and creative tricks

Exploring a few useful tips

Ihave literally thousands of Photoshop tips and tricks to share with you,
but space here allows for only ten. Actually, just about anything you do
that doesn’t use Photoshop’s default values or presets could be considered a
tip or a trick. However, you're likely interested in creative and productive
shortcuts rather than something like this: Save copies of your custom brushes,
styles, and other such bits and pieces somewhere other than the Photoshop folder
so you don'’t lose them should you ever need to reinstall the program.
(Oops! I snuck in an extra tip, didn’t [?)

In this chapter, [ present ten of my favorite creative and
useful techniques. Some of these tricks I developed
while helping solve problems in my role as Help Desk
Director for the National Association of Photoshop
Professionals (NAPP), and others are tried-and-true
helpers that have been around for years.

y &

Adding Artistic and Creative Effects

Surely you’d prefer to read Fill a layer with brown, use
the Add Noise filter (Gaussian Distribution, Monochrome),
and then apply a Motion Blur filter to create a wood grain effect
rather than If you need to apply a grayed-out filter to a CMYK image,
apply it to one channel, and then the other three individually using 8 +F/Ctrl+F.
(Now, don’t consider those to be tips or tricks — remember that the chapter
title says “Ten”!) Here are some of my favorite and most useful creative tips.
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Smoothing skin perfectly

When you see glamour shots — you know, photos of The Beautiful People
who look so absolutely perfect — one of the things you're not seeing is the
texture of the skin. No wrinkles. No creases. No pores? Indeed, the skin
appears to be perfectly smooth (see Figure 18-1).

® OO  ©1150039_MD.TF @ 150% (Layer 1, RC3/8)

©2003PhotoSpin, PhotoSpin image #1150039
Figure 18-1: Use the Healing Brush and a plain-color source area to smooth skin.

Here’s how you can achieve that effect without blurring:

1. Open a copy of your image.

Whenever you use a technique that makes permanent changes to the
pixels in your image, you should work on a copy. That preserves the
original image, which not only protects you from any errors that you
(or Photoshop) might make but also keeps that original for different
techniques and tricks in the future. (Does that count as a tip?)

2. Add a new layer by clicking the New Layer button in the Layers palette.
3. Make a selection.

The selection should be away from the face area, and sized at least one-
half the width and height of the face.

4. Fill the selection with color; then deselect.
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Press Option+Delete (Mac)/Alt+Backspace (Windows) to fill it with the
foreground color (it doesn’t matter what color).

5. Select the Healing Brush and set the source point.

Make sure that the Sample: All Layers option is selected in the Options
bar and that Aligned is deselected. Option/Alt+click in the center of the
filled selection.

6. Paint over the skin.

In the Layers palette, click on the lower layer, the original image layer, to
make it active. Click and drag with the Healing Brush to smooth areas of
skin. The Healing Brush replaces the texture of the skin (pores and all)
with the texture of the source area (smooth). Use short strokes that
follow the contour of the face. Make sure that you don’t paint over eye-
brows, nostrils, lips, and other areas of critical detail.

From a photo to a painting

You have dozens of ways to create a “painterly” effect in Photoshop. Here’s
one of my favorites, as illustrated by Figure 18-2.

1. Open a copy of your image as a Smart Object.

@"N\BEH Choose File=>Open as Smart Object or, if the image is already open,

& choose Layer=>Smart Objects=>Convert to Smart Object. When working
with Smart Filters, you can later — if necessary — reopen the filter and
change the settings.

2. Select the shadows and blur.

Open the Channels palette and 8/Ctrl+click the channel at the top (RGB
or CMYK or Lab) to make a selection according to the brightness of each
pixel. Use the shortcut 38+Shift+I/Ctrl+Shift+] to invert the selection
(select shadows rather than highlights). Apply a slight Gaussian Blur,
perhaps 1 or 2 pixels, to blur detail in the darker areas. (Remember that
you can use the shortcut 8+H/Ctrl+H to hide the “marching ants” and
make the selection border disappear — and that’s not yet another tip!)

3. Select the highlights and sharpen.

You need to reselect the highlights, so again 8/Ctrl+click the channel at
the top (RGB or CMYK or Lab). Apply the Sharpen=>Smart Sharpen filter
with initial settings of Amount: 200% and Radius: 2 pixels. (Adjust the
values to match the content of your image and your artistic vision.)

4. Add a canvas texture to the image.

Don’t deselect (so that the texture will be applied a bit more prominently
to the image’s highlights than to the shadows). Use the Texturer>Texturizer
filter to add a slight canvas texture, enhancing the painterly effect.
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Figure 18-2: Blur shadows, sharpen highlights, and add texture for a “painterly” effect.

Creating a sketch from a photo

Simulating a painting in Photoshop is great, but sometimes you might need
line art or a sketch. Photoshop has a couple of filters that do a nice job of cre-
ating pencil sketches, but none of them really do a great job with outlines.
Here’s an easy way to create line art from a photo (see Figure 18-3).

1. Open a copy of your image and create a Smart Object.

Again, pen your image as a Smart Object or convert with the command
Layer=>Smart Objects>Convert to Smart Object before. When working
with Smart Filters, you can later — if necessary — reopen the filter and
change the settings.
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©2003 PhotoSpin, PhotoSpin image #0990140
Figure 18-3: You can use the versatile Smart Blur filter to produce line art from a photo.

2. Apply the Smart Blur filter.

Set the filter to Quality: High and Mode: Normal. Use settings that
remove all the tiny detail in your image (such as pores and individual
hairs or blades of grass) but maintain edges and major detail (such as
eyes, noses, golf balls, and trees).

3. Define edges with Smart Blur.

Reopen the Smart Blur dialog box and set the Mode pop-up menu to Edge
Only. Adjust the sliders until the white-on-black preview shows approxi-
mately the amount of detail you want in the final image; then click OK.

4. Invert the colors.

Using the button at the bottom of the Layers palette or the Layer->New
Adjustment Layer menu, add an Invert adjustment layer. (Not only is it a
good idea to use adjustment layers rather than adjustment commands,
but you'll find that you can’t use most adjustment commands with Smart
Objects.)

5. Blur the lines.

Click the Smart Object layer again in the Layers palette to make it active
and apply a 1- or 2-pixel Gaussian Blur to soften the edges of the lines.

6. Adjust the thickness of the lines with a Levels adjustment layer.

In the Levels dialog box, drag the middle slider control left and right
until you're satisfied with the image’s appearance. If desired, you can
further refine the sketch with the Sharpen=>Unsharp Mask filter.
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Creating snow or rain

Here’s a multiuse tech-
nique that you can use
to create falling snow
or rain (as shown in
Figure 18-4):

1.

. Still in the Layers

8O P U ioWeb.tif @ 12.5% (RG3/8)

6 0P P icyWebd copy..
7 F, / / .'

Add a new layer

to your image by
clicking the New
Layer button in the
Layers palette.

palette, change the
layer’s blending
mode from Normal
to Screen.

Figure 18-4: Use the Noise and Crystallize filters to produce

Because this tech- Snow or rain.

nique uses a separate

layer, you can consider it to be nondestructive (you can always delete
the layer later), so you don’t have to work on a copy of your image.
But it’s always a good idea to work on a copy, just in case.

. Choose Edit->Fill to fill the layer with black.

Because the layer’s blending mode is Screen, you won'’t see the black fill.

. Add Noise to the layer.

Use the Noise>Add Noise filter to add some variation to the layer. Use
Amount: 20%, Distribution: Gaussian, and mark the Monochromatic
check box.

. Enlarge the noise with the Crystallize filter.

Use the Pixelatew>Crystallize filter to turn the little noise into larger
chunks. Use Cell Size: 3 for small snow or rain; try 7 or 10 for larger
flakes. You can also apply a slight Gaussian Blur to increase the size.

. Sharpen the edges.

Using the Unsharp Mask filter, sharpen until the snowflakes have distinct
edges. Use Amount: 100%, Radius: 2, Threshold: 0. When you create rain,
use Amount: 40%.

. Apply a Levels adjustment.
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In the Levels dialog box, drag the middle slider about halfway to the left;
then drag the left slider slowly to the right until you see the amount of
snow or rain that you want. Afterward, if desired, you can apply the
Motion Blur filter to the falling snow/rain. And, of course, you can add a
layer mask to control visibility.

The Glass Text effect

Perfect for adding a large copyright notice right across the center of your
image (while allowing the image’s beauty to still show through), this tech-
nique is so easy it doesn’t even need a step-by-step explanation. Simply type
your copyright info or any other text and add a Bevel and Emboss layer style
(perhaps with a slight Inner Shadow and maybe a 1-pixel black Stroke effect).
Then, at the top of the Layers palette, reduce the Fill slider (not the Opacity
slider) to 0 (zero). The pixels on the layer become transparent, but the layer
style remains visible.

Useful Tricks to Make Life Easier

3

Here are five techniques that make life easier and your work look snappier
and more professional.

Changing product colors in a snap

Use the Replace Color feature (in the
Image~>Adjustments menu) to quickly |
and easily make variations of a single [
image by changing color. Replace
Color is especially handy in produc-
tion environments, letting you shoot
one shot and produce numerous
color variations. (See Figure 18-5.)

Open Replace Color and Shift+drag ©1998 PhotoSpin, PhotoSpin image #0070004
the Eyedropper tool through the Figure 18-5: The Replace Color adjustment
color you want to change. Adjust makes quick work of color changes.

the Fuzziness slider to fine-tune the
selection; then adjust the Hue/Saturation and Lightness sliders to change
the color.

If the target color appears in more than one part of the image, perhaps a red
blouse and red lipstick, make a loose selection around the area you want to
change (excluding the other areas) before opening Replace Color.

367
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Deleting a plain white background

Lots of stock photographs come as a subject shot against a plain white back-
ground. Clip art also generally comes on a plain white background. Most of
these images have clipping paths or alpha channels that you can use to
extract the subject from the background to add it to another image. And
when there is no path or channel? Open both images in Photoshop and drag
the stock photo’s Background layer from the Layers palette to the window
of the destination image. Make sure that the upper layer is active in the
Layers palette and then open the Blending Options panel of the Layer Style
dialog box. In the Blend If area at the bottom, drag the upper-right slider
handle to the left until the upper layer’s white background is completely
gone. (See Figure 18-6.)

B A A 20010032 MID.TF @ 66.7% L. & O A 00010012 MED.TIF @ 66.7% (La.
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Both images ©1998 PhotoSpin, PhotoSpin image #0010032 (background) and image #0120013 (foreground)
Figure 18-6: Use the Blend If sliders to hide a white background.

Making dashed and dotted lines

Changing a couple of settings in the Brushes palette enables you to create
dashed and dotted lines with ease. In the Brush Tip Shape pane, increase
Spacing to a value higher than 100% to separate the individual imprints of the
brush tip (the brush tip instances). Switch to the Shape Dynamics pane and
select Direction from the Angle Jitter pop-up menu. For best results, make a
selection and choose Edite>Stroke to apply your dotted or dashed brush
along the selection border.

Ouick and easy edge effects

Need some way to make your images stand out? Try this:

1. Add a new layer to your image by clicking the New Layer button in
the Layers palette.
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To avoid making any permanent change to your image (primarily so you
can change your mind about the border later), work on a new layer.

2. Select a border area around the image.

Choose Select>All and then choose Select>Modify=>Border. Enter a
value twice the width that you want for your edge effect.

3. Fill the selection with black, gray, or white.
e Black: Makes your image look brighter and more saturated
¢ Gray: Minimizes any perceived color shift
e White: Mutes the image somewhat but allows it to stand on its own
Alternatively, use any color from the image (or its inverse).
4. Apply filters to the layer.

Open the Filter Gallery and apply one or more filters to the border to
create an interesting edge effect (such as the samples in Figure 18-7).
Remember, too, that you can convert this layer to a Smart Object before
applying filters so that you can later change your settings.

Not that this counts as an additional tip in this chapter, but remember that
you can open this image, open another image of the same size, and drag the
frame layer from the Layers palette of the first image to the window of the
second image to duplicate it. Reusable frames!

Professional-looking contact sheets

You can use this trick to produce a more traditional-looking contact sheet
with a black background and white type:
1. Set up Contact Sheet II.

Choose Filem>Automater>Contact Sheet Il to open the dialog box. Select
your source folder, make decisions on page size and layout, pick a font
for the filenames, and so on.

2. Clear the Flatten All Layers check box.

Before running Contact Sheet II, make sure you clear this check box to
ensure that your contact sheet retains its layers.

3. Generate the contact sheets.

Select your page size, source folder, and other settings as I describe in
Chapter 16. Click OK.

4. Fill the Background layer with black.



370 Partv:The Part of Tens

In the Layers palette, select the layer named Background, press D to set
your foreground color to black, and then press Option+Delete/Alt+
Backspace to fill the layer with black.

5. Change the type to white.

Figure 18-7: Filtering a border area creates interesting edge effects for your images.

In the Layers palette, 8/Ctrl+click each of the type layers to select them all,
click the Link Layers button at the bottom of the Layers palette, and then
Shift+click the color swatch in the Character palette to open the Color Picker.
Set the color to white (or bright yellow or whatever color suits your fancy)
and then click OK. You can now flatten the image (if desired).



Ten Reasons to Love
Your Wacom Tablet

In This Chapter

Considering reasons to use a tablet

Setting up your tablet for efficient Photoshop work

D rawing tablets from Wacom enable you to use a special stylus, which
you hold like a pen or pencil or brush, to move the cursor (rather than
using a mouse, track pad, or trackball). There are several reasons why using
a stylus is a huge improvement over a mouse, and I give you five to start off
the chapter. Another five reasons you’ll love your Wacom tablet involve maxi-
mizing your efficiency; those reasons conclude the chapter.

More natural movement

Whether you use a pen only to sign your name or you're
a traditionally trained artist, the movement of a stylus
is far more natural than pushing a mouse around
a desk.

Health and safety

Use of a drawing tablet instead of a mouse can help
avoid repetitive stress injuries and carpal tunnel syn-
drome, and can be vastly more comfortable for those
of us who suffer from arthritis and tendonitis.
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Artistic control

With up to 1,024 levels of sensitivity, e -

a “CllCl'{” or a “drag” using a drawing e cove MR
tablet is far more versatile than ooy Gl o] ewe B
working with a mouse. Open the — g

Photoshop Brushes palette and take e

a look at the eight different options WO yes. | dngism
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Wacom Airbrush) Stylus Wheel | Bl
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trolled with pen pressure, such as
the Quick Selection tool, which can
use pen pressure to adjust the brush
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Extended comfort

You can lean back and relax or sit up  Figure 19-1: Scattering, Color Dynamics, and
straight: With fingers poised over the (Qther Dynamics also have pen-controlled
keyboard or hand grasping mouse, options.

you'’re pretty much locked into a

single position, often for hours at a time. With the long cord of a Wacom
tablet plugged into a handy USB port, you have the flexibility to change posi-
tions, move back from the monitor, even slouch in a way that would make
Mom turn pale — all while still sending input to the computer. (Or how about
a Bluetooth cordless model?) Whether you work with the tablet on the desk
or on your lap, it doesn’t matter; do whatever is most comfortable and effi-
cient for you.

Programmable ExpressKeys and Touch Strips

How about convenient controls, right on the tablet, that let you access
modifier keys, keyboard shortcuts, and even brush sizes and tool selection?
No need to lean back in toward the desk to press a key or two; just program
your most-needed keystrokes to the tablet.

The optimal tablet

The modestly priced Graphire line comes in two sizes (4 x 5 and 6 x 8 inches)
and has 512 levels of pressure sensitivity. The professional Intuos line includes
six different sizes, from 4 x 6 to a whopping 12 x 19 inches. The 12 x 19-inch
and 6 x 11-inch sizes are specifically designed for widescreen and dual-monitor
systems. If you have a fine-arts background, you might want a larger tablet.

If not, you might be more comfortable with a smaller tablet, on which you can
make smaller strokes. Regardless of what size tablet you have, don’t forget
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that you can zoom in on a specific area of your image while you work. (And
keep in mind that you might also want to have a smaller tablet to slide right
into your laptop case, too.)

The pen’s switch

Most (but not all) Wacom pens have a switch, called the DuoSwitch, or two
right on the side that (by default) let you right-click or double-click simply by
rocking the switch. Rather than tapping the pen twice on the tablet to double-
click (which could leave two spots of color if the Brush tool is active), simply
press the DuoSwitch’s upper rocker. And, of course, you can program the
DuoSwitch to other functions as well.

Setting preferences

After downloading and installing the latest version of the Wacom driver for
your tablet, open the Control Panel and customize your tablet. (On a Mac,
choose System Preferences>Wacom Tablet. In Windows, choose Start=>All
Programs=>Wacom Tablet=>Wacom Tablet Properties.) The Control Panel
(see Figure 19-2) enables you to assign a specific function or keystroke to
each of the ExpressKeys and Touch Strips, as well as program your various
pens and mouse.

an Wacom Tablet

Tablet E
GEaEmy

Click
Tool Right Cick
Middle Chick
4th Click
5th Click *
Double Click
Chick Lock t
| Keystroke xh$trip  Pop-up Meny

Applicationd

| Open/Run

Pressune Hold

Fop-up Menu
« ink Toggle ’
Disatded
Delault

Datauit

About Options

Figure 19-2: Think about what keys and keystrokes are best
assigned to the easy-to-reach ExpressKeys.
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Don’t forget the accessories

Wacom offers a variety of pens, several different kinds of mouse (including a
five-button model), and even an airbrush to help you get the very most out of
your tablet. Choose the input device that’s best for you — or switch among
several, using the one that’s most appropriate for the specific job at hand.

Cintiq for the ultimate control

It’s a monitor, it’s a tablet; it’s a tablet, it’s a monitor! It’s both. Cintiq is a
21-inch monitor that you can leave on the desk or place in your lap, and you
draw right on the surface. Monitor resolution of 1,600 x 1,200 pixels and ultra-
high tablet resolution (5,080 lines per inch) and you draw right on the image
as you work with it. The ultimate in cool and efficient.
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Ten Reasons to Own
a Digital Camera

In This Chapter

Five professional-life reasons to go digital

Four personal-life reasons to go digital
One good-for-the-future-of-the-planet reason to go digital

p icking just ten reasons to own and use a digital camera is hard. In an
effort to play to heartstrings everywhere, I've included ideas about
job-related shooting, uses in the home, travel considerations . . . the list
goes on and on, but only up to ten. After that, you have to use your
imagination.

The gap in capability between 35mm film and high-end digital
cameras disappeared some time ago. The technology
that allows digital cameras to match 35mm quality is
now found in quite reasonably priced equipment.
(Admittedly, only the most expensive digital camera
backs for very expensive high-quality cameras can
even think about competing with medium or large
format film.) If you haven’t yet gone over to the digi-
tal side, here are some convincing arguments to
make the jump. If you already are digital in mind,
body, and lens, read the list anyway — it might

give you a few points for future discussions with
traditionalists.
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Shooting Digital for Your Work

In the field, in the studio, and even in the home and on the road, digital offers
a number of advantages over film.

1 No processing time (or cost): You don’t have to wait to start editing
your images. Instead, you download to your computer and open the
images in Photoshop. No longer do you have those pesky delays
for processing/printing/scanning, nor those bothersome bills for film
processing.

1~ Instant feedback: You can evaluate the shot immediately on the camera’s
LCD screen, which allows you to quickly delete any boo-boos before
anyone else sees them. Oh, and that frees up storage space, too, of
course! And don’t forget about LCD previews available on many cam-
eras, which let you makes decisions even before you shoot.

1~ Create libraries of textures and patterns: Shoot digital images of clouds
and bark and grass and fabric and concrete and bricks and whatever to
create libraries of textures to use in Photoshop. Use blending mode and
the Texturer>Texturizer filter with your library images to create wonder-
ful backgrounds and artistic effects, such as the visually interesting
background in Figure 20-1.

Figure 20-1: The Texturizer filter uses grayscale .psd files, such as tree
branches and clouds, to add detail to an image.
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1 Remote control: Use your computer’s monitor (if your camera/software
allows) to adjust and perfect the shot before shooting. The screen is a
lot larger and more accurate than the camera’s LCD. This is often referred
to as tethered shooting.

1~ Multiple exposures for one image: Bracket the exposure and then
combine the images automatically in Photoshop with Merge to HDR.
(See Chapter 10 for specific instructions on shooting for Merge to HDR.)

Shooting Digital for Vourself

Owning a digital camera comes in handy for your personal life, too.

1~ Travel convenience: With a digital camera, you eliminate worries about
X-ray machines, baggage scanning, and film storage. And don’t forget
how much easier it is to carry a half-dozen Flash cards than dozens of
rolls of film!

» Home inventory: Do it. Really. Do it. Go around the house and take
photos of the important stuff. (Don’t forget the jewelry!) If your camera
has a date/time stamp, use it. You don’t even need to print these shots.
Just drop that Flash card or whatever storage device your camera uses
in the safe deposit box at the bank. Or mail it to your family attorney.

Or put it in an envelope at the office. But have it safe, just in case Mother
Nature (or Human Nature) requires you to file an insurance claim.

1~ Family gatherings: Hey, aren’t you the Photoshop expert? Doesn’t that
make you the perfect person to take this group photo? (Read about
instant feedback in the preceding section.)

1~ Explore your artistic boundaries: It really doesn’t cost anything
(dollar-wise) to shoot digitally. Take the off-angle shot. Play with aper-
ture and exposure. Have fun, play, and experiment. And see what you
really have inside you.

Shooting Digital for the Rest of Us

Digital photography is so much more environmentally friendly than film that
it boggles the mind! No toxic waste related to film production. No processing
chemicals to dispose of (or illegally dump down the sink). Really, truly, digital
is a more Earth-friendly way to shoot. And isn’t that a nice thought with
which to end this book?

I wish you peace, love, health, and happiness!

377
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3D (three-dimensional) artwork, 351-352
8-bit color, 109

8-bit/channel color, 109

16-bit color, 110

16-bit/channel, 110

32-bit color, 348-350

35mm film, 375

o/ o

a channel, in a Lab image, 108

Absolute radio button, 122

Acrobat, Adobe, 332

Actions

Batch command, 344-345
recording custom, 341-344

Actions palette, 52, 60, 340, 342-343

active alpha channel, 174

Add Anchor Point tool, 236

Add Fonts dialog box, 292

Add Layer Mask button, Layers palette,
176, 192, 228

Add Noise filter, 361, 366

Add to Swatches button, Swatches
palette, 300

Adding detail filter, 324

additive color mode, 107

adjustable adjustments, adjustment
layers, 177

adjustment layers, 92, 114, 154, 177, 178,
179-180

Adjustments menu, 91, 126

Adobe Acrobat, 332

Adobe Bridge, 53, 63, 68-70, 136

Adobe Camera Raw plug-in. See Camera
Raw plug-in

Adobe Composer option, palette menu, 279

Adobe Creative Suite 3, 347

Adobe Digital Negative Converter software,
132

Adobe Premiere, 14

Adobe Reader, 332

Advanced Blending option, 258-262

Airbrush mode, Options bar, 297

Airbrush option, Brushes palette, 308

Aligned check box, Options bar, 190

aligned left margin, 284

Aligned option, 183

alignment (justification), 273, 284

All Channels View, 89

All Layers option, Options bar, 363

alpha channels, 39, 172, 174

Amount slider, 99, 151, 315

Analysis menu, 348

anchor points, 229, 236-238

Angle Jitter pop-up menu, Brushes palette,
368

Angle/Use Global Light option, Layer Style
dialog box, 249

Animation palette, 353

anti-aliasing, 157-158, 273

antivirus software, 21

Apple Cinema Display, 75

Apple Studio Display, 75

AppleScripts, 346

Apply Image command, 42

aspect ratio, 31, 51, 72-73, 137, 339

asset-management program, 68

Auto Add/Delete option, Option bar, 236

Auto button, Levels dialog box, 93

Auto commands, 90-91

Auto Contrast command, 114

Auto correction, 90

Auto Erase option, 297

Auto Levels command, 114

Auto Levels/Auto Contrast/Auto Color
command, 114

autobackup software, 21
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Auto-Collapse Icon Palettes, Interface
pane, 54
Automate menu, File menu, 336
Automate submenu
collecting thumbnails in contact sheets,
334-336
Portable Document Format (PDF)
presentations, 332-334
saving paper with Picture Package,
337-339
Web sites, 336-337
automation
Actions
Batch command, 344-345
recording custom, 341-344
Automate submenu
collecting thumbnails in contact sheets,
334-336
Portable Document Format (PDF)
presentations, 332-334
saving paper with Picture Package,
337-339
Web sites, 336-337
scripts, 345-346
Auto-Spacing, 81, 335
Average filter, 317

o fje

b channel, 108

Background, Layers palette, 176

Background Eraser tool, Toolbox, 298

background layers, 179, 202, 205, 223, 229,
280, 368, 370

backgrounds, deleting plain white, 368

Balance slider, 149

banding, 110

barrel distortion, 319

Baseline Shift field, Character palette, 276

Basic pane, 143-144

Basic tab, Tone Curve tab, 145

Batch command, 80, 340, 344-345

Batch dialog box, 345

Batch Rename, 71

Batch Rename command, Bridge, 71

Bevel and Emboss effect, 244, 253-254

Bevel and Emboss pane, Layer Style dialog
box, 254

Bevel layer style, Layers palette, 367

Bicubic algorithm, 34

Bicubic Sharper, 34, 53, 73

Bicubic Smoother, 34, 53, 73

Bilinear algorithm, 34

binary code, 24

Bit Depth option, 216

Bitmap color mode, 108

Black & White adjustment, 3, 11, 117

Black Matte, Selection Preview menu, 168

black pixel, 91

Black Point Compensation check box, 59, 75

Blacks slider, 144

Blend Clipped Layers as Group, Advanced
Blending options, 261

Blend Interior Effects as Group, Advanced
Blending options, 261

blending modes, 202-205, 319, 376

Blending Options pane, 244, 258, 260,
262, 368

Bloat tool, 326

blur filter, 313

Blur filter, 317

Blur More filter, 317

bomb symbol, 112

Border command, Modify submenu, 169

bounding box, 184, 282

Box Blur filter, 317

Bridge, Adobe, 53, 63, 68-70, 136

brightness, 86

Brightness slider, Parametric pane, 144, 146

Brightness/Contrast command, 91, 116

Brush Density, Liquify window, 327

brush engine, 12

Brush Presets pane, Brushes palette, 306

Brush Pressure, Liquify window, 327

Brush Size, Liquify window, 327

brush tip instances, 368

Brush Tip Shape pane, Brushes palette,
306, 368

Brush tool, 50, 129, 156, 182, 232, 294,
295-297

Brushes palette, 4, 190, 293, 296, 301, 305,
308-309, 372



Burn tool, 102, 128-129, 183, 185, 302
Button Mode, Actions palette, 341
buttons

Camera Raw plug-in, 152

Paths palette, 234-236

oo

Cache Levels, Performance, 56
Calibrate tab, 151
Camera Raw plug-in
adjusting tone curve, 144-146
Basic pane, 143-144
buttons, 152
customizing camera profiles, 151-152
Detail pane, 147
histograms, 139-140
HSL/Grayscale tab, 148-149
Lens tab, 150-151
presets, 142-143
Presets tab, 151-152
preview area, 140
preview options, 136-139
Raw format
advantages, 132-133
defined, 131
working in, 134
requirements, 135
Split Toning tab, 149-150
tools, 136-139
workflow options, 140-142
cameras. See digital cameras
Canvas Size command, 18-19, 72, 340
Caps Lock key, 296
CapsLock toggles, 56
card reader, 63
carpal tunnel syndrome, 371
categories, 69
center aligned margin, 284
Change Layer Content, Layer menu, 223
changing size, with Image Size command,
30-33
Channel Mixer command, 122
Channel Mixer with the Monochrome box,
117

channels, manual color corrections in,
128-129
Channels in Color, Interface pane, 53
Channels palette, 48, 60, 111, 129, 172, 363
Character palette, 52, 266, 273, 274-275,
283, 370
Chromatic Aberration sliders, Lens
Correction window, 150, 321
CIELAB, 108
Cinema Display, Apple, 75
Cintiqg monitors, 374
clip art, 40
Clip slider, Shadows/Highlights dialog box,
100
Clipboard, 282
clipped colors, 127
clipping, 100, 206-207
clipping path, Paths palette, 232-233
Clone Source palette, 43, 353
Clone Stamp tool, Options bar, 183, 184,
185, 189, 190, 212, 303
closed path, 229
Clouds filter, Render menu, 328
CMYK (cyan/magenta/yellow/black), 59, 106
CMYK (cyan/magenta/yellow/black) color
images, 38, 107, 112, 300
color
32-bit, 348-350
adding to artwork, 298-301
adjustments
commands, 114-126
Histogram palette, 113
Info palette, 113
manual corrections in individual
channels, 128-129
Variations feature, 126-127
changing, 367
CMYK (cyan/magenta/yellow/black) color
images, 38, 107, 112, 300
depths, 106, 109-111
flesh tone formulas, 129-130
management
solutions, 76-77
using Print with Preview, 74-76
models, 106-109

Index 38 ’
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color (continued)
modes, 106, 109
recording color in images, 111
selecting for painting, 298-301
Color Balance command, 115-116
Color Balance dialog box, 116
Color blending mode, Layers palette, 204
color cast, 90, 111, 151
color correction, 4, 111
Color Correction/Brightness slider,
Shadows/Highlights dialog box, 100, 125
color depths, 106, 109-111
Color Dynamics pane, Brushes palette,
307-308
Color Handling pop-up menu, 75
Color Libraries button, 301
Color Libraries dialog box, 301
color management, 58
Color Management Policies area, Color
Settings dialog box, 58
Color Management section, Print dialog
box, 59
color models, 106-109
color modes, 106, 109
Color Negative effect, 115
Color Noise Reduction slider, Detail tab,
147
Color Overlay layer effect, 256
Color palette, 245, 299
Color Picker window, Color palette, 299
color profile, 106
Color Range command, 120, 167-169
Color Replacement tool, 188, 302
Color Sampler tool, 113, 130, 136-137
Color Selection option, Layer Style dialog
box, 249
Color Settings dialog box, 52, 58-59
color shift, 90
color stops, 304
color table, 107
color-adjustment commands
Auto Levels/Auto Contrast/Auto Color
command, 114
Black & White command, 117
Brightness/Contrast command, 116
Channel Mixer command, 122
Color Balance command, 115-116

Curves command, 115
Desaturate command, 118
Equalize command, 125
Exposure command, 125
Gradient Map command, 122-123
Hue/Saturation command, 117-118
Invert command, 125
Levels command, 114
Match Color command, 118-120
Photo Filter command, 124
Posterize command, 126
Replace Color command, 120-121
Selective Color command, 121-122
Shadow/Highlight command, 125
Threshold command, 125
Colored Pencil filter, 195
combining images
automatically
combining exposures for high dynamic
range (HDR) images, 216-217
creating panoramas with Photomerge,
214-215
blending modes, 202-205
creating clipping groups, 206-207
layer masks, 205-206
layers, 200-201
naturalness, 207-208
pixel opacity, 205-206
pixel transparency, 205-206
selecting with Extract feature, 208-209
Smart Objects, 201-202
Vanishing Point feature, 209-213
commands
color adjustment, 114-126
Select
Color Range command, 167-169
mask-related selection commands, 172
primary, 166-167
selection modification commands,
169-170
transforming shape of selections,
170-171
commercial printing, file formats, 38-39
compositing, 199
compositing images, 4. See also combining
images
composition, 30



compound paths, 236, 238

Conditional Mode Change command,
Automate menu, 343

Constrain Proportions check box, Image
Size dialog box, 31

Constrain Proportions option, 29

constrains proportions, 222

contact sheet, 80

Contact Sheet II, 80, 334-335, 369

contact sheets

collecting thumbnails in, 80-81, 334-336
creating, 369-370

Contour option, Layer Style dialog box, 249

Contour picker, Layer Style dialog box, 45

Contract command, Modify submenu, 170

Contract/Expand option, Refine Selection
Edge, 166

Contrast option, Refine Selection Edge,
165-166

Contrast slider, Basic tab, 146

Control Panel window, 292

control points, 229

Convert Point tool, Toolbox, 236

Convert to Grayscale option, Basic tab, 148

cool image, 124

Copy Layer Style command, Layers palette,
247

corner anchor points, 229, 237

Count tool, Toolbox, 356

Create Layers command, Layer Style menu,
248

Create New Path button, Paths palette, 235

Create New Tool Preset button, Options
bar, 276

Create Plane tool, 210

Creative Suite 3, Adobe, 347

Crop tool, 18, 51, 72, 137, 193

cropping, 30, 72-73

Cross Process effect, 115

crosshair option, 56

Crystallize filter, 366

Current Pick position, 127

Cursors pane, 56

Curve Display Options, 97

Curves command, 91, 95-97, 115

Curves dialog box, 95

custom brushes, 309, 361
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Custom Shape palette, 225
Custom Shape picker, Options bar,
45, 223, 225
Custom Shape tool, 223-224, 228
customization
shortcuts, 50
tool presets, 51-52
vector paths
adjusting type for custom font, 240-241
anchor points, 236-238
combining paths, 238-240
workspaces, 48-50
cyan/magenta/yellow/black (CMYK), 59, 106
cyan/magenta/yellow/black (CMYK) color
images, 38, 107, 112, 300
Cylindrical option, 214

o) o

Darken blending mode, 205
Darken slider, 138
Darker Color blending mode, 205
DCS file format, 39
default location, 20
Define Custom Shape, Edit menu, 225
Delete Anchor Point tool, 236
Delete Path button, Paths palette, 235
Desaturate command, 118
Deselect command, Select menu, 167
Detail pane, 147
Device Central tool, 338
DICOM (Digital Imaging and
Communication in Medicine), 357-358
Dictionary field, Character palette, 276
Difference blending mode, Layers palette,
204
Difference filter, Render menu, 328
digital cameras
customizing profiles, 151-152
downloading images from, 63-64
environmental benefits, 377
personal use, 377
professional use, 376-377
digital images. See images
Digital Imaging and Communication in
Medicine (DICOM), 357-358
digital negative, 98
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Digital Negative Converter software,
Adobe, 132

digital noise, 181, 187-188

DigitalColor Meter, 75

digitizing, 24

digits, 105

Direct Selection tool, 177, 227, 236, 237,
238, 240

direction lines, 229

DNG file, 152

DNG Options dialog box, 152

Dodge tool, 102, 103, 183, 185, 186, 302

download time, 108

downloading images, from digital cameras,
63-64

Drag Grid tool, Lens Correction window, 320

Drag the Contrast slider, 144

Dreamweaver, 15

Drop Shadow effect, 268

Drop Shadow layer effect, 250

drop shadows, 247

Dual Brush pane, Brushes palette, 307

DuoSwitch, 373

Duotone color mode, 108

Duplicate command, Image menu, 189

dye sublimation printers, 77
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Edge Contrast field, Options bar, 163
edge effects, 368-369
Edit Fade Brush, 319
Edit Layout button, 339
editing, imported video, 353
effects
changing colors, 367
contact sheets, 369-370
dashed and dotted lines, 368
deleting plain white background, 368
edge effects, 368-369
Glass Text effect, 367
painting effect, 363-364
sketch effect, 364-365
smoothing skin, 362-363
snow or rain effect, 366-367
Ellipse tool, 222

Elliptical Marquee tool, 46, 158, 159, 161,
162, 170
e-mailing images, 81-82
Emboss layer style, Layers palette, 367
EPS file format, 38
Equalize adjustment, 91
Equalize command, 125
Eraser tool, 298
Expand command, Modify submenu, 170
Expanded View, 89
Export Layers to Files, 345
Exposure adjustment, 98
Exposure command, 125, 216
Exposure dialog box, 102
Exposure feature, 97
exposures
changing, 101-102
combining for high dynamic range (HDR)
images, 216-217
ExpressKeys, 373
Extract feature, 208-209
eyeball column, 175, 201
Eyedropper, Photoshop Toolbox, 195
Eyedropper tool, 97, 113, 356, 367
eyedroppers, 94-95
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Fade command, reducing to undo with, 20
Fade Unsharp Mask, Edit menu, 20
Faux Styles field, Character palette, 276
Feather command, Modify submenu, 170
Feather option, Refine Selection Edge, 166
feathering, 157-158, 170, 207
Feathering field, Options bar, 207
file extensions, 16, 345
file formats, 35

commercial printing, 38-39

digital photos, 36-37

PowerPoint, 40

Raw, 131-134

Web graphics, 37-38

Word, 40
File Handling pane, 54-55
File Naming area, Batch dialog box, 344
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files
renaming, 71
saving, 17
Fill command, Edit menu, 303
fill layers, 178
Fill Light slider, 144
Fill Opacity slider, 261
Fill option, 258-262
Fill Path button, Paths palette, 234
Fill slider, 203, 205, 250, 260, 367
Fill tool, 208
Filter Gallery, 195, 316, 323-325, 369
filters
bending and bubbling, 328
blurring images or selections, 316-319
creating clouds, 328
Filter Gallery, 323-325
Lens Correction filter, 319-321
Liquify feature, 325-327
Reduce Noise filter, 321-323
re-editable, 311-313
sharpening to focus eye, 313-314
Smart Sharpen filter, 315-316
Unsharp Mask filter, 314-315
Fine/Coarse slider, 127
Fit Image command, Automate menu,
343-344
Fixed Aspect Ratio option, Style drop-down
menu, 160
Fixed Ratio, Style popup menu, 73
Fixed Size option, 73, 160
Flash cards, 64, 377
Flatness field, 234
Flatten All Layers check box, 339
flesh tone formulas, 129-130
floating palettes, 43
Flow setting, Options bar, 297
Focus tools, Toolbox, 302
folders, organizing, 67-68
Font Book, Mac OS, 22
font family, 291
Font menu
Options bar, 272
Type tool, 224
Font Size field, Options bar, 273
Font Style menu, Options bar, 272

fonts
customizing, 240-241
downloading and purchasing, 290-291
installing and removing, 291-292
Fonts dialog box, Control Panel, 292
foreshortening, 193
Forward Warp tool, 326
Fractional Widths option, palette menu, 278
Frame Animation mode, Animation palette,
353
Freeform Pen option, Options Bar, 232
freeform tool, 163
Freeze Mask tool, 327
Frequency field, Options bar, 163
full justification, 277
Full Screen mode, Camera Raw, 140
Full Size Brush Tip option, 56
function keys, 48
Fuzziness slider, 120, 167, 367
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gamut, 106, 140

Gaussian Blur filter, 316, 317, 363, 365

General pane, 18, 53

GIF file format, 38

Glass Text effect, 367

Glass Type technique, 260

Global Light command, Layer Style menu,
247-248

glyphs, 278

GPU Settings, Performance, 56

Gradient Editor, 257

Gradient Map command, 122-123

Gradient Overlay layer effect, 257

Gradient palette, 257, 305

Gradient picker, Options bar, 45

gradients, 304-305

Graphire line, 372

Grayscale color mode, 107

grayscale photo, 11

Grayscale setting, 59, 168

Grayscale Toolbar Icon, Interface pane, 53

Green channel, Channels palette, 129

green-eye, 182

groups, 201

Guides, Grid & Slices pane, 57
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Hand tool, 136, 320, 327

Hard Light blending mode, Layers palette,
204

HDR (high dynamic range) images,
111, 216-217

HDR Color Picker, Toolbox, 349

Healing Brush tool

Layers palette, 363
Options bar, 183, 303

Healing tools, Toolbox, 302

Height field, Options bar, 160

hidden adjustments, adjustment layers,
177

Hide All Effects command, Layer Style
menu, 248

high dynamic range (HDR) images,
111, 216-217

high-key image, 88

Highlighter tool, 208

highlights, 87

Highlights slider, Parametric pane, 146

Histogram palette, 48, 87-88, 111, 113, 139

histograms, 86-90, 139-140

History Brush feature, 18-19, 66, 153, 209

history log, 53

History palette, 18, 189, 300

history state, 300

History States, Performance, 55

Horizontal Perspective slider, Lens
Correction window, 321

Horizontal Type Mask tool, 268

Horizontal Type tool, 268, 282

HSL/Grayscale tab, 148-149

Hue/Saturation command, 117-118

Hue/Saturation slider, 367

hyphenating, 285

hyphenation options, 278, 284
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ICC profiles, 59

Image Cache, 88

Image Interpolation method, 53
Image Processor, 345

image resolution
changing size with Image Size command,
30-33
choosing, 34-35
overview, 27-29
resampling methods, 33-34
Image Size command, 18-19, 30-33, 42, 72,
80, 340
Image Size dialog box, 29, 73
image-editing program, 10
images
deleting plain white background, 368
digital images defined, 24-25
edge effects, 368-369
file formats, 35
commercial printing, 38-39
digital photos, 36-37
PowerPoint, 40
Web graphics, 37-38
Word, 40
high dynamic range (HDR), 216-217
importing, 62
downloading from digital cameras,
63-64
scanning prints, 64-67
improving, 181
landscapes, 188-195
noise reduction, 187-188
portraits, 182-186
organizing
creating folder structure, 67-68
renaming files, 71
using Adobe Bridge, 68-70
painting effect, 363-364
pixels, characteristics, 25-27
printing, 71
alternatives to, 77-78
color management solutions, 76-77
controlling color using Print with
Preview, 74-76
cropping to specific aspect ratio, 72-73
resolution, 73-74
recording color in, 111
resolution of
basic types, 27-28
checking and changing, 28-35



rotating, 195
sharing
collecting thumbnails in contact sheets,
80-81
e-mailing images, 81-82
Portable Document Format (PDF)
presentations, 78-80
sketch effect, 364-365
snow or rain effect, 366-367
Import/Export folder, Plug-Ins folder, 64
importing images
downloading from digital cameras, 63-64
scanning prints
determining scan resolution, 65-66
preventing moiré patterns, 66-67
improving images
landscapes
fixing perspective, 193-194
removing unwanted objects, 188-193
rotating images, 195
noise reduction
digital noise, 187-188
luminance noise, 188
of people
glasses, 185
red-eye, 182-183
teeth, 186
weight reduction, 184-185
wrinkles, 183-184
Indent First Line option, Paragraph palette,
277
Indent Margins option, Paragraph palette,
277
Indexed Color mode, 107-108
Info palette, 48, 111, 113
Inkjet printers, 77-78
Inner Bevel effect, 268
Inner Glow layer effect, 253
Inner Shadow layer effect, 250-251
installing, Photoshop CS3, 20-22
Interface pane, 53-54
Internet Service Provider (ISP), 337
Inverse command, Select menu, 167
Invert command, 125
ISP (Internet Service Provider), 337

0]0

jaggies, 26, 158

JPEG compression, 323

JPEG file, 35, 36-37

JPG file format, 37-38

justification (alignment), 273, 284
Justification option, Paragraph palette, 277
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Kerning field, Character palette, 275
keyboard shortcuts, 18, 48, 49

Keyboard Shortcuts, Edit menu, 50
keywords, 69

Knockout, Advanced Blending options, 261

o/ o

Lab color mode, 20, 108

landscape aspect ratio, 72

landscapes
fixing perspective, 193-194
removing unwanted objects, 188-193
rotating images, 195

Large Document Format (PSB), 37

Large Thumbnail option, Styles palette, 246

lasso selection tools, 162-163

Lasso tool, 163, 268

launching Photoshop CS3, 16

layer blending mode, 227

layer content, 227

layer effect, 244

layer mask, 176

Layer Mask Hides Effects, Advanced

Blending options, 261

layer masks, 176, 227

Layer Style dialog box
Bevel and Emboss layer effect, 253-254
Color Overlay layer effect, 256
Drop Shadow layer effect, 250
Gradient Overlay layer effect, 257
Inner Glow layer effect, 253
Inner Shadow layer effect, 250-251
Layers palette, 243, 258, 263, 281, 306

Index 38 7
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Layer Style dialog box (continued)
Outer Glow layer effect, 252
Pattern Overlay layer effect, 257-258
Satin layer effect, 254-255
Stroke layer effect, 258

Layer Style menu, 244, 247-248

layers
in 32-bit color, 348-350
adding masks to, 176
adjustment layers

adding, 178
limiting adjustments, 179-180
defined, 200-201
layer masks, 205-206
shape
changing appearance of, 226-227
converting custom shapes from
symbols, 224-226
Custom Shape tool, 223-224
shape tools, 222-223
simulating multicolor, 227-229
styles
creating, 247-262
defined, 244-245
saving, 262-264
Styles palette, 245-246

Layout pop-up menu, 339

Leading field, 275, 283

lens, distortion, 313

Lens Blur filter, 316, 317

Lens Correction filter, 319-321, 325

Lens tab, 150-151

Levels adjustment, 175

Levels command, 91, 92-95, 114

Levels command, Image, 92

Levels dialog box, 50, 94, 367

Lighten blending mode, 205

Lighter Color blending mode, 205

lightness channel, 108

Lightness slider, 367

limitable adjustments, adjustment layers,

177

line screen frequency, 35

Line tool, 222

lines, 368

Link button, Layers palette, 201

Liquify feature, 185, 208, 325-327

Liquify window, 325-326

Load Selection command, 172

Load Selection dialog box, 173

Load Statistics button, 120

Load Styles command, Styles palette, 246

loading settings, Lens Correction window,
321

loops, 333

lossy compression scheme, 39

Lower Layer, Layers palette, 205

low-key image, 88

luminance noise, 188

Luminance slider, 119

Luminosity blending mode, Layers palette,
204
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Mac Finder, 63
Magic Eraser, 298
Magic Wand tool, 164-165, 294
Magnetic Lasso tool, 162, 163
Magnetic option, Freeform Pen, 232
marquee selection tools, 159-162
Marquee tool, 211
masks
adding to layers, 176
adding to Smart Objects, 176
defined, 172
editing alpha channel, 173-175
layer masks, 205-206
masking with vector paths, 177
mask-related selection commands, 172
saving and loading selections, 172-173
working in Quick Mask mode, 175-176
Match Color command, 118-120
MATLAB software environment, 357-358
Measurement Log palette, 355
megapixel (MP) rating, 27
Memory Usage, Performance, 55
Menu Colors, Interface pane, 54
menus, 42-43
Menus dialog box, 49
Merge to HDR command, Photomerge,
332, 377
Merge Visible menu command, Layers
palette, 209



metadata, 134

Midpoint slider, 151

Midtone Contrast slider,
Shadows/Highlights dialog box, 100

midtones, 87, 96

Mirror tool, 327

Modify commands, 169

moiré patterns, preventing, 66-67

moiré reduction feature, 66

monitor resolution, 27, 374

Monochrome check box, Channel Mixer,
122

Motion Blur filter, 20, 316, 317, 361, 367

Move tool, Edit menu, 156

MP (megapixel) rating, 27

Multichannel color mode, 108

Multiply blending mode, 204, 250

o\ o

NAPP (National Association of Photoshop
Professionals), 10, 361

National Association of Photoshop
Professionals (NAPP), 10, 361

naturalness, of combined images, 207-208

Navigator palette, 189

Nearest Neighbor algorithm, 34

nested groups, 201

network drives, 16

New Action button, Actions palette, 341

New Adjustment Layer menu, Layers
palette, 178, 365

New Brush Preset command, Brushes
palette, 309

New command, File menu, 349

New Fill Layer menu, Layers palette, 178

New Layer button, Layers palette, 190, 366

New Spot Channel dialog box, 112

New Style dialog box, 263

No Break option, palette menu, 278

Noise option, Brushes palette, 308

noise reduction, 187-188

Noise slider option, Layer Style dialog box,
249

Normal blending mode, 190, 203, 250, 256

o () o

opacity, 192, 203, 227, 250, 258-262, 297,
298, 304
Open dialog box, 333
open path, 229
Open Using Rosetta option, Get Info
window, 21
OpenType fonts, 278
Options bar, 41, 43, 45, 266, 272-273, 351
Options button, Levels dialog box, 93
organizing images, 67-71
creating folder structure, 67-68
renaming files, 71
using Adobe Bridge, 68-70
Orientation button, Options bar, 272
Outer Glow layer effect, 252
Outer Glow options, 252
out-of-gamut colors, 168
Output Levels slider, 93
Overlay blending mode, Layers palette,
204, 250

oo

Page layout, 14
page layout programs, 35
Paint Bucket tool, Edit menu, 303
painting
in 32-bit color, 348-350
Brushes palette
custom brush tips, 308-309
options, 306-308
effects, 363-364
tools
adding color, 303-304
Brush tool, 295-297
Eraser tool, 298
gradients, 304-305
other brush-using tools, 301-303
Pencil tool, 297
selecting colors, 298-301
to undo with History Brush, 18-19
Palette menus, 50
Palette Options, 130, 207
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palettes, 43-45, 48, 278
panoramas, 214-215
paper, saving with Picture Package, 337-339
Paragraph palette, 52, 266, 274, 277, 284
Paragraph type text, 265
Parametric pane, Tone Curve tab, 144
Pass Through to Normal mode, Layers
palette, 180
Paste command, Edit menu, 156
Paste Layer Style command, Layers
palette, 247
Patch tool, 51, 183
Path from Selection button, Paths palette,
235
path segments, 220, 229, 237
Path Selection tool, Toolbox, 236
path shape, 227
path-related tools, 45
Paths palette, 48, 223, 232-236
Pattern Overlay layer effect, 257-258
Pattern palette, 257
Pattern picker, Fill dialog box, 45
PDF (Portable Document Format), 37, 38,
78, 332
PDF (Portable Document Format)
presentations, 78-80, 332-334
PDF Presentation dialog box, 78
Pen tool, creating vector paths with
components, 229
Paths palette, 232-236
practicing, 230-232
Pencil tool, 97, 232, 294, 297
Performance pane, 55-56
perspective, 193-194, 207
Perspective check box, Options bar, 193
Perspective command, Edit menu, 193
Perspective option, 214
Photo Filter command, 124
photographs, 214
Photomerge, 2, 214-215
Photoshop CS3
capabilities, 10-14
customization
shortcuts, 50
tool presets, 51-52
workspaces, 48-50

installing, 20-22
keyboard shortcuts, 18
launching, 16
menus, 42-43
palettes, 43-45
saving files, 17
tools, 45-47
troubleshooting, 60
undoing, 18-20
using instead of specialized software,
14-15
working with images, 16-17
Photoshop CS3 Extended
32-bit color, 348-350
advanced features, 357-358
description, 348
editing imported video, 353
pixel analysis
counting, 356-357
measuring, 354-356
Smart Object stack modes, 350
three-dimensional (3-D) artwork, 351-352
Photoshop Raw file format, Save As dialog
box, 134
pickers, 45
picture element, 24
Picture Package, 337-339
pin cushioning, 319
pivot points, 144
pixel grid, 25
pixels
characteristics, 25-27
counting, 356-357
dimensions, 18, 29, 65, 172
measuring, 354-356
opacity, 205-206
transparency, 205-206
pixels per inch (pip), 80, 221
Plug-Ins pane, 57
PANG file format, 38, 40
point of origin, 287
point of rotation, 184
Point pane, Tone Curve tab, 145
point type, 282
Point type text, 265
Polygon Lasso tool, 155, 163



Polygon tool, 222, 223
Portable Document Format (PDF), 37, 38,
78, 332
Portable Document Format (PDF)
presentations, 78-80, 332-334
portrait aspect ratio, 72
portraits
glasses, 185
red-eye, 182-183
smoothing skin, 362-363
teeth, 186
weight reduction, 184-185
wrinkles, 183-184
pasteurization, 93-94
Pasteurization, 110
Posterize command, 126
PostScript, 221, 290
PowerPoint
file formats, 40
presentations, 35
pip (pixels per inch), 80, 221
Preferences dialog box, 266
Preferences file
Cursors pane, 56
File Handling pane, 54-55
General pane, 53
Guides, Grid & Slices pane, 57
Interface pane, 53-54
Performance pane, 55-56
Plug-Ins pane, 57
Transparency & Gamut pane, 56
Type pane, 57
Units & Rulers pane, 57
Preferences menu, Camera Raw, 138-139
Premiere, Adobe, 14
Preserve Luminosity check box, 116
Preserve Photoshop Editing Capabilities,
PDF Options dialog box, 39
Preset Manager command, 45, 53, 60,
225-226, 246, 263-264
Presets tab, 151-152
preview area, Camera Raw plug-in, 140
Preview check box, Camera Raw, 140
print size, 29
Print with Preview option, 74-76
Printer Profile pop-up menu, 75
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printing
alternatives to, 77-78
color management solutions, 76-77
controlling color using Print with Preview,
74-76
cropping to specific aspect ratio, 72-73
resolution, 28, 73-74
prints, scanning
determining scan resolution, 65-66
preventing moiré patterns, 66-67
Prophet RIB color space, 141
Protect Texture option, Brushes palette,
308
PSB (Large Document Format), 37
PAD file format, 17, 36, 39
Pucker tool, 326
Pupil Size slider, 138
Push Left tool, 326-327

OQO

quarter tones, 96

Quick Mask mode, 166, 175

Quick Mask Options dialog box, Toolbox,
175

Quick Mask preview, 168

Quick Selection tool, 3, 164, 167, 294,
302, 372

o R o

Radial Blur filter, 317
Radius option, Refine Selection Edge, 165
Radius slider
Detail tab, 147
Shadows/Highlights dialog box, 100
Unsharp Mask filter, 315
ragged margin, 284
rain effects, 366-367
Range slider, 252
Range to Midtones, Options bar, 103
raster art program, 12
raster artwork, 157
raster image processor, 107
Raster imagery, 220
raster zed, 268
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Raw file format
advantages, 132-133
defined, 131
working in, 134
Reader, Adobe, 332
Reconstruct Options, Liquify window, 327
Reconstruct tool, 326, 327
Record Measurements button, 355, 357
Record Stop dialog box, Actions palette,
343
Rectangle tool, 222
Rectangular Marquee tool, 46, 72, 73, 159,
161, 162, 268
Red channel, Channels palette, 129
Red Eye Reduction tool, 138
Red Eye Removal tool, 137
Red Eye tool, 182
red-eye, 182-183
red-eye effect, 181
red/green/blue (RIB), 106, 107, 109
Reduce Color Noise slider, Reduce Noise
filter, 323
Reduce Noise filter, 187, 321-323
reducing, to undo with Fade command, 20
re-editable filters, 202
Refine Edge button, 165, 207
Refine Selection Edge feature, 165-166
Relative Colorimetric, 141
Relative radio button, 122
Remember icon, 6
Remember Palette Locations, Interface
pane, 54
removable media, 16
Remove Distortion tool, Lens Correction
window, 320
Remove JPEG Artifact option, Reduce
Noise, 188
removing unwanted objects, 188-193
Render menu, Filter menu, 328
repetitive stress injuries, 371
Replace Color feature, 120-121, 367
Replace Styles command, Styles palette,
246
Resample Image box, Image Size dialog
box, 32
resampling, 31-34, 142
Reselect command, Select menu, 167

Reset All Warning Dialogs, 53
Reset option, palette menu, 279
Reset Palette Locations setting, 48
Reset Styles command, Styles palette, 246
Reset Swatches command, Swatches
palette, 75
resolution
basic types, 27-28
image
changing size with Image Size command,
30-33
choosing, 34-35
resampling methods, 33-34
printing, 73-74
scanning, 65-66
response curve, 217
Restore All button, Liquify window, 327
Retouch tool, 136, 137
Reveal All command, 43
reversible adjustments, adjustment layers,
177
RIB (red/green/blue), 106, 107, 109
rich black, 78
Rights-managed images, 65
Roman Hanging Punctuation option,
palette menu, 278-279
rosette pattern, 66
Rotate for Best Fit option, 81, 335
rotating images, 195
Rounded Rectangle tool, Options bar, 223
rounded rectangles, 222
Royalty-free images, 65
Ruler tool, 195, 355, 356
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Sample All Layers button, Options bar, 190

Sample All Layers option, 164

Satin layer effect, 254-255

Saturation tab, 148

Save Actions command, Actions palette,
341

Save Adobe PDF dialog box, 333

Save As dialog box, 35

Save for Web & Devices command, 15

Save New Camera Raw Defaults command,
Camera Raw, 142



Save Selection command, 172
Save Settings command, Camera Raw,
143, 152
Save Shapes menu command, Custom
Shape picker, 225
Save Statistics button, 120
Save Styles command, 246, 263
saved path, Paths palette, 232
saving files, 17
Saving settings, Lens Correction window,
321
scale, 207
Scale Effects command, Layer Style menu,
248
Scale Styles check box, Image Size dialog
box, 30
Scaling field, Character palette, 275
scan resolution, determining, 65-66
scanning prints
determining scan resolution, 65-66
preventing moiré patterns, 66-67
Scattering pane, Brushes palette, 307
Scratch Disks, Performance, 55
Screen blending mode, 204, 250, 252
scripting, 341
scripts, 331, 345-346
S-curve, 96
Select commands, 166-172
Select menu, 166-167
selecting images, with Extract feature,
208-209
Selection from Path button, 235, 236
selections
adjustment layers
adding, 178
limiting adjustments, 179-180
anti-aliasing, 157-158
commands
Color Range command, 167-169
mask-related, 172
primary selection commands, 166-167
selection modification commands,
169-170
transforming shape of selections,
170-171
defined, 154-156
feathering, 157-158
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making with tools
lasso selection tools, 162-163
Magic Wand tool, 164-165
marquee selection tools, 159-162
Quick Selection tool, 164
Refine Selection Edge feature, 165-166
masks
adding to layers, 176
adding to Smart Objects, 176
defined, 172
editing alpha channel, 173-175
masking with vector paths, 177
saving and loading selections, 172-173
working in Quick Mask mode, 175-176
Selective Color command, 121-122
Set White Point Preview slider, 216
Shadow/Highlight feature, 5, 98-100, 125
shadows, 87
Shadows slider
Parametric pane, 146
Shadows/Highlights dialog box, 99
Shadows/Highlights dialog box, 99
Shape 1 Vector Mask, Paths palette, 223
Shape Blur filter, 318
Shape Dynamics pane, Brushes palette,
306-307, 308, 368
shape layers
changing appearance of, 226-227
converting custom shapes from symbols,
224-226
Custom Shape tool, 223-224
shape tools, 222-223
simulating multicolor, 227-229
shape tools, 222-224
sharing images
collecting thumbnails in contact sheets,
80-81
e-mailing images, 81-82
Portable Document Format (PDF)
Presentation, 78-80
sharpen filter, 313
Sharpness slider, Detail tab, 147
Shear filter, 328
shortcuts, 18, 50
Show Clipping check box, 127
Show More Options check box, Shadows/
Highlights dialog box, 99
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Show Overlay option, 353
Show Slice Numbers option, Smart
Guides, 57
sidecar file, 134
Single Column Marquee tool, 159, 162
Single Row Marquee tool, 159, 162
sketch effects, 364-365
skin tones, 129-130
slider controls, in Camera Raw, 144
Small Thumbnails view, Styles palette, 246
Smart Blur filter, 188, 318, 365
Smart Filters, 14, 17, 177, 202, 364
Smart Guides, 57
Smart Objects
adding masks to, 176
advantages of, 201-202
stack modes, 350
Smart Sharpen filter, 147, 313, 315-316, 363
smooth anchor points, 229, 237, 238
Smooth command, Modify submenu, 169
Smooth option, Refine Selection Edge, 166
Smoothing detail filter, 324
Smoothing option, Brushes palette, 308
snapshots, 300
snow effects, 366-367
Soft Light blending mode, Layers palette,
204
Source pop-up menu, 120
source state, 19
Space Before/After option, Paragraph
palette, 278
secular highlights, 125
Spheres filter, 328
splash screens, 348
Split Toning tab, 149-150
Sponge tool, 183, 302
spot channels, 39, 112
spot colors, 301
Spot Healing Brush, 190
spy ware, 21
Stack Modes submenu, Layer menu, 350
stacking order, 201
stacks, 70
Stamp tools, Toolbox, 302
stochastic printing devices, 34
stops, 304

Straighten tool, Lens Correction window,
320

Stroke command, Edit menu, 303

Stroke Emboss option, 258

Stroke layer effect, 258

Stroke Path button, Paths palette, 234-235

Studio Display, Apple, 75

Stuff It, 81

Style drop-down menu, Options bar, 160

Style popup menu, Rectangular Marquee
tool, 73

Styles palette, 243, 244, 245-246, 262-263

submenu, 42

sub paths, 238

subtractive color mode, 107

Suitcase Fusion, Extensors, 22

Summation stack mode, 350

Surface Blur filter, 188, 318

Swatches palette, 75, 245, 300

symbol fonts, 225

Symbol layer, Layers palette, 179

symbols, creating custom shapes from,
224-226

System Layout option, palette menu, 278
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tablet resolution, 374
temperature, 124
Temperature slider, 136
tethered shooting, 377
text
attributes, 272-273
fonts, 289
downloading and purchasing, 290-291
installing and removing, 291-292
Glass Text effect, 367
tools
attributes, 271-274
palette menus, 278-279
palettes, 274-278
text-shaped pictures, 280-281
type containers
alignment (justification), 284
hyphenating, 285
typing on path, 285, 287-289
warping text, 285, 286



Texture pane, Brushes palette, 307
Textures filter, 195, 363, 376
Thaw Mask tool, 327
third-party plug-ins, 21
three-dimensional (3-D) artwork, 351-352
three-quarter tones, 96
Threshold command, 125
Threshold slider, Unsharp Mask filter, 315
thumbnails, 80-81, 333, 334-336
thumbnails layer, 207
TIFF file format, 38
tiles, 24
Tint slider, 136
Tip icon, 5
tolerance, 164
tonal range, 86
Tonal Width sliders, Shadows/Highlights
dialog box, 99-100
tonality
adjusting, 86
Auto commands, 90-91
changing exposure, 101-102
Curves command, 91, 95-97
histograms, 86-90
Levels command, 91-95
Shadow/Highlight feature, 98-100
toning tools, 102-103
tone curve, adjusting, 144-146
Tone Curve tab, 144
toning tools, 102-103, 302
tool presets, customization, 51-52
Tool Presets palette, Options bar, 52, 272
Tool Tips, Interface pane, 54
Toolbox palette, 299
tools
Camera Raw plug-in, 136-139
making selections with
lasso selection tools, 162-163
Magic Wand tool, 164-165
marquee selection tools, 159-162
Quick Selection tool, 164
Refine Selection Edge feature, 165-166
painting
adding color, 303-304
Brush tool, 295-297
Eraser tool, 298
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gradients, 304-305
other brush-using tools, 301-303
Pencil tool, 297
selecting colors, 298-301
presets, 51-52
text
attributes, 271-274
palette menus, 278-279
palettes, 274-278
text-shaped pictures, 280-281
toning, 102-103
ToolTips, 42
Touch Strips, 373
tracking, 288
Transform commands, Edit menu, 34, 207
Transform controls, Lens Correction
window, 321
Transparency & Gamut pane, 56
transparency adapters, 66
transparency grid, 262
Transparency Shapes Layer, Advanced
Blending options, 261
troubleshooting, Photoshop CS3, 60
Turbulence tool, 327
tweak able adjustments, adjustment layers,
177
Twirl Clockwise tool, 326
Type Color, Options bar, 273
type containers
alignment (justification), 284
hyphenating, 285
overview, 282-283
type layers, 268
type mask tool, 269
Type pane, 57
Type tool, 52, 224, 225, 260, 267
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undoing
painting to undo with History Brush, 18-19
reducing to undo with Fade command, 20
Undo/Redo function, 50
Units & Rulers pane, 57
unprocessed image data, 132
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Unsharp Mask filter, 313, 314-315, 319, 365,
366

upper layer, Layers palette, 205

Use Previous Layer to Create Clipping
Mask option, Layers menu, 179

oo

Vanishing Point feature, 199, 209-213, 348,
356
Variations feature, 126-127
vector art, 12, 219, 220
vector layer mask, 223
vector logo, 221
vector mask, 223, 261
Vector Mask Hides Effects, Advanced
Blending options, 261
vector mask path, Paths palette, 233
vector masks, 177
vector objects, 220, 236
vector paths
creating with Pen tool
components, 229
Paths palette, 232-236
practicing, 230-232
customizing
adjusting type for custom font, 240-241
anchor points, 236-238
combining paths, 238-240
shape layers
changing appearance of, 226-227
creating custom shapes from symbols,
224-226
Custom Shape tool, 223-224
shape tools, 222-223
simulating multicolor, 227-229
types of, 232-234
Version Cue, Creative Suite, 54
Vertical Perspective slider, Lens Correction
window, 321
Vertical Type Mask tool, 268
Vertical Type tool, 268
Vibrancy slider, 144
video, editing imported, 353
video layers, 353
Video Layers submenu, Layer menu, 353

Vignette sliders, Lens Correction window,
321

Igniting sliders, 151

Visual Basic scripts, 346

o(l/ o

Waco tablets

accessories, 374

advantages of, 371-372

Cintiq monitors, 374

pen switches, 373

setting preferences, 373

sizes, 372-373
warm image, 124
Warning icon, 6
warnings, 59
Warp command, Edit menu, 208
warping text, 285, 286
Web graphics, file formats, 37-38
Web images, 35
Web Photo Gallery features, 12
Web server, 337
Web sites, creating, 336-337
Web-safe colors, 300
Wet Edges option, Brushes palette, 308
White Balance tool, Basic pane, 143
white pixel, 91
Width field, Options bar, 160, 163
Windows Explorer, 63
WinZip, 81
Word, file formats, 40
word processing documents, 35
word wrap, 282
work path, Paths palette, 232
Workflow Options dialog box, 140-143
workflow options, for Camera Raw, 141-142
Workspace menu, Windows, 70
workspaces, customization, 48-50

o/ o

zones, 339

zoom and grid controls, Lens Correction
window, 321

Zoom tool, 136, 320, 327





