AuthorizationTrampoline
AuthorizationTrampoline command filedesc argument...

Description

An SUID root program that invokes actions with superuser privileges on behalf of applications calling the AuthorizationExecuteWithPrivileges routine (part of the Security framework's Authorization Services API). Successful use of this routine requires authorization against the system.privilege.admin right defined in /etc/authorization, meaning that it's limited to root and to those in the admin group.

Options/Usage

argument

A list of arguments to be passed to command.

command

The path to the program to be executed with superuser privileges.

filedes

A file descriptor for a temporary file containing the authorization reference obtained by the application calling AuthorizationExecuteWithPrivileges. The reference is used by AuthorizationTrampoline to determine if the request should be allowed.

Location

/System/Library/CoreServices


autodiskmount
autodiskmount [-d] [-v] [-a] [-F [-V vol_name]]

Description

Automatically discovers and mounts disk volumes.

Options/Usage

-a

Mounts removable disk volumes, as well as volumes on fixed disks.

-d

Prints debugging information to standard output.

-F

Prints the device name and filesystem type of the largest unmounted HFS+ or UFS volume on an internal fixed disk to standard output. If all volumes are the same size, prints information for the first one found. If -a is specified, prints information for all such volumes.

-v

Should print a list of mounted volumes to standard error after it's finished working, but does not work in Panther.

-V

Prints information only for the specified volume, if found.

Location

/sbin


automount
automount -help

automount -V

automount [-m map_directory map [-mnt mount_directory] [-1]]... [-a mount_
directory] [-d] [-D { mount | nsl | options | proc | select | all }]... [-f]
[-s] [-tcp] [-tl timeout] [-tm timeout]

Description

Provides transparent, automated access to NFS and AFP shares. When running, any filesystem access to map_directory is intercepted by automount. Typically, automount will then set up a symbolic link from map_directory or one of its subdirectories to a mount point under mount_directory, automatically creating directories and mounting remote volumes as needed. It will also unmount remote volumes that have been idle for too long. Directories or mounts set up by automount are removed when automount exits.

automount makes use of maps to determine how to mount volumes. When using a file as a map, the format is similar to that used by NFS automounters on other Unix platforms. Each entry in the file consists of a single line, either a comment beginning with a hash mark (#), or a mount directive of the form:

subdirectory server:/pathname

If this line were included in a file named /etc/mountmaps, and automount were called like so:

# automount -m /mount_directory /etc/mountmaps

upon accessing /mount_directory, automount would mount the NFS-exported server:/pathname on /private/mount_directory/subdirectory and create a symlink to that mount point from /mount_directory/subdirectory.

At one time it was also possible to use a map stored in a NetInfo database under /mountmaps/, but that functionality has been deprecated in future versions of Mac OS X.

AFP URLs

The format of the AFP URLs in the automount examples is described in the manpage for mount_afp, but there are certain constraints you should be aware of:

  • First, server must be a valid TCP/IP hostname or IP address, which may be different than the AFP name that shows up, for example, in a Connect to Server... dialog window.

  • Second, share_name is the AFP name for the share point, which is not necessarily the same as the full pathname to the share point on the server.

  • Finally, there are a few ways to handle authentication to the AFP server. If guest access to the share is allowed, then you may use a URL like those in the examples for automount:

         afp://;AUTH=NO%20USER%20AUTHENT@server/share_name

If user authentication is required, then you have two options. The first is to specify the necessary authentication information in the URL like so:

afp://username:password@server/share_name

However, this makes the authentication password available to anyone with access to the configuration stored in Open Directory. The other option is to leave out the authentication parameters:

afp://server/share_name

In this case, a user logged into the graphical console is presented with an authentication dialog to enable access to the share. Of course, if no one is logged into the GUI, this won't work, and the mount attempt will fail.

In addition to map files, there are several special maps available. Foremost among them are those used by default on Mac OS X systems, -fstab, -static, and -nsl. The following commands are run from the NFS startup item:

automount -m /Network -nsl
automount -m /automount/Servers -fstab -mnt /private/var/automount/Network/
Servers[RETURN]
  -m /automount/static -static -mnt /private/var/automount

Both -fstab and -static maps use similar configuration formats, stored in an Open Directory database under /mounts/. The following configuration line triggers automount when using the -fstab map:

server:/subdirectory /mount_point url[RETURN]
  net,url==afp://;AUTH=NO%20USER%20AUTHENT@server/share_name 0 0

The AFP mount is used as an example for the remainder of this section, but an equivalent NFS configuration would look like this:

server:/subdirectory /mount_point nfs net 0 0

There are several options for getting this configuration into Open Directory; one is to use niload fstab domain, then enter the configuration line, followed by Ctrl-D. The configuration will be stored in Open Directory like this (as displayed by nidump -r /mounts domain):

{
  "name" = ( "mounts" );
  CHILDREN = (
    {
      "dir" = ( "/mount_point" );
      "dump_freq" = ( "0" );
      "name" = ( "server:/subdirectory" );
      "opts" = ( "net", "url==afp://;AUTH=NO%20USER%20AUTHENT@server/share_name" );
      "passno" = ( "0" );
      "vfstype" = ( "url" );
    }
  )
}

The net option is the signal for automount to use this configuration line with the -fstab map. If the net option is not used, this configuration line is picked up by the -static map.

With this configuration, and automount called like so:

# automount -m /automount/Servers -fstab
  -mnt /private/var/automount/Network/Servers

upon accessing /automount/Servers, automount mounts share_name from server on /private/var/automount/Network/Servers/server/subdirectory, and creates a symlink from /automount/Servers/server. (Alternatively, the mount may be accessed via /Network/Servers/server, thanks to a symlink created by the NFS startup item.) The configured mount point (the value of the dir property) is ignored by the -fstab map.

Don't use a map_directory argument to -m that traverses a symlink, or any accesses to the mount will hang. For example, it's OK to do this:

# automount -m /private/tmp/map_dir -fstab

but not this:

# automount -m /tmp/map_dir -fstab

since /tmp is a symlink to /private/tmp.

While the -static map uses a configuration very much like this for -fstab, its mounting and linking behavior is significantly different. With a configuration like this (viewed as the output of nidump fstab domain):

server:/subdirectory /mount_point url [RETURN]
  url==afp://;AUTH=NO%20USER%20AUTHENT@server/share_name 0 0

and automount called like so:

# automount -m /automount/static -static -mnt /private/var/automount

upon accessing /mount_point, automount mounts share_name from server on /private/var/automount/mount_point, creates a symlink to this directory from /automount/static/mount_point, and then makes another from /mount_point to /automount/static/mount_point. The configured server:/subdirectory (the value of the name property) is ignored by the -static map for AFP shares. (Incidentally, the term "static" is a misnomer. Mounts are made dynamically when they're accessed, just as with the -fstab map.)

In order to avoid networking overhead, automount attempts to create symlinks directly to folders that are shared from the same machine. In other words, , rather than mounting a share that exists locally on a file server, automount sets up the symlinks to provide for direct access.

However, as of this writing, automount exhibits what is apparently a bug—the symlinks created for local shares always point to the server's root directory (/). In most cases this means that shares accessed from the server are useless, as the path to those shares doesn't match what is seen on remote clients.

The -nsl map uses the Network Services Location service discovery API to automatically find available shares on the network (just as the Finder's Connect to Server... menu item does) and create mounts for them. With automount invoked like this:

# automount -m /Network -nsl

discovered shares are mounted on subdirectories of /private/var/automount/Network/server, with a symlink created from /Network/server.

Before version 10.3, the -nsl map didn't really work, and generated I/O errors when access to a mount was attempted. The automount command making use of the -nsl map in the NFS startup item was added in Panther.

Another special map is the -user map, which doesn't actually cause any remote filesystems to be mounted on its own. It merely sets up symlinks to every user account's home directory from the map_directory, which may be useful if you want a single place to look in for everyone's home directory. But proceed cautiously if you have a very large number of user accounts.

The -host map is meant to automatically mount NFS exports from hosts listed in a NIS hosts map when accessing a subdirectory of the map_directory with the same name as the host. For example, accessing /net/hostname/export should mount hostname:/export if /net is the map_directory. This is similar to the -hosts map of other NFS automounters.

The -null map mounts... well, nothing. It will, however, intercept filesystem calls for the map_directory, thus effectively mounting an empty directory over whatever might have been there before. In the original automount, from which NeXT's and Apple's versions are descended, this was meant to nullify configuration entries included from a network-wide NIS map.

When running in daemon mode, automount stores its process ID in /var/run/automount.pid, and responds to SIGHUP by reloading its configuration.

Options/Usage

-1

Creates directories on the path to a -fstab mount point one at a time, as they're traversed, rather than creating the entire path to a mount point when the mount is accessed. However, using this option leads to I/O errors when trying to access the mount.

-a

Specifies the directory in which mounts are made. Symbolic links from the directory specified in the -m option are used to access these mounts. The default directory is /private/var/automount.

-d

Sends debugging output to standard error, and prevents daemonization.

-D

Outputs debugging messages of the specified type. If the -d option is used, output is to standard error; otherwise it's via syslog. Multiple occurrences of this option may be used to specify multiple types.

-f

Used internally by automount to indicate that the process has already forked during daemonization. (You can see in the output of ps -ax that the automount daemon runs with the -f flag, even though it isn't invoked that way from the NFS startup item.)

-help

Prints a usage statement to standard output.

-m

Uses the specified map to mount shares and create symlinks from the specified directory to the mount points. The map argument can be an absolute pathname to a file, a map in the /mountmaps/ directory of an Open Directory domain, or one of the special values -fstab, -host, -nsl, -null, -static, or -user. Multiple -m options enable the use of multiple maps. In the absence of a -m option, automount attempts to find maps in Open Directory.

-mnt

Like -a, but specific to a single map.

-s

Supposedly creates all mounts at startup, and never unmounts them. However, mounts are still attempted only upon access when using this option, at which point automount prints a bus error and dumps core.

-tcp

Attempts to mount NFS volumes over TCP, instead of the default UDP.

-tl

Specifies a time-to-live (TTL) value for mount names, in seconds. After the timeout expires, mounts are rechecked. A timeout of 0 sets an infinite TTL. The default TTL is 10000.

-tm

Specifies a timeout to retry failing mounts, in seconds. The timeout roughly doubles with each mount attempt, until giving up after a few tries. The default timeout is 20.

-V

Prints version number and host information to standard output.

Location

/usr/ sbin


CCLEngine
CCLEngine  -l integer -f filename -s { 0 | 1 } -e { 0 | 1 } -c { 0 | 1 } -p
{ 0 | 1 } -d { 0 | 1 } -m { 0 | 1 | 2 } [-v] [-E] -S octal_integer -I string
-i URL -C string -T phone_num -U username -P password

Description

Parses a modem script and initiates a PPP dialout. When a PPP connection is attempted, pppd starts up, parses /Library/Preferences/SystemConfiguration/preferences.plist, and calls CCLEngine with the appropriate arguments.

Options/Usage

-c

If set to 1, enables Van Jacobson TCP/IP header compression. This option is the opposite of the novj option to pppd, and is obtained from the IPCPCompressionVJ parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-C

If the modem script asks for input, this option provides the label for the alternate button (i.e., the one that's not labeled "OK") on the dialog that pops up. Normally this option is set to "Cancel".

-d

If set to 1, starts dialing the modem without waiting for a dial tone. This option corresponds to the modemdialmode option to pppd, and is obtained from the DialMode parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-e

If set to 1, enables compression and error correction in the modem. This option corresponds to the modemcompress and modemreliable options to pppd, and is obtained from the ErrorCorrection parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-E

Prints output to standard error.

-f

Provides the name of a modem script, normally in /System/Library/Modem Scripts/. This option corresponds to the modemscript option to pppd, and is obtained from the ConnectionScript parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-i

If the modem script asks for input, this option provides a URL for the pop-up dialog icon. This URL is usually file://localhost/System/Library/Extensions/PPPSerial.ppp/Contents/Resources/NetworkConnect.icns.

-I

If the modem script asks for input, this option provides the title for the dialog that pops up. Normally the title is set to "Internet Connect".

-l

Specifies the service ID for the network configuration to use from /Library/Preferences/SystemConfiguration/preferences.plist. This option corresponds to the serviceid option to pppd.

-m

Determines whether the modem should try to connect (0), disconnect (1), or be set up to answer calls (2).

-p

If set to 1, the modem uses pulse dialing. This option corresponds to the modempulse and modemtone options to pppd, and is obtained from the PulseDial parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-P

Specifies the password for PPP authentication.

-s

If set to 1, enables sound output from the modem through the computer speakers. This option corresponds to the modemsound option to pppd, and is obtained from the Speaker parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-S

Specifies the syslog priority level and facility to use for logging errors. The argument is an octal integer which serves as the first argument to a syslog system call, as described in the syslog manpage and in /usr/include/sys/syslog.h. The low-order digit specifies priority level from 0 (emerg) to 7 (debug), while the higher-order digits specify facility. The default value is 150, which logs to the remoteauth facility at emerg level.

-T

Specifies the telephone number to dial. This option corresponds to the remoteaddress and altremoteaddress options in pppd, and is obtained from the CommRemoteAddress and CommAlternateRemoteAddress parameters in /Library/Preferences/SystemConfiguration/preferences.plist.

-U

Specifies the username to use for PPP authentication. This option corresponds to the user option to pppd, and is obtained from the AuthName parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

-v

If set to 1, enables verbose logging to /tmp/ppp.log. This option is taken from the VerboseLogging parameter in /Library/Preferences/SystemConfiguration/preferences.plist.

Location

/usr/libexec


cd9660.util
cd9660.util { -m | -M } device mount_point

cd9660.util { -p | -u } device

Description

Mounts ISO-9660 (CD-ROM) filesystems into the directory hierarchy.

Options/Usage

-m

Mounts the device.

-M

Attempts to force the mount.

-p

Probes the device, and prints the volume name to standard output.

-u

Unmounts the device. This function doesn't appear to work.

device

The CD device filename, e.g., disk1s2.

mount_point

The directory on which the CD filesystem is mounted.

Location

/System/Library/Filesystems/cd9660.fs


certtool
certtool { v | d | D } filename [h] [v] [d]

certtool y [h] [v] [k=keychain [c [p=password]]]

certtool c [h] [v] [a] [k=keychain [c [p=password]]]

certtool { r | I } filename [h] [v] [d] [a] [k=keychain [c [p=password]]]

certtool i filename [h] [v] [d] [a] [k=keychain [c [p=password]]]
[r=filename [f={ 1 | 8 | f }]]

Description

Manages X.509 SSL/TLS certificates. It uses the Common Data Security Architecture (CDSA) in much the same way that /System/Library/OpenSSL/misc/CA.pl uses OpenSSL to ease the process of managing certificates.

As arguments, it takes a single-letter command, often followed by a filename, and possibly some options.

Options/Usage

a

When adding an item to a keychain, this option creates a key pair and includes a private key with a more restrictive ACL than usual. (The default behavior creates a private key with no additional access restrictions, while specifying this option adds a confirmation requirement to access the private key which only certtool is allowed to bypass.)

c

As a command, walks you through a series of interactive prompts to create a certificate and a public/private key pair to sign and possibly encrypt it. The resulting certificate (in DER format) is stored in your default keychain. (Note that the first prompt, for a key and certificate label, is asking for two space-separated items. Common choices are an organization name for the key, and a label designating the purpose of the certificate.)

As an option, instructs certtool to create a new keychain by the name given in the k option.

d

As a command, displays the certificate contained in filename.

As an option, indicates that the format of the CSR or CRL contained in filename is DER (a binary format), instead of the default PEM (an ASCII format, which is essentially a DER certificate with Base64 encoding).

D

Displays the certificate revocation list (CRL) contained in filename.

f

Specifies the format of the private key in the file specified with the r option. A single character specifies the format: 1 (for OpenSSL's PKCS1, the default), 8 (PKCS8), or f (FIPS186, or BSAFE).

h

Prints a usage statement to standard output, negating whichever command was given.

i

Imports the certificate contained in filename into the default keychain.

I

Imports the CRL contained in filename into the default keychain.

k

Specifies the name of a keychain (in ~/Library/Keychains) to use other than the default.

p

Specifies the keychain password on the command line. To avoid password exposure, it's better to let certtool prompt for it.

r

As a command, walks you through a series of interactive prompts to create a certificate-signing request (CSR) and a public/private key pair to sign and possibly encrypt it. The resulting CSR is stored in filename.

As an option, specifies the file containing a private key for the certificate being imported. This is useful if you've used OpenSSL to generate a certificate, instead of certtool.

v

As a command, verifies the CSR contained in filename.

As an option, should enable verbose output, but it doesn't actually seem to make a difference.

y

As a command, displays the certificates and CRLs in the specified keychain.

Location

/usr/bin


checkgid
checkgid group_name...

Description

Checks for the existence of the specified groups. If all groups exist, the return value is 0 and nothing is printed. If any groups do not exist, the return value is 255 and the following is printed to standard error for each nonexistent group_name:

checkgid: group 'group_name' not found

checkgid should be run with superuser privileges.

This tool is part of the Apache distribution.

Options/Usage

group_name

Takes a list of group names as arguments. It should also be able to take numeric group IDs as #groupID, but checkgid always returns successful for arguments of that form.

Location

/usr/bin


chkpasswd
chkpasswd [-c] [-i infosystem] [-l location] [username]

Description

Useful for scripts, chkpasswd prompts for a password, which is then compared against the appropriate directory service for the user specified. If the password is correct, chkpasswd returns 0; otherwise, it returns 1 and the string Sorry is printed to standard error.

Options/Usage

-c

Compares user input with the password hash directly, rather than running it through the crypt algorithm first.

-i

Specifies the directory service to use, which may be file, netinfo, nis, or opendirectory.

-l

Depending on the directory service being used, it's a file (the default is /etc/master.passwd), a NetInfo domain or server/tag combo, a NIS domain, or an Open Directory node (like /NetInfo/root).

username

Designates whose password will be checked. It defaults to that of the user running the command.

Location

/usr/libexec


configd
configd [-b] [-B bundle_ID] [-d] [-t pathname] [-v] [-V bundle_ID]

Description

The System Configuration Server, which monitors changes to network-related items such as link status, DHCP assignments, PPP connections, and IP configuration, and provides an API for applications to be notified of these changes. To monitor various items, it uses a set of plug-in configuration agents, including the Preferences Monitor, the Kernel Event Monitor, the PPP Controller Agent, the IP Configuration Agent, and the IP Monitor Agent. The agent plug-ins are located in /System/Library/SystemConfiguration/. More information on the System Configuration framework can be found at http://developer.apple.com/techpubs/macosx/Networking/SysConfigOverview926/.

It's started as a bootstrap daemon, from /etc/mach_init.d/configd.plist (processed by register_mach_bootstrap_servers). When running in daemon mode, configd stores its process ID in /var/run/configd.pid.

Options/Usage

-b

Disables loading of all agents.

-B

Disables loading of the specified agent.

-d

Runs the process in the foreground, preventing daemonization.

-t

Loads the agent specified by pathname.

-v

Enables verbose logging.

-V

Enables verbose logging for the specified agent.

Location

/usr/sbin


CpMac
CpMac [-mac] [-p] [-r] source_path [source_path...] dest_path

Description

Copies files, keeping multiple forks and HFS attributes intact.

Options/Usage

-mac

Arguments use legacy Mac OS pathname syntax (i.e., colons as path separators, paths as viewed from the Finder).

-p

Preserves file attributes.

-r

Recursively copies directory contents.

Location

/Developer/Tools


create_nidb
create_nidb [tag [master_hostname [root_dir]]

Description

A Perl script that creates and populates an Open Directory database from the contents of flat files in /etc/. This may be especially useful if you have configuration information you wish to carry over from another Unix system. Currently create_nidb makes use of the following files:

/etc/master.passwd
/etc/group
/etc/hosts
/etc/networks

create_nidb should be run with superuser privileges.

Options/Usage

master_hostname

The name of the host serving the master copy of the Open Directory database. The default is localhost if the tag is local; otherwise, it's the hostname of the system on which create_nidb is run.

root_dir

The directory in which var/db/netinfo/tag.nidb will be created. The default is /.

tag

The tag of the Open Directory database. The default is local.

Location

/usr/libexec


DirectoryService
DirectoryService [-h | -v]

DirectoryService [-appledebug | -appleframework | -applenodaemon |
-appleoptions | -appleperformance | -appleversion]

Description

The server process for the Directory Service framework. It's started as a bootstrap daemon, from /etc/mach_init.d/DirectoryService.plist (processed by register_mach_bootstrap_servers).

The manpage for DirectoryService on Panther is very good, but this entry details the additional -apple options.

Options/Usage

-appledebug

Runs the service in debug mode, disabling daemonization, and logging to /Library/Logs/DirectoryService/DirectoryService.debug.log.

-appleoptions

Prints a usage statement for the second form of command invocation to standard output.

-appleperformance

Runs the service in the foreground and logs extensively.

-appleversion

Prints software build version to standard output.

-h

Prints a usage statement for the first form of command invocation to standard output.

-v

Prints software release version to standard output.

Location

/usr/sbin


disktool
disktool [-l | -r | -x | -y]

disktool [-d | -e | -g | -m | -p | -u | -A | -D | -S] device

disktool -s device integer_flag

disktool -n device vol_name

disktool -a device vol_name vol_flags

disktool -c userID

Description

Controls disks, including mounting, unmounting, ejecting, enabling permissions, and volume naming. Most options require a device name argument (e.g., disk0), and some require additional parameters.

Options/Usage

-a

Adds disk to Disk Arbitration tables, to notify applications of a mounted volume. This is useful if you have forced a mount, thus bypassing standard notification.

-A

Activates permissions on the volume, adding an entry to /var/db/volinfo.database if one does not already exist.

-c

Specifies user ID of account to use when mounting disks.

-d

Removes disk from Disk Arbitration tables, to notify applications of a dismount. This is useful if you have forced a dismount, thus bypassing standard notification.

-D

Deactivates permissions on the volume.

-e

Ejects disk.

-g

Prints HFS encoding on a volume to standard output.

-l

Lists disk volumes to standard output.

-m

Mounts disk.

-n

Gives the device a new volume name. For HFS, HFS+, and UFS partitions only.

-p

Unmounts partition. Device name is that of a partition (e.g., disk0s5).

-r

Refreshes Disk Arbitration tables.

-s

Sets HFS encoding on a volume. Takes encoding as additional integer argument.

-S

Prints status of volume in /var/db/volinfo.database to standard output.

-u

Unmounts disk.

-x

Disallows dismounts and ejects.

-y

Allows dismounts and ejects.

Location

/usr/sbin


fixmount
fixmount [-q] [-a | -d | -e] [-v [-h hostname_or_IP] | -r | -A] [-f]
nfs_server...

Description

Communicates with the NFS mount daemon, mountd, to remove invalid records of client mounts from the NFS server. fixmount is run from the client, and when called without flags, prints the client's IP address to standard output if the server has a record of NFS mounts from the client.

mountd maintains records of which clients have mounted exports from the server, and writes the records to a file so that this information is retained through process or system restarts. (On most Unix platforms, this file is /etc/rmtab; on Mac OS X, it's /var/db/mountdtab.) Over time, this file accumulates a lot of outdated information, primarily due to clients rebooting or otherwise dropping their mounts without properly informing the server, or changing their hostnames.

The primary purpose of fixmount is to clear bogus entries from the file kept by mountd. On most Unix systems, it does this by comparing the current set of mounts on the client (as listed in /etc/mtab) to the server's list of mounts from the client, and asking the server's mountd to remove any entries that don't match up.

However, a Mac OS X system keeps a current list of mounts in the kernel, and doesn't use /etc/mtab. Therefore, when fixmount checks this file and finds it empty (or nonexistent), it perceives all of the server's entries as bogus—even those that do match up to current mounts on the client. This makes fixmount, at least as currently implemented, of very limited utility on Mac OS X.

Options/Usage

-a

Lists mounts from the client in the form IP_addr:pathname. This option is similar to showmount -a, but limited to providing information about the client on which fixmount is run.

-A

Removes all of the entries for the client from the server's /var/db/mountdtab.

-d

Lists exports that are mounted on the client, instead of the client's IP address. This option is similar to showmount -d, but limited to providing information about the client on which fixmount is run.

-e

Prints the server's list of NFS exports to standard output. This option is the same as showmount -e.

-f

Forces all entries for the client to be interpreted as bogus. This option makes -f -r equivalent to -A. On a Mac OS X client, it's as if this flag is always set.

-h

Communicates with the server's mountd as if the client's hostname or IP address were that given by the argument to this option. This option is useful when the client has changed its hostname or IP address, but the server retains invalid entries with the old information.

-q

Minimizes output from error messages.

-r

Removes bogus entries for the client from the server's /var/db/mountdtab.

-v

Runs the verification procedure to determine the list of bogus entries for the client (which is printed to standard output), but doesn't actually remove anything from the server's /var/db/mountdtab.

Location

/usr/sbin


fixPrecomps
fixPrecomps -help

fixPrecomps [-checkOnly] [-force] [-relroot directory] [-all |
-precompsList filename] [-precomps filename...] [-find_all_precomps] [-gcc2 |
-gcc3all] [-skipIfMissing] [-output directory] [-precompFlags flag...]

Description

Compiles header files to improve performance for programs including them. When invoked without arguments, fixPrecomps reads any files in /System/Library/SystemResources/PrecompLists/ in alphanumeric order by filename. Normally this includes phase1.precompList and phase2.precompList. These files are expected to consist of lists of precompiled header filenames to generate. fixPrecomps then runs cc -precomp on the ordinary header files where the precompiled headers are either out-of-date (i.e., have modification times less recent than the ordinary headers) or nonexistent.

The headers listed in the precompList files have filename extensions of either .p or .pp. fixPrecomps finds ordinary headers with the same base filenames but extensions of .h. The .p headers are compiled with GCC Version 2 for use with C and Objective-C programs, while the .pp headers are compiled with GCC Version 2 for C++ and Objective-C++ programs. By default, fixPrecomps compiles headers with GCC Version 3, in which case C/Objective-C precompiled header filenames end in -gcc3.p, and C++/Objective-C++ precompiled header filenames end in -gcc3.pp.

Options/Usage

-all

Uses all files contained in /System/Library/SystemResources/PrecompLists/. This is the default.

-checkOnly

For each header file listed in the precompList files, prints a status message to standard output indicating whether the precompiled header exists and is up-to-date with the ordinary header.

-find_all_precomps

Requires specification of -all, -precompList or -precomps, but otherwise doesn't appear to do anything.

-force

Produces precompiled headers even if they're up-to-date. Using this flag causes the -checkOnly flag to be ignored.

-gcc2

Applies the command to GCC Version 2 C/Objective-C (.p) and C++/Objective-C++ (.pp) precompiled headers.

-gcc3all

Applies the command to GCC Version 3 C++/Objective-C++ (-gcc3.pp) precompiled headers, as well as to those for C/Objective-C (-gcc3.p).

-help

Prints a usage statement to standard error.

-output

Checks for and creates precompiled headers in locations relative to the specified directory. Intermediate directories must already exist, or compilation will fail.

-precompFlags

Specifies additional cc command-line flags to use when compiling headers.

-precompList

Uses only the precompList files specified.

-precomps

Specifies a list of precompiled headers to check or create.

-relroot

Looks for System/Library/SystemResources/PrecompLists/ relative to the specified directory. The default is /.

-skipIfMissing

Compiles precompiled headers if they're out-of-date, but not if they don't exist. Using this flag causes the -checkOnly flag to be ignored.

Location

/usr/bin


FixupResourceForks
FixupResourceForks [-nodelete] [-nosetinfo] [-q[uiet]] pathname...

Description

Recombines the resource fork and HFS metadata split out into a separate file (named ._filename) with the file's data fork (in a file named filename), resulting in a single multi-forked file (named filename) with HFS attributes. As such, this option works only on HFS and HFS+ volumes. It reverses the effect of running SplitForks.

FixupResourceForks does a recursive descent into the directory specified by pathname, working on every file within it.

Options/Usage

-nodelete

Prevents deletion of ._filename after recombination with filename.

-nosetinfo

Disables setting of HFS attributes on the recombined files.

-quiet

Suppresses printing the name of each recombined file to standard output.

Location

/System/Library/CoreServices


gcc_select
gcc_select [-v | --version] [-h | --help] [-l | --list]

gcc_select [-v | --version] [-n] [-force] [-root] [-dstroot pathname] { 2 |
3 | 3.x }

Description

A shell script that sets the default version of GCC (either 2.95.2 (2), 3.1 (3), or some other version (specified as 3.x)) by creating various symlinks for compiler tools, libraries, and headers. With no arguments (or with just -v), the current default version is printed to standard output.

Options/Usage

-dstroot

Specifies the root-level directory where changes are made. The default is /usr.

-force

Recreates symlinks for the specified version, even if it is already the current default version.

-h | --help

Prints a usage statement to standard output.

-l | --list

Lists available GCC versions.

-n

Prints the list of commands that would be executed to standard output, but does not actually execute them.

-root

Disables the initial check for root access before executing commands.

-v | --version

Prints the version of gcc_select to standard output.

Location

/usr/sbin


hfs.util
hfs.util { -m | -M } device mount_point { fixed | removable }
{ readonly | writable } { suid | nosuid } { dev | nodev }

hfs.util -p device { fixed | removable } { readonly | writable }

hfs.util { -a | -k | -s | -u } device

hfs.util { -J | -U | -I } mount_point

Description

Mounts HFS and HFS+ filesystems into the directory hierarchy.

Options/Usage

-a

Enables (adopts) permissions on the volume, creating an entry for it in /var/db/volinfo.database if one does not already exist. Unlike disktool -A or vsdbutil -a, this option functions only on an unmounted volume.

-I

Prints information about the journal file to standard output.

-J

Enables journaling on the volume.

-k

Reads the disk's UUID key and prints it to standard output. Functions only on an unmounted volume.

-m

Mounts the device.

-M

Attempts to force the mount.

-p

Probes the device, and prints the volume name to standard output.

-s

Generates a new disk UUID key and sets it on the volume. Functions only on an unmounted volume.

-u

Unmounts the device. This function doesn't appear to work.

-U

Disables journaling on the volume.

device

The disk device filename, e.g., disk0s5.

mount_point

The directory on which the filesystem is mounted.

Location

/System/Library/Filesystems/hfs.fs


hostinfo
hostinfo

Description

Prints basic information about the system to standard output, including Darwin version number, number and types of processors, amount of physical memory, current number of Mach tasks and threads running in the kernel, and CPU load.

Example

% hostinfo
Mach kernel version:
         Darwin Kernel Version 7.0.0:
Wed Sep 17 20:12:58 PDT 2003; root:xnu/xnu-510.obj~1/RELEASE_PPC

Kernel configured for a single processor only.
1 processor is physically available.
Processor type: ppc750 (PowerPC 750)
Processor active: 0
Primary memory available: 320.00 megabytes.
Default processor set: 51 tasks, 114 threads, 1 processors
Load average: 0.18, Mach factor: 0.89

Location

/usr/bin


hwprefs
hwprefs [-h]

hwprefs [-v] parameter[=value] [parameter[=value]]...

Description

Prints some information about the system to standard output. This option is installed as part of the Computer Hardware Understanding Development (CHUD) set of developer tools.

Options/Usage

-h

Prints a usage statement to standard error.

-v

Prints information verbosely.

parameter

One of the following: cpus reports the number of CPUs (either 1 or 2), cpunap reports whether the CPU may slow down to conserve energy (either 0 or 1), hwprefetch reports the number of prefetch engines used by a G5 CPU (either 4 or 8), and ostype reports the code name for the system's OS: Cheetah (Mac OS X 10.0), Puma (10.1), Jaguar (10.2), Smeagol (10.2.7), or Panther (10.3).

Location

/usr/bin


ipconfig
ipconfig getifaddr interface

ipconfig getoption { interface | "" } { option_name | option_code }

ipconfig getpacket interface

ipconfig ifcount

ipconfig set interface { BOOTP | DHCP }

ipconfig set interface { INFORM | MANUAL } IP_addr netmask

ipconfig waitall

Description

Interacts with the IP Configuration Agent of configd to manage network configuration changes.

Options/Usage

getifaddr

Prints the specified network interface's IP address to standard output.

getoption

Prints the value of the specified DHCP option to standard output. If interface is specified, the option is interface-specific. If empty quotes are used instead, the option is global. Option names and numeric codes are DHCP-standard (such as host_name, domain_name, netinfo_server_address, etc.).

getpacket

Prints DHCP transaction packets to standard output.

ifcount

Prints the number of network interfaces to standard output.

set

Sets the method by which the specified network interface is assigned an IP address. Using BOOTP or DHCP causes the system to attempt to contact a server of the appropriate type to obtain IP configuration information. Using INFORM sets the IP address locally, but initiates a DHCP request to obtain additional IP configuration information (DNS servers, default gateway, etc.). Using MANUAL indicates that all IP configuration information is set locally.

waitall

Sets the configurations of all network interfaces according to the specifications in /etc/iftab.

Location

/usr/sbin


kdumpd
kdumpd [-l] [-s directory [-u username] [-c | -C]] [-n] [directory]

Description

Provides a service meant to accept transfers of kernel core dumps from remote Mac OS X clients. Based on tftpd, kdumpd offers a simplistic file drop service. Setting it up involves:

  • Adding a kdump entry to /etc/services, recommended on UDP port 1069.

  • Creating a kdump service file in /etc/xinetd.d/, modeled after that for tftp.

  • Executing sudo service kdump start.

Once that's done, you can invoke tftp on a client system, enter connect server_name 1069, and use put filename to transfer a file. The file will be saved on the server in the directory specified in the arguments to kdumpd. There are restrictions: the filename cannot include / or .., so the target file will be deposited into the target directory only and must not already exist.

This service is apparently not used by any current facility, but may exist for future use by Apple.

Options/Usage

-c

Same as -C. Using this option should reject the connection if the path including the client IP address doesn't exist, but a bug prevents it from doing this.

-C

Adds the client's IP address to the end of the chroot directory path. If this path doesn't already exist, it falls back to the one specified for -s.

-l

Enables logging via syslog using the ftp facility. However, logging is enabled by default, so this option doesn't actually do anything.

-n

Suppresses a negative acknowledgment if the client requests a relative pathname that doesn't exist.

-s

Performs a chroot to the specified directory.

-u

Changes user ID to the specified username. Defaults to nobody.

Location

/usr/libexec


kuncd
kuncd [-d]

Description

The Kernel-User Notification Center server, which handles communication to users from kernel processes. kuncd is started as a bootstrap daemon from /etc/mach_init.d/kuncd.plist (processed by register_mach_bootstrap_servers). For more information, check out http://developer.apple.com/documentation/DeviceDrivers/Conceptual/WritingDeviceDriver/KernelUserNotification/.

Options/Usage

-d

Enables debugging output.

Location

/usr/sbin


languagesetup
languagesetup -h

languagesetup -langspec language

languagesetup [-English | -Localized]

Description

Changes the default language used by the system. If invoked with no arguments, or with the -English or -Localized flags, languagesetup enters an interactive session in which the new language may be chosen from a menu.

Options/Usage

-English

Presents interactive prompts in English.

-h

Prints a usage statement to standard output.

-langspec

Specifies the new system language on the command line, instead of interactively.

-Localized

Presents interactive prompts in the system's default language.

Location

/usr/sbin


makekey
makekey

Description

Produces crypt password hashes. This command could be used to automatically populate a password database from known passwords, or to make hashes of prospective passwords that could be subjected to cracking attempts before being put into use.

Options/Usage

makekey takes no command-line arguments. It accepts a character string on standard input, consisting of an eight-character password combined with a two-character salt, which is used to permute the DES password encryption algorithm. (Use man crypt for more information.) It prints a thirteen-character string to standard output, with the first two characters being the salt, and the other eleven characters being the password hash. The entire string is suitable for use as the password field in a standard Unix /etc/passwd-format file, or as the value of the passwd property in an Open Directory entry for a user employing Basic authentication.

Example

% echo password12 | /usr/libexec/makekey
12CsGd8FRcMSM

Location

/usr/libexec


mDNS
mDNS [-E | -F | -A | -U | -N | -T | -M]

mDNS -B type domain

mDNS -L service_name _app_protocol._transport_protocol domain

mDNS -R service_name _app_protocol._transport_protocol domain port
[string] . . .

Description

A basic client for Rendezvous multicast DNS (mDNS), primarily used for testing local mDNS service. When invoked with no arguments, it prints a usage statement to standard error. In most instances, the command doesn't return on its own, so you'll need to use Ctrl-C to break out.

When registering or looking up a name like website._http._tcp.local., website is the service_name, http is the app_protocol, tcp is the transport_protocol, and local is the domain. For example, to register such a service:

% mDNS -R website _http._tcp local 80 "my web site"

Options/Usage

-A

Tests mDNS by repeatedly adding, updating, and then deleting an HINFO resource record for Test._testupdate._tcp.local..

-B

Browses for services (although this doesn't seem to work).

-E

Discovers and lists domains recommended for registration of services.

-F

Discovers and lists domains recommended for browsing of services.

-L

Looks up a service, displaying its host address, port number, and TXT records if found.

-M

Tests mDNS by registering a service (Test._testdualtxt._tcp.local.) with multiple TXT resource records.

-N

Tests mDNS by registering a service (Test._testupdate._tcp.local.) with a large NULL resource record.

-R

Registers a service.

-T

Tests mDNS by registering a service (Test._testlargetxt._tcp.local.) with a large TXT resource record.

-U

Tests mDNS by repeatedly updating a TXT resource record for Test._testupdate._tcp.local..

Location

/usr/bin


mDNSResponder
mDNSResponder [-d]

Description

The server for Rendezvous multicast DNS (mDNS). mDNSResponder is started by the mDNSResponder startup item, creates a PID file in /var/run/, and responds to TERM and INT signals by quitting cleanly.

Options/Usage

-d

Runs in debug mode, preventing daemonization, although it doesn't appear to be particularly useful in this state.

Location

/usr/sbin


mount_devfs
mount_devfs [-o mount_options] devfs mount_point

Description

Mounts the devfs filesystem in /dev, where block and character device special files exist.

Options/Usage

-o

Takes -o options as listed in the mount manpage. Not normally used for mount_devfs.

mount_point

The directory on which the filesystem will be mounted, normally /dev.

Location

/sbin


mount_ftp
mount_ftp [-o mount_options] [ftp://][username:password@]ftp_server:port_
num[/pathname] mount_point

Description

Mounts FTP archives as filesystem volumes.

Options/Usage

-o

Takes -o options as listed in the mount manpage.

username

The login name to use with an FTP server that requires authentication.

password

The password to use with an FTP server that requires authentication. Note that specifying this option on the command line exposes the password in a process listing.

ftp_server

The hostname or IP address of an FTP server.

port_num

The port number on which the server offers FTP service.

pathname

The path to the directory you wish to access on the FTP server, relative to the site's default FTP root directory (e.g., /Library/FTPServer/FTPRoot on Mac OS X Server). Defaults to /.

mount_point

The directory on which the filesystem will be mounted. It must be an absolute pathname.

Location

/sbin


mount_smbfs
mount_smbfs { -h | -v }

mount_smbfs [-u username_or_ID] [-g groupname_or_ID] [-f mode] [-d mode]
[-I hostname_or_IP] [-n long] [-N] [-U username] [-W workgroup_name]
[-O c_user[:c_group]/s_user[:s_group]] [-M c_mode[/s_mode]] [-R num_retries]
[-T timeout]  [-o mount_options] [-x max_mounts] //[workgroup;][username[:
password]@]smb_server[/share_name] mount_point

Description

Mounts Server Message Block (SMB) shares as filesystem volumes. It takes a share UNC and a mount point as arguments.

mount_smbfs can make use of the same configuration files used by smbutil: either .nsmbrc in the user's home directory, or the global /usr/local/etc/nsmb.conf, which overrides per-user files. The following example .nsmbrc demonstrates some of the parameters available:

[default]
username=leonvs
# NetBIOS name server
nbns=192.168.1.3

[VAMANA]
# server IP address
addr=192.168.1.6
workgroup=TEST

[VAMANA:LEONVS]
password= $$178465324253e0c07

The file consists of sections, each with a heading in brackets. Besides the [default] section, headings have a server name to which the parameters in the section apply, and can also include a username and a share name.

Sections of the configuration file may not be read properly unless the hostnames and usernames in the section headings are rendered in uppercase characters.

All sections and parameter definitions in .nsmbrc are optional; everything can be specified right on the mount_smbfs command line. This option may come in handy for providing passwords for automated connections, when prompting for a password (which is the most secure method of providing it) is impractical. The value of the password parameter can be a cleartext password, but it's derived from the output of smbutil crypt password in this example. While this is better than cleartext, don't trust the encryption too much, as it's fairly weak. Make sure you restrict permissions on .nsmbrc to prevent anyone from reading your passwords.

Options/Usage

-d

Specifies directory permissions on the mounted volume, which default to the same as file permissions, plus an execute bit whenever a read bit is set. The argument is an octal mode, as described in the chmod manpage.

-f

Specifies file permissions on the mounted volume, which default to the same as those set on the mount point. The argument is an octal mode, as described in the chmod manpage.

-g

Specifies group ownership for files and directories on the mounted volume, which defaults to the same as that set on the mount point.

-h

Prints a brief usage statement to standard error.

-I

Avoids NetBIOS name resolution, connecting directly to the hostname or IP address specified as an argument.

-M

Assigns access rights to the SMB connection.

-n

With an argument of long, disables support for long filenames, restricting them to the "8.3" naming standard.

-N

Suppresses the prompt for a password. Unless a password is specified in a configuration file, authentication will fail for non-guest users.

-o

Takes -o options, as listed in the mount manpage.

-O

Assigns owner attributes to the SMB connection.

-R

Specifies the number of times to retry a mount attempt. The default is 4.

-T

Specifies the connection request timeout (in seconds). The default is 15.

-u

Specifies ownership for files and directories on the mounted volume, which defaults to the same as that set on the mount point.

-U

Specifies a username for authentication. This may also be part of the UNC.

-v

Prints software version to standard error.

-W

Specifies an SMB workgroup or NT domain for authentication. This may also be part of the UNC.

-x

Automatically mounts all shares from the SMB server. The argument specifies a maximum number of shares that mount_smbfs is willing to mount from a server, to forestall resource starvation when the server has a very large number of shares. If the server has more shares than max_mounts, the mount attempt is cancelled.

workgroup

The name of the SMB workgroup or NT domain to use for authentication to the SMB server.

username

The name to use for authentication to the SMB server.

password

The password to use for authentication. Note that specifying this option on the command line exposes the password in a process listing.

smb_server

The NetBIOS name of an SMB server.

share_name

The name of the SMB share you wish to access.

mount_point

The directory on which the filesystem will be mounted.

Location

/sbin


mount_synthfs
mount_synthfs [-o mount_options] synthfs mount_point

Description

Mounts a synthfs filesystem, which is a simple mapping of memory into the filesystem hierarchy (i.e., the contents of a synthfs filesystem are contained in memory). While creation of files in the filesystem is prevented (in fact, you may cause the system to hang after attempting to create files), directory hierarchies are allowed. This option could be used to set up transient mount points for other volumes on, for example, read-only media with a shortage of spare directories to serve as mount points (such as an installation CD).

Options/Usage

-o

Takes -o options as listed in the mount manpage.

mount_point

The directory on which the filesystem will be mounted.

Location

/sbin


mount_volfs
mount_volfs [-o mount_options] mount_point

Description

Mounts the volfs filesystem in /.vol. The volfs filesystem enables the Carbon File Manager API to map a file ID to a file, without knowing the BSD path to it. Thus, HFS aliases, which use file IDs, remain consistent, even if the targets of the aliases move around within the volume.

The /.vol directory contains subdirectories named with numeric IDs, each associated with a volume on the system. While the directories appear empty if listed, with a file or directory ID one can access any object on those volumes. A file ID is a unique number associated with each file on a volume (analogous to an inode number on a UFS-formatted filesystem), and can be viewed with the -i option of ls.

If you know a file's ID, you can access it as /.vol/vol_ID/file_ID. If you know the ID of the directory the file is in, you can also access it as /.vol/vol_ID/dir_ID/filename. The root directory of a volume always has a directory ID of 2, so you can map volume IDs to volumes with:

% cd /.vol/ vol_ID /2; pwd

Options/Usage

-o

Takes -o options as listed in the mount manpage. Not normally used for mount_volfs.

mount_point

The directory on which the filesystem will be mounted, normally /.vol.

Location

/sbin


msdos.util
msdos.util -m device mount_point { fixed | removable }
{ readonly | writable } { suid | nosuid } { dev | nodev }

msdos.util -p device { fixed | removable } { readonly | writable }

msdos.util -u device

msdos.util -n device name

Description

Mounts FAT (MS-DOS) filesystems into the directory hierarchy.

Options/Usage

-m

Mounts the device.

-n

Resets the volume name of the device. This function doesn't appear to work.

-p

Probes the device, and prints the volume name to standard output.

-u

Unmounts the device. This function doesn't appear to work.

device

The disk device filename, e.g., disk0s5.

mount_point

The directory on which the filesystem is mounted.

Location

/System/Library/Filesystems/msdos.fs


notifyd
notifyd [-no_restart] [-no_startup] [-shm_pages integer]

Description

The notification server for the API described in the notify(3) manpage. (Use man 3 notify to display this page.) Using the API, processes may post notifications associated with arbitrary names, and other processes can register to be informed of such notification events. (A name should follow the convention used for Java classes: the reversed DNS domain name associated with the responsible organization, followed by one or more segments; for example, com.apple.system.timezone.) notifyd sets up the shared memory used for the notify_register_check call, and directly answers notify_check requests for other notification methods (signal, Mach port, and file descriptor).

notifyd also reads a configuration file, /etc/notify.conf. Each line begins with one of two keywords: reserve or monitor. The reserve keyword lays out access restrictions for portions of the namespace. The arguments are a name, a user and a group that "owns" the name, and a set of read /write permissions for the user, the group, and others, similar to those applied to files. For example, the following line:

reserve com.apple.system. 0 0 rwr-r-

states that any names starting with com.apple.system. are owned by UID 0 (root) and GID 0 (wheel), and that anyone can receive notifications for these names, but only root (the owner) can post notifications.

The monitor keyword takes a name and a filename as arguments. When the specified file is changed, a notification is posted for the name. For example, the following line from the stock /etc/notify.conf can be used by processes wishing to keep track of time zone changes:

monitor com.apple.system.timezone /etc/localtime

Another use would be to monitor changes to a daemon's configuration file. When the file is changed, the daemon or another process could receive notification and cause the daemon to automatically reread the configuration.

notifyd is started as a bootstrap daemon, from /etc/mach_init.d/notifyd.plist (processed by register_mach_bootstrap_servers). It responds to HUP or TERM signals by restarting (unless the -no_restart flag was used), thus rereading /etc/notify.conf. Before notifyd exits, it sends notifications for all registered names; after it restarts, processes registered for notifications must register again, as their tokens become invalid.

Options/Usage

-no_restart

Disables automatic restart. Normally, if notifyd is killed, it's restarted within a few seconds.

-no_startup

Apparently prevents notifyd from issuing notifications, while using all available CPU time. The purpose of this option is unknown.

-shm_pages

Specifies the number of pages (i.e., units of 4096 bytes) to reserve for shared memory (although it appears to use about twice that). Defaults to 1.

Location

/usr/sbin


ntp-wait
ntp-wait [-v] [-f] [-n num_tries] [-s time]

Description

A Perl script that reports whether the local ntpd has synchronized yet. Returns 0 if synchronized; 1 if not.

Options/Usage

-f

Causes ntp-wait to return 1 if an indeterminate result is received from ntpd; otherwise, ntp-wait returns 0.

-n

Specifies the number of times to try for a successful result before quitting. Defaults to 1000.

-s

Specifies the number of seconds between tries. Defaults to 6.

-v

Enables verbose output to standard output.

Location

/usr/bin


ntptimeset
ntptimeset [-l] [-d]... [-v] [-s] [-c filename] [-u] [-S integer]
[-V integer] [-t timeout] [-H] [-a key_id] [-e delay]

Description

Synchronizes the system clock in a manner similar to ntpdate, but in a way that attempts to compensate for current, possibly degraded, network conditions.

Options/Usage

-a

Enables secure authentication with the key specified by the given identifier.

-c

Specifies the location of the configuration file. Defaults to /etc/ntp.conf.

-d

Enables debugging output.

-e

Specifies the delay, in seconds, caused by authentication. Normally this value is negligible.

-H

Simulates poor network conditions by dropping a proportion of network packets.

-l

Enables logging to syslog.

-s

Sets the system clock. Otherwise, ntptimeset merely reports the clock's offset.

-S

Specifies a minimum number of servers that must respond. Defaults to 3.

-t

Specifies time, in seconds, spent waiting for a server response. Defaults to 1.

-u

Uses an unprivileged client port.

-v

Enables verbose output.

-V

Specifies a minimum number of servers that must respond with a valid time. Defaults to 1.

Location

/usr/sbin


od
od [-c] [-a] [-b] [-B] [-o] [-O] [-d] [-D] [-i] [-I] [-l] [-L] [-f] [-e]
[-F] [-h] [-x] [-H] [-X] [-v] [filename]

Description

Prints the contents of a file to standard output in a variety of formats. (If no filename is specified, it acts on the contents of standard input.) The name is an acronym for octal dump, from its default behavior of displaying files as series of octal numbers.

od has been deprecated in favor of hexdump; in fact, the two binaries are hard-linked to the same data. However, traditional od syntax applies when invoked by that name. See the hexdump manpage for more.

Options/Usage

-a

Displays content in 1-byte chunks of ASCII characters, hexadecimal numbers, and short strings representing control characters.

-b

Displays content in 1-byte chunks of octal numbers.

-B

Displays content in 2-byte chunks of octal numbers. This option is the default.

-c

Displays content in 1-byte chunks of ASCII characters, octal numbers, and escape sequences representing control characters. This is probably the most commonly used option.

-d

Displays content in 2-byte chunks of unsigned decimal integers.

-D

Displays content in 4-byte chunks of unsigned decimal integers.

-e

Displays content in 8-byte chunks of decimal floating-point numbers.

-f

Displays content in 4-byte chunks of decimal floating-point numbers.

-F

Same as -e.

-h

Displays content in 2-byte chunks of hexadecimal numbers.

-H

Displays content in 4-byte chunks of hexadecimal numbers.

-i

Displays content in 2-byte chunks of signed decimal integers.

-I

Displays content in 4-byte chunks of signed decimal integers.

-l

Same as -I.

-L

Same as -I.

-o

Same as -B.

-O

Displays content in 4-byte chunks of octal numbers.

-v

Disables the suppression of duplicate lines, which are normally represented by a single asterisk.

-x

Same as -h.

-X

Same as -H.

Location

/usr/bin


opendiff
opendiff file1 file2 [-ancestor ancestor_file] [-merge merge_file]

Description

Opens the two designated files in the FileMerge application.

Options/Usage

-ancestor

Compares the two files against a common ancestor file.

-merge

Merges the two files into a new file.

Location

/usr/bin


open-x11
open-x11 app_name...

Description

Starts specified X Window System applications using the X11 application.

Options/Usage

app_name

The name of an executable X11 application. Those delivered with Mac OS X are in /usr/X11R6/bin/. If located in a standard directory, the application pathname is not required.

Location

/usr/bin


pdisk
pdisk

pdisk device { -diskSize | -isDiskPartitioned | -dump | -blockSize |
-initialize }

pdisk device { -partitionEntry | -partitionName | -partitionType |
-partitionBase | -partitionSize | -deletePartition } part_num

pdisk device { -setWritable | -setAutoMount } part_num { 0 | 1 }pdisk device

-makeBootable part_num boot_addr boot_bytes load_addr goto_addr

pdisk device -createPartition part_name part_type part_base part_size

pdisk device -splitPartition part_num part1_size part2_name part2_type

pdisk device -getPartitionOfType part_type instance_num

pdisk device -getPartitionWithName part_name instance_num

Description

Provides control over Apple partition maps on disk devices in Macintosh systems.

Options/Usage

-blockSize

Prints the block size of the specified device, in bytes, to standard output.

-createPartition

Adds a partition to the partition map with the specified name, type (such as Apple_HFS or Apple_UFS), base (i.e., starting block number), and size (in blocks).

-deletePartition

Deletes the specified partition from the partition map.

-diskSize

Prints the size of the specified device, in megabytes, to standard output.

-dump

Prints the partition map on the specified device to standard output.

-getPartitionOfType

Prints the number of a partition with the specified type to standard output. An instance_num of 0 refers to the lowest-numbered partition of the specified type, 1 refers to the second partition of that type, etc.

-getPartitionWithName

Prints the number of a partition with the specified name to standard output. An instance_num of 0 refers to the lowest-numbered partition with the specified name, 1 refers to the second partition of that name, etc.

-initialize

Creates a partition map on the device.

-isDiskPartitioned

Returns 0 if the device has an Apple partition map on it, 1 if not.

-makeBootable

Sets the startup bit on a partition. This is unused by Mac OS X.

-partitionBase

Prints the starting block number of the specified partition to standard output.

-partitionEntry

Prints a line to standard output containing the name, type, base, and size of the specified partition.

-partitionName

Prints the name of the specified partition to standard output.

-partitionSize

Prints the size of the specified partition, in blocks, to standard output.

-partitionType

Prints the type of the specified partition to standard output.

-setAutoMount

Sets (1) or clears (0) the automount bit on a partition. This option is unused by Mac OS X.

-setWritable

Sets (1) or clears (0) the writable bit on a partition.

-splitPartition

Splits an existing partition in two. The arguments include the size (in blocks) of the first partition formed from the split, and the name and type of the second partition.

device

The disk device filename, e.g., /dev/disk0.

Commands

pdisk enters interactive mode when invoked without arguments. Interactive commands that take arguments will prompt for any that are missing.

?

Displays a summary list of commands.

a

Toggles the abbreviate flag. When in abbreviate mode, partition type names are shortened. For example, Apple_HFS is displayed as HFS.

d

Toggles the debug flag. When in debug mode, some extra commands are enabled, including commands to display block contents and partition map data structures.

e device

Edits the partition map on a device.

E device

Should open a partition map for editing after prompting for a redefinition of the logical block size from the default 512 bytes, but doesn't appear to work at present.

h

Displays a summary list of commands.

l device

Displays the partition map on a device.

L

Displays the partition maps on all devices.

p

Toggles the physical flag. When in physical mode, block positions and sizes are reported according to the physical limits of the partitions, which may not be the same as their logical limits.

q

Quits interactive mode.

r

Toggles the read-only flag. When in read-only mode, changes to the partition map are disallowed.

v

Prints the version number and release date of pdisk. (The output is currently far out of date, listing a release in 1997, when it was still used for MkLinux.)

x device block_num

Displays the contents of the block given by block_num. While it always appears to produce a bus error when called at this level, the same functionality is available from an expert level while editing a map, where it does work.

Location

/usr/sbin


pdump
pdump [-v] [-s] [-h] [-p] [-d] [-d0] [-d1] [-d2] [-d3] [-d4] [-d5] [-d6]
[-st] [-i] [-e] [-x] [-if] [-t] [-o] [-k] [-m] [-class class] [-protocol
protocol] [-arch arch] [-f]

Description

Prints information about precompiled header files to standard output. See the entry for fixPrecomps for more on precompiled headers.

Options/Usage

-arch

Appears to do nothing.

-class

Lists the method declarations for the specified class.

-d

Lists all declarations.

-d0

Lists type definition declarations.

-d1

Lists class declarations.

-d2

Lists category declarations.

-d3

Lists protocol declarations.

-d4

Lists enumerated constant declarations.

-d5

Lists function declarations.

-d6

Lists variable declarations.

-e

Lists entry macros.

-f

Appears to do nothing.

-h

Lists included headers.

-i

Lists all identifiers.

-if

Lists conditional macros defined outside the precompiled header.

-k

Lists "must keeps".

-m

Lists method names and their classes.

-o

Lists preprocessed tokens.

-p

Lists paths to included headers.

-protocol

Lists the method declarations for the specified protocol.

-s

Lists bytes taken up by each of several kinds of elements in the precompiled header.

-st

Lists all strings.

-t

Lists all tags.

-v

Enables verbose output.

-x

Lists exit macros.

Location

/usr/bin


postfix-watch
postfix-watch

Description

Starts Postfix processes necessary to send email on demand. For a system that isn't providing mail service, Mac OS X runs those processes only when mail is queued for sending in /var/spool/postfix/maildrop.

postfix-watch is started by the Postfix startup item.

Location

/usr/sbin


register_mach_bootstrap_servers
register_mach_bootstrap_servers config_source

Description

Registers a Mach port with the bootstrap task of mach_init on behalf of a specified daemon. (A Mach task is analogous to a process that runs within the kernel of Mac OS X; a port is used to communicate between tasks.) When another task sends a request to the bootstrap task for access to a port, mach_init starts up the associated daemon if necessary.

This program serves as a replacement for certain startup items on Panther. Instead of launching services from /System/Library/StartupItems/ (processed by SystemStarter), files in /etc/mach_init.d/ are processed by register_mach_bootstrap_servers, which is called from /etc/rc. (Per-user services are started by the login window application, which uses register_mach_bootstrap_servers to process /etc/mach_init_per_user.d/.) One advantage of this program over startup items is that a daemon can be run only when needed, if another process needs to communicate with it, thus reducing resource consumption.

Options/Usage

config_source

Either an XML property list (.plist) file, or a directory containing such files. Each file is usually named after the associated daemon, and contains some of the following keys:

Command

The path to the server executable. This is a required key.

isKUNCServer

Specifies whether the daemon is kuncd, the Kernel-User Notification Center server, used by the kernel to communicate with users. Defaults to false.

OnDemand

Specifies whether the daemon should only be started when it first receives a request for its bootstrap port. If set to false, the daemon is started immediately. Defaults to true.

ServiceName

An identifier for the service. The name should follow the convention used for Java classes: the reversed DNS domain name associated with the responsible organization, followed by one or more segments specifically identifying the service (e.g., com.apple.DirectoryService). This is a required key.

Username

The user under which the daemon is started.

Location

/usr/libexec


screencapture
screencapture [-i [-s | -w | -W] | -m] [-x] { -c | pathname ...}

Description

Saves the contents of the screen to a PDF file or to the Clipboard. Unless using the -i option to start an interactive screen capture, the contents of the entire display are captured.

Options/Usage

-c

Saves screenshot to the Clipboard for later pasting.

-i

Initiates interactive screen capture. The mouse is used to select a region of the screen to capture. Pressing the spacebar toggles between this mouse selection mode and a window selection mode, in which clicking on a window captures the portion of the screen taken up by that window. Pressing the Control key saves the screenshot to the Clipboard. Pressing the Escape key cancels the interactive screen capture.

-m

Captures only the main display, if multiple displays are in use.

-s

Disables window selection mode in an interactive screen capture; only mouse selection is allowed.

-w

Disables mouse selection mode in an interactive screen capture; only window selection is allowed.

-W

Starts an interactive screen capture in window selection mode instead of mouse selection mode.

-x

Disables sound effects.

pathname

The name of a file in which to save the screenshot. You should terminate the filename with a .pdf extension.

Location

/usr/sbin


scselect
scselect [[-n] location]

Description

Changes active network Location. With no arguments, a usage statement and a list of defined Locations (or "sets") are printed to standard output, along with an indication of which Location is currently active. Locations can be referred to by name or by integer ID.

Options/Usage

-n

Changes the active network Location, but does not apply the change.

Location

/usr/sbin


scutil
scutil [-v] [-p]

scutil [-v] [-d] -r { hostname | IP_addr [IP_addr] }

scutil [-v] -w key [-t timeout]

scutil [-v] --get { ComputerName | LocalHostName }

scutil [-v] --set { ComputerName | LocalHostName } [hostname]

Description

Provides control of the System Configuration framework's dynamic store. scutil is used to open an interactive session with configd, in which various commands are available to view and modify System Configuration keys.

As a quick example of interactive use, try this:

  • Invoke scutil. You will be placed at the scutil prompt.

  • Enter open to open the session with configd.

  • Enter list. You will see a set of keys, some of which are provided by the System Configuration framework (such as the keys in the File: domain), some of which are obtained from /Library/Preferences/SystemConfiguration/preferences.plist (the Setup: keys), and some of which are published by the configuration agents (the State: keys).

  • Enter show State:/Network/Global/DNS to display the DNS dictionary. You should see a list of DNS servers and search domains configured on your system.

  • Enter close, then quit.

Options/Usage

-d

Enables debugging output to standard error.

--get

Prints the system's computer name or Rendezvous hostname to standard output.

-p

Enables a private API with additional commands, including lock, unlock, touch, snapshot, n.file, n.signal, n.wait, and n.callback.

-r

Determines how the specified node (given as a hostname or an IP address) would be reached, printing the result to standard output. Possibilities include Reachable, Directly Reachable Address (the address is on the local network), and Local Address (the address resolves to the host on which the command is run). For systems with more than one network interface, two arguments may be given, where the first is the system's local address, and the second is the remote address. Note that this option does not determine whether a machine at the specified address is currently active, only whether that address is reachable.

--set

Sets the system's computer name or Rendezvous hostname. If the new hostname isn't specified on the command line, it's taken from standard input.

-t

Specifies the timeout to wait for the presence of a data store key, in seconds. Defaults to 15.

-v

Enables verbose output to standard error.

-w

Exits when the specified key exists in the data store, or until the timeout has expired.

Commands

scutil enters interactive mode when invoked with no arguments.

add key [temporary]

Adds a key to the data store with the value of the current dictionary. The temporary keyword causes it to be flushed when the session to configd is closed.

close

Closes a session with configd.

d.add key [* | ? | #] value...

Adds an entry to the current dictionary. The optional type specifier can be used to designate the values as arrays (*), booleans (?), or numbers (#).

d.init

Creates an empty dictionary.

d.remove key

Removes the specified key from the current dictionary.

d.show

Displays the contents of the current dictionary.

exit

Exits the scutil session.

f.read file

Reads prepared commands from a file.

get key

Causes the value of the specified key to become the current dictionary.

help

Prints a list of available commands.

list [regex]

Lists keys in the System Configuration data store. A regular expression may be specified to restrict which keys are listed.

lock

Prevents changes to the data store by other processes.

n.add key [pattern]

Requests notification of changes made to the specified key, or to keys matching a regular expression (when the pattern argument is used).

n.callback [verbose]

Sends notifications via a callback function defined in the scutil code. This isn't particularly useful without modifying the source code.

n.cancel

Cancels n.watch settings.

n.changes

Lists changed keys that have been marked with notification requests, and resets the state of notification.

n.file [identifier]

Sends notifications to a file descriptor. After issuing this command, the prompt returns only after a notification is received.

n.list [pattern]

Lists keys upon which notification requests have been set. With the pattern argument, lists notification requests for keys matching regular expressions.

n.remove key [pattern]

Removes notification requests for the specified key or regular expression (when the pattern argument is used).

n.signal signal [process_ID]

Sends notifications by signaling a process. If a process ID isn't specified, the signal is sent to the scutil process. The signal is specified either as a name or a number (as described in the kill manpage).

n.wait

Sends notifications via Mach messaging.

n.watch [verbose]

Causes changes to keys marked with notification requests to issue immediate notices, obviating the need to use n.changes to notice that the change has occurred.

notify key

Sends a notification for the specified key.

open

Opens a session with configd.

q

Exits the scutil session.

quit

Exits the scutil session.

remove key

Removes the specified key from the data store.

set key

Sets the specified key to the value of the current dictionary.

show key [pattern]

Same as get key, followed by d.show.

snapshot

Saves current store and session data to XML property lists in /var/tmp/.

touch key

"Touches" the specified key, spurring notifications as if it had changed, but leaving it unaltered.

unlock

After issuing a lock command, allows other processes to make changes to the data store.

Location

/usr/sbin


SecurityServer
SecurityServer [-a config_file] [-d] [-E entropy_file] [-f]
[-N bootstrap_name] [-t max_threads] [-T thread_timeout] [-X]

Description

Provides services to the Security framework, including authorization and secure key management.

Options/Usage

-a

Specifies an Authorization Services configuration file. Defaults to /etc/authorization.

-d

Runs process in debug mode, and disables daemonization. Output is sent to standard error and to syslog.

-E

Specifies a file to use as a source of entropy for cryptographic operations. Defaults to /var/db/SystemEntropyCache.

-f

Forces immediate initialization of the Common Security Services Manager (CSSM), the central access point for services provided by the Common Data Security Architecture (CDSA). Normally the CSSM will be initialized when it is first needed.

-N

Specifies a service name used to register a Mach bootstrap port. Defaults to SecurityServer; any other setting will prevent authorization from working.

-t

Limits the number of Mach threads started by the SecurityServer process. Defaults to 100.

-T

Specifies a timeout for Mach threads started by the SecurityServer process, in seconds. Defaults to 120.

-X

Directs SecurityServer to re-execute itself when in daemon mode, needed to work around Mach-related bugs in libraries.

Location

/System/Library/CoreServices


service
service --list

service { --test-if-available | --test-if-configured-on } service

service service { start | stop }

Description

A shell script used to list, start, and stop network services. service is primarily an interface to services managed by xinetd, but it also includes support for Postfix (with a service name of smtp) and for receipt of faxes (fax-receive) on Panther.

Options/Usage

--list

Prints a list of services available for management to standard output.

--test-if-available

Returns 0 if the specified service is available on the system; 1 if not.

--test-if-configured-on

Returns 0 if the specified service is currently configured to run; 1 if not.

Location

/sbin


sips
sips [-h | --help | -H | --helpProperties]

sips [--debug] { -g | --getProperty } property image_or_profile_filename...

sips [--debug] { -x | --extractProfile } profile_filename image_filename...

sips [--debug] { -X | --extractTag } tag tag_filename profile_filename...

sips [--debug] { -v | --verify } profile_filename...

sips [--debug] { -s | --setProperty } property value [--out filename]
image_or_profile_filename...

sips [--debug] { -d | --deleteProperty } property [--out filename]
image_or_profile_filename...

sips [--debug] { -r | --rotate } degrees [--out filename] image_filename...

sips [--debug] { -f | --flip } { horizontal | vertical } [--out filename]
image_filename...

sips [--debug] { -c | --cropToHeightWidth | -p | --padToHeightWidth |
-z | resampleHeightWidth } height_pixels width_pixels [--out filename]
image_filename...

sips [--debug] { -Z | --resampleHeightWidthMax | --resampleHeight |
--resampleWidth } pixels [--out filename] image_filename...

sips [--debug] { -i | --addIcon } [--out filename] image_filename...

sips [--debug] { -e | --embedProfile | -E | --embedProfileIfNone | -m |
--matchTo } profile_filename [--out filename] image_filename...

sips [--debug] { -M | --matchToWithIntent } profile_filename { absolute |
relative | perceptual | satuation } [--out filename] image_filename...

sips [--debug] --deleteTag tag [--out filename] profile_filename...

sips [--debug] --copyTag src_tag dst_tag [--out filename]
profile_filename...

sips [--debug] --loadTag tag tag_filename [--out filename]
profile_filename...

sips [--debug] --repair [--out filename] profile_filename...

Description

The Scriptable Image Processing System (SIPS) tool can be used to manipulate images and ColorSync profiles from the command line.

ColorSync profiles are International Color Consortium (ICC) files that characterize the color properties of different devices, so that accurate color matching can be performed between them. There are ColorSync profiles located under /System/Library/ColorSync/Profiles/, /Library/ColorSync/Profiles/, /Library/Printers/, and /Library/Image Capture/Devices/, among other places. For more on ColorSync, see http://www.apple.com/macosx/features/colorsync/.

Options/Usage

-c | --cropToHeightWidth

Crops an image to the specified size (in pixels). The image is cropped equally from both top and bottom, and from both sides.

--copyTag

Copies the value of a tag in a ColorSync profile to another tag in the same profile.

-d | --deleteProperty

Deletes the specified property. A list of possible properties may be obtained with sips -H.

--debug

Enables debugging output.

--deleteTag

Deletes the specified tag from a ColorSync profile.

-e | --embedProfile

Embeds the specified ColorSync profile into the image.

-E | --embedProfileIfNone

Embeds the specified ColorSync profile into the image only if another profile is not already embedded.

-f | --flip

Flips an image in the specified direction.

-g | --getProperty

Prints the value of the specified property to standard output. A list of possible properties may be obtained with sips -H.

-h | --help

Prints a usage message to standard output.

-H | --helpProperties

Prints a list of image and profile properties to standard output.

-i | --addIcon

Adds an icon for an image file to its resource fork, which is used in Finder previews.

--loadTag

Copies the value of a tag from a file to a ColorSync profile. (This is the opposite of --extractTag.)

-m | --matchTo

Matches an image to the specified ColorSync profile.

-M | --matchToWithIntent

Matches an image to the specified ColorSync profile with the given rendering intent. (Note the misspelled satuation; this is a typo in the sips code.)

--out

Specifies the filename of the modified image file. By default, sips modifies the file in place; this option lets you save the modified file under a different name, leaving the original unchanged.

-p | --padToHeightWidth

Pads an image with blank space to the specified size (in pixels). The image is padded equally on both top and bottom, and on both sides.

-r | --rotate

Rotates an image the specified number of degrees clockwise.

--repair

Attempts to repair a malformed desc tag in a ColorSync profile. This option is the same as the Repair operation under Profile First Aid in the ColorSync Utility application.

--resampleHeight

Stretches or compresses an image to the specified height (in pixels).

--resampleWidth

Stretches or compresses an image to the specified width (in pixels).

-s | --setProperty

Sets a property to the specified value. A list of possible properties may be obtained with sips -H.

-v | --verify

Verifies the syntax of a ColorSync profile. This option is the same as the Verify operation under Profile First Aid in the ColorSync Utility application.

-x | --extractProfile

Copies an embedded ColorSync profile from an image to a file with the specified name.

-X | --extractTag

Copies the value of a tag (such as desc) from a ColorSync profile to a file with the specified name.

-z | --resampleHeightWidth

Stretches or compresses an image to the specified size (in pixels).

-Z | --resampleHeightWidthMax

Stretches or compresses an image while maintaining the aspect ratio. The largest dimension (height or width) is set to the specified size (in pixels).

Examples

Show the properties of a ColorSync profile (similar to what's displayed under the Profiles tab of the ColorSync Utility application):

% sips -g all /Library/ColorSync/Profiles/WebSafeColors.icc
/Library/ColorSync/Profiles/WebSafeColors.icc
  size: 10644
  cmm: appl
  version: 2.2.0
  class: nmcl
  space: RGB
  pcs: Lab
  creation: 2003:07:01 00:00:00
  platform: APPL
  quality: normal
  deviceManufacturer: 0
  deviceModel: 0
  deviceAttributes0: 0
  deviceAttributes1: 0
  renderingIntent: perceptual
  creator: appl
  md5: 14487F1ED8F8947B15F6682BFCF21E00
  description: Web Safe Colors
  copyright: Copyright 2001 - 2003 Copyright Apple Computer Inc., all rights reserved.

Convert a TIFF to a JPEG from the command line (also works for PNG, GIF, PICT, BMP, and other image formats):

% sips -s format jpeg --out sample.jpeg sample.tiff

Location

/usr/bin


SplitForks
SplitForks { -u | [-v] pathname }

Description

Copies the resource fork and HFS attributes from a file named filename into a separate file named .filename, equivalent to an AppleDouble Header file. The original file retains the resource fork and HFS metadata as well.

If pathname refers to a file, that file's resource fork and metadata are split out. If pathname is a directory, SplitForks does a recursive descent into the directory, working on every file within it.

FixupResourceForks undoes the actions of SplitForks.

Options/Usage

-u

Prints a usage statement to standard output.

-v

Enables verbose output.

Location

/Developer/Tools


systemkeychain
systemkeychain [-v] [-f] -C [password]

systemkeychain [-v] -t

systemkeychain [-v] [-c] [-k dest_keychain] -s keychain

Description

Creates and manages the system keychain, /Library/Keychains/System.keychain. (systemkeychain also creates /var/db/SystemKey, which presumably contains a randomly generated keychain password in encrypted form.) This keychain is used by system processes that run as root, such as daemons and boot processes, and is created automatically by the SecurityServer startup item.

Options/Usage

-c

Creates the destination keychain if it doesn't already exist.

-C

Creates a new system keychain, unless one already exists. The keychain password can be specified with an optional argument.

-f

Forces the overwrite of an existing system keychain when creating a new one.

-k

Instead of adding a key to the system keychain, adds it to the specified destination keychain.

-s

Adds a key to the system keychain that can be used to unlock the specified keychain.

-t

Unlocks the system keychain.

-v

Enables verbose output.

Location

/usr/sbin


udf.util
udf.util -m device mount_point

udf.util { -p | -u } device

Description

Mounts UDF (DVD) filesystems into the directory hierarchy.

Options/Usage

-m

Mounts the device.

-p

Probes the device, and prints the volume name to standard output.

-u

Unmounts the device.

device

The DVD device filename, e.g., disk1.

mount_point

The directory on which the DVD filesystem is mounted.

Location

/System/Library/Filesystems/udf.fs


ufs.util
ufs.util { -k | -p | -s } device

ufs.util -n device name

Description

Manipulates UFS filesystems.

Options/Usage

-k

Reads the disk's UUID key and prints it to standard output.

-n

Resets the volume name of the device. It takes effect after the next remount.

-p

Probes the device, and prints the volume name to standard output.

-s

Generates a new disk UUID key and sets it on the volume.

device

The disk device filename, e.g., disk0s5.

mount_point

The directory on which the filesystem is mounted.

Location

/System/Library/Filesystems/ufs.fs


unzip
unzip [-v]

unzip -Z [-v] [-M] [-s | -m | -l | -1] [-T] archive_filename [pathname...]
[-x pathname...]

unzip -Z [-v] [-M] [-2] [-h] [-t] [-z] archive_filename [pathname...]
[-x pathname...]

unzip [-q[q] | -v] [-M] [-l | -t | -z | -p | -c [-a[a]]] [-b] [-C]
archive_filename [pathname...] [-x pathname...]

unzip [-q[q] | -v] [-M] [-f | -u] [-a[a] | -b] [-C] [-L] [-j] [-V] [-X]
[-n | -o] [-d directory] archive_filename [pathname...] [-x pathname...]

Description

Lists or extracts files from a ZIP archive (such as one created by the zip command). If the name of the archive file ends in .zip, that extension need not be specified in archive_filename. If pathname arguments are given, only archive items matching those arguments are processed; otherwise, unzip lists or extracts all items in the archive. When called with no arguments, it prints a usage statement to standard output.

Options/Usage

-a

Converts text files in the archive to native format. For instance, this option translates DOS linefeeds to Unix linefeeds on Mac OS X. When doubled (-aa), it attempts to convert all files, whether text or binary.

-b

Treats all files as binary, so that no text conversions are attempted.

-c

Extracts file data to standard output.

-C

Uses case-insensitive matching of pathname arguments to archive items.

-d

Extracts files into the given directory. Otherwise, files are extracted into the current working directory.

-f

Extracts files only if they already exist, and if the modification timestamps in the archive are more recent than those on disk.

-j

Discards the paths of archived files, so that all files are extracted into the same directory.

-l

Lists archive contents, along with sizes, modification timestamps, and comments. More information is printed if -v is also used.

-L

Converts filenames to lowercase if they were archived from a single-case filesystem (such as FAT). When doubled (-LL), all filenames are converted to lowercase.

-M

Displays output a page at a time.

-n

Never overwrites existing files when extracting. By default, unzip prompts the user if an existing file would be overwritten.

-o

Overwrites existing files when extracting, without prompting.

-p

As -c, except that text conversions are not allowed.

-q

Minimizes output. When doubled (-qq), produces even less output.

-t

Performs a CRC check on archive items to determine if they have changed since being archived.

-u

As -f, but also extracts files that don't already exist on the disk.

-v

Enables verbose output. If it's the only argument, prints version information, compile settings, and environment variable settings to standard output.

-V

For items archived on a VMS system, this argument retains file version numbers in filenames.

-x

Excludes the files specified by the additional pathname arguments, which usually include wildcards to match filenames of a certain pattern.

-X

Restores owner and group information for extracted files. Successful use of this flag will most likely require superuser privileges.

-z

Prints comments stored in the archive file to standard output.

-Z

Provides more control over information displayed to standard output about archive contents. When invoked as the only argument, prints usage information for the following options to standard output.

-h

Prints archive name, size, and number of archived items.

-l

As -s, but compressed size is also displayed.

-m

As -s, but compression ratio is also displayed.

-M

Displays output a page at a time.

-s

Prints information about each item in the archive: permissions, version of zip used to create the archive, uncompressed size, file type, compression method, modification timestamp, and name. This is the default behavior if no other options are specified.

-t

Prints number of archived items, cumulative compressed and uncompressed sizes, and compression ratio.

-T

Prints timestamps in a sortable format, rather than the default human-readable format.

-v

Enables verbose output.

-x

Excludes the files specified by the additional pathname arguments, which usually include wildcards to match filenames of a certain pattern.

-z

Prints comments stored in the archive file.

-1

Prints only filenames of archived items.

-2

As -1, but -h, -t, and -z flags may be used to print additional information.

Location

/usr/bin


vndevice

Syntax

vndevice { attach | shadow } device pathname
vndevice detach device

Description

Attaches or detaches a virtual device node to or from a disk image file. (Note that the functionality of vndevice is incorporated within hdiutil.) Modifications to data on the attached disk image will instead be written to the virtual node, or shadow image, and subsequent access to that data will be from the shadow. This allows effective read/write access to data on a disk image that should not or cannot be modified.

Options/Usage

attach

Attaches a device node to a disk image designated by pathname.

detach

Detaches a device node from a disk image.

shadow

Associates an attached device node to a shadow disk image designated by pathname.

device

The device node filename; e.g., /dev/vn0.

Examples

Create a disk image, attach a virtual device node to it, and mount it:

% hdiutil create test.dmg -volname test -size 5m -fs HFS+ -layout NONE
% sudo vndevice attach /dev/vn0 test.dmg
% mkdir mount_point
% sudo mount -t hfs /dev/vn0 mount_point

Wait a minute, and then:

% touch mount_point/test_file
% ls -l test.dmg

Note that the modification time on the disk image is current, reflecting the change you made by creating a test file.

Now set up shadowing. Unmount the volume first, then create the shadow disk image, attach the virtual node to it, and mount it again:

% sudo umount /dev/vn0
% hdiutil create shadow.dmg -volname shadow -size 5m -fs HFS+ -layout NONE
% sudo vndevice shadow /dev/vn0 shadow.dmg
% sudo mount -t hfs /dev/vn0 mount_point

Wait a minute, and then:

% rm mount_point/test_file
% ls -l test.dmg; ls -l shadow.dmg

The modification time on the test image wasn't updated, but the shadow image reflects the change you just made, indicating that writes are being passed through to the shadow.

Finish up by unmounting the volume and detaching the virtual node:

% sudo umount /dev/vn0
% sudo vndevice detach /dev/vn0

Location

/usr/libexec


vsdbutil
vsdbutil { -a | -c | -d } pathname

vsdbutil -i

Description

Enables or disables the use of permissions on a disk volume. This is equivalent to using the "Ignore Privileges" checkbox in the Finder's Info window for a mounted volume. The status of permissions usage on mounted volumes is stored in the permissions database, /var/db/volinfo.database.

Options/Usage

-a

Activates permissions on the volume designated by pathname.

-c

Prints the status of permissions usage on the volume designated by pathname to standard output.

-d

Deactivates permissions on the volume designated by pathname.

-i

Initializes the permissions database to include all mounted HFS and HFS+ volumes.

Location

/usr/sbin


zip
zip [-h | -v]

zip [-q | -v] [-T] [-0 | -1 | -9] [-F[F]] [-o] [-f | -u] [-g] [-b directory]
[-J] archive_filename

zip [-q | -v] [-T] [-0 | -1 | -9] [-r [-D]] [-m] [-t MMDDYY] [-o] [-c] [-z]
[-X] [-j] [-k] [-l[l]] [-y] [-n suffix[:suffix]...] [ -f | -u] [-d] [-g]
[-b directory] [-A] archive_filename { pathname... | -@ } [{ -i | -x }
pathname...]

Description

The files given by the pathname arguments are collected into a single archive file with some metadata (as with tar), where they are compressed using the PKZIP algorithm. The archive file is named with a .zip extension unless another extension is specified. If pathname is given as -, then data to be archived and compressed is read from standard input; if archive_filename is -, the ZIP archive data is written to standard output instead of to a file. If archive_filename already exists, then the specified files are added to or updated in the existing archive. When called with no arguments, it prints a usage statement to standard output.

Unlike the creation of ZIP archives from the Finder, zip does not preserve resource or attribute forks.

Options/Usage

-A

Adjusts the file offsets stored in the ZIP archive to prepare it for use as a self-extracting executable archive.

-b

When updating an existing archive, this option specifies the directory in which the new archive is temporarily stored before being copied over the old. Normally the temporary file is created in the current directory.

-c

Prompts for one-line comments associated with each file in the archive.

-d

Removes files from an existing archive, instead of adding or updating them.

-D

Disables the creation of directory entries in the archive.

-f

Updates files in an existing archive if the modification timestamps of the source files are more recent than those in the archive. Does not add new files to an existing archive.

-F

Attempts to repair an archive file that has been corrupted or truncated. When doubled (-FF), it performs a more thorough analysis of the archive.

-g

When updating an existing archive, attempts to append to the existing file, rather than creating a new file to replace the old.

-h

Prints a usage statement to standard output.

-i

Includes only the files specified by the additional pathname arguments, which usually include wildcards to match filenames of a certain pattern.

-j

Discards the paths of archived files, retaining only the filenames.

-J

Strips data prepended to an archive, such as code to make the archive a self-extracting executable.

-k

Attempts to archive files using DOS-compatible names and attributes.

-l

Translates Unix-style newlines in files to DOS newlines. When doubled (-ll), converts DOS newlines to Unix newlines.

-m

Deletes the source files after they've been archived.

-n

Disables compression for files with names ending in the specified strings.

-o

Sets the modification timestamp of the ZIP archive to that of the most recently modified item in the archive.

-q

Minimizes output.

-r

Performs a recursive traversal of directories specified in the pathname arguments, and archives their contents.

-t

Only archives files with modification timestamps more recent than the given date.

-T

Tests the integrity of the ZIP archive created by the command. If the test fails, then a preexisting archive file will not be overwritten, and source files will not be deleted (if using -m).

-u

Updates files in an existing archive if the modification timestamps of the source files are more recent than those in the archive. Unlike -f, new files are also added.

-v

Enables verbose output. If it's the only argument, prints version information, compile settings, and environment variable settings to standard output.

-x

Excludes the files specified by the additional pathname arguments, which usually include wildcards to match filenames of a certain pattern.

-X

Disables storage of file metadata in the archive, such as owner, group, and modification date.

-y

Archives symbolic links as symlinks, rather than archiving the targets of symlinks.

-z

Prompts for comments to be stored in the archive file.

-0

Disables compression.

-1

Compresses more quickly, at the cost of space efficiency.

-9

Compresses better, at the cost of time.

-@

Takes the list of source files from standard input.

Location

/usr/bin


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

acct daemon, starting
acid command-line tool
Active Directory plug-in (Directory Access)
ADC (Apple Developer Connection)
documentation for Xcode
Xcode Tools
AddModule and LoadModule directives (httpd.conf)
administrative privileges, granting
Advanced Package Tool (APT)
AFP (AppleTalk Filing Protocol)
AFP URLs
automated access to AFP shares
agvtool
AirPort Base Station, sending traffic to Mac acting as server
alloc.h header file
AltiVec Velocity Engine (Motorola)
Amber command-lline tool
anacron, setting up
animation, 3D graphics package
anonymous server, configuring ProFTPd as
ANSI
C predefined macros
escape sequences
trigraph preprocessing
Apache server 2nd
hostconfig entry for
optional modules
hfs_apple_module
perl_module (mod_perl)
php4_module (mod_php4)
rendezvous_apple_module
ssl_module (mod_ssl)
WebDAV module (dav_module)
source code, web site for
Apache::Registry module
AppKit framework
in Objective-C Hello World example
_ _APPLE_ _ macro
_ _APPLE_CC_ _ macro
Apple C compiler
Apple debugger
Apple Developer Connection (ADC)
documentation for Xcode
Xcode Tools
Apple Events, invoking from Perl
Apple File Sharing
launching at startup
starting
Apple Remote Desktop
Apple Type Solution server
AppleScript
RAqua, using with
running from command line
Script Editor service
support by iTeXMac
support by TeXShop editor
AppleScript Studio
AppleTalk Filing Protocol [See AFP]
AppleTalk protocol
appletviewer tool
application bundle
Application menu
Hide option
Show All option
X11
connecting to other X Windows Systems
customizing
application-specific framework
preprocessor searches for
applications
contents of
opening with shell open command
starting automatically
X11-based [See X11]
apropos command
APT (Advanced Package Tool)
apt-get commands
Aqua
interactions with X11
native port of LyX (LyX/Mac)
open source video viewing applications
OSXvnc server, support by
RAqua
real estate-saving features of
terminal applications 2nd [See also Terminal application]
version of Qt for Mac OS X
VNC client
VNC viewers
X11 full screen and rootless modes
AquaTerm
archive file (.pax) for packages
archiving files and directories
file compression and storage
jar tool
in tar files, using gnutar and gzip
in .zip format directly from Finder
arithmetic
basic operations (vBasicOps library)
expr command
libm library
arrays, contiguous memory accesses for elements
_ _ASSEMBLER_ _ macro
assembler
online information about
audio codec Ogg Vorbis
audio/video player, MPlayer for Linux/Unix
authentication
BSD flat files, using
relying solely upon
Directory Access Authentication tab
Linux-PAM, using
NetInfo database and
PostgreSQL and
Windows users logging onto Mac
X11, configuring for
authentication server, starting
AuthorizationTrampoline command
autoconf utility
detecting sytems that require malloc.h file
determining supported compiler features
autodiskmount command
automount command
automount daemon, NFS
awk tool

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

backups of NetInfo database
bash shell 2nd
# prompt for root user
$ user prompt
DISPLAY variable, enabling X11 forwarding
escape sequences used with
basic arithmetic operations (vBasicOps library)
basic linear algebra subprograms (BLAS)
BBEdit, forcing file to be opened with
beeps (system alert), for X11
Berkeley-compatible command-line interface
biendian byte order, PowerPC
big- or little-endian order for bytes
bill of materials (.bom) file
describing package contents
listing contents of
binaries
installation, mixing with source
installing via dselect
binary formats
ELF
Mach-O
BIND DNS server
binding, prebinding Mach executables
bison command
BLAS (basic linear algebra subprograms)
Blender 3D graphics package
installing on Mac OS X
OpenGL, use of
bless tool
Bluetooth device, sending file to
Bombich Software, SMD application
bookmarks
iTerm support for
KDE Konsole terminal emulator
BootCacheControl, launching
booting Mac OS X
/etc/rc script
/etc/rc.boot script
BootX loader
fsck command, failure of
initialization
Login Window
Open Firmware variables that control behavior of
register_mach_bootstrap_servers
in single-user mode
SystemStarter
in verbose mode
bootstrap script, running for Fink installation
bootstrap services (Mach)
launching
listing of
BootX loader 2nd
Bourne shell 2nd [See also bash shell; shells]
BSD operating system
flat files [See flat files]
initialization of supporting data structures
osx2x application
bsdmake command
build type
building software
gnuplot application
Unix-based, on Mac OS X
header files
X-11 based applications
BuildStrings tool
bundles 2nd
application
viewing contents of
CPAN, installing
framework
loadable
loading
bunzip2 command
burning CDs
bytes, endian order of
bzcat command
bzip2 command
bzip2recover command

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

C/C++ [See also Objective-C/C++]
ANSI C predefined macros
AquaTerm adapter for C
C compiler with Xcode
C declarations in header files
C library, gethostent( )
C pointers, size of
distributing code builds with distcc
Mac OS X C compiler
PFE precompilation, support for C++
preprocessors for
CA (Certificate Authority)
cetificate signed by trusted CA, getting
creating untrusted CA
caching
BootCache control, launching
CacheBasher performance analysis tool
flushing cached credentials with sudo lookupd -flushcache
invalid credentials, caching by Directory Services
kextcache utility
longer cacheline size in L1 cache on G5
performance monitoring with CHUD tools
calculator, dc command for
Carnegie Mellon University, Mach microkernel
case insensitivity, HFS+ filesystem
case-sensitivity
cc compile driver and
tarball filenames
cat command
cc command
-F option
-faltivec flag
-framework option
-precomp compile driver flag
-trigraph option
invoked without options
languages supported, filename suffixes and -x arguments
linking to static library
cc compiler
shared library or bundle, special flags for
CCLEngine command
cd command
cd9660.util
CDs
burning
disk image of Mail application
mounting ISO-9660 filesystems
CDSA (Common Data Security Architecture)
certificates, server
creating untrusted CA
signed by trusted CA, information about
signing your certificate
X.509 SSL/TLS certificates
certtool
characters not available on older terminals
checkgid command
chflags command
Chicken of the VNC (Aqua VNC client)
chkpasswd command
chmod command 2nd
chown command, recursively setting home directory ownership
chsh, chfn, and chpass commands
CHUD Tools (Computer Hardware Understanding Development)
hwprefs
CinePaint
class name (Java), browsing Java documentation for
Classic application, launching
clear command
click to position cursor option
clipboard, Terminal and
cmp command
Cocktail application
Cocoa and Carbon applications
AquaTerm application (Cocoa)
Cocoa toolkit, contents of
GUI editor for applications (Interface Builder)
including framework header file in source code
Mac::Carbon (Perl module)
online information for Cocoa programmers
programming support by Xcode IDE
CodeTek, VirtualDesktop shareware
color output, terminal support for
colors (X11 look and feel), customizing
ColorSync profiles
comm command
command line [See also commands; Terminal application]
Apple command-line tools
creating disk images from 2nd
downloading files from
launching customized Terminal window
System V- and Berkeley-compatible interfaces, provided by CUPS
command prompt
command-line switches, Terminal customization and
commands
AuthorizationTrampoline
autodiskmount
automount
CCLEngine
cd9660.util
certtool
checkgid
chkpasswd
configd
CpMac
create_nidb script
DirectoryService
disktool
fixmount
fixPrecomps
FixupResourceForks
gcc_select
hfs.util
hostinfo
hwprefs
information about, man command for
ipconfig
kdumpd
kuncd
languagesetup
locating by keyword, apropos command for
makekey
mDNS
mDNSResponder
mount_devfs
mount_ftp
mount_smpfs
mount_synthfs
mount_volfs
msdos.util
notifyd
ntp-wait
ntptimeset
od
open-x11
opendiff
pdisk
pdump
postfix-watch
register_mach_bootstrap_servers
scselect
scutil
SecurityServer
service
SimG5 and SimG4 tools
sips
SplitForks
systemkeychain
udf.util
ufs.util
Unix, on Mac OS X
unzip
vndevice
vsdbutil
zip
comments, preprocessor recognition of
Common Data Security Architecture (CDSA)
common ports, access to blocked by ISPs
Common Unix Printing System [See CUPS]
comparisons, expr command
compatibility version number
compiler flags
-fast
-funroll-loops
-mtune-970
Compiler Release Notes (Mac OS X)
Compiler Tools
compilers [See also GCC]2nd
cross-compilers
javac
jikes
Just-In-Time (JIT), architectural issues and
supported features, determining with GNU autoconf
compiling source code
AltiVec Velocity Engine (Motorola compiler)
architectural issues
32-bit and 64-bit systems
inline assembly code
tuning code for G5 architecture
commands for compiling an application
differences between GCC for Mac OS X and other Unix systems
gnumake/make commands
MySQL from source
Unix applications on Mac OS X
frameworks
helpful files in tarball top-level directory
host type
Mac OS X GCC compiler flags
preprocessing
programming languages supported
vecLib framework, using
X-11 based applications and libraries
Comprehensive R Network, distribution of RAqua
compress tool
compressed files
corruption of tar files by older versions of Stuffit Expander
download and extraction with Stufflt Expander
tools for
Computer Hardware Understanding Development Tools (CHUD)
hwprefs
config.guess file
config.sub file
configd
connecting to
configuration
CPAN shell
files for Unix applications and services
system, utilities for
defaults command
nvram
scutil 2nd
Configuration server daemon
configure scripts
autoconf-managed source code from CVS archive
Darwin version
generating makefiles for X11-based applications
host type
config.guess and config.sub files
macros to detect Mac OS X
console messages, displaying during startup
contact information, searching Directory Services for
Contents/ directory
context of precompilation
context switches, latency utility for measuring
contextual menus
iTerm
Terminal
cycling between open Terminals
xterm windows vs.
contiguous memory accesses
Control-clicking in an xterm window
copying and pasting
to the clipboard, Terminal vs. xterm
between X11 and Mac OS X applications
controlling with osx2x
core dumps
hostconfig file setting
from remote Mac OS X clients
Core Services daemon
cp command
CPAN modules, installing
configuring CPAN shell
dependency problems
installBundle::CPAN command
Jaguar and
selecting preferred CPAN mirrors
shell interface to CPAN
cpan> shell prompt
cpio tool
CpMac tool 2nd
cpp (GNU C preprocessor)
-no-cpp-precomp switch
-traditional-cpp switch
incompatibilities with cpp-precomp
cpp-precomp 2nd 3rd
documentation for
incompatibilities with GNU cpp preprocessors
PFE mechanism vs.
CPU
breakdown of usage, top utility
performance tool, Reggie SE
process usage of, top utility statistics
CPU architectures, endianness of
CRAN (Comprehensive R Network)
crash report generation for applications
create_nidb script
cron daemon, starting
cron jobs
anacron and
daily, backups of NetInfo database
running with MacJanitor
TinkerTool System, running with
crontab -e command
crontab -l command
crontab file
csh shell
DISPLAY variable, enabling X11 forwarding
CUPS (Common Unix Printing System)
hostconfig entry for
launched at startup
printing from remote systems
starting
web site for source code and documentation
curl utility
Current symbolic link (shared library)
curses screen library
cursor, click to position option
cut tool
cvs tool
CVS, installing Fink from
cvs-unwrap tool
cvs-wrap tool
cvswrappers tool

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

daemons
starting at boot time
starting with Mach bootstrap services
daily cron jobs
backups of NetInfo database
changing time for
Darwin kernel
absolute pathname for libraries
Apple C compiler, differences from GNU version
building
compiler flags for
config.* files, support for Darwin
g77 (GNU FORTRAN 77) compiler, source code
online resources for information
PIC flags and
system library (libSystem)
utilities for
version, in configure script
DarwinPorts project
data forks, removing from a file
data store for NetInfo and LDAP
Data::Dumper module
database
creating for PostgreSQL
MySQL, creating for
network configuration (dynamic store)
database routines (libdbm)
datasource entry (slapd.conf), editing for OpenLDAP
dates and times
daily cron job, changing time for
NTP client, starting
ntptimeset, for system clock
dav_module (mod_dav)
DBD::mysql module
DBD::Pg module
DBI module
dc command
ddb utility
Debian Advanced Package Tool (APT)
debuggers
Apple debugger
gdb debugger
Java debugger
debugging
Panther tools for
reparing disk volumes with Disk Utility
a running kernel with ddb
defaults command
examples of use
DeRez tool
desktop environments 2nd
controlling all X11- and Mac OS X-based desktops
Exposé, in Mac OS X Panther
LaTeX and its frontends [See LaTeX]
real estate-saving features of Aqua
SSH GUIs for Mac OS X
virtual desktop applications for Mac OS X
virtual desktops and screens
X11
available from Fink
websites for download and instructions
developer tools
Apple command-line tools
Mac OS X Unix tools
performance and debugging
uninstalling
Unix, standard
X11SDK, for building X11-based applications
development tools
Java
devfs filesystem, mounting
devices, virtual device node (vndevice)
diagnostic utilities
top
memory information
process information
vm_stat
information displayed by
dictionary (key/value pairs), displaying for configuration database
dictionary attacks against password files
diff/diff3 commands
digital signal processing (vDSP library)
Direct CG (AIPI)
directories [See also individual directory names]
/dev directory
/etc directory, contents of
/Library
/System/Library
/var
manipulating, commands for
names, working with
tab completion
opening in Finder
packages in
root directory, files and directories in
setting up for intended package installation
Directory Access application
Authentication tab
caching of invalid credentials after changes to
Contact tab
directory service plug-ins
Directory Services
configuring
Authentication tab, Directory Access
BSD flat files as sole authentication source
plug-ins supported by Directory Access
configuring to run OpenLDAP
exporting directories with NFS
flat file counterparts
groups, managing
adding user to a group
creating groups with dscl
creating groups with niload
deleting groups
listing all GIDs
listing with nidump
hostnames and IP addresses, managing
NetInfo Manager
programming with
passwords
restoring the database
users and passwords, managing
adding users
creating user with dscl
creating user with niload
creating user's home directory
deleting user with dscl's delete command
granting administrative privileges
listing users with nidump
modifying user with dscl -create
utilities
list of
DirectoryService daemon 2nd 3rd
disk arbitration daemon
disk images
attaching/detaching virtual device node
creating from command line
creating with Disk Utility
converting disk image
copying files to disk image
distributing
Internet-enabled disk image
dual and single fork
installing Fink from
packaging applications as
unmounting
Disk Utility
burning disk image to a CD
creating a disk image
converting disk image
copying files to image
disk image of Mail folder, making
disk images created with
packaging and distributing application as disk image
Repair Permissions feature
repairing problem disk volume
disks
controlling Apple partition maps on
Macintosh tools for
disktool
diskutil tool
DISPLAY variable, enabling X11 forwarding in Terminal
distcc command 2nd
distributed notifications daemon
ditto command 2nd
with --rsrc flag
dlcompat library functions 2nd
libdlcompat library
dlfcn.h header file
DNS
lookup against your IP address
MX (Mail Exchange) record
Rendezvous multicast client
DNS server, hostconfig entry for
Dock
changing location with defaults command
minimization of X11 windows to
using Terminal and
X11
Document Type Definition (DTD), PropertyList.dtd
documentation
building and using precompiled header files
Compiler Release Notes, Mac OS X
for Xcode[documentation
Xcode
Java, generated with javadoc
performance and debugging tools
double-clickable executables
dpkg
commands
dselect frontend
installing Fink package with
drivers
drivers for printers
from Gimp-Print
HP Inkjet Project
dscl utility
adding users
adding users to group with merge command
delete command
deleting groups
groups, creating with
modifying user with -create command
dselect utility
DTEs [See desktop environments]
dual fork disk image (.img file extension)
DVD filesystems, mounting
DVI files, viewing with ITeXMac
dyld (dynamic linker) 2nd
converting Unix code to use its APIs
prebinding and
dyld( ) function
DYLD_LIBRARY_PATH variable
dylib actions, translating dlopen( ) function calls to
dynamic libraries (.dylib files)
dynamic link editor (Mach-O)
dynamic linking (libdlcompat library)
dynamic loader (dyld), prebinding of binary files
dynamic store (network configuration database)
dynamic_pager daemon

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

echo command
editors
emacs
forcing file to be opened with TextEdit
GUI editor for Cocoa and Carbon
image [See GIMP]
nedit 2nd
pico 2nd
Property List Editor 2nd 3rd
Script Editor service for AppleScript
shell escape sequences, typing
static and dynamic link editors (Mach-0)
TeXShop [See TeXShop]
vim 2nd
editing XML property lists
egrep tool
ELF (Executable and Linking Format)
building shared libraries
paths to linked dynamic shared libraries
shared libraries, version numbers
emacs tool
email
configuring Postfix to receive
configuring Postfix to send
sending on demand with Postfix
encrypted passwords, retrieving
BSD flat files, using for authentication
Panther and
endian order, listing for some operating sytems
environment variables
in hostconfig file
TERM, possible values for
EPS files
converting to PDF
viewing with iTeXMac
Equation Editor (LaTeX)
Equation Service (LaTeX)
escape sequences 2nd
escaping spaces in file/directory names
eterm, replacement for xterm
Ethernet (built-in, on Mac OS X), proxy settings for
ex tool
Executable and Linking Format [See ELF]
executables
changing icons for
making double-clickable
prebinding of
execution of programs, profiling tool (gprof)
execution strings
exporting
directories with NFS
web site as a filesystem
Exposé (desktop environment)
expr command
extensions (networking), loading
extensions, kernel
status of currently loaded (kextstat)
tutorials on
extern keyword

[ Team LiB ]