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Introduction

Welcome to Flash CS54 All-in-One For Dummies. Our goal when writing
this book was to share our enthusiasm for Flash and, at the same
time, demystify the application. You can do so many things with Flash that
it becomes mind boggling. The minibooks in this reference are designed to
take the boggle out of your mind and show you how to use Flash to create
Web banners, animations, and other delights. We also delve into the topics
of ActionScript and Flash video.

If you're reading this introduction in a bookstore and deciding whether this
Flash book is the one for you, we want to give you a few facts. The authors
of this book are card-carrying geeks who love working in Flash. We’re also
professional authors, which means that we value our readers. We don’t
overload you with technical terms. Each section was written as though we
were looking over a friend’s shoulder while they were working with Flash
and then showing them how to work smarter and not harder. We've also
injected enough humor to keep you awake while learning Flash, and (we
hope) to make you chuckle out loud at least once per chapter.

About This Book

This book isn’t meant to be read from front to back. It’s more like a refer-
ence: Each chapter is divided into sections, each of which has self-contained
information about something you can do in Flash CS4.

You don’t have to memorize anything in this book. The information here is
what you need to know to get by and see how Flash works. When you need
specific information, let your fingers do the walking to the table of contents
or the index, and then open the book to that page and read. We recom-
mend that you use those little sticky flags to mark pages that interest you.
Feel free to highlight text and scribble in the borders (it’s your book). We
request that you keep this book on your desk and out of harm’s way — for
some reason, poodles love to chew For Dummies books.

Wherever we mention a new term or are possessed by the need to get geeky
with our technical descriptions, we let you know so that you can decide
whether to read them or ignore them. You can thank us now, or you can
thank us later.
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Conventions Used in This Book

We realize that doing something the same way over and over again can be
boring (such as always having to put on your socks before your shoes), but
sometimes consistency is a good thing. For one thing, it makes stuff easier to
understand. In this book, those consistent elements are conventions. In fact,
we use italics to identify and define new terms.

Our book is cross-platform. In fact, your friendly authors are cross-platform:
Doug uses Flash on a PC; Bill, on a Mac. Whenever we show a keyboard
shortcut, we list the keyboard sequence for both platforms.

Whenever you have to type something to complete a task, we put the stuff
you need to enter in a bold type so that it’s easy to see.

When we type URLs (Web addresses) within a paragraph, they look like this:

www.pixelicious.info.

What You Don’t Have to Read

We've added little tidbits of interest in many parts of this book. You'll see
sidebars with information relating to the topics being discussed and icons
that list technical information relating to tasks we’re showing you how to
do. Treat these little tidbits like snacks: You can devour them when you see
them, ignore them, or read them when you get a chance.

Foolish Assumptions

This is the spot where we help you determine whether you've got the stuff
that’s needed to do what we show you how to do in this book. First, if you
thought that this book was about flashing, you’re in the wrong section of
the bookstore. Second, we assume that you have a computer capable of run-
ning Flash CS4. Third, we assume that you have Flash CS4 installed on your
computer, or will have it installed soon. If you're blushing because we’ve
assumed incorrectly, quietly put this book back on the shelf and slowly walk
away, carefully avoiding any closed-circuit TV monitors in the store.

How This Book Is Organized

We’ve divided this book into minibooks, which are organized by topic.

The minibooks point out the most important aspects of Flash CS4. If you're
looking for information on a specific Flash topic, such as motion tweens or
ActionScript, skim the table of contents or check the headings in it, or check
out ye olde index.
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By design, this book enables you to find as much (or as little) information as
you need at any particular moment. If you need to know something superfast
for your meeting with a new client who wants an all-singing, all-dancing Flash
site, for example, just skim the index until you find the topic, and then read
that section. By design, Flash C54 All-in-One For Dummies is your desktop
companion for all things Flash. When you’re working on a project and you're
stumped, pick up this book and quickly find the information you need.

Book I: Introducing Flash

When you launch Flash and first see all that stuff on your monitor, you might
let loose with an expletive that we can’t print in this book because our edi-
tors would delete it. But we agree: Flash has a lot of features. If you're not
familiar with Flash, you’ll find Book I rather comforting because our sole
purpose when writing it was to show you what you can do with Flash and
familiarize you with the application. If you're a Flash veteran, you may be
tempted to skip this minibook, but we advise you to skim through it so that
you can see some of the cool new Flash features.

Book II: Creating Graphics

Flash has a Tools panel filled with neat-looking icons. In Book I, we show
you how to use these icons to create objects for your Flash movies. In addi-
tion to showing you the Flash drawing tools, we show you how to create
text. And because it seems that nothing in today’s world is black and white,
we show you how to add color to your Flash projects. And while we’re on
the subject of projects, in Book Il we show you how to streamline your proj-
ects by creating symbols for the items you use repeatedly and how to orga-
nize your work with layers. If your project involves digital images, fear not:
We devote one chapter of this minibook to that topic.

Book 11I: Animating Graphics

Animation is a moving subject, which is why we devote an entire minibook
to it. If you've seen Flash animations, you know that they can be complex.
Fortunately, Flash CS4 makes it easier than ever to create an interesting
animation. In Book III, we show you how to create motion tween and shape
tween animations. We also show you how to animate text.

Book 1V: Adding ActionScript 3.0 Magic

ActionScript 3.0 is used to show you how to control every aspect of your
Flash CS4 creation. Although powerful, ActionScript 3.0 is perfectly manage-
able, and you will quickly find out how to create the effects and functionality
that you always wanted but didn’t know how to produce. We show you how
to use the latest ActionScript classes in ActionScript files and how to make
simple Timeline entries using the Actions panel.
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How This Book Is Organized

Book U: Working with Flash Audio

Flash is alive, with the sound of music. Well, not by default, but if you want
to add music to your Flash projects, Book V is the place to go. We show you
how to import sound into your Flash projects, synch it with the Timeline,
edit the sound, optimize it for your project, and much more. We also show
you how to create buttons that make noises when you click them.

Book VI: Working with Flash Uideo

One of the best new benefits of Flash CS4 is the ease with which you can
incorporate video into your Flash project. You can create a video using
anything from a humble Webcam to a state-of-the-art digital video camera to
either stream live or create recorded video to be played at the user’s leisure.
We show you how to use the FLVPlayback component to set up a video in a
few steps and to create your own video player using ActionScript 3.0. On top
of all of this, Flash CS4 allows you to use the crystal-clear H.264 format for
high-quality playback.

Book VII: Getting Interactive

In Book VII, we start by showing you how to create buttons and then use
ActionScript to make them do interesting things when users click them. You
also find out how to use the components for making menus, text displays
with scrollbars, interactive buttons that change dynamically when the user
presses them, and a host of other powerful components to add a highly pro-
fessional touch to your Flash masterpiece. In addition, Book VII shows you
how to use the newest version of AIR to create desktop versions of the same
Flash applications that are launched on the Web.

Book VIII: Finalizing a Flash Project

Creating a Flash document is a lot of fun. But at some point, you have to
publish the document so that you can share it with the world, or at least
with a few close friends. In Book VIII, we show you how to test and preview
your Flash creations. We also show you how to debug the ActionScript code
in your Flash projects. The last chapter of this minibook shows you how to
publish your creation for the Web and other destinations.

Companion Web site

Graphic files, text files, AIR files, source code (FLA) files, ActionScript (.as)
files, and other necessary files for the featured projects in the book are avail-
able for downloading at the book’s companion Web site: www . dummies.
com/go/flashallinone. Everything has been tested (and retested) so
that if you make a typo in one of the project applications, you still have what
you need.
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Icons Used in This Book

3

To make your experience with this book easier, we use various icons in the
margins to indicate particular points of interest. If fact, you can use these
icons to skim through a chapter and find sections that interest you.

Whenever we give you a hint or a tip that makes an aspect of Flash CS4
easier to understand, we mark it with this little Tip doohickey — it’s our way
of sharing the tidbits of wisdom we’ve learned by being charter members of
the School of Hard Knocks — so that you don’t have to.

This icon is a friendly reminder or a marker for information that you want to
make sure to keep in mind when performing a task.

Ouch! Warnings give you important directions to keep you from doing some-
thing that throws a giant roadblock in your path or that, even worse, causes
Flash to crash and obliterates your hard work. We know what not to do, and
this handy little icon can prevent you from having to struggle through the
same pitfalls we once encountered.

Sometimes we feel obligated to share some geek stuff with you that’s inter-
esting but not essential to your knowledge of Flash. We mark that informa-
tion with our supergeeky hero so that you know that it’s just background
information.

This icon identifies files available for downloading from the book’s compan-
ion Web site (www.dummies.com/go/flashallinone).

Where to Go from Here

Now you’re ready to use this book. Look over the table of contents and find
something that catches your attention or a topic that you think can help you
solve a problem. Launch Flash and then read about the topics that interest
you. We find it best to just jump in and perform a task, so if you follow along
while you read, you’ll get the knack of Flash rather quickly.
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The 5th Wave By Rich Tennant

you wWant to do, is balance the image of
the pick-up truck sittin’ behind your home
page, w?& a busted washing machine in
the foreground.”




Fash CS4 is new. And, it’s different. You can
do the same tasks with Flash CS4 that you
could do with Flash CS3 — and then some. If you
want to find out about all the things you can do
with Flash, and get a preview of the features we
show you in this book, you’ve parked your bi-
focals on the right minibook.

In Book I, we show you what’s new and different in
Flash, and we show you some of the works of art
you can expect to create if you finish reading this
book in its entirety. So, if you want to see what
Flash and this book are all about, flip the page.




Chapter 1: Exploring Flash

In This Chapter

1+~ Discovering what’s new in Flash CS4
1~ Examining the Flash workspace

+~ Exploring the Flash tools

1~ Customizing Flash

ust when you thought you had Flash all figured out and believed that it

was safe to continue merrily with your old Flash CS3 habits, along comes
Flash CS4. The fact that you hold this book in your hands means that you
own Flash CS4 and want to know more about the application. Flash CS4 is
an extremely sophisticated piece of software. And — yikes! — it has come a
long way since Adobe purchased Macromedia in December 2005. It seems
like only yesterday that Flash 4 (and its medieval
ActionScript and shape tweening) were consid-
ered the best thing since sliced bread.

Using a program like Flash has a tendency to
organize you. Organized authors that we are, we
figured the best place to start a book is by get-
ting to know the lay of the land, so to speak. This
process is kind of like a car manual: You don’t
start out by showing the driver how to change a

tire — you start with a diagram that shows the nut
behind the wheel where to park and then show Welcome to X-treme Sports. Whet
him how to start his fuel-efficient hybrid car that your sense of adventure takes yo

takes dainty sips of gas when it’s not running on Shove the water. below the water
electricity. First, we tell you what’s new and excit- g :

ing in Flash CS4, and then we familiarize you with
the new workspace. And, because we know that
no two people work alike (that’s why they cre-
ated preferences), we show you how to customize
Flash to suit your working preference.

he open road, you've found yo
aior the ultimate in equing




10 Finding Out What's New in Flash CS4

Finding Qut What's New in Flash CS4

It’s always something with new software, and for that matter, with life. Just
when you think that you know something like the back of your hand, tech-
nology raises its pointy little head and turns your beloved application into
an 800-pound gorilla that must be tamed.

As authors, we're glad that technology keeps changing, because it gives us
something to write about. When we find a new application, the software
maker sends us a prerelease version of the software because it’s not ready
for prime time yet. The first thing we do is “lift the hood” and poke around
until we find the new features. After that, our next job is to figure out just
what the heck the feature is and why it was added. The following sections
highlight some of the flashy stuff we found in Flash CS4.

Discovering the new features

Working with a new version of an application is like peeling an onion: The
outside looks familiar, but then you start revealing its layers. And, without
documentation, using a program’s new features can bring you to tears. Don’t
worry: We already peeled Flash CS4. The following list shows you the new
features we found:

1 Inverse kinematics: If you feel the need to add an animation of a dancing
chicken to a Web site, you can do it with Flash CS4, thanks to the Inverse
Kinematics animation tool. You can use it to create animations such as
people walking across the screen or working with machinery. You use
the Flash drawing tools to create, in essence, the parts of the dancing
chicken, dancing dude, or dancing fool. Then you create an inverse kine-
matics chain, which creates your character’s bones. We show you how
to get bad to the bone with inverse kinematics in Book IlI, Chapter 2.

1~ Kuler: Adobe Kuler is an online resource for creating color palettes for
Web pages and illustrations, for example. Flash CS4 comes with a Kuler
panel that you use to view color palettes created by other designers and
to create your own color palettes. We show you how to be cooler with
Kuler in Book II, Chapter 2.

1 Scrubby sliders: A scrubby slider is an interactive way of entering a value.
When you see a value in blue with a line underneath it, pause the cursor
over the value. The cursor becomes a hand with a pointing forefinger
sprouting a dual-headed arrow. Click and drag to interactively change
the value. Hold down the Shift key while dragging to change the value in
large increments, or hold down the Ctrl key (Windows) or the Command
key (Macintosh) while dragging to change the value in small increments.
Use scrubby sliders to enter precise, minty-fresh, ecologically safe values.
(No pixels were harmed or destroyed in the creation of this paragraph.)
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~ Motion tweening: If you've used Flash for a while, you’ve no doubt cre-
ated a motion tween animation. As its name implies, you move an object
from Point A to Point B, and Flash calculates the frames between the
start and end of the animation. The designers of Flash CS4 have now
made motion tweening child’s play, and you have more control than
ever. For example, if you need to create an animation of a ball jump-
ing through many hoops (which is similar to getting a bill through
Congress), we show you everything you need to know about motion
tweening but were afraid to ask in Book Il, Chapter 2.

1~ Motion Editor: If you're a veteran Flash animator, you may be familiar
with the term easing, which determines how the animation starts and
ends. You can ease into the animation slowly, and ease out quickly, like
a car accelerating, or vice versa. In Flash CS4, the new Motion Editor
tool enables you to edit any facet of your animation, not just the begin-
ning and end. In the Motion Editor, you use straight lines, curved lines,
graphs, and grids, for example. In other words, the Motion Editor is a
virtual treasure trove for animators who want to precisely control every
facet of an animation. And yes, Virginia, the Motion Editor has scrubby
sliders.

Introducing the new tools

When you have new features, you have new tools. (It’s a law, you know.)
Many new Flash tools were created for use with the new features listed in
the previous section. Some of the other new tools have absolutely nothing to
do with new features, but are welcome additions to the Tools panel. The fol-
lowing list discusses the new tools and what you can do with them:

1~ 3D Rotation: Gives you the power to take an object for a spin. Create a
motion tween animation, add this tool, and spin gently (or not), and you
end up with a cool animation when the object appears to flutter through
space in three dimensions. Can you envision an animation of falling
leaves? This tool can do it.

~ 3D Translation: Has three axes — X, Y, and Z — that you use to move
an object left and right, up and down, forward and backward. We know
what you’re thinking: Flash is 2D. And you’re right. But in a motion
tween animation, this tool makes it possible for you to simulate a 3D
experience. Don’t preview animations made with this tool in front of
your pet because it may make the critter dizzy.

1~ Deco: Used with the default graphic to populate a Flash project with
vines and flowers. Or, you can use symbols from the document library
to put your own spin on the graphic created by the tool. You can also
animate the graphic created by the tool.

Book |
Chapter 1
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1~ Bone: Helps define the structure of your object when you delve into
the world of inverse kinematic animations. In essence, you use this tool
to give the object a skeleton. When you add bones to an object, Flash
creates a new layer named Armature. You can use as many bones as
you need in order to animate an object, and you can create additional
branches to create sophisticated animation. Yep, Flash is still 2D, but
this tool takes your animations to the next level.

~ Bind: Used in conjunction with the Bone tool, but, contrary to its name,
not to bind things. If an animation isn’t performing the way you want,
you use the Bind tool to tell Flash which points should be connected to
which bone.

1~ Spray Brush: Extra! Extral Read all about it: Creates graffiti in Flash
designer. You use this interesting addition to the Flash toolbox to spray
color that looks like it was applied with an airbrush. Or, you can load the
brush with a symbol from the document library and have some fun. You
can use this virtual spray gun to add decoration to any Flash project
with no toxic fumes or messy clean-up from clogged spray heads.

Flash CS4 and you

Like the proverbial well, Flash CS4 is deep. How deep you go is entirely up

to you. This book gives you a full-course serving of Flash, from soup to nuts.
And, the fact that this book is thicker than most phone books means that
Flash CS4 has lots of features. As card-carrying geeks and fastidious authors,
it’s our job to show as much as we possibly can about Flash CS4 in this book.
That’s why we give you eight minibooks to get the job done. It’s a smorgas-
bord with a heaping helping of everything Flash has to offer. The good news
is that if you need just a little snack, you can cut right to the chase and read
a minibook, or a chapter of a minibook.

There’s so much you can do with Flash that the mind boggles. If you just dip
your toe in the shallow end of the pool, you can create some awesome ani-
mations for Web pages. If you've ever seen Web site banners that move and
thereby move the visitor, you've seen only the tip of the iceberg. Figure 1-1
shows a Web site (phoenixfl.com) with an all-singing, all-dancing banner.

The Flash intros that were all the rage a few years ago have gone the way of
the dodo. Would you want to see the same thing every time you visit a cer-
tain Web site? Flashy intros fail to thrill after a couple of visits.
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Phoenix Industries, LLC

7 o Ly 1 2 7 =
Warchousing and Distribution Serv

Welcome to Phoenix

Opportunities

ections

#AlIB Certificates

Phoenix Industries, LLC, is a multi-temperature food grade storage and
distribution company strategically located in Winter Haven and Miami Florida. We
provide frozen, refrigerated, protective, and dry storage as well as distribution
throughout peninsular Florida. Other services offered are order pick, case pick,
repack, container loading/unloading, railcar loading/unloading, and LTL and
truckload distribution services.

Figure 1-1: If you use your imagination, you can see all the dancing text at the top of this page — or just visit

the site.

Here’s a taste of the interactivity that Flash CS4 provides:

’/

ActionScript: You can also use Flash to build full-fledged interactive Web
sites with all kinds of bells and whistles or flashy games. Interactive Flash
designs and games rely heavily on ActionScript. ActionScript 3.0 has
been around since Flash CS3. You can still create interactive designs
using ActionScript 2.0, but that version of ActionScript will eventu-

ally be relegated to history. In this book, we show you how to use
ActionScript 3.0. Although this version can seem a little daunting if you
want to create an interactive Web site, we do our best to demystify it

in Book IV. Figure 1-2 shows an interactive, online Flash portfolio for an
aspiring model (dasdesigns.net/demo).

Book |
Chapter 1
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Click a thumbnail to view a larger image

Portfalio 1 Portfolio 2 Contact

Phatas Copyright Doug Sahlin 2004

Figure 1-2: Interactive Flash Web sites are a thing of beauty and a joy forever.

~ Flash video: Flash video is a wonderful thing. Flash CS4 supports high-
definition video. And yes, you can put high-definition video on the Web
for visitors to see and enjoy. If you or a client records video using a stan-
dard camcorder, you still see great results when converting it to Flash
video. The file format for Flash Video is FLV.

1 Adobe Media Encoder: Flash CS4 also ships with the Adobe Media
Encoder, which makes it possible for you encode video while you sleep.
All you do is load the encoder with your videos, choose a setting for
each video, click a button, and let the media encoder do its thing while
you solve the world’s problems or tackle a less lofty goal. The media
encoder has a wide variety of presets, or you can modify a preset to suit
a particular video or Web site. We show you how to master the video
encoder and much more in Book VI. Figure 1-3 shows a Web site with
some Flashy video (www.antonioswinterhaven.com/video.htm).
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Those are just a few of the tasks you can do with Flash. As you become more Book |
familiar with the application, you may venture into creating games that can Chapter 1
be played online or on devices. When you’re armed with a creative mind,
Flash CS4, and a little help from your friendly authors, the possibilities to
create compelling content with Flash are virtually endless.

yse4 buriojdx3
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Figure 1-3: Flash video is squeaky clean, and it streams.

Exploring the Flash Workspace

The Flash CS4 interface has all the familiar parts you’ve come to know and
love in Flash CS3 — and a couple of new ones. Adobe’s first iteration of Flash
was CS3, and the interface looked decidedly Adobe. The Flash CS4 interface
is even more Adobe-like — if that’s possible. Adobe interfaces are similar

to German sports cars, where form follows function. The new interface has
been well thought out. In the following sections, we show you the nuts and
bolts of the interface and the manner in which it’s constructed. But, hey —
if you don’t like the way it’s constructed, we also show you how to decon-
struct it and set it up to your liking. Figure 1-4 shows the new interface in all
its glory.
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Now that you know what the new interface looks like, roll up for a magical
mystery tour of it. The lists in the following sections demonstrate the closest
we could come to an actual survey of the new workspace:

Display bar Menu bar Stage Property inspector Document library
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Figure 1-4: | cant find anything in this new interface. Please pass the GPS.

Getting to know the menu bar

When you create a new document in Flash, or open an existing one, the
menu bar changes to display all menu groups. It’s almost the same as the
one you came to know and love in Flash CS3, and it’s at the top of the inter-
face, which is why we decided to start there. The menu bar is divided into
the groups described in Table 1-1.



Table 1-1
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The Menu Bar Book |

Menu

Chapter 1
What You Can Do with It

File

Create new documents, open existing documents, and close and
save documents. You also find commands for publishing and print-
ing documents.

Edit

Cut, copy, paste, duplicate, and find objects; work with the
Timeline; and edit symbols, for example. Because Flash has many
Timeline commands, they're conveniently grouped on a submenu.

yse4 buriojdx3

View

Zoom in and out, change the level of magnification, enable rulers,
show the grid, enable snapping to other objects and the grid, plus
much more. The Go To submenu is especially useful because it lists
symbols in the document. Click a symbol name to go to that symbol.

Insert

Insert symbols, create motion or shape tweens that you use to
animate objects in your project, and create scenes. You can use
the Timeline submenu to create layers, layer folders, frames, key-
frames, and blank keyframes.

Modify

Modify the document, and modify objects in the document. Use
submenus to modify bitmaps (photorealistic digital images), sym-
bols, shapes, and the Timeline. You also find commands to trans-
form, arrange, and align objects.

Text

If you're going to have text in your document, you can use this
menu group to specify fonts, sizes, and styles, for example. You
can even find a command to check your spelling.

Commands

Although the name of this menu group may seem redundant, you
use the group to manage commands you create, find more com-
mands from Adobe, and run commands, for example.

Control

Navigate the Timeline; play, rewind, and test a movie; test a scene,
and much more.

Debug

Ensure that everything in your Flash production runs without a
hitch. When you debug a movie, you can stop it at critical points
to see what's happening and to make sure that any ActionScript
is executing as expected.

Window

Display Tools panels or libraries or switch to another workspace,
for example.

Help

Use this menu when you need to get by with a little help from
Flash — but not before you check the index in this book.
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Examining the display bar

This part of the interface changes to let you know where you're at in the
Flash universe. When you are working on the main Timeline, the current
scene is displayed. When you edit a symbol, the symbol name is displayed
with a Back button you click to exit Symbol Editing mode.

Additionally, the display bar contains these standard elements:
1~ Edit Scene icon: Click this icon to display all scenes in your production.

Click a scene name to edit it.

v~ Edit Symbol icon: Click this icon to display a list of the symbols in your
document. Click a symbol name to edit it.

1 Magnification drop-down menu: Change the magnification or fit the
project on the stage, for example. Figure 1-5 shows a symbol being
edited and the choices from the Magnification drop-down menu.

Edit Symbol

Edit Scene | Magnification

Fle Edit View Insett Modify Text Commands Control Debug Window Help Default v | =8 x
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Figure 1-5: Editing a scene.
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Taking the stage

Published Flash projects are known as mouvies, so it’s only fitting that the
spot where you do your animation wizardry is the Stage.

Exploring the panels

The default workspace has two panel docks: one on the right side of the
interface, and one on the bottom. The right panel dock is home to the docu-
ment library and the Property inspector. The lower panel dock is home to the
Timeline and Motion Editor. But nothing is cast in stone, of course. If you don’t
like this setup, you can customize it, a task we show you in a later section.

Property inspector

The Property inspector tells you

everything you want to know about

a selected object. You also use it ’—
FL

PROPERTIES

. D it
to modify the parameters of tools Wiy

used to create shapes, to change the
properties of an object on the Stage,

DancingTextBanner.fla

= PUBLISH
name (in Symbol Editing mode)
movie clips that will be accessed by Player: Flash Player 10
ActionScript, and much more. Script ActionScript 3.0
The Property inspector has a cha- Class: | | &
meleon nature. It changes on the ; ;

Profiles Default Edit...

fly when you select an object or it I
tool. Figure 1-6 shows the Property ATR Settings

inspector as a floating window,

displaying the parameters for a e BROCERTEE

document. FPS:
Size: 550 1400 px Edit...
Document library mm

The document library displays all
objects used in a Flash project and
helps you stay organized. You can
also check out items from the docu-
ment library for use in your current
Flash project. For that matter, you
can open a library from a differ-

ent document and use items from it Figure 1-6: Properties that aren’t on the real
in your current project. Figure 1-7 estate market.

shows a document library as a float-

ing window.

Book |
Chapter 1
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Figure 1-7: A library you don’t need a card for.

Timeline

The Timeline is sort of a roadmap: It shows you the frames, keyframes,
layers, and layer folders that were created for your Flash project. We show
you how to master the Timeline (which is shown as a floating window in
Figure 1-8) in Book III, Chapter 1.
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Figure 1-8: Timelines stand still for no man.
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Motion Editor Book |
The Motion Editor is a new addition to Flash. You can use it to precisely con- Chapter 1
trol the speed at which an animation starts and finishes. You can control other
parameters by using the Motion Editor, such as object opacity during the ani- m
mation. You can also add keyframes and manually adjust any parameter from =
within the Motion Editor. It’'s shown as a floating window in Figure 1-9. =
E
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Figure 1-9: The Motion Editor controls animations without inducing motion sickness.

Other panels
Flash has panels — lots of panels.
If you read the preceding sections, ALTGHN

you already know what to use the ;
panels for that are displayed in the Align:

workspace by default. Other panels B & & T @0 Oo Yo
remain incognito — wherever that Distrliatas stage:
is — until you select them from the T A ’“:I:-[-
Window menu. You can have as =s5= Pk ] O
many panels as you want floating in Match size: Space:

the workspace. You can also access =l 03 Bz =2 4k

panels by using keyboard shortcuts.

Figure 1-10 shows the Align panel. Figure 1-10: You can float panels in the
The little X icon at the top is used workspace.
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to close the panel, and the left-pointing —

double arrows collapse the panel to an
icon. Keeping a frequently used panel
in the workspace is an efficient way to
work. We give you the straight scoop
on individual panels when they’re
needed to perform a task.

Getting chummy with

the Tools panel

On the right side of the default work-
space, dangerously close to the docu-
ment library and a few scant pixels
away from the Property inspector, is
the lean, mean Tools panel. It’s lean
because it’s one tool wide and quite
tall, and it’s mean because it packs a
lot of wallop. The Tools panel gives
you the power to create and move
objects and do much more.

Figure 1-11 shows the Tools panel float-
ing in a separate window. The panel has
so many tools that some of them share
space on the Tools panel. Whenever
you see a triangle in the lower-right
corner of a tool, click it to have access
to the other tools that share the space,
as shown in Figure 1-11. The last tool
used is always displayed when multiple
tools occupy the same space.

Table 1-2 gives you the lowdown on
the tools at your disposal.

m [ | Rectangle Tool (R)
(3 Oval Tool (0}
E Rectangle Primitive Tool {R)
@ Oval Primitive Tool {0}
D PolyStar Tool

PERNS SRS/ BV REr>

o\
HE

L]

L

B o

Figure 1-11: A Flashy Tools panel, if there
ever was one.
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Table 1-2 The Tools Panel
Tool What You Can Do with It
Selection Select and move objects.

Subselection

Select points on a path.

Free Transform

Transform an object. You can resize an object proportion-
ately, change its width or height, and skew or rotate the
object.

Gradient
Transform

Transform the position of a gradient that fills an object. This
tool resides on a fly-out menu with the Free Transform tool.

3D Translation

Change the X, Y, and Z positions of an object in a motion
tween animation. Flash isn’t 3D, but the tool can make an
object appear as though it's traveling in three dimensions.

3D Rotation Rotate a tool along its X, Y, or Z axis in a motion tween anima-
tion. It works well for mimicking objects fluttering in space.

Lasso This tool is used to select objects, or round up if you will;
hence the name Lasso.

Pen Create paths. This tool has several buddies on the fly-out
menu that are used to add, delete, and convert anchor points
on the path.

Text Add text to a document. Flashes uses three flavors of text:
Static, Input, and Dynamic. Input and Dynamic text are used
in conjunction with ActionScript to accept text (Input text), or
display text (Dynamic text). Static text is used when you want
to display text, and can also be used to display hyperlinks in
a Flash project.

Line Create a straight line from Point A to Point B.

Rectangle Create rectangles and rounded rectangles.

Oval Create objects of the elliptical variety, known as ovals. You
can also use this tool to create objects that look like pies with
wedges and a piece missing.

Rectangle Create rectangles and rounded rectangles. The beauty of

Primitive using a primitive shape is that you can edit all its attributes at
any time by using the Property inspector.

Oval Primitive Create ovals that can be edited in the Property inspector any
time after they're created.

Polystar Create multisided polygons and stars.

(continued)
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Table 1-2 (continued)

Tool

What You Can Do with It

Pencil

In the Property inspector, specify the color and width of

the stroke and many other attributes. (This tool is the virtual
equivalent of a 2H Eberhard Faber pencil.) Flash smoothes
shapes that you create with the Pencil tool. You determine
how much smoothing by choosing a modifier from the bottom
of the Tools panel.

Brush

Add splashes of color to a Flash project, or, if you're really
talented, to actual artwork. You determine how the brush

stroke looks by choosing options in the Property inspector
and choosing modifiers from the bottom of the Tools panel.

Spray Brush

Add graffiti-like splashes of color to a document. You can
change the color that sprays out of the nozzle, or spray a
symbol from the document library out of the nozzle.

Deco

Draw a shape that looks like a flowering vine. You specify the
colors in the Property inspector, and you can also choose a
symbol from the document library for the leaf and the vine.

Bone

Create an inverse kinematics (IK) animation. You use this tool
to add bones to the object you're animating. The bones com-
prise the inverse kinematics chain: You tug on a bone and the
bones that are higher in the chain move.

Bind

Fine-tune an IK animation that's not performing up to snuff
(that's bound up, if you will). You use this tool to bind points
from an object with a bone.

Paint Bucket

Fill a shape with color or a gradient.

Ink Bottle

Change the outline (the stroke, in Flash-speak) of an object.

Eye Dropper

Sample afill color.

Eraser Erase parts of objects. You can specify how the tool works by
choosing a modifier from the bottom of the Tools panel.

Hand Pan from one part of the document to another.

Zoom Change the level of magnification. You specify whether the

tool zooms in or out by choosing a modifier from the bottom
of the Tools panel.

Stroke Color

Show the selected color for strokes (outlines) created with
the drawing tools.

Fill Color

Show the selected fill for shapes. Afill can be a solid color or
a gradient.

Default Colors

Revert the stroke and fill to the default colors, which are
black and white, respectively, just like in a newspaper.

Swap Colors

Swap the current stroke and fill colors.

No Color

Change the current color to no color.
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Customizing the Workspace Chater

If you're one of those right-brained people using Flash, which was obviously
designed by left-brained people, you’ll be happy to know that you can cus-
tomize the workspace to suit the way you work and, for that matter, think.
You can customize the layout of the workspace, the Tools panel, and much
more. If you're interested in changing the way the Flash workspace is set up,
the following sections are just for you.

yse4 buriojdx3

Customizing the Tools panel

The default Tools panel shows you every tool that the Flash designers have
known, and that’s quite a few tools. You'll be happy to know that if you don’t
use every tool on the Tools panel, you can customize the panel by removing
tools and rearranging the locations of the others. To customize the Tools
panel, follow these steps:

1. Choose Edit~>Customize Tools Panel.

The Customize Tools Panel dialog box appears (see Figure 1-12).

Customize Tools Panel
Available tools: Current selection;
il K LJ’ 3D Rotation Todl... % subselection Too...
i 0 ..J\. 3D Translation T...
P \& \'§+ Add Anchor Foin...
TN & Brush Tool (B)
ol ; Eonvert Anchor ...
— ; eco Tool (U)
Cdid ":’_ Delete Anchor P... i
Calle)
s
RVIEY

Figure 1-12: Create your own, special Tools panel.

2. Select the tool you want to modify from the facsimile of the Tools
panel on the left side of the dialog box.

The name of the tool appears in the Current Selection pane. If other
tools are available from a fly-out menu, they're listed as well.

3. Do one of the following:

® Make a tool available as a choice on a fly-out menu: Select the tool
from the Available Tools pane and then click Add. You can add as
many tools as you want to a fly-out menu.
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e Remove a tool from the Tools panel: Select the tool in the Current
Selection pane and then click Remove. This action leaves a blank
space on the Tools panel, which you fill by choosing a tool from the
Available Tools pane and then clicking Add.

4. Continue arranging the Tools panel to suit your needs and then click OK.

Voila — you have your own, special Tools panel.

You can always revert to the default Flash workspace by choosing Window=>
Workspaces=>Default.

Rearranging the workspace

The easiest way to change the Flash workspace is to change where items are
located. And, you don’t need an interior designer to show up with a bunch
of color swatches and talk about applying feng shui (whoever he is!) to your
space. Here are some ways to customize your workspace:

 Undock a panel. Click the panel’s title and drag it into the workspace.

1~ Dock a floating panel. Click the panel’s title bar and drag it to the one
of the interface sides. When you see an opaque vertical bar, release the
mouse. The panel docks to a side of the workspace. When you see an
opaque, horizontal black bar, release the mouse to dock the panel at the
top or bottom of the workspace.

1 Dock one floating panel with another. Drag one panel’s title bar toward
the other panel. When an opaque blue overlay appears over the other
panel, release the mouse button to dock the panels together. If you see
an opaque blue line appear over the panel to which you're docking, the
panel you're moving docks on top of the other panel.

1~ Change the size of a panel. Move the cursor toward a corner of the
screen. When the panel becomes a line with a double-headed arrow,
click and drag to resize the panel.

Saving a custom workspace

When you rearrange the workspace to suit your preferences, Flash remembers
the setting when you close the application. The next time you launch Flash, all
the panels and Tools panels are right where you left them. However, if another
Flash designer shares your computer, she may want to arrange the workspace
differently. After she uses the computer, you're stuck with her custom work-

space, and a Battle of the Designers ensues. This unfortunate situation doesn’t
have to happen. You can save a custom workspace by following these steps:

1. Rearrange the workspace to suit your needs.



Customizing the Workspace 27

2. Customize the Tools panel. Book |

If you don’t know how to customize the Tools panel, we show you how A0

in the section “Customizing the Tools panel,” earlier in this chapter.

3. Choose Window->Workspacer>  (‘jaw Workspace
New Workspace.

Mame:

The New Workspace dialog box
appears (see Figure 1-13), in
which you can save a custom IE

workspace for posterity.

yse4 buriojdx3

4. Enter a name for the workspace. Figure 1-13: Saving a custom workspace.
5. Click OK.

The new workspace is saved and is added to the Workspace submenu.

<MBER To change from the current workspace to a saved workspace, choose
Window>Workspace, and then click to select a workspace. Figure 1-14
shows a custom workspace that Doug created, which looks a lot like the
Flash CS3 workspace. If you don’t like the new workspace, you can create a
reasonable facsimile of the old one.
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Figure 1-14: A custom workspace that looks vaguely familiar.
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Managing workspaces

Flash designers and developers can change their minds whenever they want.
If you've experimented with different workspace designs and find that you
have too many lurking about on the Workspaces submenu, you can alleviate
the clutter by managing your workspaces as outlined in these steps:

1.

Choose Window=>Workspacesr> | Manage Workspaces
Manage Workspaces. S
The Manage Workspaces dialog
_Rename...

box appears (see Figure 1-15).
You can manage your custom ]
workspaces at any time.

. Select the workspace you want
to modify.
From here, you can either Figure 1-15: Managing custom workspaces.

rename or delete the workspace.

To rename the workspace, follow these steps:

1.

3.

Click Rename to rename the selected workspace title.

The Rename Workspace dialog box appears.

. Enter a new name for the workspace and click OK.

The workspace is renamed.

Click OK again to close the Manage Workspaces dialog box.

To delete the workspace, follow these steps:

1.

Click Delete.

Flash displays a message box telling you that the deletion cannot be
undone.

Click Yes to delete the workspace, or No to save the selected workspace.

If you click Yes, the workspace vanishes into the great cyberspace ether.

. Click OK to apply your changes.

Your changes are saved, and the Manage Workspaces dialog box closes.

Changing keyboard shortcuts

Keyboard shortcuts are tremendous timesavers. (Doug uses them all the
time.) Adobe has a default set of keyboard shortcuts for Flash CS4, which
may or may not be ideally suited to your working preferences. For example,
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if you remember a set of keyboard shortcuts from another application that

has commands similar to Flash and the Flash keyboard shortcuts are differ-
ent, you can modify the default set to match the shortcuts you memorized.

To change keyboard shortcuts, follow these steps:

1. Choose Edit~>Keyboard Shortcuts.

The Keyboard Shortcuts dialog box appears (see Figure 1-16).

Duplicate Set

Keyboard Shortcuts

Current set: | Adobe Standard

Commands: | Drawing Menu Commands

» @6 BT

[ File

[# Edit

B View

# Insert

[# Modify

B Text

# Commands
# Control

[# Debug

g T T

Description;

Shortcuts: &+ | —

Press key:

[ CK H Cancel I

Figure 1-16: Use this dialog box to make keyboard shortcuts work the way you want.

2. Click the Duplicate Set button.

The Duplicate dialog box appears. You cannot modify the default set,
but you can modify a duplicate set.

<P To match the keyboard shortcuts of popular applications, choose a set
from the Current Set drop-down menu. You can choose to match the
keyboard shortcut set of applications such as Flash 5, Photoshop 6, or

[llustrator 10, for example.

Book |
Chapter 1
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10.

11.

. Enter a name for the duplicate shortcut set.

You can give it any name you want. However, if you're creating multiple
keyboard shortcut sets, it makes sense to give the keyboard shortcut a
name that reflects the task for which you use the shortcut set; for exam-
ple, My ActionScript Shortcuts.

. Choose an option from the Commands drop-down list.

The list includes all command groups, such as Actions Panel Commands,
Debug Movie Commands, and Drawing Menu Commands.

. Click the plus sign (+) icon next to a command group.

The command group expands to display all commands.

. Select the menu command for which you want to assign a keyboard

shortcut, or change an existing keyboard shortcut.

If the command has a keyboard shortcut, it’s displayed in the Shortcuts
pane. If the command doesn’t have a keyboard shortcut, the pane is
empty.

. To create a keyboard shortcut for a command the doesn’t have one,

click the plus sign to the right of the Shortcuts title.

The word <empty> appears in the Shortcuts pane and the Press Key pane.

. Press the key sequence you want to use as a shortcut for the command.

You can use keys such as Backspace or Delete or the arrow keys without
a modifier. If you use a letter or number for a shortcut, you must use it
in conjunction with the Ctrl key; for example, Ctrl+T. If you press a key-
board shortcut used by another command, a warning message appears
underneath the Press Key pane.

. Press Change to apply the keyboard sequence to the command.

If you choose a keyboard sequence assigned to another command, the
Reassign dialog box appears. Click Reassign to reassign the keyboard
shortcut sequence or press Cancel. When you reassign a keyboard
shortcut, it’s no longer associated with the other command (to avoid
any potential conflicts).

Continue modifying and adding keyboard shortcuts to suit your work-
ing preferences.

Click OK to apply the changes to your new keyboard shortcut set and
then close the Keyboard Shortcuts dialog box.

The new keyboard shortcuts remain in effect until you invoke the
Keyboard Shortcuts command again and choose a different keyboard
shortcut set from the Current Set drop-down menu.



Customizing the Workspace 31

Setting Flash preferences

Flash is a popular application that’s used by a wide variety of people. Some
of them are card-carrying geeks, like your friendly authors, and others are
mild-mannered designers. Yes, even some soccer moms use the application
to create cool animations for their kids’ soccer teams.

Of course everyone is different and works differently, so you’ll be glad to
know that, in addition to modifying the Tools panel, workspace, and key-
board shortcuts, you can change other Flash elements to suit your own
working preferences. For example, if you’ve worked behind a computer so
long that the text in the Actions panel looks positively miniscule, you can
change the font type and size by modifying ActionScript preferences.

If we showed you the steps involved to modify every single Flash preference,
our editors would pull their hair out because we would exceed our allocated
page count. Besides, many of the options are self explanatory. The following
steps give you a jumping-off point:

1. Choose Edit-oPreferences.

The Preferences dialog box appears (see Figure 1-17).

Preferences
Categary General
General
ActionScript On launch: | Welcome Screen hd
Auto Format
Clipboard
Drawing Undo: | Documentdevel Undo -
Text
Warnings 100 | levels
Workspace
PSD File Imparter Workspace: [ | Open test movie in tabs
AL File Importer [[] auto-Collapse Icon Panels

Selection; [¥] shift select
Show tooltips
Contact-sensitive Selection and Lasso toolks
Show axes for 3d movie dips

Timeline: [ ] Span based selection
["IMamed anchor on Scene

Highlight color: () Use layer color

(o} .| Drawing objects
E. Drawing primitives
W% Groups
¥ Symbols
B Other elements

Project: [¥] Close files with project
[[]save files on test or publish project
Version Cue: [_| Enable Version Cue

Printing: || Disable PostSeript

Figure 1-17: You can change Flash preferences to suit the way you work.
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2. Choose the category you want to modify from the Category pane.

The title changes and the dialog box is updated to show the options you
can modify.

3. Modify the options however you want.

Most options are self explanatory. For example, if you use Adobe
Illustrator to create artwork for your Flash projects, the options in the Al
File Importer category should be familiar to you. If you don’t use Adobe
[llustrator to create artwork for your Flash projects, you have no busi-
ness mucking about in that category.

4. Continue modifying categories and options as needed.

5. Click OK to apply the changes and close the Preferences dialog box.



Chapter 2: Introducing Graphics,
Symbols, and Animations

In This Chapter

1~ Creating good-looking graphics in Flash
»~ Introducing symbols and instances
v~ Flash Animation 101

Fash is an extremely versatile application. You can create interactive
Flash projects with audio and video and other bells and whistles. But
Flash’s humble beginnings were all about graphics and animations. Combine
great-looking graphics with interactivity, and the sky’s the limit.

If you're a first-time user of Flash CS4, you might
feel like a kid in a candy store — you literally want
to experiment with every tool. But, like anything
else that’s new, before you dive into the deep
end of the pool, you have to dip your toe in the
shallow end. In this chapter, we show you what
you can accomplish with the Flash tools, and we
introduce you to the backbone of any lean, mean
Flash production: symbols, which are reusable
graphics. But we're getting ahead of ourselves. In
this chapter, you get an introduction to the type
of things you can create with the drawing tools,
plus an introduction to symbols and the docu-
ment library.

Working with Flash Graphics

Great-looking graphics separate a ho-hum Flash

production from something that grabs viewers by the scruff of the neck and
makes them want to view the entire project, whether it’s a game, an interac-
tive Web site, or a great-looking Flash banner on a Web site. If you're artis-
tically inclined, you can use the Flash drawing tools to create compelling
graphics. In the following sections, we introduce you to some of the things
you can accomplish using the drawing tools and the Text tool, and we show
you how to get colorful with the Swatches panel.
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Creating graphics with drawing tools

Flash has a plethora (one of Doug’s favorite words) of drawing tools. You
can draw lines, rectangles, ovals, polygons, and stars. You can use several
tools to create a finished drawing. For example, to create a facsimile of a
storefront, you can use the rectangle tool to create the basic shape and win-
dows and then use the Oval tool to create some objects in the store window,
the sun, and perhaps a sign or two. If you have a street in your project, you
can use the Polystar tool to create a stop sign. Figure 2-1 shows a logo that
was created with the Primitive Oval tool and the Text tool.
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Figure 2-1: Colorful logos are a snap to create with the drawing tools.

The Pencil and Brush tools

If you know how to get the most out of a pencil or a paint brush, you’ll be
happy to know that Flash has the digital equivalent of these tools in its Tools
panel. When you create graphics with the Pencil tool, you can modify the
tool so that each stroke you draw is a separate object, or you can use the
old paradigm of the Flash drawing tool, where each stroke of the same color
develops a magnetic attraction to those you draw over. The Brush tool also
works in a similar manner. If you're drawing with these tools using a mouse,
Flash automatically smoothes the shape after you draw it.
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Use a pressure-sensitive tablet and stylus to gain precise control over your
work. Flash still smoothes the lines and brush strokes you draw, but the
resulting artwork looks more professional.

The Pen tool

Another drawing tool in the Flash Tools panel enables you to create shapes
and paths with point-by-point accuracy. If you work with illustration pro-
grams, you're familiar with what the Pen tool can do. If you don’t work with
illustration programs and you’re brand-new to Flash, you create paths with
the Pen tool. The path is composed of points, which come in two flavors:

v~ Straight

1 Curve

You use the Pen tool to create an open path (a series of connected points
resulting in a curved line or several connected straight line segments), or a
closed path (an outline or solid shape filled with color).

The control you have with the Pen tool enables you to create sophisticated
shapes and artwork. You can edit the paths by moving the points or by
changing straight points to curve points and vice versa. You can also edit
curve points by changing the tangent handles. If you're new to the wonderful
world of paths and Bezier curves, we give you a full-course serving in Book II,
Chapter 1.

If you own Adobe Illustrator, you can use the program to create vector art-
work for your Flash projects. lllustrator has a robust toolset for creating
sophisticated vector illustrations. You can import Illustrator artwork into
Flash and preserve layers, and you can import an Adobe Illustrator EPS file
or Adobe PDF file by saving it in the Al format and then importing the file
into Flash. You can also import the file to the stage or into the document
library.

Introducing the Text tool

If you have (or your client has) something to say and you're going to say it in

Flash, you have to use the Text tool. Text in Flash comes in three flavors:

1~ Static: Displays text in a document. When you create the text, you can
specify the font type, size, and color, for example. You can even embed
fonts that may not be on your viewer’s computers.

v Input: Captures user input.

 Dynamic: Creates a text field that can be dynamically changed during
the course of a Flash movie. You use ActionScript to determine the text
that’s displayed in the field. You can also convert text into a vector

Book |
Chapter 2
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object that can be manipulated on a point-by-point basis. Figure 2-2
shows a published Flash movie in which the Text tool was used to
create informational text, text for the navigation menu, and text for the
banner.

i x_tremesports.swf B[]

File View Control Debug

Welcome to X-treme Sports. Whether
your sense of adventure takes you
above the water, below the water, or
to the open road, you've found your
source for the ultimate in equipment,
apparel and adventures.

Browse through our online catalog and
you're sure to find something to satisfy
your need to take it to the limit.

Figure 2-2: Using the Text tool for fun and profit.

Getting colorful

A Flash production without color would be, well black and white. And a day
without sunshine is night. But seriously, if you're going to attract visitors to
a Flash Web site or create Flash projects for a living, you have to use color.
We don’t tell you which colors to use, but we do show you how to specify
which colors are used for object strokes, fills, and backgrounds, for example.
Figure 2-3 shows the Color panel, which has been used to mix the radial gra-
dient that you see as the background for the Flash project.

You can use solid colors or gradients as fills:

1 Solid color: The Solid Color option fills an object with one color. (We
know that seems blatantly obvious, but we have to cover all the bases.
You never know when an alien might find our Internet and download
this book in electronic format.)

1~ Gradient: A blend of two or more colors. You can create one of these
types of gradients:
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e Linear: Blends colors from Point A to Point B in a straight line

=]
=]
(=]
=~

* Radial: Blends colors from the center out in a concentric pattern A

e Bitmap: Uses a photograph as the fill
Use the default colors and gradients from the Swatches panel, or mix your

own by using the Color panel. After you master working with colors, you can
create cool items, such as facsimiles of tie-dyed T-shirts and much more.
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Figure 2-3: Add a splash of color to create a compelling Flash movie.

Finding Out about Symbols and Instances

Symbols and instances are the lifeblood of any Flash project. When you use
instances of symbols rather than create a new symbol every time you need
one, it’s like feeding your Flash project one of those diets used by the rich
and incredibly vain (diets with fancy names that are copyrighted and there-
fore can’t be used in our book). That’s right: Symbols decrease the file size
of a published Flash project.
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You can create a symbol from scratch or convert an object to a symbol.
Symbols are stored in the document library. When you use a symbol in a
Flash project, you're creating an instance of a symbol. And then disaster
strikes. Suppose that the client (the guy with the fat wallet) calls you up and
tells you that he wants to change the color of the soup can symbol, which is
used a gazillion times in the project, from green to red. When this happens,
you must be stern and tell the client that completing this task will take a
long time. Then when you hang up the phone, you simply edit the symbol
and change the color from green to red, and each instance of the symbol is
instantly updated.

Understanding graphic symbols

Graphic symbols are static symbols that you create by using drawing

tools or by importing vector artwork from an application such as Adobe
[llustrator. When you create complex graphic symbols that are composed of
many objects, you use layers to segregate the objects, which makes it easy
to edit complex symbols.

You can also use an image as the basis for a symbol. This capability is useful
when you need to display the image several times in a Flash project or ani-
mate the symbol. That’s right: You can animate graphic symbols, and they’re
static. The later section on animation makes this perfectly clear.

Buttons, buttons, and more buttons

Buttons are everywhere. You see them on jackets and shirts and on Web
sites. It’s the clickable type we're referring to, although you can create a
graphic symbol that looks like a shirt button. A button in Flash is a symbol
with four states:

» Up
» Down
» Over
1~ Hit

The graphic in each state defines what the viewer sees when the button is
first visible, when the cursor is paused over the button, and when the button
is clicked. The Hit state defines the size of the active area of the button. You
can create multiple layers when creating a button. You can also use sounds
in a button. For example, if the button is used for a shopping cart checkout,
you can have a “ka-ching” sound play when the button is clicked. Figure 2-4
shows a button being created.



Finding Out about Symbols and Instances 3 9

m Fle Edit View Insert Modfy Text Commands Control Oebug Window Help | | Defautt v | -8 x

| PROBERTIES | LisRARY | =

[ Xtremesports fia > &= @

XtremeSports.fla® x

50 flems | |

Yame A Lk
[2) Bar 1=
¥ [ suttons
¥ Accessories
%) Adventures
l'f) Apparel
& Diving
" Equipment
& Events
") Home
) invisible buton
) Rafting
" Running
) shoes
& surfboards
) surfing
[5) captions
) dd background
dive G
[Z] diverpownipg
[ diving =
™| 7 [¥ Graphis:

. —— — 9 Symbol2

TmeLtve ORI EDTORS = @EW
@0 U |G oo w I Raft ]

JEr 2 B . | B [0 Raftss =5

q Layeri oo He 20| @] rsfterspg o

) rafting

[£] Randem quote

[ Run

e

[%) Running BG

IEVISE 2] I —

UG SRS E >0 rE

s

<

cHle B £

< 2

(L
cn
£

al o F b EE Ry 2wk gas [ ] »

Figure 2-4: As Wimpy might have said, click me today and I'll gladly pay you on Tuesday.

Changing movie clip properties

Movie clips serve several purposes: You can use them as self-contained
animations, as targets for external content that will be loaded into a project,
or as containers for ActionScript. You create a movie clip when you want

to create multiple instances of an animation in a Flash project. Why work
harder when you can work smarter instead?

Movie clips can also be addressed by ActionScript. You can use ActionScript
to change various properties of a movie clip. For example, if you want the
movie clip to change dimensions, give the Movie Clip instance a name, and
then change its .xscale and .yscale properties. Figure 2-5 shows a movie clip
on the Stage that’s being addressed by ActionScript. Notice that the instance
name in the Property inspector is also present in the Actions panel. We
show you how to control movie clips in Book IV, Chapter 1.
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Checking out symbols from the library

When you create a symbol, it’s added to the document library. Each symbol
type can be identified by a unique icon. When you select a symbol, you see a
preview at the top of the library. If the symbol is a movie clip, you can play it
before adding it to your production.

Tools in the library make it possible for you to segregate objects into fold-
ers. This capability is useful when you have a huge Flash show with lots of
graphics, movie clips, and buttons. You can create a folder for each symbol
type, as shown in Figure 2-6. When you finish perusing a folder, you can col-
lapse it to get a better look at the other items in the document library. You
can also modify objects from another document library to suit the current
document.
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Figure 2-6: Be quiet, numbskull. You're in the document library.

Introducing Flash Animation

Flash began life as the animation program FutureSplash. Macromedia bought
the application and developed it, and then Adobe bought Macromedia and
developed Flash into the application you use today. In every iteration of
Flash, animation has always been a strong Flash feature. And it’s gotten even
better with Flash CS4. In the following sections, we introduce you to Flash
animation, and we cover the topic in more detail in Book III.

Frame-by-frame animation (the old school )

If you've watched cartoons, you've seen frame-by-frame animations at work.
Artists draw the characters in different poses and motions. The whole thing
is assembled as a video, and you see seamless motion. Flash gives you easier
ways to create animation. However, frame-by-frame animation can some-
times still be used to good effect without causing you to break much of a
sweat. You have to create lots of frames, however. Creating an image slide-
show and typewriter text are two uses we can think of for frame-by-frame
animation. Figure 2-7 shows the timeline for a frame-by-frame animation.
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Figure 2-7: Let's see — one frame for each letter and then. . ..

Motion tweening will move ya

Suppose that your client wants, on the home page of his Web site, a Flash
animation that moves an object from Point A to Point B to Point C. If you are
new to Flash and just finished reading the preceding section, on frame-by-
frame animation, you're probably thinking, “Yikes. That will take three fore-
vers.” Calm down, Flash Grasshopper. Breathe deeply and chant the mantra:
Motion tween. When you need to create a complex animation, you create the
symbol you want to animate (or not) and then choose Motion Tweening, and
Flash creates the in-between frames. Get it? In between! Motion Tween.

After Flash creates the initial frames, you can add frames and keyframes to
create the animation you want. And, if that’s still not enough, you can tweak
the animation 57 ways to Tuesday in the Motion Editor. Figure 2-8 shows a
motion tween animation. We enabled onion skins so that you can see each
frame of the animation. If we add ActionScript, we can have a “Twinkle, twin-
Kkle, little star” motion tween animation.
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Figure 2-8: An animation that’s not between a rock and a hard place.

Shape tweening will morph ya

Did you ever wish that you could change one thing into another — such

as turn your former significant other into a piece of coal? Flash can’t help
you with your significant other, but it can morph one shape into another by
using shape tweening. All you have to do is create two keyframes on which
there are two separate shapes, apply shape tweening, and watch the fun
begin. There’s a bit more to it than that, so we show you how to morph the
shape of your choice into another shape in Book IIl, Chapter 2.

Figure 2-9 shows a Shape Tween animation in which a star is morphing into
an oval while moving. Onion skins are enabled so that you can see the in-
between frames. If the thought of onion skins brings you to tears, you prob-
ably haven’t tweaked a Shape Tween animation, a task we show you how to
do in Book I, Chapter 4.
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Figure 2-9: Morphing magic with shape tweening.

Inverse kinematics is bad to the bone

Character animation is loads of fun. (Doug did a lot of character animation in
3D programs.) Now you can create 2D character animations in Flash. If you
want a character to strut her stuff into your Flash project, you can do so by
creating an Inverse Kinematics animation. After you create your character
using Flash drawing tools, you use the Bone tool to give the character form.
And, if your character is a dog, for example, you use the Bone tool to give
the dog a skeleton (see Figure 2-10).

If the animation doesn’t play properly, you use the Bind tool to unbind the
parts that were bound and determined to not make your animation run
smoothly. We show you how to bone and bind in Book III, Chapter 2.
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Chapter 3: The Engine Beneath
Flash: ActionScript 3

In This Chapter

+~ Understanding what you can do with ActionScript 3
1~ Placing ActionScript on the Timeline

» Communicating with buttons

1~ Providing information just in time

~ Exploring ActionScript levels

A ctionScript 3 is the programming language that can be used with Flash
CS4. If you’re new to Flash, you will find ActionScript to be a powerful
and extensive language. However, you will also
find that just a little goes a long way. Experienced
Flash hands will see how to use ActionScript and
shift from many of the old practices to new tech-
niques for getting the most out of ActionScript 3’s
new features.

Book IV, which is dedicated to ActionScript 3,
guides you through several uses of ActionScript
and its levels of sophistication. In this chapter, we
provide you with an introduction to ActionScript
and tell you how to start using it. Also, if you

have used ActionScript in Flash CS3, you will be
delighted to find that the CS4 version has changed
little from the CS3 version, which means that you
don’t have to figure out how to use the language
all over again (as has often been the case in past
revisions).

Understanding What ActionScript 3 Can Do for You

We like to treat ActionScript as the engine beneath your Flash creation.
Think of it as you would after building a beautiful automobile chassis and
body: You need an engine and a steering mechanism to make the device go
and to guide it through the many different possibilities you plan for your
project.
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Suppose that you build an eye-catching animation with a beautiful design
and that viewers see your Flash page on the Web. The first time a viewer
sees your page, she’s impressed and shows it to her friends. After a few
views of the page with your animation on it, however, the viewer becomes
bored. It’s similar to telling a joke: The first time you tell it, it’s funny.
However, with every retelling, the joke loses its flavor and you need to dip
into your repertoire to pull out another one. Unless you want to go through
life repeatedly telling the same joke (or repeatedly showing the same Flash
movie), you need ActionScript in order to make practical and interesting
Web sites with Flash CS4.

Controlling the Timeline

In many ways, the Flash Timeline is like a runaway train: After the playhead
starts moving through the different frames and your animation begins, the
viewer can do nothing other than watch whatever you created. In even the
earliest versions of Flash, the software engineers realized that Flash viewers
needed some way to start and stop the playhead on the Timeline. Thus, the
first ActionScript version consisted of a simple set of commands to control
the Timeline. (It was ActionScript in diapers!)

To let viewers control the playhead, early versions of Flash had Button
symbols that could be programmed with ActionScript. The Button symbols
were bandwidth friendly because, as symbols, they could be reused as dif-
ferent instances. You could create a single Button symbol and then make
100 instances, and only a single symbol’s code was hauled over the Internet.
(Buttons are still bandwidth friendly, as are movie clips.)

When ActionScript was updated, the plan of putting it into buttons and
movie clips got progressively worse. The more movie clips and buttons in

a Flash application, the more little pieces of disconnected ActionScript that
need to be dealt with. Trying to track down hundreds of buttons and movie
clips that had snippets of code on each one was similar to playing Where’s
Waldo? in a house of mirrors. Even the addition of Movie Explorer was of
little help because, after you located the code in Movie Explorer, you had to
try to find the object’s frame in what might be a very long Timeline with lots
of layers.

With ActionScript 3, Flash’s key language is no longer at the proverbial chil-
dren’s table of Internet programming languages. ActionScript is all grown up
now, and although many users miss the old ways, it’s similar to missing a
bad habit, such as smoking. So use the new ActionScript to see how to move
along the Timeline without adding code directly to the button. (See Book 1V,
Chapter 1 for a more detailed example.)
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Working with the Timeline

In a nutshell, working with the Timeline, you must

1 Make a button. You can do it on the Stage or by using ActionScript.

1~ Attach a listener to the button. The listener tells the button what to
listen for — usually a click on the button.

1 Write a function that alters movement on the Timeline. Actions include
moving to a frame and stopping, moving to a frame and restarting stopped
movement, or starting play from the Timeline’s current position.

Of course, the best way to show this process is to create an example.

Creating Timeline Functions with ActionScript

In this section, you create two buttons: a winning choice and a losing choice.
(If only life were that simple! Sigh.)

Creating two buttons

To create the buttons, follow these steps:

1. Open a new Flash file (ActionScript 3), and save it as Fate.fla.

2. Add two layers by clicking the New Layer icon below the Timeline,
naming the top layer Actions, the second layer Frames, and the bottom
layer Buttons, as shown in Figure 3-1.

3. In the Actions layer, click Frame 3, and press F5 to insert keyframes
out to Frame 3.

4. In the Frames layer, click Frames 2 and 3, and press F6 to add
keyframes.

5. In the Buttons layer, click Frame 3, and press F5 to add three frames.
6. Click the lock icon in both the Actions and Frames layers.

This step locks the layers to help prevent you from making mistakes.
7. Click the first frame of the Buttons layer.

8. Using the Oval tool, draw a circle to be used as a button; select the
oval and press F8 to open the Convert to Symbol dialog box.

9. Type Btn for the name, select Button as the type, select the Export for
ActionScript check box, and click OK.

(If you don’t see the check box, click the Advanced button.)

Now you should have a button on the Stage.
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Figure 3-1: Setting up layers in an application.

10.

11.

Select the button, and while holding down the Ctrl key (the Option
key on the Mac), drag the button to create a duplicate.

Position one button above the other.

Formatting the buttons

Now you’re ready to apply some properties to the buttons. Follow these
steps:

1.
2.

S ook oW

=

Select the top button by clicking on it.

Choose Windowr>Properties (Ctrl+F3, 38+F3 on the Mac) from the
menu bar to open the Property inspector. In the Instance name box,
type Win, as shown in Figure 3-2.

Select the bottom button.

In the Instance name box of the Property inspector, type Lose.

Next to the top button, type Win; next to the bottom button, type Lose.
Lock the Buttons layer by clicking the column beneath the lock icon.
Alock icon appears in the layer.

Unlock the Frames layer by clicking the lock icon.

8. Click the first frame, and select the Text tool.

9. Select a 36-point font, and type Choose your fate (see Figure 3-3).
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10. Select Static Text in the pop-up menu in the Property inspector, if it
isn’t already selected.

11. Click the second frame, and then using the Text tool, type You won!
You can program in ActionScript 3.0.

12. Click the third frame with the Selection Tool, and then with the Text
Tool, type You lost your fear of programming in ActionScript 3.0

13. Lock the layer.

Adding the ActionScript

The last part of the process is adding the code. Follow these steps:

1. Click the Actions layer, and choose Windowr>Action.
The Actions panel opens.
2. Click inside the Actions panel and add the following script:

stop () ;
Win.addEventListener (MouseEvent .CLICK,goWin) ;
Lose.addEventListener (MouseEvent .CLICK, goFearless) ;

function goWin (e:MouseEvent) :void
{
gotoAndStop (2) ;

}

function goFearless (e:MouseEvent) :void

{
gotoAndStop (3) ;
}

3. Save the . £la file.

The ActionScript’s actions

The following points show exactly what the ActionScript did to the flow on
the Timeline:

1. The playhead was stopped with the stop () statement.

2. The event listener was added to both the Win and Lose instances of the
buttons. Each one listens for a button CLICK.

3. The Win button’s function is gowin () ; the Lose button’s function is
goFearless (). Each function moves the playhead to the appropriate
keyframe.
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As you can see, the example used the simple sequence of Make (you made Book I
the button), Listen (the button listened for the CLICK), and Action (the Chapter 3
ActionScript functions moved the playhead where specified.) —
o =
Test the movie by choosing Control=>Test Movie. The message you see Z E-:
depends on which button you click. Figure 3-4 shows what happens when E‘E.
you click the Lose button. s 3
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Figure 3-4: Clicking the Lose button leads to this output.

Bringing in New Objects

One persistent challenge in developing Web sites — whether it’s in HTML
or Flash or any other Internet language — is sending an object over the
Internet. The size of the object you're sending determines the experience of
the person on the receiving end.

Big objects take more time to transport than small ones do. Suppose that
you’re making a Flash site for a travel agency. The agency wants a Flash ani-
mation on every page along with a photograph to accompany the animation.
The site will have a total of ten pages. Your client tells you that under no cir-
cumstances can any page be larger than 50KB. However, because you know
Flash, you want to place each page in a keyframe with each one taking up

no more than 50KB. By using buttons to control the Timeline, you can then
have viewers quickly change content, including the animation and graphic.
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If you place all ten elements in the Flash document at the same time, it has
a load cost of 500KB. That takes a while to load, and impatient users may
not wait — the deadly Back button in a browser always beckons whenever a
page loads slowly.

On the other hand, you can display ten pages by using ActionScript to load a
movie clip whenever it’s needed. At only 50KB, the clip should load quickly,
and users may not even be able to notice. Also, after the materials are in the
cache (temporary memory), they load even more quickly the second time
around. The other pages simply wait on the server until requested. Because
the pages aren’t loaded, users don’t have to wait for pages they haven’t
asked to see.

Figure 3-5 illustrates the difference between the two approaches.

=500KB

All objects are loaded
atonce.

=50KB

Only one objectis
loaded at one time.
All others wait for
arequest.

Figure 3-5: Loading all at once and loading on request.
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Both techniques require ActionScript, and because it makes more sense in
the context of real-world Web use to load pages only when requested, that
technique is the one you want to use. (See Book IV for examples.)

You reuse the same code repeatedly. Just dust off the old code and reuse it
whenever you need it. There’s no sense in reinventing the wheel every time
you use ActionScript.

Providing information just in time

The concept of organizing your Flash application so that ActionScript

loads materials only when requested is related to another important
consideration — getting what you want when you want it. Some materials may
be requested, but the information need not be in front of viewers until a speci-
fied time. For example, a recipe doesn’t require its baking instructions until

all the ingredients have been prepared and mixed. Other types of information
may arrive in real time, such as a Web service that tracks thunderstorms. By
breaking down tasks into smaller parts and keeping them on the server until
needed, you avoid cluttering your screen or overworking your computer’s
processor. You get what you need just in time.

Organizing tasks
When you’re developing Flash Web sites, you can depend on two events
taking place:

1. Your site will change.

2. Your site will grow.

By breaking down a Flash site into smaller parts and using ActionScript to
control those parts, you make your life easier. Suppose that a client runs a
grocery store and wants to run weekly specials, and that you have to change
the site weekly. If that client then decides to expand her services to include
a soup-and-salad bar, you have to add another component. Figure 3-6 com-
pares two ways to approach that problem.

By taking a more granular approach to your application, you create far more
flexibility for growth and change. The “parts” are really just little Flash pro-
grams in . swf format. These smaller Flash files (in . swf format) make it
easy to find out about Flash and to build sophisticated applications.
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Single SWFfile Controlled by

ActionScript

Change requires that the
whole application be
changed.
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I
Only the new ! !
element needs — I
to be added. X :

I

Figure 3-6: Organizing for change and growth.

Looking at the Many Levels of ActionScript

Working with ActionScript 3 in Flash CS4 provides you with a wide range of
options. Flash CS4 can use earlier versions of ActionScript (ActionScript 1 and
ActionScript 2), but we don’t cover these earlier versions. ActionScript 3 was
introduced in Flash CS3, so it’s not even brand-new. If we were to spend time
discussing earlier ActionScript versions, we would just be going backward,
and many of the functions in those earlier versions have been deprecated.

The Timeline code

If you use ActionScript on the Timeline, you're best served by keeping it in
a single frame on a single layer. It can be tempting to add code in keyframes
wherever you think you need to, but you can bet that doing so will lead to
problems. As you can see in Figure 3-1, the top layer is the Actions layer,
and you can see in the first frame the little a, indicating that the frame has
ActionScript.

When you place your script on the Timeline, use the Actions panel. It helps
you write ActionScript and provides aid in the form of code hints and avail-
able options. Figure 3-7 shows the Actions panel and all its parts.
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Figure 3-7: The Actions panel.

For the most part, you just use your keyboard to write in ActionScript.
However, the following list briefly describes each part of the panel:

» Toolbox: A library of ActionScript language that’s organized into classes.
At the end is an index with all the terms arranged alphabetically.

1~ Script Navigator: Helps you find where you placed your code. Put it all
in one place, and the Script Navigator shows the current selection and
scene with ActionScript. (If you put your code all over the place on the
Timeline, the Script Navigator can’t save you! You still have to select
each element with ActionScript to show it in the Script Navigator.)

Book |
Chapter 3

€ 1duaguonay :ysey4
yreauag auibug ay|



58

a\\J

Looking at the Many Levels of ActionScript

Add Item: Allows you to click an ActionScript statement to enter it into
the program (an alternative to typing).

Find: Lets you search for terms in the program.

Insert Target Path: Helps to define the absolute or relative path to an
object, such as a movie clip.

Check Syntax: Checks for syntax errors and reports them.

Auto Format: Formats code and makes your code more readable. It auto-
matically adds semicolons where needed and checks for syntax errors.

Rather than use Check Syntax, we favor using Auto Format. If no errors
are found, your code is formatted; if it’s not, all syntax errors are
reported.

Show Code Hint: Helps you figure out how to use ActionScript far better
than the Script Assist feature does. (We keep this feature turned on all
the time.) For example, if you place a period (.) next to an object, all the
properties and methods associated with that object’s class appear.

Debug Options: Adds little red dots to the left of the line number. In
longer programs, these little red dots make it easier to find a problem
you’re working on.

Collapse between Braces, Collapse Selection, Expand All: Three tools
used to hide or show code that can be useful in longer programs.

Apply Block Comment, Apply Line Comment, Remove Comment:
Assist in creating and removing comments, which are notes that a pro-
grammer inserts into the code.

Show/Hide Toolbox: A toggle button that displays and hides the
Toolbox on the left side of the Actions panel.

Script Assist: The original ActionScript entry mode. Some people see

it as the greatest thing since solar power, and others see it as an awk-
ward programming tool. It shows the options available and helps display
the structure of statements. (Code hints are, in our opinion, a better
alternative.)

Help (?): An essential tool that helps you use ActionScript. Rather
than a typical Help resource, this one instead opens the ActionScript
3.0 Reference, including examples, in your browser. You can select

a term, and the Help (?) button immediately displays the term in the
ActionScript 3.0 Reference.
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Keep in mind that the Actions panel is used only for programs developed by
placing the code in the Timeline. However, there’s a better way to develop
ActionScript wholly independently of the Timeline that we introduce in the
next section.

ActionScript files and classes

Writing code on the Timeline leaves a lot to be desired. For programmers,
it’s an unnatural place for programs. For designers, while offering certain
advantages, has long-range consequences for applications that are likely to
fail at some point. Also, scripts linked to the Timeline hinder changing code
and reusing the same code in another project.

To write scripts that are independent of the Timeline, you use ActionScript
files along with the familiar Flash file. The Flash (. £1a) file’s primary use is
to hold the symbols in its library and hold the name of the class to be loaded
and run.

From Timeline to ActionScript file

Preparing to program using an properTIES [ e =
ActionScript file begins with the

. . Document
Flash file. You simply open a new Fl
Flash file and put the name of the FateFree.fla
ActionScript file in the Class window, SRR =
found in the Property inspector, as il
shown in Figure 3-8. Player: Flash Player 10

Script: ActionScript 3.0

If you have any movie clips or
buttons in the Flash file, you can St |r‘“_e | &
address the movie clips and buttons Profile: Def;mt (Edir.. |
by using ActionScript statements.
Suppose that you build some but- AR Settings
tons that you want to use. All you = PROPERTIES
have to do is to leave them in the ik —
library and let ActionScript put them B
where you want them on the Stage. Size: 550 x 400 px [ Edit... -
Figure 3-9 shows code that’s similar
to the code shown in Step 2 of the Figure 3-8: Placing the class name in the
section “Adding the ActionScript,” Property inspector.

earlier in this chapter.
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CEAN &2 i Target: | FateFree fia
1 package N
v R
3 import flash.display.Sprite;
4 import flash.events.MouseEvent;
5 public class Fate extends Sprite
6 {
7 private var Win:Btn;
8 private var Lose:Btn;
9 public function Fate()
10 {
11 Win=new Btn();
12 Win.x=33,Win.y=139;
13 addChild(Win);

| 14 Lose=new Btn();

[ 15 Lose.x=33,Lose.y=183;
16 addChild(Lose);
17
18 Win.addEventListener(MouseEvent.CLICK, goWin);
19 Lose.addEventListener(MouseEvent.CLICK,goFearless);
20 }
21 function goWin(e:MouseEvent):void
22 {
23 trace("You won! \nYou can program \nin ActionScript 3.@\n");
24 }
25 function goFearless(e:MouseEvent):void
26 {
27 trace("You lost your fear\nof programming in\nActionScript 3.@!\n"); a
28 ¥ 3 v

Line 24 of 30, Col 4

Figure 3-9: All ActionScript is in the ActionScript file.

Notice that the buttons named Win and Lose in the code shown in Figure 3-9
make a reference to the same buttons that you saw in the example using the
Actions panel (see the section “Creating Timeline Functions with ActionScript,”
earlier in this chapter). The only difference is that rather than provide instance
names for them, each one is named in the code.

Don’t expect to understand much of the ActionScript coding at first. Just
look at the statements and how they’re used. Even though ActionScript is

a little more difficult to use initially, it has a consistent logic that makes it
much easier in the long run. Book IV has more examples and explanations to
ease you through the process.

When you test an application that was created with ActionScript files rather
than on the Timeline, the results can be either similar or identical. In this
case, you can see the differences by comparing Figure 3-10, which uses the
trace () statement to send the text messages to the Output panel, and
Figure 3-4, which places messages on the Stage.
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2| 28 }
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a || 3@ 3
7 Line 1 of 30, Col 1
- DUTPUT
& You won!
M | You can program
=5 | in ActionScript 3.0
%-g You lost your fear
2 of programming in
ActionScript 3.0!

Figure 3-10: The ActionScript structure is similar to the one used on the Timeline.

Taking it in a little at a time

When you start using ActionScript and Flash, slow and steady works best.
Because ActionScript is so powerful, it must have a large set of ActionScript
statements. Figure out how to use the basics and then extend your knowl-
edge (and power!) a little at a time. Book IV is dedicated to showing you how
to use ActionScript, and it gets you going.
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Chapter 4: Creating Your
First Flash Project

In This Chapter

+~ Planning your project
~ Creating your first Flash document

1~ Creating your first animation

Ezery project has a beginning and an end, which is the point where you
breathe a sigh of relief and then sit back and bask in the glow of accom-
plishment of a job well done. But the beginning isn’t where you think it
might be. If you begin a project without planning, it’s like trying to go some-
where you’ve never been without using a road map. If you don’t know where
you're going, any road will take you there. So, the

first step when you're creating a Flash project,

whether it’s for fun or for hire, is to plan. «_J) Printer

The amount of planning you do is directly propor-

tionate to the scale of your project, and whether color: vl

you're creating the project for a client. If you're

planning the project for a client, the 90/10 rule |#‘EDDFE 3
takes effect: The first 90 percent of any phase of a ne rate:

project takes 90 percent of the allotted time. The I
final 10 percent of any phase of a project is equal =1 pnits:

in duration to the first 90 percent of the project.

When the planning phase is over, you can roll up

your sleeves and launch Flash.

-

In this chapter, we discuss some things you
should consider when planning your project, and
we show you how to create your first Flash document
and animation. Let’s delve into the wonderful world
of Flash.

Planning Your Project

The loftiest goal in the world isn’t anything more than a dream until you
write it down on paper along with a list of action steps you have to take
to accomplish the goal. Creating a project in Flash is similar: We like to
start with a clean sheet of paper and start noodling — a technical term for
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daydreaming on paper with a purpose in mind. During the initial planning
stage, you come to grips with the scope of your project and determine what
you need in order to — as Larry the Cable Guy would say — get ’er done.

Mappmq out the pro;ect

When Doug starts a new project, he uses the mind-mapping technique: He
starts with a blank piece of unlined paper and draws circles to define the
various parts of the project. This strategy is especially useful if you're creat-
ing a large project that has a lot of content. For example, if you're creating

a Flash Web site, you have the home page and the other sections of the site
(see Figure 4-1). Mapping out a site in this manner helps you envision the
entire project. You also have associated items, such as the interface, back-

ground music, and images. After you have all the items listed, you draw lines
to show how the various objects are connected.

Doug’s
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Figure 4-1: Map out your site.

If you're creating a complex animation or game, you can use storyboarding,

a filmmaking technique. In a nutshell, you create a facsimile of each major
scene in the animation. Your storyboard doesn’t have to be a work of art;
it’s just a visual reference to keep you on track. Your storyboard can consist
of several rectangles that are the approximate aspect ratio of your Flash
project. Create one rectangle for each keyframe or scene in your project and
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draw stick figures. If you’re working out a storyboard in a restaurant with
your client, you may end up using napkins to sort out your storyboard. Just
make sure that the napkins don’t get wet after you create the storyboard.
Whether you create your storyboard on a legal pad, computer screen, or
napkin, the result is your vision of the final project.

Different people work in different ways, so mind mapping and storyboarding
may not work for you. But we urge you to do some kind of planning when
you tackle a complex Flash project, even if you just make some notes on a
legal pad. When you put it in writing, what you see in your mind’s eye may
not be as cut and dried as you first thought.

Determining the scope of your project

After you do your initial planning, you have a good idea of what you need to
get the job done. At this stage, you have an idea of the approximate amount
of time it will take to finish your project. This information is useful if a client
is chomping at the bit to post your Flash masterpiece on the Web.

If you're dealing with a client and the project is grand in nature, create some
milestones and discuss them with the client. The milestones help keep you
focused, especially if you're juggling more than one project.

Your initial planning also gives you an idea of whether you have the neces-
sary knowledge to create your grand vision. If the project involves a lot of
ActionScript and you don’t know how to use the actions necessary to pull off
the project, you may have to

1~ Find some assistance.
v “Dummy down” (big grin) the project.

v Thumb through the index of the reference book you hold in your hands
and find the information you need to get the job done. We packed a lot
of gems of wisdom — and blood, sweat, and tears — into this handy
reference.

Planning a project may seem like a huge expenditure of time, and we agree
that planning isn’t as much fun as working in Flash. However, if you spend a
little extra time up front, it can save you a huge amount of time when you’re
working on a project. Another benefit of planning ahead of time is that you
don’t reach the end of a project (or what you thought was the end of it) and
realize that it has a fatal flaw or that you forgot to do one little thing at the
start of the project. When you're dealing with hundreds of frames or hun-
dreds of lines of ActionScript code, trying to find a flaw is like trying to find
the proverbial needle in the haystack.
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Making a list and checking it twice

Creating a checklist is a handy way to manage a project. Your list shows you
everything you need to create for the project. The objects you need to create in
Flash are assumed, but listing them helps you recognize areas where you can
save time and bandwidth by creating symbols, which help keep the resulting
project rather svelte in regard to file size. Even with today’s fast Internet con-
nections, file size is still a factor. When you're listing the objects you need to
create in Flash, begin with symbols, which are reusable. For example, you can
create a rounded rectangle graphic symbol that can be used as a background
for text. The same symbol can double as the basis for a button. Creating reus-
able symbols means less work for you. Then add to the list the other items you
need to create, such as the user interface, movie clips, and animations.

The last part of the list consists of the objects you need from your client, such
as photos, text, and logos. Here are some tips for gathering those items:

1~ Images: Make sure that you tell your client the size and resolution you
require for the project images. Better yet, ask the client to send you the
original digital file on disc, as long as it meets or exceeds your minimum
requirements.

1 Video and audio files: If your client supplies video and audio files, make
sure that they’re in the proper format. If the client is supplying video,
ask for the original video captured by the camcorder. If she gives you
video that has already been compressed, she won'’t like the results.
Compressing a compressed file isn’t just redundant — it doesn’t pro-
duce good results, either. Plop the original file into the Adobe Media
Encoder and do something exciting while the application renders a
squeaky-clean FLV file for your project.

Covering your assets

After you create your list, you know what you need in order to create the
project. We recommend rounding up all necessary items ahead of time. It’s
extremely counterproductive to realize, right in the middle of a project, that
you're missing a vital element. We also recommend that you store all project
assets in the same folder. Eventually, they’ll end up in the document library,
but being organized ahead of time is helpful. When your creative juices are
flowing like the mighty Niagara Falls, it’s not a good idea to slow down and try
to remember where you stored an asset. Nothing stifles creativity quicker.

Creating Your First Flash Document

After you know where you’re going and all your assets are safely nestled
away in a folder, it’s time to get down and get funky with Flash. When you
create a Flash document, you have choices: You can start with a template
or create your own document from scratch. If you use a template, it has
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all the information you need to start your project. However, if you create a
document from scratch, you specify the document type, width, height, back-
ground color, and frame rate.

In the following sections, we show you how to create a simple Flash anima-
tion. If you're new to Flash, this information is extremely helpful. If you're an
old hand at Flash, it’s still helpful because animation is done slightly differ-
ently in Flash CS4.

Ve olde Welcome screen

When you launch Flash for the first time, you see the Welcome screen (see
Figure 4-2). From there, you can do several things: Create a new document,
click links to view online tutorials, find out about new features, or check out
online resources, for example.

Open a Recent ltem Create New Create from Template
i DoSound.fia Bl Flash File (ActionScript 3.0) il Advertising
B finger.fla Bl Flash File (ActionScript 2.0)
3 open... i Flash File (Adobe AR) Extend
Bl Fiash Fie (obike) & Fiash Exchange »

T ActionScript File
i ActionScript Communication File
" Flash JavaScript File

= Flash Project

\4 Getting Started » Adobe® Flash® €54 Professional
L] New Features » . Find the latest tips, podcasts, and more in
|| Resources» Adobe® Bridge Home,

|| Dontshow again

Figure 4-2: Welcome back, my friends, to the show that never ends.

You can find the same Welcome-screen resources on the Help menu, includ-
ing the Flash Exchange. (No, unfortunately, you cannot exchange an old
version of Flash for a new one.) What you can do in the Flash Exchange is
find extensions for Flash. Extensions are similar to plug-ins in an image edit-
ing application: They enable you to create some cool elements, such as
Flash slide shows, without breaking a sweat. We leave it up to you to decide
whether you want to display the Welcome screen each time you launch
Flash, or disable it by selecting the Don’t Show Again check box (which is
what Doug will do as soon as he finishes writing this sentence.) From now
on, we use menu commands to create new documents.

Book |
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=
=3
@
-
=

193lo1d yse4
)sii4 Ino) Buneal)



08

Creating Your First Flash Document

Creating a document from a template

A template is a wonderful thing. It’s all set up for a specific application, wait-
ing for you to add your own splash of creativity to turn the published project
into something special. Flash templates are in several categories: You can
choose a template to create a Flash advertising banner, create a Flash proj-
ect for a mobile device, create a photo slide show, or create a Flash project.

To create a document from a template, follow these steps:

1. Choose Filez>New.
The New Document dialog box appears.
2. Click the Templates tab.

The dialog box refreshes and displays the template categories (see

Figure 4-3).
New from Template
| General | Templates |
Category: Templates: Preview:
Advertising T 120x600 (Skyscraper)

BREW Handsets B 160x600 (Skyscraper)
E;:l:g;g::;as B 180x150 (Rectangle)

Japanese Handsets % 230500 Rexicdige)

Photo Slideshows 250250 (Popup)

T 300x250 Rectangle)

P 336x280 Rectangle)

P 336x280 (Transitional)
T 466160 Banner)

P 500x500 (Popup)

Desription:

Use this template for publishing
Skyscraper 120x800 ads.

Figure 4-3: Creating a Flash document from a template is easy.

3. Choose a category from the left pane.
Flash displays all templates associated with the category.
4. Select a template.

A description of the typical use of the template appears in the lower-
right corner of the dialog box.

5. Click OK to close the dialog box.

Your shiny, new document is front and center on the Stage.
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Creating a document from scratch

Flash has a default template for each document type. You can modify the
document to suit your specific project after you create the document. The
document type determines what the published document will be used for.
To create a new document, follow these steps:

1. Choose File->New.

The New Document dialog box appears (see Figure 4-4).

New Document %]
General | Templates |
Type: Description:
| Flash File (ActonScript 3.0) Create anew Flash Project fle (=.fip). Use Flash Project
Flash File (ActionScript 2.0) files to group related fies (% fia, *.as, *.jsf, and media
"Bl Flosh Fie (Actonsrpt 2.0) ) e e p St e o e e os s dsnak
P Flash File (Adobe ATR) e e
P Fiash File (Mobile)
P Flash Slide Presentation
P Fiash Form Application
=i ActionScript File
) ActionScript Communication File
% Flash JavaSaript Fle
=" Flash Project

Figure 4-4: Which type of document do you want to create today?

2. Review the available document types.

The document type determines the ultimate use of the published file.
Your choices are described in this list:

e Flash File (ActionScript 3.0): Creates a new Flash FLA file in the
Document window using the default dimensions. The resulting docu-
ment is published as a Flash ActionScript 3.0 SWF file that plays in
the Adobe Flash Player.

e Flash File (ActionScript 2.0): Creates a new Flash FLA file in the
Document window using the default dimensions. The resulting docu-
ment is published as a Flash ActionScript 2.0 SWF file that plays in
the Adobe Flash Player.

e Flash File (Adobe AIR): Creates a new Flash FLA file in the Document

window using the default dimensions. The Publish settings are for
Adobe AIR, which enables you to publish a desktop application that’s

played on the Adobe AIR runtime. The published file is cross-platform.
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Adobe AIR makes it possible for you to create an application in Flash.
The published file can be installed and executed on any computer that
has the free Adobe AIR extension for the Flash Player (http://get.
adobe.com/air).

e Flash File (Mobile): After you choose this option, the Adobe Device
Central CS4 application appears. Choose a device, a player version,
an ActionScript version, and a content type, which creates a new
document tailored to the device you select.

e Flash Slide Presentation: Choose this option to create a Flash slide-
show presentation that’s published as a Flash SWF file.

e Flash Project: Choose this option to create a Flash Project, which is
essentially a folder in which you store project content. This option is
handy when you have many SWF and ActionScript files for a project.

3. Choose ActionScript 3.0 and then click OK.

Flash creates a document with publish settings that are tailor-made for
an ActionScript 3.0 document.

Setting the document size, background
color, and frame rate

When you create an ActionScript 2.0 or 3.0 document, the default size is

550 x 400 pixels, the frame rate is 24 fps (frames per second), and the default
Stage color is white, which isn’t terribly useful if you're creating an anima-
tion of a polar bear in a snowstorm. You can change any of these options to
suit your project by following these steps:

1. After creating a new document, choose Windowr>Properties.

The Property inspector opens (see Figure 4-5). If you're using the default
workspace, you can open the Property inspector by clicking its tab in
the Panel Dock on the right side of the workspace. In Figure 4-5, notice
the options to change the Publish settings.

2. Click the Edit button in the Properties area.

The Document Properties dialog box opens (see Figure 4-6).
3. Enter some dimensions in the (width) and (height) fields.
4. Choose a Match option:

e Default: The default option matches the document to the default
dimensions of the ones you specify.

e Printer: If you choose Printer, the document size changes to match
the dimensions of the paper now in the default printer, minus the
printer margin size.



Creating Your First Flash Document

71

File Edt View Inset Modfy Text Commands Control Debug Window Help |

5 Seene 1

| Default

& & (e v

“
|
o
%

L3
|: Fl Document
Untitled?
7 PUBLISH
Player: FlashPlayer10 Q
Script: ActionScript 30 T‘
O |
Frofile Default [(Edita. | H,
= &
AIR Settings
— &
: <7 PROPERTIES W
1 FPS: 24.00 ‘!hj
14 Size: 550%400 px O,
sage ] .
2
Q
"
S
v |
> -
45. 500 55. 60 (]
=
a7
e}
>
¥ .

It mmmpy

al o §

(g g W T

Figure 4-5: It's time to change your Flash document's properties.

e (Contents: If you have objects on the Stage when you modify docu-
ment properties, the Contents radio button becomes available.
Choosing this option leaves an equal margin around the content on

all sides.

5. Click the Background color
swatch.

The Swatches panel opens (see
Figure 4-7).

6. Click to select a swatch.

The Background color swatch
changes to the selected color.

7. Enter a value in the Frame Rate
field.

‘Document Properties

Dimensions: | 550Kl | (width) x  400px | (height)

Match: () Printer (%) Default
Badkground color: | |

Framerate: |24 | fps

Rerunts; Poels v

=2

Cancel

Figure 4-6: Every document has properties. It's
a Flash law.
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Document Properties

Dimensions: | 550 px (width) x 400 px {height)

Match: () Printer Contents () Default

Background color: _-,!

Frame rate: |

#DeDeDa

Ruler units:

lancel

O EE

Figure 4-7: Is there a sky-blue pink in this panel?

The default frame rate of 24 frames per second (fps) is ideal for many
projects, including those with external streaming video that loads into
the published file. However, if you're creating a project for people who
will be accessing the Internet with a slow connection, you can specify a
frame rate as low as 12 fps and still produce good results with motion
tweening and shape tweening animations.

8. Choose a unit of measure from the Ruler Units drop-down menu.

This option changes the unit of measure for the document. The default
option is pixels. Your choices include inches, inches (decimal), points,
centimeters, millimeters, and pixels. The change is reflected in every
dialog box that changes the size or location of an object.

If you create lots of documents with the same dimensions, background
color, and frame rate, you should create a new document, change the
document properties as outlined in this section, and then click the Make
Default button in the Document Properties dialog box before clicking OK.

9. Click OK.

The dialog box closes, and your changes are applied to the document.

Creatmq your fH‘St animation

After you create a document, it’s time to make something happen. In this
section, we show you how to create a basic animation using motion tween-
ing. To create your first animation, follow these steps:
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. Create a new document, as out-
lined earlier in this chapter.

If you rushed to this section to find
out how to create your first anima-
tion and you don’t know how to
create a new document, take a deep
breath and flip back a few pages to
the section about creating a docu-
ment from scratch.

. In the Tools panel, select the Oval
Primitive tool.

If you haven’t used the tools yet,
click the triangle to the lower-right
of the Rectangle tool and select the
Oval Primitive tool from the fly-out
menu (see Figure 4-8).

. Click and drag on the Stage to
create the oval.

Create a relatively small oval on
the left side of the Stage.

. Right-click (Windows) or
Control+click (Macintosh), and
choose Create Motion Tween from
the context menu.

Flash displays a dialog box telling
you the shape because it cannot be
tweened. You have the option to
have Flash automatically convert it.

. Click OK.

Flash converts the object to a
symbol and adds several frames
to the Timeline. The last frame is
selected (see Figure 4-9).

. Select the Selection tool.

/3

m [ | Rectangle Tool (R)
(3 Oval Tool (0}
Ij Rectangle Primitive Tool {R)
& Oval Primitive Tool {0)
D PolyStar Tool

2R NOS GANDO/ 2 VO n Y

2% »

&

I

Figure 4-8: Allow us to introduce the Oval
Primitive tool.

It’s the solid, left-pointing arrow at the top of the Tools panel.
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10.

Drag the oval to the right side of the Stage and down.

Flash creates a solid green line with a point for each frame. A keyframe
is also added to the end of the Timeline (see Figure 4-10).

Move the Selection tool close to the green line.

When you see a curve icon appear below the tool, click and drag to arc
the line (see Figure 4-11).

Release the mouse button when the arc looks like the one shown in
Figure 4-11.

Flash curves the line, which in Flash-speak is known as the path.
Choose Control->Test Movie.

Flash opens another window and your animation plays again and again
and again. After you tire of looking at your handiwork, click the red X to
close the dialog box.

Untitled-8*

Fle Edit View Insert Modify Text Commands Control Debug Window Help | | Default v|-8x

PROPERTIES

o £ 4 [mm [v
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MovieCip | ¥
Instance oft Symbol 1

=7 POSITION & SIZE

X 150 ¥: 1330
€5 w: gno H: 580
| | %7 3D POSITION & VIEW
X 150 %134z a0
o = W: 790 H: 570
Perspectiveangle:  55.0
Vanishing peint X 275.0 ¥ 2000

Rese|

<7 COLOR EFFECT

Style

7 DISPLAY
T]|  Blending: [Morma I~
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Figure 4-9: Gee, it's easy to create animations in Flash CS4.
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11. If you want to save your first animation for posterity, choose File->
Save and follow the prompts to save the document in its native
FLA format.

When you combine animation with ActionScript and the other delightful
features we discuss in this book, you create compelling Flash projects
that will amaze your friends and family members and, if you're learning
to use Flash for a living, your clients.



Chapter 5: Pushing the
Panic Button — Help!

In This Chapter

+ Summoning help
v~ Updating Flash
v~ Finding and installing Flash extensions

v~ Joining the Flash online community

Fash is a multifaceted software application. You can use it to create ani-
mations, multimedia presentations, interactive applications, and much
more. You might say that Flash is vast: If it had only 50 percent of its current
features, it would be half-vast. But even a half-vast program can present stum-
bling blocks. Your first line of defense is this book.
Suppose that you're working in a client’s office,
though. Faced with an insurmountable problem,
you don’t want to whip out a For Dummies desk ref-
erence, so you can always resort to using the Help
information supplied with the Flash application. It
doesn’t have any traces of the authors’ charm and
wit, but it provides help, and fast.

In this chapter, we show you how to summon Flash
Help. We also show you how to use the other good-
ies lurking on the Flash Help menu. And, if you're

a communal kind of Flash designer or developer,
we show you the way to the Adobe online forums.
Something for everyone, a Forum tonight.

Getting By with a Little
Help from Flash

Flash can stump you when you least expect it. You may be working away,
merrily drawing vectors and shapes and symbols and adding interactive
snippets of ActionScript when Murphy (the guy who wrote the law) rains on
your parade. Fear not, trepid Flash groupie, when Murphy strikes with a ven-
geance, an umbrella and some sunshine are just a few mouse clicks away.
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Using Flash Help

The Flash Help menu, like the program, is bi-i-ig. With a bit of work, though,
you can cut to the chase and find the information you’re seeking. To
summon Flash Help, follow these steps:

1. Choose Help->Flash Help.

Alternatively, you can press F1 to get help. The menu command or
keyboard shortcut displays an HTML page with Flash CS4 Help loaded
and awaiting your command (see Figure 5-1).

Figure 5-1: Help me, Flash.

If you like to have information at your fingertips, click the PDF link in the
upper-right corner of the Flash Help pages. A PDF file called Using Adobe
Flash CS4 Professional loads in your browser. On the Acrobat toolbar,
click the Save button to save a copy of the document on your computer.

If you're online when you summon Flash Help, pages from an Adobe
Web site load in your default Web browser. If you're offline when you
summon Flash Help, you see HTML pages that were added to your hard
drive when you installed Flash.

. Choose an option from one of the menus.

The menu consists of several topics that contain information about
every conceivable nook and cranny in Flash, minus the sage wisdom
and humor of your friendly authors, Bill and Doug. If you want to cut to
the chase, choose a book that appears to be the logical choice for the
topic about which you need help. For example, to find information on
ActionScript 3.0 components, choose the book with that title.

. Click the plus sign (+) icon to the left of a topic to see a list of

information related to that topic.
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If you're searching for information on a topic like ActionScript, you’ll
find more topics with more plus signs. Click the applicable plus sign to
reveal more topics. When you see the title that contains the information
you’re looking for, click it, and the related information appears on the
right side of the Help window. You may have to click another plus sign
to find what you're seeking. When you select a topic of interest, you see
a list of items related to the topic.

4. Click an item of interest.

The Flash help menu gives you detailed information about the item
the piques your curiosity — the topic that had you stumped just a few
seconds ago (see Figure 5-2).

Flash €54 Professional B PDF (adobe.com)

Q | Search

Flash CS4 Resources th Bhotoshop PSD files G

Using Flash CS4 Professional

RN L Import Photoshop PSD files

Components Reference

doby format (PSD) is the default Photoshop file format. Flash can directly impert PSD files and preserve many
Photoshop features, retaining the image quality and editability of the PSD file in Flash . You can also flatten PSD files when |
imparting them, creating a single bitmap image file that retains the image's visual effects but removes the hierarchical

Disity ElesB C4 Erabescaon . layer information native ta the PSD file format.

Resources
H For a video tutorial about designing websites with Photoshop and Flash, see www.adobe.com/go/vid0201.
Workspace
Hannifi dncmests View full size graphic
Using imported artwork
Placing artwork into Flash
~ Working with Fireworks files

Woarking with Tllustrator AT
files

- Working with Phatoshop PSD
files

Imported bitmaps

Creating and Editing Artwork

Symbo es, and library.

The PSD Import dialog box
A. Layers in the PSD file being imported B. Import options available for the selected layer or object,

Tirmn and Animation

il e TEwe 1. Select File > Import To Stage or Import To Library.

Text 2. Navigate to the Adobe Photoshop PSD file to import, select it, and click OK.
Sound 3. (Optional) In the PSD Import dialog box, select layers, aroups, and individual objects and choose how to import
L each item.
4. For Convert Layers To, select one of the following:
i Creating e-learning content v|

Figure 5-2: Finally, the information I'm looking for!

You can also find information by entering a word or phrase in the Search text
box and then pressing Enter or Return. This returns a page of results from
Adobe Community Help. The topics are listed in order of relevance. You can
refine your search by choosing a topic from the list below your search query.

Getting ActionScript help

ActionScript is a whole different kettle of fish. When you’re knee-deep in
code and trying to create an interactive jigsaw puzzle before it rains any-
more and Murphy’s Law takes over, you need to get help. But you don’t want
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help for everything — just information about what a specific action does and
how to properly format the code.

To

1.

get ActionScript help, open the Actions panel and then follow these steps:

From the left side of the Actions panel, select the action that has you
stumped.

Don’t double-click the action, or else you add it to your script.
Right-click (Windows) or 8+click (Mac) and choose View Help.

Help information for the object appears in a different window, in
HyperText Markup Language (HTML). In other words, it’s an HTML
document from Adobe’s Web site. Figure 5-3 shows ActionScript help for
the Date object, which is used for telling the time (and not for wowing
unmarried Flash designers of the opposite sex).

GetTimezoneUTset] =

Constructor Detail

Date() constructor
public function Date(yearorTimevalue:Object, month:Number, date:Mumber = 1, hour:Mumber = O, minute:Number = 0, second:Number = O
millisecond:Number = 0)

Language Version: ActionScript 3.0
Runtime Versions: AIR 1.0, Flash Player 9

Constructs a new Date object that holds the specified date and time.

The Date() constructor takes up to seven parameters (year, month, ..., millisecond) to specify a date and time to the millisecond. The date that the newly
constructed Date object contains depends on the number, and data type, of arguments passed.

+ Tf you pass no arguments, the Date object is assigned the current date and time.

« If you pass one argument of data type Number, the Date object is assigned a time value based on the number of milliseconds since January 1, 1970
0:00:000 GMT, as specified by the lone argument.

« If you pass one argument of data type String, and the string contains a valid date, the Date object contains a time value based on that date.

T you pass two or more arguments, the Date object is assigned a time value based on the argument values passed, which represent the date's year,
month, date, hour, minute, second, and milliseconds.

If you pass a string to the Date class constructor, the date can be in @ variety of formats, but must at least include the month, date, and year. For example, Feb 1
2005 is valid, but Feb 2005 is not. The following list indicates some of the valid formats:

« Day Month Date Hours:Minutes:Seconds GMT Year (for instance, "Tue Feb 1 00:00:00 GMT-0800 2005", which matches toStrina())

« Day Month Date Year Hours:Minutes:Seconds AM/PM (for instance, "Tue Feb 1 2005 12:00:00 AM", which matches tolocaleString())
+ Day Month Date Year (for instance, "Tue Feb 1 2005", which matches toDateString())

« Month/Day/Year (for instance, "02/01/2005")

+ MonthyYear (for instance, "02/2005")

Parameters
yearOr Timevalue:Object — If other parameters are specified, this number represents a year (such as 1965); otherwise, it represents a time value. If the
number represents a year, a value of 0 to 99 indicates 1900 through 1999; otherwise all four digits of the year must be specified. If the number represents a
time value (no other parameters are specified), it is the number of milliseconds before or after 0:00:00 GMT January 1, 1970; a negative values represents a v
) ™~

Figure 5-3: Getting ActionScript help is easy.

Updating Flash

The people who designed Flash are like Santa’s elves: They’re continually
working to make the product the best possible application it can be. To that
end, they periodically make application updates available. If you use Flash

on

a computer that’s always connected to the Internet, available updates
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are installed automatically weekly or monthly whenever you start your com-
puter. You see a warning message to this effect that shows the updates to be
installed. If you have additional Adobe applications on your machine, avail-
able updates for those applications are also displayed.

You can also update Flash manually by following these steps:

1. Launch Flash and then choose Help~>Updates.

The Adobe Updater appears, displaying the message shown in Figure 5-4.

|."Adobe Updater |

Checking for updates for Adobe Device Central CS4

(G )

Figure 5-4: And now, the latest and greatest Flash updates will
appear.

After the Adobe Updater scans for Flash updates, the dialog box
refreshes and shows you whether updates are available for Flash — and
other Adobe applications installed on your computer (see Figure 5-5).

- Adobe Updater S]El[]

Updates are available for your &dobe applications. To begin the update process, click Download and Install
Updates,

Number of Updates: 1 Size: 65.2MB

Preferences

Show Details

[ Cancel ] [ Download and Instal Updates ]

Figure 5-5: Update now!

2. Choose one of the following options:

e Preferences: Click this link to open the Adobe Updater Preferences
dialog box (see Figure 5-6). From within this dialog box, you can
determine whether your computer automatically checks for updates,
how often the Updater scans for updates to your Adobe applica-
tions, whether the updates are downloaded automatically or you're
prompted when updates are available, and which applications are
automatically updated.
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|:' Adobe Updater Preferences

Automatically check for Adobe updates:

EveryWeek [v]
(%) Download all updates automatically and notify me when they are ready to be installed.

o Ask me before downloading any updates and then notify me when they are
ready to be installed.

Choose thie applications to update:

Adobe Acrobat 9 Pro Extended - English, Francais, Deutsch iA\
Adobe Flash €54 |
Adobe Media Encoder ‘ )
Adobe Fireworks C54 |
Adobe Bridge €54
Adobe Device Central C54
Adobe Extendscrint Toolkit C54 [se ]|

[&1 | @ |

File Location
Download all updates to this folder:

C:\Documents and Settings'\Doug SahiiniLocal SettingsApplication

Figure 5-6: Setting Updater preferences.

To disable automatic updates, deselect the Automatically Check for
Adobe Updates check box. After disabling automatic updates, you can
manually scan for updates by choosing Help>Updates.

Show Details: Click this link to open a dialog box that shows the avail-
able updates for each Adobe application installed on your computer.
When you choose this option, a check box appears next to each
update (see Figure 5-7). Deselect an update’s check box if you don’t
want to install it.

Download and Install Updates: Click this button to install the

updates — or selected updates, if you choose not to install all avail-
able updates — to your computer. If you choose this option, a dialog
box appears, showing you which update is being downloaded. A bar
shows you the progress of the update. Below the progress bar, the
Updater displays the time remaining to complete the update.

After the download is complete, the Installation Progress dialog box
appears, showing you which update is being installed. You have

the option to cancel the install or minimize the Installation Process
dialog box to the system tray (Windows). The dialog box notifies you
if an installation fails and tells you what you need to do to apply the
update to the application in question. When the update is complete,
a message to that effect appears and the dialog box disappears.
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Extending Flash

Lots of geeks out there love to write extensions for Flash. The majority of
the extensions are pretty cool and do just as they’re advertised to do — give
you the capability to do something different from within the Flash applica-
tion. You extend Flash by taking a short and tumble journey from Flash to
the Flash Exchange. Here you find all kinds of extensions: some for video and
some for ActionScript, for example.

The Flash Exchange is a popular place where lots of designers and develop-
ers upload extensions for Flash and other Adobe applications. Some of the
extensions are free, and others aren’t. But if an extension makes it possible
for you to do something with Flash that you couldn’t do before, it must have
some value.

Finding Flash extensions

If you want to explore which Flash extensions are available, follow these
steps:

1. Launch Flash and choose Help->Flash Exchange.
Your default Web browser opens to the Adobe Exchange.

2. In the Exchanges by Product section, click Flash.

The page refreshes to show the Flash Exchange (see Figure 5-7). The
Flash Exchange is divided into four tabs: Staff Picks, Most Recent, Most
Popular, and Highest Rated.

3. Click to select a tab.

The page refreshes and shows the extensions filtered to all license
types.

4. Choose an option from the License Type drop-down menu, and then
click Filter.

For example, one of the license options is Freeware. If you’re on a
budget and looking to extend Flash, this is the place to start.

5. Click the Download button to the right of any extension to download
it. The applications that cost money have a Buy button next to them.
Click the button to purchase and download the extension.

Alternatively, you can click the extension title to display a page that has
more information about the extension. If, after reading the description,
you decide that the extension is for you, click Download or Buy. If you
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download an extension, you're prompted for your Adobe ID and pass-
word. If you don’t have an Adobe account, you can set one up at this
page. (It’s free — what are you waiting for?) After signing in, the down-
load begins.

e
Youraccount | B | Contact | United States (Change) SRR ’\‘
1Q
Home Solutions Products Support  Communities Company Downloads Store. Adobe
Flash Exchange
Most Recent Most Papular Highast Ratad Search Flash
License type | Al v Filter ol
earch
13507107 [1][7]
o Advanced search
Flash ECommerce Template Buy
A Flash ecommerce salution with full L
administrative section. Driven by Flash Flash home
remoting using AMFPHP and a MySQlL
et Browse by category
Al
B User Interface
Mavigation
Flash Photo Slide Show Albums Creator Download Howp
update from 21 April 2007 PSSAA was — App Servers
created especially people who'd like to have ActionScript Classes &
professional PhotoGalleries on their websites Libraries
e Browsers
Text
Design
Flash Panorama Player Buy Commerce
Panorama player engine. Uses Flash Player 9 e TR e,
ta play cubical {spherical) panaramas. ’ =

Figure 5-7: The Flash Exchange is chock-full of extensions for Flash.

Installing Flash extensions

After you download some Flash extensions, you install them. After you install
them, you can use them to extend Flash in ways that may boggle your mind.
To install an extension, follow these steps:

1. From within Flash, choose Help->Manage Extensions.

Alternatively, you can double-click an extension. Either method launches
the Adobe Extension Manager CS4. When you launch the Extension
Manager for the first time and have extensions installed in the previous
version of it, you have the option to migrate them to the current version.

2. Click Yes to migrate extensions from the previous version of the
Extension Manager into the current one.
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If you're pressed for time, click Later. If you don’t want the old exten-
sions, click Never. If you click Yes, the Extension Manager migrates the
extensions. Click OK to complete the migration, and then restart the
Adobe Extension Manager CS4.

. Click Install.

The Select Extension to Install dialog box appears.
. Navigate to the extension you want to install.

We generally download extensions to the computer desktop. They're
easy to find there, and you can delete them after the Extension Manager
installs them.

. Select the extension you want to install, and then click Open.

The Extension Manager displays the extension disclaimer. In essence,
the disclaimer says that a third party created the extension and that
Adobe doesn’t warrant or support it. (It says a lot more, but we’re not
from Philadelphia, nor are we lawyers.) We suggest that you read the
disclaimer thoroughly before accepting it.

. Click Accept to install the extension.

The extension is installed, and a message to that effect is displayed,
which also notes that you must restart Flash CS4 for the extension to be
recognized.

. Click OK.

The message box closes.
. Close Adobe Extension Manager CS4 and then restart Flash.

After installing an extension and restarting Flash, you can use the
extension. Whether it appears as a tool or a menu command is prede-
termined by its designer. Refer to the Adobe Extension Manager CS4 for
information.

Managing Flash extensions

After you download and install extensions for any Adobe application, you
use Adobe Extension Manager CS4 to manage your extensions. You can dis-
able an extension, remove an extension, or visit the Flash Exchange from
within Adobe Extension Manager CS4. To manage your extensions, follow
these steps:

1. Launch Flash and choose Help->Manage Extensions.

The Adobe Extension Manager CS4 appears.

2. Select from the Products column the application whose extensions

you want to manage.
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The check box in the Enabled column is selected for any extension that’s
enabled (see Figure 5-8).

__ | ADOBE" EXTENSION MANAGER CS4

Figure 5-8: Manage your extensions with ease by using Adobe
Extension Manager CS4.

3. Click a selected check box next to an extension to disable it.

A bar appears, showing the progress, and then a message appears, tell-
ing you that the extension was successfully disabled.

4. Click Remove to remove the extension.

A message appears, telling you that you're about to remove an
extension.
* 5. Click OK to remove the extension.
;‘
From within Adobe Extension Manager CS4, click Exchange to visit the
Adobe Exchange.

Flash Online Resources

Adobe believes that its customers should be informed and have access to a
plethora of online resources. And, you don’t have to do a Google search to
find these resources. You can access a wealth of information by choosing
one of these options from the Help menu:
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1~ Flash Support Center: Opens the Flash Support Center, where you can
search the Flash Knowledge Base by entering a few key words in the Search
For text field. You also see a Search Tips link and an Advanced Search link.

1 Adobe Online Forums: Opens the Flash Support Forums Web page,
which is divided into several categories. Click a category that interests
you to read the posts. You can add your two cents to a thread or use
the forums as a resource for ideas or to search for information about a
design problem that has been bothering you.

1 Adobe Training: Leads you to the Flash Resources section of the Design
Center tutorial, where you find tutorials, articles, and reference materi-
als as well as links to blogs and other resources.
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Fash! The very name of this application leads
you to believe that you can create compelling

projects. That’s right — we’re talking flashy here.
To create flashy projects to present on the Web,
you need to create good-looking graphics. Flash
has all the tools you need to create rectangles,
ovals, stars, and other shapes. You can add artis-
tic splashes of color to the shapes you create with
the Flash drawing tools. You can also kick up your
projects a notch or two by importing photo-
realistic images. And, when you need to get the
word out, you can use the Text tool.

Creating graphics can be time consuming, though.
You’ll be happy to know that you can create a
symbol, which is in essence a reusable graphic.
You can also organize your work with layers. We
show you how to do all of the above and more in
Book II.




Chapter 1: Creating Flashy
Graphics

In This Chapter

+~ Understanding vectors and bitmaps
1~ Creating shapes with the Drawing tools

1 Modifying shapes

A thing of beauty is a joy forever. If you want your Flash design to be
a thing of beauty, you need to have eye-catching graphics. Can you
imagine an interface with just text? You don’t see one of those in modern
designs. If you’ve been around for a few years, like your friendly authors
have, you may remember when the Internet was text-only. When you
opened a Web page, it looked like a giant outline
from a word processing application. That was
back when computers had black-and-white moni-
tors and not much processing power. Even the
most basic modern computer can handle pretty
much anything the Web or Flash can throw at it.

So, unless you want your Flash project to look like
something from the Jurassic period of the Internet,
you need to become friendly with the tools that are
used to add shapes to a design. In this chapter, we
show you how to come to grips with the tools you
use to create shapes and the drawing tools.

A Tale of Two Graphic Types

Flash graphics have a split personality. The

shapes you draw with the shape and drawing tools can be scaled almost
infinitely, with the exception of graphics that are filled with complex gradi-
ents. (Color is covered in the next chapter, so we stick with shapes here.)
The shapes you create with the Flash drawing and shape tools are known as
vector graphics. (Give me a vector, Victor.) When you import photorealistic
images into Flash, you're importing raster graphics, mon. Raster graphics
come in many flavors, but have one thing in common: If you try to greatly
increase the size of a raster graphic, the result doesn’t look good. If it all
seems about as clear as a gallon of molasses, read the following sections to
discover the difference between the two.
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A Tale of Two Graphic Types

Understanding vector graphics

When you create a graphic using

a Flash drawing or shape tool, the
resulting graphic is composed of
points and line segments. In essence,
it’s pure math. When you increase
the size of a vector graphic, mathe-
matical formulas preserve the place-
ment of the points, whether the point
is a straight or curve point or the
relative length of the line segment
between the points, for example.
Figure 1-1 shows a shape created
with the Polystar tool. The shape has Figure 1-1: Vector images are all about the
been selected with the Subselect tool math.

to show you the points that make up

the shape.

Understanding bitmap (raster) graphics

A photograph taken with a digital camera or scanned into a computer is known
as a bitmap, which you shouldn’t confuse with the Windows . bmp format —
also called bitmap. A bitmap is a pixel-based image (see Figure 1-2). A pixel is

a square of color. If you zoom in on a bitmap — we’re geeks, so we prefer the
term raster — you can see the individual pixels, as shown in Figure 1-3.

I VINNIES HoTs
| ONAROLL
DOGS

w0 oy A 0

Figure 1-2: It's a bitmap image, mon.
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Bitmaps are resolution dependent.
For example, an 8x10-inch image,
with a resolution of 300 ppi (pixels
per inch) has a document size of
2400 (8 inches x 300 ppi) x 3000 (10
inches x 300 ppi) pixels. A resolution
of 300 pixels per inch is perfect for
printing, but is more than you need
for your Flash projects. A resolution
of 96 or 72 ppi is perfect for view-
ing images on a computer monitor,
which is where most Flash projects
are viewed.

We don’t launch into a long disserta- e 1-3: pixels are a hitmap’s lowest
tion on sizing images. Just keep the
size of your Flash project in mind
when you’re optimizing images for a
Flash project. If you use the default document size of 550 x 400 pixels, resize
your images so that they don’t exceed either dimensions with a resolution
of 96 pixels per inch. You can also shrink them to the size you want in Flash,
but if you try to increase them, you don’t produce good results because
you're asking Flash to increase the size of each pixel. For more information
on working with bitmaps, check out Chapter 6 of this minibook.

common denominator.

Creating Shapes

You can get a lot of mileage out of shapes. You can use your garden-variety
rectangle as a background for text, the framework for a building, part of an
interface, and much more. You can create five basic shapes: lines, ovals,
polygons, rectangles, and stars. These five basic shapes are the framework
for your Flash artwork. Rectangles and ovals have special status in Flash:
primitive rectangles and ovals, and basic rectangles and ovals. You can
modify primitive rectangles and ovals at any time. This isn’t the case with
basic ovals and rectangles, but basic ovals and rectangles have other tricks
up their vector sleeves. In the following sections, we show you how to get
the most bang for your buck by using the shape tools.

Using the Primitive Oval and Rectangle tools

The Primitive Oval and Primitive Rectangle tools are anything but primi-
tive. In fact, they’re downright sophisticated. However, referring to a tool as
sophisticated might seem a little snobbish, so the Flash guys and gals settled
on the moniker Primitive. Using these tools, you can create a rectangle with
rounded or chamfered corners or an oval that looks like a slice of pie or a
doughnut.

Book I
Chapter 1
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Creating a Primitive Qval shape

A primitive oval can be perfectly round or elliptical in nature. You can create
lots of interesting shapes with the Primitive Oval tool. To check out this
powerful tool, follow these steps:

1.

Select the Primitive Oval tool.

The Primitive Oval tool hangs out with his other shape pals on the ninth
slot of the Tools panel. The last used tool is always at the top of the
heap.

. Click on the Stage to define the starting point for your shape, and then

drag to create the shape.

As you drag the tool, an oval outline appears, designating the current
size of the oval. Hold down the Shift key to constrain the oval to a circle.

. Release the mouse button when the oval is the shape you want.

This step gives you a garden-variety oval. But you can do so much more
with this tool after the shape is created. If you're using the Shift modifier
to constrain the tool to a circle, make sure to release the mouse button
before you release the Shift key.

. Choose Windowr>Properties.

The Property inspector appears.

By default, the drawing tools snap to grid points as you create objects
with them. To disable snapping to the grid, click the magnet icon in the
Tool Options section of the Tools panel.

. In the Oval Options section, drag the Start Angle slider to the right.

An alternative method is entering a value in the Start Angle text field,
but we find that using the slider is more intuitive and more rewarding.
As you drag the slider, watch the shape change into something like a pie
with a couple of slices gone.

. In the Oval Options section, drag the End Angle slider to the right.

The missing slice starts getting smaller.

Experiment with the Start Angle and End Angle sliders to see the variety
of shapes you can create with these options.

. Click the Reset button.

The garden variety ho-hum oval returns.

. Drag the Inner Radius slider to the right.

Holy doughnut hole, Batman!
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9. Drag the Start Angle and End Angle sliders to see the different variety
of shapes you can create with the tool.

Figure 1-4 shows a shape created with the tool. Notice the parameters in
the Oval Options section.

10. Click the Close Path check box to deselect the default option.

If you changed any of the Oval Options, you see a path with the current
Stroke color.
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Figure 1-4: This is a primitive oval? Hmm.

Creating a Primitive Rectangle shape

You can create some unique shapes with the Primitive Rectangle tool. If you
like rectangles or squares with corners that aren’t square, this tool is the
one for you. Follow these steps to try it out:

I 1. Select the Primitive Rectangle tool.

The Primitive Rectangle tool hangs out with his other shape pals on the
ninth slot of the Tools panel. The last used tool is always at the top of
the heap.

Book

Chapter 1

sajydesn
Aysey4 uneary



96 Creating Shapes

2. Click on the Stage to define the starting point for your rectangle, and
then drag to create the shape.

As you drag the tool, a rectangular outline appears, designating the cur-
rent size of the rectangle. Hold down the Shift key to constrain the tool
to a square.

3. Release the mouse button when the rectangle is the shape you want.

This step creates a rectangle with square corners, and that may or
may not be cool. If you use the Shift modifier to constrain the tool to a
square, make sure to release the mouse button before you release the
Shift key.

4. Choose Windowr>Properties.
The Property inspector appears.

5. In the Rectangle Options section, drag the slider to the right.
The Rectangle now sports round corners.

6. In the Rectangle Options section, drag the slider to the left.

As you drag the slider, the corners are squared off. Drag the slider until
negative values appear and the corners are chamfered (see Figure 1-5).

\3 . .
P You can create rounded or chamfered corners while creating the shape.

Press the down-arrow key while creating the shape for rounded corners
or the up-arrow key for chamfered corners.

7. Click the Reset button.
You have a rectangle with sharp, pointy corners again.
8. Click the Lock icon.

You can now create a rectangle with a different radius or chamfer on
each corner. When you choose this option, the slider is no longer
functional.

9. Enter a value in a corner text field.

Enter a negative value to chamfer the corner, or a positive value to
round the corner.

10. Continue experimenting with different values to see the variety of
shapes you can create with this tool.

<P You can set the parameters for the Primitive Oval and Rectangle tools before
you draw the shape by selecting a tool, opening the Property inspector, and
then entering values or dragging sliders in the Oval or Rectangle Options
section. The options remain in effect for every shape you draw with the tool
until you change the values.
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Figure 1-5: Chamfered corners, just like on a piece of antique furniture.

Modifying Primitive Ovals and Rectangles

As you create shapes for your Flash project, you may decide that a shape
you created with the primitive tool needs a little tweaking or touching up.
You can easily modify a shape by following these steps:

1. Select the shape with the Selection tool.
2. Chose Window=>Properties.

The Property inspector opens.

3. Modify the values in the Oval Options (shape created with the
Primitive Oval tool) or Rectangle Options (shape created with the
Rectangle Primitive tool) for the shape.

From the Property inspector, you can also modify the size and posi-
tion of the shape, a topic we cover in the “Modifying Objects with the
Property Inspector” section, later in this chapter.
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Creating shapes with the Oval and Rectangle tools

When you create ovals and rectangles with these tools, you can create the
same type of shapes as the tool’s primitive counterparts, but you can’t edit
the options after the fact. But these tools have two different drawing modes:
Standard Drawing mode and Object mode. We explain the difference in the
following sections.

The Oval tool

The Oval tool creates shapes that look identical to what you can create
with the Oval Primitive tool (discussed earlier in this chapter), with two
exceptions:

» You have to set your parameters in the Property inspector before you
create the shape.

»* You can’t edit the parameters in the Property inspector after you create
the shape.

Follow these steps to create a shape with the Oval tool:

1. Select the Oval tool.

The Oval tool bunks with his other shape pals on the ninth slot of the
Tools panel. The last used tool is displayed at the top of the heap.

2. Choose Window=>Properties.

The Property inspector appears, looking like that famed TV detective in
a rumpled raincoat. (“Err, just one more thing, Oval tool.”)

3. In the Oval Options section, drag the Start Angle slider to the right.

An alternative method is entering a value in the Start Angle text field,
but we find that using the slider is more intuitive and more rewarding.
Larger values create a shape that looks like a pie with a couple of pieces
missing. Larger values create a shape that looks like a piece of pie.

4. In the Oval Options section, drag the End Angle slider to the right.

The type of shape that results depends on the start angle value. If you
have a high start angle value, the wedge gets larger. If you have a small
start angle value, you end up with a smaller wedge missing from the
circle.

5. Drag the Inner Radius slider to the right.

This step is similar to punching a hole in a doughnut. You modify this
option in conjunction with the start and end angle values to produce a
shape that looks like the letter C, or a curve.
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6. Click the Stage to define the starting point for your shape, and then
drag to create the shape.

As you drag the tool, an oval outline appears, designating the current
size of the oval. Hold down the Shift key to constrain the oval to a circle.

7. Release the mouse button when the oval is the shape you want.

This step results in a nice shape that can’t be edited. The parameters
you specify in the Property inspector are used with other shapes you
create with the tool until you specify different options.

The Rectangle tool Book II
You use the Rectangle tool to create rectangles with pointy, round, or Chapter 1
chamfered corners. You can modify the rectangle corners as you create the
shape, or by modifying parameters in the Property inspector. To create a
ho-hum, or not so ho-hum, rectangle, follow these steps:

= 1. Select the Rectangle tool.

solydein
Aysey4 uneary

This rascal sublets space on the ninth slot of the Tools panel.

2. Click to define the starting point for your rectangle and then drag
diagonally.

As you drag the tool on the Stage, a rectangular outline shows the cur-
rent size of the shape. Hold the Shift key to create a square. Press the
down-arrow key to create rounded corners or the up-arrow key to create
chamfered corners. Release the arrow key when the corners are the way
you want them.

You can modify the corner radius by opening the Property inspector
after you select the tool and before you create the shape. This action

is counterintuitive, however, because you can’t see the result. And you
cannot modify the options after you create the shape. The only bonus
for setting rectangle options in the Property inspector is when you want
a different radius on each corner. To achieve this effect, click the Lock
icon and then manually enter values in the text fields.

3. Release the mouse button when the rectangle is the size and shape
you want.

The Property inspector plays the ultrasmart detective and records the
radius values for the shape you just created. These values are applied
to future shapes you create with the tool until you either click the Reset
button in the Property inspector and manually enter values or create a
new rectangle and define the shape of the corners by using the arrow
keys.
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Mastering the Polystar tool

You have a Flash project with a boring, jet black midnight sky in need of a
star or 50. Or, perhaps you have a project that needs a multisided shape.
When either occasion occurs, you need look no further than the Tools panel.
Check out the Polystar tool — Poly is short for polygon, which is a multi-
sided shape, and star represents twinkle, twinkle, big or little. You use this
multifaceted tool to create multisided shapes. Talk about your ultimate mul-
titasker. (Yikes — our copy editor will probably tell us that using multi that
many times is redundant.)

To master the Polystar tool, follow these steps:

'D 1. Select the Polystar tool. rTuul Settings

The tool is a tad introverted and
may be hidden on the fly-out menu, Style:
on the ninth slot of the Tools
panel. Mumber of Sides: |5

2. In the Tool Settings section
of the Property inspector
(Window=>Property Inspector),
click the Options button. OK l [ Cancel

The Tool Settings dialog box
appears (see Figure 1-6).

| star |

Star point size:  |0.50

. Figure 1-6: Okay, Polystar — this is a set-up.
3. Choose an option from the Style

menu.
You have a choice: Polygon or Star.
4. Enter a value for the number of sides.

We advise that you don’t get too carried away here. If you create a shape
with a lot of sides, it’s hard to edit, and it increases the file size of the
published movie.

5. Enter a value between 0 and 1 in the Star Point Size field.

This value determines the depth of the star, when you choose that
option. If you specify a value closer to 0, the star has longer points. This
option has no effect on polygons.

Creating unique shapes with the
Oval Rectangle and Polystar tools

When you create shapes with the Oval and Rectangle tools with no stroke,
the shapes have an affinity for each other. You can create unique shapes in
one of two ways. Here’s the first one:
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1. Select the Oval, Rectangle, or Polystar tool.

Don’t select one of the Primitive tools. They're independent critters who
like to maintain their own identity.

2. Select a fill color and no stroke.

We know: We haven’t covered selecting stroke and fill colors yet. But,
hey: Which came first — the chicken or the egg? We show you how to
specify strokes and fills in Chapter 2 of this minibook.

3. Create a shape on the Stage.

4. Create another shape with the Oval, Rectangle, or Polystar tool with
the same fill color and no stroke.

When you create the second shape, make sure that it overlaps the first.

5. Release the mouse button after
you create the second shape.

6. Select the Selection tool and
click the shape to select it.

7. Drag the shape to a different
spot on the Stage.

Notice that the two shapes are

joined at the hip (see Figure 1-7).

You can stack multiple shapes to

create some truly unique shapes.

You can also use the Brush tool

to add to a shape when painting

a brush stroke that’s the same Figure 1-7: | declare, Lance, the sum is better
color over an existing shape. than the parts.

If you prefer more control when combining basic shapes to create unique
shapes, create the second shape, but don’t overlap it with the first one.
Select the shape with the Selection tool and then overlap it with the first
shape. You can now freely move the second shape until you have it exactly
where you want it. It doesn’t join with the first shape until you click a blank
area of the Stage with the Selection tool.

When you overlap shapes that aren’t the same color, one shape cuts away
from the other. This oil-and-vinegar relationship makes it possible for you
to create some truly unique shapes. Follow these steps to get an idea of how
this second method works:
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1. Select the Oval tool.

2. Open the Property inspector (choose Window= Properties) and select
a fill color but no stroke.

We know we haven’t covered No stroke
color yet. Here’s your baptism |

by fire. In the Fill & Stroke sec- [ | zossms Aphe % U @
tion of the Property inspector, u [

ol

BEEE

click the Stroke swatch (it’s next
to the pencil icon) and click the - - e
No Stroke icon (the white rect- 1L [
angular icon with a red diagonal —
slash in the Swatches panel, as i
shown in Figure 1-8). Then click
the fill color swatch (it’s next to
the paint bucket icon), and click
one of the color swatches in the

Swatches panel. .
Figure 1-8: To stroke or not to stroke. . ..
3. Draw an oval on the Stage.

4. With the Oval tool still selected, click the fill color swatch in the
Property inspector and choose a different color.

It doesn’t matter which color you choose. You delete the shape when
you're done.

5. Create a smaller oval that doesn’t overlap the first shape you created.
6. Select the shape with the Selection tool.
The Selection tool is the head honcho at the top of the Tools panel.

7. Drag the second shape over the first shape until it’s in the position
you want.

8. Click anywhere outside the shape.
This step deselects the shape.
9. Click the smaller oval and drag it outside the first shape.

A hole appears in the first shape. You can continue using the different-
colored oval to cut out of the first oval. Just drop it into position, dese-
lect it, and then move it someplace else. With a bit of work, you could
create a piece of Swiss cheese for your favorite digital mouse (see Fig-
ure 1-9). Oh, you noticed the outlines around the cheese and the holes.
These were created with the Ink Bottle tool, which we show you in
Chapter 2 of this minibook.
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Figure 1-9: Look! It's Flash Swiss cheese! Where's my digital Swiss Army knife?

Creating lines — the straight and narrow

If you have a Flash project that needs to toe the line, so to speak, summon
the Line tool. You use the tool to create straight lines. When you feel the
need to draw a straight line, follow these steps:
1. Select the Line tool.
This tool is prominently displayed on the eighth slot of the Tools panel.

2. Click on the Stage to define the starting point, and then drag to create
the line.

As you drag the tool, a crosshair signifies the current position of the
tool.

3. Release the mouse button when the line is the length you want.

We were going to include an illustration, but realized that you already
know what a straight line looks like.
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E 2. Click the Drawing Object icon at the bottom

Hold the Shift key while dragging the line tool diagonally to constrain the
line to a 45-degree angle. Hold the Shift key while dragging from left to right
(or from right to left, if you're so inclined) to create a horizontal line, or
while dragging from top to bottom (or from bottom to top) to create a verti-
cal line.

Using the basic shape tools in Object Drawing mode

You have seen the basic shape tools in their default mode. In this section,
we show you how to use the basic shape tools in Object Drawing mode.
When you use this mode, you create a unique object that cannot be merged
with other objects. You can, however, edit the basic shape after you create
it. To create a shape in Object Drawing mode, follow these steps:

1. Select the Line, Oval, Rectangle, or Polystar [ Rectangle Tool (R}
tool. @ 0valTool (0)

The Line tool appears in the eighth slot of the | [ RedtanaleFrmitieToal ®)

Tools panels, and the other tools appear on i CvalEmiteTaol (O]
the fly-out menu in the ninth slot of the Tools | ® © PolystarTeal
panel (see Figure 1-10).

Figure 1-10: Choosing a shape
of the Tools panel. tool.
3. Create a shape.

After you create the shape, a border appears around the shape, which
signifies that it’s an object (see Figure 1-11).

Modifying basic shapes

The basic shapes you create with the Line, Oval, Rectangle, or Polystar tool
can be modified to create unique shapes. As discussed previously, you can
overlap shapes of the same color to create a new shape, or use a different-
colored shape to take a chunk out of another shape. You can also mold a
shape like putty with the Selection tool, or use the Line tool like a scalpel to
carve up a shape as long as you don'’t click the Object Drawing icon in the
Tool Options section. To modify a basic shape:

1. Select the Selection tool.

2. Use the tool to select, move, or modify the shape as follows:

e C(Click the shape to select it. If the shape has a stroke, double-click the
fill to select both the stroke and the fill. After selecting a shape, drag
it to a position on the Stage.
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Figure 1-11: Creating an object with a shape tool.

e To select several shapes,
click and drag the Selection
tool around the shapes you
want to select.

e Move the Selection tool
toward a shape that hasn’t
been selected. When a curve
icon appears beneath the
tool icon, click and drag to
change the shape (see Fig-
ure 1-12).

The Line tool can also be used to
cut a basic shape into two or more
pieces. To cut a shape down to size,
follow these steps:

1. Select the Line tool.

Figure 1-12: Bend me, shape me, any way you
want to.

It’s the diagonal line icon right below the T (Text tool) on the Tools

panel.
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2. Create a line that intersects and is wider than or taller than the shape
you want to cut.

3. Select the Selection tool.
4. Select one part of the shape and drag it away from the other.

What was once joined is now parted (see Figure 1-13). If the shape has a
stroke, make sure that you double-click it to select both the shape and
the stroke.

5. You can now select the line, which is now in three segments, and
delete it by pressing the Delete key.

Thank you, line. You have served us well.
You can also use a line to slice and dice another line. Move one line over

another, and then select a piece with the Selection tool and move it to
another position.
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Figure 1-13: The Line tool cuts like a knife.
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If you're the artistic type who likes to doodle with a pen or brush (Doug’s
drawing tool of choice when he was a kid was an Etch-A-Sketch), you’ll enjoy
working with the drawing tools. If you like creating freeform shapes, become
familiar with the Pencil and Brush tools. If you like point-by-point accuracy
when creating shapes, the Pen tool has your initials carved on it.

Drawing with the Pencil tool

The Pencil tool should be colored yellow to resemble the good old Eberhard
Faber pencil that also made a good impromptu drum stick that could be
used to good effect when trying to drive a substitute teacher absolutely bon-
kers. But it’s a boring gray, just like the other tools. Don’t let that fool you,
though. This single tool is the equivalent of every pencil you've ever used
and then some. To create lines with the Pencil tool, follow these steps:

PROPERTIES |[LIBRARY | =]

It’s the tenth tool in the Tools o Pencil Tool
panel.

1. Select the Pencil tool.

2. Choose Window=>Properties. SR e

The Property inspector appears, P | & [ ]
displaying the parameters you

can modify for the tool (see Stroke: L—————

Figure 1-14). Style: |Solid = 2
3. Select a stroke color. Scale: [ Normal | » | [ Hinting
Click the color swatch next to Cap: =| v

the pencil icon and choose a
color from the Swatches panel.
For more information on work- AT EING
ing with the Swatches panel, see SinnabABG: 50
Chapter 2 of this minibook.

Join: = * Miter: 3.

4. Drag the Stroke slider to specify
the width of lines you draw with Figure 1-14: Even a pencil stroke has
the tool. properties.

Alternatively, you can enter a
value from 1 to 200 in the text field to the right of the slider.

5. Choose an option from the Style drop-down menu.

You can draw a hairline or a solid, dashed, dotted, ragged, stippled, or
hatched line.

To create with the Pencil tool a line that doesn’t interact with other
shapes, click the Object Drawing icon in the Options section of the Tools
panel.
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10.

11.

To create a custom style, click the Edit Stroke Style icon (it looks like

a pencil) in the Property inspector to open the Stroke Style dialog box.
Follow the prompts to create your custom line. The parameters you can
modify depend on the style you start with.

. Choose a scale option.

These options determine how the stroke is scaled in Flash Player. Your
options are described in this list:

e Normal: Scales the thickness of the stroke.

e Horizontal: Doesn’t scale the thickness if the object is resized
horizontally.

e Vertical: Doesn’t scale the thickness if the object is resized vertically.
e None: Doesn’t scale the stroke.
Select the Hinting check box to enable stroke hinting.

This option positions anchor points on pixels, which prevents blurry
lines.

. Choose one of the following options from the Cap drop-down menu:

e None: Makes the cap flush with the end of the line.

® Round: Adds to the end of the line a round cap that’s half the width
of the stroke.

e Square: Adds to the end of the line a square cap that’s half the width
of the stroke.

. Choose one of the following options from the Join drop-down menu:

e Miter: Creates a 45-degree miter joint where path ends join.
* Round: Creates a rounded corner where path ends join.
* Square: Creates a square corner where ends join.

If you choose Miter for the Join option, specify a Miter value.

This option is a scrubby slider. Drag the slider to specify the Miter
value, which prevents the join from being beveled. For example, if you
specify a value of 2 for a three-point stroke width, when the length of the
join is more than six points, the join is squared off.

Specify a smoothing option.

This option appears in the Modifier section of the Tools panel. Your
choices are described in this list:

e Straight: Straightens lines. Use it when you want to draw objects,
such as triangles and rectangles.

e Smooth: Smoothes lines. This option is useful when you use a mouse
with the Pencil tool.
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e Ink: Applies no smoothing to lines. Use this option when you're cre-
ating freeform artwork with the Pencil tool.

Specify a smoothing value.

This option determines the degree to which Flash smoothes a line. The
default value is 50. Specify a higher value for a smoother line. Note that
this is a scrubby slider. Hover the cursor over the current value until
you see a pointing finger icon with two arrows, and then click and drag
to change the value.

Drag the tool on the Stage to create the line.

The default drawing mode creates a basic shape, which acts like a line
drawn with the Line tool. If you draw it over other shapes, the line you
create bisects the other shape.

Alternatively, you can click the Object Drawing button (shown in the
margin) to draw a line that becomes an object and doesn’t interact with
other shapes.

Painting with the Brush tool

If you like dabbling with a paint brush and watercolor, oil, or acrylic paint,
check out the Brush tool. It gives you the power to add artistic or calli-
graphic splashes of color to your Flash projects. If you're truly talented and
use a digital tablet and stylus, you’ll love the artistic strokes you can create
with this tool. To grace your Flash projects with eye-catching strokes from
the Brush tool, follow these steps:

j?’ 1. Select the Brush tool.

We love truth in advertising. This tool’s icon, which occupies the elev-
enth slot on the Tools panel, looks just like an artist’s paint brush.

Select a fill color.

We know: We haven’t covered color yet. That happens in the next chap-
ter. The quick and easy way is to click the fill color swatch (it’s next to
the paint bucket icon in the Property inspector or the Tools panel), and
choose a color from the Swatches panel.

Choose a painting mode.

By default, the tool creates strokes just like a normal brush. When you
paint over something, it disappears. You can change the way the tool
creates strokes by choosing a different painting mode in the Options
section of the Tools panel (see Figure 1-15).

You have these options:
e Paint Normal: Paint over lines and fills on the same layer.

e Paint Fills: Paint within closed paths (outlines) and blank areas of the
Stage without affecting lines.
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* Paint Behind: Paint color on blank areas
of the Stage on the active layer, without
affecting lines and fills. In other words,

you’re painting behind the lines and fills

» £3 PaintNormal
you already created.

2 PaintFills
{_} PaintBehind
& Paint Selection
(3 PaintInside

e Paint Selection: Paint within selected
objects.

ER N ] JOREYs

e Paint Inside: Paint within a closed path

(shape outline) without affecting other
lines. You can also paint on blank areas of
the Stage without affecting other fills and . .
lines on the same layer. After choosing Figure 1-15: Choosing a
this mode, click inside the object with the different painting mode.
fill you want to change.

4. Choose a brush tip size.

You choose this option from
the Options section of the Tools
panel (see Figure 1-16).

o i
& He i

b

the brush tip depending on the
amount of pressure you apply
against the stylus.

e

09

@
. '
5. Choose a brush tip shape. ) " —
You choose this option from | - i H
the Options section of the Tools o !
panel (see Figure 1-17). - e |
'; 6. If you use a Wacom tablet and j ® j -
stylus, click the Use Pressure icon. (3| @@ ) /
This option changes the size of & e /
®
=4
:if"‘-'l- 7. If you use a Wacom tablet and i I
stylus, click the Use Tilt icon.
This option changes the angle of . _ . e
calligraphic brush tips when you  Figure 1-16:Dol Figure 1-17:I'm in a
tilt the stylus. need a teeny-weeny  calligraphic state of

brush or a big ‘'un? mind.
8. Create something nice to

look at.

You can dabble with the tool until you're good enough to create some-
thing nice to look at.

Using the Spray Brush tool

If you have the urge to spray graffiti in parts of a Flash project, check out the
Spray Brush tool. It’s multifunctional. In this section, we show you how to
use this tool to spray color.
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This tool is introverted by nature and shares space with the Brush tool
on the eleventh slot of the Tools panel.

2. Choose Window=>Properties.

The Property inspector opens, displaying the properties you can modify
for the Brush Spray tool (see Figure 1-18). Don’t fret about the Symbol
section yet. We show you how to spray symbols in Book II, Chapter 4.

3. In the Brush section, specify
the width and height.

These options determine how
large a burst of color one click
of the tool produces. The
default sprays a burst of color
92 x 92 pixels. These values are
changed by using scrubby slid-
ers. Position the cursor over
the current value, and when the
icon becomes a pointing finger
with two arrows, drag left to
decrease the size or right to
increase the size.

4. In the Brush section, specify
the brush angle.

This option determines the
angle at which the spray dis-
perses from the tool. The default
option sprays horizontally. Vary
the angle to achieve different
effects.

5. Spray with the tool.

We know you want to. That’s
right: Experimentation is the key

eroperTIEs [ |

E::@ Spray BrushTool

— SYMBOL

Spray: <nosymbol=
™ Default shape

Scale width: 100
Scale height: 100

[ Random scaling
[ Rotate symbol
[ Random rotation
= BRUSH
Width: 32 px Height 10 px
Brushangle: 78 CW

Figure 1-18: And the mother skunk said to her
children, “Let us spray.”

to success with any new tool. We had lots of fun using the tool to spray

graffiti on a blank Flash document.

Creating paths with the Pen tool

If you like precision, you’ll like the Pen tool. When you create a shape with
the Pen tool (known as a path in vector-speak), you create points. It’s like
that connect-the-dots artwork you find in restaurants that keep your kids
endlessly amused while you decide whether to order a salad or indulge and
have a decadent appetizer, like deep-fried mozzarella. When you create a
path with the Pen tool, you can create straight points or curve points. To
create a basic path with the Pen tool, follow these steps:
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1. Select the Pen tool.
* 2. Choose Window=>Properties.

This step opens the Property inspector and displays the properties you

can modify for the Pen tool. The options are identical to those for the

Pencil tool (refer to Figure 1-14). Please refer to our words of wisdom

in the “Drawing with the Pencil tool” section, earlier in this chapter, for

concise instructions on how to set these properties.

\3 . e s .
P To create a shape with the Pen tool that doesn’t interact with other

shapes, click the Object Drawing icon in the Modifier section of the
Tools panel.

3. Click to define your first point.
The first anchor point appears as a hollow dot.
4. Click to define the second point.

A line segment appears between the two points. Shift+click to constrain
the line segment to a 45>-degree angle. Shift+drag to create a curve point.
When you create a curve point, tangent handles appear and the outer
tangent handle is active. If you continue to drag the tangent handle, the
radius of the curve increases. You can also change the angle of the tan-
gent handle as you create the curve point.

5. To finish creating the path, do one of the following:
e To create an open path: Select a different tool.

e To close the path: Click the first anchor point (the hollow dot).
Figure 1-19 shows a closed path and an open path.

untitled-1* x |
1 Soene 1 = A | 0o% v

£ ¥

Figure 1-19: A tale of two paths.
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The Eraser tool — the quicker picker-upper

Digital erasers are the greatest thing since the

invention of computer image-editing applica- &
tions. You get to eradicate your mistakes, and
you don’t have to deal with a bunch of pink or )
white eraser crumbs. You might think that you
know how to use an eraser, but the Flash Eraser 2
tool has some special modes you should know =,
about. To use the Eraser tool, follow these Za
steps: ®

) 1. Select the Eraser tool.

L] C Erase Normal
) EraseFils
C Eraselines
@ Erase Selected Fills
© Eraselnside

This tool looks like the pink erasers your
friendly authors used in grade school.

Figure 1-20: Erasers are a digital

2. Select an eraser mode. artist’s best friend.

You choose Eraser mode in the Options
section of the Tools panel (see Figure 1-20).

Your options are described in this list:

e FErase Normal: Erase lines and fills on the same
layer.

e Frase Fills: Erase fills within closed paths (outlines)
and blank areas of the Stage without affecting lines.

e FErase Lines: Erase color on blank areas of the Stage
on the active layer, without affecting lines and fills.
In other words, you erase behind lines and fills
that you already created.

e FErase Selected Fills: Erase fills within selected
objects.

e Frase Inside: Erase within a closed path (shape
outline) without affecting other lines. After choos-
ing this mode, click inside the object whose fill you
want to erase either partially or totally.

3. Choose an eraser tip size and shape.

You choose this option from the Tool Modifiers sec-
tion of the Tools panel, shown in Figure 1-21. The sizes
are identical to those of the Brush tool.

2 |

@O NiEc I £

H

Figure 1-21: Do
square erasers
erase square pixels
and round erasers
remove dots?

Wait — there’s more. If you need to erase line segments, or fills within
shapes, select the Eraser tool, select the Faucet modifier from the Tools
panel Options section, and then click the fill you want to remove. Like magic,
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the tool and selected option suck it up, just like one of those superfantastic
paper towels. To remove a line segment, select it with the Selection tool, and
then select the Eraser tool and enable the Faucet modifier. Click the selected
line segment and it is, to quote the raven, “Nevermore.”

Modifying Objects

After you create an object, you have the option to modify it. You can modify
objects using menu commands or tools or both. Modifying objects isn’t
rocket science, or brain surgery, but you have to choose the right menu
command or tool for the job. After all, you don’t drive home a finishing nail
with a sledgehammer. In the following sections, we show you how to use the
drawing tools to modify the shapes you create.

Selecting objects

After you populate a Flash project with a bunch of objects, you need to grab
the critters by the scruff of their pixels so that you can modify them. After
you select one or more objects, you can use menu commands or tools to
modify them.

h‘ You select objects with the Selection tool. We know that’s a case of the bla-
tantly obvious, but you can use the tool in different ways. To master the
Selection tool, create a Flash document and then create a couple of objects
with the drawing tools. Select the Selection tool and do the following:

1 To select a stroke segment of an object created in Basic Drawing
mode: Click the segment.

1 To select the stroke of an object created in Basic Drawing mode:
Double-click any stroke segment.

 To select the stroke and fill of an object created in Basic Drawing
mode: Double-click the object’s fill.

1~ To edit an object created in Object Drawing mode: Double-click the
shape to display the object in another window. You can then use the
Selection tool to select individual stroke segments or modify the object
on a point-by-point basis, as outlined in the following section.

1 To select several objects: Click and drag the tool around the objects you
want to select. As you drag the tool, Flash displays a bounding box that
shows the current selection area. Release the mouse button when the
bounding box surrounds the objects.
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1 To add objects to the selection: Select an object and then Shift+click. To
add an object created in basic Shape Drawing mode, Shift+double-click
the object’s fill to add it to the selection.

1 To round up objects: Select the Lasso tool (it’s on the fly-out menu in
the fourth slot of the Tools panel), and drag it around the objects you
want to round up.

Modifying shapes point by point

When you create a shape with one of the shape tools or drawing tools, you
create a Vector object that’s composed of points and line segments (see
Figure 1-22). You can modify these shapes on a point-by-point basis. In this
section, we show you how to move points, add points, convert points, and
perform other, similar tasks.

When you select an object with the Subselection tool, which is like the
Selection tool on steroids, you can modify the shape on a point-by-point
basis. To quickly get to the point with the Subselection tool, follow these
steps:

1. Select the Subselection tool.

2. Click the perimeter of the shape
you want to modify.

The points that make up the shape
are displayed as hollow dots.

3. Click a point to select it.

The dot is filled, which signifies
that the point is selected.

4. Drag the point to a new
location. Figure 1-22: A tangent handle that twists a

The shape changes. curved line segment into submission.

5. Click a curve point.

The point and the tangent handles for the connecting line segments are
displayed.

6. Drag a tangent handle to modify the line segment.

As you drag the handle, Flash displays a preview of what the resulting
line segment will look like. If you select a point with two tangent handles
(the intersection of two curve line segments), the handles move in lock-
step. Press the Alt key (Windows) or Option key (Macintosh) and then
one tangent handle to modify it and not the adjoining tangent handle. If
you select a point that is the intersection of a straight and curve line seg-
ment, you have only one tangent handle to modify (see Figure 1-22).
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Modifying objects with the Pen tool and friends

What you create with the Pen tool, you can modify with the Pen tool. In
fact, you can modify any Vector shape with the Pen tool or one of his pals
that hang out on the same fly-out menu. You can modify a Vector shape by
adding anchor points and convert straight anchor points to curve anchor
points and vice versa.

To modify an object’s anchor points, select the object with the Subselection
tool and do one of the following:

1 Select the Add Anchor Point tool, and click a line segment to add an
anchor point. This action adds a straight point to the line segment. Click
and drag the point to convert it to a curve point.

1~ Select the Delete Point tool, and click a point to remove it.

1~ Select the Convert Anchor Point tool and click a curve point to convert
it to a straight point.

1~ Select the Convert Anchor Point tool, and then click and drag a straight
point to convert it to a curve point and modify the tangent handles at
the same time.

You can also use the Pen tool to modify the anchor points of an object you
select with the Subselection tool. As you move the tool toward a line seg-
ment, you see a plus sign (+) to the lower right of the tool icon, indicating
that you can click the line segment to add a point. If you move the tool
toward an anchor point and see a minus sign appear to the lower right of
the tool icon, you can click the point to delete it. If you move the tool toward
an anchor point and see an angled inverted lowercase v to the lower left of
the icon, you can convert the anchor point to its polar opposite by clicking
it. Make sure that you click the point you intend to modify; if you don’t, you
start creating a new path.

Modifying objects with the Property inspector

You use the Property inspector to set the properties for a drawing tool
before you use it. After you create the shape, you can also use the Property
inspector to modify it. The properties you can modify depend on the type of
object you created. To modify a basic shape:

1. Select the shape with the Selection tool.

2. Choose Window=>Properties.

The Property inspector appears, displaying the properties you can
modify for the selected object. Figure 1-23 shows the properties for a
shape created with the Oval tool. You can modify all basic properties for
the shape, such as fill color, stroke color, stroke width, and style.
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You can also modify the follow- PROPERTIES [ =

ing factors for any object you

select: Shape

e X: The position of the object
registration point from the
left side of the document. AR
e Y: The position of the object T i

registration point from the &5 w. 2370 He 160.0
top of the document. '

e W: The width of the object.
* H: The height of the object.

=7 FILL & STROKE

s - & - Book I

Stroke: (F—— Chapter1
You use scrubby sliders to change Style: [Solid [v] [Custom..]
these values. Position the cursor S
over a value. When it changes to a Scale: | Normal | * | O Hinting P
pointing finger with two arrows, drag -§ 2
left to decrease the value, and drag Cap: | ¥ loin: %> v Miter 1 oD
right to increase it. ¢ .%.

&,N\BER The unit of measure for values in
& the Property inspector is the same

unit of measure you specify for the ) . .
document. Figure 1-23: Modifying a basic shape.

Using the Free Transform tool

Another way to transform an object is by using the Free Transform tool. The
tool isn’t free, of course. You or your boss paid for Flash, the application in
which you find the tool. But you do use the tool to freely transform an object
into something that suits your Flash project. To freely transform an object,
follow these steps:

. 1. Select the Free Transform tool and then click the object you want to
e transform.

If the object was created using Basic Drawing mode, double-click the
center of the object to select the stroke and fill. After selecting the
object with the tool, eight handles appear around the object, as shown
in Figure 1-24.

2. To freely change the dimensions of the object, do one of the following:

e To change the height: Click the middle handle on the top or bottom of
the object, and then drag up or down.

e To change the width: Click the middle handle on the right or left side
of the object, and then drag right or left.

e To resize the object: Click a corner handle and then drag diagonally.
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Figure 1-24: The buck doesn't stop here with the Free Transform tool.

Hold the Shift key while dragging a corner handle to resize the object
proportionately. Remember to release the mouse button before releas-
ing the Shift key, or else the object may not resize proportionately.

. To move the object, place the cursor in the center of the object. When

it becomes a left-pointing arrow, with a four-sided arrow at the lower
left, click and drag the object to the position you want.

If the Free Tranform tool isn’t enough for you, choose Modifyr>
Transform=>Envelope. This command creates an envelope with eight
handles. Each handle is a Bezier point with two tangent handles. You
can click and drag the Bezier point to distort the object, and then fur-
ther distort the object by dragging the tangent handles. Such fun!

. To rotate the object, move the cursor toward one of the corner han-

dles. When it becomes a curved line with a downward-pointing arrow,
click and drag left or right to rotate the object.

. To skew the object, move the cursor to a line between the handles.

When the cursor becomes two lines with arrows pointing in opposite
directions, click and drag to skew the object.

. To transform an object using only one of the corner handles, press

Ctrl (Windows) or & (Macintosh) and move the cursor toward the
handle you want. When the cursor becomes a hollow arrow, click and
drag to transform the object from only that handle (see Figure 1-25).
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Figure 1-25: Quch! You got me by the short handle.

The Transform panel — a geek’s best friend

Some Flash designers are card-carrying, pocket-protector-wearing, duct-
taped-glass-wearing folks who think that math rules. If you find yourself
in that category, the Transform panel is your best friend. To transform an
object using the Transform panel, follow these steps:

1.
2.

Select the object you want to transform.

Choose Window=>Transform.

The Transform panel appears (see Figure 1-26).

To change the dimensions of the object, do one of the following:

e Drag the scrubby slider that’s located to the right of the horizontal,
dual-headed arrow to the left to decrease the width or to the right to
increase the width.

* Drag the scrubby slider that’s to the right of the vertical dual-headed
arrow to the right to increase the height or to the left to decrease the
height.

e C(Click the Constrain slider and then change the width or height. Flash
changes to other dimensions to resize the object proportionately.

. To rotate the object, click the Rotate radio button (the default selec-

tion), and drag the scrubby slider to the right to rotate the object
clockwise or to the left to rotate the object counterclockwise.

. To skew the object, click the Skew radio button and drag the first

scrubby slider to skew the object horizontally, and the second
scrubby slider to skew the object vertically.
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% [*—— Remove Transform

Duplicate Selection and Transform

Figure 1-26: It's time to transform an object.

The 3D Rotation section is used for animation, a topic we cover in
Book IIL.

6. To remove all transformations applied to the object, click the Remove
Transform icon in the lower-right corner of the panel.

7. To duplicate the object and transformation, click the Duplicate the
Selection and Transform icon in the lower-right corner of the dialog box.

This option is quite useful. For example, to create spokes for a wheel, use
the Line tool to create a vertical line. Then open the Transform panel and
rotate the line 15 degrees. After applying the first transformation, click the
Duplicate and Transform icon 11 times to spin your spokes.

The Info panel — read all about it

Sometimes you need precise information. When this need occurs, you can
find out the size of an object and its position from one handy little panel.
You can also use the panel to change the object’s dimensions and position
and to specify the coordinates of the cursor and the RGB values under the
cursor. (Talk about your multitasker!) To find out almost everything you
ever wanted to know about an object, follow these steps:

1. Select the object.
2. Choose Window=>Info.
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The Info panel appears, dis-
playing information about the

dimensions and position of the

selected object (see Figure 1-27). | = Wi 323.0 4G X 125.0
3. To change the size of the H: 167.0 ¥: 105.0

object, enter different values in o

the W and H fields. . G i 4% 3100

The Info dialog box doesn’t " B: 204 Y. 188.0

change the size proportionately. A: 100%

Use at your own risk.

4. To change the position of the  Figure 1-27: Extra! Extra! Read all about it.
selected object, enter different
values in the X and Y fields.

The X value controls the horizontal position of the object, and the Y
value controls the vertical position of the object.

5. Hover the cursor over an object to display its color values.

The Info panel displays color information using the RGB color model,
and also displays the alpha (transparency) value of the object.

6. Move the cursor to different positions on the Stage.

As you move the cursor, its current position (X and Y coordinates) are
displayed in the lower-right corner of the panel.

The Align panel — when precision counts

Freeform can be fun. But sometimes you have to align objects with precision.
At other times, you have to distribute a selection of objects equally (you
know, get your ducks in a row?), match their size, or space them equally.
When one of these tasks confronts you, there’s no need to whip out a calcula-
tor — or abacus or slide rule, if either one is your preferred calculation tool.
All you need to do is summon the Align panel and let it take care of the grunt
work for you. You can perform the following tasks with the Align panel:

1 To align an object to Stage: Select the object, open the Transform
panel (choose Windowr>Align), shown in Figure 1-28, click the To Stage
icon, and then click to select vertical and horizontal alignment icons.
The Transform panel is the one to use when your objects are out of
alignment.

1~ To align objects relative to each other: Select the objects you want to
align, open the Transform panel, deselect the To Stage option, and select
the horizontal or vertical alignment icons you want.

1 To evenly distribute selected objects relative to each other: Open the
Transform panel, deselect the To Stage option, and then select the verti-
cal or horizontal distribution buttons you want.
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1~ To evenly distribute selected Align Align
objects relative to Stage: Open horizontally vertically
the Transform panel, click the

To Stage icon, and then select ALicH | T
the vertical or horizontal distri-
bution buttons you want. Align:
] =] 1=

1+ To match the size of selected [Bn & oS|| | T° @0 ol o,
objects: Open the Transform Distribute: stage:
panel, deselect the To Stage = =[O [ N
option, and then click an icon Makch Jze- g : T
to match the width or height, Izu I-'{']EE-IEII_ E»:Ice.l
or both. If you select the To = H= B2 -= @

Stage option and choose one of |
the Match Size options, Flash Distribute
matches the selected objects vertically
to the width, height, or both
dimensions of the Stage.

Distribute
horizonatally

Figure 1-28: The panel to call when your objects

1~ To space three or more are out of alignment.

selected objects relative

to their current positions: Open the Transform panel, deselect the
To Stage option, and then click the space-vertically icon or space-
horizontally icon (or both).

1~ To space two or more selected objects relative to the Stage: Open the
Transform panel, select the To Stage option, and then click the space-
vertically icon or the space-horizontally icon (or both).

When you use the Align panel to match sizes or alignment of objects, Flash
uses the last selected object as the reference.

Creating groups

When you create a complex object that’s composed of many shapes, it’s
time to round them all up into a group. When you create a group, it behaves
like an individual object on the Stage, which is a good thing when your group
is a complex character. You can edit individual objects in the group, and
you can disband the group at any time, which can be useful if you're creat-
ing a Flash project that documents the history of a rock-and-roll band that
changed members more often than most people change underwear. Here are
some ways to work with groups:

1 To create a group: Select the objects you want to group and then
choose Modify=~>Group.

1~ To edit individual objects in the group: Double-click the group. This action
opens the group in a new window. You can now select individual objects in
the group and edit them using one of the many methods described in this
chapter. After you edit a group, click the Back or Scene button.

1 To ungroup a group: Select it and then choose Modify=>Ungroup.



Chapter 2: A Splash of Color,
S’it Vous Plait

In This Chapter

+~ Choosing the stroke color

1~ Choosing the fill color

1~ Using the Swatches panel

1+~ Working with the Color panel
~ Creating gradients

A Flash document without color would be black and white — or, in
other words: boring. Fortunately, Flash gives you all the tools you
need to create stunning full-color or, if you're so
inclined, Web-safe color documents. Whether
you're creating ho-hum rectangles, rotund circles,
or curvy paths, you can get wild and crazy, like
Van Gogh or Dalj, or take a slightly more sedate
route by just adding a splash of Web-safe color. If
you like rainbows of color, you’ll love our section
on creating gradients.

Color is what this chapter is all about. So put on
your rose-colored sunglasses and mix up a frothy
glass of pink lemonade while we show you every-
thing you need to know to create a colorful Flash
document.

Getting to Know Color: The Skinny
on RGB, HSB, and Hexadecimal

When you mix up a color for your Flash project, you mix a combination of
red, green, and blue; in other words, the RGB color model. In Flash, you can
specify the color by entering values for red, blue, and green or for hue, satura-
tion, and brightness. In another method, you enter the hexadecimal value for
a color. Here’s the lowdown on these methods for expressing color values:
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»* RGB: When you use the RGB color model to mix a color, you work with
256 hues of each color. When you do the math, you see that you can
choose from 16,777,216 colors. Even the trendiest interior designer would
go slightly bonkers from working with that many colors. But the possi-
bility exists. When you specify colors using RGB values, lower numbers
mean darker hues. Pure black is 0,0,0, and pure white is 255,255,255. Pure
red is 255,0,0; pure green is 0,255,0, and pure blue is 0,0,255.

1 HSB: When you specify colors using H,S,B values, you enter values for the
hue, saturation, and brightness. The Hue value is from 0 to 360 degrees,
and pure black is 0 or 360. Yellow is 120 degrees, green is 180 degrees,
and blue is 240 degrees. The Saturation value is from 0 to 100 percent; 0 is
totally unsaturated, and 100 is fully saturated. The Brightness value is also
a percentage, with darker colors falling on the lower end of the spectrum
and brighter colors falling at the high end of the spectrum.

1~ Hexadecimal values: When you specify colors using hexadecimal
values, you use a combination of numbers from 0 to 9 and letters
from A to F (six digits total). Pure black is #000000, and pure white
is #FFFFFF. The first two digits represent the Red value; the next two
digits, the Green value; and the last two digits, the Blue value. The pos-
sible combinations give you 256 hues of each color. Yep, you guessed it:
Hexadecimal is just a different way of expressing RGB values.

There’s no right or wrong way of expressing color values. If you're a pho-
tographer or you’re familiar with Photoshop, you probably prefer the RGB
method of expressing color. If you were born to be wild on HTML, you may
prefer hexadecimal. (We're not sure about HSB, but we think that it may
have originated in France after a night of Brie and Bordeaux.) Now that you
know everything — or perhaps more than you wanted to know — about
color, it’s time to work it into your Flash workflow.

Stroked and Filled, but Not Punched

When you create a shape with one of the shape tools, you have the option
of creating an outline for the shape — which, in Flash-speak, is known as the
stroke — and filling the shape with color or a gradient. The color inside the
outline is the fill.

A shape can have a stroke but no fill, or a fill but no stroke. If you like to
cover all the bases, you can create a shape that has no stroke and no fill, but
unless you're creating a Flash version of a polar bear in a snowstorm, we
advise against this strategy. In the following the sections, we show you how
to define the stroke and fill colors.
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Defining the stroke color

When you create a shape such as a circle or rectangle, you can add a stroke
to the shape, which in essence is a border. When you use the Pencil, Pen, or
Line tool, a stroke is all you've got. And, if you use the Pen tool to create a
sword — that’s another kettle of fish. To define the stroke color, follow these

steps:
1. Click the color swatch below the Stroke icon.
It looks like a pencil, near the bottom of the Tools panel.

The Swatches panel opens, as shown in Figure 2-1. The selected color is
shown in the upper-left corner of the panel. Notice the number next to

the color. That’s the hexadecimal — Gesundheit! — value for the color.
You also see an Alpha value, which determines the opacity of the color.

— Currently selected color

Hexadecimal value No Stroke

o

Figure 2-1: Defining the stroke color.

2. To create a shape with no stroke, click the No Stroke icon.
3. To specify the stroke color, do one of the following:

e Click a swatch. After you click a swatch, the panel closes, and the
Stroke color swatch changes to reflect your choice.

¢ Double-click the current hexadecimal value and enter a value.

e C(Click the color wheel in the upper-right corner to open the system
color picker. From within the color picker, click a color swatch or
enter values in the Red, Green, and Blue fields or the Hue, Sat, and
Lum fields.
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After clicking the current stroke color swatch, move the cursor to the
Stage and click an object whose color you want to match perfectly. This
technique is an ideal way to match a color from an image or a logo.

4. Accept the default Alpha value or drag the scrubby slider to specify a
different value.

Alternatively, you can double-click the current value and enter one

you want. When you specify a value less than 100 percent, the color

of underlying objects or the background is visible, which changes the
hue of the stroke. When you specify a low value, more of the underlying
color influences the color of the stroke.

You can also specify the stroke for objects you create with a tool in the
Property inspector. Select the tool, and in the Property inspector, click the
Stroke icon and follow these steps again.

Defining the fill color

Whether you create a cool shape by mixing and matching regular shapes

or create a shape using one of the drawing tools, your next step is to flesh
out your creation by filling it with color. To define the fill color, follow these
steps:

1. Click the color swatch below the Fill icon, which looks like a paint
bucket, near the bottom of the Tools panel.

The Swatches panel opens (refer to Figure 2-1). The selected color is
shown in the upper-left corner of the panel. The number next to the
color is the Hexadecimal value for the color. You also see an Alpha
value, which determines the transparency of the color. (We discuss
hexadecimal values in the section “Getting to Know Color: The Skinny on
RGB, HSB, and Hexadecimal,” at the beginning of this chapter.)

2. To create a shape with no fill, click the No Color icon (which is the
white square with the diagonal red slash).

3. To specify the fill color, do one of the following:

e C(Click a swatch. After you click a swatch, the panel closes, and the
Stroke color swatch changes to reflect your choice.

¢ Double-click the current hexadecimal value and enter a value.

e C(lick the color wheel in the upper-right corner to open the system
color picker. From within the color picker, select a color swatch or
enter values in the Red, Green, and Blue fields or the Hue, Sat, and Lum
fields.
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\3
P After clicking the current fill color swatch, move the cursor to the Stage

and click an object whose color you want to match perfectly. This tech-
nique is an ideal way to match a color from an image or a logo.

4. Accept the default Alpha value, or drag the scrubby slider to specify a
different value.

Alternatively, you can double-click the current value and enter one of
your own. When you specify a value less than 100 percent, the color

of underlying objects or the background is visible, which changes the
hue of the stroke. When you specify a low value, more of the underlying
color influences the color of the stroke.
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The Swatches panel is what you see when you specify a stroke or fill color. AL

There are, however, other ways to access this color collection of cubes that QZ §

may have inspired Rubik. If you're the adventurous type, you'll be glad to =

know that you have full control over the colors in the panel. You can delete -

colors, add colors, and export colors, for example. We show you how to use £ %

the Swatches panel in the following sections.

Understanding Web-safe colors

In a perfect world, you could use any color and it would look the same in
all Web browsers and all operating systems. But don’t forget the infamous
browser wars and whether ’tis nobler to Mac or PC — facts that leave the
poor Flash designer in a color-choosing quandary. Most modern monitors
and video cards can display any color you can throw at them. However, if
you're creating a Flash project that will be viewed on a device that doesn’t
support 16- or 24-bit color, choose your colors from the default Flash color
palette, which consists of 216 colors that are unsafe at any speed — er, we
mean safe in any browser viewed on any platform.

Getting to know the Swatches panel

The Swatches panel has color swatches (216, to be exact) and gradient
swatches. You use the Swatches panel to select colors for the fill and stroke
of objects created with the drawing tools. You also use the Swatches panel
to manage and export color sets, for example. Follow these steps for a quick
tour of the Swatches panel:

1. Choose Windowr>Swatches.

The Swatches panel (see Figure 2-2) appears. If you're into keyboard
shortcuts like we are, press Ctrl+F9 (Windows) or 8+F9 (Mac) to open
the panel.
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2. To add a color to the panel from an object Click to open Options menu
in the workspace, move the cursor over
the object whose color you want to sample
and then click. Move the cursor inside the
Swatches panel (the icon becomes a paint
bucket) and then click to add the sampled
color to the panel.

3. Click the icon to the far right of Swatches.

The Swatches panel Options menu (see
Figure 2-3) opens.

4. Choose one of the following options from
the menu:

e Duplicate Swatch: Duplicates the selected

swatch. Figure 2-2: The Swatches panel
o Delete Swatch: Deletes the selected has lovely cubes of color.
swatch.

e Add Colors: Opens the Import Color
Swatch dialog box, which enables you to add a Flash color set (using
the .CLR extension) or a color table (using the .ACT extension). You
also have the option to import colors from an existing image in the
GIF format. When you choose the latter option, Flash recognizes the
colors in the image and creates a swatch for each color.

Duplicate Swatch
Delete Swatch

Add Colors...
Replace Colors...
Load Default Colors

Save Colors...
Save as Default

Clear Colors

Web 216

Sort by Color

Help

Close

Close Group

Figure 2-3: Every panel has to have options.
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If you're creating a Flash project for a client and you need to match
the colors from the client’s logo, import the logo into your favorite
image-editing application and save it as a GIF file. Use the Add Colors
command from the Swatches panel Options menu and then select
the image to add the colors to the existing color set.

e Replace Colors: Opens the Image Color Swatch dialog box. Select a
Flash color set or a color table. The colors from the imported color
set or table replace the existing colors. Another option is to select an
image in the GIF format. Flash recognizes the colors in the image and
uses them to replace the existing colors.

e Load Default Colors: Loads the default color set.

e Save Colors: Opens the Export Color Swatch dialog box, in which
you can save the colors that are currently in the Swatches panel as
a Flash color set with the .CLR extension or a color set with the .ACT
extension.

If you're going to use an exported color set in another Adobe applica-
tion, such as Fireworks or Photoshop, save the exported colors as a
color set with the .ACT extension.

e Save as Default: Saves the current colors as the default color set for
creating new documents.

e (Clear Colors: Removes all color swatches except for the default black
and white colors. This choice is excellent if you're creating a color
set from scratch using the Color panel or by adding colors from an
existing color set or .GIF image.

e Web 216: Loads the Web Safe palette with 216 colors.

e Sort by Color: Arranges the swatches according to hue.

Creating a custom color set

If you're creating Flash projects for clients and use the same colors regu-
larly, you may find it beneficial to create a custom color set. You can easily
do so from within the Swatches panel by following these steps:
1. Choose Windowr>Swatches.
The Swatches panel appears.
2. Delete the colors you don’t want saved with the custom color set.

To delete a color, select the swatch you want to delete and then choose
Delete Swatch from the Swatches panel Options menu.
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3.

5.
6.

8.

Add colors to the color set.

You can add colors by choosing Add Colors from the Swatches panel
Options menu and then importing a color set or having Flash create the
color swatches from an existing GIF image.

To sample a color from an object on the Stage, select the eyedropper tool,
click the color you want to sample, move the cursor into the Swatches
panel, and then click to add the sampled color to the color set.

Add and delete additional colors as needed.

After customizing the color set, choose Save Colors from the Swatches
panel Options menu.

The Export Color Swatch dialog box appears, as shown in Figure 2-4.

Export Color Swatch B[]
Savein i;"_‘?Cn\anets |vl o s A b

Recent

Deskiop

My Documents

8

My Computer

‘t; File name: | iV[ Save
My Networ | Save asiype: | lsh Cobr Set (o I

Figure 2-4: Exporting a custom color set.

Navigate to the folder in which you want to save the color set.

Store the file in a folder you can easily find. You may want to create
a new folder named Color Sets in either your client’s folder or your
Documents folder.

Enter a name for the color set.

Choose a name that reflects the purpose for which the color set is used.
If it’s for a client, use the initials of the client’s company as the filename.
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9. Choose an option from the Save as Type drop-down menu.

Your choices are Flash Color Set (.CLR), or Color Set (LACT). If you're
only using the color set in Flash, save it as a Flash color set. For maxi-
mum compatibility with other Adobe image-editing applications that use
color sets, choose Color Set.

10. Click Save.

Flash saves the color set for future use.

Mixing a Color

Book II

Yellow, blue, what'll you do? Chapter2
Maybe you should mix a color. =
v

Black, white, is all right =hL
s

Living color may be what you need. s ;:
2o

The Swatches panel is a useful starting point when you need to choose 2 %

a color for a Flash project. But sometimes the color you need isn’t in the
Swatches panel. Mixing a color, though, isn’t just about mixing up a solid
color like the paint department down at your local hardware store does.
You can mix gradients, which are blends of two or more colors. When you
need a hipper-than-hip-funkier-than-funky color or a gradient that contains a
plethora of colors, look no further than on the Color panel. In the following
sections, we show you how to mix a color and gradient.

Getting up close and personal with the Color panel

A swatch is a cool tool when you need to get down, get funky, and grab a
color quickly. But if you're creating a Flash project on a rainy day while
you're dreaming away, you can create any color — even sky-blue pink — in
the Color panel. The Color panel also makes it possible for you to mix gra-
dients — blends of two or more colors — that come in different flavors. We
show you everything you need to know about mixing colors and gradients
with the Color panel in the following sections.

Mixing a swatch of color

When you need a color for a stroke or fill that’s not present on the Swatches
panel, you can easily mix what you need by using the Color panel. You can
mix a color by dipping the cursor into the color well or by entering the
values of the color, if you know them. To mix a color by using the Color
panel, follow these steps:



132 Mixing a Color

1. Choose Window=>Color. — Fill

The Color panel appears, as Stroke
shown in Figure 2-5. The panel

gives you the option of mixing a
color for strokes or fills created
by using the drawing tools. You

can also revert to the default ol | Type:|Solid |+
stroke and fill colors (black
and white), specify no color, or & o)
swap the existing stroke and fill L)
colors.
2. Click the Stroke or Fill color - S ||
icon. G:| 104 |w
This step determines whether B:| 66  |wi
the mixed color appears in the Alpha: | 100% | | £395842

Stroke or Fill color swatch in the
Tools panel.

3. Choose an option from the
Type drop-down menu.

Your options are None, Solid,
Linear, Radial, or Bitmap. The
Linear and Radial options are Figure 2-5: Mix a color without getting
for gradients, which are covered in  paint on your hands.

the “Creating a gradient” section,

later in this chapter. (Creating a

bitmap fill is covered in Chapter 6

of this minibook.)

4. If you know the color values, enter them.

If you know the RGB, HSB, or hexadecimal values, you can enter them
in the appropriate fields. If the color model you want isn’t displayed,
you can choose it from the Color panel Options menu (see Figure 2-6),
which is accessed by clicking the icon in the upper-right corner of the
panel.

5. To mix a color from scratch, drag inside the color well until the
swatch is the hue you want, and then drag the Brightness slider.

As you change the color and brightness, the Current Color Swatch is
updated in real time.
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Color well

cocor | I _ ch

HSB

Add Swatch
Help

Close
Close Group

— Brightness slider

Figure 2-6: Options are a good thing.

6. Drag the Alpha slider to change the opacity of the color.

Alternatively, you can enter a value from 0 to 100. When you specify a
value less than 100 percent, the color becomes partially transparent,
and you can see the underlying colors.

7. Choose Add Swatch from the Color panel Options menu to add the
color to the Swatches panel.

After mixing a color for the stroke or fill, you can keep the panel open to
mix the other color. If you're creating a custom color set from scratch,
you can continue mixing colors and choose Add Swatch from the Color
panel Options menu to finish creating the custom color set.

Creating a gradient

The Flash Swatches panel has a couple of default gradients you can use.

But if you or your client think that the project needs custom color gradients,
you can mix your own in the Color panel. You can create a linear gradient,
which mixes the colors from left to right, or a radial gradient, which mixes
the colors concentrically. Figure 2-7 shows both a linear and radial gradient.
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Linear Radial

Figure 2-7: Gradients come in two flavors — linear and radial.

To create a gradient, follow these steps:

1. Choose Window=>Colors.
The Color panel appears.
2. Click the Fill icon.

You wouldn’t specify a gradient for a stroke, would you?

3. Select a gradient type from the Type drop-down menu.

Your choices are Linear and Radial. The
default gradient colors are black and white
(see Figure 2-8). (Black-and-white gradients
are only one stop removed from monotone,
from which the word monotonous is derived.)

4. Choose an option from the Overflow drop-
down menu.

This option determines how colors are
applied when they extend beyond the gradi-
ent. You have three overflow options:

e Extend: The default option applies the
colors past the end of the gradient.

e Reflect: The colors of the gradient are
repeated in a pattern from beginning to
end and then reversed, which fills a shape
with a mirror-like reflection.

e Extend: Repeats the gradient colors from
beginning to end until the shape is filled.

COLOR
— ey

<R [

B £ i =

EY O\rerﬁow.!" E .Lv.!
[Linear RGE

" A8

Figure 2-8: Black-and-white
gradients — horing.
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5. Select the Linear RGB check box to create a gradient that’s SVG
(Scalable Vector Graphics) compliant.

You can scale the vector object to which the gradient fill is applied, and
the fill scales properly with no degradation.

6. Select the first color stop and specify a color for it.

The default gradients have two stops. You add a stop wherever you
want to introduce a new color. You can specify a color for a stop in sev-
eral ways: You can double-click the stop to open the Swatches panel,
drag the cursor in the color well, and then drag the brightness slider,
enter the RGB, HSB, or hexadecimal values for the color you want, or
drag the individual color sliders.

7. Specify the Alpha value for the first color stop.

To specify the Alpha value, enter a value in the text field or drag the
slider.

8. Select the second color stop and specify its color and Alpha value.
We know what you’re thinking: Are two stops all we get? If that question
weighs heavily on your mind, please read Step 9.

9. Move the cursor toward the color bar and click when it becomes a
left-pointing arrow with a plus sign (+).

Another color stop is added. You can add as many color stops as you
need.
10. To remove an unneeded color stop, select it and drag it off the
color bar.
The secretary disavows any record of its existence.
11. Specify the color and Alpha value for any ﬂ
color stops you add. LDLOR
. . . . e Type: | Radial v
Figure 2-9 shows a radial gradient with more T
colors than a psychedelic ice cream concoc- S e .
tion you'd find in a Haight-Ashbury ice cream % 1% [lipenses
store. R:| 235 Iv B
Gi| 205 |w h
If you want to save a gradient for future use, B: 88 |w -
choose Add Swatch from the Color panel Options Alpha: | 100% |+ | #EBCDSS
menu. ;
& m| @
When you create a radial gradient, the leftmost
stop is the color in the center of the gradient.

Figure 2-9: Two scoops of
Strawberry Alarm Clock,
please.
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Using the Transform Gradient tool

After you apply a gradient to a shape, you can change the way the gradient is
mapped to the shape by using the Transform Gradient tool. You can use it to
scale the gradient, rotate the gradient, and change the width of the gradient.
To modify a gradient with the Transform Gradient tool, follow these steps:

1. Select the Transform Gradient tool.

The Transform Gradient tool shares the third slot on the Tools panel.
If the tool isn’t visible, click the Free Transform tool and select the
Transform Gradient tool from

the fly-out menu. Hollow dot Round handle

2. Click the shape whose gradient
you want to transform.

If you click an object with a
linear gradient, two handles
appear around the object, and
one hollow dot appears in the
center (see Figure 2-10). If you
click an object with a radial
gradient, three handles appear
around the object, and one
hollow dot appears in the center (see Figure 2-11).

Square handle

Figure 2-10: Transforming a linear gradient.

3. If you're transforming a linear gradient, these are your options:

* Rotate the gradient: Position the cursor over the round handle, and
when it becomes a circle with four curved arrows, drag clockwise or
counterclockwise to rotate the gradient relative to the shape.

Hollow dot Handles—

Figure 2-11: Transforming a radial gradient.
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* Change the width: Position the cursor over the square handle, and
when it becomes a dual-headed arrow, drag left or right to decrease
or increase the width of the gradient.

* Change the center: Position the cursor over the hollow dot, and when
it becomes a cross with four arrows, drag to change the center of the
gradient relative to the object.

4. If you’re transforming a radial gradient, here are your options:

* Change the width: Position the cursor over the uppermost handle,
and when it becomes a dual-headed arrow, drag left or right to
decrease or increase the width of the gradient.

e Change the scale: Position the cursor over the uppermost circular
icon, and when it becomes a hollow circle with a diagonal arrow,
drag in or out to increase or decrease the scale of the gradient.

* Rotate the gradient: Position the cursor over the lower circle, and
when it becomes a hollow circle with four curved arrows, drag clock-
wise or counterclockwise to rotate the gradient relative to the shape.

e Change the center: Position the cursor over the hollow dot, and when
it becomes a cross with four arrows, drag to change the center of the
gradient relative to the object.

Changing Colors

Editing colors on Flash objects is a piece of cake. You can change the stroke
or fill of an object at any time. You change the stroke by using the Ink Bottle
tool and change the fill by using the Paint Bucket tool.

Using the Ink Bottle tool

You use the Ink Bottle tool to change an object’s stroke. You can change an
object’s stroke at any time by following these steps:
@ 1. Select the Ink Bottle tool.

2. In the Property inspector, click the Stroke color swatch and select a
color from the Swatches panel.

3. In the Property inspector, specify the stroke width and style.
4. Click the object whose stroke you want to change.

The object’s stroke changes to reflect the stroke parameters you specify
in the Property inspector. If the object has no stroke, a stroke is applied
to it.
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Using the Paint Bucket tool

When you need to ch-ch-ch-change the fill of an object, you use the Paint
Bucket tool. The ability to quickly change the fill of any object comes in
handy when you have a client who can’t seem to make up her mind, and a
blinding flash of artistic insight tells you that every pink object in your Flash
project should be mellow yellow. To change the fill of an object with the

Paint Bucket tool, follow these steps:

& 1. Select the Paint Bucket tool.

2. In the Property inspector, click the Fill color swatch and select a color

from the Swatches panel.

3. Click the object whose fill you want to change.

Using the Kuler Extension

If you want to have a colorful Flash design (and who doesn’t?), consider

using the Kuler extensions. We're not sure how
this term is pronounced or how Adobe came up
with the name, but we’re pronouncing it “cooler.”
So whenever you want a cooler Flash design, call
up the Kuler extension and mix up some master-
ful color:

1. Choose Window=>Kuler.

The Kuler panel appears (see Figure 2-12).
Notice the colorful round area — the color
wheel.

2. Select an option from the Rule menu.
Your choices are described in this list:

e Analogous: Creates a color palette using
colors that are adjacent to the base color
on the color wheel. This color scheme is
also referred to as harmonious.

e Monochromatic: Creates a color palette
using different values the base color.

e Triad: Creates a color palette using colors
that are 120 degrees from the base color
on the color wheel.

e Complementary: Creates a color palette
using colors that are opposite each other
on the color wheel.

R O& N
e
G:?———
Dl —

143

(i}

=

Save Theme +5 @

Figure 2-12: Kuler rhymes (we
think) with cooler.
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e Compound: Creates a color palette using a combination of the rules.

e Shades: Creates a color palette using colors that are shades of the
base color. If your client is a blues guitarist, this option is an excel-
lent choice. Choose blue as the base color and you’ll have several
shades of blue for your Flash creation.

e Custom: Creates a palette based on your input.

. Select a base color.

You can select a base color by dragging the R, G, and B sliders.
Alternatively, you can enter the R, G, B, or hexadecimal values of a color.

. Modify the color scheme.

The beauty of Kuler comes into play in this step. You can drag any of the
dots to modify the color scheme. You can also double-click any color

to make it the active color and then modify the R, G, B, or hexadecimal
values. You can also control the brightness of the active color by drag-
ging the brightness slider. This action creates a darker or lighter shade
of the color.

To create a color scheme based on the current stroke color, click the
Add Current Stroke Color as Base Color icon. To create a color scheme
based on the current fill color, click the Add Current Fill Color as Base
Color icon.

. Click a color swatch and the click the Remove This Color from the

Theme icon.

The color is removed from the palette. After you remove a color from
the palette, the Add a New Color to the Theme icon becomes available.
After clicking the icon, you can mix a new color by entering R, G, B, or
hexadecimal values. The other colors are changed based on the color
rule you specify in Step 2. You can remove any color from the palette
except the base color.

You can also modify the color palette by clicking the Affect the Other
Colors in the Theme Based On Harmony icon.

. Click the Stroke color swatch and then click a color from the Kuler

color palette you created.

The stroke color is updated to reflect your choice.

. Click the Fill color swatch and then click a color from the Kuler color

palette you created.

The fill color is updated to reflect your choice.

. Click Save Theme.

The Save Theme dialog box appears.

. Enter a name for the theme and click OK.
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The color palette is saved to the Kuler panel. To use the saved theme,
click Browse and then choose Saved from the drop-down menu.

10. Click Add This Theme to Swatches.
The color palette is added to the Swatches panel.
11. Click Upload to Kuler.com.

Choose this option if you want to share your creation with other Kuler
fans. When you choose this option, you're prompted for your username
and password.

If you're not feeling terribly creative or you just want to see what other Kuler
users are doing, click Browse. The Kuler panel refreshes to show color pal-
ettes created by other Kuler users. You can sort the palettes by choosing an
option from the drop-down menu. For example, you can choose the highest-
rated or most popular palettes. You can fine-tune your search by limiting the
time period in which the palettes were uploaded to Kuler. The default is All
Time, but you can limit the number of palettes by choosing Last 7 Days or
Last 30 Days. After navigating the themes, you can add a selected theme to
the Swatches panel or edit the theme as outlined in this section.



Chapter 3: Getting the
Word Out with Text

In This Chapter

1~ Mastering the Text tool

1~ Stylizing text
1~ Creating text
v~ Editing text

+~ Finding and replacing items

W‘iters love words. So do readers. If you create Flash projects with
information from writers that will be read by site visitors, it’s your
job to add the words to the Flash project. You do
so with the Text tool. We know that sounds like

a case of the blatantly obvious, but the Text tool
isn’t as easy to use as some would think. In fact,
each of the three text types has different proper-
ties: garden-variety static text when you need to
get the word out; dynamic text when you’re creat-
ing a project with text that changes frequently or
otherwise need to be addressed with ActionScript;
and input text when you want site users to enter
information such as their names or credit card
numbers. (In fact, you can even animate text, but
that’s a subject for another chapter.) In this chap-
ter, we show you how to master the Text tool.

Using the Text Tool

The Text tool is similar to one of those pens with

three colors of ink and a PDA stylus all wrapped in one neat container. With
the Flash text tool, you can create static text, dynamic text, or input text. In
the following sections, we show you how to use the Text tool to create each
text type.
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Creating static text

Static text may sound somewhat boring, but you can get a charge out of it.
You can use any font on your system when creating static text. You can styl-
ize the text, have a multiline text field, and do much more. To create static
text, follow these steps:

1.
2.

Select the Text tool.

In the Property inspector (choose
Windowr>Properties), choose
Static Text from the uppermost
drop-down menu (see Figure 3-1).

. Click and drag the area where

you want the text to appear.

When you create static text boxes,
you can only set the width of the
text box. The default option is to
display a single line of text.

. Set the text parameters in the

Property inspector.

The parameters for static,
dynamic, and input text are almost
identical. We cover them in the
later section “Formatting Text.”

Select an option from the
Orientation section of the Property
inspector.

The default option is horizontal.

PROPERTIES | =

Text Tool L3
[ Static Tt [>] R
=+ CHARACTER

Family: |Er‘-na" | ¥ | g
e = |8
Size: 81.0pt Letter spacing: 0.0 [Tl

color: [l & uto kern <
Anti-alias: | Anti-alias for readability. | | =
| = YT, G
&,

= PARAGRAPH '/
Forma: B2 EH) 5;
Spacing: f
Margins: =
Behavior: v o’\m
Orientation: B |» Q‘

Figure 3-1: Creating static text.

You can also create vertical text that goes from left to right or from right

to left.

You can change the orientation of the text after creating it and then
choosing an option in the Orientation section of the Property inspector.

. Type some text.

As you enter text, it automatically wraps to the next line.

. Modify the width of the text box in the Property inspector.

You cannot modify the height of a static text field.
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8. When you finish creating text, click outside the text box or select
another tool.

As long as the cursor is inside the text field, the Text tool is still active,
primed, and ready.

Adding a hyperlink to text

When you create static text, you can PROPERTIES

apply a hyperlink to a selection of text.

After you create the hyperlink, you T :

specify whether it opens in the same [EETE E2
window or a different window. To e b s T

create a hyperlink, follow these steps:

1. Create a block of static text.

If you don’t know how to create
a block of static text, read the

. . . Family: |:rsa| | |
“Creating Static Text” section, ear- — =
lier in this chapter. Style: |Regular

Size: 12pt Letter spacing: [
2. Using the Text tool, select the text
5 v
to which you want to apply the cofor: I I Auto kern
hypel‘link. Anti-alias: | Anti-alias for readability | »|
EIERE! (1y(z)

3. In the Options section of the
Property inspector (choose
Window=>Properties) enter the
URL for the Web page that will

== PARAGRAPH

open when the link is clicked. Format: (£ £ E/ =

4. Choose an option from the Target Spacing: 25 (pt 3= lpx
drop-down menu (see Figure 3-2). Margins: +E 0 px =
Your choices are shown in this e
list: Behavior: | Multiline | >

) Orientation: 75 | =
e _blank opens the page in a new
window. S ORTIOM: >

e _parent opens the page in the Link: [http://www.dasdesigns.net |
parent of the current frame. Target: | |
* _self opens the page in the _blank ]
current frame in the current _parent
. =7 FILTERS
window. el _self
Propeny tl]p
* _top opens the page in the - =

top-level frame in the current
window. Figure 3-2: Aim to load the URL in the
target.
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Creating input text

You create an input text field when you want the Flash application to accept
input from the user. Input text fields can be formatted to accept a single line
of text or multiple lines of text. You can also specify whether the text wraps
to a new line when it exceeds the width of the field. And you can and limit
the maximum number of characters that users can input into the field. To
create an input text field, follow these steps:

1. Select the Text tool.

2. In the Property inspector, choose Input Text from the Text drop-down
menu.

3. Enter an instance name for the text box.

You use the instance name when you address the text box with
ActionScript.

4. Click and drag the area where you want the text to appear.

When you create input text boxes, you can set the dimensions as you
drag the tool on the Stage.

5. Set the text parameters in the Property inspector.

The parameters for static, dynamic, and input text are almost identical.
We cover those in the later section “Formatting Text.”

Creating dynamic text
Dynamic text boxes display text that’s updated dynamically at runtime or
by the use of ActionScript. Dynamic text boxes can also be used to display
text that’s loaded from an external file. To create a dynamic text box, follow
these steps:

1. Select the Text tool.

2. In the Property inspector, choose Dynamic Text from the Text drop-
down menu.

3. Enter an instance name for the text box.

You use the instance name when you address the text box with
ActionScript.

4. Click and drag the area where you want the text to appear.

When you create dynamic text boxes, you can set the dimensions as you
drag the tool on the Stage.
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5. Set the text parameters in the Property inspector.

The parameters for formatting static, dynamic, and input text are almost
identical. We cover those in the later section “Formatting Text.”

<P To make an input or dynamic text box that’s scrollable, create the text field
and then choose TextroScrollable. After you issue this command, a black dot
appears in the lower-left corner of the text box. You can fill it to overflowing.
When the file is published, a user can click inside the text box and drag the
mouse to scroll the text.

If you have a lot to say, create your text in a word processing application,

\\J
press Ctrl+A (Windows) or 38+A (Mac) to select the text and then press Book Il

Ctrl+C (Windows) or 8+C (Mac) to paste the text to the Clipboard. In Flash, Chapter 3
place the cursor inside the text field and then press Ctrl+V (Windows) or
8+V (Mac). Note that some of the formatting you apply in a word processing o
application may not be preserved when you paste it into Flash. g E
s3a
=3
Formatting Text g5
(=9

Text without formatting is boring. When you create static, input, or dynamic
text, you can specify all the usual suspects, such as font, size, style, and
color. You can also determine whether viewers of your Flash masterpiece
(why would you create anything less?) can select text. In the upcoming sec-
tions, we show you how to set character parameters, format paragraph text,
and resize text fields.

Specifying text character parameters

Formatting text in Flash is almost like formatting text in your favorite word
processing application. The options are almost identical for static, dynamic,
and input text, which is why we’re conserving paper and showing you how
to specify character styles in one section. When a parameter is unique to a
specific type of text, we tell you which type of text for which the parameter
is used. To specify character parameters, follow these steps:

1. Create a text field.

Vive la difference. Specify whether the text is input, dynamic, or static in
the Property inspector. The Character section of the Property inspec-
tor updates to show you the available options. Figure 3-3 shows the
Property inspector after creating a dynamic text box.



’46 Formatting Text

2. In the Property inspector, select a
font type from the Family
drop-down menu.

You have lots of choices; one for
each font you installed on your
computer.

3. Select a style from the Style drop-
down menu.

This is Word Processing 101 — you
can choose from Regular, ltalic,
Bold, or Bold-Italic.

4. Drag the scrubby slider to specify
the text size.

Alternatively, click the current
size to reveal a text field, and then
enter a value.

5. Drag the scrubby slider to specify
text spacing.

Alternatively, click the current
value to reveal a text field and
then enter a value. Positive values
space the letters farther apart, and
negative values scrunch the text
closer together.

6. Accept the default text color or
click the color swatch.

Clicking the color swatch reveals
the Swatches panel. Select a color.
If you want the text to be semitrans-
parent, specify an alpha value less
than 100. For more information

on color, refer to Chapter 2 of this
minibook.

7. Accept the default Auto Kern
option, or click the check box to
deselect it.

PROPERTIES |1

T

| Dynamic Text

== POSITION AND

Family: |-trlal

B2

Style: |::cEguIar

[v]

55.0pt
color: I & auto kem

Size:

Letter spacing: 0.0

Anti-alias: | Anti-alias for readability

eS| L

| Character Embedding...

= PARAGRAPH

Format: |%|§||%H%

Spacing: 2=

Margins:

Behavior: | Single line

Ak

Orientation: | »

=7 OPTIONS

Link: |

Target:
Variable:

== FILTERS

[k

Proparty | Walus

4

Figure 3-3: Dynamic, isn't it?
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Auto Kern uses the font family information to determine the spacing
between characters. If you disable this option, all characters are spaced
equally, which may cause certain character pairings to look a bit odd.

Choose an option from the Anti-Alias drop-down menu. Your
choices are

e Use Device Fonts: Anti-aliases text according to the fonts installed on
a user’s computer. If you choose this option, make sure that you use
one of the Flash device fonts when creating the text: _sans, _serif, or
_typewriter.

e Bitmap Text (No Anti-Alias): Disables anti-aliasing and renders crisp
text, which results in a larger file size because font outlines are
embedded with the resulting SWF file. The text renders well at the
original size but doesn’t scale well.

e Anti-Alias for Animation: Alignment and kerning information are dis-
regarded, which results in a smoother animation. This option results
in a larger file size because font outlines are embedded. When using
this option, in order for the text to be legible, make sure that the font
size is 10 or larger.

e Anti-Alias for Readability: The Flash text engine renders the font to
ensure high quality and legibility. The file size increases because the
font outlines are embedded. When you use this option, the file must
be published for Flash Player 8 or later.

e Custom Anti-Alias: The Custom Anti-Aliasing dialog box opens, which
enables you to modify the font by specifying the thickness of the font
anti-alias transition and the sharpness of the transition between the
font and the background. This option increases the file size. To spec-
ify custom anti-aliasing, you must publish the file for Flash Player 8
or later.

(Optional) Click the Selectable icon.
This option enables users to select the text.
(Optional) Click the Render Text as HTML icon.

This option enables you to use HTML formatting on an external text file
that’s loaded into the field. For example, to make text boldface, you use the
<b> and </b> tags. Any text between the tags conforms to the tag attribute.

To create an outline around the text field, click the Show Border
around Text icon.
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12.

13.

To add superscripting or sub-
scripting to selected text, click
the applicable icon.

You can apply character set-
tings to an entire block of text or
apply settings to a selected set of
characters or, in non-geek-speak,
a word or selection of words.

To embed font characters with
the published file, click the
Character Embedding button.

This step opens the Character
Embedding dialog box (see
Figure 3-4). Select a character
set from the list. You can select
multiple character sets by press-
ing Ctrl and then clicking the
sets you want to embed. You
can have Flash determine which
characters need to be embed-
ded based on what you already
entered in the field by clicking

‘Character Embedding

Select the character sets you want to embed. To select
multiple sets or to deselect a set, use Ctrl+dick.

| All {55870 glyphs) lA.l
|Uppercase [A..Z] (27 glyphs) il
|Lowercase [a..z] (27 glyphs)

| Mumerals [0..9] (11 glyphs)

| Punctuation 1@#%...] (52 glyphs)

|Basic Latin (95 glyphs)

| Japanese Kana (318 glyphs)

| Japanese Kanji - Level 1 (3174 glyphs)

| Japanese (All) (7517 glyphs)

| Kiorean Basic Hangul (3454 glyphs)

| Korean Hangul (All) (11772 glyphs)

| Traditional Chinese - Level 1 (5609 glyphs) |
| Traditional Chinese (Al (18439 alvohs) _|V|

Indude these characters;

Auto Fil

Total number of glyphs; 0

’Don'tEmbed ] [ OK ] ’ Cancel ]

Figure 3-4: Yikes! We're gonna be embedded.

the Auto Fill button. After selecting a character set, click OK to close the

dialog box.

Working with paragraph text

If you're creating a simple banner or one line of input or dynamic text,

you're finished after you specify the character settings. However, if you have

multiple lines of text, you can format the text just like you would format a
paragraph in your favorite word processing application. To apply paragraph
settings to a text field, follow these steps:

1.

Create a text field.

Select Static, Input, or Dynamic from the Type drop-down menu. If

you select Static, you can’t apply paragraph settings to the field until
you create several lines or paragraphs of text. Figure 3-5 shows the
Paragraph section in the Property inspector when formatting a dynamic

text box.

. Choose an option from the Format section.

Your choices are align left, align center, align right, or justify.

sentence in each paragraph.

. Drag the Indent Spacing scrubby slider to set an indent for the first

Alternatively, you can click the current value and enter a value.
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4. Drag the Line Spacing scrubby PROPERTIES
slider to set the spacing between | |
lines. T

| Input Text | =]

Alternatively, you can click the

current value and enter a value. SRR AND

[k

5. Drag the Left Margin scrubby

slider to set the left margin. H: 32
Alternatively, you can click the
urrent value and enter a value. i aciel =
6. Drag the Right Margin scrubby Style: [Regular (=]
slider to set the right margin s
g gin. Size: 55.0pt  Letter spacing: 0.0 Chapter 3
Alternatively, you can click the color: I & auto kem
current value and enter a value. e TP ——— o ®
. —_—— 2
7. Choose an option from the (o) [T, g- g
Behavior drop-down menu. S5
| Character Embedding... = g
The option you choose determines 2o " s
how the text flows. Your choices - = g._

are Single Line, Multiline, Multiline Format: (£ £ E| =
No Wrap, and (if you're creating

Spacing: 22 [0 pt 20 px
input text) Password. = ;

Margins: += 0.0 px A px

9 0 . .
8. If you re creatmg input text, in Setird [ sinaie line i
the Options section drag the Max
. : e T [
Chars scrubby slider to the value | °rientstion: == |
you want. <7 OPTIONS
Use this optional step if you want Max chars: 0
to limit the number of characters =
that the characters using the bhatesilad
published file can enter into the ]
text box. Alternatively, you can —
. =~
click the current value and enter a
Proparty | Valua

value.

4

Figure 3-5: Formatting paragraph text.

Creating Text

A Flash project without text is just graphics. If you already read the previous
sections, you know that you have a great deal of flexibility when you need to
add text to a Flash project. However, sometimes even the best-laid plans go
to waste and you end up with a document with gobs of text. In this section,
we point out some issues you need to consider when creating text for your
documents — and some solutions.
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Font considerations

Some designers get carried away when using fonts. They mix and match

font types and mix boldface and italicized fonts, for example. This creates a
confusing message to viewers because it looks like the designer cashed in on
a font sale at Font’s Fifth Avenue and finally found a design in which to use
them. In addition to presenting a confusing message, it bloats the file size.
So, whenever possible, think “less is more” when choosing fonts. In the fol-
lowing sections, we offer more sage advice for choosing fonts.

Choosing fonts for static text fields

When you specify a font for a static text field, Flash embeds the font outline
in the resulting SWF file to ensure that the text looks identical when played
in the Flash Player on other users’ computers. However, if you have a large
amount of text in a Flash project that uses different font families and styling,
you run the risk of creating a large file that takes a while to load. When you
plan a project that contains a lot of text, make sure to stick with one font
family. If file size is a real issue, consider using device fonts because they
aren’t embedded in a Flash SWF file. When you use a device font, the Flash
Player uses the closest match from the user’s computer to render the text.
As a bonus, device fonts result in more legible text when you specify a font
size of 10 points or smaller. To convert a text field to device fonts, follow
these steps:

1. Select the Text tool.
2. Double-click the text field you want to convert to device fonts.

All the text is selected.

3. In the Character section of the Property inspector, choose one of the
following choices from the Family drop-down menu:

e _sans: Resembles Arial or Helvetica
e _serif: Resembles Times Roman

e _typewriter: Resembles Courier

Some font outlines cannot be embedded in a Flash SWF file. To ensure that
you choose fonts that can be embedded, choose Viewr>Preview=>Anti-Alias
Text. If any text you create with a font family has jagged edges, don’t use
that family in your project.

Choosing fonts for input and dynamic text fields

When you create input or dynamic text fields and specify a font family, Flash
records the name with the published SWF file. When the file is played, Flash
Player renders the text using the same font or a similar one from the user’s
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computer. To ensure that the file renders correctly, you can embed font out-
lines with the file, but that increases file size. You can also specify a device
font as outlined in the previous section.

Converting text to graphics

Sometimes you pick a cool font that you want to use for a banner or for an
animation. You can embed a font with the file, which increases the file size. If
you already have lots of other text, embedding your way-cool text bloats the
file size. So, if the text is just another pretty face, you can convert each letter
to a graphic. Here’s how:

1. Create some text.

If you're in an experimental state of mind, try something big and bold
using the Impact font family.

2. Select the text with the Text tool.
3. Choose Modify->Break Apart.

Flash breaks the text into individual pieces; one piece per letter.
4. Choose Modify->Break Apart.

No, we’re not being redundant. The first time you break the text apart,
it’s still text and can be edited as text. The second time you apply the
command, each letter is converted into a shape. You can now convert
each shape to a symbol or, if you want to have some fun, select a letter
with the Subselection tool. Now you can select and manipulate each
point. You can also modify each shape with the Selection tool. For more
information on folding, spindling, mutilating, and performing other edits
on shapes, refer to Book II, Chapter 1. Figure 3-6 shows a letter that has
been modified after it was converted to a shape.

cargo

Figure 3-6: Shaken but not stirred.
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Editing Text Fields

When you have a document with lots of text, you almost always end up
making some kind of change. The client may change his mind, or you may
decide that a text field is a little too large. You may also find that your
spelling isn’t perfect. Nothing is worse than a Flash project with typos.
Unfortunately, text is infinitely editable in the native FLA document, except
when you convert it to a shape. Then it becomes infinitely malleable. In the
upcoming sections, we show you some of the most common edits you need
to perform.

Resizing a text field

The great thing about text fields is that you can resize them at any time. You
can resize text fields in two ways, and neither distorts the text within the
field. To resize a text field, do one of the following:

1~ Select the text field with the Selection tool, and then drag one of the
handles.

~ In the Property inspector, use a scrubby slider to change the width or
height of the text field. Click the icon that locks the width and height
values (it looks like a broken link) if you want to resize the field
proportionately.

Editing text

To err is human, and to change one’s mind is also human. The fact that Flash
designers and developers work for humans means that at some point you
have to edit text on one of your projects. Before you can edit text, you have
to select it. Here are your options for selecting text:

1~ Drag the text tool over the character, word, or sentence you want to edit.

1 Double-click a word with the Text tool to select it.

1~ Select the Text tool, click to designate the beginning of a selection you
want to edit, and then Shift+click to designate the end of the selection.

1~ Select the Text tool, click inside a text field, and then Press Ctrl+A
(Windows) or 8+A (Mac) to select all text within a field.

Spell-checking text fields

Don’t you just hate it when you have tons of text to type, your fingers go
numb, your finger slips from F to V, and without knowing it you make a
couple of bad typos. If you miss the mistake when you proofread, — you do



Editing Text Fields 153

proofread your stuff before you post it to the Web, don’t you?— after you
upload the published file to your client’s Web site, you're up the proverbial
creek without a paddle, not to mention the copious amounts of egg you’ll
have to wipe off your face. Typos are bad, but typos posted to the Web can
be fatal to your career as a Flash designer. Fortunately, there’s a backup for
your proofreading. It’s known as spell check.

Setting up the Flash spell check

Before you can run a spell check, you have to tell Flash the items you want
spell-checked, what to ignore, or which dictionary to use. You can also add
words to a personal dictionary (like your last name if it’s not common) that
might otherwise be listed as suspects for correction. To set up the Flash
spell check feature, follow these steps:

1. Choose Text->Spelling Setup.
The Spelling Setup dialog box appears (see Figure 3-7).

‘Spelling Setup &

Document options Dictionaries
Check text fields content I Adibe fall
[l chedk scene and layer names American English =
[check ﬁ'alme |?bE|5J’.COr‘I‘II'I‘I?I"ItS [] Brazilian Portuguese 3
[l check strings in ActionScript [] Eritish English =
[ check symbal /bitmap names [ Eahadim _
[ check current scene only [ catalan T
] check single letter text fields ] Danish
[ 5how in Movie Explorer panel ] Dutch
Select text on stage [ Finnish |

| T Eranch |_\:|l
Personal dictionary
Path: | C:\Documents and Settings\Doug Sahlin\Application Datale | [

[ Edit Personal Dictionary ]
Checking options
[ 1anore non-alphabetic words [IFind duplicate words
[[J1gnore words with numbers [ split contracted words
[J1anore internet/file addresses [ 5plit hyphenated words
[ 1gnore words in UPPERCASE [ 5plit words (German, Finnish)
[ 1anore words with MIxedCasE [ 5uggest split words
[lignore first letter capped words Suggest phonetic matches
[J1anore possessives in words Suggest typographical matches
[ ok || cance

Figure 3-7: Setting up the Flash spell check.
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2. Select the options you want Flash to include when you invoke the
Check Spelling command.

You see two groups of options: Document and Checking. To prevent you
from nodding off, we refrain from listing every option, because they’re
self explanatory. Note that you have options to spell-check scene and
layer names, which is something we use so that our editors don’t send
screen shots back because of misspelled words.

3. Choose a dictionary. Edit Parsonal Dictionary )

Pixelicious
You can include multiple dictionaries, if you |
want. You can also switch dictionaries, which
is a handy option if you're creating a Flash
document in a different language.

4. Click Edit Personal Dictionary.

The Edit Personal Dictionary dialog box
appears (see Figure 3-8).

5. Enter words that Flash may list as suspects el
for correction.
Press Enter or Return after entering a word. ~ Figure 3-8: Flash lets you
Add words like your last name, the name of set up your own, personal

your client’s business, or any unusual techni-  dictionary. How great is that?
cal terms that may not appear in the diction-
aries Flash is using as resources when checking spelling.

6. Click OK to close the Edit Personal Dictionary dialog box, and then
click OK to close the Spelling Setup dialog box.

You’re now ready to let Flash check your documents for spelling errors.

Running the Flash spell checker

After spending hours sprinkling a Flash document full of graphics, anima-
tions, and text fields, it’s time to test your handiwork. We cover testing the
entire document in Book VIII, Chapter 1. Now we show you how to check the
document for spelling errors:

1. Choose Text->Check Spelling.

The Check Spelling dialog box appears and Flash highlights the first
word that it suspects is spelled incorrectly. If suggested corrections are
available, Flash lists them in the Suggestions pane (see Figure 3-9).
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‘Check Spelling
Word not found (text field):
The Flash check speling command iz your frind.
e |
S ]
spieling il
| selling | Change
| peeling
|pe|ﬁng |
(sapiing. 9]
’ Setup... ] [ Close ]

Figure 3-9: Oops. Somebody spelled something wrong!

2. When Flash highlights a suspect, click one of the following buttons:

Add to Personal: Adds the highlighted word to your personal dictionary.

Ignore: Ignores this instance of the suspect word, and Flash contin-
ues to check the document for spelling errors.

Ignore All: Ignores all instances of the suspect word.

Change: Changes this instance of the suspect to a suggested replace-
ment that you select in the Suggestion pane. When you select a
suggestion, it appears in the Change To field. Alternatively, you can
enter a word in the Change To field.

Change All: Changes all instances of the suspect to a suggested
replacement that you select in the Suggestion pane. When you select
a suggestion, it appears in the Change To field. Alternatively, you can
enter a word in the Change To field.

Delete: Deletes the suspect word from the object that Flash is spell-
checking.

Setup: Opens the Spelling Setup dialog box, which is a handy option
if you notice that Flash isn’t handling the spell checking the way you
want it to.

Close: Exits the spelling check before Flash finishes checking the
document.

3. After Flash finishes checking the document, a dialog box appears, tell-
ing you that the spelling check has been completed. Click OK to close
the dialog box.
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Using the Find and Replace Command

When your client changes her mind and needs you to change some text, it
can be a time-intensive task if you're working on a large project. Fortunately,
you can find and replace text in a document. For that matter, you can find
and replace almost anything in a Flash document. To use the Find and
Replace command, follow these steps:

1. Choose Edit=>Find and Replace.

The Find and Replace dialog box appears (see Figure 3-10).
2. Select an option from the Search In drop-down menu.

You can search in the entire document or the current scene.
3. Choose an option from the For drop-down menu.

You can search for the following:

e Text: Search for a word or block of text. You can also enter text that
replaces the text for which you’re searching. You also have the usual
suspects for options, such as searching for the whole word or for
matching case.

FIND AND REPLACE =

Searchin: |Current Document ]| Find Next
For: |Text b Find Al

Text:
Replace Al

Replace with:
Text:

[ whole word Text fields contents

["Match case Frames/Layers/Parameters

D Regular expressions Strings in ActionScript
ActionSeript

[CLive edit

Location Matched Items Type

Ready.

Figure 3-10: Looking for something?
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Font: Search for instances of text using a specific font. You can
narrow your search by specifying a style and a size. You can replace
all instances of the font with a different font.

Color: Search for all instances of a specific color. You choose the
color to search for by clicking a swatch, which opens the Swatches
panel. Click to choose the color or enter its hexadecimal value. You
choose the replacement color in the same manner. You can replace
the color in fills or strokes or text or any combination thereof.

Symbol: Search for all instances of a symbol and replace them with
another symbol, if you want. Drop-down menus list each symbol you
created for the document. Think of this option as the Swap Symbol
command on steroids.

Sound: Search for a sound file in the document and replace it with
another, if you want. Drop-down menus list each sound you imported
into the document.

Video: Search for a video file in the document and replace it with
another, if you want. Drop-down menus list each video you imported
into the document.

Bitmap: Search for an image file in the document and replace it with
another, if you want. Drop-down menus list each image you imported
into the document.

4. After selecting an object, click one of the following:

Find Next: Finds the next instance of the object for which you’re
searching.

Find All: Finds all instances of the object for which you’re searching.

Replace: Replaces the current instance of the object with the replace-
ment object.

Replace All: Replaces all instances of the object for which you’re
searching with the replacement object.
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Chapter 4: Creating Graphic
Symbols for Fun and Profit

In This Chapter

1~ About symbols and instances
~ Creating and editing symbols
v~ Putting the document library to good use

erl you need to create a Flash project with lots of graphics that are
similar, you don’t have to reinvent the wheel. When you create a

graphic symbol, it appears in the document library. You can use the symbol
whenever and wherever you need, even in another document. You can even
duplicate an existing symbol and use it as the basis for a new symbol. (Talk
about recycling resources! We wonder whether

using a symbol repeatedly reduces Flash’s carbon

footprint on the planet and can be considered

“going green.”) If the judicious use of symbols

requires less time behind the computer, which

enables a Flash designer to turn off her computer

sooner, thereby conserving energy, we guess that

symbols can be considered going green. In the

spirit of conserving resources, we'll cut to the

chase and show you how to use symbols in your

own Flash project.

Understanding Symbols and
Instances

When you create a graphic symbol in a Flash

document, it’s a stand-alone object, kind of like a

stand-up comic. It can entertain, but if you need more than one graphic, you
have to create another. When you create a symbol, it’s like creating a DVD
of a stand-up comic. You can play it in other places, and it looks and sounds
just like the original. When you create a symbol, it resides in the document
library. You can create an instance of the symbol at any time by dragging

it from the document library to the Stage. When the Flash Player sees an
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instance of a symbol in a Flash movie, the player uses the information from
the document library to reconstruct the symbol, which means a smaller file
size — and less work for you.

Creating Symbols

Symbols are the lifeblood of any Flash document. As we mention elsewhere,
you can create a symbol and then use instances of it as needed. In the following
sections, we explain the different symbol types and show you how to create a
symbol from scratch or convert an object to a symbol. A symbol can be edited
at any time. When you edit a symbol, all instances are affected. The carte
blanche use of graphics increases file size. However, when you use instances of
symbols in lieu of creating new graphics, you greatly reduce the file size.

Understanding symbol types

You can create three types of symbols in Flash: Movie Clip, Button, and
Graphic. When you examine the symbol names, you may think that the
movie clip is the only symbol that can be animated. You can animate a
graphic and have an animated button too. Each symbol type has a unique
icon in the document library. The following list explains the differences
between the symbol types:

7 Movie Clip: Can have multiple frames and be an animation. A Movie Clip
symbol can also be a single object on a single frame. When you create an
instance of a movie clip and give it a unique name, you can address the
symbol instance with ActionScript and get it to do some cool stuff, such
as change dimensions and move, for example. When you create an ani-
mation inside a movie clip, the parent Timeline doesn’t need to have the
same number of frames as the movie clip. An animation in a movie clip
loops endlessly unless you address its Timeline with ActionScript.

& 1 Button: An interactive critter that responds to mouse clicks. You can use
ActionScript to determine what happens when a button is clicked. A Button
symbol has four frames, which enables you to display different graphics
when the user hovers the mouse over the button and clicks it. You can use
a short animation in a button frame to create a unique button.

@ 1 Graphic: Can contain multiple graphics and be an animation. However,
an instance of a Graphic symbol cannot be addressed with ActionScript.
A Graphic symbol is locked to the main Timeline. If you create a graphi-
cal symbol with multiple frames, the main Timeline must have enough
frames from the point where you add it to the Timeline to play the entire
animation.
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Converting an object to a symbol

If you create a graphic on the Stage and decide that you need to use it
repeatedly, you can convert the object into a symbol. Then you can choose
the type of symbol that the object becomes and do much more. To convert
an object to a symbol, follow these steps:

1.

Select the object you want to ‘Convert to Symbol ]
convert to a symbol. Names | Symocl 1
Tpe: [Movedp  [w]  Reswaton: 283 [ cancel

Choose Modify=>Convert to
Symbol.

Folder: Library root

The Convert to Symbol dialog
box appears (see Figure 4-1). Figure 4-1: Converting an object to a symbol.
Enter a name for the symbol.

Use a logical name with no spaces or special characters. Even though
the document library provides methods for organizing a project, we add
prefixes to our symbols that further identify their use. For example, our
graphic symbols might be GCar(01; our movie clip, McCar01; and our
button, Btn01.

Choose the symbol type from the Type drop-down menu.

Your choices are Movie Clip, Button, or Graphic. If you fast-forwarded to
this part of the chapter, and don’t know about symbol types, rewind to
the section “Understanding symbol types.”

Choose the registration point.

We prefer to use the upper-left registration point, which makes it easy to
align objects relative to the edge of the Stage, which is x=0, y=0.

. Click Advanced.

This step expands the dialog box to show the advanced options for
converting an object to a symbol (see Figure 4-2). The options differ for
a button and movie clip. If you're converting an object to a graphical
symbol, you have no advanced options.

If you’re converting a graphic into a movie clip that will have
instances to scale, click the Enable Guides for 9-slice Scaling option.

When you choose this option, you have more control when you scale
instances of a symbol. A movie clip with 9-slice scaling has a visual
overlay with nine sections. When you scale the instance, each section
is sized individually, without scaling the corners. This option maintains
the visual integrity of movie clip instances when scaled.
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‘Convert to Symbol
Name: | Symbol 1 X
Tyoe: | VE Registration: EEE Cancel

Folder: Library root

H Ilg_q

[JEnable guides for 9-slice scaling

Linkage
[C]Export for ActionScript

Sharing
[ JExport for runtime sharing

[ 1mport for runtime sharing

Source
File:

Symbol name: Symbal 1

Figure 4-2: Yikes! Advanced options.

8. If applicable, select the Export for ActionScript check box.

This step reveals the Identifier, Class, and Base Class fields. It also gives
you the option to export the symbol in the first frame, which means that
it’s accessible to ActionScript during the course of your Flash project.
For more information on the ActionScript identifiers, classes, and base
classes, see Book IV.

9. If applicable, select the Export for Runtime Sharing check box.

This step allows you to treat the symbol as a class and to instantiate
instances of it from ActionScript. For more information on importing and
exporting for runtime sharing, see Book IV.
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10. Click OK.

The object is converted to a symbol and added to the document library.

Creating a new symbol

If you plan out your project ahead of time (you did plan out your project,
didn’t you?), you know exactly how many symbols you need for your proj-
ect. Whenever possible, we like to take care of the grunt work before creat-
ing instances of symbols on the Stage, adding frames to the Timeline, writing
ActionScript code, and performing other delightful tasks. To create a new
symbol, follow these steps:

1. Choose Insert=>"New Symbol. Create New Symbol

&
If you like keyboard shortcuts, o
Cancel

press Ctrl+F8 (Windows) or $8+F8 | ™= = ¥
(Mac). Both methods open the Folder: Librarv root
Create New Symbol dialog box e

(see Figure 4-3).

2. Enter a name for the symbol. Figure 4-3: It's time to get symbolic and
create a new symbol.

Use a logical name with no

spaces or special characters.

Even though the document library provides methods for organizing a

project, we add prefixes to our symbols that further identify their use.

For example, our graphical symbols might be GCar01; our movie clips,

McCar01; and our buttons, Btn01.

3. Choose a symbol type from the T
Type drop-down menu. o
Your choices are Button, Graphic, @ Existing folder:
or Movie Clip. If you don’t know a B huters
graphic from a movie clip, check B craphics
out the section “Understanding B9 Movie Ciips
Symbol Types,” at the beginning of
this chapter.
4. Accept the default folder (the
Library root) or click the default = = ! Bl
folder name to open the Move To '
dialog box (see Figure 4-4). [ sekct | [ concel ]

Figure 4-4: Moving the new symbol to a
different folder.
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10.

We're strong believers in being organized. If your project has lots of
Button, Movie Clip, and Graphic symbols, we recommend storing them
in separate folders. Notice in Figure 4-4 that we already created a folder
for each symbol type. Step 5 assumes that you think our advice is sage,
Rosemary, and segregates your symbols in separate folders.

Select the folder in which to store the symbol, or create a new folder.

To create a new folder, enter the name in the New Folder text field.
Alternatively, click the Existing Folder radio button, and then select a
folder. If you like the idea of creating your folders ahead of time, like we
did, check out the section “Creating library folders,” later in this chapter.

. Click Advanced.

The dialog box expands to show the Advanced options for creating

a symbol (see Figure 4-5). The options differ for a button and movie
clip. If you’re converting an object to a graphical symbol, you have no
advanced options.

If you’re converting a graphic into a movie clip that will have
instances to scale, click the Enable Guides for 9-Slice Scaling option.

When you choose this option, you have more control when you scale
instances of a symbol. A movie clip with 9-slice scaling has a visual
overlay with nine sections. When you scale the instance, each section
is sized individually, without scaling the corners. This option maintains
the visual integrity of movie clip instances when scaled.

. If applicable, select the Export for ActionScript check box.

This step reveals the Identifier, Class, and Base Class fields. It also gives
you the option to export the symbol in the first frame, which means that
it’s accessible to ActionScript during the course of your Flash project.
For more information on the ActionScript identifiers, classes, and base
classes, see Book IV.

. If applicable, select the Export for Runtime Sharing check box.

This step lets you treat the symbol as a class and instantiate instances
of it from ActionScript. For more information on importing and export-
ing for runtime sharing, see Book IV.

Click OK.

If you've never used Flash, don’t freak out — you haven’t crashed the
program. A new window opens when you create a symbol from scratch.
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‘Create New Symbol

Mame: | Symbol 1 oK

Type: | Movie Cip 4 Cancel

Folder: Library root

E Ilgq

[JEnable guides for 9-slice scaling

Linkage
[CIExport for ActionScript
Book II
Chapter 4

Sharing
[JExport for runtime sharing

[Jimport for runtime sharing

woid
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Source

Browse... | File:

Symbol name: Symbal 1

Figure 4-5: Advanced symbols go to the head of the class.

11. Use the Flash tools to create the symbol.

You can also use images you imported into the document library as
part of your symbol. You can also use multiple layers when creating a
symbol. Figure 4-6 shows a button symbol being constructed.

12. When you finish creating the symbol, click the Back button or the
current scene button.

The symbol is added to the document library.
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Figure 4-6: Build me a button, my lovely.

Spraying symbols

The Spray Brush tool lets you spray graffiti-like strokes of color wherever
you want, as outlined in Chapter 1 of this minibook. But you can also load
the Spray Brush tool with a symbol. This sprays instances of the symbol,
which reduces the document file size. For example, if you need a sky full of
stars, use the Polystar tool to create a star and then use the Spray Brush
tool to sprinkle the sky full of stars. To spray symbols, follow these steps:

1. Select the Spray Brush tool.

2. In the Symbol section of the Property inspector, click the Edit button.
The Swap Symbol dialog box appears (see Figure 4-7).

3. Select the symbol you want to load in the Spray Brush tool and click OK.

The tool is primed and ready for you to set the rest of the parameters in
the Property inspector.



4. Set parameters in the Symbol sec-
tion of the Property inspector
(see Figure 4-8).

You can scale the size of the
symbol by changing the Width
and Height values. We advise you
to change both parameters to
the same value; otherwise, the
tool sprays a distorted variation
of your lovely (or not so lovely,
depending on your artistic capa-
bilities) symbol. You can add some
variety to the sprayed symbol by
choosing one or more of the fol-
lowing options: Random Scaling,
Rotate Symbol, and Random
Rotation.

5. Change the parameters in the
Brush section.

You can change the brush width
and height as well as the angle of
rotation.

6. Click on the Stage where you
want to spray the symbol.

Figure 4-9 shows a starry, starry
night, courtesy of the Spray Brush
tool and a symbol created with the
Polystar tool.
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Figure 4-7: Swapping symbols to load the
Spray Brush tool.

PROPERTIES |

5”@ Spray Brush Tool

— SYMBOL

Spray: gStar |
O Default shape

Scale width: 100
Scale height:

[] Random scaling
] Rotate symbal
[] Random rotation

== BRUSH

Brush angle: 0 OW

Figure 4-8: The Spray Brush tool will soon
be locked and loaded.

Figure 4-9: Are the stars out tonight?
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Editing Symbols

Symbols are a wonderful thing, especially when you get a document library
filled with them. Then when your client comes up with a “brainstorm” when
you’re 90 percent done with the project, you wince and then smile as you
remember that you did most of your work with symbols. When you edit a
symbol, all instances of the symbol are updated. What could be simpler?

Editing symbols in place

When you need to edit a symbol and it’s imperative that you know what
effect your edits will have on the rest of your project, you can edit a symbol
in place. In reality, you're editing a symbol instance, but the changes are
applied to every symbol instance in the document. To edit a symbol in place,
follow these steps:

1. Select the Selection tool.

2. Right-click (Windows) or Control+click (Mac). Select the symbol you
want to edit.

A context menu appears.
3. Choose Edit in Place.

The rest of the objects on the current frame are dimmed. The symbol
<P name is listed to the right of the scene (see Figure 4-10).

You can also edit a symbol in place by double-clicking any instance of it
on the Stage.

Y et ® B &, o v

4

f—— = _‘q

|_ J | ]

£ 2

Figure 4-10: You can edit a symbol in place.
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4. Perform any edits you want.

You can use any tool to change the symbol. In addition, you can add
objects to the symbol.

5. Click the Back button or the current scene button.

Alternatively, you can choose Edite>Edit Document. Your edits are
applied to the symbol and all instances thereof.

Using symbol-editing mode

When you edit a document in symbol-editing mode, you edit it separately
from the main Timeline. This action is similar to creating a new symbol. To
edit a symbol in symbol-editing mode, follow these steps:

1. Do one of the following to invoke symbol-editing mode:
¢ Double-click the symbol’s icon in the document library.

¢ Right-click (Windows) or Control+click (Mac) a symbol instance on
the Stage and choose Edit from the context menu.

e Select an instance of the symbol on the Stage and choose Edit=>Edit
Symbols.

¢ Select the symbol in the document library and choose Edit from the
context menu, or choose Edit from the Library panel Options menu.

2. Apply any edits you want to the symbol.

You can add graphics to the symbol or nest graphics or other symbols
within the symbol, for example.

3. To leave symbol-editing mode, click the Back button or current scene
button.

Alternatively, you can choose Edit>Edit Document. Your edits are
applied to the symbol and all instances thereof.

Editing symbols in another window

Another option for editing a symbol is to edit it in another window. When
you edit the symbol in another window, you have access to the symbol and
the main Timeline. To edit a symbol in another window, follow these steps:
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170 Editing Symbols

1. Select an instance of the symbol on the Stage, right-click (Windows) or
Control+click (Mac) and then choose Edit in New Window.

2. Perform any edits you want on the symbol.

3. Click the Close button to return to the main Timeline and apply your
edits to all instances of the symbol.

Swapping symbols

When a client changes his mind when a project is almost complete, you can
use another method to thwart the fork he puts in your road. Suppose that
your client represents an insurance company whose symbol is a duck and
you created an animation designed to “quack up” the viewer. Then your client
switches insurance companies, and now the mascot is an English bulldog.
Don’t fret — just create a new symbol with a dancing bulldog (with or without
stiff upper lip) and swap the symbol. To swap a symbol, follow these steps:

1. Select the symbol instance on the Stage.

To open the Swap Symbol dialog box (see Figure 4-11), do one of the
following:

¢ Right-click (Windows) or Control+click (Mac) and choose Swap
Symbol from the context menu.

e In the Property Inspector, click Swap.
2. Select a symbol and click OK.

Presto-chango. The symbol is swapped.

Swap Symbol

= A o ]

¥ Movie clips -_Can:e\
McCaptions
McDiving
McRaft
MeRafting |
MeRandomquote E|
MeSurf [w]

=]

Figure 4-11: Swapping one from Column A with one from Column B.
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Modifying symbol instance properties

You edit a symbol to modify every instance of it in a Flash project. However,
you can also modify the properties of a symbol instance. You can change the
dimensions of a symbol instance, tint it, and change its brightness or Alpha
(transparency) value. To modify the properties of a symbol instance, follow
these steps:

1. Select the symbol instance on the Stage.
2. Choose Window=>Properties.

The Property inspector opens.

3. Change the position and size of the symbol instance by entering
values in the applicable fields in the Position and Size section of the
Property inspector.

4. To change the appearance of PROPERTIES
the symbol instance, choose an
option from the Style drop-down
menu in the Color Effect section.
Your options are described in this
list:

| Graphic [«

Instance of: Symbol 1 | swap.. |

=7 POSITION AND SIZE

* Brightness: Displays a slider
that enables you to change the
brightness of a symbol. Drag = We 308.0 H: 1630
the slider to the right to make |
the symbol instance brighter,

X @330 Y: 1140

=7 COLOR EFFECT

or to the left to make it darker. Style: | Tint |>|
e Tint: Displays four sliders (see Tinty ——————————\ %
Figure 4-12). Drag the sliders e e

until the object becomes the

color you want, and then drag _
the Tint slider to specify the Blues = F———
amount of tint to be applied

Greap: ——————— = 208

LOOPING
to the object. The Red, Green, B .
and Blue sliders enable you Optiens: | Loon lv]
to precisely “dial in” the color First:

by using the RGB color model.
(See Chapter 2 of this mini-
book.)

Figure 4-12: Tinting a symbol instance.
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* Advanced: Displays eight values [ eroperties
(see Figure 4-13). You can use
the values on the left to reduce
the transparency or color in | Graphic
the symbol instance by a spe-
cific percentage from -100 to
100, and use the values on the =7 POSITION AND SIZE
right to modify the red, green, X: 2253 Y: 1340
and blue values of the symbol
instance from -255 to 255. &8

=7 COLOR EFFECT

[x|

Instance of: oddbackaround | Swap... |

e Alpha: Displays a slider you can
use to change the transparency Styler | Advanced | v
of the object. Values less than
100 percent render the symbol
instance partially opaque.

xA +

xR+

5. Use the Free Transform tool to xoa

skew, scale, rotate, or move the Blue: 100% xB +

symbol instance.
= LOOPING

As its name implies, you use this
tool to freely transform the object. :
For more information about the e
Free Transform tool, see Chapter 1
of this minibook.

Options: | Loop I=|

Figure 4-13: And now, the Advanced Color
Effect.

Using the Document Library

When you create a symbol or import an image clip or a video or sound clip,
it ends up in the document library. If you create complex Flash projects,
you can end up with a lot of items in your document library. The document
library takes up a relatively small spot in the Flash workspace; therefore, a
document library with lots of items ends up looking cluttered. But you can
whip the document library of any Flash project into shape — without resort-
ing to a professional organizer — by reading the following sections.

Creating library folders

When you create a new Flash document, you start with an empty document
library, which you can quickly fill to the brim by creating symbols and import-
ing media, for example. When you create a symbol, you can create a folder at
the same time. When you import external media, it’s placed in the root folder
of the document library. You can quickly alleviate clutter by creating a sepa-
rate folder for each type of object that you plan to use in your Flash project.
To create a folder in your document library, follow these steps:



Using the Document Library

. Choose Windowr>Library.

The document library appears (see
Figure 4-14) without that musty
old book smell. (This document
library isn’t an example of the way
we work. We create folders for
each type of object in our Flash
projects.)

. Click the New Folder icon at the

bottom of the document library.

A folder icon appears at the
bottom of the document library,
with the default name Untitled
Folder 1. The folder name is high-
lighted, which indicates that you
can rename it. We strongly advise
you to never accept default names.

. Enter a new name for the folder.

The logical choice is a name that
indicates what you're storing in
the folder. For example, Movie
Clips is a logical name for a folder
that you stuff full of movie clips.
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| Untitled-1

Preview not available

2y |

14 tams

Mame a | Linksge

[®] 020308_Niki-2jpg
(2] n20308_Niki-5jpg
[#] 020508 IKLND-45.jpa
Q diverDown.jpg

@ gddbackaground

] Mctaptions
mCdiving

(k] Mcraft

mCrafting

@ McRndQuote

Q rafterjpg

[#] st Pete. RW_04314pg
& timer

@ Tween 3

Figure 4-14: A document library in need of
some TLC.

. Select the items you want to store in the folder, and then drop them

on top of the folder.

The selected items are no longer
visible, but the arrow to the left of
the folder indicates that the folder
can be expanded to reveal the con-
tents within.

. Continue creating new folders as
needed and populate them with
the applicable objects.

We create a folder for each object
type that we intend to use in a
project. Working in this manner
keeps us organized from the
get-go. Figure 4-15 shows our
squeaky-clean document library
with a folder for everything, and
everything in its folder. One folder
has been expanded to reveal its
contents.

S]] werary [

I»] @ Gn

| Untitled-1

@ | |

18 items

Mame 4 | Linksge

3 @ Components
3 E_jj Graphic Symbols

v @7 Images

[%] 020308 Niki-2.jpg

[3¥] 020308_niki-5ipa

[%] 020508 IKLND-45pg

_ﬂ diverDown.jpa

i] rafter.jpg

[%] st_Pete_ RW_0431jpg
3 Ej Movie Clips

Figure 4-15: A neat and tidy document
library.
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Duplicating symbols

When you need to create a new symbol, there’s no need to reinvent the
wheel. For example, if you're creating a navigation bar with buttons that use
identical graphics with the exception of the button name, you can save a lot
of time by duplicating a symbol, and then editing it. To duplicate a symbol,
follow these steps:

1. Open the document library and then select the symbol you want to
duplicate.

2. Right-click (Windows) or Control+click (Mac) and choose Duplicate
from the context menu.

The Duplicate Symbol dialog box appears, as shown in Figure 4-16.

‘Duplicate Symbol

%]
Neme: | BinRaft

Type: [putton  [w] Cancel

Folder: Library root

Basic

Linkage
[ Export for ActionScript
Sharing
[] Export for runtime sharing
] impert for runtime sharing

Source

Symbol name: mCrafting copy

Figure 4-16: Duplicating a symbol.
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3. Enter a name for the duplicate symbol.
Give the symbol a meaningful name.

If you're exporting the duplicate symbol for ActionScript, click the
Advanced button. The options are the same as the Create New Symbol
dialog box, which we cover in the section “Creating a new symbol,” ear-
lier in this chapter.

Understanding that default

names are not your friends

As we mention earlier in this chapter, in the section “Creating a new
symbol,” you should never, never, never (we apologize for being redundant,
but this advice is important) use the default name that Flash assigns for a
symbol. The default names don’t make a lot of sense, especially if you're
using ActionScript. The same rule applies for folders you create in the docu-
ment library or the media you import into the document library. If you're
using someone else’s assets (in case you don’t have your own assets cov-
ered) that have less-than-desirable names, you can easily rename them in
the document library. Follow these steps:

1. Open the document library and double-click the item you want to
rename.

The current name of the item is highlighted, indicating that you can
enter a new name.

2. Enter a new name for the item and then click Enter or Return.

The object has a new moniker.

Keeping the document library neat
and tidy: The Felix Unger factor

Sometimes you err on the side of caution and create more items than you
need for a project. If you publish a Flash project with more items in the
Library than you need, you increase its file size. Therefore, it’s in your best
interest to keep the document library fastidiously clean. Follow these steps:

1. Choose Windowr>Library.

The document library appears.
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A\

2. Click a symbol to preview it.

The preview appears at the top of
the Library panel. If the symbol is
a movie clip, a Play button appears
next to it (see Figure 4-17).

. Press Delete to remove a selected

symbol from the document
library.

Alternatively, you can click the

| Untitled-1

18 items dﬁ|

Nams

v @7 Components
& timer

v @}? Graphic Symbols
[4] gddbackground

Delete button. It looks like a trash [ Tween3
can at the bottom of the Library v [ mages

panel. Either method deletes the
symbol from the document library
and removes all instances of it
from the document. Flash doesn’t
warn you before you delete a
symbol. Make sure that you don’t
need the symbol before deleting it.

. To see all unused symbols in the

document, choose Select Unused
Items from the Library panel
Options menu.

[®] 0z20308_Niki-2jpg

[%] 020308 Niki-Sipa

[®] 0z20508_IKLND45.pg

g diverDownjpg

Q rafterjpo

[%] st Pete_ RW_0431jpg
v @P’ Movie Clips

McCaptions

mcCrafting

(] mecdiving

McRaft

@ McRndQuote

All unused items are highlighted.
You can now delete them by click-  Figyre 4-17: This library's a mess. Call in the
ing the Delete button at the bottom  ¢|ganing crew.
of the Library panel.

The document library has other tricks up its sleeve. Click the Library panel

Options icon to reveal the Library panel Options menu, from which you can
create new symbols; rename, delete, or duplicate selected symbols; move a
selected symbol to another folder; edit, play, or update a symbol; or display
symbol properties, for example.

Importing symbols from another Flash document

If you've already spent a lot of time creating symbols for a Flash project and
you create a new Flash project that can use the same or similar symbols,
you have no need to re-create them. Simply grab the symbols from the other
Flash project and drag them into the current document library. Here’s how
todo it:
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Choose Windowr>Library.

The document library appears (see
Figure 4-18).

Click the New Library Panel icon.

A copy of the document library
appears on the Stage.

In the new library panel, click the
Pin Current Library icon.

This step keeps the duplicate
library open, even when you open
another document.

Open the document that contains
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LIBRARY

[ MyFlashProject.fla |»] 5 B

Preview not available

44 ftams

| |

Namz s | Linksgs

3 @ Buttons
» Eﬂ Graphics
» ﬁ Images

2 Movie clips

Figure 4-18: You can pin a document
library.

the symbols you want to use in the current document.

The document opens and is designated by another tab. The document
library from your other project is on the Stage.

Select a symbol from the library of the document you just opened, and
drag the symbol into the document library from your other project.

When you drag the symbol into the other document library, a plus sign
appears, indicating that the symbol will be added to the pinned docu-

ment library (see Figure 4-19).

5 Scene 1

diving

2 & mw

rafting running

LIBRARY

@

24 ems

Name
» [ Buttans
» [ Graphics
» [ 1mages
1 Mavia Clips Ih

i

al 6 @[ 3

Figure 4-19: Robbing from Peter to pay Paul.
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6. Release the mouse button.

The symbol is added to the document library.
§‘\‘e,N\i-"'-:If
Y

& 7. Continue dragging symbols between libraries.

Work smarter, not harder. It’s a creed we authors live by.



Chapter 5: Organizing Your Work

In This Chapter

+ Understanding layers
v~ Adding layers to a document
+~ Using layer folders

v~ Viewing rulers and grids

Being organized is a good thing, especially when you’re dealing with a
document full of symbols, movie clips, and buttons, not to mention
ActionScript. When you have this much going on in a document, trying to
stuff it all on one layer is like storing your clothes in a dresser with no draw-
ers. (You can’t find nothing, honey.) In the last chapter — you did read it,
didn’t you? — we showed you how to organize your symbols in the docu-
ment library. In this chapter, we get down to brass tacks and show

you how to organize the stuff on Stage.

Organizing a Project with Layers

When you create a new document, you have one
layer with which to work. No, the Flash guys and
gals weren’t being stingy when they designed the
program; they just wanted to give you options.
The option to create a layer whenever you need ‘
to gives you a tremendous amount of flexibility.

You can think of layers as a place to put your

Flash stuff. But if you have lots of Flash stuff on lots
of Flash layers, you have a hard time finding your

stuff. When that happens, you create a layer folder that
neatly collapses to a single icon. Figure 5-1 shows a Flash

document with a lot of stuff neatly segregated on layers, and
neatly packed away in layer folders. (This paragraph was inspired
by the late George Carlin, who taught us everything we needed to know
about stuff.)
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Figure 5-1: Layers and layer folders are places to put your Flash stuff.

It’s useful to think of layers as clear sheets of plastic. The objects on an
upper layer eclipse the objects directly below them on underlying layers.
When you work with objects on one layer, it doesn’t affect the objects on the
underlying layers. When you have a lot of objects on many layers, getting a
good grasp on what you’re doing is difficult, especially when you’re trying to
edit objects on the bottommost of five layers. When that happens, you can
temporarily hide a layer. And, when the magic moment arrives and you have
everything on a layer just the way you want it, you can lock it. Don’t worry
about having to locate a key — you unlock a layer by clicking an icon. In
upcoming sections, we show you how to organize your work with layers.

Creating a new layer

You know when you need to create a layer — when the Stage looks like a
dressing room for a troupe of ballet dancers with shoes scattered every-
where, topped with tutus and boas. You get the picture. Layers don’t make
a crowded Stage look less cluttered, but they make it easier for you to find
objects and edit them. To create a new layer, follow these steps:
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Select the layer below the spot where you want the new layer to
appear.

When you have only one layer, it’s a no-brainer. But when you have
multiple layers, the new layer you create is directly above the selected
layer.

To create the layer, do one of the following:

e Right-click (Windows) or Control+click (Macintosh) and choose
Insert Layer from the context menu.

e C(Click the New Layer icon at the bottom of the Timeline panel.

Accept the default layer name, or double-click it and enter a new
layer name.

Unless you're dealing with a two- or three-layer document, we strongly
advise you to give your layers meaningful names.

Creating layer folders

When a Flash project has a heaping helping of layers, you have somewhat of
a logistical nightmare: You use the scrollbar incessantly to move from one
layer to the next. Fortunately, the Flash designers added a layer folder to the
application. A layer folder can be filled with layers and then collapsed to a
single icon on the Timeline. How convenient. Of course, you have to expand
the layer folder again to edit the Timelines. But that’s a small price to pay for
the convenience of not having to slog through layer after layer after layer. To
create a layer folder, follow these steps:

1.

Open the Timeline panel.

You can open the Timeline panel by clicking its title or choosing
Windowr>Timeline.

Select the layer below the spot where you want the layer folder to
appear.

If you have an extremely busy Timeline, the obvious place to create the
layer folder is just above the last object in the stack that you want to
add to the layer folder.

Click the Layer Folder icon.

A layer folder is born.

. Double-click the default folder name.

The text is highlighted, indicating that you can enter a new title name.

We strongly advise you to give everything in the project a unique name.
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5. Enter a new name for the folder.
Create a name that reflects the folder contents.
6. Drag and drop some layers into the folder.

Make sure that you stack the layers in the same order that they previ-
ously appeared on the Timeline.

7. Collapse the layer folder.

Click the downward-pointing arrow to the left of the folder’s name to col-
lapse the folder. Click it again to expand the folder. Figure 5-2 shows a
Timeline that has been organized with named layers and layer folders.

Lock or Unlock All Layers

Show or Hide All Layers|Show All Layers as Qutlines

TIMELINE | MO =
5 H] 15 20 25 30 35 40 45 50 55
v 3 User Interface « « W Z
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@l Sound « = W s
@l Graphics v o W5 I
) Buttans « o Mg
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Delete Layer
New Folder

New Layer

Figure 5-2: A group of layers whipped into shape by a fastidious Flash designer.

Editing layers

After you organize your work with layers and layer folders, you can edit
them as needed. In this section, we show you everything you need to know
about editing objects on layers and editing layers.

Hiding one or more layers is beneficial when you have a lot of objects on the
Stage stacked in different layers. When you have this much going on, it can be
hard to select an individual object on a layer. To select, reveal, or hide a layer:

1 To select a layer for editing: Click the layer name. This action makes
the layer the active layer (as indicated by the pencil icon), which
enables you to edit objects on only that layer.



Organizing a Project with Layers 183

To hide a single layer: Click the dot to the right of the layer’s name and
below the eyeball icon.

To hide all layers except the selected layer: Right-click (Windows) or
Control+click (Macintosh) and choose Hide Others from the context
menu.

To hide all layers: Click the eyeball icon.

To reveal hidden layers: Right-click (Windows) or Control+click
(Macintosh) and choose Show All from the context menus.

Locking one or more layers is beneficial when things are just the way you
want them. When you lock a layer, it prevents you from inadvertently select-
ing an object that’s in pixel-perfect position. To lock or unlock layers:

’/

To lock a single layer: Click the dot to the right of the layer’s name and
below the lock icon.

To lock all layers except the selected layer: Right-click (Windows) or
Control+click (Macintosh) and choose Lock Others from the context menu.

To lock all layers: Click the lock icon.

To unlock a locked layer: Click the lock icon to the right of the layer’s
name.

Displaying layer objects as outlines is another way to alleviate clutter and
make it easier to see what’s going on in a busy project. To display objects on
layers as outlines, do one of the following:

 To display objects on a single layer as outlines: Click the Show Objects

as Outlines icon to the right of the layer’s name.

1~ To display all layers as outlines: Click the Show Layers as Outlines icon

in the upper-left corner of the Timeline panel.

Editing layer properties

Everything in Flash has properties, even layers. You can edit layer proper-
ties to change the manner in which the layer is displayed on the Timeline,
the layer type, or the layer name, for example. To edit layer properties,
follow these steps:

1.
2.

Select the layer whose properties you want to edit.

Right-click (Windows) or Control+click (Macintosh) and choose
Properties from the context menu.

The Layer Properties dialog box appears (see Figure 5-3).

Accept the current name for the layer or enter a new name.
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10.

Type: (&) Normal
. Select the Show check box to OM"’%‘_
toggle visibility of the layer. O Folder
) Guide
If the layer is visible, the check
box is selected. Outline color: [

. Select the Lock check box to

If you suddenly decide to get “Layer Properties
organized and the current name
is the default name, we strongly [oc |
suggest that you give the layer a [lshow  [lock
meaningful name.

Name: = ActionScript

[ view layer as outiines

lock or unlock the layer. Layer height: |100% [v]

If the layer is unlocked, the

check box isn’t selected. Figure 5-3: Layers have properties that make
no sense to Realtors.

Accept the current layer type or

click a different radio button.

Unless you're a Flash veteran, the choices other than Normal and Folder
may seem strange to you. Don’t worry; we describe each layer type as
needed in later chapters. Just remember how to change them and you’re
good to go.

. Accept the default layer outline color or click the swatch, which opens

the Swatches panel and enables you to select a different color for the
layer outline.

This color is the one that’s used to designate objects when you choose
to display the layer contents as outlines.

. Select the View Layer as Outlines check box to specify whether the

layer objects are displayed as outlines.

When the check box is selected, layer objects are displayed as outlines.

. Choose an option from the Layer Height drop-down list.

The default layer height is 100 percent. You can increase the height to
200 or 300 percent. Increasing the layer height makes it easier to work
with keyframes and frame spans.

Click OK to apply the new properties to the layer.

Being Precise with Rulers and Guides and the Grid

Flash has a powerful trio of features that are quite useful when you’re creat-
ing a document. Using rulers and guides and the grid enables you to pre-
cisely place objects. In fact, you can choose options to have objects snap to
the grid or guides when you move them. If you're a precise kind of person,
read the following sections, where we show you how to be precise when
working on a Flash project.
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Using rulers

Rulers are displayed on the top and left sides of the Stage. The unit of mea-
sure for rulers is the same unit of measure as the document. When you move
an object, lines appear on the applicable ruler to designate the width and
height plus the x and y position of the object. To display rulers and modify
the unit of measure, follow these steps:

1 To display or hide rulers, choose Viewt>Rulers.

1~ To change the rulers’ unit of measure, choose Modify=>Document and
choose an option from the Ruler Units drop-down menu.

Creating guides

Guides are a wonderful thing unless you have a mouthy global positioning
system (GPS) in your vehicle. When you work in Flash, you can create as
many guides as you need to align the objects in your project. Guides are
useful when you’re creating a navigation menu and you want to align buttons
with pinpoint accuracy. To create guides, follow these steps:

1. Position the cursor over a ruler, and then click and drag a guide onto
the Stage.

The current position of the guide is indicated by a line that’s parallel to
the ruler from which the guide is created. You also see the current posi-
tion marked off on the opposite ruler.

2. Release the mouse button when the guide is in the position you want.

The new guide is designated by a line that is the default guide color.
After adding one or more guides to a Flash document, you can do the following:

» Move a guide: Click it with the Selection tool and drag it to another
position.

1~ Make objects snap to guides: Choose Viewr>Snappinge>Snap to Guides.

1 Lock guides in their current positions: Choose View=>Guides=Lock
Guides.

1~ Toggle visibility of guides: Choose View=>Guides=>Show Guides.

1~ Edit guides: Choose View=>Guides=Edit Guides. This command opens
the Guides dialog box, which enables you to change the color of guides
and determine whether guides are shown, whether objects can snap to
them, and whether guides are locked. You can also choose a snap accu-
racy from a drop-down menu. Your snap accuracy choices are

e Must Be Close
e Normal

e (Can Be Distant
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You can also remove all guides from the document by clicking Clear All.

» Remove all guides from the document: Choose Viewr>Guides=>Clear
Guides.

Using the grid

Flash has a grid that’s hidden by default. When you choose to view the grid,

it looks like somebody put a piece of transparent graph paper over the Stage.
We don’t think the default grid is particularly useful because the grid spacing is
so small (10x10 pixels is the default size of each grid square). However, with a
little work, the grid can be extremely useful. To use the grid, follow these steps:

1. Choose View>oGrid=>Show Grid.

The grid is displayed. However, the default size and color may not suit
your project.

2. To edit the grid, choose Grid %]
Viewr>Grid=>Edit Grid. Cokr: I E]
i i [Ishow arid
glk;,l l’(il‘lsc_lélc)l‘lalog box appears (see Flas peeape
[I5nap to grid
3. Accept the default grid color, or o | 10px
click the swatch to specify a dif- e
ferent color from the Swatches - —
SNap accuracy: !Norma\ |:I
panel.

This step is useful when you're
working on a document that’s
almost the same color as the
grid. When this is the case, select
a color that contrasts well with the background.

Figure 5-4: Edit the grid to suit your document
and preferences.

4. Click the Show Grid check box to toggle grid visibility.

5. Select the Show Over Objects check box to display the grid on top of
the objects.

We’'re not crazy about this option especially with the default grid size,
but try it — you might like it.

6. Select the Snap to Grid check box.

When this option is selected, objects develop a magnetic attraction to
grid intersections.

7. Accept the default grid measurements or enter different values.

You can change the width independently of the height and vice versa. If
you're creating a document with a lot of objects that have similar dimen-
sions, you may want to change the dimensions of the grid to a common
dimension for your most-often-used object. (You know — similar to navi-
gation menu buttons.)
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8. Choose an option from the Snap Accuracy drop-down menu.

This option determines how close an object must be to the grid before it
can be snapped to a grid intersection. Your snap accuracy choices are

e Must Be Close
e Normal
e Can Be Distant
9. Click OK.
The changes are applied to the grid. Figure 5-5 shows a grid that has

been modified to suit a specific document.

If you use the grid frequently on similar documents, modify the grid as out-
lined in this section and then click Save Default. You have to close Flash and
then relaunch the application for the new default settings to take effect.
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Figure 5-5: Flash grids are better than gridlock.
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Chapter 6: Working with Images
(Or, Bumpin’ with Bitmaps)

In This Chapter

+ Understanding compatible file formats
1~ Getting images ready for Flash

1~ Working with image sequences

v~ Tracing bitmaps

1~ Editing images

1~ Creating a bitmap fill

1 Swapping images

Images can make or break a Flash project. The size and
quality of your images determine the file size and qual-
ity of the resulting Flash movie. If you or your client p
starts out with crisp images, you get good results. On

the other hand, if your client presents you with a ‘
bunch of images that have already been severely
compressed, you have no way to create a decent-
looking Flash movie. In this chapter, we're letting
Doug take the lead. He has published books on
digital photography and knows Photoshop and
Fireworks inside and out. In this chapter, Doug
shows you how to create Flash movies with great-
looking images.

Knowing Your File Formats

Flash supports the popular image file formats. Unfortunately, if you

don’t deal with images regularly, choosing the right image format for a Flash
project can be daunting. The following list describes some characteristics
about the image file formats supported by Flash.
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»» PNG File: The PNG (PNQG) file format is the native Fireworks file format.
In Fireworks, the format supports layers and slices and all the other
goodies you need in order to create image documents for the Web.
Other applications can also export PNG files. The PNG format supports
8-, 16-, 24-, and 32-bit depth. If you're using this file format in a Flash doc-
ument, the best bet is a 24-bit (true color) PNG file. You can, however,
use an 8-bit PNG file if you're working with an image, such as a logo, that
has large areas of solid color.

1~ Photoshop: The Photoshop image format (PSD) supports layers, mul-
tiple color models, adjustment layers, and much more. When you import
a Photoshop image, you have the option to import each layer. Certain
Photoshop layers aren’t supported by Flash and cannot be imported.

»~ Bitmap: The Bitmap image format (BMP) can be exported from many
image editing applications. The term bitmap is often confused with the
generic reference to all photorealistic images as bitmaps. One drawback
to bitmap images is that the file size is quite large as a result of an image-
editing application applying no compression when saving images to this
file format. Some image editing applications use Zip lossless compres-
sion when saving in this file format, which results in a smaller file size.

1 GIF Image: The GIF image format (GIF) is widely used for Web page images.
This format is best suited to images with large areas of solid color. It also
works well for images that have lots of text. As a rule, you're better off creat-
ing your text in Flash because you can edit Flash text at any time. The only
time you should consider using a GIF file in a Flash project is when you're
working with a logo, which generally has large areas of solid color.

 JPEG Image: The widely used JPEG image format (JPG) uses full (24-bit)
color. The JPEG format is known as a lossy format because data is lost
when images are compressed. The amount of data that’s lost depends
on the amount of compression you apply to the image when saving it.
In Photoshop and many other image editing applications, you have the
option of setting the quality of the image on export. In Photoshop, image
quality ranges from 0 (high compression, poor image quality, and small
file size) to 12 (little or no compression, high image quality, and large
file size). Some image editing applications use a range from 0 to 100; the
latter yields the best image quality and the largest file size.

1 Macintosh PCT Image: The Macintosh PCT Image format (PCT) was origi-
nally a Macintosh-only image format. Many image editing applications,
including image editing programs in the Windows operating system, can
export in the PCT format. The image format is full (24-bit) color.

»» MacPaint Image: The MacPaint Image format (PNTG) is a Macintosh
format. Images using this file format are similar to images created with
the Windows Paint program and are not compressed.

»» TGA Image: The TGA Image file format (TGA) can be created by most
popular image editing programs. The resulting file doesn’t support
layers and isn’t compressed.
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v~ TIFF Image: The TIFF image format (TIF, TIFF) is widely used. TIFF
images support layers, and the file format can be saved from most popu-
lar image editing applications. The format supports layers and can be
compressed on export. Flash, however, cannot import TIFF files com-
pressed using the Zip or JPEG compression options.

Preparing Images for Flash

If you read the previous section, you know that you can import most popular

file formats into Flash. However, just because you can import an image into

Flash doesn’t mean that it’s the right image for the job. Image editing applica- Book Il
tions refer to image size in document dimensions, which is a combination of Chapter 6
the image size in pixels and the resolution of the image in pixels per inch. For
example, an 8-x-10-inch image with a resolution of 300 pixels per inch (ppi)

has dimensions of 2400 x 3000 pixels with a whopping file size of 20.6MB. The
same image at 72 pixels per inch has dimensions of 720 x 576 pixels and a
relatively svelte file size of 1.19MB. Using the right commands in a good image-
editing application enables you to get an even smaller file size on the order of
about 50K or smaller. For monitor viewing, a resolution of 72 pixels per inch

is sufficient. If you've ever saved a properly optimized image from a Web site
(shame on you!) and printed it, you noticed that the image is blocky. That’s
because the image doesn’t have a resolution that’s high enough for printing.
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To give you an example of the impact that image size and resolution can
have on a Flash project, consider the following. The 8-x-10-inch image noted
in the previous section was exported from Photoshop with no compression
using the TIFF format and then imported into Flash. The image size was
huge — much larger than needed for the document. The image was cut down
to size using the Transform command. However, the original image was in
the document library; the same bloated 20.6MB file that was imported to
Flash. Flash applies image compression when exporting a file. The document
was published using the default compression settings, resulting in a file size
of 410K;; it’s relatively small compared to the size of the original image, but
imagine what the file size would be if you added other elements, such as
graphic objects, text, or animation.

The same image was exported from Photoshop in the JPEG format with a
Quality setting of 10 after being resampled to dimensions of 400 x 320 pixels
with a resolution of 72 ppi. The image that was imported into Flash was the
proper size. The file when published was 58K, considerably smaller than

the first published file. In Photoshop, the original image was resampled to
the same dimensions and resolution as the previous example, and exported
with a Quality setting of 7. The visual difference between the two images was
negligible. The image with a quality setting of 7 was imported into Flash. The
published file size was 28K — a considerable savings.



192 Preparing Images for Flash

As you can see from the previous example, preparing images ahead of time is
beneficial when you start to work with the images in Flash. Here are some rec-
ommendations you should consider when optimizing images for a Flash project:

1 Resample the image to pixel dimensions that aren’t wider than or taller
than your Flash document.

1 Change the image resolution to 72 ppi.

v~ If you're creating lots of Flash movies with images, consider investing in
an application such as Fireworks, which gives you the capability of com-
paring, side by side, the original image (2-Up, if you're being technical)
and the image with compression applied (see Figure 6-1).

1~ If you're working in an application like Photoshop and using the Adobe
RGB color profile or working with images from a digital camera that uses
the Adobe RGB color profile, convert the color profile to sSRGB IEC61966-
2.1. If you don’t, the image doesn’t display properly.
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Figure 6-1: Optimizing images in Fireworks CS4.
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1 Export the image using the JPEG format with Medium quality. However,
if you export at a higher quality, you can optimize the image in Flash.

v~ If you're creating images for a Flash file show, give the images sequential
names, such as img_01, img_02, and so on. You see why in the next section.

Importing Image Sequences

Creating Flash slide shows is fairly easy: Stack some images on the Timeline,
add a few frames to determine how long each image is displayed, add a little
ActionScript on the back end to loop the show, and you have something you
can plug into an HTML page or use as part of a Flash project. The trick is to
rename the images before you import them into Flash. Here’s how:

Book II
Chapter 6

1. Rename the images that will be in your image sequence.
Give the images sequential names, such as img_01, img_02, and so on.

2. In Flash, choose Filez>Import->Import to Stage.
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The Import dialog box appears.
3. Select the first image of your image sequence and click Open.

Logic may tell you to select them all. Don'’t. It creates more work if you do.
If you select the first image, you see the dialog box shown in Figure 6-2.

Adobe Flash C54 (%]

g/ This file appears to be part of a sequence of images. Do you want to import all of the images in the sequence?

[ Yes H No ” Cancel I

Figure 6-2: Yes, you can easily import an image sequence.

4. Click Yes.

Flash imports each image in the sequence and creates a keyframe for
each one on the Timeline (see Figure 6-3). Notice that the image you can
see isn’t aligned properly. If you're a Flash veteran, you may know how
to correct it. If you don't, or if you’ve never worked with frames, this is
your indoctrination by fire.

5. Click the Edit Multiple Frames icon.

Three frames are selected.



194 Importing Image Sequences

Bl e edt View Insen Modify Text Commands Control Debug Window Help | | Essentiats v | —Hx
Scene 1 B e
% i é' é“- —Ll [ test 2fla I~] & @
B
7 tems o ]
> |lnkags_[uss

dpa

u:
0

1

= 1

\ :
1

1

1

v
<] [ J (3]

TIMELINE

AoB el N FPCANS S EAND /B 00E~F

alad [{ mE Wl e Loks 24s [{] I ¥ (a6 ®= I 3

Figure 6-3: Imported and stacked on the Stage.

6. Drag the first handle to the first keyframe.

Now all the frames created from importing the image sequence are
selected for editing (see Figure 6-4).

7. Select the Selection tool, and then drag to marquee-select all images.

The easiest way to select all images is to click and drag outside the
perimeter of the Stage.

8. Choose Windowr>Align.
The Align panel appears.

9. Align the select images to the vertical and horizontal center of the
Stage.

For more information on using the Align panel, see Book I, Chapter 1.

Now that you have all your ducks in a row — er, we mean images aligned — you
can start adding frames between each keyframe, which determines how long
each image is displayed. Detailed information on working with the Timeline is in
Book III, Chapter 1.
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Figure 6-4: Selected, not rejected.

Importing a Photoshop Document with Layers

If you've created a document in Photoshop with objects on different layers,
you can preserve the layers when importing the document into Flash. After
the document is in Flash, you can move the objects on the layers to suit your
project. Imagine the power! You could create a collage in Photoshop with each
image on a different layer. Import the document into Flash and apply a motion
tween (see Book IIl, Chapter 2) to each image, and you have an animated col-
lage. To import a Photoshop document with layers, follow these steps:

1. Choose File=>Import to Stage.

The Import dialog box appears.

2. Select the Photoshop document (with the PSD extension) you want to
import and then click Open.

The Import [Name of Document] to Stage dialog box appears, as shown in
Figure 6-5. All layers supported in Flash are selected for import by default.
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‘Import "LayerStyle.psd” to Stage %]

Check Photoshop lavers to import: Layer import options:

T

Work Hard - Play Hard =

! Background =

To set import options, select one
or more layers on the left.

Convert layers to: |Flash Layers \v]
[“]Place layers at original position
[[Iset stage size to same size as Photoshop canvas (320 x 400)

Cancel

Figure 6-5: Import a Photoshop document to the Stage.

3. To deselect a layer, select its check box.

4. Choose an option from the Convert Layers To drop-down menu.
Your choices are Flash Layers and Keyframes.

5. Accept the default option, Place Layers at Original Position.

This option places the layers in the same position as they were in
Photoshop. If you deselect this option, the layers are centered to the Stage.

6. (Optional) Choose Set Stage Size to Same Size as Photoshop Canvas.
This option resizes the stage to the same size as the image.

7. Click OK to import the document.

Tracing Bitmaps

If you have an image you want to convert to vector objects, you can easily
do so with the Trace Bitmap command. When you convert an image to vec-

tors, it’s no longer linked with the bitmap in the document library. To trace a
bitmap, follow these steps:

1. Select the image you want to trace.

Figure 6-6 shows a photo of a flower that will be traced.
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Figure 6-6: You're going to trace a bitmap!

. Choose Modify=Bitmap->Trace [Trace Bitmap 1=
Bltmap. Color threshold: ma] .
The Trace Bitmap dialog box o .

M 2 |8 el
appears (see Figure 6-7). e e 5__
Curve fit: M‘i

. Accept the default Color Corner threshold: |Normal [v] Preview

Threshold value or enter a dif-

ferent value.

Figure 6-7: Tracing a bitmap.
Increase the value to decrease
the number of colors in the
traced bitmap, or decrease the value to increase the number of colors in
the traced bitmap. If you choose a lower value, the traced bitmap looks
more like the original image, but the file size is larger.

. Accept the default Minimum Area value or enter a different value.

This value determines the number of surrounding pixels to consider
when Flash determines which colors are assigned to which pixels.
Smaller values prevent banding if your image has lots of colors.

. Choose an option from the Curve Fit drop-down menu.

The Pixels option creates a traced bitmap that looks close to the origi-
nal. These options work differently depending on the number of curves
in your image and the complexity of the image. Our best advice is to
experiment. If you don’t like the result, undo the Trace Bitmap command
and try different settings until you find something you like.

. Choose an option from the Corner Threshold drop-down menu.

The Many Corners option creates a traced bitmap that looks more like
the original bitmap. Again, we advise you to experiment.
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7. Click OK.

Flash traces the bitmap. Alternatively, you can click the Preview button
to get a sneak peek at what the traced bitmap looks like with the current
settings. If you don’t like what you see, change the settings and click
Preview again. Figure 6-8 shows the traced bitmap that results from the
following settings:

e Color Threshold = 30
e Minimum Area = 4
e Curve Fit = Pixels

e Corner Threshold = Many Corners

Figure 6-8: The traced bitmap.

8. After you trace a bitmap, all the pixels are still selected. At this stage,
we advise you to choose Modify-> Group.

If you don’t, you run the risk of inadvertently selecting several pixels
and moving them. When you create a group, it acts as one object.

Editing Images

After you import images into Flash, you can edit them. No, we’re not talking
about transforming them; we’re talking about editing the actual image and
changing its image properties. In the following sections, we show you how to
edit images in an external image editor and how to change image properties.



s

<MBER

Editing Images 199

Editing images in an external editor

After you import an image into Flash, you can edit the image in an external
editor. What happens is that you make a round trip from Flash to the exter-
nal editor (Fireworks CS4 by default) and back again. When you finish the
round trip, the image is updated to reflect your edits. To edit an image in an
external editor, follow these steps:

1. In the document library, select the image you want to edit.

2. Right-click (Windows) or Control+click (Macintosh) and choose Edit
with Fireworks from the context menu.

After you choose this command, Fireworks launches and the Find
Source dialog box appears. This action gives you the option of choosing
a Fireworks source file in the application’s native PNG format or using
the file you imported into Flash.

3. Choose the source file option.

After choosing a source file option, the file opens in Fireworks. The Flash
symbol and the message “Editing from Flash” appear above the image,
which is a handy reference in case you become flummoxed and forget
the application in which you’re working.

4. Use the Fireworks image editing tools to perform the edits you want.

Unfortunately, a tutorial on editing images in Fireworks is beyond the
scope of this book.

5. After editing the image, click Done.

The image is updated to reflect your edits in Fireworks.

If you don’t own Fireworks, choose Edit With from the context menu and
from the Select External Editor dialog box, locate the EXE file for your image-
editing application.

If you edit an image in an external editor without taking a round trip from
Flash, your edits aren’t reflected in the image you imported into Flash. You
can easily rectify this situation by selecting the image and then choosing
Update from the context menu.

Editing image properties

You can affect the file size of a published document and the quality of

the images by editing image properties. You can modify the compression
method and the amount of compression applied to an image. To edit image
properties, follow these steps:

Book II
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. In the document library, select the image whose properties you want
to update.

. Right-click (Windows) or Control+click (Macintosh) and choose
Properties from the context menu.

The Bitmap Properties dialog box appears (see Figure 6-9). From within
this dialog box, you can modify the compression settings and test the
next settings before committing to them. If the dialog box opens in
Advanced mode, don’t worry — be happy. Advanced mode is used when
ActionScript is involved. ActionScript is covered in Book IV.

Bitmap Properties

o128 50 5.8

C:\Documents and Settings\Doug
SahlinDesktop\Flowersibinymagesarge'0128

Sunday, June 01, 2008 5:22:12FM
267 x 400 pixels at 32 bits per pixel

[ Allow smoothing
Compression: | Photo (JPEG) [v] [ rest |

Quality: (%) Use imported JPEG data
) Custom: (100=highest)

Imported JPEG: original = 427.2 kb,

compressed = 46.2 kb, 10% of original

Figure 6-9: Editing image properties.

. Accept the default label (the image filename) or enter a different
label.

Changing the label makes it easier to indentify what’s in the image when
you see the label in the document library. This is useful when you work
with images from a digital camera with filenames such as img2641.jpg. If
you change the label, the link to the original file is still intact.

. (Optional) Select the Allow Smoothing check box.

This option anti-aliases the edges of the bitmap. In our experience,
you don’t need this option if you're working with a sharp digital image.
Smoothing makes the image look a little fuzzy around the edges.

. Select an option from the Compression drop-down menu.

Choose Photo (JPEG) for photorealistic images or choose Lossless
(PNG/GIF) if the image contains large areas of solid color.

. Accept the default image quality, which is based on the original
image, or click Custom.

If you choose Custom, a text box appears.
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7. If you choose Custom, enter a value.

The highest quality is 100, which matches the quality of the original
image. Lower values result in smaller file sizes at the expense of image
quality.

8. Click Test.

This step tests your custom settings. The image in the dialog box is
updated to reflect the current quality setting. If you're not happy with
the results, enter a different value and test the settings again. When you
change compression settings, text at the bottom of the dialog box notes
the current compression setting, the original file size, and the com-
pressed file size.

\§
P If you decide to accept a low quality setting, you may notice that the

image looks blocky. Click Enable Deblocking to smooth the blocky
pixels.

9. Click OK.

The new properties are applied to the image.

Creating a Bitmap Fill

If you read Chapter 2 of this minibook, you might recall that we show you how
to specify a fill for an object. In case you didn’t read the chapter (sniff — it’s
some of our best work), you have your solid fills and you have your gradient
fills. Guess what? If you have images in your document library, you can create
a bitmap fill. That’s right: You can fill an object with an image by following
these steps:

1. Select the object you want to fill with a ﬂ
COLOR

bitmap.
AWl Type: Bimjap v
2. Choose Window>Color. > I e
The Color panel appears. m 5':,

3. Choose Bitmap from the Type drop-down
menu.

The dialog box refreshes, and the first bitmap
in the document library replaces the previous |_ —
fill. Thumbnails of all images in the document | & !ﬂ‘
library appear at the bottom of the panel (see | v|

Figure 6-10).

4. Move the cursor over the thumbnails in the
bottom of the Color panel. Figure 6-10: Fill me with a

The cursor becomes an eyedropper. bitmap.
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5. Click a bitmap.
The object is filled with the bitmap.

<P If you don’t see a bitmap worthy of filling your object, click Import to
open the Import to Library dialog box. Select an image and click Open
to import it to the library. The imported image appears at the bottom of
the Color panel and can be selected to fill the object.

6. After selecting a bitmap, close the Color panel.

If the bitmap doesn’t fill the image the way you want, use the Transform
Gradient tool to resize the bitmap fill relative to the object, rotate it, or
skew it, for example. For more information on the Transform Gradient
tool, see Chapter 2 of this minibook. Figure 6-11 shows a rectangle that
has been filled with a bitmap. The fill was transformed by using the
Transform Gradient tool.

"\\ 3
\

Figure 6-11: Oh, my —filled with a bitmap.

<P Click the Fill icon in the Tools panel to open the Swatches panel. At the
bottom of the panel, next to the gradients, you see thumbnails of bitmaps
you imported to the Stage or to the document library. Click the thumbnail
and it becomes the current fill.

Swapping Bitmaps — It’s Legal in All 50 States

After you import a bunch of bitmaps into the document library and start
using them, you may find that a different image is needed. And then there’s
the scenario in which you have almost finished the project and your client
suddenly decides that the picture that was sent to you looks horrible and
wants a recent glamour shot used instead. When either event occurs, you
can swap a bitmap quicker than this paragraph was typed. Here’s how:
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1. With the Selection tool, select the bitmap you want to swap.

2. Right-click (Windows) or Control+click (Macintosh) and choose Swap
Bitmap from the context menu.

Alternatively, you can choose Swap Bitmap
MOdlfyli>BltmapE:>Swap Bltmap | 2 /) izj 012808_Bok_S.3pg oK
Either method opens the Swap % [ 012008 Bok 11400 P

[%] 020308_fiwrs_10.jpg

Bitmap dialog box (see Figure - Bl
6-12). The Swap bitmap dialog
box shows the selected bitmap
and a list of all bitmaps in the
document library.

Book Il
3. Click a filename. Figure 6-12: Shhh — we're swapping a Chapter 6

The dialog box is updated to bitmap.

show the replacement bitmap.

Unfortunately, the dialog box doesn’t show thumbnails of the other bit-
maps in the document library. If you didn’t pick the right file, you can
select a different one.
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4. Click OK to swap the bitmap.
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Book Il
Animating
Graphics

The 5th Wave By Rich Tennant

w

“I can’t explain it, but everytime I

animate someone swinging a golf

club, a little divot of code comes
up missing on the home page.”




Fash has always provided the tools to create
compelling animations. However, in previous

versions of Flash, you had to jump through a cou-
ple of hoops before you could create even the sim-
plest animation. Flash CS4 makes it easier than
ever to animate graphics. You can make a shape
go from Point A to Point B and back again, or you
can morph one shape into another without having
to do a bunch of work on the Timeline.

In Book I, we show you how to harness the
power of Flash to create your own animations. We
also show you how to master the Timeline, simu-
late 3D animation, and create character anima-
tions with the new Inverse Kinematics feature. So
if you have the notion to get a move on, take this
minibook for a spin.




Chapter 1: Working with
the Flash Timeline

In This Chapter

+~ Understanding the Timeline
1~ Creating frames and keyframes

v~ Editing frames

men you create a Flash document, the default settings give a
Timeline with one keyframe, which is great if you're creating

something static. But Flash is all about motion and animation, so 1-frame
Timelines just don’t cut the mustard. The Timeline determines what hap-
pens during the course of your Flash movie. Keyframes on Timelines are
places where things change, because if something didn’t change, it
wouldn’t be Flash. When you create animations, you use the
Timeline to designate where action starts and stops. In
this chapter, we present a timely treatise on keyframes,
frames, and Timelines. And the Timeline signifies
that it’s time to stop the intro and start writing.

Getting to Know the Timeline

Someone told us that it’s all happening on the
Timeline. We do believe it. We do believe it’s

true. In Flash, the Timeline is used to arrange
content over time. You can put forks in the road,
known as keyframes, where things happen. The
document frame rate determines how the action on
each frame occurs. The default document frame rate of 12
frames per second (fps) means that you need 12 frames for
each second of action and that each frame is /. of a second. And,
we computed all that without the aid of a calculator or an abacus.

Each layer has its own Timeline. Each layer’s Timeline runs independently
of other Timelines. Flash gives you the tools to create a sophisticated ani-
mation. When you work with the Timeline, you can navigate from frame

to frame (also known as scrubbing the Timeline) by dragging the playhead
across the Timeline. Figure 1-1 shows the Timeline of a Flash project.
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Figure 1-1: The Flash Timeline is a happening place.

Frames and Keyframes and Blank Keyframes

Flash has three kinds of frames: frames (no, we aren’t being redundant),
keyframes, and blank keyframes. A Flash Timeline is composed of frames,
keyframes, blank keyframes, and frame spans. Figure 1-2 shows the anatomy
of a Timeline.

RIS & Ma e wE e | Biks o= EI [ v

Frames Frames

End of frame span

Figure 1-2: A Timeline waits for no man.

This list describes the elements on the Flash Timeline:
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1 Frame: A placeholder; a place where content stays the same — at least
at this stage of the game. In Chapter 2 of this minibook, when we show
you how to create motion tween animations, you’ll see that frames
become in-between frames, where Flash takes the reins and determines
what happens. Frames are designated by blank spaces on the Timeline.

1~ Keyframe: Designates where something changes in your animation. You
create a keyframe when you need a fork in the road. The keyframe can
contain a different graphic, or the graphic from the previous keyframe in a
different position. A keyframe is identified by a solid dot on the Timeline.

~ Blank keyframe: Signifies that a change is going to happen, but the frame
is empty. You can create blank keyframes at the beginning of a project to
set up the timing. You can then populate the blank keyframe by selecting
it and dragging an item from the document library to the Stage.

1~ Frame span: Consists of a keyframe and the following frames exclusive
of the next keyframe. The end of a frame span is indicated by an unfilled
rectangle.

Now that you know who all the players are, we suggest that you rock on to
the next section, where we show you how to create frame, keyframes, and
blank keyframes.

Creating Frames, Keyframes, and Blank Keyframes

3

After you map out your Flash project, you know where you need to add
frames, blank keyframes, or frames to your Timeline. In this section, we
show you how to add these gems to your Timeline.

If you do a lot of work with frame spans, you may prefer the option of click-
ing a frame in the sequence to select the entire sequence. To enable this
selection option, choose Edit=Preferences to open the Preferences dialog
box. In the Timeline section of the General tab, choose Span Based Selection.
Click OK to close the dialog box and immediately enable the feature.

Adding a frame
To add a frame to the Timeline, follow these steps:

1. Click the spot on the Timeline where you want to add the frame.

If you click in a frame span, the frame is added at that place in the frame
span. If you click an unused frame beyond the last frame in the Timeline,
Flash adds frames up to that point.
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If you enabled span-based selection in the Preferences dialog box,
Ctrl+click (Windows) or 88+click (Mac) to select a single frame.

2. To add the frame, do one of the following:

¢ Choose Insert>Timeline=>Frame.
e Press F5.

Adding multiple frames

To add multiple frames to the Timeline, follow these steps:

1. Click the spot where you want to add multiple frames to the Timeline.

Congratulations. You successfully selected a frame.

If you enabled span-based selection in the Preferences dialog box,
Ctrl+click (Windows) or 8+click (Mac) to select a single frame.

. Drag right or left to increase the selection to the number of frames

you want to add.
Alternatively, you can Shift+click the final frame you want to select.

If you enabled span-based selection in the Preferences dialog box,
hold down the Ctrl key (Windows) or 3 key (Mac) while dragging.
Alternatively, you can press Ctrl+Shift (Windows) or 8+click (Mac) to
select the final frame you want to select.

. Choose Insert> Timeline~>Frame.

Alternatively, you can press F5. Either method adds the same number of
frames to the Timeline you selected.

Adding a keyframe

To add a keyframe to the Timeline, follow these steps:

1. Click the spot on the Timeline where you want to add the keyframe.

If you click in a frame span, the keyframe is added at that place in the frame
span. If you click an unused frame beyond the last frame in the Timeline,
Flash adds a keyframe at the point and adds frames to fill the gap.

2. To add the frame, do one of the following:

e Choose Insert=>Timeliner>Keyframe.
* Press F6.
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Adding multiple keyframes

If you're creating a project such as a frame-by-frame animation, you need to
add multiple keyframes to the Timeline. To add multiple keyframes to the
Timeline, follow these steps:

1. Click the spot where you want to add multiple keyframes to the
Timeline.

One frame of the Timeline is selected.

If you enabled span-based selection in the Preferences dialog box,
Ctrl+click (Windows) or 8+click (Mac) to select a single frame.

2. Drag right or left to increase the selection to the number of keyframes
you want to add.

Alternatively, you can Shift+click the final frame you want to select.

If you enabled span-based selection in the Preferences dialog box,
hold down the Ctrl key (Windows) or 3 key (Mac) while dragging.
Alternatively, you can press Ctrl+Shift (Windows) or 8+click (Mac) to
select the final frame you want to select.

3. Choose Insert>Timeliner>Keyframe.

Alternatively, you can press F6. Either method adds the same number of
keyframes to the Timeline as the number of frames you selected.

Adding a blank keyframe

Did you ever have to make up your mind? Well, sometimes you know that
something is going to happen, and you know where it’s going to happen, but
you don’t know what is going to happen. If that’s what’s troubling you, just
walk right in and sit right down because we show you how to add a blank
keyframe to the Timeline. To add a blank keyframe to the Timeline, follow
these steps:

1. Click the spot on the Timeline where you want to add the blank key-
frame.

If you click in a frame span, the blank keyframe is added at that location
in the frame span. If you click an unused frame beyond the last frame in
the Timeline, Flash adds a blank keyframe at that point and add frames

to fill the gap.

If you enabled span-based selection in the Preferences dialog box,
Ctrl+click (Windows) or 8+click (Mac) to select a single frame.
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2. To add the blank keyframe, do one of the following:
e Choose Insert>Timeliner>Blank Keyframe.

* Press F7.

Editing Frames

Sometimes, you hit it right the first time, and your Flash project plays just the
way you want it to. And sometimes things happen too fast or too slow. You may
also find the need to cut frames or copy frames to another layer, for example.
Like the heading says, in this section we show you how to edit frames.

Selecting a frame

You can select one of your frames by doing one of the following:

\‘&N\BEH v~ Click a frame to select it.
©
« If you enabled span-based selection in the Preferences dialog box,
Ctrl+click (Windows) or 38+click (Mac) to select a single frame.
1~ Click one frame and then drag to select a range of frames.
1 Click one frame and then Shift+click another frame to select contiguous
frames.
§‘&N\BER v Double-click inside a frame span to select the entire frame span.
Y
Iy

If you enabled span-based selection in the Preferences dialog box, click
any frame in-between keyframes to select a frame span.

1 To select the entire Timeline, select a frame and then choose
Edit=>Timeliner>Select All Frames. Alternatively, you can press
Ctrl+Alt+A (Windows) or $8+Option+A (Mac).

Copying a frame
Another change you may need to make is to copy and paste a frame of a
frame span. To copy and paste, do one of the following:

1 Alt+click (Windows) or Option+click (Mac) a keyframe and drag it to the
location to which you want to paste it.

1~ Select a frame or frame span, choose Edit>Timeline~>Copy Frames, click
inside a frame span, and then choose Edit=>Timeliner>Paste Frames to
replace the frame span.
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Alternatively, click a blank frame at the end of the Timeline, and then
choose Edit=>Timeliner>Paste Frames to add the copied frames to the
end of the Timeline. You can also paste frames to another layer.

Managing a Timeline

There are many other ways to manage a Timeline. You can remove frames
and copy and paste frames, for example. The following list describes the dif-
ferent options you have for managing a Timeline filled with frames and key-

frames and frame spans and — whew!

1~ 1f you enabled the span-based selection option, you can change the dura-
tion of a frame span by moving the cursor over the last frame in the frame
span. When the cursor becomes a line with two arrows, click and drag to
the right to extend the frame span, or drag to the left to shorten it.

1 To delete a frame or frame
sequence, select the frame or
frame sequence, and then choose
Edit=>Timeline=> Remove Frames.
After invoking the command, Flash
moves the upstream keyframes
and frame spans to fill in the gap.

1 To move a keyframe or frame
sequence, select it and drag it to a
location you want. After you move
the selection, Flash extends the

appropriate selection to fill the gap.

1 To clear a keyframe, select it and
then choose Edit=>Timeline=>Clear
Frames.

» To convert a keyframe to a frame,
choose Edit=>Timeliner>Convert
to Keyframes. Flash fills the con-
verted frame with the contents of
the previous keyframe.

We wouldn’t be doing our job if we
didn’t introduce you to the power

of the context menu. Right-click
(Windows) or Ctrl+click (Mac) a key-
frame to reveal the context menu
shown in Figure 1-3. Every conceivable
command you can use is just a mouse
click away.

Figure 1-3: The Timeline context menu.
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Chapter 2: Creating a Flash
Animation

In This Chapter

v Creating a frame-by-frame animation
~ Creating a motion tween animation
1~ Creating a shape tween animation

» Animating with tools

 Creating an IK animation

A nimation has always been a staple of Flash projects. Motion tweening
and shape tweening have been part of Flash since we can remember,
and that was just before the Watergate scandal. (Kidding.) Tween
animations are slightly younger than dirt, and creating a

tween animation has changed considerably in Flash CS4.

You no longer have to create a symbol and then begin-

ning and ending keyframes before applying a motion

tween. That’s too much work.

Instead, you create a shape and tell Flash that

you want it to be a motion tween animation, and
Flash adds enough frames for a 1-second anima-
tion. You move the object to the last frame, and
Flash fills in the in-between frames to create your
animation. Tween, in between. Logical, isn’t it? In
this chapter, we show you how to create anima-
tions with motion and shape tweening. Careful with
the motion tween, Eugene!
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Creating an Animated Background

The new Art Deco tool makes child’s play out of creating a background that
draws itself. Yes, that’s right — the background is animated. It makes an
interesting background for certain projects. You can use the Art Deco tool to
replace the default symbols with any symbol you've added to the document
library. To create an animated background with the Art Deco tool, follow
these steps:

1.

Select the Art Deco tool and then select the frame where you want the
animation to start.

If you're creating a background, select the first frame.

. In the Drawing Effect section of the Property inspector, accept the

default symbols or click Edit to choose a symbol from the document
library.

Our experiments indicate that you’ll be happy if you accept the default
leaf shape and choose a flower shape from a symbol in the document
library. For example, you can create a star Graphic symbol with the
Polystar tool and use vines of stars for the background. (That might
work for a rock star’s Web site.)

. In the Advanced Options section, change the branch angle, pattern

scale, and segment length to suit your project.

For more information on setting up the Art Deco tool, see Book II,
Chapter 4.

. Select the Animate Pattern check box.

This option creates keyframes as you drag the tool across the Stage.

. Specify the Frame Set option.

This step determines how many frames it takes for each step of the ani-
mation to occur. If you accept the default option, Flash creates lots of
keyframes and your published file has more baggage than your ex-
girlfriend or -boyfriend does, which means that it’s a large file. If you
choose a value of about 30, the file size is manageable.

. Click on the Stage.

Sit back and relax while the tool fills the Stage with vines and leaves and
creates a keyframe for each step (see Figure 2-1).
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Figure 2-1: Creating an animated background with the Art Deco tool. Chapter 2

Creating a Frame-by-Frame Animation

A frame-by-frame animation is similar to the way cartoonists work. A car-
toonist creates a separate drawing for each frame of the cartoon, and when
the frames are compiled, they play back smoothly. You might have created
flip books when you were young, in which you draw stick figures at the top
of the pages on a small pad, change the character ever so slightly on each
page of the pad, and then quickly thumb through the pages to make the stick
figure move. This process is similar to a frame-by-frame animation, and you
know that it involves a lot of work.
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In a nutshell, what you do is create an object on a keyframe. Then you
create additional keyframes and change the object ever so slightly in each
keyframe. When the keyframes are played back, you see relatively smooth
motion. We don’t show you the steps for creating a frame-by-frame anima-
tion in this chapter because it’s not used often with graphics. It’s useful
when you're animating text, though, so we show you how to create a frame-
by-frame animation in Chapter 3 of this minibook.
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Making a Motion Tween Animation

Motion tween animations have been around forever in Flash. In Flash CS4,
you can create a motion tween animation more easily (much more easily)
than you could do it in previous versions of Flash. When you create a motion
tween animation in Flash, you use keyframes, which is where the changes in
motion take place. Flash interpolates the motion on the in-between frames.
When you play the animation, you see smooth motion. To create a motion
tween, follow these steps:

WMBER
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1.

Create a new document and create an object, and then position the
object where you want it on the Stage.

For the purpose of this exercise, create an oval; any color you like. When
you create your own animations, you can place the object anywhere you
want. For the purpose of this exercise, place the object in the lower-left
corner of the Stage.

. Double-click the object with the Selection tool to select it.

You have to double-click an object to select both the stroke and the fill.

. Choose Insert->Motion Tween.

Alternatively, you can right-click (Windows) or Ctrl+click (Mac) and
choose Motion Tween from the context menu. Either method displays a
dialog box warning you that the symbol cannot be tweened but notifying
you that Flash will gladly convert it to a symbol for you.

The dialog box doesn’t appear if you select a Graphic or Movie Clip
symbol from the document library.

. Click OK.

Flash adds 23 frames to the animation and positions the playhead on the
twenty-fourth frame of the animation, to give you a 1-second animation.

. Move the object to a different position on the Stage.

For the purpose of this exercise, move the object to the upper-right
corner of the Stage. After you move the object, Flash creates a keyframe
in the twenty-fourth frame and a line with dots from the starting point of
the animation to the ending point of the animation (see Figure 2-2).

. Drag the playhead to preview the animation.

You see smooth motion from Point A to Point B.

. Click the sixth frame and drag the oval up.

Flash converts the twelfth frame to a keyframe. The oval changes direc-
tion at this point and travels in a straight line unless you modify the path
between keyframes.
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Figure 2-2: Creating a motion tween animation. Chapter 2

8. Select the Selection tool.
You use this tool to modify the motion tween path.

9. Move the cursor toward the bottom segment of the path.
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When a curved line appears under the cursor, it’s your notification that
you can curve the motion path.

10. Click and drag to curve the path.
11. Repeat Steps 9 and 10 for the upper segment of the path.
The motion path should resemble the one shown in Figure 2-3.

12. Press Ctrl+Enter (Windows) or $+Return (Mac) to preview the anima-
tion in another window.

Flash publishes the animation as an SWF movie and plays it in another
window over and over and over and — the movie continues looping until
you press Esc. To prevent this from happening when you publish your
file for public consumption, you have to add some ActionScript, which
we cover in Book IV.
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Figure 2-3: This animation is not on the straight and narrow.

MBER
¢ You can create a motion tween animation inside a movie clip. When you do

this, it occupies only a single frame on the Timeline, and you can use it wher-
ever it’s needed in your Flash project. (Talk about your reusable animations!)

After creating a motion tween animation, you can tweak the animation with
the Motion Editor or Property inspector. The sophisticated Motion Editor
feature gives you more control over your animations than was possible in
previous versions of Flash. (Like the proverbial well, this subject is deep.)
We cover the Motion Editor and other ways you can tweak your motion
tween animations in Chapter 4 of this minibook.

Building a Shape Tween Animation

Another form of animation you can create in Flash is a shape tween anima-
tion. You supply the keyframes and the shapes, and Flash morphs one shape
into another on the in-between frames. (It’s a shame that you can’t morph
images in Flash — what better way to get even with a significant other who
turned into a significant nothing?) To create a shape tween animation in
Flash, follow these steps:
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1. Create a shape on a keyframe.

When you create a shape tween animation, you cannot use a symbol. The
shape must be created with one of the object drawing tools. For the pur-
pose of this exercise, create a rectangle with the Rectangle Primitive tool.

2. Select a blank frame and then press F7 to create a blank keyframe.

The number of frames between the first keyframe and the blank keyframe
determines the length of the animation. With a default frame rate of 24
frames per second (fps), a 48-frame animation lasts for two seconds.

3. With the blank keyframe still selected, create another shape.

For the purpose of this exercise, create an oval using the Oval Primitive
tool. The shape doesn’t need to be in the same size or in the same position.
With a shape tween animation, one shape morphs into another and moves.

4. Click a frame between the keyframes and then choose Insert=>Shape
Tween.

Alternatively, you can right-click (Windows) or Ctrl+click (Mac) and
choose Shape Tween from the context menu. After using either method,
the in-between frames become green, and an arrow appears between
keyframes (see Figure 2-4).
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Figure 2-4: Creating a shape tween animation.
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5. Drag the playhead to preview your animation.

One shape morphs smoothly into the other.

In most instances, Flash does the math correctly, and you have an outstand-
ing shape tween animation. We recommend against trying to tween a shape
with negative space (a hole, if you will), which can cause undesirable results.
However, if you're bound and determined to create a complex shape tween
animation, shape hints can be added to show Flash which part of the first
shape should morph into which part of the second shape. We cover tweak-
ing an animation with shape hints in Chapter 4 of this minibook.

Reversing an Animation

Sometimes, you may need to have an animation reverse itself. For example,
you can create a motion tween animation in which an object gently arcs

in a direction from the upper-left to the lower-right of the Stage and then
reverses direction. You can do the same thing for a shape tween animation:
Have an object morph to another shape and then unmorph itself. It’s easier
than you think. Follow these steps:

1. Create a motion tween or shape tween animation as outlined earlier
in this chapter.

What? You didn’t read the previous sections? If you don’t know the new
and much easier way of creating motion tween and shape tween anima-
tions, we suggest that you flip back a page or two where we show you
how much easier it is in Flash CS4.

2. Select the first keyframe of the animation, and then Shift+click the last
keyframe of the animation.

You’'ve selected the enter animation.

3. Right-click (Windows) or Ctrl+click (Mac) and then choose Copy
Frames from the context menu.

4. Select the blank frame after the last keyframe in your animation,
right-click (Windows) or Ctrl+click (Mac), and then choose Paste
Frames from the context menu.

Flash pastes all frames from the animation to the Timeline.

5. Select the first keyframe of the frames you just pasted, and then
Shift+click the last keyframe of the frames you just pasted.

The pasted frames are selected.

6. Right-click (Windows) or Ctrl+click (Mac) and choose Reverse
Keyframes from the context menu.

It doesn’t look like anything has happened. To see the results of your
handiwork, you have to preview the animation.
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Going retro

Flash motion tweening seems to have been
around forever. In the Jurassic period before
Flash CS4, you had to create a symbol and then
create keyframes and apply the motion tween.
Flash CS4 makes it easy for anyone to create
a motion tween animation. However, if you like
the old way of creating a motion tween, you're
in luck. After performing the preliminary steps of
creating the symbol and keyframes, position the
cursor on an in-between frame and then choose
Insertc>Classic Tween. We like the new way
better because you produce a motion path that
you can edit. Speaking of motion paths, you can
also use the old method of animating a symbol
along a path. After creating your classic motion

tween, right-click (Windows) or Ctrl+click (Mac)
the layer on which you created the classic tween
and choose Create Classic Guide from the con-
text menu. After you invoke the command, Flash
creates a classic motion guide layer, just like
the ones we knew and loved in previous ver-
sions of Flash. To finish the animation, you need
to create a path on that layer, align your symbol
to the start of the path on the first frame of the
animation, and then align your object to the end
of the path on the final frame of the animation.
That's way too much work, as far as we're con-
cerned. We tried the new way and we like it. But
you know what they say: “Different strokes for
different folks.”

7. Press Ctrl+Enter (Windows) or 38+Return (Mac).

Book

Flash publishes the movie as an SWF file and plays it in another window.
Your animation goes from Point A to Point B and then to Point A again.
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<P To reverse the order in which a motion tween animation plays, select the
frame span, right-click (Windows) or Ctrl+click (Mac), and choose Reverse
Keyframes from the context menu. After you invoke this menu command, the
last keyframe becomes the first keyframe and vice versa.
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Simulating 3D Animation

Maybe some future version of Flash will be 3D, but true 3D isn’t available in
Flash CS4. However, the application has taken a quantum leap because now
you can simulate 3D using the 3D Translation tool and the 3D Rotation tool.
The first tool is used to make it appear as though an object is closer to or
farther from the viewer during the course of an animation. The 3D Rotation
tool can be used to make it appear as though an object is spinning through
space during the course of an animation. These new tools are useful addi-
tions to an animator’s arsenal. Combine the tools in the same animation and
you get something way cool.
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Using the 3D Rotation tool

The 3D Rotation tool makes it possible for you to create animations where
objects look like they’re spinning in space. As with a regular 3D spinning top,
you can use the tool to make an object appear as though it’s spinning on the
X (top to bottom), Y (left to right), or Z (front to back) axis. To use the 3D
Rotation tool, follow these steps:

1. Create a motion tween animation with three or four keyframes.

For the skinny on how to create a motion tween animation, refer to the
“Making a Motion Tween Animation” section, earlier in this chapter.

2. Select the second keyframe, and then select the 3D Rotation tool.

Okay, you can select the first keyframe, but we want you to see how cool
this tool is by comparing the shape on the first keyframe to the second
keyframe.

3. Click the object.

Three rings appear around the object (see Figure 2-5): a red ring, which
controls rotation around the X axis, a green ring, which controls rotation
around the Y axis, and a blue ring, which controls rotation around the Z
axis.
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Figure 2-5: What goes up must come down. Spinnin’ wheel, spinnin’ round.

4. Click and drag your favorite color.

The object spins about the associated axis.
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Click and drag other rings to rotate along the other axes.

The tool gets addictive — use it with discretion. You never know
whether viewers might be susceptible to motion sickness.

. Repeat Steps 4 and 5 on the other keyframes however you want.

With a bit of experimentation, you create some interesting results by
using this tool. Use it in conjunction with the 3D Translation tool to
amaze your friends and the viewers of your Flash animations.

Using the 3D Translation tool

The 3D Translation tool makes it possible for you to create an animation that
looks like an object is traveling toward and away from you during the course

of the animation. Imagine creating a symbol that looks like the Enterprise and
then creating a complex motion tween animation where the ship is bobbing and
weaving between planets. Then use the 3D translation tool to make the ship
appear to be at different distances from the viewer during the course of the
animation. Put a reasonable facsimile of your favorite captain at the helm — we
vote for Picard.

To use the 3D Translation tool, follow these steps:

1.

Create a motion tween animation with three or four keyframes.

For the skinny on how to create a motion tween animation, refer to the
“Making a Motion Tween Animation” section, earlier in this chapter.

2. Select the second keyframe, and then select the 3D Translation tool.

Click the object.

Ared and green arrow appear from the center of the object (see Figure 2-6).
The red arrow controls motion along the Y axis (from left to right), and the
green arrow controls motion along the Y axis (from top to bottom). You
can control motion on both axes with the Selection tool. The 3D Translation
tool has another axis, which is Z (from front to back).

Move the cursor over the center dot until a small z appears.
You can now make the object appear closer to or farther away from you.

Drag left to make the object appear closer, and drag right to make it
appear farther away.

. Repeat Steps 3 through 5 after selecting the object on other key-

frames.

If you want, use the other arrows to move the object along the X and
Y axes. When you do so, the motion path is redrawn to reflect your
changes.

Press Enter or Return to preview the animation.

“I canna hold Warp Six, Cap’n; the reactor’s gonna blow.”
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Figure 2-6: Say what? 3D in Flash! Way kewl.

Animating with the Spray Brush Tool

When you use the Spray Brush tool, you can fill it full of symbols and spray
them at Will, if you have Mr. Robinson (in danger or not) in your Flash proj-
ect. If you load the Spray Brush with a movie clip symbol of an animation,
you have the basis of a cool animation. To animate with the Spray Brush
tool, follow these steps:

1. Create a Movie Clip symbol.

If you're not sure how to create a movie clip, place a bookmark here
(we would appreciate it if you didn’t dog-ear the corner of the page) and
check out Book II, Chapter 4.

. Create an animation.

A shape tween or motion tween animation works equally well with this
tool. You can also create an animation using an effect in the Property
inspector. For example, you can use the Alpha effect on an object, like

a star you create with the Polystar tool. Create an animation with three
keyframes. On the first and third keyframes, set the Alpha value to zero
and leave the middle frame at 100 percent. The resulting animation looks
like a flashing star.

3. Select the Spray Brush tool.
4. In the Symbol section of the Property inspector, click Edit.

The Swap Symbol dialog box appears (see Figure 2-7).



Creating an Inverse Kinematics (1K) Animation 227

“Swap Symbol
asterad
] space shi
o [ Starburst
El

Figure 2-7: Swap symbols to load the Spray Brush tool.

5. Select the desired symbol and click OK.
The Spray Brush tool is locked and loaded.

6. Click the tool wherever you want in order to sprinkle the animation
into your project.

Creating an Inverse Kinematics (1K) Animation

A cool new feature of Flash CS4 is the ability to create an inverse kinemat-

ics animation. If you've ever worked with 3D applications, you know what an
inverse kinematics animation is. If you aren’t familiar with 3D, think about how
your body moves. You have a skeleton of bones that are connected at joints.
The joint has a range of motion. For example, unless you're a cast member of

a horror movie, your neck has a range of motion of 180 degrees. Bones also
work in unison. When you move your hand, the connected bones move as well.
This is exactly what inverse kinematics is. You use the Bones tool to create an
inverse kinematics chain and then specify the range of motion for each bone.
When you drag a bone that’s a child of another bone, the parent moves. This is
just another shocking case where the child has control over the parent, which
proves that it pays not to grow up when you grow older. In the upcoming sec-
tions, we show you how to create an inverse kinematics animation.
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Creating the 1K chain minus the daisies

When you create an IK animation, you use the Bones tool to create a skel-
eton for the object or symbols that are part of your animation. When you use
the tool, you drag out the bones for the skeleton. The first bone you create

is the parent for the following bones you create. Each subsequent bone in
the chain is the parent of the next bone. You animate the chain by dragging
a child to move the parent and all bones upstream. To create an IK chain,
follow these steps:

1. Select the object to which you want to add an IK chain.

2. Select the Bones tool, which looks like a dog bone.
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3. Click where you want to position the head of the first bone, and then
drag to determine the length of the bone.

When you create a bone, Flash automatically adds an armature layer.
4. Release the mouse button when the bone is the length you want.

Be as precise as you can when creating the bones. This is the first ver-
sion of IK in Flash, and there’s no way to change the length of a bone
after it’s created. It may be beneficial to add guides as a visual reference
where you want each bone to end.

5. Click and drag to create the next bone.

Continue in this manner until you’ve created the skeleton for your
shape. Figure 2-8 shows a finger created with the Oval tool and a bit of
tweaking. The Bones tool was used to create a skeleton for the finger.
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Figure 2-8: Pull my finger.

You can also create an IK chain with symbols. Create a Movie Clip symbol
for each part of your IK chain and then use the Bones tool to create the
skeleton as outlined in the previous steps. The only weird thing you’ll notice
is you can’t see the last bone in the IK chain. Oh well, this is the first time
we’ve had inverse kinematics in Flash.
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You can change the way bones are displayed by selecting the armature layer
and choose an option from the Style drop-down menu in the Options section
of the Property inspector. You can display the bones on the armature by
using one of the following styles: Solid, Wire, or Line.

Constraining the bones

When you create an IK chain, each bone rotates 360 degrees by default. If
you’re going to create realistic animations, you know that will never fly.
You can, however, change this situation by constraining the bone. You can
constrain the rotation of a bone, and constrain movement along the X and Y
axes. You can also disable rotation or movement along the X and Y axes. To
constrain bones in an IK chain, follow these steps:

1. Using the Selection tool, select the first bone in the chain.

The Property inspector reconfigures to display options for constraining
a bone (see Figure 2-9).
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Figure 2-9: It's time to put a constraining order
on this bone.
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2. Accept the default Speed value, or use the scrubby slider to specify a
different speed.

You can also click the current value and enter a different value. The
Speed value determines how quickly the bone moves when a child is
moved. If you want the bone to lag behind a bit, specify a slower speed.
If you specify a speed of 0, the bone doesn’t move.

3. In the Joint Rotation area, modify the following options:

e FEnable: Joint rotation is enabled by default. Deselect this option, and
the bone cannot rotate and instead acts an anchor.

e Constrain: Enable this option and the Min and Max options become
available. Use the scrubby slider to constrain the minimum and maxi-
mum angle to which the bone can rotate. For example, if you were
constraining rotation for a bone that will function as a forearm, the
minimum angle would be 0 (zero), and the maximum angle would be
about 90 because the human forearm has approximately a 90-degree
range of motion unless you’re double-jointed. When you constrain
rotation, an icon appears at the head of the bone and is a graphical
representation of how far the bone can rotate in each direction.

4. Specify translation options in the Joint: X Translation and Joint: Y
Translation sections.

These options determine whether the bone can move from left to right
(X Translation) or up and down (Y Translation). You have the following
options:

e FEnable: Choose this option to enable movement along the applicable
axis. For example, if you were animating a leg, the bone you create
for the foot would be able to move forward and backward with mini-
mal rotation. When you enable this option for the X axis, a horizontal
line with two arrows appears at the head of the bone. If you enable
this option for the Y axis, a vertical line with two arrows appears at
the head of the bone.

e (Constrain: Enable this option to constrain motion along the applicable
axis. When you choose this option, the Min and Max options are avail-
able. Use the scrubby slider to constrain the minimum and maximum
range of motion that the object has along the applicable axis. The Min
value for the X axis determines the range of motion to the left, and the
Max value determines the range of motion to the right. The Min value of
the Y axis determines the range of motion in a downward direction, and
the Max value determines the range of motion in an upward direction.

A\\S
Use the arrow keys at the top of the Property inspector to navigate from one
bone to the next.
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Creating the animation

After you create the IK chain and constrain the bones, you're ready to ani-

mate the puppy, or whatever you decided to animate. All you need to do

is create a couple of keyframes and tug a bone or two, and Flash fills in the
frames between the keyframes. To get a move on with your IK chain, follow
these steps:

1.

Select the Armature layer.

If you have a lot of layers in your project, you may find it beneficial to
lock the layers not directly associated with your IK animation.

Click the frame where you want a change to occur and then press F6.
This step creates a keyframe.

Click a bone and drag it.

It’s alive — err, we mean, the bone moves.

Move the other bones as needed.

Press the Shift key to constrain motion to the selected bone. This option
comes in handy when you want to simulate motion, such as the second
joint of a finger bending without affecting the first joint. Figure 2-10
shows a bent finger ready to point at something.

Continue adding keyframes and moving bones as needed to finish
your animation.
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Figure 2-10: Let me make my point perfectly clear.
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Using the Bind tool

In a perfect world, Flash would know which points to connect to which
bones. But Flash is a computer application. Flash employs, at best, a scien-
tific wild guess when interpolating which points should move when a bone is
moved. If your animation isn’t playing as expected, you need the help of the
Bind tool. To use the Bind tool, follow these steps:

1. Select the Bind tool and then click the bone that needs to be edited —
unbound, if you will.

The points influenced by the bone are highlighted in yellow. Points that
are connected to more than one bone are designated as triangles (see
Figure 2-11).

< m B

Figure 2-11: Some of these points are bound to be changed by
the Bind tool.

2. To prevent a point from being influenced by a bone, Alt+drag
(Windows) or Option+drag (Mac) the point to whichever bone you
want.

The point is highlighted in red. If the point was previously influenced by
more than one bone, the icon changes from a triangle to a rectangle.

3. To determine which bone influences a point, select it with the Bind
tool and then Shift+drag it to the bone you want.

The modified point is highlighted in red. If the point was previously
influenced by only one bone, its icon changes to a triangle.



Chapter 3: Animating Text

In This Chapter

1~ Creating typewriter text

» Animating text

A s authors, text is near and dear to our hearts. Without text, there
wouldn’t be books, and without books, there wouldn’t be authors,
which wouldn’t be much fun for us. Dummies authors like to have fun with
words, which means that we also like to play with text. So whenever we’re
writing about an application such as Flash, it’s a no-brainer to create some
flashy text about flashy techniques that animate text. If that’s too much
Flash for you, we’ll excuse you while you catch your breath. Ah, you're
back. Get ready to have some fun animating text.

Creating Typewriter Text

Believe it or not, people used to use a device
known as a typewriter to write things like letters
and books. It had no spell check. And it had no
cut-and-paste feature. If you made a mistake, you
dabbed on some correction fluid, waited for it to
dry, and then typed again. If you remember type-
writers (Doug still has one), we're sure that you
welcome the power of the computer and the word
processor. But if you're creating a Flash Web site
for an author, for example, and you want to make
it look like his name is being typed, you’'ve come
to the right chapter in this book. In this section,
we show you how to create an animation that
appears as though each word was typed. Follow
these steps:

1. Create a block of static text.

Choose a font type, size, and color to suit your project. Because we're
authors, we'’re partial to the Courier font because it looks like it was cre-
ated by a typewriter.

2. Select the text and then choose Modify->Break Apart.

The text block is divided into individual, selectable letters.
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3. With the text still selected, choose Modify=> Timeliner>Distribute to
Layers.

Flash creates a separate layer for each letter, and each layer is named
for the letter (see Figure 3-1).
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Figure 3-1: Distributed to layers again.

4. Delete Layer 1.

It contains all the letters on the layers just created by the Distribute to
Layers command. Therefore, you don’t need it any more.

5. Select the keyframe in the second layer and drag it one frame to the
right.

Flash creates a blank keyframe in the first frame and moves the key-
frame to the second frame.

6. Select the keyframe on the third layer and drag it two frames to the
right.

Starting to get the picture? You're adding an additional space between
each keyframe to make the text look like it’s being typed one letter at a
time.

7. Continue moving the keyframe for each letter, as outlined in Steps 1
through 6.

8. Select the blank frame to the right of the keyframe in the second-to-
last layer, and then Shift+click the same frame in the first layer.

You've selected the same frame in all layers.
9. Press F5.

This keyboard shortcut adds enough frames to display all letters until
the end of the animation. If you didn’t add the frames, each letter would
disappear as soon as the next one appears. Your Timeline should resem-
ble the one shown in Figure 3-2.
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Figure 3-2: The typewriter text Timeline.

10. Press Ctrl+Enter (Windows) or 38+Enter (Mac).

Flash displays the animation in another window (see Figure 3-3). The
only thing missing is the sound of a typewriter. If you like this technique
and want to add some sound, take a look at Book V, Chapter 2, where we
show you how to add sound to a Flash project.
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Figure 3-3: It's the old hunt-and-peck animation.

Creating Flying Text

Cool animation isn’t reserved for graphical objects. When you create static
text, you can use motion tweening to animate text. Of course, when you
create a motion tween animation, it must be on its own layer, which is easily
done with the Distribute to Layers command. If you have a lot of letters to
animate, you may think that this task is difficult, but it’s not. Follow along
with us and we’ll show you how to create an animation where text flies into
the scene. Follow these steps:
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. Use the Text tool to create a block of static text.

Create the text off the Stage. The effect you're creating has the text
flying in from every direction.

With the text still selected, choose Modify->Break Apart.

Flash breaks the block of text into individual letters that you can
animate.

. Modify~>Timeline~ Distribute to Layers.

Flash creates a separate layer for each letter.

. Select Layer 1 and drag it to the Delete icon.

You no longer need this layer because each letter is on its own layer.

Select the first frame of the first layer, and then Shift+click the first
frame of the last layer.

You've selected the first frame in all layers.

Right-click (Windows) or Ctrl+click (Mac), and choose Create Motion
Tween from the context menu.

Flash adds 11 frames to each layer’s timeline. The background is blue,
indicating that a motion tween animation can be created by changing
the position of the object in the last frame.

. Move the playhead to the last frame.

8. Using the Selection tool, move the letters to the position where you

11.

12.

13.

want them to stop.

Flash adds a keyframe to the twelfth frame of each layer.

. Move the playhead to the first frame.
10.

Using the Selection tool, move each letter to a different position.

The letters “fly in” from the position to which you move them. Make
sure that you truly jumble the position of the letters and vary the dis-
tance they have to travel. Your goal is to create some visual eye candy.

Select an individual letter.
The letter’s frame span is selected, and you can see its motion path.
Move the cursor toward the motion path.

When the cursor changes to a pointing arrow with a curve beneath it,
you can bend the motion path into a graceful curve.

Click and bend the motion path into a graceful curve (see Figure 3-4).
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Figure 3-4: Bending the motion path.

14. Bend the motion paths for the other letters.

Bend the paths in different directions to make each animation look
random.

15. Select the frame span in the second layer, and drag it a couple of
frames to the right.

The goal is to have the letters fly in at different times. Moving the frame
span to the right causes the second letter to fly in after the first.

16. Select the frame span in the third layer, and drag it a couple of frames
to the right of the second layer.

Your Timeline should resemble Figure 3-5.

17. Repeat Step 16 for the remaining layers in your animation.

Book llI
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Figure 3-5: No letter will fly before its time.

18. Select the blank frame directly above the last keyframe in the bottom
layer.

19. Shift+click the same frame in the first layer and then press F5.

Flash adds enough frames to display each letter for the duration of the
animation (see Figure 3-6).
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Figure 3-6: Adding enough frames to display each letter for the entire animation.
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20. Press Ctrl+Enter (Windows) or &+Enter (Mac).

Flash publishes the project as an SWF file and plays it in another window
(see Figure 3-7). The animation plays repeatedly, which means that you
need to add some ActionScript to stop the animation.
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Figure 3-7: Is it a flock of seagulls? No. It's
flying letters.
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You can modify the animation by adding keyframes and then moving the let- Chapter 3

ters to a different position. Imagine having the letters fly in and then pause
before flying out to different directions. Your only limitation is your imagi-
nation. When you have some spare time, experiment with different ways to
animate text. If you don’t have any spare time, check out Successful Time
Management For Dummies, by Dirk Zeller (Wiley Publishing).

3] Bunewnuy
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43“% When you create a text animation, it doesn’t have to be on the main Timeline.
You can create a Movie Clip symbol for your animation. When you create an
instance of a movie clip, it occupies only one frame on the Timeline.
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Chapter 4: Advanced Animation
Techniques

In This Chapter

1~ Using motion presets
 Manually editing motion paths
v~ Editing animations

1 Copying motion

1~ Using visual aids

n Flash CS4, animation took a quantum leap forward. In addition to

changing the manner in which you create animation, the designers of
Flash gave animators some bells and whistles that they can use
to create sophisticated animations. New to Flash CS4 is the
Motion Presets panel. The panel has some impressive
presets that enable you to take your animations to the
next level. And, if you create an animation of your
own that you want to use again, you can add it to
the panel.

The new Motion Editor is another tool you can

use to create a sophisticated animation. From
within the Motion Editor, you can control all
phases of the animation, including property
changes. You can also manually edit a motion

path using the Subselection tool. You can even
copy motion and apply it to other objects in your
Flash project. If you prefer shape tween animations

(also known as morphing), there’s something for you B e —
in this chapter as well. In this chapter, we show you some TE———
advanced animation techniques and show you how to edit your

animations.

Using Motion Presets

The Motion Presets panel is a welcome new addition to Flash CS4. If you're
not the best animator in the world, you can apply a preset from the Motion
Presets panel to an object in the workspace and — quicker than you can
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blink an eye — Flash does all the heavy lifting. If you're a good animator, or
maybe even an expert one, you can use one of the presets as a starting point
for your own animation. To use a motion preset, follow these steps:

1. Create an object on the Stage.

Use your favorite drawing tool to create the object. You don’t have to
convert it to a symbol; Flash does that for you. Alternatively, you can
use a symbol from the document library.

2. Choose Windowr>Motion Presets.

The Motion Presets panel appears. At this stage, it’s ho-hum. In fact, you

might say it’s boring. Read on.
3. Click the Motion Presets folder.
Yikes! — look at all those presets.
4. Select a preset.

A preview of the animation plays in
the panel (see Figure 4-1).

5. When you find an animation you
like, right-click (Windows) or
Ctrl+click (Mac) and choose an
option from the context menu.

Choose Apply at Current Location
to apply the motion preset from
the selected keyframe forward, or
choose End at Current Location to
create the last frame of the anima-
tion at the current keyframe.

6. Press Ctrl+Enter (Windows) or
8 +Enter (Mac).

Your animation plays in another
window.

Creating a motion preset

When you create a cool animation, one
that you want to use on other projects
or share with or sell to other Flash
users, you can easily do so. To create a
motion preset, follow these steps:
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Figure 4-1: Follow the bouncing ball.

1. Select the frame span that contains the animation you want to save as

a preset.
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2. Right-click (Windows) or Ctrl+click (Mac) and choose Save as Motion
Preset.

The Save as Preset dialog box appears.

3. Enter a name for the preset and click OK.

Make sure that you give the preset a meaningful name that reflects what
the animation does to an object; for example, Exit Stage Left. After you
save the preset, it appears in the Custom Presets folder of the Motion
Presets panel.

Managing motion presets

You've got presets; lots of presets. As you gain experience as a Flash ani-
mator, you may find that some of the old presets you created are lame and
should be evicted from the Motion Presets panel. You may also find that the
name you gave to the animation isn’t useful and should be changed. Or, you
may find that you're scrolling through way too many presets to find the one
you want and you need to use feng shui on the panel or call in a professional
organizer. We're pleased to inform you that it’s not nearly that difficult if you
follow these steps:

1. Choose Windowr>Motion Presets.

The Motion Presets panel opens.

2. Open the Motion Presets Options menu by clicking the icon in the
upper-right corner of the panel, and choose one of the following
commands:

Import: Imports a Motion Preset File in the XML format. You use this
command to import a motion preset that a fellow Flash user has
exported.

Export: Exports a selected preset as a motion preset file in the XML
format. You use this command to share a motion preset with a fellow
Flash user who can then use the Import command mentioned in the
preceding bullet to import the preset into her Motion Presets panel.

Rename: Renames a custom preset. You cannot rename one of the
default Flash motion presets.

New Folder: Creates a new folder in the Motion Presets panel. This
option comes in handy when the panel overfloweth or you're using
this copy of Flash with another user and you want to keep matching
(or even his and hers) preset folders.

Remove: Removes a custom preset from the Motion Presets panel.
You cannot remove a default Flash preset.

Save: Saves the selected frame span as a custom motion preset.
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Manually Editing a Motion Path

When you create a motion tween animation, you can bend the path with the
Selection tool, as noted in Chapter 2 of this minibook. Because a motion path
has a point for each keyframe, you can manually edit the points with the
Subselection tool. To edit a motion path manually, follow these steps:

1. Select the Subselection tool.

It’s the second tool on the toolbar.
2. Click a point on the path.

The Bezier handles for all points are displayed (see Figure 4-2).
3. Drag the Bezier handles to change the motion path.

Selecting a Bezier handle can be tricky. When the cursor for the
Subselection tool becomes a solid arrow with no tail, you can click

and drag one tangent handle to reshape the curve. If you Alt+click
(Windows) or Option+click (Mac), the tool affects only the selected tan-
gent handle. You can move a handle up and down to reshape the curve
or the path, to the right to increase the length of the handle (which cre-
ates a gently flowing curve), or to the left to decrease the length of the
handle (which creates a sharp curve).

4. Move the tool toward a point.

When an unfilled square appears below the tool, click and drag the point
to a different position.
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Figure 4-2: Manually editing a motion path.
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5. Move the tool toward the path.
When you see a filled square beneath the tool, click and drag to move
the path to a different location.

You can also select a path with the Selection tool and then drag it to a differ-
ent location.

Editing Motion Tween Animations

Motion tween animations may not be the greatest thing since sliced bread,
but they certainly beat creating animations frame-by-frame. After creating

a motion tween animation, you can edit the animation to perfection. In the
following sections, we show you techniques you can use to create the anima-
tion exactly the way you want it.

Fine-tuning the animation

Sometimes you create an animation, but it’s too slow or too fast. And then at
other times, you want the animation to start slowly and end quickly. Perhaps
you even want the object to rotate a time or two during the course of the
animation. The following subsections show you how to change the timing of
the animation and edit the animation in the Property inspector.

Changing the timing of an animation

Does your animation fly by like a Jumpin’ Jack Flash, or is it as slow as
molasses flowing uphill? If your animation has either problem, you can
change the timing of an animation by doing one of the following:

1 Move the cursor toward the last frame in the animation. When it
becomes a line with two arrows, click and drag to the right to increase
the duration of the animation, or drag to the left to decrease it.

v Ctrl+click (Windows) or +click (Mac) a frame between keyframes,
and then press F5 to add a frame. This action increases the duration
of the animation. Press Shift+F5 to remove a frame, thereby decreasing
the duration of the animation. You can also use the keyboard shortcut
to select a single frame and then drag to select additional frames. Press
F5 to add the same number of frames you selected, or press Shift+F5 to
remove the same amount of frames you selected.

Editing an animation in the Property inspector

The new motion tween animation truly simplifies your life as a Flash anima-
tor. After you create the animation on the Stage, you can do several things
to fine-tune it in the Property inspector. After creating an animation, follow
these steps:
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1. Select the object you're PROPERTIES |LIBRARY | ==
animating. Motion Tween
2. Click Properties in the panel | |
dock to open the Property
inspector. = EASE
If you modified the work- R
space or are using a work- < ROTATION
space tha.t doesn’t display the Ratate: =graets) i~
Property inspector, choose
Window=>Properties. Figure 4-3 Direction: | none k3
shows the Property inspector [ Orient to path
after selecting the path for a
— PATH

motion tween.

X ¥ =116
3. In the Ease section, drag the
scrubby slider to set a value. & W: 3 H: 172
Drag the slider to the left < OPTIONS
to specify a negative value. Tt At s

Negative values cause the ani-
mation to start slowly and end
quickly. It’s the equivalent of

a car accelerating from a dead
stop. Drag the slider to the right
to specify a positive value. This
action causes the animation to start quickly and end slowly, like a car
stopping for a light. The default value of 0 gives you constant speed
throughout the animation.

Figure 4-3: A motion path has properties you
can modify.

4. (Optional) Drag the Rotation scrubby slider.

If you enable this option, the object rotates along the path. Rather than drag
the scrubby slider, you can click inside the field and enter a value.

5. To add rotation to the object, drag the plus sign (+) scrubby slider.

This step specifies the number of degrees to be added to the object’s
rotation. In other words, if you specify 1 for the number of times the
object rotates and specify 90 for this value, the object makes one com-
plete rotation plus 90 degrees.

6. If you enabled rotation, choose an option from the Direction drop-
down menu.

This step is easy. The animated object can either rotate clockwise (CW)
or counterclockwise (CCW). If you choose None, the object doesn’t
rotate and the value you specified in the Rotation section reverts to the
default value of 0 (zero).
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7. Select the Orient to Path option if you haven’t enabled rotation.

10.

When you choose this option and you have a curved motion path, Flash
aligns the object to the path. When the animation plays, the object
rotates to maintain its original orientation to the path.

In the Path section, use the scrubby sliders to change the X and Y

values.

This step moves the motion path. Changing the X value moves the path

horizontally, and changing the Y
value moves the path vertically.

In the Path section, use the
scrubby sliders to change the W
and H values.

This step changes the width and
height of the motion path. The
path is resized proportionately

by default. Click the chain icon to
change the icon to a broken link,
and you can then resize each value
independently of the other.

In the Options section, accept the
Sync Graphic Symbols option or
select the check box to disable it.

This option synchronizes the
timeline of a symbol with the main
Timeline.

This set of steps shows you the
options you have for the path, but
there’s much more you can do to a
motion tween animation. Select the
object you're tweening, and a different
set of options appear in the Property
inspector. The following steps show
you how to modify the object:

1.

Select the object you’re
animating.

The Property inspector dons
another mask, showing you the
options available for modifying the
object that’s being animated (see
Figure 4-4).
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Figure 4-4: And now you get to modify the
object you're animating.
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2. Drag the playhead to navigate to the point in the animation where you
want a change to occur.

3. In the Position and Size section, drag the scrubby sliders to modify
the X and Y values.

These values determine where the object is at this point in the anima-
tion. The X value determines where the center of the object is along
the horizontal axis, and the Y value determines where the center of the
object is along the vertical axis. Remember that the X and Y values for
the upper-left corner of the Stage are 0 (zero).

4. Use the scrubby sliders to modify the W and H values.

These values determine the width and height of the object at this point
in the animation. The object is resized proportionately by default. Click
the chain icon to change it to a broken link, and you can then resize
each value independently of the other.

5. In the 3D Position and View section, drag the scrubby sliders to
change the X, Y, and Z values.

The X value determines the position of the object from left to right, the
Y value determines the position from top to bottom, and the Z value
determines the value from front to back. In essence, these values mimic
a 3D animation. The Z value varies the size of the object to make it
appear as though it’s closer to or farther from the viewer at this point in
the animation.

Flash CS4 doesn’t create keyframes when you change a property. You
do, however, see a diamond icon on the Timeline when you change a
property on a frame.

6. Drag the scrubby slider to modify the perspective angle.

This value changes the apparent perspective of the object for the entire
animation. Higher values severely distort the perspective of the object
and can lead to some unpredictable results. Experiment with this value
until you see something you like.

7. Drag the scrubby sliders to change the X and Y vanishing point
values.

These values stay constant for the entire animation. The X value deter-
mines the vanishing point relative to the horizontal axis, and the Y value
determines the vanishing point relative to the vertical axis.

8. Choose an option from the Color Effect drop-down menu.

This option applies a color effect at this point in the animation. You can
create an interesting animation by applying a color effect, such as Alpha
at the start of your animation. Set the Alpha value to 0 at the start of the
animation and 100 at the end of the animation. The object looks like it’s

appearing out of thin air.
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Introducing the Motion Editor

In Flash CS3, you had the option to create a custom ease. In Flash CS4,

you have more control over your animations, thanks to the addition of the
Motion Editor. If you've used Adobe After Effects, the Motion Editor should
look familiar to you. In a nutshell, it enables you to control every facet of
your animation, including applying a custom tween. We show you how to
use the animation powerhouse now:

1. Create a motion tween animation.

We go out on a limb here and assume that, because you'’re reading this
section, you know how to create a motion tween animation. If not, check
out Chapter 2 of this minibook, where we cover motion tweens, shape
tweens, and all tweens in between.

2. Open the Motion Editor.

The Motion Editor’s default spot in the workspace is at the bottom of
the workspace, next to the Timeline. Click its title to open it. If you're
working in a different workspace or have created a custom one that
doesn’t display the Motion Editor by default, choose Window=>Motion
Editor. The Motion Editor in all its glory is shown in Figure 4-5. Notice
that there’s a section for each motion parameter you can modify. Drag
the scrollbar to navigate to the hidden ones.
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Figure 4-5: Yikes — the Motion Editor is a busy place.

3. At the bottom of the interface, you find three icons. You use them to
change the motion editor:

e Graph Size: Drag the scrubby slider to change the height of each
graph. The option to increase graph height comes in handy when
you're editing a complex animation with lots of changes on the
Timeline.
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e Expanded Graph Size: Drag the scrubby slider to set the height of the
graph from the default graph size value explained in the preceding
bullet. After changing this option, when you select a parameter such
as X or Y in the Basic Motion section, the graph for that parameter
expands to this value. You can use a relatively large value to gain
better control when editing the Timeline for that parameter.

e Viewable Frames: Drag the scrubby slider to change the number of
frames displayed in the Motion Editor.

4. Navigate to the section you want to modify.
You can modify these sections:

* Basic Motion: Change motion on the X and Y axes and rotate the
object on the Z axis.

e Transformation: Skew the object along the X and Y axes and scale the
width (Scale X) and Height (Scale Y); change a color effect; change
filters that have been applied to the object; and specify which ease
options are available for the parameters that are animated. Note
that each parameter has a check box that gives you the option of
enabling or disabling animation for that parameter.

5. In the Basic Motion and Transformation sections, you can click the
curved arrow to the right of the section to reset values.

When you reset values for a section, any changes that have been applied
to the Timelines in that section are removed.

6. Choose an easing option from a parameter’s easing drop-down menu,
to the right of the check mark.

You can add easing options to the menu, as we explain in this step list.

7. Drag the playhead to a frame on the Timeline where you want to
change a parameter.

The playhead is identical to the one on the main Flash Timeline.

8. To add a keyframe for a parameter, right-click (Windows) or Ctrl+click
(Mac) and choose Add Keyframe from the context menu.

A keyframe on the Motion Editor Timeline is signified by a filled square.
9. Change the value of the parameter.

You can change the parameter by dragging the keyframe up or down. We
prefer using the scrubby slider next to the current value or clicking the
current value and manually entering the value because it’s more accurate.



10.

11.

12.

13.

14.

15.
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Add additional keyframes as needed.

When you have multiple keyframes on a Timeline, the arrow keys to the
right of the Ease drop-down menu can be used. These arrows enable you
to navigate to the next or previous keyframe. If you navigate to a frame
on which there’s no keyframe, click the spot between the arrows to

add a keyframe. If you navigate to a frame on which there’s a keyframe,
a beige diamond appears between the arrows. Click the diamond to
remove the keyframes for the parameter you're editing from the frame
on which you parked the playhead.

To add a color effect to the animation, click the plus sign (+) icon to
the right of the Color Effect section.

When you add a color effect to the animation, you can set the value on
the first keyframe and it remains constant throughout the course of the
animation, or you can create a keyframe further into the animation and
specify the value at that point. When you choose the latter method, the
default value is applied to the first frame. After choosing a color effect,
add keyframes and modify the values at each keyframe.

To add a filter to the animation, click the plus sign (+) icon to the right
of the Filter title.

You can apply multiple filters to an animation. After choosing filters, add
keyframes and modify the values at each keyframe and then choose a
filter from the drop-down menu.

To remove a filter or color effect from the animation, click the minus
sign (-) icon to the right of the Color Effect or Filters section.

After you click the minus sign, a menu appears, showing the color effect
or filters that have been applied to the animation. Select the filter or
color effect you want to remove.

To add more eases to the animation, click the plus sign (+) to the right
of the Eases title and choose an ease method from the drop-down menu.

When you select an ease, a graphical representation of the ease appears
to the right of its name. As they say, a picture is worth a thousand
words, so we save several thousand and let the graphs do what the
designers of Flash intended — show you what the ease looks like.

Modify the number of iterations of the ease.

If you choose an ease, such as Bounce or Sawtooth Wave, a value
appears to the right of the name. For example, the default option for the
Bounce ease causes the object to bounce four times. Use the scrubby
slider to change the value, or click the current value and enter your own.
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Figure 4-6 shows the Motion Editor after several parameters have been
modified and three eases have been selected. Notice the Bezier handles
on the Sawtooth Timeline. You can use these handles to modify the way
the transition eases from one keyframe to the next. Each keyframe also
has a context menu, which is also displayed in Figure 4-6. For the pur-
pose of this animation, the Motion Editor has been undocked from the
Timeline, which isn’t a bad idea if you have a busy animation and have
enough monitor real estate to view the Motion Editor and the Stage at
the same time.

<P You can create a custom ease by choosing Custom from the Eases menu.
Add keyframes to the Timeline to specify where the motion change takes
place. Each keyframe has a Bezier point with handles. The first and last key-
frame have one tangent handle. Drag the handles for each keyframe to define
the custom ease, and then choose the parameters to which it will be applied.

<P If you're editing a motion tween animation and you decide that you want
to animate a different symbol, select the first keyframe of the animation
and drop a symbol from the document library onto the symbol you want to
replace. Flash displays a dialog box asking whether you want to replace the
symbol. Click Next to complete the swap.
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Figure 4-6: The Motion Editor is an animator’s best friend.
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Understanding nonroving and roving keyframes

When you create a motion tween animation and change an object’s position
on a specific keyframe, Flash applies the change at that keyframe. For exam-
ple, if you create a 12-frame animation and on the eighth frame move the
object, Flash adds a keyframe to the Timeline to note the change. When the
animation plays, the object travels from Point A to Point B in 8 frames and
then travels from Point B to Point C in 4 frames. If the distance from Point A
to Point B is long and the distance from Point B to Point C is short, the first
part of the animation proceeds slowly and then speeds up. When this sce-
nario occurs, the object moves from Point A to Point B in a linear fashion,
and then from Point B to Point C in a linear fashion. This process is known
as an animation with nonroving keyframes (see Figure 4-7). Notice how much
closer the points are on the final curve of the animation.

£ >

Figure 4-7: A motion tween animation with nonroving frames.

If you prefer to have a linear animation, you can do so if you switch the ani-
mation to roving frames. When you create a motion tween animation with
roving keyframes and change the duration of the animation, the keyframes
rove the motion path to create an animation that’s perfectly linear from
beginning to end. To change to roving keyframes, right-click (Windows)

or Ctrl+click (Mac) the motion path and choose Motion Path=>Switch
Keyframes to Roving. Figure 4-8 shows the same motion path as in Figure
4-7 with roving keyframes. Notice that the dots that signify the in-between
frames are evenly spaced. In fact, there isn’t an in-between frame when the
object changes direction. If, after previewing the animation, you decide to
switch back, right-click (Windows) or Ctrl+click (Mac) the motion path and
choose Motion Path=>Switch Keyframes to Non-roving.
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Figure 4-8: These frames were made for roving, and that's just what they’'ll do.

Copying Motion

Animation is fun. If you create a complex animation, though, with lots of key-
frames and lots of changes in the Motion Editor, the chances of your dupli-
cating the animation are nil unless you created the animation in a Movie
Clip symbol. But if you didn’t and you decide that what’s cool for one object
is cool for several more, you can replicate the animation blow by blow,
keyframe by keyframe. You can do this by using a command or by using
ActionScript as discussed in the following sections.

Using the Copy Motion command

It’s Friday afternoon and you’re thinking about a wonderful weekend not
spent in front of a computer monitor when your favorite client (the one you
nicknamed PITA) calls and tells you that the roller-coaster text animation
you created for a word needs to be duplicated for two other words. In other
words, the second word slides down the slippery slope a second or so after
the first, and then the third follows the second. And you think “Yikes. No
way.” But there is a way. Follow these steps:

1. Select the first keyframe of the animation you want to duplicate, and
in the Property inspector, note the X and Y coordinates of the object.

This step is necessary only if you want the duplicated animation to start
from the same spot.

2. Right-click (Windows) or Ctrl+click (Mac) the first layer, and choose
Insert Layer from the context menu.

Flash creates a new layer.
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3. Select the frame where you want the second animation to start and
then press F6.

A keyframe is born.
4. Create the object that you want to follow the first.

If you want the object to begin moving from exactly the same point,
open the Property inspector and change the object’s X and Y values to
the same values you noted in Step 1. If you don’t do this, the object has
an identical motion path but starts from a different position. Sometimes
that’s just what you need, but in this scenario, you want the objects
starting from the same place.

5. In the first layer, right-click (Windows) or Ctrl+click (Mac) the motion
path and choose Copy Motion from the context menu.

6. In the second layer, right-click (Windows) or Ctrl+click (Mac) the
object and then choose Paste Motion from the context menu.

Like magic, a motion path is attached to the object.

7. Repeat Steps 2 through 7 for other objects to which you want to apply
the same animation.

Figure 4-9 shows three words that follow the same path, thanks to the
Copy Motion command.
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Figure 4-9: Follow the leader.

Copying motion using ActionScript
What happens when you create a cool animation and you want to use it with
several instances of an object already on the Stage and on the same layer?
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It’s child’s play — ActionScript to the rescue. We know what you’re thinking:
The ActionScript chapter hasn’t happened yet. But you don’t need to know
much about ActionScript. All you need to do is name your symbol instances,
use a command, and Flash does the rest. Follow these steps:

1. Select a symbol instance that you want to animate with ActionScript.
2. Open the Property inspector.
3. In the Property inspector, give the symbol instance a name.

If the symbol instance is a graphic, choose Movie Clip from the Type
drop-down menu to convert the symbol from a graphic to a movie clip.
You can give a symbol instance any name you want, but don’t use any
special characters or spaces. For more information on naming symbol
instances, see Book V.

4. Choose Windowr>Actions.
The Actions panel appears.
5. Click the keyframe where you want the animation to start.

Alternatively, create a new keyframe where you want the animation to
start.

6. In the Actions panel, right-click (Windows) or Ctrl+click (Mac) and
choose Paste from the context menu.

The Actions panel is filled with copious amounts of ActionScript that
only a geek can understand (see Figure 4-10).
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28
2
0
n
2 )
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< >
o Laverz:1 =
Ling 330F 33, Col 3.

Figure 4-10: Do what?
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Scroll to the next-to-the-last line of ActionScript.

The number of lines varies depending on the complexity of your anima-
tion. If you have lots of changes in your animation, you have a lot of
code. The last line of code in this case is a curly brace. You're modifying
the line of code before that.

Delete the two forward slashes at the start of the line.

Forward slashes indicate that the code is a comment. Some developers,
including the fine folks at Adobe, comment a line of code that will turn
into instructions when the forward slashes are deleted.

Select the text <instance name goes here> and replace it with the
instance name you created in Step 3.

Figure 4-11 shows the modified ActionScript.
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Figure 4-11: Cut and paste is simply mah-velous, dahlink.

Press Ctrl+Enter (Windows) or 38+Enter (Mac).

The ActionScript you pasted into the frame has the symbol instance
jumping through hoops.
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Editing a Shape Tween Animation

If you up the ante on a shape tween animation and have the sublime morph
into the cor blimey, you may have a problem on your hands. If the shapes
aren’t simple, Flash may have a tough time doing the math, and Zippy the
Wonder Rectangle doesn’t morph into Zippy the Wonder Star in a predict-
able manner. When you create a shape tween animation, your audience
should have a clue what the final shape will look like during the transition
period from one keyframe to the next. If the in-between frames look like
Heinz 57 pixels, you have to lend Flash a helping hand in the way of shape
hints. To find out all about them, follow these steps:

1. Create a shape tween animation.
2. Drag the playhead across the frames of the animation.

Pay special attention to the shapes on the in-between frames. Figure 4-12
shows a blob of pixels that’s supposed to be a 5-pointed star morphing
into a triangle. This shape is difficult for Flash to calculate because of
the difference in the number of sides for each shape. When you have

a difficult shape tween, look for common elements between the two
shapes. In our scenario, the triangle has three points. Look for three
points on the star that form a similar shape.
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Figure 4-12: Say what?
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Select the first keyframe in your animation, select the object, and then
choose Modify=>Shape~>Add Shape Hint.

Flash places in the middle of the shape a small red dot with a lowercase
letter a in its center. You can’t see it, but a red dot with a lowercase a in
its center has been placed in the center of the second object. You use the
letters as a guideline when placing shape hints on each object. Shape Hint
a on the first object morphs into Shape Hint a on the second object.

Drag the shape hint to the location you want.

If you examine both objects for similarities, you know where to place the
shape hint. You should place it on something that Flash can recognize,
such as the point where two lines intersect.

Choose Modify->Shaper>Add Shape Hint.

Flash places in the center of the first object a small red dot with a lower-
case b and in the center of the second object.

. Drag the second shape hint to the location you want.

Shape hints work best when you arrange them in counterclockwise order.
Continue adding shape hints as needed.

At the risk of being redundant, let us say that you’ll know how many shape
hints you need after examining the shapes for similarities and examining
the animation on the in-between frames before adding shape hints.

Click the last keyframe in the animation.

In the center of the shape, you find a pile of shape hints; the same as the
number of shape hints in the first object. The last shape hint is on top.

Arrange the shape hints on the second shape.

Remember to arrange the shape hints in counterclockwise order. As you
move the shape hints to their respective points on the second object,
they turn green, and the shape hints on the first object turn orange, which
is Flash telling you that it can create a decent shape tween animation.
Figure 4-13 shows the triangle in the animation with shape hints applied.

Drag the playhead to preview the shapes on the in-between frames.

Figure 4-14 shows the in-between frames for the shape tween animation
of a star morphing into a triangle. The viewer has a good idea of the
shape that will appear at the end of the animation. Compare this object
to the gnarly-looking one shown in Figure 4-11.
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Figure 4-14: Shape hints come to the rescue again.
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Editing Multiple Frames and Other Delights
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When you’re working with a frame-by-frame animation, the option to edit
multiple frames can save you a lot of time. At other times, you might want
to see what’s happening on the other frames in your animation. That’s when
you call in the onion skins. Sometimes you need both features at the same
time. If we've piqued your curiosity, please read on.

Using onion skins

Onion skins make it possible for you to see what your animation looks like
on other frames. When you enable the Onion Skins option, Flash displays a
lower-opacity version of the shapes on the in-between frames of a motion
tween or shape tween, which shows you how the shapes on the in-between
frames will be drawn and where they appear on the Stage. If you don’t like
what you see on a motion tween, you can modify the motion path and imme-
diately see the results. If you're editing a shape tween animation, the onion
skins on the in-between frames show you how the object morphs from Shape
A to Shape B. You can view onion skins as outlines or as lower-opacity rendi-
tions of the shape as it appears on that frame. To enable onion skins, click
the second icon on the bottom of the Timeline panel. To enable onion skin
outlines, click the third icon at the bottom of the Timeline panel.

Figure 4-15 shows an animation after onion skins have been enabled. The
default option shows only two frames on either side of the selected frames.
You can change this option by dragging the hollow dots at the end of the
onion skin markers that look like black braces at the end of the onion skin
frame span, which is designated in dark gray on the Timeline.

You can change the manner in which onion skins are displayed by clicking
the Modify Onion Markers icon at the bottom of the Timeline panel. This
action opens a menu that gives you the option to display onion skin mark-
ers, anchor the onion skins to the selected frame, and specify the number of
frames to which onion skins are applied.

Editing multiple frames

The option to edit multiple frames comes in handy when you need to fine-
tune a classic motion tween or classic shape tween animation. When you
enable the editing of multiple frames, you can select an object on any key-
frame and change its position or size, for example. Used in conjunction
with onion skins, it’s a powerful one-touch punch that helps you finish your
editing in record time. To enable the editing of multiple frames, click the
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Edit Multiple Frames icon at the bottom of the Timeline. Figure 4-16 shows a
shape tween animation with the Edit Multiple Frames option enabled. Notice
that both shapes are displayed as though they were on the same frame even
though the playhead is parked on an in-between frame. Each shape can be
edited from this frame or from any frame in the marked span.
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Figure 4-15: Use onion skins when your animation drives you to tears.

When you work with a shape or motion tween animation created with the
new paradigm, viewing multiple frames is useful. However, you can edit only
the object on the first keyframe in a motion tween animation and then edit
the path. Using the new method of creating a shape tween, you can edit the
object on the first and last keyframe.
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Figure 4-16: Editing multiple frames is a powerful option.

263

sanbiuysa}
uonewIuy pasueapy



264  Book 111: Animating Graphics



Book IV
Adding
ActionScript 3.0
Magic

The 5th Wave

B Rich Tennant

“See? I created a litble Selon figuve that
runs avound our Web site hiding behind
banner ads. On the last

e, ouy logo

log
puts him in a non-lethal choke hold and
brings him back to the home page.”




A ctionScript 3.0 gives you total control over
what you want to happen on the stage. Long

gone are the days when all ActionScript could do
was start and stop an animation. You can now do
everything from create shapes dynamically to
load animated movie clips on the fly.

Book IV shows you how to harness the power of
ActionScript 3.0 using both the Timeline and the
external ActionScript files. You can drag images
across the stage, dynamically use text to respond
to user actions, use the new Vector class to draw
images and store and retrieve data, and much,
much more. This is Flash with a power boost!

LOGICAL
OPERATIONS

THE YECTOR
(OMPANY

Pres-Joe Smith
Marketing-Brenda Jones

Development-Lee Pierce
Finance-Gideon Thomas
Production-Jesse Femandez
Sales-Nancy Huang




Chapter 1: Who's Afraid of the
Big Bad ActionScript 3.0?

In This Chapter

+~ Understanding old and new ActionScript

1 Working on the Timeline

1~ Writing scripts

1~ Using event listeners

v~ Capturing mouse events

1~ Creating functions for buttons

1~ Controlling movie clips

A ctionScript in Flash began as a way to control the
Timeline of a Flash movie. Buttons, movie clips,
and keyframes could all contain little bits of script.

For example, you could assign a gotoAndStop (12)

statement to a button so that when that button is FRAME]
pressed, the playhead would move to Frame 12
and stop. Usually, the targets of the script were

FRAMETS

keyframes where new content would appear.
The downside of this method is that each button
required its own script, and as application sizes AT
grew, so too did the complexity of working with @ -
all those little scripts.

With each new version of Flash, ActionScript
improved, but nowhere near as dramatically as with
ActionScript 3.0, where the language has been revised
from top to bottom.

So that you can write more powerful ActionScript, Adobe modeled the latest
release of ActionScript similar to other programming languages. Yes, we
said the ugly word: programming. But before you run off and jump into caul-
dron of boiling oil as a pleasant alternative to programming, in this chapter
we show what you can do with ActionScript 3.0 and (we hope!) convince
you to give the latest version a try.
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The new ActionScript 3.0 is based on a standard with the rather drab moni-
ker ECMAScript Revision 4.

Standardizing the language increases both stability and familiarity, so you
don’t have to learn the language all over again each time a new version of
Flash is released. The following sections give you the lowdown on some
of the basic features of the new, improved ActionScript and how they’'ve
changed from previous versions.

Button scripts

ActionScript 3.0 can be used in conjunction with buttons and movement
on the Timeline, but things are done differently. If you're an old hand with
ActionScript, it might help to review some of the differences. If you’re new
to Flash and ActionScript, ignore the old way of using ActionScript and just
concentrate on the new way.

The old way of working with buttons and ActionScript was to select a button
and in the Actions Panel write something like the following:

on(release) {
gotoAndStop (5) ;
}

Because the ActionScript was written on the button, you didn’t have to
reference the button name. It was simple, but with several buttons spread
throughout an application at different levels and positions on the Timeline,
debugging each individual button could quickly become a nightmare.

With ActionScript 3.0, the reference to a button is to the button instance
name, where an instance is just the name you give to a button. For example,
the name myButton uniquely identifies a button and differentiates it from
every other button instance.

All button instance names must be unique so that you can tell one from the
other.

You give a button an instance name by selecting the button and typing the
name of the button in the Properties panel. (Figure 1-1, a little later in this
chapter, shows the instance name of the button in the Properties panel.)

Mouse events

When you want a button to do something, first you assign it an event han-
dler, which for a button can be several different actions, just as with the
old ActionScript. However, because the events are actions taken using the
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mouse, the event handler is some kind of MouseEvent. The following mouse
events are available:

CLICK

DOUBLE_CLICK

MOUSE_DOWN

MOUSE_MOVE

MOUSE_OUT

MOUSE_OVER

MOUSE_UP

MOUSE_WHEEL

ROLL_OUT

ROLL_OVER
As you can see, they're expressed in ALL CAPS; this is because they’re con-
stants that don’t change in value. So, a CLICK is always a mouse click by the
user and nothing else. Just say “Play it again, Sam:” A CLICK is just a CLICK,

a mouse is just a mouse. These fundamental concepts apply as the Timeline
goes by.

Also, MouseEvent constants are fairly self-explanatory. For example, a
DOUBLE-CLICK means that the button is double-clicked, and a ROLL_OVER
occurs when the mouse is rolled over the button.

Listen up! Adding event listeners to buttons

We human beings listen for all kinds of events every day, practically all day.
You listen for your cell phone or doorbell to ring or for the dog to bark or a
baby to cry. With ActionScript 3.0, you do the same thing. When this event
occurs, the event listener is basically telling the rest of the code, “Listen up!
do something!” The generic format for writing an event listener is

myButton.addEventListener (MouseEvent.EVENT, function);

This line of code needs one of the ten mouse events listed in the previous
section. Likewise, the function that it calls can be any kind of function allow-
able in ActionScript 3.0; for example:

btnTxt.addEventListener (MouseEvent.CLICK, launchShip);

Imagine that a doorbell is the button, the wiring of the doorbell to the
chimes adds the event listener, the particular sound made by the chimes is
the event (“ding, dong!”), and the function (answering the door) is the action
taken when the doorbell rings. Figure 1-1 illustrates this relationship.
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doorBell.addEventListener(Chimes.DINGDONG, answerDoor)

Button Possible sounds Action to take

Wire doorbell to chimes Specific event

Figure 1-1: The relationship between the even listener, event, and action.

Functions for buttons

You need to add a function in order to do something. Further details

about ActionScript 3.0 functions are discussed in Chapters 2 and 5 of this
minibook, but for now, we describe a simple one just to get you started.

An ActionScript 3.0 function is made up of the word function; a function
name; parameters, if any; and statements telling the application what to do.
Functions also have a return type, consisting of either the data type returned
or void, which means that nothing is returned. (Think of a return as a value
that the function generates, just like a value in a variable.) Sometimes when
the function returns nothing, the return type is omitted. With buttons, you
always need an event parameter that provides a variable with the event
type. For example, the following code shows a function that tells the applica-
tion to go to Frame 10 and stop:

function launchShip(e:MouseEvent) :void
{

gotoAndStop (10) ;
}

Figure 1-2 shows all the different parts of the function used by the button.

Function name Parameter type

Function Parameter name

function goFramelO(e:MouseEvent)

{
}

gotoAndStop(10);

Statement

Figure 1-2: The parts of a function.
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In looking at the parts of a function, they’re pretty simple. You might think of
them as instructions you give to a small child. You lay out the instructions in
detail. First, you tell the child that you're giving him an instruction (function)
and the name of the task (coming to dinner.) The parameters represent the
event that initiates the action (immediately), and the statements are further
instructions (sit down, don’t play with your food, and eat your vegetables).
It might look like this:

function comeToDinner (yell:MomInstruction)
{

sit down;

don't play with your food;

eat your vegetables;

}

The extent to which you imagine functions as a set of instructions — an
instruction package — the more sense they make.

Bossing around movie clip scripts

As you may know from working with Flash movies, the main stage or
Timeline is just one big movie clip. So writing movie clip scripts is just a
matter of selecting keyframes on a movie clip’s Timeline and adding code in
the Actions panel. However, we don’t have you write much code on movie
clips’ Timelines because it’s not only an easy way to get tangled up and
make a mess but also bad form. That’s because it hides the code from the
main program, and you’ll play Where’s Waldo trying to find out which movie
clips have embedded code. Essentially, you need a way to order movie
clips around. With buttons as a user interface, the code needs to indicate
which movie clip is being sent an instruction. Keeping all your code in one
place makes life a lot easier, and the only code that’s in the movie clips is a
stop () statement in the first frame.

You might be thinking, if you build a sophisticated movie clip with lots of dif-
ferent places to stop, that you need lots of stop () statements in the movie
clips. It isn’t true. Suppose that your movie clip has 50 places with 50 differ-
ent keyframes where the user should be able to stop. The magic method is

gotoAndStop (n) ;

You can not only direct a movie clip’s Timeline to stop at a keyframe (n)
but also have it stop at any frame. All you need is to address the movie clip’s
instance name and use the magic method. For example,

froggy.gotoAndStop (23) ;

instructs a movie clip with the instance name froggy to hop over to Frame
23 and stop.
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You're not confined to using Timeline commands. You can use any of the
MovieClip class methods or properties that you want. Figure 1-3 gives you an
idea of the large number of methods that are available. Just select the MovieClip
class in the Actions panel and click the Methods or Properties directory.

ACTIONS - FRAME 'é“

[‘ActionScript 3.0 + L
[E) movieciip
L} [@) events
[E) methods il

addchild (DisplayObjectContainer)

addChildAt (DisplayObjectContainer)

addEventListener (EventDispatcher)
arelnaccessibleObjectsUnderPoint (DisplayObjectContainer)
contains (DisplayObiectContainer)

dispatchEvent (EventDispatcher)

getBounds (DisplayObject)

getChildAt (DisplayObjectContainer)

getChildByName (DisplayObjectContainer)

getChildindex (DisplayObjectContainer)
getObjectsUnderPoint (DisplayObjectContainer)

getRect (DisplayObject)

globalToLocal (DisplayObjecty

globalToLocal3D (DisplayObject) H
gotoAndPlay

gotoAndStop

hasEventListener (EventDispatcher)

hasOwnProperty (Object)

hitTestObject (DisplayObject)

hitTestPoint (DisplayObject)

isPrototypeOf {Object)

local3DToGlobal (DisplayObject) J
lacalToGlobal (DisplayObject)

MovieClip

nextframe

nextscene

play

prevFrame

prevScene
propertylsEnumerable (Object}
removeChild (DisplayObjectContainer} v| P

2EPERAAARAEEPEREEPAEIAAIEEEAEREEE®

= e, L

Figure 1-3: The Actions panel displaying a
MovieClip's methods.

To find the MovieClip class, you need to first locate the directory (or pack-
age) it’s in. Take a look in the f1lash.display directory.

Experiment with some of the different methods besides gotoAndStop (),
and notice that you already used addEventListener () , another MovieClip
method. After you experiment with several methods, open the Properties
directory and see what trouble you can cause. (Just kidding.) For example,
the following examples show the use of different MovieClip properties with a
movie clip instance, myClip:

myClip.x=200; // Horizontal position on screen
myClip.y=150; // Vertical position on screen

myClip.rotation=33; // Tilt to 33 degree angle

Go ahead and experiment with different properties until you get the hang of it.
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After you have an idea of what you can do, we show you how to use that
knowledge to put together something practical; for example, an application
that lets the user control the Timeline.

The following steps walk you through the project using buttons, keyframes,
simple graphics and ActionScript 3.0 that holds the whole thing together:

1. Open a new Flash file (ActionScript 3.0), give the file a name, name
the layer, and then save the file.

Our example uses three different pages located on three different key-
frames. The ones we use in this example are just big circles, but they
could be different product or services descriptions, steps in a project,
descriptions of different people in a company, or any other endless
number of possibilities.

In the example, we saved it as TimeLine. fla and named the layer
actions.

2. Click on a frame and press the F5 key.
We clicked on Frame 30 and pressed F5, which creates 30 frames.

3. Create two more layers and position them below the Actions layer.
We named the layers Controls and Timeline, as shown in Figure 1-4.

4. Select the Timeline layer and add the keyframes you want by selecting
each frame you want to add content to individually and pressing F6.

We added keyframes at Frames 15 and 30.

5. Click on the first frame of the Timeline layer and add whatever con-
tent you want to the frames.

We drew a circle and, in the middle of the circle, typed Frame 1 using
the Text tool set to Static Text. We did the same thing in Frames 15 and
30, typing the names Frame 15 and Frame 30, respectively. Figure 14
shows how Frame 30 looks.

6. Lock the layer.

7. To create a button, click on a frame and add an image to it, if it
doesn’t already have one.

This image is the visual button that users expect to click. We clicked the
first frame of the Controls layer and drew a circle with the dimensions
(W=32.5 and H=32.5). The numbers represent the number of pixels, but
all you see in the Properties panel are the numbers associated with W
and H — W(idth) and H(eight).

Book IV
Chapter 1
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Figure 1-4: An instance name of a selected button being added in Properti

8. Select the image and press F8.
The Convert to Symbol dialog box appears.

es panel.

We selected the circle (including the stroke line) and pressed F8 to

create a symbol.

We named ours Btn.
10. Make as many buttons as you want and click a button.

The Properties panel appears.

Select Button as the type, type a name for the button, and then click OK.

For this example, we made two copies of the button, lined them up verti-
cally (as shown earlier, in Figure 1-1), and selected the top button.

11.
other buttons, if you have more than one.

We named our buttons not very imaginatively but short,

obvious: btnl, btn2 (refer to Figure 1-4), and btn3.

12.
the layer.

Type a name for the button’s instance name and do the same for any

sweet, and

Add content to the frames that the buttons will target and then lock
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We used the Text tool set to Static Text and then typed Frame 1 next to
the first button and Frame 15 and Frame 30 next to the second and third
buttons, respectively (refer to Figure 1-4).

13. Click the first frame of the Actions layer, open the Actions panel, and
add a script similar to the following. Change the italicized text and
add or delete lines as necessary, depending on the number of buttons
you have, their names, and which frames you used:

stop () ;

//Add event listeners to buttons

btnl.addEventListener (MouseEvent .CLICK,go01) ;
btn2.addEventListener (MouseEvent .CLICK,gol5) ;
btn3.addEventListener (MouseEvent .CLICK,go30) ;

//Functions for buttons
function go0l(e:MouseEvent) :void

{
gotoAndStop (1) ;

}

function gol5(e:MouseEvent) :void

{
gotoAndStop (15) ;

}

function go30(e:MouseEvent) :void

{
gotoAndStop (30) ;

}

You might be wondering what :void means in the functions. That term
tells the compiler not to expect anything to be returned. If you want a
value returned, you enter the type (such as String or Number) rather
than void.

14. After you complete the script, lock the layer and test the movie by
pressing Ctrl+Enter (or 38+Return on the Mac).

If everything is working correctly, your movie plays. Book IV

Chapter 1
If you followed our example (download it at www . dummies . com/ aper

flashallinone), you see that as you press each button, a different
circle appears, indicating the appropriate frame. You have total control
over the Timeline, and users can select where on the Timeline to posi-
tion the playhead. Of course, users never see the playhead. All they see
is different information arranged so that it’s easy to find, and you man-
aged to create three pages from a single page.
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P If you use the Timeline as a means of moving to different sets of information in
your application, your application can accumulate a large number of bytes
in the size of the SWF file. For smaller projects with just a few images or a
little text, it works fine. In Chapter 2 of this minibook, you see an alternative
to using the Timeline. Rather than create giant SWF files, you just bring in
what you need, when you need it, and still just use one page.
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After you know how to control a Timeline using ActionScript 3.0, you can
see how to control another movie clip’s Timeline. Keep in mind that the task
we show you in the preceding section only moves the playhead on the main
Timeline, What you do in this section is move the playhead on a different
movie clip’s Timeline.

Suppose that you have created an animation that you want to execute only
when directed to do so by the user. You can have bouncing balls, danc-

ing bears, and juggling jugglers if you want, all animated and ready to go.
However, you only want the balls to bounce, bears to dance, and jugglers to
juggle when the user so directs. You can add a lot of stop () statements to
different positions on a Timeline of a movie clip to help to control the flow,
but to do so adds an unacceptable level of clutter.

Clutter in an application is a slippery slope to chaos, wringing of hands,
and gnashing of teeth. The bigger the application, the more problems you
encounter. Therefore, the only ActionScript in the movie clip is a single
stop () statement in the first frame of the Timeline.

Now we show you how to do something interesting with a movie clip and
ActionScript.

The following application uses three instances of a single movie clip. The
movie clip represents a glass that fills up using a shape tween. Four buttons
control the glasses and the tween in the movie clip. The following instruc-
tions step you through the process:

1. Open a new Flash file (ActionScript 3.0), name it, save it under the
name you want, and then name the layer.
We saved our file as McTimeLine. fla and named the layer actions.
2. Choose Insert~>New Symbol.
The Create New Symbol dialog box appears.

3. Type the name for the symbol, select Movie Clip for the type of
symbol, and then click OK.

The Symbol Editor appears, where you can create your movie clip as
though you’re working on the main Timeline.

We typed Cup for the name.

4. In Symbol Editor mode, name the layer and type the stop(); statement
in the Actions panel (as shown in Figure 1-5).

We named the layer action.
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Figure 1-5: The Timeline in the Symbol Editor shows the shape tween in the midway position.

5. Click on a frame and press the F5 key to add frames from Frame 1 all
the way out to your chosen frame. Then lock the action layer.

We chose to add frames out to Frame 30 and then locked our action
layer.
Book IV

6. Add at least one more layer beneath the action layer, name the new e
apter

layers, and lock them.

Our example adds two more layers beneath the actions layer and
names them glass and wine, respectively (refer to Figure 1-5); we
locked only the wine layer.

7. Select a layer where you want your image and draw or paste an image
on the Stage.
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We selected the glass layer and pasted an image of a glass on the Stage.
We used a large (roughly 70 x 400) image to make it easier to create a
shape tween of liquid being added in the next step. After we finished, we
locked the glass layer.
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10.

11.

12.

13.

. Unlock the layer you plan to use, select it, and use the Paint tool to

add drawings to be tweened.

We unlocked the wine layer, and using the Paint tool, brushed a small
burgundy-colored (#8E3557) dab at the bottom of the glass. This makes
it look as though just a small bit of wine remains.

. Click on the frame where you want the tween to end and press the F6

key to add a keyframe. Expand the painted image to the size you want
at the end of the tween.

We selected Frame 30 on the wine layer to add a keyframe. Using the
Paint tool, we filled in the area so that the entire glass is burgundy col-
ored. You can expand the initial paint dab using one of the selection tools
or just paint using the Paint tool to fill it up. The largest glass in Figure 1-7
(later in the chapter) shows what the filled glass should look like.

Click on the first frame of the current layer and right+click the mouse
(or Ctrl+click on the Mac) to open the context menu. When the context
menu opens select Create Shape Tween. To check whether the tween
is working as intended, drag the playhead back and forth on the
Timeline.

We selected the wine layer. The arrow with a green background on the
wine layer told us that we had successfully created a shape tween. If
everything is working correctly, save all files and then click the Scene 1
icon to close the Symbol Editor and open the main Timeline.

In the main Timeline, add three layers and provide names for them.

We named the layers buttons, glasses, and table, placing them
below the actions layer, as shown in Figure 1-6. Then we locked all
layers except the table layer. In the upper-right corner, we added a
rectangle that serves as a “table” on which to place the wine glasses.
After it was completed, we locked the table layer.

Prepare to add your movie clips above the background layer by
unlocking the layer and locking the others. Drag your movie clips
from the Library panel to the Stage and use the tools to modify them.

We selected the glasses layer and dragged three instances of the Cup
movie clip from the Library panel to the table area, as shown in Figure
1-6. We resized the Cup instances using the Free Transform tool.

Select each movie clips object, and in the Properties panel, provide
each one with a unique instance name in the Instance window.

We selected each of the Cup instances and in the Instance name window
in the Properties panel, named them glass1, glass2, and glass3. This
step is crucial because ActionScript uses those names to reference each
instance. We locked the glass layer when we finished.



14.

15.

16.

17.
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Unlock and select the layer where you plan to place your buttons. Use
the Oval tool to draw an image on the Stage that you will transform
into a button. Then select the image and press F8 to open the Convert
to Symbol dialog box and select Button as the type. Finally, provide a
name for the symbol and click OK.

We used the buttons layer (no surprise there). Using the Oval tool, we
drew a simple circle for our button shape and named it £i11. When you
click one of these buttons, it fills the glass — we probably could have
named it Phil.

Drag button instances from the Library panel to the Stage and arrange
them as you want them to appear. Then select each button and pro-
vide each one with a unique instance name in the Properties panel.

We made a total of four buttons and arranged them vertically, as shown
in Figure 1-6. Then, in a fit of creativity, we named the buttons btnl,
btn2, btn3, and btn4, respectively, from top to bottom.

Add static text labels to the buttons. Then lock the layer when you’re
finished.

Figure 1-6 shows the labels we used for the buttons, ordering from top
to bottom, Full, Half, Third, and Down the Hatch.

Click the first frame of the actions layer, open the Actions panel and
add the ActionScript. Then save the file.

We used the following code:

//Buttons

btnl.addEventListener (MouseEvent.CLICK, full) ;
btn2.addEventListener (MouseEvent .CLICK,half) ;
btn3.addEventListener (MouseEvent.CLICK, third) ;
btn4 .addEventListener (MouseEvent .CLICK, empty)
//Button Functions

function full (e:MouseEvent) :void

{

7

glassl.gotoAndStop (30) ;
}

function half (e:MouseEvent) :void

{
glass2.gotoAndStop(15) ;

}

function third(e:MouseEvent) :void

{
glass3.gotoAndStop (10) ;

}

function empty (e:MouseEvent) :void

Book IV
Chapter 1
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{
glassl.gotoAndStop(1l) ;
glassl.rotation=90;
glassl.x=450,glassl.y=200;
glass2.gotoAndStop(1l) ;
glass3.gotoAndStop (1) ;

\}

| ® Flash File Edit View Insert Modify Text Ci ds Control Debug Window Help < 4 Tuell:29AM = Q |

1 acions F .
Al buttons

AR AL SR AL A e e e e e e o e
Al glasses

. &b COMPONENTS:
l table || &, component mspecton

.
A F M} mEmE 2400 0gs [T I 7]

LIBRARY

s i =
McTimeline.fla =] 2 @

ﬁﬁfg

(%] wineGlass.gif

Bes[cl PE0NpE SANE/ S7 00 n B

i

4
—~

Figure 1-6: Adding movie clip and button instances to the Stage.

18. Test the application by pressing Ctrl+Enter (or 3+Return on the Mac).

After the application has launched, click the different buttons. You see
the glasses filled at different levels after clicking the top three buttons,
as shown in Figure 1-7.
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Figure 1-7: ActionScript controls the tweens in the movie clips.

When you press the Down the Hatch button, all glasses are emptied, and one
falls on its side. They’re emptied by moving the playhead to the first frame,
and the glass tipped over had its rotation changed.

Book IV
Chapter 1
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Chapter 2: Working Off the
Timeline with Symbol and
Component Classes

In This Chapter

1~ Working off the Timeline

1 Writing programs in ActionScript files

+~ Inserting comments in code

1+~ Using clip code

1~ Creating a class

+~ Using a symbol button in a class

1~ Addressing classes and instances on the Stage
1~ Using user interface (U) component classes

1~ Constructing list events

Designers and developers have long been Input Text
accustomed to the idea of using clip art in Hi, All in One!
their work. Clip art includes ready-made draw-

ings and photographs that can be used copy- Output Text
right-free in everything from printed flyers to
images used in Flash applications.

Click to transfer
You don’t have to be an artist or a designer to oy text
use clip art, but you have to have a sense of design
in terms of where to place it. (Yes, you can create
ugly designs if you put clip art in the wrong surround-
ings!) Likewise, using code, you can cut and paste chunks
of ActionScript code like clip art, but rather than artwork, it’s
just code. That’s all we mean by clip code — it’s just a chunk of code that
you can cut and paste and that does something. To get started working
with ActionScript 3.0 off the Timeline, you may have to think of some of
the codes as clip code: You may not understand all of it at first, but if you
know where to put it, it can accomplish just what you want. Coding “off the
Timeline” means that you write ActionScript in separate (ActionScript) files
rather than in the Actions panel associated with a keyframe on the Timeline.
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Having code scattered throughout keyframes in a Flash application multiplies
exponentially the chance of experiencing a disaster every time you add a new
keyframe with code attached. Changing code makes an even bigger mess, so
we show you how to use the available tools in Flash CS4 and ActionScript 3.0
to start working without having to rely on code embedded in the Timeline.

Forming a tag team with ActionScript
and a Flash file

Before you begin creating applications with ActionScript 3.0, you must to con-
sider two basic concepts: class and object. An easy way to think of these two
concepts is in terms of a template for a class and an actual use of the template
for an object. For example, Flash CS4 lets you open the Advertising template
named Banner. That template is similar to a class — it’s the general outline.
Some templates are rich and complex, and others, like the Banner template, are
quite simple. When you use the banner template to create a banner for your
company, Acme Flash Developers, for example, that’s analogous to an object.

Rather than have you develop programs using the Actions panel, we show
you how to use another method that doesn’t use the Timeline. Flash files are
used in conjunction with ActionScript files. The Flash file provides the Stage
for any graphics and symbols you want to create and access ActionScript
by a reference to a class name. That class name is embedded in the
ActionScript file. Figure 2-1 illustrates this method of working with dual files.

With a Flash file open, you just type the class name in the Properties panel.
Then you use that name for the class you create in the ActionScript file.
Most classes begin with these lines:

package
{

class ClassName

{
function ClassName ()

{

The package statement may be followed by the name of a folder where you
have stored other classes. No matter what, you start your class definition
with package. Following a curly brace ({), type the class statement fol-
lowed by the name of the class and another curly brace ({). After the second
curly brace ({), add a constructor function, which typically has the same
name as the class. The constructor function contains the main statements
that can call other functions (methods) in the class and construct objects
from other classes or assign values to properties.
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Figure 2-1: A Flash file and an ActionScript file with class.

When you create a class in ActionScript 3.0, your class generally inherits from
another class that has all the necessary methods, events, and properties you
need in order to display objects on the Stage. More likely than not, you use
the Sprite or MovieClip class as a basis for your new class. We prefer using
the Sprite class because we don’t need the Timeline for most projects, and the
files are a bit smaller. To inherit a class, ActionScript 3.0 uses the extends
statement. Furthermore, to use the Sprite class in addition to most other
classes, the other classes need to be imported from the appropriate package.
For example, the Sprite class is imported using the following line:

import flash.display.Sprite;

All imports generally begin with either f1ash or £1. The £1ash packages
contain the bulk of ActionScript classes, and £1 packages contain compo-
nents such as buttons and lists. As you can see in Book VII, Chapter 2, com-
ponents are treated just like classes in that they have properties, methods,
and events that you can address with code.

Book IV
Chapter 2
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Comments and clip code

In a computer program, comments are lines of code that are used to remind
the developer what the code is used for or to suggest alternatives. You usu-
ally see comments embedded within lines of code. A single comment is pref-
aced by double slashes (//). In our example, the following line reminds the
developer that the color red is used:

//0xcc0000 is a medium dark red

Sometimes, comments are used to add a title or description at the beginning
of a code set. At other times, comments are quite long, and rather than place
double slashes at the beginning of every line, the developer uses /* to begin a
block of comments and */ to end the block. For example, the following block
reminds the developer that different options are available for text styling:

/* Instead of using the default serif
font, try a sans serif font, such as
Arial or Verdana. Also, consider
changing the background color to make
it stand out more.

*/

Comments are important for making code easier to understand for develop-
ers — and for the people they work with. Comments help explain what’s
going on in a program. In this book, you see some comments, but because
most of the code is described in the text, comments in the code are minimal.
Seeing the flow of the code is important, and sometimes comments can get
in the way of seeing that flow. So, because you’re finding out how to use
ActionScript 3.0, we decided not to put too many comments in the code.

The first piece of clip code is something you can cut and paste into most of
your classes. It’s a class template that you see repeatedly in this book. You
can save the template in an ActionScript file named ClassStarter and just
load it up and then use the Save As command to save it as the name of the
current class:

//Class Starter
package
{
import flash.display.Sprite
/*Declare private variables
here */
public class ClassName extends Sprite
{
public function ClassName ()
{
//Add statements here
}
I
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The world’s simplest class

In this section, we show you a simple class, and then we show you how to
build a class that displays text in the Output panel using the trace () state-
ment. Follow these steps:

1.

Open a new Flash (ActionScript 3.0) file, and in the Properties panel,
type a name for the class in the Class window and then save the file.

You see a warning message that the file wasn’t found, but don’t worry
about that. The next step creates the necessary file.

We named our class SimpleClass, as shown in Figure 2-2. We then
saved the file as SimpleClass. fla.

PROPERTIES
’iFl Document
SimpleClass.fla & ELIEEHER IS
<7 PUBLISH = &, COMPONENT INSPECTOR
Player: Flash Player 10
) ) ) % coLor
Script: ActionScript 3.0
Class: |SimpleClass & B swarcues
Profile: Default |E)ocument Class l-!—‘ Ctn
AlR Settings
~ PROPERTIES i} TRANSFORM
FPS: 24.00 ]
|-
i ALIGN
Size: 550 400 px [Edit. | |+
Y uBrasy

(A) ACTIONS - FRAME

Figure 2-2: Setting the Document class in a Flash file.

Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We named our file SimpleClass.as and saved it in the same folder as
SimpleClass.fla.

Open the ClassStarter clip code file and copy the contents to the
Clipboard.

You can download ClassStarter from this book’s companion Web site at
www . dummies.com/go/flashallinone.

Book IV
Chapter 2
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You can copy by choosing Edite>Select All and then Edit=>Copy or by
pressing Ctrl+A (Windows) or 8+A (Mac) to select all the code and then
Ctrl+C (Windows) or +C (Mac) to copy it.

4. Open the file you created in Step 1 (again, we named ours
SimpleClass.as) and paste the ClassStarter code into the file.

You can paste by choosing Edite>Paste or by pressing Ctrl+V (Windows)
or 8+V (Mac).

5. Edit the code so that it appears as the following and then save the file:

//Simple class
package
{
import flash.display.Sprite

public class SimpleClass extends Sprite
{
public function SimpleClass ()
{
trace ("Simple class--hello world");

}
}

As you can see, all you had to change was the name of the class from
ClassName to SimpleClass (or whatever name you chose) and add the
trace statement. (The changes are highlighted in bold.)

6. Test the application as you would test any Flash file by pressing
Ctrl+Enter (Windows) or $8+Return (Mac).

If all the code is entered correctly in the Output panel, you see the text
Simple class--hello world (refer to the bottom of Figure 2-2).

Making a MovieClip class in Flash

During all the time you’re creating movie clips, you're creating new classes.
Each movie clip can be treated as a class by simply opening the Symbol
Properties dialog box and selecting the Export for ActionScript check box, as
shown in Figure 2-3.

In this application, you don’t place any items on the Stage in the Flash (FLA)
file. Instead, you use the code in the ActionScript file to do it for you. To use
code to place the movie clip on the Stage, you use a display list, which lists
everything displayed on the Stage. You don’t see the list, but ActionScript
keeps it for you. Using the statement addChild (objName), you add
objects to the Stage (and the display list). Using the x and y properties of
the MovieClip class, you can put the movie clip object anywhere you want
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on the Stage. The most recently added objects overlap the earlier objects.
However, using addChildAt (objName, index), you can specify the
index level. Higher index values overlap lower index values. Likewise, using
the rotation property, you can angle it any way you want.

Symbol Properties

Name: |ActionBox ( 0K }
—— )
Type: | Movie Clip I‘i-] __ Cancel ]

( Edit Basic |

| Enable guides for 9-slice scaling

Linkage
Fii Export for ActionScript
4 kxpurt in frame 1
Identifier:
Class: |ActionBox | ﬁ m
Base class: flash.display.MovieClip E @
Sharing
"] Export for runtime sharing
Import for runtime sharing
URL:
Source
_ Browse... File:
Symbol Symbol name: Symbol 1

Always update before publishing

Figure 2-3: Exporting a movie clip class for ActionScript.

The next project shows you how easily you can create a class just by work-
ing on a movie clip on the Stage. (And you didn’t think you could make a
class!) Follow these steps:

1. Open a new Flash (ActionScript 3.0) file, add a class name for the
application in the Class window in the Properties panel and save it.

You see that pesky alert box telling you that the class doesn’t exist; just
ignore it.

We named our class MCaction and named the file MCaction. fla.
2. Choose Insert>New Symbol to open the Symbol Editor.

3. When the Create New Symbol box appears, type a name for the
symbol, select MovieClip for the type, and select the Export for
ActionScript check box. Click OK when you’re finished.

Book IV
Chapter 2
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We named our symbol ActionBox.

The Export in Frame 1 check box is automatically selected. (In case you
don’t see it, click the Advanced button to display the advanced options.)

4. Draw a 150 x 100 rectangle using the Rectangle tool at the 0,0 point in

the Symbol Editor.

The 0,0 point represents the little crosshair (+) that appears when you

open the Symbol Editor.

5. (Optional) You can add tweens, inverse kinematics (IK), additional

frames, or anything else that you would add to any other movie clip.

Figure 2-4 shows a movie clip that’s loaded, containing an IK and some

shape tweens that reverse the rectangle’s fill and stroke colors.

[(® Grab File Edit It 0Ol Window Help O ™ T 4 satl0:27 AM

Q|
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ala§ [{ mmml L 20 0o [ T ¥l | @ color

i C < | simpleci = " 7'
T TRrereT [ weacsontar = |
<9 & scene 1 [i] ActionBox = & 0%

eE[(o[]N PEU NP E GANO /A= 000
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Figure 2-4: Constructing a standard movie clip in the Symbol Editor.

6. After you finish the movie clip, click Scene 1 and save the FLA file
again.

Do not place a copy of the movie clip on the Stage. The Stage should
be blank, and the movie clip should be visible in the Library panel.
All the placement is done by ActionScript, and if you leave any movie
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clips on the Stage, they may overlap the ones created dynamically by
ActionScript.

7. Open a new ActionScript file and save it in the same folder as the file
you created back in Step 1.

We named ours MCaction.as and saved it in the same folder as the
MCaction. fla file.

8. Add the following script to the ActionScript file and then save the file:

package

{
import flash.display.MovieClip;

public class MCaction extends MovieClip

{
private var abl:ActionBox;
private var ab2:ActionBox;

public function MCaction ()
{
abl=new ActionBox() ;
addChild (abl) ;
abl.x=150, abl.y=150;
abl.rotation=33;

ab2=new ActionBox() ;
addChild (ab2) ;
ab2.x=200, ab2.y=165;
ab2.rotation=-30;

}

The public and private statements are access statements. If a vari-
able is defined using a private access statement, it can be used only
by elements in the same class. The public access statements are the
default option, but adding them helps to remind you that they’re public. Book IV
Chapter 2

9. Save the file and then test the application by pressing Ctrl+Enter
(Windows) or 38+Return (Mac).

You see the two movie clips on the Stage, one slightly overlapping the
other, as shown in Figure 2-5. They’re two instances (objects) of the
ActionBox () class. Because a movie clip is involved, the class inherits
(extends) from the MovieClip class rather than from the Sprite class.
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206 MCaction.swf

Figure 2-5: Movie clips sent to the Stage.

Buttons and text fields: A tale of two objects

After you realize that you can treat a movie clip symbol as a class, why

not treat a button symbol and a text field in the same way? You can make

a button symbol and export it for ActionScript, just as you can do with a
movie clip. The button symbol is based on the SimpleButton class. However,
a text field has a different story. A text field, as you might recall, isn’t one of
the symbol options. You create it by using the Text tool. Then you decide
whether the text is Input, Dynamic, or Static, depending on the task. (The dif-
ferent types of text fields are introduced in Book II, Chapter 3.) Nevertheless,
ActionScript has a TextField class that you can dynamically create.

Follow these steps to create a button class by using standard drawing tools
and to create different kinds of text fields using only code:
1. Open a new Flash (ActionScript 3.0) file and save it.
We saved ours as TextMove. fla.
2. Open the Properties panel, and in the Class window, type TextMove.
3. Create a few layers, name them, and save the file.

We created three layers with the names Labels, Oval, and Lines, from
top to bottom, respectively.

Add a dark background or use the one shown in Figure 2-6 so that the
light-colored text used by the dynamically created output text field is
visible.
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Figure 2-6: The label position on the Stage in the Properties panel.

4. Choose Insert~>New Symbol to open the Symbol Editor.

The Create New Symbol box appears.

5. Type a name for the symbol, select Button for the type, and select the
Export for ActionScript check box.

We named our symbol Btn.

The Export in Frame 1 check box is automatically selected. If you
don’t see the check box, click on the Advanced button to display the

advanced options.

6. Draw a circle that has a 29-point diameter (W=29, H=29) using the
Oval tool at the 0,0 point in the Symbol Editor.

The 0,0 point is represented by the little crosshair (+), in the middle of
the page, that appears when you open the Symbol Editor.

7. (Optional) Add varying state conditions in the special Button Timeline
by adding keyframes and different shapes or colors to the button
object; when you’re finished, click on the Scene 1 icon to close the

Symbol Editor.

Book IV
Chapter 2
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3

10.

11.

. Back on the main Timeline, add the following text to the Labels

layer by using the Text tool set to Static Text. (See Book II, Chapter 3
for a refresher on how to add static text with the Text tool.) Use the
Properties panel to create the precise x and y values.

e Input Text: x=223, y=97
e Output Text: x=223, y=161
e Click to transfer text: x=260, y=219

Figure 2-6 shows the first label’s information in the Properties window.

. Save the file.

If you're a designer, add the text where you think it looks best and make
a note of the x and y positions by selecting the objects and checking the
Properties panel. Likewise, you can add Input and Dynamic text fields
and align them with the labels. Make a note of the Input and Dynamic
text fields and remove them from the Stage. Then when you’re entering
the code that includes the x and y positions of the Input and Dynamic
text fields, everything looks the way you intended.

Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We saved our file as TextMove. as in the same folder as the TextMove.
fla file.

Add the following script to the ActionScript file:

package

{
import flash.display.Sprite;
import flash.events.MouseEvent;
import flash.text.TextField;
import flash.text.TextFieldType;

public class TextMove extends Sprite
{
private var btn:Btn;
private var inputTxt:TextField;
private var outputTxt:TextField;

public function TextMove ()

{
//Button
btn=new Btn() ;
addChild (btn) ;
btn.x=216,btn.y=220;
btn.addEventListener (MouseEvent.CLICK, moveText) ;
//Input Text Field
inputTxt=new TextField();
inputTxt.width=86, inputTxt.height=18;
inputTxt.x=223, inputTxt.y=66;
inputTxt.background=true;
inputTxt.border=true;
inputTxt.type=TextFieldType.INPUT;
addChild (inputTxt) ;
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//Dynamic Text Field
outputTxt=new TextField ();
outputTxt.textColor=0xDDDCC5;
outputTxt.type=TextFieldType.DYNAMIC;
outputTxt.x=223, outputTxt.y=128;
addChild (outputTxt) ;

}

private function moveText (e:MouseEvent) :void

{
outputTxt.text="Hi, "+inputTxt.text+"!";

}

}

12. Save the file and test it by pressing Ctrl+Enter (Windows) or 3+Return
Mac).

Figure 2-7 shows that A11 in One has been entered in the Input text
field and that Hi, A11 in One! now appears in the Output text field.

206 TextMove.swi

Input Text

Hi, All in One!

Output Text

transfer

Figure 2-7: Sending text and a greeting to a dynamic text box.

Code and Design Made Easy

In case the idea of creating all your class-based objects in code is just too
much for you, you can mix code with objects you place on the Stage. You
may already know this if you read Chapter 1, but in that chapter, we use the
Actions panel and not classes. In this section, we show you what you need to
do to write classes that can reference an object on the Stage.

Book IV
Chapter 2
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3

Going back to instance names

The good news about using objects created on the Stage is that you simply
give the object an instance name, as we mention in Chapter 1. The display
list holds the order that you put objects on the Stage and not the order
that you instantiate them in code. You don’t have to declare or instantiate
objects in code that you place on the Stage, but you do have to give each
one an instance name. Furthermore, because you're using symbols, you
need not select the Export for ActionScript check box.

This process sounds easy if you're used to working on the Stage. The only
drawback is that you cannot see the instance names of the objects unless
they’re selected and the Properties panel is open. So, when you'’re writing
your code, you need to remember the instances names.

If you choose to give objects instance names on the Stage, you might want

to add the instance names in sections of your program that are commented
out — they’re nonrunning sections of code in comment lines or tags.
(Nonrunning code refers to comments in the code that are not executed when
the program runs.)That way, you can have the instance (object) names right
in front of you while you’re entering ActionScript.

Easy application and easy objects

To see how the mixed-code-and-symbol approach works, we devised a
simple application that sends different text to two dynamic text boxes. Using
two buttons that you create on the Stage, along with the two text fields, also
created on the Stage, you use the instance names to send each text box a
message. The following steps show you how:

1. Open a new Flash (ActionScript 3.0) file and open the Properties panel
from the dock or from the Windows menu. Type a class name in the
Class window and save the file.

We named our class OnStage and saved the file as OnStage. fla.

2. Draw a circle, select it, choose Modify=>Convert to Symbol (press F8)
to open the Convert to Symbol dialog box, select Button as the type,
type a name for the symbol, and click OK.

We typed Btn for the symbol name.
3. Make a copy of the button symbol and place it on the Stage.
You now have two buttons on the Stage.

4. Select the first button and open the Properties panel from the dock or
by choosing Windows—>Properties from the menu bar. Give the button
an instance name, and then do the same for the second button.

We named our buttons btnl and btn2.
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5. Select the Text tool and click on the Stage.

6. In the Properties panel, select the font you want and set the Text type

to Dynamic in the pop-up menu at the top of the Properties panel.

Give the text field an instance name, copy the text field on the Stage,
and give it a different instance name.

We named our instances txt1 and txt2, respectively.

Use a different size, color, and font type for the two different text fields so
that you can see the difference in the text when you launch the program.

Save the file.

Figure 2-8 shows an example of two text fields and buttons on the Stage.
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Figure 2-8: Two button instances and two text field instances on the Stage.

9. Open a new ActionScript file, name it, and save it in the same folder
in which you saved the file you created in Step 1.

We named our file OnStage. as and saved it in the same folder as

OnStage. fla.

Book IV
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Add the following script to the ActionScript file:

package
{
import flash.events.MouseEvent;
import flash.display.Sprite;
{
public class OnStage extends Sprite
{
public function OnStage ()
{
btnl.addEventListener (MouseEvent.CLICK, showTxtl);
btn2.addEventListener (MouseEvent.CLICK, showTxt2);
}
private function showTxtl (e:MouseEvent)
{
txtl.text="This is txtl";
}
private function showTxt2 (e:MouseEvent)
{
txt2.text="This is txt2";
}

10. Save the file and test it by pressing Ctrl+Enter (Windows) or 38+
Return (Mac).

You should see the text moving directly into the designated text field
when the buttons are clicked, as shown in Figure 2-9.

99O OnStage. swf

This is tut2 |

Figure 2-9: ActionScript content in two text fields.
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The Simple Power of User Interface (U])
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For the most part, a component is nothing more (or less) than a fancy movie
clip. You know that you can work with movie clips, so it follows that you
should be able to work with components. Elementary, my dear Watson!

After you exhaust the logical deductions we tackle in this book, consider
the advantages you have in using components. In Book VI, you see plenty of
examples of using video components, so in this section, we focus only on Ul
components.

For the most part, components have more properties and methods than
noncomponent symbols, such as the movie clips and buttons, which means
that it’s easier to add content to a Ul component. For example, if you create
a button, you cannot dynamically label it (without a lot of extra work), nor
can you easily change its other properties. With the Component button, you
can easily label it or change it.

Choosing from a list

A handy user interface in most applications is a list. Users can see the selec-
tions in the List component and choose what they want by simply clicking
the appropriate choice. To illustrate how a list might be used and indicate
which ActionScript to use with it, this next Flash application uses both a list
and some TextArea components. After a user selects a name from the List
Ul, a quote from that name appears in the TextArea.

List events

In the next Flash application, you let the user click a name in the List com-
ponent, and a quote from that person then appears in the TextArea compo-
nent. So you have to listen for a click on a list itermn — one of the selections in
the list. The particular event handler looks like this:

list.addEventListener (ListEvent.ITEM_CLICK, handler) ;

The preceding line shows essentially the same kind of listener you see on
buttons. However, rather than a MouseEvent, it’s a ListEvent. The event is
an ITEM_CLICK rather than a CLICK. Otherwise, though, it uses exactly the
same logic.

Book IV
Chapter 2
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List data

To be able to select from a List component, you need to put something in
the List. Using the Component inspector, you add both a label and some
data. The label becomes what you see, and the data is a value (numeric

or string) associated with the label. All you need is some kind of abbrevi-
ated code — initials, for example — to determine which quote to display.
For example, for Dorothy Parker, you can use dp. However, for Homer, you
can use hom (because, like Madonna and Cher, Homer has only one name).
Figure 2-10 shows the names in the label and the data. (Whatever value you
place in the label row becomes the name that appears in the selected row.)

[FESMaRBNTS] covronet werecion | =
i:l List, <list> N
[-Parameters- Bindings = Schema |

Name Value

allowMultipleSel false

dataProvider [label Darothy Parker datardp]{label Groucho Marx data gmp{label HJ Q|
enabled true

horizontallineSc 4

horizontalPageSt 0

horizontalScrollF  auto

verticalLineScroll 4

wverticalPageScrol 0

werticalScrollPoli  auto

visible true Dialog
FI=IEIE
Name Value
¥ Dorothy Parker
label Dorothy Parker
data dp
¥ Groucho Marx
label Croucho Marx
data am
¥ Homer
label Homer
data hom
¥ Shakespeare
\ label Shakespeare 2
data w5 3
T L
e — 4 r
(" cancel ) ( oK )

Figure 2-10: Adding content to the List component.

To get the data out of the list box, you must capture the event property.
The ListEvent class has item. label and item.data properties. Using the
item.data properties, you use a switch statement to determine which
item has been clicked. (The switch statement is explained in detail in
Chapter 4 of this minibook.) Here, switch is a clip code that you can cut,
paste, and edit, and it determines which of several choices have been made:
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private var choice:String;
private var choiceNum:Number;

choice="choiceB";
switch (choice)

{

case "choiceA"
//Do A;
break;

case "choiceB"
//Do B;
break;

case "choiceC"
//Do C;
break;

}

The switch clip code can be expanded (to the limit of the computer and the
language) to add as many choices as you want. The choice variable can be
a string or a number. The numeric variable choiceNum in the clip code is
used where the data is numeric.

Don’t quote me!

The application in this section shows how to use components on the Stage
with class references through an ActionScript 3.0 user class. Creating the
application in the following steps requires only two components on the Stage:

1. Open a new Flash (ActionScript 3.0) file and save it.
We saved ours as AutoQuote. fla.

2. Open the Properties panel from the dock or by choosing
Windows=>Properties from the menu bar. In the Property panel’s
Class window, type AutoQuote and save the file.

Ignore the error message that informs you that no such class exists.

3. Open the Components panel from the dock or by choosing
Windows=>Components from the menu bar. Drag some components
from the Components panel to the Stage or double-click the compo-
nents for them to jump to the Stage. Position the components on the
Stage by dragging them. Select the components you want to change
and make the changes in the Properties panel.

We dragged one List and one TextArea component to the Stage, placing
the List component directly above the TextArea component. (Figure 2-11
shows where we placed them.) We changed the size of the List compo-
nent to 150 x 100 and the TextArea to 300 x 150 by using the Properties
panel. The two components were then center-aligned to the Stage using
the Align panel.

Book IV
Chapter 2
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CXX) AutoQuote.swf

Derethy Parker

Grouche Marx

Shakespearo
Bery | Markham

Take care of luxuries and the necessities will take care of
themselves

Figure 2-11: Displaying a quote from the selected item in the List component.

4. Select each component, and in the Properties panel enter the instance
name for the component.

We named the List component 1ist and the TextArea component
output.

5. Open the Component inspector and click on the dataProvider magni-
fying glass icon.

This step opens a box named Dialog, where you can enter the informa-
tion for the list box.

6. Click on the plus sign icon (+) and enter the label and data information.
Here’s our example:
¢ Label: Dorothy Parker: Data: dp
e Label: Groucho Marx: Data: gm
e Label: Homer: Data: hom
e Label: Shakespeare: Data: ws
e Label: Beryl Markham: Data: bm

When you finish, you should see the label names you entered in your
List component on the Stage. Save the file.

7. Open a new ActionScript file and save it.

We saved ours as AutoQuote.as.
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Add the following code in the file and save the file again:

package

{

import flash.display.Sprite;
import fl.events.ListEvent;

public class AutoQuote extends Sprite

{

private var choice:String;
private var dorothy:String;
private var groucho:String;
private var homer:String;
private var shake:String;
private var beryl:String;

public function AutoQuote()

{

}

//Quotes

dorothy="Take care of luxuries and ";
dorothy+="the necessities will take ";
dorothy+="care of themselves.";

//

groucho="Those are my principles, ";
groucho+="and if you don't like them";
groucho+="... well, I have others.";
//

homer="A generation of men is like ";
homer+="a generation of leaves; ";

homer+="the wind scatters some leaves ";
homer+="upon the ground, while others ";
homer+="the burgeoning wood brings forth";
homer+="--and the season of spring comes on.";

homer+="So of men one generation springs";
homer+="forth and another ceases.";

//

shake="For I have neither wit, ";
shake+="nor words, nor worth,";
shake+="\nAction, nor utterance, ";
shake+="nor the power of speech,";
shake+="\nTo stir men's blood: ";
shake+="1 only speak right on;";
shake+="\nI tell you that which ";
shake+="you yourselves do know;";

//

beryl="You can live a lifetime ";
beryl+="and, at the end of it,";
beryl+=" know more about other people ";
beryl+="than you know about yourself";

303

list.addEventListener (ListEvent.ITEM_CLICK, sendSelect);

private function sendSelect (e:ListEvent)

{

choice=e.item.data;
switch (choice)
{
case "dp"
output.text=dorothy;
break;

Book IV
Chapter 2
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S

case "gm" :
output.text=groucho;
break;

case "hom" :
output.text=homer;
break;

case "ws" :
output.text=shake;
break;

case "bm" :
output.text=beryl;
break;

It’s easier to read the code in a long string if you use the += compound oper-
ator. It adds each new part of the string to the whole while letting you see
what you’re writing.

Wherever you want a line break in a string of text, use the \n character.

When you test the application, you can click any of the names in the list and
display the associated quote in the TextArea component. If your text is a
long quote that’s overruns the space provided, a scroll bar appears auto-
matically so that you can scroll and read the entire text. Figure 2-11 shows
an example of what you see.



Chapter 3: Formal Features
and Structures

In This Chapter

1 Checking out basic ActionScript 3.0 structure
v~ Typing data

1 Adding instance names for stage objects

+~ Using components in the Library panel

+~ Ogling variables, constants, and objects

+~ Importing packages

1~ Setting access

1~ Working with operators

+» Commenting and uncommenting code

+~ Understanding logical operations

u p to this point in this book we really

haven’t discussed the general features of
ActionScript 3.0. Usually, discussions of the new
ActionScript begin with explanations of all of the
different parts and structures. Thus far we've

decided to choose the road less traveled and
discussed several key features and structures

and asked you to use clip code with the promise

that everything will be explained in good time. Well,
now is that good time, and so in this chapter we’ll
explore the groundwork for the code we've been using
in earlier chapters. By understanding the structures and
features, you will become less dependent on clip code and can
start developing your own code to create whatever you want.
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One of the most important basic structures in ActionScript is the variable,
which is simply a temporary storage place where you can put data. To make
life interesting, the data within a variable can change. For example, suppose
you have a variable that stores the current temperature — tempNow. As the
day passes, the temperature might be hot and then later cool off, and the
temperature changes. So, the first time we look, tempNow might be 95, and
at another time it might be 68. In this case, the variable’s value has changed
(from 95 to 68) but we're still using the same variable.

Often, we will use different properties of a class to store information that
changes, and so you can think of class properties as variables that belong to
the class.

You are soooo not my type!

In early versions of ActionScript, the variables were sometimes considered
smart, which meant that you could put any kind of data you wanted into a
variable. For example, a variable smartyPants could have number or string
values (as defined in the next section) and so the following sequence was
perfectly acceptable:

smartyPants = 55;

trace (smartyPants) ;
smartyPants = "fifty-five";
trace (smartyPants) ;

You cannot do this in ActionScript 3.0. To make the code run better and
faster, every variable now has a type. When you declare a variable, you enter
a type to indicate what kind of data it can hold. Depending on what you want
to do and which type (or types) you use. Think of String types as text and
Number types as plain old numbers. For example, if you want to keep track
of purchases and add them up, you would want a Number type; however, if
you want to store the names of your friends, you would use a String type.

Figure 3-1 shows the basic structure of a command that declares a variable
and assigns it a value.

You do not need to assign a value to a variable when you declare it. All you
need to declare a variable is indicate that it is a variable with var, give it a
name (such as myVar) and indicate the variable type by placing a colon (:)
followed by the data type (type). The following examples show some differ-
ent types of variables you may declare and assign values:
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Name of variable Must be consi/stentwith type
var myVar:Type = value;

Indicates a variable Data type

Figure 3-1: Declaring a variable and assigning a value.

var bestFriend:String;
var crowdSize:int;

var averageWeight :Number;
var favColor:uint;

All of the above variables have fairly general types:

v A string is any kind of expression enclosed in quotation marks
("string"). Usually, a string is used where the variable stores a
description or label. For example, the address 123 Elm Streetisa
string even though it contains numbers.

The numbers in an address or a phone number are really identifiers and
cannot perform like numbers. If you add two addresses, you’ll find that
you do not get the sum of the two!

When working with strings, be careful if you copy and paste a program
from a word processor or PDF file. Sometimes, smart quotes are used.
Smart quotes are either opening (*) or closing () quotes and are not
recognized by ActionScript. You need the straight quotes (" ") that are
identical for opening and closing a string.

»» Numbers, even simple ones, are a little trickier. Three different numeric
types are used: int (integer), uint (unsigned integer), and Number
(real number.) An integer is any whole number, be it positive or nega-
tive. If your integers are all positive, use unsigned integers. Finally, real
numbers are floating point numbers that can have fractions. They're
called real because they can have fractions, and floating point because
the decimal point can change places (float). (Unreal numbers are what
you put on your expense account!)

We will be using type differently than usual. Expressions such as typing a
variable or an object has been typed as a Button aren’t talking about someone
pounding away on a keyboard; rather, typed refers to what type a variable or
object has been declared.
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Typing on the Stage
So far in this minibook, you’ve created instances () of Buttons and
MovieClips on the Stage using the tools available in Flash CS4 for drawing.

When you use Flash tools to create objects on the stage and provide them
instance names in the Properties panel, you are, in effect, declaring and
typing them. Therefore, you don’t have to do it again, nor do you need to
import Button or MovieClip objects when created on the stage — it’s done
automatically. Likewise, when using the different Ul components, once they
have been declared on the stage using the Properties panel, you need not
type them or import their base class. That’s also done automatically when
you put an instance name in the Properties panel.

Using components in the Library

Say you want to dynamically create user interface (UI) buttons on the stage
with different buttons being available in different contexts: In one context,
you want five buttons, and in another you only want three. If you create
five buttons on the stage, you can reduce the number from five to three by
making two of them invisible. However, doing so will force you to rename
labels and perform other chores that may be more trouble than using
ActionScript.

To make objects more flexible when you create them on the stage, place
them in the Library panel. For example, if you place a Button component in
the Library but do not have it on the stage, you can access it by code. You
have to import the Button class and place a Ul button in the Library panel.
Here’s an outline of the procedure:

Place a Ul in the library.

Import the Ul object in the code.

Declare an instance.

Instantiate an instance.

g1l > W=

Add the instance to the display.

As an example, the following code shows Steps 2 through 5. (We assume that
the Ul component has already been placed in the Library, as mentioned in
Step 1.) Note that the lines in boldface correspond with Steps 2 through 5 in
the preceding list, respectively:
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package

{
import flash.display.Sprite;
import fl.controls.Button; //Import

public class TestBench extends Sprite

{
private var btnUI:Button; //Declare

public function TestBench ()

{
btnUI=new Button(); //Instantiate

btnUI.label="UI for You!";
btnUI.x=150, btnUI.y=200;
addChild (btnUI); //Add to display list

}

If you make any changes to the Ul component, such as color, shape, or size,
those changes will be seen when the component is placed on the stage. You
can also use ActionScript to make changes.

§‘\‘;,N\Bl.flf Even though a component is in the library, you need to provide a way to

>y reference each instance of the component. You cannot use the Properties
panel, because the component needs to be on the Stage. All you have to do
is to use a name when you declare it so that the instance name will be cre-
ated just as any other variable would be.

Variables, constants, and objects
When creating a variable or object, use the var statement.

When you create a constant (a value that does not change), you use the
const statement. Because both variables and objects have been discussed,

let’s look at constants.
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Like the name implies, constants do not vary. Certain things are immutable
such as the value of pi, the freezing point of water (32 °F/0 °C) and water’s
boiling point (212 °F/100 °C). Once you assign a value to a constant, you
cannot change it. Also, by convention, constants are written in ALL CAPS to
help you remember they’re constants and not variables.

In the following code, you'll see how constants differ from variables and
object properties. Once you declare and assign a value to a constant, any re-
assignment of a value results in an error.
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const FREEZE:uint= 32;
trace (FREEZE) ;

FREEZE= 55; // causes error
trace (FREEZE) ;

You'll get the following error message:
1049: Illegal assignment to a variable specified as constant.

That’s exactly what you want to happen with a constant. Any change in the
constant’s value means it is varying (like a variable) and it’s not supposed to
do that.

Types that need importing

One of the ongoing learning experiences in ActionScript 3.0 is knowing when
to load a class you want to use. Rather than learning all of the classes that
require you to load a package that includes the class, it’s easier to just learn
what classes you do not need to import. These are the top-level classes that
are packaged with Flash CS4 ActionScript 3.0.

If you don’t see the object class you wish to import in Table 3-1, plan on
using the import statement.

Table 3-1 Top-Level Classes
ArgumentError arguments Array
Boolean Class Date
DefinitionError Error EvalError
Function int Math
Namespace Number Object
QName RangeError ReferenceError
RegExp SecurityError String
SyntaxError TypeError uint
URIError Vector VerifyError
XML XMLList

The import statement itself is similar whether you're importing classes
or components. (Okay, okay, components are classes, but it helps to
differentiate them for now.) Figure 3-2 shows the format for importing
classes and components.
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Non-components

1mport flash.package.Class

N/ N

Import statement Name of package Class/component name

DA

import fl.package.Component

Components

Figure 3-2: Importing classes and components.

As arule, components are in the £1.* packages and the non-components
are in the flash. * packages. However, to make your life more interesting,
Adobe also includes in the £1 . * package, a class for Multilanguage text
(£1.1lang), ActionScript 3.0 Motion classes (£1.motion), and one for
Tween and Transition classes (f1. transitions).

Use the asterisk (*) as a wildcard character to allow you to quickly download
multiple files with names that begin identically and end differently. So a refer-
ence to flash.media. * means that everything in the f1ash.media package
that begins with f1ash.media. * will be either imported or referenced.

Don’t use the asterisk (*) wildcard for importing a package unless you know
you will be using everything (or almost everything) in the package. If you only
need the Video class in the f1ash.media package, for example, using the
wildcard would load up nine unnecessary classes, adding unnecessary size
(bulk!) to the file and giving the loading and processing more work to do.

To know which class belongs to which package, say that you have flash.
display, flash.text, flash.net, and other flash.this-and-that
packages. If you want to create a MovieClip object, you should first know
the correct package to import, but none of the f1ash. * package names
seem to have anything to do with the MovieClip class based on the package
name.
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Rather than trying to memorize all the classes in all the packages in the
ActionScript 3.0 Language and Components Reference (which comes with
Flash CS4), start with just a few and then learn the rest later as you use
them. The following packages have most of what you need:

v~ flash.display: In this package you will find most of the classes that are
commonly used in Flash. Included are the MovieClip, SimpleButton,
Sprite, Loader and many of the graphic classes.

1~ flash.text: As the name implies, this package holds classes for text, fonts
and types of text fields.

~ flash.media: When working with sound and video, this package has the
classes you need.

v~ flash.net: While you will find expected classes like NetConnection and
NetStream in this package, you will also find the classes you need to link
to other Web pages.

1~ flash.events: You may overlook this package, but this is where you
will find the events you need for a wide assortment of classes that use
events to trigger methods. The MouseEvent class is one widely used
example.

1~ fl.controls: The Ul components can be found in this package.

Forget memorizing all of this. Don’t
waste your time! As soon as you type
the import flash statement and
add a period, a pop-up menu appears
and shows you the available options.
(This is code hinting! Hint, hint.)
Likewise, when you select an avail-
able package from the list and add a
period, the next level appears with
the classes contained therein. So,
instead of trying to memorize every-
thing, just start using the packages
and classes that you know, and with use you’ll learn the others. Figure 3-3
shows some of the classes found in the f1ash.display package.

import flash.display.

@ Jointstyle
@) LineScaleMode

@ NativeMenultem

Figure 3-3: Using pop-up menus to find which
class you need.

Access denied! Setting access

Anouther statement type that you will see is an access modifier. Access modi-
fiers determine what other objects can access variables, constants, and func-
tions (methods). Unless otherwise stated, constants, variables and methods
are available to other classes — public access, meaning that any other class
can use the element. The problem with such open access is that the same vari-
able may be given conflicting values. Likewise, different parameters may be
assigned to a method when that’s not really what you want.
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If you ever find yourself at a gathering where programmers are serious about
their craft (also know as a flock of geeks . . . or would that be a gaggle?), you
will hear the term encapsulation, one of the foundations of object oriented
programming (OOP). You definitely should understand what it means. When
programming with objects, you can think in terms of larger parts that can
have several variables (properties) and functions (methods).

Think of your automobile as an object with lots of parts (properties and meth-
ods) that make up the car. You have control over access to your car because
it is encapsulated — self-contained. If your car were not private — that is, if it
had no locks and key — anyone could use it. In programming, the same is true.
An encapsulated object restricts access to its properties and methods just like
you restrict access to your car. In the same way that you can own your car,
and the car “owns” its various parts, encapsulated elements in your class help
to maintain the object character of your program. (Think of an object character
as an object in its own right instead of a collection of parts.)

The following list briefly describes the main access modifiers:

1~ public: Any other class can access and use the object. For the most part,
you want your classes and construction functions to be public. Also, if
you have methods you want to be able to be used when implemented by
another class, the methods should be given public access.

1~ private: Only members of the same class can access this object.
(Remember your car!)

1~ protected: Only members of the same class or inherited from the same
class can use the method or property.

To demonstrate how to use these access modifiers, check out the following
two classes. The first class, TestBench, has three different methods, one
each for private, protected, and public access modifiers. Both the private
and protected methods can be called from the TestBench class. All pri-
vate, protected, and public methods can be called from the class of origin.
However, only the public methods can be called from an outside class. So, in
the TestBench class, we called the private and protected method. The fol-
lowing listing shows this. (You can create this listing in an ActionScript file
saved as something like TestBench.as.)

package
{
import flash.display.Sprite;

public class TestBench extends Sprite
{

private var privMsg:String;
private var protecMsg:String;

public function TestBench ()
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privMsg="This is exclusive...";
priv(privMsg) ;

protecMsg="This 's extended to children...";
protec (protecMsg) ;
}
private function priv(msg:String) :void
{
trace (msg) ;
}
public function pub(msg:String) :void
{
trace (msqg) ;
}
protected function protec(msg:String) :void
{
trace (msqg) ;

}
}

To call the public method and illustrate how it can be used, we created

a second class, PubPriv. All this class does is create (programmers say
instantiate) an instance of the TestBench class and invoke the pub ()
method. The following listing shows the code for this simple chore. (Create
this listing in an ActionScript file saved as PubPriv.as.)

package
{
import flash.display.Sprite;

public class PubPriv extends Sprite
{
private var tb:TestBench;
private var outMsg:String;

public function PubPriv ()
{
tb=new TestBench() ;
outMsg="Greetings from another class!"
tb.pub (outMsg) ;
//tb.priv("private") ;
//tb.protec ("protected") ;
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To test these two classes, you can create a PubPriv. fla file using the
PubPriv as a class reference in the Properties panel. Save it in the same
folder as the TestBench. as file.

You do not need a TestBench. f1a file because you can use any FLA file to
contain the name of the class you will be using.

Be sure to place all the files in the same folder and then load PubPriv. fla
and test it. You see the following lines in the Output panel:

This is exclusive...
This is extended to children...
Greetings from another class!

The first two lines are generated by the TestBench class because it’s the
only one with access to the private and protected methods. The third line is
generated by the PubPriv class. It uses the pub () method, adding a string
literal (actual text, like “hello!”) in the parameters.

Note that two lines in the PubPriv class have been commented out.

//tb.priv("private") ;
//tb.protec ("protected") ;

After testing the application, uncomment the lines (that is, remove the
slashes / /), save it, and try it again. You’ll get error messages because you
attempted to launch functions with limited access (private and protected.)
Because the PubPriv class is a different one than the one where the meth-
ods are created (TestBench) and it is not derived from (that is, it does not
extend) TestBench, it has access to neither private nor protected methods
in that class.

Operators: Assign, Compare, and Do the Math

ActionScript 3.0 has a wide range of operators, some of which we’ve used.
For example, we’ve used the equal sign (=) operator to assign values to vari-
ables and we’ve used the plus sign (+) to perform addition as well as concat-
enate (combine) strings. Some operators have been compound, such as the
plus equal (+=) used to add the existing string with a newly added one.

Operator? Operator?

Now it’s time for a general overview of three types of operators we’ll be
using. Table 3-2 shows the main operators used in math, comparison,
logical, and assignment operations.
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Table 3-2 Operators

Symbol Name Action

+ Addition Adds numbers

-- Decrement Subtracts 1 from current value

/ Division Divides one number by another

++ Increment Adds 1to current value

% Modulo Returns remainder in division

* Multiplication Multiplies numbers

- Subtraction Subtracts numbers

+= Add/assign Adds current value to new value

/= Divide/assign Divides current value by second value

%= Modulo/assign Shows modulo of current value divided
by second value

*= Multiply/assign Shows product of current value multi-
plied by second

-= Subtract/assign Shows result of current value minus
second value

Assignment

= Assignment Assigns value to object property,
variable, or array element

Comment

Operators

1 Comment Sets line to a comment

[** Block comment Provides block for comments

Comparison

Operators

== Equality Tests for expression equality

> Greater than Tests for left expression being greater
than right expression

>= Greater than or Tests for left expression being greater

equal to than or equal to right expression
1= Inequality Tests for inequality to right expression
<= Less than or equal Tests for left expression being less than

to

or equal to right expression

Strict equality

Tests for left expression being equal to
right expression and the same data type

Strict inequality

Tests for left expression being unequal to
right expression and a different data type
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Symbol Name Action
Logical
&& Logical AND Returns true if values for left and right

expressions are both true. Otherwise
returns false.

&&= Logical AND Assigns true if values for left and right
assignment expressions are both true. Otherwise
assigns false.

! Logical NOT Tests for expression false. If itis NOT
true, it returns a true.

I Logical OR Returns true if either value for left or
right expressions are true. Otherwise
returns false.

l|= Logical OR assign- Assigns true if either value for left or

ment right expressions are true. Otherwise

assigns false.

As you can see, we've already used a number of the operators. In Chapter
4 of this minibook, we examine the basic structures of ActionScript 3.0 and
more of its operators.

A Sheffer stroke or vertical bar symbol (|) is often called a pipe, and the two
vertical bars comprise a double pipe. We'll use the term pipe because it
sounds cooler than a Sheffer stroke or vertical bar symbol.

Elementary logic, my dear Watson

In this section, we give you examples of comparison and logical operators.
Comparison operators compare two values and decide if they’re different or
the same. Logical operators examine expressions (code with operators) to
see if they are true or false. The results of the comparison are (evaluate to)
either true or false.

This next little program does a number of logical comparisons (compares
expressions to see if they’re true or false) so that you can get an idea of how
they work. Because the outcomes can only be true or false, we use a Boolean
type. In this application, one Boolean variable name logicalResult will always
be true or false. All you have to do is to compare two expressions and evalu-
ate their outcomes. This sample application is designed for you to use as

a logical test bench. Go ahead and try out different combinations of logical
expressions and see if you can get to the point where you are no longer sur-
prised by the outcome. You’ll be using them a good deal in the next chapter.
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The following steps show how to create the application:

1. Open a new Flash (ActionScript 3.0) file, name it, and save it (we
saved it as Logic.fla).

2. Open the Properties panel by selecting Window=>Properties from the
menu bar (Ctrl+F3 in Windows or 8+F3 on the Mac) and enter the
class name (we used Logic).

o Everyone knows that when you start thinking logically, the gears begin

to spin. Well, you can add spinning gears to the application for an added
flair. Follow these steps to do so:

a. Add some frames to the existing layer, name it Label, and add a
static text label.

We added 40 frames to have some room to work with and named it
Logical Operations.

b. Add one or more layers depending on how many gears you want.
We created three and named them Gear1, Gear2, and Gear3.
c. In each layer, add a movie clip shaped like a gear.

See Figure 3-4 to give you an idea.

("N H"] Logic.swf

LOGICAL
OPERATIONS

Figure 3-4: Add a movie clip shaped like a gear.

d. Select the first frame of one of the layers, right-click it (or
Ctrl+click on the Mac), and choose Create Motion Tween.

e. Then click into your last frame (ours is Frame 40) and choose
Insert~> Timeline~>Keyframe (or press F6) to add a keyframe.
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f. With the keyframe in Frame 40 selected, open the Motion Editor

by choosing
selection by

Windowr>Motion Editor, and open the Basic motion
clicking the little arrow.

g. Set the Rotation Z value to between = () to 360.

A negative value rotates to the left and a positive value rotates to the

right. Higher

values make the rotation faster.

h. Repeat the process for the layers with gears in them (in this case,
the Gear2 and Gear3 layers) and save the file.

3. Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We named ours Logic.as and saved it in the same folder as we saved

the Logic.fla

file back in Step 1.

4. Add the following script and save it again.

package

{
import
import
import

public
{

flash.display.Sprite;
flash.text.TextField;
flash.text.TextFormat;

class Logic extends Sprite

private var outcome:TextField;
private var textFormat:TextFormat;
private var expl:String;

private var exp2:String;

private var logicalResult:Boolean;

public function Logic/()

{

expl="up";

}

exp2="down";
//Logical expressions

logicalResult= ! (expl==exp2) ;
//logicalResult=(expl=="up" && exp2=="up");
//logicalResult=(expl=="up" || exp2=="up");
//logicalResult=(expl=="up" && exp2=="down") ;
//logicalResult= ! (expl!=exp2) ;

//logicalResult=(expl===exp2) ;

doFormat ("Verdana") ;
doTextField() ;

private function doFormat (txFont:String)

{

textFormat=new TextFormat () ;
textFormat.bold=true;
textFormat. font=txFont;
textFormat.size=24;
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private function doTextField()

{
outcome=new TextField ();
outcome.x=145,outcome.y=230;
outcome.defaultTextFormat=textFormat;
outcome. text=logicalResult.toString() ;
addChild (outcome) ;

}

5. Remove comment operators from the different values assigned the
Boolean variable logicalResult and save it again.

<MBER
)

Whenever you un-comment one of the lines, add the comment operators
to all others.

6. Choose Control-~>Play (press Ctrl+Enter in Windows or $+Return on
the Mac) to test the program by trying out the different logicalResult
values.

If you recall in English class where you were warned never to use double
negatives, you’ll understand better what’s going on in the logic. The negative
operator (!) can be used with other results with the consequence that you
will end up with an unexpected true or false. If you say (or think), “Hmmm,
the two expressions are not equal, and if [ say that they are not not equal,
that would be false.” For the most part, it’s a good idea to avoid double
negatives in your logical operations to reduce confusion. However, unlike
your English teacher, ActionScript 3.0 is perfectly willing to accept double
negatives and generate results reflecting their logic.

Experiment with the program with logical operators to see the different
results. Such experimentation will help you understand how they work and
give you some ideas for using them.



Chapter 4: Making Decisions . . .
and Repeating Yourself

In This Chapter

+~ Ogling conditional statements

»~ Making decisions with the if statement

1 Checking out the else clause

v~ Structuring the switch statement

v~ Setting up the for loop

+~ Finding unknown elements with the for. .in loop
v~ Extracting properties with the for each..in loop
1+~ Iterating through a while loop

 Getting loopy the do. .while loop

‘ omputer programs can make decisions by com-

paring different sets of information. In Flash
(CS4, this can be important for applications where
more than one alternative is available to the user.

. . Sale ltems
Likewise, your computer can process repeated T 7
chores so that you only have to write a little code Flash Driv es

. . External Hard Drives
and you can repeat it using loop structures. DVD Diives
O ptical Drives
In this chapter, we explore the main applied struc- k

tures of ActionScript 3.0 and also a special kind

of object called an array, in which you can store all
kinds of elements in a single object. You can use these
structures with different functions you can create. Some
of the features in this chapter may be familiar from other
chapters, but in this chapter we go into more depth.
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On One Condition! (Or, Maybe More than One):
Conditional Statements

At its base, the conditional statement in ActionScript 3.0 works very much
like everyday decisions, such as what to wear, what to read, where to go,
and what to do. In all these decisions are conditions. For example, in decid-
ing what to wear, you may have a situation where you don’t know whether it
is going to rain or not rain. So, you may have the following decision:

If it’s going to rain, I'll wear my raincoat. Otherwise, I'll wear a light
windbreaker.

The two conditions are rain and no rain, and depending on which of those
conditions occurs, you make one choice or the other. So, when considering
conditional statements in ActionScript 3.0, keep in mind that they work just
like you think they do.

The if statement

The most basic conditional statement is the i f statement. If you're making
a game, for example, you may need to check to see whether the player has
met whichever condition ends the game. Also, if the game is over, you need
to find out whether the player won or lost. If the player won, she sees a
banner declaring “You won!,” but if she lost, she sees a different banner,
“Better luck next time.” Figure 4-1 shows the structure of an if statement.

In Chapter 3 of this minibook, we discuss Structure

Boolean variables, which can have only if(condition == true)
the values true or false. As you can {
see in Figure 4-1, the condition x > 50
has a Boolean result. Either x is going }
to be greater than 50 or it is not. If x is
greater than 50, the result is true; other- Example
wise, the result is false. If(x > 50)
To help you visualize the concept, sup- output.text="Winner!";
pose you are pre-screening candidates for |

//statements

a job. You want to select a candidate who

knows either ActionScript 3.0 or object Figure 4-1: The structure of an i £
oriented programming. You could write a  statement.

statement such as

if (candQl == knowsAS3 || candQ2 == knowsOOP)
{
hire();

}
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Now suppose you have a deep and talented candidate pool and decide that
you want someone who knows ActionScript 3.0 and knows how to design
sites in Flash. Such a person would be an even better candidate:

if (candQl == knowsAS3 && candQ3 == knowsDesign)
{

hire();

}

In the first conditional statement, if either condition is true, the result is
true. However, in the second condition, both conditions in the expression
must be true to result in true. Otherwise, the result is false.

When using logical operators for AND (&&) and OR (| |), remember that you
must have two complete expressions separated by a logical operator. If you
type if (depth > 6 && < 20), you’ll encounter an error. The variable
depth must be restated after the && operator. Typing i f (depth > 6 &&

depth < 20) instead correctly lists both conditions.

The else clause

The else clause in an if statement allows you to have
more than one option. In other words, “if X is true, do Y,
else, do Z.” Figure 4-2 shows the basic structure in the
context of an i f statement.

Using the if statement together with the else clause, you
have more options. To get a grip on what you can do with
the i f. .else statement, this next application is a simple
interaction that keeps looking to see if the game is over. If
the game is not over, it outputs the number of times you
have clicked the button. When you get to 10, it tells you
that the game is over and disables the button. The follow-
ing steps show you how to get it up and running:

1. Open a new Flash (ActionScript 3.0) file and save it.

We saved ours as SimpleIf.fla.

2. In the Property inspector, enter the name for the class and save the

file again.

We named ours SimpleIf.

You can open the Property inspector by choosing Window=>Properties

(or pressing Ctrl+F3 in Windows or 8+F3 on the Mac).

The else clause
if(condition)
{

//Do this
1
else
{

//Do that
1

Figure 4-2: The

structure of the

else clause.
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Optionally, you can decorate the Stage as shown in Figure 4-3. The
button and text output fields are dynamically added by the code, so
don’t add them on the Stage using Flash tools. If you do so, save the file

when you’re done.
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200 Smplell el

Decimion Maker

BLLLFT
Clicks =4

200 Tmplell vl

Decision Maker

Figure 4-3: Using the 1 £ . . el se statement to determine the end of the game.

3. Open the Components panel by choosing Window=>Components (or
pressing Ctrl+F7 in Windows or 3+F7 on the Mac). Drag a Button com-
ponent to the Stage and delete it.

You now have a Button component stored in the library.

4. Open a new ActionScript file and save it in the same folder as the

Simple. fla file.

We named ours SimpleIf.as and saved it in the same folder as the

Simple. fla file.

5. Add the following code and save the file again:

package
{

import fl.controls.Button;

import flash.
import flash.
import flash.

import flash

public class

{

display.Sprite;
text.TextField;
text.TextFormat;

.events.MouseEvent;

SimpleIf extends Sprite

private var btn:Button;

private var scoreBoard:TextField;
private var styleBoard:TextFormat;
private var addClick:uint;

public function SimpleIf ()

{

btn=new Button ();

btn.addEventListener (MouseEvent.CLICK, addScore) ;
btn.x=200;btn.y=150;

btn.label="Click to Play";

addchild(btn) ;

//Add text field

scoreBoard=new TextField();
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scoreBoard.x=200;
scoreBoard.y=180;
addChild(scoreBoard) ;
//Add text format class
styleBoard=new TextFormat () ;
styleBoard.font="Arial Black";
scoreBoard.defaultTextFormat=styleBoard;
}
private function addScore (e:MouseEvent) :void
{
addClick++;
if (addClick>=10)
{
scoreBoard. text="Game over";
btn.label="Disabled Button";
btn.enabled=false;
}
else
{

scoreBoard. text="Clicks ="+addClick;
}
}

}

6. Test the application by choosing Control=>Test (or pressing Ctrl+Enter
in Windows or 38+Return on the Mac).

You will see that the program adds new values to the output each time
you click the button. When you click it for the tenth time, the button is
disabled and the Game Over sign appears. Figure 4-3 shows what you’ll
see before the count reaches 10; on the left, you can see what it looks
like after the count has reached 10. By disabling the button, the user
cannot add more values than the game allows.

The addclick in the preceding variable is an unsigned integer (uint).
Notice that while it is declared, it is created (instantiated) by the add-assign
(++) compound operator, which is perfectly legal because it adds a value of
one to a value of undefined. With each click, the add-assign operator adds
one to its value to be evaluated by the conditional statement.

Let’s do the switch/

With one or two outcomes, the if statement with the else clause works
fine. However, when you have several different conditions and need to deal
with several outcomes, you need to be able to handle them all. Thanks to the
switch statement, you can use several different condition states and deal
with each case appropriately.

Although we first mentioned the switch statement in Chapter 2 of this mini-
book, Figure 4-4 shows the structure of the switch statement in a bit more
detail.

Book IV
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switch (test)
{ Compares test variable
case outcomel: with each case outcome
//statements
break;
case outcomeZ:—— Colon as case delimiter
//statements
break; Exit switch statement
default: If none of the outcomes are
//statements the same as the value of the
} test variable, the default
statements are invoked (Optional)

Figure 4-4: The structure of the swi tch statement.

The logic of the switch statement is different from the if statement. With
the if statement, you use a Boolean (true or false) condition. With the
switch statement, a test value is compared with several different case
values. If the values are equal, the statements in the case are invoked. Using
the break statement (after the other case statements are launched) moves
the program to the next statement.

In this next example, we’ll create a program with three choices in three dif-
ferent buttons — Larry, Curley, and Mo. With a few exceptions, when we’ve
assigned an event listener to a button, we’ve used different functions for
each button. However, in this application all of the listeners call the same
function. By using the target and label information passed when the
button is clicked, we can store that information in a variable and then use
that variable as the test variable in the switch statement. The following line
uses a string variable named decide to store the target (instance name):

decide=e.target.label;

The e is the instance name of the mouse event passed in a parameter in this
line:

private function choose (e:MouseEvent)

So, if you've been wondering what the event parameter is, now you know!
The following steps show how to create the full application:

1. Open a new Flash (ActionScript 3.0) file and save it.

We named ours Switch. fla.
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2. In the Property inspector, enter the name for the class.
We named ours Switch.

You can open the Property inspector by choosing Window=>Properties
(or pressing Ctrl+F3 in Windows or 8+F3 on the Mac).

3. Place a Button and TextArea component in the Library that will
instantiate with code and save the file again.

You can place a component on the stage and then delete it to automati-
cally place it in the library. However, don’t leave the components on the
Stage, or else they will conflict with the components being placed on the
Stage by the program. If you want, you can decorate the Stage, as shown
in Figure 4-5, or use your own design.

09 e Switch.swf

Figure 4-5: Using button information and the swi tch statement.

. . . . Book IV
4. Open a new ActionScript file and save it as in the same folder as the Cht:l:ter 4
file you created in Step 1.
Y]
We named our file Switch.as and saved it in the same folder as we 25
saved the Switch. f1a file. g5
[+]
5. Add the following code and save the file again: 5-5”- g
package ‘i g:
{ gz
import flash.display.Sprite; g:

import flash.events.MouseEvent;
import fl.controls.Button;
import fl.controls.TextArea;
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public class Switch extends Sprite
{
private var larry:Button;
private var curley:Button;
private var mo:Button;
private var showMe:TextArea;
private var decide:String;

public function Switch()

{
larry=new Button ();
larry.x=245,larry.y=180;
larry.label="Larry";
larry.addEventListener (MouseEvent.CLICK, choose) ;
larry.width=60;
addChild(larry) ;
curley=new Button ();
curley.x=245,curley.y=205;
curley.label="Curley";
curley.addEventListener (MouseEvent .CLICK, choose) ;
curley.width=60;
addChild(curley) ;
mo=new Button ();
mo.x=245,mo.y=230;
mo.label="Mo";
mo.addEventListener (MouseEvent.CLICK, choose) ;
mo.width=60;
addChild (mo) ;
showMe=new TextArea ();
showMe .x=225, showMe.y=260;
addChild (showMe) ;

}

private function choose(e:MouseEvent)
{
decide=e.target.label;
switch (decide)
{
case "Larry"
showMe.text="Hi Mo and Curley";
break;

case "Curley"
showMe.text="Hi Mo and Larry";
break;

case "Mo"
showMe. text="Hi Larry and Curley";
break;

6. Test the application by choosing Control->Test (or pressing Ctrl+Enter
in Windows or 38+Return on the Mac).

You will see that as you click on each name, a greeting to the other two
characters appears in the TextArea component. Figure 4-5 shows what
you can expect to see.



Let the Looping Computer Do the Work 32 9

As you can see when you test the application, all of the responses are
from the single choose () method (function). This should give you some
ideas for using the switch statement when you have several buttons
but only want to use a single method for an event handler.

Let the Looping Computer Do the Work

When you have a repeated set of tasks, instead of writing multiple state-
ments to handle the same task, ActionScript 3.0 allows you to write a single
loop statement with the task inside the loop and repeat the same task again
and again. ActionScript 3.0 has the following types of loops:

v for

» for..in

» for each..in

» while

» do..while

Each of these loops has a different purpose. In the following sections, we

show you each one in turn and provide a small example of using each. A bit
later on in the section on arrays, we show you more uses for loops.

The £or loop

The for loop is the most common loop. With it, you can specify a starting
point, an end condition (what will make it stop), and an increment (increase
value) or decrement (decrease value). The basic structure is

for (begin , end_condition, wvalue_change)

For example, the following loop begins at 0, ends if the value is less than 10,

and increments by 1 with each iteration through the loop: Book IV
Chapter 4
for( var lv:uint = 0; 1lv < 10; 1lv++) -
2
The loop variable (1v) has a value of 0 the first time through the loop, a _E’ g
value of 1 the second time, 2 the third time, and so forth until it reaches 10 8 ]
and stops the iterations. You will often see the term iterate when dealing =3 2
with loops of all types; an iteration refers to a single time through the loop. E )
a2
g:

The following example shows the value of the loop variable (ele) incre-
mented as it goes through the loop. Follow these steps to set it up:
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. Open a new Flash (ActionScript 3.0) file and save it.

We saved ours as Loopy . fla.

. In the Property inspector, enter the name for the class.

We named our class Loopy.

You can open the Property inspector by choosing Window=>Properties.

. Choose Window=>Components to open the Components panel and

drag a TextArea component to the Stage. Then save the file.

This action automatically places the component and supporting files in
the library that you will instantiate with code.

Delete the component from the Stage so that it does not conflict with the
components placed on the Stage dynamically with ActionScript.

. Open a new ActionScript file and save it in the same folder as the file

you created in Step 1.

We named our file Loopy . as and saved it in the same folder as the
Loopy . fla file.

. Add the following code and save the file again:

package

{
import flash.display.Sprite;
import fl.controls.TextArea;

public class Loopy extends Sprite
{

private var showLoop:TextArea;

public function Loopy ()

{
showLoop=new TextArea() ;
showLoop.x=150, showLoop.y=100;
showLoop.height=150;
showLoop.width=50;
addChild (showLoop) ;

for (var ele:uint =1; ele < 11; ele++)
{

showLoop.appendText (ele.toString () +"\n") ;
}

}

6. Test the program.

When you test it, you will see the output neatly presented in the elon-
gated TextArea component.

Keep this loop in mind whenever you encounter a situation where you
need to repeat a task a given number of times.
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The foreign . . . er, for. .in loop

Sometimes you have no idea how many times you have to loop through an
object or list to get everything out that’s in the object. In these cases, the
simple for loop isn’t much help, in which case you use the for. . in loop,
which keeps iterating until all elements in the object are accounted for. The
for..in loop has the following structure:

for (var property in object)

When dealing with objects, you can add just about anything as a property.
Suppose that you’'re making a Flash site for a musical trio made up of a bass,
guitar, and piano. You want the group to be flexible so that if a player is

out sick or out of town, you can add another player. Also, you don’t know
whether the trio might decide to become a quartet or a duo. In this case,
here comes the for..in loop to the rescue. The following steps show how:

1. Open a new Flash (ActionScript 3.0) file and save it.
We saved ours as Loopy?2.fla.

All the loop examples use the same component: TextArea. You can save
time if you use Save As and just save the files with a different name and
Document name. For example, you could save Loopy. fla and Loopy .
as as Loopy?2.fla and Loopy?2 .as. Then just use the different code
for each example and be sure to change the class name in the Property
inspector.

2. In the Property inspector, enter the name for the class.
We named our class Loopy?2.
To open the Property inspector, choose Window=>Properties.

3. Choose Windowr>Components to open the Components panel and
drag a TextArea component to the Stage. Then save the file.

This action automatically places in the library the component and
supporting files that you will instantiate with code.

Delete the component from the Stage so that it does not conflict with the
components placed on the Stage dynamically with ActionScript.

4. Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We named ours Loopy?2.as and saved it in the same folder as the
Loopy?2 . fla file.

5. Add the following code and save the file again:

package

{
import flash.display.Sprite;
import fl.controls.TextArea;

Book IV
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public class Loopy2 extends Sprite
{
private var showLoop:TextArea;
private var obj:0Object;

public function Loopy2 ()

{
obj=new Object();

obj={Bass:"Joe",Piano: "Sheila",Guitar: "Harry"};
showLoop=new TextArea ();
showLoop.x=150, showLoop.y=100;
showLoop.height=100;
showLoop.width=150;
addChild (showLoop) ;
showLoop. text="The Loopy Trio\n";
showLoop.appendText ("---------—=---———- \n");
for (var prop in obj)
{

showLoop.appendText (obj [propl+" playing "+prop+"\n");

}

}

}

This example shows that you get both the static (unchanging) property
(an instrument) and the dynamic (changing) property of the static prop-
erty (one of the musicians). So, the piano can be played by Sheila one
day and by Joe the next day — same piano, different players.

The for each..in loop

The for each. .in loop was developed primarily for XML files with E4X.
E4X is language support that allows access to XML from ECMAScript lan-
guages like ActionScript 3.0. If you're not familiar with XML, don’t worry
about it. The loop iterates through an object and targets only the dynamic
elements of an object, including an XML object. It has the following format:

for each(var ele in object)

The each keyword simply tells the loop that only dynamic elements are to
be brought out and all the static properties are ignored. This approach is
probably more realistic because you're usually interested in the dynamic
values anyway.

Because the loop was developed for XML, we’ll loop through an XML object.
The following steps show you how:
1. Open a new Flash (ActionScript 3.0) file and save it.
We named ours Loopy3.fla.
2. In the Property inspector, enter the name for the class.

3. In the Component panel, drag a TextArea component to the stage and
delete it.
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This action places a component in the library, where ActionScript 3.0
can access it.

4. Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We named ours Loopy3.as and saved it in the same folder as the
Loopy3. fla file.

5. Add the following code and save the file again:

package

{
import flash.display.Sprite;
import fl.controls.TextArea;

public class Loopy3 extends Sprite
{
private var showLoop:TextArea;
private var xmlFun:XML;

public function Loopy3 ()
{
xmlFun=new XML () ;
xmlFun=
<dogs>
<breed>Sheep Dog </breed>
<breed>Swiss Mountain Dog </breed>
<breed>Basset Hound </breed>
<breed>English Springer Spaniel</breed>
</dogs>;

showLoop=new TextArea ();

showLoop.x=150, showLoop.y=100;
showLoop.height=100;

showLoop.width=180;

addChild (showLoop) ;

showLoop.text="Dogs I know\n";
showLoop.appendText ("--------—-—-—-——— \n");

for each (var doggy in xmlFun.breed)
{

showLoop.appendText (doggy+"\n") ;
}

} Book IV

} Chapter 4
}

. 2=
6. Test the program by ch(.)osm.g Control=>Test Dicges | iend PE
(or pressing Ctrl+Enter in Windows or ... E a
8 +Return on the Mac). Sheep Dog =3 g
Swiss Mountain Dog Qe &
Figure 4-6 shows what you can expect to see.  Basset Hound ~)
English Springer Spaniel E @

The for each. . in loop was successful in =l s:

extracting just the information that you want.
If you decided to add more dog breeds to

the XML file, the for each. . in loop would
get the additional information out for you.

Figure 4-6: Output of the for
each. . in loop to extract
data from an XML file.
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(Go ahead and add a Chihuahua to the XML breed list and watch him get

extracted and displayed on the screen.)

The while and do. .while loops

A while loop keeps looping until a certain condi-
tion is met. (You keep doing this until you get it
right! Now do it again!) You need to know that the
condition can be met; otherwise, you can get into an
infinite loop that locks up the program. Figure 4-7
shows the general format for both types of loops.

The only difference between these two types of
loops is that the do. .while loop always iterates

at least once, and the while loop stops before

any iteration of the condition is met. The following
example shows how each is set up and the identical
outcomes they generate in the case where the first

time through the loop, the stop condition is not met:

1. Open a new Flash (ActionScript 3.0) file and
save it.

We saved ours as Loopy4 . fla.

while loop
while(condition)
{
//statements
}

do..while loop
do

{
//statements

}
while

(condition)

Figure 4-7: The structure of
whileanddo. .while
loops.

2. Choose Window=>Properties to open the Property inspector. In the
Property inspector, enter the name for the class.

We named ours Loopy4.

3. Choose Window=>Components to open the Components panel and

drag a TextArea component to the Stage.

This action places a component in the library, where ActionScript 3.0

can access it.

4. Open a new ActionScript file and save it in the same folder as the file

you created in Step 1.

We named ours Loopy4 . as and saved it in the same folder as the

Loopy4 . fla file.

5. Add the following code and save the file again:

package

{
import flash.display.Sprite;
import fl.controls.TextArea;

public class Loopy4 extends Sprite
{
private var showLoop:TextArea;
private var endItAll:uint;
private var iter:String;
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public function Loopy4 ()

{
showLoop=new TextArea ();
showLoop.x=150, showLoop.y=50;
showLoop.height=265;
showLoop.width=120;
addChild (showLoop) ;
showLoop.text="A Tale of Two Loops\n";

showLoop.appendText ("--------------- \n");
showLoop .appendText ("The while loop\n");
endItAll=6;

iter="Iteration=";

while (endItAll !=0)

{
showLoop.appendText (iter+endItAll+"\n") ;
endItAll--;

}

showLoop .appendText ("\n") ;

endItAll=6;
showLoop.appendText ("The do..while loop\n");
do
{
showLoop . appendText (iter+endItAll+"\n");
endItAll--;
} while (endItAll !=0);

6. Choose Control~>Test to test the application.

The outcomes should be identical to what you see in the figure on the
left in Figure 4-8.

However if you change the loops to the following segment, the outcome
will instead look like the right panel of Figure 4-8:

endItAll=20;
iter="Iteration=";

while (endItall !=20)

{
showLoop.appendText (iter+endItAll+"\n") ;
//endItAll--;

}

showLoop.appendText ("\n") ;

endItAll=20;
showLoop.appendText ("The do..while loop\n");
do
{
showLoop.appendText (iter+endItAll+"\n") ;
//endItAll--;
} while (endItAll !=20)

Book IV
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A Tale of Two o A Tale of Twe Loops
loops: | | [ee——
--------------- The while locp

The while keop
Iteration=6 The do. while loop
teration=5 Iteration=20
[teration=4 k
lteration=3
Iteration=2
lteration=1

The do..while locp
teration=6
teration=5
temtion=4
lteration=3
lteration=2
temation=1

k |-

Figure 4-8: The do . .while loop always has at least one iteration.

Instead of both loops generating the same values, the do. .while loop
has the condition at the bottom, so it generates a single iteration and
the while loop generates nothing.

With the basic conditional and loop structures at your service, you have
most of the structures you need to create programs that can make decisions
and repeat processes without having to rewrite the same code repeatedly.



Chapter 5: Harnessing the
Power of ActionScript 3.0

In This Chapter

1~ Creating arrays

+~ Pushing data to arrays

1~ Retrieving array elements with Pop

v~ Sorting arrays

+~ Introducing the Vector class

v~ Using string identifiers in Vector elements

+~ Incorporating the Vector. forEach () method
1~ Starting and stopping drag operations
 Drawing with ActionScript 3.0

+~ Creating triangles with vertices and indices

ARRAY MACHINE

T)o often, we hear Web designers and devel- e b i ee Wiy, oot
opers pine for the “good old days” when 0

ActionScript consisted of just a few lines of code

spread all over the place. Well, we disagree. 1

ActionScript 3.0 has a learning curve for people g”;v

accustomed to using previous versions, but the 68

good thing about ActionScript 3.0 is that now that Apple

it has been retooled into a standardized, more :141592653539?93

efficient form, it will be around for a while, and, R

even though some changes will inevitably be made

in future versions, you don’t have to figure out how to

use it from scratch every time a new version is released

and you want to sit down to make the world’s greatest Flash
application.

In this chapter, we show you how to use grouping structures that corral
more than a single element and give each one a unique value, and we

tell you about arrays that have been included in several generations of
ActionScript. Using arrays, you can easily have several values different
types of data stored in the same place for ease of access. In addition, you
see vectors, the brand-new type of grouping structure. As you will see, vec-
tors are much like arrays, although they can be of different types, just like
variables.
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In this and the preceding chapters in this minibook, we only scratch the sur-
face of ActionScript 3.0. In Book VI, you see lots more ActionScript 3.0 used
with video.

All the code listings in this chapter are available for downloading from this
book’s companion Web site at www.dummies.com/go/flashallinone.
Some code listings are long, so you may want to download the code to avoid
making typing errors. Then you can make changes to create your own appli-
cations with the same structures.

Meet the Gang: Arrays

When you have several different elements organized in groups, you may
need an array. In some respects, an array is just any other object with differ-
ent properties. As you've seen, object properties can be numeric, Boolean,
or character strings. The same is true with arrays.

Unlike a variable, an array isn’t assigned a type. In programmer lingo, you
would say instead that an array isn’t typed, rather, an array is a type. When
you create a variable, you include the data type. So, variable xray might be
a string and variable stack might be a number. When you create an array,
you add elements of any type you want — or you can just use literals. An
element in an array is a unique member of the array — sort of like a member
of a club with the array as the club. Each element can have its own value. A
literal is an actual value, such as the number 2 or the string "hello".

Creating an array

When you create an array, you use the following format:

var myArray:Array;
myArray=new Array();

At the same time you create the array, you can include data within the
parameters. For example, this line:

myArray=new Array (7, 30, "San Francisco");

creates an array with three elements: two numbers and a string. These are
stored in elements with a zero-base numbering system using the following
format:

myArray[0];
myArray[1l];
myArray[2];
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For example, the value of myArray[1] is 30. You can pass that value to a
variable or do whatever else you want do with it as you would a variable or
literal. For example, the following chunk of code passes the third element to
a string:

var song:String = "I left my heart in ";
song += myArrayl[2];
//song value = I left my heart in San Francisco

The important difference between strings and arrays is that both numbers
and strings are added to the array. Variables can accept only a certain data
type that is made when the variable is declared.

Getting pushy: Adding data to an array

Besides adding data to an array when you instantiate (create an instance of)
the array, you can do it in other ways too. The easiest is just to keep adding
elements with different numbers. For example, to add more elements to an
array with three elements in it already, you could do the following:

myArray[3]="New York";
myArray[4]1=22;
myArray[5]=false;

Keeping in mind that the array is zero-based, the three added elements give
the array a new total of six elements.

In addition to assigning values to array elements (just like assigning values
to variables), you can use the push () method. When you add elements to
an array using the push statement, you place the most recent element on
the top of the stack. For example, the following would add three elements
to the array numbered 6, 7, 8 from left to right if added to the existing ele-
ments already in the array:

group.push ("Apple",4,Math.PI) ;

Keep in mind that the push () method adds elements to the top of the array.
Imagine one of those spring-load cafeteria tray containers, and that each
tray is an array element. As you add more elements, they’re simply added to
the top.

pop () goes the element! Retrieving
data from an array

Getting elements out of an array has several advantages over using variables
to store data, the most important being that you can use a loop to numerically
iterate through the array to extract all the values. Consider the difference

Book IV
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between using an array with 100 elements and 100 variables that you’re put-
ting into a TextArea for output. First, in looking at variables, you would have
to do something like the following:

myTA.appendText (wheels + "\n");
myTA.appendText (door + "\n");
myTA.appendText (radiator + "\n");

//On to the 100th variable
myTA.appendText (tailPipe + "\n");

You can imagine the amount of coding you would have to do for a quick vari-
able inventory. With an array, all you need to do is to loop through the array
and extract each element in turn using the following code:

for (var myEle in myArray)

{
textArea.appendText (myArray[myEle]+"\n") ;
}

The for. .in loop keeps on extracting element values until the array is
empty. You can easily add or reduce the number of elements, but you need
not change any code to send the code to an output.

Rather than iterate through a loop and selecting each element by a reference
to the element number, you can also use the pop () method. The pop ()
method takes the top element off the array, makes it available, and then
discards it. For example, this statement:

myVar = myArray.pop();

passes the value of the last element on the array to myVvar. After the value is
passed to the variable, the size of the array is reduced by 1.

You must remember that the pop () operation uses and removes the last
element. So, if you want the first element, you're better off using array [0]
rather than pop ().

You may be scratching your head wondering, “What would I ever do with an
array using pop () ?” If you have a large number of values you want to pass
using an array, using the pop () method gets rid of the content as soon as
you're finished using the information, which can help free up memory.

In case you're thinking of creating games with Flash CS4, you can keep a
game crisp (running without delays) by keeping memory free.
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Sorting with an array

The final topic we cover with arrays is the sort () method. By adding it
with an array instance, you can sort (surprise!) all elements in the array. For
example, this line:

myArray.sort () ;

sorts all contents in ascending order (from lowest to highest). To sort in
descending order, all you have to do is to use the number 2 as a param-
eter. So, this line:

myArray.sort (2) ;

would begin with the highest value and go to the lowest. Using the ten most
common American surnames (last names), let’s take a look using the follow-
ing chunk of code:

var myArray:Array;

myArray=new Array ("Smith", "Johnson","Williams") ;
myArray.push("Jones", "Brown", "Davis", "Miller") ;
myArray.push("Wilson", "Moore", "Taylor") ;
myArray.sort () ;

for (var ww in myArray)

{

trace (myArray[ww]) ;

}

The preceding code sorts the names alphabetically. If you change the line
with the sort () method to the following:

myArray.sort(2);
all the names are instead listed in reverse alphabetical order.

Strings are case sensitive when it comes to sorting and capital letters come
before lowercase letters. For example, if you change Davis to davis, it’s
sorted last using ascending order.

Array practice

Now that you have an idea of what you can do with arrays, this next applica-
tion employs different kinds of content in addition to input and output. The
following steps guide you through creating it:

1. Open a new Flash (ActionScript 3.0) file and save it.

We named ours ArraySample. fla.

Book IV
Chapter 5
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. In the Class box in the Properties panel, enter the class name.

We named ours ArraySample.

You can open the Property inspector by choosing Window=>Properties
(or pressing Ctrl+F3 in Windows or 8+F3 on the Mac).

. Using the Text tool, position a static TextField on the Stage and add

some content.

We positioned ours at X=100, Y=42, and using a 32-point graphic font,
typed Array Machine and saved the file.

. Create a small shape to become a button and Choose Modify->Convert

to Symbol from the menu bar (or press F8) to open the Convert to
Symbol dialog box.

We drew a circle with the Oval tool with a diameter of 32 (H=32, W=32).

. In the Convert to Symbol dialog box, select Button as the type and

type a name for the button (we named ours Btn). Click the Export for
ActionScript check box and click OK.

. Select the button and press the Delete key to remove it from the Stage.

The button is preserved in the library.

. Drag a Label and TextArea component to the library.

Alternatively, you can drag the Label and TextArea components to the
Stage and then delete them. This action places the components in the
library.

Depending on how you have your panels docked, it might be easier

to drag components from the component panel to the Stage and then
delete them. As soon as a component or symbol is placed on the Stage,
one is automatically placed in the library.

. Open a new ActionScript file and save it in the same folder with the

file you created in Step 1.

We named ours ArraySample.as and saved it in the same folder as the
ArraySample. fla file.

. Add the following code and save the file again:

package

{
import flash.display.Sprite;
import flash.events.MouseEvent;
import fl.controls.Label;
import fl.controls.TextArea;

{
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public class ArraySample extends Sprite
{
private var group:Array;
private var size:String;
private var msg:String;
private var btn:Btn; //From Library
private var label:Label;//From Library
private var textArea:TextArea; //From Library
{
public function ArraySample ()
{
group=new Array(l,true, "Cow",66);
group.push("Apple",4,Math.PI);

label=new Label () ;
label.x=100,label.y=80;
label.width=250;

msg="Press button to ";
msg+="see array contents:";
label.text=msg;
addChild(label) ;

textArea=new TextAreal();
textArea.width=150, textArea.height=200;
textArea.x=100, textArea.y=140;
addChild(textArea) ;

btn=new Btn() ;
btn.x=100,btn.y=100;
btn.addEventListener (MouseEvent.CLICK, unpeel) ;
addChild (btn) ;
}

private function unpeel (e:MouseEvent)
{
//group.sort () ;
//for (var stuff:uint =0; stuff<7;stuff++)
for (var stuff in group)
{
textArea.appendText (group [stuff]+"\n");
//textArea.appendText (group.pop () +"\n") ;
}

size="This array has "+group.length +" elements."
textArea.appendText (size) ; Book IV

Chapter 5
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10. Test the file by choosing Control=>Test (or pressing Ctrl+Enter in
Windows or 8+Return on the Mac).

0°¢ ¥duaguonoy
J0 J13amod ay}
Buissawie

Figure 5-1 shows what you can expect to see the first time you test it,
assuming that you used our examples to the letter.
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000 ArraySample.swf

ARRAY MACHINE

Press button to see amay contents:

3.141592653585753
This amay has 7 elements

Figure 5-1: TextArea component displaying contents of array.

The lines in the unpeel function that are commented out are for testing the
application using different methods. Begin by un-commenting (taking out

// characters) the statement, group.sort (). Test it and see what you get.
Next, change it to read, group.sort (2). As you can see, numbers have
lower values than strings, so 20000 always comes before Aardvark in an
ascending sort. However, the opposite is true in a descending sort.

Next, change the unpeel function to the following:

private function unpeel (e:MouseEvent)
{
for(var stuff:uint =0; stuff<7;stuff++)
{
textArea.appendText (group.pop ()+"\n") ;
}
size="This array has ";
size+=group.length +" elements.";
textArea.appendText (size) ;

}

Because you used the pop () method, the order is reversed and the size of

the array is down to zero. The for loop was used to iterate through all the

elements rather than the for. .in loop because of the shrinking size of the
array. With each iteration, the loop size changes and because the for..in
loop uses the array size, some elements are always left out.
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New in Flash CS4: Uectors

3

Vectors are close cousins to arrays and are newly introduced in ActionScript
3.0 with Flash CS4. A vector is something like an array, and most of the meth-
ods used with arrays are also available for vectors.

The main difference between the two is that vectors are typed and all items
in a vector must be of a single declared type. The result is that vectors are
much faster and more efficient than arrays. Adobe recommends that vectors
be used rather than arrays wherever you're storing data of the same type in
a single object.

To see how each one is set up, Figure Array
5-2 shows their structures along with an | var myazzay:azzay:

) myArray=new Array("optl", opt2)
example (in blue) so that you can see
the difference. You cannot add data to a
vector when you instantiate it as you can
with an array, and so in Figure 5-2, the Vector o )

: . var myVector:Vector.<T>;

optl and opt2 elements indicate the myVector=new Vector.<T>(length, fixed)
option of declaring an array and adding
data at the same time and of different

types.

One feature about vectors that you will Figure 5-2: Arrays and vectors.

find new is the use of arrow brackets

(<>) for typing vectors. The <T> is a generic symbol used for type, and the
type can be any ActionScript 3.0 type. So you might see <String>, <int>,
<Number>, or any other type. Also, note that a dot (.) appears between
Vector and the type (Vector.<String>).

Checking out non-numevic 1D for vector elements

The first example shows how to set up a vector and to use string names as
element identifiers. This means that you can name an element anything you
want using quotes around a label, such as

myVector["alpha"]="A perfect day!";
myVector["beta"]="A beautiful night!";

You can do the same thing with arrays but Adobe recommends that you use
an Object instance rather than an array. Doing so allows you to initialize
your array with an object literal.

A vector is another alternative for creating groups of elements using string
literals rather than numbers to identify the items in the vector. This next
example provides a simple example:

Book IV
Chapter 5
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1. Open a new Flash (ActionScript 3.0) file and save it.
We named ours VectorWork. fla.

2. In the Class box in the Properties panel, enter the class name and save
the file again.

We used VectorWork as the class name.
3. Drag a TextArea component into the library.
We told you it’s in the library!

4. Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We named ours VectorlWork. £1a and saved it in the same folder as
VectorWork.as.

5. Add the following script and save the file again:

package

{
import fl.controls.TextArea;
import flash.display.Sprite;
import fl.controls.ScrollPolicy;

public class VectorWork extends Sprite
{
private var myAA: Vector.<String>;
private var textArea:TextArea;
private var cr:String;

public function VectorWork ()

{
myAA=new Vector.<String> (6, true);
myAA["President"]="Pres-Joe Smith";
myAA["VPm"]="Marketing-Brenda Jones";
myAA["VPA"]="Development-Lee Pierce";
myAA["VPf"]="Finance-Gideon Thomas";
myAA["VPp"]="Production-Jesse Fernandez";
myAA["VPs"]="Sales-Nancy Huang";

textArea=new TextArea ();
textArea.x=188, textArea.y=160;
textArea.width=175;
textArea.height=130;
textArea.verticalScrollPolicy=ScrollPolicy.OFF;
addChild (textArea) ;
putOut () ;

}

private function putOut ()

{
cr="\n";
textArea.appendText
textArea.appendText

myAA["President"] + cr );
myAA["VPm"] + cr);

( [

( [
textArea.appendText (myAA["VPd"] + cr);
textArea.appendText (myAA["VPE"] + cr);
textArea.appendText (myAA["VPp"] + cr);
textArea.appendText (myAA["VPs"] + cr);
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Note how the vector items were addressed. Each element is addressed
by the element name and not by a number. For example, the vice presi-
dent of finance has the item identifier "vP£ " rather than any numeric
value. If you attempt to use a number as an index to one of the elements,
you find a return value of undefined.

6. Choose Control->Test from the menu bar (Ctrl+Enter in Windows or
& +Return on the Mac) to test the application.

Sometimes you do not want the scrollbar to appear — ever. Using the
ScrollPolicy class, you can set it to OFF. Assign ScrollPolicy.
OFF to the verticalScrollPolicy or horizontalScrollPolicy
method to hide the scroll bar. (Alternatively, you can set it to ON or
AUTO.)

Figure 5-3 shows the output you can expect to see when you test the
application.

VectorWork.swf

THE YECTOR
(OMPANY

Pres-Jog Smith
Marketing-Brenda Jones
Development-Lee Pierce
Finance-Gideon Thomas
Production-Jesse Femandez
Sales-Nancy Huang

L

900

Figure 5-3: OQutput sent to TextArea from the Vector instance.

Using the forEach () method

Another unique feature of vectors is the forEach () method. From Chapter 4,
you're familiar with the for. . each loop, but the Vector class has a method
that includes a loop! Figure 5-4 shows how to set up and use the special func-
tion used by the forEach () loop method. (Arrays also have a forEach ()
method.)
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Vector identifier Any object(default=null)
_——
myVec.forEach(fName, vecObj); Data type
Data type

function fN&me(item:T, indent:int, vec:Vector.<T>):void

veck.foreach(puller,null);

function puller(item:String index:int vect:Vector.<String>):void

Function called

//Statements

trace(item);

Figure 5-4: Using Vector . forEach ().

You do not need to know the name of vector elements using for each. All you
need to do is provide the name of the first parameter set up in the function.
(In the example, ‘item’ is the term used, but it could be any label.)

With this valuable new knowledge, let’s see an example using the
forNext () method. The following steps show you how:

o

Choose Newr>Flash File (ActionScript 3.0) from the menu bar to open
a new Flash (ActionScript 3.0) file and save it.

We saved ours as EachVector. fla.

In the Class box in the Properties panel, enter a class name and save
the file again.

We chose EachVector as the class name.

You can decorate the Stage any way you want. Figure 5-5 shows a simple
design using a dynamically created TextArea component.

Drag a TextArea component into the library.

Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

Add the script in the following listing and save the file again:

package

{
import flash.display.Sprite;
import fl.controls.TextArea;

public class EachVector extends Sprite
{
private var myVec:Vector.<String>;
private var textArea:TextArea;

public function EachVector ()

{
textArea=new TextAreal();
textArea.x=210, textArea.y=150;



New in Flash CS4: Vectors 3 49

textArea.width=130;
textArea.height=100;
addChild(textArea) ;

myVec = new Vector.<String>;
myVec.push("Sale Items\n",

"Flash Drives\n",
"External Hard Drives\n",
"DVD Drives\n",
"Optical Drives");
myVec.forEach(displayItems, null);
}

private function displayItems(item:String, index:uint,
vec:Vector.<String>) :void

{
textArea.appendText (item) ;

}

The forEach () method depends on the function that it calls having all the
right parameters — an element type (item), a typed index (index:uint)
and a vector type (String). Within that function, just type your statements in
the ActionScript file. Note that in the example, the item is each and every ele-
ment in the vector. We could have written the line as

textArea.appendText (myVec[index]) ;

and you would have had the same results. Figure 5-5 shows what you can
expect to see.

000 EachVector.swf

Book IV
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Figure 5-5: TextArea populated using forEach () method.
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Look what the cat dragged in!

One fun feature for any Web page is a an object you can drag. Well, you can
drag any movie clip or sprite you want by writing a little ActionScript. All
you need to make a movie clip or sprite draggable is the startDrag () and
stopDrag () methods. Follow these steps:

1.

Choose Newr>Flash File (ActionScript 3.0) from the menu bar to create
a new FLA file.

. Draw a shape to drag by using the Text tools and choose Modify~>

Convert to Symbol from the menu bar (or press F8) to open the
Convert to Symbol dialog box.

We made ours from a dark red rectangle and a static text label of “Drag Me!”

Select Convert to a MovieClip, select the Export for ActionScript check
box, and click OK.

We saved ours with the name DragRat.

. Delete copies of the movie clip from the Stage by selecting them and

pressing the Delete key.

The movie clip is still in the library, however.

. In the Properties panel, type the class name and save the file.

We saved our file as Drag. fla.

Create an ActionScript file and save it in the same folder as the file
you created in Step 1.

We saved our file as Drag. as and saved it in the same folder as the
Drag. fla file.

. Add the following code save the file again.

package

{
import flash.display.Sprite;
import flash.events.MouseEvent;

public class Drag extends Sprite
{

private var dragRat:DragRat;

public function Drag()

{
dragRat=new DragRat() ;
dragRat.x=200,dragRat.y=150;
dragRat.addEventListener (MouseEvent .MOUSE_DOWN,

ratDrag) ;

dragRat.addEventListener (MouseEvent .MOUSE_UP, ratFree);
addChild(dragRat) ;
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private function ratDrag (e:MouseEvent) :void

{
dragRat.startDrag() ;

}

private function ratFree(e:MouseEvent) :void
{

dragRat.stopDrag() ;
}

}

8. Test the program by choosing Control=>Test (or pressing Ctrl+Enter in
Windows or $8+Return on the Mac).

9. If you used our files, place the mouse on the red rectangle and drag
it around the Stage. Otherwise, test your application to see whether it
does what you expected it to do.

<MBER You can add the preceding code to any Sprite or MovieClip object that
you want to be draggable. By copying and pasting the code to your own
application, you don’t have to reinvent the wheel every time you sit
down to create an application that has draggable objects.

An Introduction to ActionScript Graphic Programming

Although most of your graphics work may be done with graphic tools in
Flash, you can also program Flash graphics for dynamic rendering and total
flexibility in your design. In this section, we get you started, but it’s only the
first step in a 1,000-mile trip!

Get in Shape!

The first class you need to consider is Shape. Along with Shape is the
Graphics class. In fact, just about everything that Shape does with graphics
is through the shape.graphics property. Although a bit different from
most implementations, the graphics property provides a Graphics object to Book IV
be used as part of the Shape object. It makes all the drawing methods avail- Chapter 5
able to the Shape object. As a result, whenever you see Shape imported, you
also see Graphics imported. The statements

var myShape:Shape=new Shape() ;
myShape.graphics.beginFill (Oxaabbcc) ;
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show how an instantiated Shape object works with the Graphics class
through the graphics property and not a direct instance of the Graphics
class. Don’t lose any sleep over this structure; just remember that when you
want a Shape, you need Graphics. (Or vice versa — take your choice.)
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Simple rectangle

Let’s start with a simple rectangle drawing. Here’s what you need in any rect-
angle (pretend that you're using the Drawing tool):

1~ Fill color: beginFill(Oxaabbcc);
1~ Border stroke size and color: lineStyle(3, Oxccbbaa);
» Xand Y & W and H: drawRect(30, 30, 160, 120);

You need exactly the same elements with ActionScript 3.0 code. Beginning
with a Shape object, you then use the graphics property to provide all the
methods you need. The following example shows you how:

1. Open a new Flash (ActionScript 3.0) file and save it.
We named ours Rectangle. fla.

In the Class box in the Properties panel, enter the class name and save
the file.

We chose Rectangle as the class name.

2. Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We saved ours as Rectangle.as in the same folder as the Rectangle.
fla file.

3. Add the following script and save the file again.

package

{
import flash.display.Sprite;
import flash.display.Graphics;
import flash.display.Shape;

public class Rectangle extends Sprite
{

private var rec:Shape;

public function Rectangle()

{
rec = new Shape();
rec.graphics.beginFill (0x880000) ;
rec.graphics.lineStyle (3, 0x008800);
rec.graphics.drawRect (30, 30, 160, 120);
rec.graphics.endFill () ;
addChild(rec) ;

}

4. Test the application.

You see a red rectangle with a green border in the upper-right portion
of the Stage. So, really, all you're doing is drawing with code. Simple
shapes are easy to create with code.
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The image maker

To make image creation easier, you can create a class that can make circles,
ellipses, rounded rectangles, and triangles. (The createTriangles ()
method is a new one that is a bit different, and we look at it a bit more later.)
The class has methods that you can invoke from another class, and that’s
exactly what we plan to do. First, though, put GraphicPlay class together
with the following steps:

1. Open a new ActionScript file and save it.
We saved ours as GraphicPlay.as.

2. Add the following script and save the file again.

package

{
import flash.display.Sprite;
import flash.display.Graphics;
import flash.display.Shape;

public class GraphicPlay extends Sprite
{
private var circle:Shape;
private var rndRec:Shape;
private var elip:Shape;

public function GraphicPlay ()
{
//Constructor
}
public function doOval (
fill:uint,borW:Number, borC:uint,
px:Number, py :Number, r : Number) :void

circle = new Shape();
circle.graphics.beginFill (£ill);
circle.graphics.lineStyle (borW,borC) ;
circle.graphics.drawCircle (px,py, ) ;
circle.graphics.endFill();
addChild(circle);
}
public function doRnd(
fill:uint, borW:Number, borC:uint,
px:Number, py : Number, rw: Number, rh: Number,
ew:Number) :void

rndRec = new Shape();
rndRec.graphics.beginFill (£i11);
rndRec.graphics.lineStyle (borW, borC) ;
rndRec.graphics.drawRoundRect (px, py, rw,rh,ew);
rndRec.graphics.endFill () ;
addChild (rndRec) ;
}
public function doLips (
fill:uint, borW:Number, borC:uint,
px:Number, py : Number , rw: Number,
rh:Number) :void

Book IV
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elip = new Shape();
elip.graphics.beginFill (£ill);
elip.graphics.lineStyle (borW, borC);
elip.graphics.drawEllipse (px, py, rw, rh);
elip.graphics.endFill();
addChild(elip) ;
}
public function doTri(fill:uint,vl:Number,v2:Number,
v3 :Number, v4 :Number,
v5:Number, v6 : Number) : void
{
graphics.beginFill (£fill);
graphics.drawTriangles (Vector.<Number>
([vl,v2,v3,v4,v5,v6]));

3. Open a new Flash (ActionScript 3.0) file and save it in the same folder
as the file you created in Step 1.

We named our file UseGraphics. f1la and saved it in the same folder as
GraphicPlay.as.

4. In the Class box in the Properties panel, enter the class name.
We typed UseGraphics as the class name.

5. Also in the Properties panel, provide a light gray background and
save the file again.

6. Open a new ActionScript file and save it in the same folder as the file
you created in Steps 1 and 3.

We named ours UseGraphics.as and saved it in the same folder as the
GraphicPlay.as and UseGraphics. fla files.

7. Add the following script and save the file again:

package
{
import flash.display.Sprite;

public class UseGraphics extends Sprite
{
private var graphicPlay:GraphicPlay;

public function UseGraphics ()

{
graphicPlay=new GraphicPlay();
addChild (graphicPlay) ;
graphicPlay.doOval (0x800000,3,0x008000,150,100,20) ;
graphicPlay.doRnd (0xf£f££00,3,0x000000,130,220,60,70,30) ;
graphicPlay.doTri (0x000080,300,300,410,200,410,300);
graphicPlay.doLips (0x008800,3,0x990099,280,80,130,88);
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8. Select the tab containing the FLA file and test the application.

Figure 5-6 shows what you can expect to see when you test the
application.

0@ UseGraphics.swf

D
- M

8
8

Figure 5-6: Dynamically created graphics.

Try changing the values in the parameters of the methods used in the
UseGraphics application. In this way, you see that you have complete
control over the graphics.

The triangle and the vector

The triangle represents a whole new way of dealing with graphics. It uses
our friends the Vector and Graphics classes, but they’re built-in so that you
can use them without either the Shape class or the addchild () method to

place graphics on the page. Book IV

Chapter 5

Two kinds of vector parameters are used — vertices and indices. The
drawTriangles () method expects the first set of numbers to be coordinates
on the Stage and the second set to be indices referencing the coordinates. The
indices are zero-based, just like you would expect in a Vector — the first coor-
dinates are 0; the second, 1; and so on.
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In thinking about the drawTriangles () method, first consider it to be a
simple statement with two parameters:

graphics.drawTriangles (vertices, indices);

The vertices are coordinate pairs made of an x and a y position (such as
20, 30). Each triangle needs at least three coordinates. So, at a minimum,
the vertices are made up of six values representing three pairs of coordi-
nates. The vertices are stored in a vector typed as a number. For example,
the following vertices parameter shows three sets of coordinates:

Vector.<Number>([60,60, 160,60, 60,16017)

You can create a simple triangle using just the vertices, but finding out how
to use the vertices and indices together gives you a better idea of how to use
this powerful new tool that will be the basis of 3D graphics in Flash.

Indices are integers pointing to the different coordinates. The first vector
item in the indices points to the first pair. Being zero-based, the first index is
0. For example, if the first coordinate pair in the vertices list is 20, 30, then 0
would point to the coordinate 20, 30. The following line shows what you can
expect to see in the second parameter in the drawTriangles () method:

Vector.<int>([0,2,1])

Essentially, that parameter tells the program to draw a triangle starting at
coordinate 0, and then proceed to coordinate 2, and then to coordinate 1.
When you put it all together, you get the full statement:

graphics.drawTriangles (
Vector.<Number>([60,60, 160,60, 60,160]1),
Vector.<int>([0,2,1]1));

At first glance, you might be thinking that the preceding looks a bit redun-
dant, given that the first set of numbers does a dandy job of defining the
coordinates. So why the second set? The reason for that is to reduce the
number of references. Because you have only three coordinates, you're
going to get the same triangle no matter what you do. However, if you add a
fourth set of coordinates, you can draw a far wider range of triangles using
only three indices for each triangle rather than six numbers. Figure 5-7
shows the relationship between vertices and indices.

In looking at Figure 5-7, you can see a green and red triangle overlapping one
another. The indices 0,1, and 3 define the green triangle and the indices 1, 3,
and 2 define the red triangle. If you trace those values with your finger, you
can see how each comes to create a different triangle.
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Figure 5-7: Vertices and indices define triangle paths.

Now, all that’s left is to create an example that brings everything together.
Follow these steps:

1. Open a new Flash (ActionScript 3.0) file and save it.
We named ours Triangle. fla.

2. In the Class box in the Properties panel, enter the class name and save
the file again.

We used Triangle as the class name.

3. Open a new ActionScript file and save it in the same folder as the file
you created in Step 1.

We named ours Triangle.as and saved it in the same folder as the
Triangle.fla file.

4. Add the following script and save the file again:

package

{
import flash.display.Sprite;
import flash.display.Graphics;

public class Triangle extends Sprite
{
public function Triangle()
{
graphics.beginFill (0x800000) ;
graphics.drawTriangles (
Vector.<Number>([60,60, 160,60, 60,160, 160,160]),
Vector.<int>([0,1,3, 1,3,21));

Book IV
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Notice that the code has no Shape
instances and doesn’t require the
addchild () method to place the
images on the Stage. Figure 5-8
shows the hourglass image that
you get. That’s because nothing
appears where the two triangles
overlap. If you remove the first
three or last three numbers in the
indices parameter, you can see the
single triangle for each.

Figure 5-8: An hourglass created by using
triangles.



Book V
Working with
Flash Audio

The 5th Wave By Rich Tennant

S==al, Ol

“Is this really the best use of Flash
animation on our e-commerce Web site?
A bad wheel on the shopping cart icon
that squeaks, wobbles, and pulls to

the left ?”




LVhen you visit a full-fledged Flash Web site,
sound is almost always present. Some
sites greet you with background music, and other
sites have buttons that make noises when you
click them. Sound used with discretion is a useful
addition to any Flash project. In this minibook, we
show you how to incorporate sound into your
projects. We discuss the supported sound formats
and then show you how to sync sound to your
projects and create noisy buttons to optimize
your joyful noises for Flash. We also show you
how to use ActionScript to load external sound
files into a project.




Chapter 1: Understanding
Web Audio

In This Chapter

v About Internet audio files

+~ Deciphering bit depth and data rate

+~ Audio hardware and software

S)und is everywhere on the Internet, and you can include sound in your

Flash projects. If you're creating a Flash Web site for a music group, you

can include background music or an audio player, for example, and add sounds

to buttons. For example, if you're creating a Web site for a photographer, you

can have a shutter-click sound play when a button is clicked. In this chapter,

we discuss the sound file formats supported by Flash and introduce you to a

couple of important concepts about sound. In case you will be

recording your own material or editing material supplied -
by clients, we show you some hardware and software ¢
solutions.

Exploring Flash-Sanctioned
Audio Formats

Flash supports many different sound formats. -
We don’t profess to be experts when it comes to R —
sound, but we do know enough to be dangerous, ' T
and more than enough to know the lowdown on ; =
sound for Flash. Do you need to be a sound expert to POLEw/Tng e
incorporate sound in your Flash movies? No. But it does
help to know something about the different file formats, espe- e
cially if you're dealing with clients who ask you to add sound to

their Flash projects. When they do, you tell them which format you need it in.

The following list briefly describes the sound formats supported by Flash:

1 WAV (*.wav): A format that’s compatible on the Windows and
Macintosh operating platforms. (WAV is an abbreviation of WAVeform.)
As arule, sound in this format isn’t compressed and is encoded with
PCM (pulse-code-modulation). If you use a WAV file in a Flash project,
you start with high-quality sound. This format is ideal if you're including
background music that must be of high quality.




3 62 Understanding Bit Depths, Data Rates, and Sample Rates

v~ AIFF Sound (*.aif, *.aiff): A format that can be used on both Windows
and Mac operating systems. This sound file format (another one that
usually isn’t compressed) offers CD sound quality and is another good
option for high-quality background music. (AIFF is an acronym for Audio
Interchange File Format.)

1 Adobe Sound Document (*.asnd): A file created by using the Adobe
Soundbooth software. The user can specify the data rate and bit
rate for the file. Flash CS4 has an option to edit a sound file in Adobe
Soundbooth.

r MP3 (*.mp3): Officially known as MPEG-1 Level 3 but more commonly
referred to as MP3. This sound format is commonly used for Internet
sound and portable audio players. Sound in this format is compressed.
The amount of compression (the data rate) determines the quality of
the sound. This format is acceptable for a music background with a data
rate of 128 Kbps and also works well for the spoken word. You can get
good results with an MP3 recording of the spoken word with a data rate
of 16 Kbps.

If you have QuickTime 4 or later installed, you can also import the following
file formats into Flash:

 Sound Designer 2 (*.sd2, Macintosh only): A sound format developed
for recording audio on Macintosh-based computers. This high-quality
sound format is capable of recording CD-quality sound.

» Sun Audio (*.au): A sound format created by Sun Microsystems for
Internet use. The file format is suitable for simple sounds and the
spoken word, but not for music.

1 System 7 Sounds (Macintosh only): Associated with the Mac OS7 oper-
ating system.

Understanding Bit Depths, Data Rates,
and Sample Rates

Whenever sound is recorded, a bit depth and sample rate are chosen. When
sound is compressed for playback, a bit depth and sample rate are also
chosen. These factors determine the quality of the sound, and the resulting
file size.
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Bit depth determines the dynamic range and signal-to-noise ratio of a digital
audio file. The dynamic range is the sound range in decibels that can be
reproduced when the sound is played back. The human hearing range is
approximately 100 decibels (dB). A 16-bit recording has a dynamic range of
approximately 98 dB. The signal-to-noise ratio is the amount of noise that
can be heard in soft passages. When you import a sound into Flash that has
a high bit depth, you end up with a sound that has a wide dynamic range and
a low signal-to-noise ratio.

Frequency, measured in hertz (Hz), is the number of cycles a waveform com-
pletes in one second. A frequency of [ Hz plays 1 sound wave or cycle per
second. The human range of hearing is from approximately 20 Hz to 20 kHz
(20,000 Hz). A fellow named Harry Nyquist came up with the theory that the
frequency needed to cover the range of human hearing is exactly double that
range. A fudge factor of 10 percent was added, which brings the frequency
to 44.1 kHz, the frequency commonly used to record CD-quality sound. TV
audio is 48 kHz, and DVD-quality audio has a frequency of 96 kHz.

When you’re choosing an audio file for a Flash project, the bit depth and fre-
quency are quite important. If you're importing a sound file for background
music, choose a 16-bit file with a 44.1 kHz frequency. If you're importing a
simple sound for a button, you can get by with an 8-bit file with an 11 kHz
frequency. For more complex sounds or a recording of the spoken voice, use
an 8-bit file with a 22.5 kHz frequency. For music, use a 16-bit file with a 44.1
kHz frequency.

Data rate is a factor when a file is compressed into a format such as MP3.
The data rate, also known as the bit rate, is the number of bits played back
per second. A low bit rate produces a small file size at the expense of sound
quality. For the spoken voice with no background music, a bit rate of 16
Kbps is acceptable, unless the person has a deep voice. FM radio quality is
96 Kbps, and near CD quality is 320 Kbps.

Stereo is something else to consider. Stereophonic sound consists of two
channels, which plays back in the left and right speakers of a stereo sound
system or a computer with a sound card that supports stereo. A stereo file is
twice as large as a monophonic (one channel of sound) sound file.

If you're not sure about the frequency and bit depth of a sound file, launch
Flash and choose Filec>Import to Library. After the file is imported to

the document Library, select it, right-click (Windows) or Control+click
(Macintosh), and then choose Properties. The properties of the sound file
appear to the right of the waveform (see Figure 1-1).

Book V
Chapter 1
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‘Sound Properties =
Wespon Whs 01103
C:\Program Files\Adobe\Adobe Flash
% s _ C54‘en\Configuration\sound
' boothimp3\Weapon Whips 01.mp3
Thursday, March 29, 2007 1:02:15 AM
44 kHz Mono 16 Bit0.25 21.2 kB
Compression: _EEEIB_L-ﬂt :\Zj
Stop

Will use publish setting: MP3, 16 kbps, Mano

Device sound: a Advanced

Figure 1-1: This sound file has properties.

Recording Hardware

If you record sound for your Flash productions or are considering recording
sounds for your Flash production, you should buy the best microphone you
can afford. Several microphone models operate from one of your computer’s
USB ports. This section presents a couple of solutions that will give you
good sound quality without breaking the bank.

Zoom H2

The Zoom H2 (type H2 in the Search box at www . samsontech. com) is a
handheld recording powerhouse with four microphones in an incredibly
small package. The device can record 16- or 24-bit sound files with a fre-
quency of 96/48/44.1 kHz uncompressed in the WAV format or in the MP3
format with a sample rate of up to 320 Kbps. Users can change the sound
format, frequency, and sample rate by using menu commands. Buttons on
the front of the recorder enable users to switch microphone configurations.
The unit can record a 90-degree pattern using two microphones from the
front of the unit, which is ideal for recording your own voice; a 120-degree
pattern using two microphones from the rear of the unit, ideal for recording
a group of people; or four microphones for 360-degree surround sound. The
sound quality is incredible.
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The Zoom H2 also doubles as a USB microphone. Simply plug in the supplied Book V
USB cable to the microphone and use a menu command to connect the H2 as  Chapter1
an audio input device, and you can use your computer recording software to
record your voice or sounds. In fact, Doug has used the Zoom H2 to record
podcasts. For field recordings, the unit uses SD (Secure Digital) memory
cards. The unit ships with a 512MB SD card, earbuds, a small tripod, a wind-
screen, a USB cable, a power adapter, and a handle that can be used to con-
nect the device to a microphone stand. As of this writing, the list price of the
Zoom H2 (see Figure 1-2) is $199.

olpny g3
fuipuejsiapufn

Figure 1-2: The Zoom H2 can be used for field and computer recordings.

Blue Snowball

Professional podcasters and radio personalities use condenser microphones
to produce sweet, rich vocals. Most condenser microphones need phantom
power to work. Blue Microphone’s Snowball (see Figure 1-3) is white and
round — just like a snowball — and is powered by your computer’s USB
port. The Snowball (click the Snowball link at the top of the page at www .
bluemic.com) is a professional-quality condenser microphone.
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It has two polar patterns — omnidi-
rectional (360 degree) and cardioid —
which records sound from the front of
the microphone. The cardioid pattern
is ideal if you're recording in an envi-
ronment with background noise such
as computer fans. There is also a car-
dioid pattern with a -10 dB attenuator
if you're recording in a noisy environ-
ment. The microphone records 16-bit
sound with a sample rate of 44.1 kHz.
The microphone needs no drivers.

Connect the Snowball to a micro-

phone stand using the thread mount

at the bottom of the unit, connect

the USB cord to the microphone,

and then to your computer. It’s as

simple as that. The Snowball works

with a Macintosh (OS X; USB 1.0 or .
2.0; with a minimum of 64MB RAM)

oron Wind'ows (XP Home Edition' OT  Figure 1-3: The Snowball condenser

XP Professional; USB 1.0 or 2.0; with microphone is ideally suited for computer

a minimum of 64MB RAM). The initial recording.

USB drivers for Windows Vista caused

some problems with this microphone.

If you perform a Windows update, the microphone will work just fine. Doug
uses the microphone with Vista to record his podcast. As of this writing, the
Blue Snowball has a list price of $159.

Blue Snowflake

Blue Microphone’s Snowflake is an ideal recording solution for road war-
riors. The Snowflake is small — toss it in your laptop case and it’s readily
available when you need to record on the road. The device can be placed
flat on a desktop or clipped to most laptop computers. The Snowflake is a
professional-quality condenser microphone in an incredibly small package.

The microphone has a cardioid pattern, which means that the device picks
up sound in front of the microphone. The Snowflake records 16-bit sound
with a sample rate of 44.1 kHz and needs no drivers. Connect the USB cable
to the microphone and then to your computer, and you're ready to record.
When you need to pack the microphone away, coil the USB cord, place it in
the base, and close it. You can also separate the base and attach the micro-
phone to a laptop computer (see Figure 1-4). This handy microphone is
about the same size as a classic iPod and works with a Macintosh (OS X;
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USB 1.0 or 2.0; with a minimum of 64MB RAM) or on Windows (Vista, Book V

XP Home Edition, or XP Professional; USB 1.0 or 2.0; with a minimum of Chapter 1
64MB RAM). For more information, visit www.bluemic.com and click the

Snowflake link at the top of the page. As of this writing, the Blue Snowflake
has a list price of $79.

olpny g3
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Figure 1-4: The Snowflake, a road warrior’s best friend.

Sound-Editing Software

After picking up a good microphone, you need software to capture your
words of wisdom and the sounds you record. Sound-editing software is also
useful when you need to edit files supplied by a client. In this section, we
show you three applications we use: Adobe Audition, Sony Sound Forge, and
Acid Music.

Adobe Audition

Adobe Audition (www.adobe.com/products/audition) is a full-featured
professional recording and sound-editing application. You can record
multiple tracks with the application, clean up existing audio, and edit your
projects. The software features several options. You can work in multitrack
mode or edit an individual track. The software has tools you use to analyze
a sound and much more. You can also restore noisy and clipped files. Doug
uses Audition to record and edit his podcast (www.pixelicious.info).
The workspace (see Figure 1-5) is fairly intuitive if you’'ve edited sound
before. As of this writing, Adobe Audition lists for $349.
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Track s

w | 000000 | 053555 || 0:53555

Figure 1-5: Edit and record sound with Adobe Audition.

Adobe Audition may be overkill for your needs. Adobe has another applica-
tion, Sound Booth, that’s targeted toward developers and designers with
little or no experience in sound editing. The application is tailored for work-
ing with Flash and other Adobe applications. As of this writing, the applica-
tion lists for $199.

<P When you record, make sure to use the VU meters that are available in most
applications. When you record, make sure that the VU meters don’t reach
the red zone. If you do, the peak of the waveform is flat, which means that
the sound is clipped and distorted.

Sony Sound Forge

Sony Sound Forge is another powerful sound-editing application. Sony Sound
Forge 9.0 (www . sonycreativesoftware.com/soundforge) features multi-
track editing. You can record, edit, restore old recordings, and do much
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more. As of this writing, Sony Sound Forge 9.0 retails for $299. If you don’t Book V
need the option to record multiple tracks, Sony Sound Forge Audio Studio Chapter 1
(www . sonycreativesoftware.com/audiostudio) may be the solution
for you. As of this writing, the application sells for $54.95. Figure 1-6 shows
the workspace for Sony Sound Forge 7.0.

Il Sony Sound Forge 7.0 - [CD-323328461-TRACKI17 (2) (96000 Hz).wav] SE[%]
{f File Edit View Special Provess Effects Tools DX Favorites Options Window Help BE

(D20 @@ yas888|aco|[FRea|
|0 @ P> W OKKD» M|
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Figure 1-6: You can record, edit, and repair sound files with Sony Sound Forge.

Sony ACID Music Studio (Windows only)

The Sony ACID Music Studio (www . sonycreativesoftware.com/music
studio) application enables you to create soundtracks using music sample
loops. The application supports multiple tracks and recording. When you
assemble a song in ACID, the loops seamlessly mix to create your sound-
track. If you have clients who can’t create their own soundtracks and you
have an ear for music, consider purchasing a copy of ACID Music Studio.
The application ships with 3,000 sound loops that you can mix and match to
create your own unique soundtracks. Doug uses Sony ACID to record back-
ground music for his podcast and Flash projects. Bill uses the Macintosh
equivalent: GarageBand (www.apple.com/ilife/garageband/). As of
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this writing, Sony ACID Music Studio sells for $54.95. You can purchase addi-
tional loops for most musical instruments in a wide variety of genres from
the Sony Web site (www. sony

creativesoftware.com/loops).

If you're on a budget, check out a cross-platform application called Audacity
(http://audacity.sourceforge.net). It’s not the prettiest interface on
the planet, but it does support multiple tracks and editing. There are also
plug-ins that enable you to export the sound in the MP3 format (http://
audacity.sourceforge.net/download/lame).



Chapter 2: Adding Sound
to a Flash Production

In This Chapter

+~ Importing audio to your projects
1~ Adding sound to your projects
1~ Adding sound to buttons

1~ Using ActionScript to load an external sound file or a soundtrack

It seems like every Flash movie has sound in it. Flash sites have back-
ground music playing, and buttons make noise when they’re clicked, for
example. If you want sound in your Flash projects, you've come to the right
place. In this chapter, we show you how to import audio, add audio to
keyframes, and add audio to buttons. Last but not least, we show
you how to use ActionScript to load a music soundtrack.

Importing Audio

If you want music in a Flash project, you have to
import it — it’s a Flash law. When you import
music to a project, you can import it to the Stage
or to the document library.

Cos00 0 : 0400 0450 0500 h

-
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To import a sound to the document library:

1. Choose Filec>Import~>Import to Library.

The Import to Library dialog box appears
(see Figure 2-1).

2. Select the file you want to import.

You can import any sound file format supported by Flash. If you don’t
have your sound assets organized in their own folder, you can save time
by choosing All Sound Formats from the Files of Type drop-down menu.
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When you choose this option, only supported sound files are displayed
in the dialog box. Alternatively, you can select a file format type from
the Files of Type drop-down menu to display only those files.

3. Select a file and then click OK.

The sound file is added to the document library.

“Import to Library <]
Look in | I SoundFX ] ©2 @
G]] 007.wav @] fire_truck_driving_away_in_echoey
,JI @l 11124901 WAV @ Fx-121_1.wav
Recent Q] AmbLoops. wav e] FX-148_1.wav
@] Bell_Ringing_(Several_&_Single).wav @] FXnoise 1. wav
— @] CAR-V6, TYRE_SKID_SQUEAL (44100 Hz).wav @] lights_traffic.wav
La (@] CAR-V6,_TYRE_SKID_SQUEAL.wav (EllLow_zip_up.wav
Deskiop @] Deep_Amb_003.wav @_] Magic_Wand_4 (2).wav
@] Deep_Tube.wav @] Magic_Wand_4.wav
Gj] digital_camera_turn_on.wav @] open_botte. wav
@] digtal_stretch.wav @] Pass_Thru_JO.wav
it Daciuiis @] doppler_whoosh (2).wav Gﬂ quicky_in_cheap_motel.wav
@] doppler_whoosh (2. 1).wav @] RallingIntoSpace. wav
(a‘]dupplar_whoush‘wav e]sndsdml.mpS
;;] @] Earthquake.wav @] Whoosh_Martial_D1.wav
- C a @F1 BR_07_1eraV.wav
omputer
* (£ Im | [=]]
File name: | |VI [ Open ]
My Network | Files of type | A1 Formats [v] [ Cancel |

Figure 2-1: Importing a sound file to the document library.

To add a sound to the Stage, follow these steps:

1. Select the keyframe where you want the sound to appear.

You can select a keyframe on the main Timeline, a Timeline for a movie
clip you're creating, or the keyframe for a button you’re creating. If you
select a frame, Flash adds the sound to the previous keyframe.

2. Choose FilemImport~>Import to Stage.

The Import dialog box appears (see Figure 2-2).
3. Select the file you want to import.

You can import any sound file format supported by Flash.
4. Select a file and then click OK.

The file is imported to your project, and a waveform appears in the key-
frame (see Figure 2-3).
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Figure 2-2: Importing a sound to the Stage.
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Figure 2-3: A sound imported to a keyframe.

Using Sound in a Project

After you add some sound files to the document library, it’s time to put them
to work. You may think that you can just plop a sound file on the Timeline
and be done with it. But no, you have to tell Flash how to synch the sound

to the Timeline. Then you decide whether you want the sound to play more
than once or when you want it to stop, for example. It’s not rocket science,
but if you’'ve never done it, you've come to the right section of the book. In
the following sections, we show you how to use sound from the document
library, choose the proper method of synching the sound, and add sound
effects if you want them.
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Adding a sound from the document library

Unless we'’re using ActionScript to load a sound file, we always add our
sounds to the document library and then add them to the project. We

find this method to be a better way to work than importing sounds to the
Timeline when you suddenly remember that a sound is supposed to play
on Keyframe 6. To add a sound from the document library to your project,
follow these steps:

1. Select the keyframe where you [ properties
want the sound to appear.

Frame
You can select a keyframe on the ’T
main Timeline, on a Movie Clip o
symbol you’re creating, or on = LABEL
a keyframe for a button you're

MName: |
creating. If you select a frame by =
mistake, Flash adds the sound to Tyoc (Naine LY
the previous keyframe. < SOUND
2. Open the Property inspector. Name: | None | * |
If the Property inspector isn’t Effect: | lone AR
visible in the workspace, choose &ync: | Event [

Windowr>Properties (see
Figure 2-4).

3. In the Sound section, select a
file from the Name drop-down
menu.

| Repeat =] % 1

No sound selected

Figure 2-4: Adding a sound from the
On this menu, you find a list of ~ documentlibrary.

all sounds you’ve imported to the

document library.

4. Select an option from the Effect menu.
We cover effects in the “Adding Sound Effects” section of this chapter.
5. Select an option from the Sync menu.

We cover these options in the “Synching sound” section, later in this
chapter. After you add a sound to a keyframe, the sound’s waveform
appears on the Timeline.

Synching sound

After you add a sound to your project, you have to determine how Flash
synchronizes the sound to the Timeline. You have several different options
to consider. These options determine how the sound file plays in relation to
your movie. To synchronize a sound, follow these steps:
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1. Add a sound to the Timeline from the document library or by import-
ing a sound to the Stage.

If you jumped to this part of the chapter before reading anything else
and you don’t know how to add a sound to the Timeline, put on the
brakes and read the earlier sections “Importing Audio” or “Adding a
Sound from the document library.”

2. Choose one of the following options from the Sync drop-down menu:

e Fvent: Plays the sound when the keyframe is reached and plays the
sound in its entirety. The sound plays again when the keyframe is
triggered. This may cause a problem if you add the sound to the
Timeline of a looping animation and the duration of the sound is
longer than the duration of the animation. The sound plays again,
even though the first instance of the sound hasn’t stopped playing.
This sync method is best suited for sounds that have a short dura-
tion, such as the sound you add to button keyframes.

e Start: Starts the sound when the keyframe is reached. However, it
doesn’t play again if the keyframe is reached before the sound stops

playing.

e Stop: Stops the sound when the keyframe is reached. This option
works well when you want a sound to stop on a given frame.

e Stream: Starts playing the sound as soon as enough frames have
downloaded into the viewer’s Flash Player. This option causes the
Flash Player to skip frames if the animation cannot keep up with the
streaming sound. If an animation in the movie stops while the sound
is playing, the sound stops too. A streaming sound stops playing if its
duration exceeds the number of frames in the movie.

3. Choose an option from the Sound Loop drop-down menu that’s right
below the Sync menu.

The default option, Repeat, enables you to determine how many times
the sound plays. After choosing this option, drag the scrubby slider to
determine how many times the sound plays, or click the current value
and enter a different one. Alternatively, you can choose Loop from the
menu and the sound loops infinitely. Looping isn’t recommended for
streaming sounds because it adds frames to the file to play the sound
for the number of times you specify, which can significantly increase the
file size.

Adding sound effects

By default, the sound plays out of both speakers. Can you say stereo? We
knew you could. However, by adding a sound effect, you can have the sound
play in the left channel or right channel, or cross the great divide from right
to left, or vice versa. Intrigued? Follow these steps:

Book V
Chapter 2
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1. Add a sound to the Timeline from the document library, or by import-
ing a sound to the Stage.

If you don’t know how to add a sound to the Timeline, read the earlier
sections “Importing Audio” or “Adding a sound from the document
library.”

2. Choose one of the following options from the Effect menu:
e None: The default option; applies no effect to the sound
e Left Channel: Plays the sound in the left speaker of the host computer

e Right Channel: Plays the sound in the right speaker of the host
computer

e Fade to Right: Gradually fades the sound to the right speaker of the
host computer

e Fade to Left: Gradually fades the sound to the left speaker of the host
computer

e Fade In: Gradually increases the volume of the sound through its
duration

e Fade Out: Gradually decreases the volume of the sound through its
duration

e Custom: Lets you tweak the sound to your liking. If you're a custom
kind of person, check out Chapter 3 of this minibook.

Adding Sound to Buttons

Button sounds are quite common in Flash movies. You can have a sound
play when a user pauses the cursor over the button or clicks the button. To
add a sound to a button, follow these steps:

1. Create a button.

We know — we haven’t covered buttons yet. If you don’t know how to
create a button, please bookmark this page and check out the section in
Book VII, Chapter 1, about creating buttons.

2. Right-click (Windows) or Ctrl+click (Mac) and choose Add Layer from
the context menu.

Flash creates a new layer. While you're at it, be neat and tidy. Double-
click the current layer name to select it, and then enter Sound. Even on
a simple two-layer Timeline, it pays to be tidy and label your layers.

3. Select the Over keyframe if you want a sound to play whenever a user
pauses the cursor over the button; or select the Down frame if you
want a sound to play when the button is clicked.
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4. Press F6 to create a keyframe.

You can have a sound play for both states. Just make sure that the
sounds are short in duration.

5. Open the Property inspector.

6. In the Sound section, choose a sound from the Name drop-down
menu.

This menu shows every sound you imported into the document library.
If you haven’t imported any sounds, choose Filew’ Import to Stage and
follow the prompts to select the file and open it.

7. Accept the default Event option from the Sync menu.

Figure 2-5 shows the Timeline of a button to which a sound has been
added to the Over state.

TIMELINE
% @ [0 Up |Over |Down Hit
= v T e — |
&l Graphic « e Wl | » |
al o F faEasils Dok ols FI] Wy

Figure 2-5: Adding a sound to a button’s Over state.

8. Press Ctrl+Enter (Windows) or 88+Return (Macintosh).
Flash publishes the movie and displays it in another window.
9. Pause the cursor over the button.

The sound plays. Of course there’s more to a button than just graphics
and sound. In Book VII, Chapter 1, we show you how to create a button
and how to create the ActionScript code that makes the button functional.

Using the Flash Sounds Library

Flash CS4 ships with an impressive library of sounds. When you need to
find a sound for a button or an animation you need, look no further than the
sounds library. To use a sound from the sounds library, follow these steps:
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1. Choose Window=>Common ﬁ
LIBRARY - SOUNDS.FLA

Libraries>Sounds. v
The sounds library appears (see S
Figure 2-6).
2. Select a sound and then click 195 fers o
the Play button to preview the | n=- ~ | Linkege
Souﬂd. «]< Emergency Siren Police Yelp From ... -

€}~ Explosion Blast Large 01.mp3

You hear the sound unless your SRS ORI DA e
€]* Foley Footstep Cowboy Boots Ru... —

Speakel'S are mUted' &}~ Foley Footstep Playing Basketball...

«J% Foley Metal Drag Through Dirt An...

3. Drag the sound to the document | ;..o whipping o1.mes

libral'y. &} Foley Movement Wood Slide Thro...
] Foley Sucked Air Out.mp3
The Sound iS added to the dOCU' ] Foley Table Drop Into Place Plasti...
ment libraYY. €] Foley Table Fist Hits Wood Table ...
€]~ Horrar Scary Human Female Screa...
4‘ Drag the sound to a keyframe_ €< Household Bongo Hit Large Drum ...
£]% Household Broom Sweep Multiple ...
After add]ng the sound to %}% Household Button Beep Microwav...
your prOjeCt, Choose a SyHC a@f Household DeodorantSD.ray Fizzle..
. &) Household Door Close Microwave...
Optlon and an effeCt' FOr more %2 Household Door Front Door Close...
information about SynChrOniZ- &]% Household Door Knodk Hollow Do...
ing Sounds, see the “Synching %}~ Househald Door Wood Door Sgue...
9 . . . . €% Household Dry Eraser On Dry Eras...
sound” section, earlier in this ; :
&) Household Faucet Bathroom Sink ...
chapter. For more information %)% Househald Light Switch Click 0n 0.
about sound events, see the i gl T 5
Adding Sound Effects section of
this chapter. Figure 2-6: A library with sounds? Isn't that an

oxymoron?

Use ActionScript to Load
an External Sound File

The ActionScript sound classes make it possible for you to load an external
sound file into Flash, which enables you to keep the file size of your movie
relatively small. In this section, we show you the code needed to load the
sound file and to start and stop the movie. The ActionScript is loaded from
external ActionScript files. We make the ActionScript files (AS3_Sound.zip)
available from this book’s companion Web site at www.dummies.com/go/
flashallinone.

To load an external sound file using ActionScript, follow these steps:

1. Choose Filer>New.
The New Document dialog box appears.
2. Accept the default ActionScript 3.0 file type and click OK.

Flash creates a new document.
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. Add two buttons to the document.

For the purpose of this example, choose Window=>Common
LibrariestoButtons. Choose a Play and Stop button from the Playback
Flat group on the Stage.

4. Select the Play button and then open the Property inspector.

5. Name the button instance start.

This is the name of the button instance as it will be addressed from the
external ActionScript files.

. Select the Stop button, and in the Property inspector, name the button

halt.

It’s a rather logical name for a button that stops a sound file.

. Save the file.

When you save the file, name the file DoSound. Leave the document
open.

. Choose File>’New and choose ActionScript File from the Type menu.

A file named Script-1 appears, and the Actions panel occupies the work-
space.

. Enter the code from Listing 2-1 in the Actions panel.

If you downloaded the ActionScript files, you can copy and paste the
code from SoundPlayer.as into the Actions panel. Alternatively, you
can open the file in Flash.

Listing 2-1: The SoundPlayer ActionScript Code

package

{

import flash.display.Sprite;
import flash.media.Sound;

import flash.media.SoundChannel;
import flash.net.URLRequest;

public class SoundPlayer extends Sprite
{

private var soundCh:SoundChannel;
private var soundReq:URLRequest;
private var soundSource:Sound;

public function SoundPlayer (url:String)
{

soundReg=new URLRequest (url);
soundSource = new Sound() ;
soundSource. load (soundReq) ;

}

(continued)
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Listing 2-1: (continued)

10.

11.

12.

public function playSound() :void
{

soundCh=soundSource.play () ;

}

public function stopSound() :void
{

soundCh.stop () ;

}

}

Save the file.

Name the file SoundPlayer. Flash automatically supplies the . as
extension.

Choose File>New and choose ActionScript File from the Type menu.

A file named Script-2 appears, and the Actions panel occupies the
workspace.

Enter the code from Listing 2-2 in the Actions panel.

This bit of code plays and stops the music file when the appropriate
button is clicked. Alternatively, you can cut and paste the code from the
DoSound. as file you downloaded.

Listing 2-2: The DoSound ActionScript Code

package

{

import flash.display.Sprite;
import flash.events.MouseEvent;

public class DoSound extends Sprite
{

private var soundNow:SoundPlayer;

public function DoSound ()

{

start.addEventListener (MouseEvent.CLICK, turnOn)
halt.addEventListener (MouseEvent.CLICK, turnOff)
soundNow=new SoundPlayer ("mySoundFile.mp3");

}

private function turnOn(e:MouseEvent):void

{

soundNow.playSound () ;

}

private function turnOff (e:MouseEvent):void

{

soundNow. stopSound () ;

}
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14.

15.

16.

17.

Using ActionScript to Load a Soundtrack 381

In the line that starts with soundNow=new SoundPlayer, select
mySoundFile.mp3, and replace the text with the name of your sound
file.

Make sure to include the extension in the filename. Also make sure that
the file is in the same folder as the ActionScript files and the DoSound.
fla document.

Save the file.
Name the file DoSound. Flash automatically supplies the . as extension.
Select the DoSound.fla title.

If you closed the document, choose File=>Open, navigate to the file, and
then open it.

Press Ctrl+Enter (Windows) or 3#8+Return (Macintosh).
Flash publishes the file and opens the movie in a new window.

Click the buttons to start and stop the music.

Using ActionScript to Load a Soundtrack

Back in the Jurassic period of Flash, you created a movie with nothing but

a soundtrack and then loaded that soundtrack movie into a target movie

clip in your main movie. However, with a bit of ActionScript, you can load a
soundtrack into another file. This is an excellent option if you don’t own a
sound editing application. You can optimize the sound in Flash as outlined in
Chapter 3 of this minibook. Whenever you load content from an external file,
the main file is as small as possible, which means that it loads quickly. To
load a soundtrack from an external source, follow these steps:

1. Create a new Flash document.

2. Open the Property inspector.

3. Change the background color to the same color as the document in

which the sound file will play.
Change the W and H values to 1.

You're creating a 1-by-1-pixel file that will nestle in a corner of your main
Flash movie.

Select the first keyframe and choose File=>Import=>Import to Stage.

In the Open dialog box, navigate to a sound file and then open it.
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10.

11.

12.

13.

14.
15.

. In the Property inspector, accept the default Event Synch method, and

choose Loop from the Sound Loop menu.

. Select the sound in the document Library, right-click (Windows) or

Ctrl-click (Mac) and choose Properties.

This opens the Sound Properties dialog box.

. Accept the default compression option, or choose a different option

from the Compression drop-down menu.

To find out everything you ever wanted to know about optimizing a
sound in Flash, check out Chapter 3 of this minibook.

Name the document and save it.

We prefer using short names, like sndTrk. Remember that you’ll end up
writing ActionScript to load the file. Why work harder?

Choose File~>Publish.

Flash publishes an HTML file and an SWF file with the name you specify
in Step 7.

Create a new Flash document.

Alternatively, open another Flash file in which you want to play a back-
ground sound.

Select the first keyframe.

Typically, you want the sound to load as soon as the file opens in the
user’s Flash Player.

Choose Windowr>Actions.

The Actions panel opens.

Copy the code from Listing 2-3 into the Actions panel.
Press Ctrl+Enter (Windows) or 38+Return (Mac).

The soundtrack loads and plays.

Listing 2-3: Loading an External Movie with a Sound File

var sound:Loader;
var url:URLRequest;

sound=new Loader () ;

url=new URLRequest ("pixelicious.swf");
sound.load(url) ;

sound.x=0, sound.y=0;

addChild (sound) ;
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16. Press Ctrl+Enter (Windows) or 38+Return (Mac). Book V
The soundtrack loads and plays. But you need some way to turn off the Sick2
sound for those who think that silence is golden. -

17. Choose Window=>Common Libraries=>Buttons. g §
The Buttons library appears. '3":2:

18. Select a button and drag it on stage. g §_
For the purpose of this example, choose any button. If you do this tech- = f

nique for your own Flash movies, you can create a spiffy button.
19. In the Property inspector, name the button instance btn.
ActionScript needs to address the button by name.
20. Select the first frame on the timeline.

If you've followed the steps so far, this is where your ActionScript
resides.

21. Add the code in Listing 2-4.

This code causes the sound to unload when clicked.

Listing 2-4: Silencing the Sound

btn.addEventListener (MouseEvent.CLICK, removeSound) :
Function removeSound (e:MouseEvent) ;void

{

Soujnd.unloadAndStop () ;
}

22. Press Ctrl+Enter (Windows) or 88+Return (Mac).
The sound loads and plays.

23. Click the button.
Ah. Peace and quiet.
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Chapter 3: Editing Sound Files

In This Chapter

»» Optimizing sound in Flash

1~ Editing sound files in Flash

f you don’t have sound editing software, you can still do a lot of work

in Flash. All you need to do is change some properties in the document
library and you can tweak the sound file to sound its best, while also creat-
ing a relatively svelte Flash file. The compression method and sampling rate
affect the file size of the published SWF file. Tweaking the properties of indi-
vidual sounds results in files that sound good and are as small as possible.
You can also modify effects you apply to sounds, such as the duration of a
fade-in or fade-out or panning from one speaker to the next.

Optimizing Sound for Your Project

If you don’t have sound editing software, you can
accomplish quite a bit in Flash. You can’t eliminate
background hiss, or slice and dice a sound file to
cut out the bits that don’t sound good, but you
can find the optimal compression method and set-
tings. You can optimize sound globally when you
publish a file. (We cover optimizing sound when
publishing a document in Book VIII, Chapter 4.)

You can also optimize individual sounds by modi-
fying their properties in the document library.
When you modify a sound’s properties there, the
published sound settings aren’t applied. To opti-
mize an individual sound file, follow these steps:

1. Choose Window=>Library.
The document library opens.

2. Select the sound you want to edit, right-click (Windows) or
Control+click (Macintosh), and then choose Properties from the
context menu.

The Sound Properties dialog box appears (see Figure 3-1).
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‘Sound Properties
Exit_Edited_01.wav
e k-

Gl \\Das-0034d\Online Projects\PixelidousLoura

Townsend Voiceovers\Exit_Edited_01,wav

b Wednesday, March 12, 2008 10:51:16 AM
44 kHz Stereo 16 Bit 10.6 5 1874.2kB
Compression: EEE!’B_Lﬂt :V_[

Stop
Will use publish setting: MP3, 16 kbps, Mono

Device sound: a

Figure 3-1: Modifying the properties of a sound.

3. Choose one of the following options from the Compression drop-down
menu:

e Default: Uses the settings specified in the Publish Settings dialog box
to compress the sound file on export.

e ADPCM: The option to use when optimizing button and small event
sounds.

e MP3: The option to use when optimizing background music.

® Raw: Uses the compression settings from the raw data of the
imported files. You can apply compression settings by modifying
the sample rate. The sound quality is similar to MP3, but results in a
larger file size.

e Speech: Uses settings appropriate for a sound file of a speaker with
no background sound.

4. If the default option is available, accept it to convert stereo to mono.

This option decreases the file size because you're not exporting data
for two sound channels. Deselect this option if you're creating a Flash
movie for a musician’s Web site or for another site where stereo sound
is important.

5. Choose settings in the Preprocessing section of the dialog box.

The available settings differ depending on the compression setting you
choose. The following list offers some guidelines for the compression
options that have preprocess setting options:
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e ADPCM: Choose an option from the Sample Rate drop-down menu.
For this format, you can choose a setting from 5 kHz (poor sound
quality, smallest file size) to 44 kHz (best sound quality, largest file
size). You can also choose an option from the ADPCM Bits drop-
down menu. Choose from 2 bits (poor sound quality, smallest file
size) to 5 bits (best sound quality, largest file size). These two
options determine the data rate of the sound.

e MP3: Choose an option from the Bit Rate drop-down menu. You can
choose an option from 8 Kbps (poor sound quality, smallest file size)
to 160 Kbps (best sound quality, largest file size). You can also choose
an option from the Quality menu: Fast, Medium, or Slow. This option
determines how long Flash takes to compress the file. Slow takes the
longest time to process, but produces the best sound fidelity.

When you initially apply com- Sound Properties
pression settings to an MP3 file, it Edted OLwav
choose the Fast Quality option, e e il
as shown in Figure 3-2. It speeds ||, .. ... s, e 12 o0 0515

up publishing the file when o sl

you're testing your Flash project. | comsesson: [res [¥]

When you're satisfied with the =
file and ready to publish, open Preprocessing: [Z]comert stereo tomono

the Sound Properties dialog box = ‘:‘:I‘

for tl}e souqd and change the TS

Quality setting to Best. o -

e Raw: Choose an option from
the Sample Rate drop-down Figure 3-2: Optimize me, baby.
menu. You can choose from
5 kHz (poor sound quality,
smallest file size) to 44 kHz (best sound quality, largest file size).

e Speech: Choose an option from the Sample Rate drop-down menu.
Your options are from 5 kHz (poor sound quality, smallest file size)
to 44 kHz (best sound quality, largest file size).

6. Click Test.

Flash applies the compression settings to the sound file and plays it. At this
stage, we experiment with different settings. When you’re applying com-
pression settings for an individual sound, remember the reason that you're
using the file in your project. If it’s a simple sound, like a button click, you
can apply more compression. If you're creating a site for a public speaker or
a musician, applying too much compression results in poor sound quality
and doesn’t showcase your client’s talents. If you're optimizing a long sound
file, click Stop when you’ve heard enough to determine whether the settings
are optimal for the file. Figure 3-2 shows a sound file being optimized using
the MP3 compression option. Notice the new file size as compared with the
original, which is displayed below the Quality setting. This information is in
the same spot in the dialog box for the other compression options.
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Editing Your Sound Files

When you import a sound file into Flash, you still have the option to edit the
file. When you add the sound to the Timeline, you have the option to apply
an effect to the sound. You can edit the manner in which the effect is applied
or choose the Custom option and then edit the file. If you have sound editing
software on your computer, you can make a round trip to the sound editor
from Flash.

Editing sound in Flash

When you add sound to a keyframe, you can apply an effect to the sound in
the Property inspector, as we outline in Chapter 2 of this minibook. You can
also edit the effect that’s applied to a sound:

1.
2.

Select the keyframe to which you applied the sound.
Open the Property inspector.

Click Properties to open the Property inspector. If you customized the
workspace or are working with a workspace that doesn’t display the
Property inspector, choose Window=>Properties.

. Click the Edit button that looks like a pencil.

The Edit Envelope appears. If you already applied an effect to a sound,
it’s listed in the Effect field. If the effect changes the volume of the sound
as it plays, you see points. Figure 3-3 shows the dialog box with no effect
applied. Notice the hollow square at the start of each Timeline. It signi-
fies that the sound plays at full volume in each speaker.

. Change the view of the waveform.

Click the icon with the magnifying glass and the plus sign to zoom in, or
click the icon with the magnifying glass and the minus sign to zoom out.

. Change the manner in which the Timeline is displayed.

The default option displays the Timeline in seconds. If the sound spans
multiple frames and you want to synchronize an edit with a frame, click
the Frames icon to display the Timeline as frames. Personally, we found
the frames option difficult to use, but try it — you might like it.

. Click the Timeline at the point where you want to make a change.

This step adds a hollow square to each Timeline.

Drag a point to modify the amplitude (volume) of the sound at that
point in its duration.

You can edit the left and right speaker Timelines independently. This
gives you the option to pan from the left to right speaker or vice versa.
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Edit Envelope
Effect: None )

O e e g
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Play Zoom Qut | |Frames
Stop Zoom In Seconds

Figure 3-3: Editing a sound in Flash.

8. Add points to the Timeline and modify them as desired.

If you added a point in error, click it and then drag it off the Timeline.
You can add as many points as you need to get the job done.

9. Click the Play button to preview  [FtEnsiss = — 4
your handiwork. e =

[
The sound starts playing. You can " 2 oo opee— il
stop the preview by clicking the

Stop button. Figure 3-4 shows a e s
sound that pans between speakers,

plays in both speakers, and then F ' e -
fades out evenly from both speak-

ers. Notice that we zoomed out - T
on the waveform to view it in its -

entirety. Figure 3-4: A sound that has been edited

in Flash.
If you don’t have a sound editing appli-

cation installed on your computer and
you like sound, we urge you to experiment with the different effects you can
produce by using the Edit Envelope dialog box.
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Editing in an external editor

If you have Adobe Soundbooth installed on your computer, you can access
the application by selecting a sound file the document library and then
choosing Edit with Soundbooth. You can also edit a sound in an external
sound editor by following these steps:

1.
2.

\NG/
&V%“

Select the sound in the document library.

Right-click (Windows) or Control+click (Macintosh) and choose Edit
With from the context menu.

The Select External Editor dialog box appears.

Navigate to the executable (. exe) file that launches the external
editor you want to use.

For example, if you have Adobe Audition installed on your computer, the
executable file that launches the application is Audition.exe.

. After selecting the executable file, click Open.

The external sound-editing application launches.

. Perform any edits you want, and then save the file.

After you save the file and return to the Flash document library, the
sound is updated to reflect your changes.

When you edit a sound in an external sound-editing application, you're
modifying the original file. Make sure that you have a copy of the original file
saved in a different folder.
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Fash works with video on many different
levels. You can embed videos directly into a
Flash application, progressively download a Flash
Video File (FLV) from a Web server, or stream an
FLV file from Flash Media Server. The ability to
work with video on the Web is a major capability
for Flash and anyone developing for the Web.

Book VI shows you how to convert video files
from different video formats into both VP6 FLV
and H.264 F4V files by using Adobe Media Encoder
(included with Flash CS4). You also find out how
to play those videos using a video player compo-
nent or a player you create yourself in a Flash
application or with the new Adobe Media Player.
We show you how to add cue points and captions
to your video for special effects. You even dis-
cover how to broadcast a live video and make an
audio/video receiver to view the broadcast.
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Chapter 1: Playing Uideo with
Flash: The Producer’s Chair

In This Chapter

1~ Working with Web video

+» Embedding video in Flash
+ Understanding progressive download

1+~ Becoming familiar with streaming video

Of all the revolutionary technologies now available with Adobe Flash
CS4, the most dramatic is the ability to send video over the Web.
Although Web video has been available for a few years, creating Web sites
with high-quality display, including high-definition (HD) video, is just now
coming to the forefront. You can create videos that use H.264
(MPEG+4, among others) format for spectacular results at a
reasonable bandwidth. Using the built-in FLVPlayer com-
ponent and other tools available in Flash CS4, you can
create a Web site that sends video to the viewer just
like Flash has delivered animation, text, sound, and
graphics. The big difference is that all these ele-
ments are combined into a single audio/video file
that can be sent smoothly over the Web.

What Is Web Video?

If you've visited YouTube (www.youtube. com),

you’ve seen Web video. In fact, if you've gone to a site =
such as http://movies.com, you've seen movie trail- v
ers done with streaming video. Even some business sites,

such as www.sandlight.com, feature streaming video presen-
tations.

If you want to know whether Flash was used to create a Web video, visit
YouTube or a favorite site that has movie trailers you can watch online, and
right-click a video (Windows) or Option-+click it (Mac). If Flash was used to
create it, you see About Adobe Flash Player at the bottom of the shortcut
menu, as shown in Figure 1-1.
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You may have several kinds of expe-
riences with Web video, such as the
following:

1 Download an entire movie file
to your computer and play that
movie in a player that recognizes
the file type.

Windows Media Player (which
you can also download and use
on a Mac) allows you to view
files with the extension .wmv,
for example. You can also use
QuickTime Player (which comes
with most Macs and is also avail-
able for Windows) to play files

. ; Figure 1-1: Find Flash information on a video’s
with the .mov extension.

shortcut menu.
1 View a podcast in iTunes.

 Click a button to play a movie embedded in a Web page that eventually
plays on your computer.

If your experience has been primarily with downloaded files, some of which
you may have received through e-mail, you’re aware that video can be sent
over the Internet. But that isn’t the kind of video we’re talking about in this
minibook. Instead, we mean the video that plays as soon as you open the
page (or when you click the Play button on the page).

In this chapter, we look at different ways to send video over the Web with
Flash CS4.

Embedded Uideo in Flash: Old School

For as long as we can remember, certain types of video files have been
embedded in Flash. Flash treated each frame as a JPEG file and ran through
the JPEG files just like frames of a regular movie, with fairly good results.
The consequence, however, was that an SWF file with embedded video was
huge. Viewers were forced to wait patiently until the giant file loaded, and as
often as not, they probably hit the Back button in their browsers and left the
file for more patient souls to view.

If you have a short video, however — perhaps a welcome message or a loop
of a dumb dog trick — you may be able to include it in a Flash file. This is a
quick solution for a specific purpose, however; for the most part, you don’t
want to embed video in Flash.
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Converting a video file for use in Flash

To start, you need a video file. Flash CS54 uses FLV and F4V files — highly com-
pressed file types that take up little space on the server. Chapters 2 and 3 of
this minibook provide information about converting different video file types
to FLV or F4V.

Figure 1-2 shows a sample AVI file that was recorded on a Webcam, with

a background added in Adobe Ultra. The AVI file was shortened and then
exported as a small FLV file because only small files in FLV format work for
embedded video. (You can download this AVI file from the book’s compan-
ion Web site at www . dummies.com/go/flashallinone.)

Book VI
Chapter 1
| siteHello.avi
o
giz
252
=3
e za
N = s
[x N
Sde
2e°
=

[ 00:00:01 T ]

“w—Q )

Figure 1-2: To work as an embedded video, your original video
has to be shortened significantly when it's converted to a FLV file.

The AVI file was shortened and then exported as a small FLV file for this
demonstration. Only small files and ones set to FLV format work with
embedded video.

Embedding the video in a Flash file

To embed the video in a Flash file, follow these steps:

1. Open a new Flash file.
2. Add a graphic background for your movie (see Book I, Chapter 2).

Figure 1-3 shows a sample background.
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Embedded.fla® % |

#5 Scene 1 & & o

' WELCOME ‘

Figure 1-3: A backdrop helps you visualize where the video will appear.

3. Choose Filec’Import->Import IO Edt View Insert M
Video (see Figure 1-4). e e
. . Browse in Bridge X80
The Import Video dialog box Open Recent >
opens, displaying the Select i ..
Video page. Save s
Save and Compact
4. Choose the Embed FLV in SWF Save As... o8s
. . . . Save as Template...
and Play in Timeline radio
button (see Figure 1-5), and iy
then click the Browse button to - e e
locate the FLYV file to embed. Export »| Import toLibrary..
Publishatangs. . Cliplmtpen Edema Liian. o d a0
Q&N\BER The warning message in the Publish Preview > Lo
& Select Video page tells you that i ane
an embedded video is likely to :
cause audio synchronization o
issues, so keep audio short or e
’ Pr!nt Margins...
leave it out when you’re embed- Print... i

ding a video.
Figure 1-4: Start the video import process.
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l_mE_ ort Video

Select Video

Where is your video file?

® On your computer:

File path:

() Load external video with playback component
) Embed FLV in SWF and play in timeline
O Import as mobile device video bundled in SWF
() Already deployed to a web server, Flash Video Streaming Service, or Flash Media Server:
URL:

Examples: http://mydomain.com/directory/video.flv BODk VI
rtmp:/ /mydomain.com/directory/video.xml Chapter 1

WARNING: Embedded video s likely to cause audio synchronization issues. This method of importing video is ONLY recommended
for short video clips with no audio track.

Learn about Embedded Video

Launch Adobe Media Encoder

Go Back Continue ) (_ Cancel )
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Figure 1-5: Setting the Embed option in the Import Video dialog box.

5. After you select your video, click the Continue button.

The Embedding page opens. By default, the Symbol Type pull-down
menu is set to Embedded, and both check boxes — Place Instance on
Stage and Expand Timeline If Needed — are selected.

6. To accept these default settings, click the Continue button.
The Finish Video Import page opens (see Figure 1-6).

7. If the selected video is the one you want, click the Finish button; oth-
erwise, click the Back button (Windows) or the Go Back button (Mac)
and load the correct files, as shown in Step 3.

8. When you see the video on the Stage, adjust its placement by dragging
it or using the Align panel.

Figure 1-7 shows an example of what you may see. Notice that the
piece of video you see is considerably smaller than the video shown in
Figure 1-2, earlier in this chapter.
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0 :

Finish Video Import

The video you are using is located at:
fUsers /billsanders Desktop/temphide/AIO Book/AlO-video/Ch01/siteHello.flv

The video will be placed on the stage.

The timeline will be ded to acc date the playback length.

"] After importing video, view video topics in Flash Help

( GoBack ) (Finish ) ( Cancel )

Figure 1-6: The final page before video is embedded.

Embedded.fla” X

£ Scene 1 £ & 100x

WELCOME

Figure 1-7: The first frame of the video appears on the Stage.
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Essentially, this process cuts the video into separate frames and displays
them in a fashion similar to setting a separate JPEG files in each frame. This
video can be looped just like any other movie, or it can be stopped and
started with ActionScript 3.0.

After you test your Flash application, see how big your SWF file is. In our
test of the example embedded video used in this section, the file is 205KB.
Considering that the video is only a few seconds long, that file is a large
one. Users with slow Internet connections may become impatient as this file
loads. Before you decide to use this method for even a small movie, look at
the next section for a much smarter alternative.

Book VI
Chapter 1

Progressive Downloading: Almost Streaming
from a Web Server

As we note earlier in this chapter, using embedded video is appropriate in
only a few situations. In fact, any video more than a few seconds long may be
automatically blocked by Flash when you attempt to embed it in Flash CS4.
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An alternative method for displaying video on a Web site — progressive
downloading — is just as easy and generates a much smaller SWF file. In fact,
a 10-minute video using progressive download generates the same-size SWF
file as a 5-second video, and the size of the video played doesn’t affect the
size of the player.

Understanding progressive downloading

Progressive downloading uses a Web server, just as a regular HTML or SWF
file does. The FLV or F4V file is downloaded in packets, and as the client
(browser) begins receiving those packets, the content is displayed in the
video player.

Imagine that the FLV file is like a big stack of pancakes. Instead of delivering
all the pancakes in one big stack, in progressive downloading, the server
delivers the pancakes one at a time. After a few pancakes are delivered, the
server begins to display the pancakes until the whole stack is visible. The
video appears to show a growing stack of pancakes, but in fact, the pancakes
are graphic images shown in sequence to give the illusion of movement.

Q&N\BEH Progressive downloading is often confused with video streaming or even

>y called HTTP streaming. Progressive downloading is not streaming, however.
When you use progressive downloading, the video file is actually down-
loaded to your computer and can be extracted from the browser’s tempo-
rary cache storage. In actual use, you may not be able to tell the difference,
especially in short videos, but the difference is real — as you see in the sec-
tion “Streaming Video: Leaving the Socket Wide Open,” later in this chapter.
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Creating a progressive download

Creating a progressive download in Flash CS4 is as easy as pie; so get out
your director’s chair and get ready to produce your first Web-length feature.

Preparing the folder and files

To start creating your progressive download, follow these steps:
1. Create a new folder.
You use this folder to save the FLA and SWF files for this application.

2. Locate the F4V file you want to use.

For this example, we used the file named blackBill. f4v. (It’s avail-
able for downloading from this book’s companion Web site.)

3. Open a new Flash file and create a background to your taste, leaving
an area in the center (approximately 330 by 270 pixels) for the video
player.

Figure 1-8 shows an example using an art deco theater motif. (The color
scheme is a retro one from Kuler.)

4. Save the file in the same folder as the F4YV file.

For the example, save the file as PlayVideol.fla.

g Scene 1 5 4] 100% @

THE€ BIJOU THEATER

SWATCHES

( | 2 . J

Figure 1-8: Base stage ready for FLVPlayer component.
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Importing and customizing your video
Next, you import the video and apply a skin and color scheme to it. Follow

these steps:

1. Choose Filem>Import~>Import Video.

The Import Video dialog box opens, displaying the Select Video page.

2. Select the Load External Video with Playback Component radio
button, and click the Browse button.

3. Select the F4YV file in the browser window and click Open.

Figure 1-9 shows an example. (Notice that the FLA and SWF files are in

the same folder.)

4. Click Continue in the Import Video window.

The Skinning page opens.

401

Import Video

Select Video

Where is your video file?
=) On your computer

File path: H‘c‘.‘se

Open

=) Load external video wil
Embed FLV in SWF and

[ Import as mobile devid

Already deployed to a web serve

[«]») (e

I

m | | [ Progressive Download

7] ([@Qsearch

Name

¥ DEVICES
=3 il sand
@ ipisk
) Macinto..
B &

Date Modified

Apr 22, 2008 8:57 PM
Yesterday, 6:13 PM
Today, 4:33 AM

Apr 1, 2008 5:34 PM

G | ¥ PLACES
Examples: http: /[, Em sktop |
rtmp: EY Movies
J3 Music
7 Applicati...
¥ MEDIA i
Jd music ' [T
Learn about Flash Media Server Enable: | All Video Formats %]
Learn about Flash Video Streamin
Cancel Open
2
" GoBack ) [ Continue Cancel
Figure 1-9: Select the F4V file to play.

5. From the Skin pull-down menu, choose a skin that has the player con-

trols you want.

Book VI
Chapter 1
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3

If you select a skin with the word Under in its filename, all the controls
are below the video. If the word Under isn’t in the filename, the player
controls are superimposed on the bottom portion of the video. (If you
prefer to display the entire video, choose an Under skin to place the con-
trols below it.)

In some cases, you may not even want any play controls. Select None
in the Skin pop-up menu in the Skinning selections in the Import Video
Window. In such cases, the video plays once and leaves the last frame
displayed on-screen. If you omit the play controls, make sure that you
don’t allow the video to loop and drive the viewer to distraction!

. Select a color.

In the example shown in Figure 1-10, the colors from the Swatches panel
open when you select a color for the skin. If you have a color scheme
that you're using for an entire page, you can select a color from the
same color scheme for your video skin so that your video player skin
blends in well with your page’s color scheme.

. Click Continue.

The Finish page opens, displaying all the settings you chose.

Import Video

Skinning

skin: | SkinUnderAll.swf ¥ coor: [m

The video's skin determines the appearance and position of the
play controls. The easiest way to get video for Adobe Flash up
and running is to select one of the provided skins.

To create your own look for the play controls, create a custom
skin SWF, select "Custom" in the Skin drop-down box, and enter
the relative path of the skin SWF in the URL field.

To remove all play controls and only import your video, select
“None” from the Skin drop down box.

Minimum width: 330 No minimum height

URL:

[ [ec7s829 Alpha: [T00% | ~ |
I

[Go Back \ (Cnm‘mue \ (" Cancel \

= _mE

Figure 1-10: Choosing a control skin and color.
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8. Click Finish.
9. If you haven’t saved your FLA file, do so at the prompt.
Remember to save it in the folder with the F4V file.
When you click Finish, you see a big black area where the video is set,
because the video is much larger than your default Stage. The selected F4V

file in Figure 1-11, for example, is 640 by 480 — way too big. In the following
section, you make some adjustments.

PlayVideol.fla® X

5 Scene 1 =) @ 100% g E

PROPERTIES |

‘E| SWF

Instance of: FLVPlayback

< POSITION & SIZE

€ ) 4lr

Figure 1-11: Video that’s too large for the Stage.

Resizing the video
To resize the video, follow these steps:

1. Open the Properties panel and set the proportion lock icon to lock.
2. Change the width to 320 and press Enter (Windows) or Return (Mac).

You should see the values in the Properties panel change to 320 by 240
pixels, and your video and page controls should appear on the Stage.
Changing the width and height of the video window doesn’t affect the
length of the video.

3. Center the video and the play controls, as shown in Figure 1-12.

Book VI

Chapter 1
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PlayVideol.fla™ >

#5 Scene 1 = @WE

PROPERTIES |

BN SWF ®

Instance of: FLVPlayback

THC BIJOU T

=~ POSITION & SIZE

Y: 800

H: 240.0

Figure 1-12: Video and play controls after resizing to fit the Stage.

4. Save everything.
5. Press Ctrl+Enter (Windows) or 3+Return (Mac) to watch the video.

Figure 1-13 shows an example of what you may see.

@e0e PlayVideol.swf
PlayVideolswt * |

TH< BIJOU THEAT<ER

Figure 1-13: A progressive download playing.
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Experimenting with the play controls

As a progressive download plays, try using the different play controls. You
can pause, rewind, and forward the video to the end, and you can use the
scrubber bar to move to different parts of the video.

The first time you run the video, you may have difficulty moving the video

ahead because it is still being downloaded. Testing it on your desktop isn’t

much of a problem, because the video is short and right on your computer.

If you place the files on a remote Web server (a host), however, it takes

longer for the video to get to your computer. As a result, not all parts of

the video are available. Scrubbing ahead may require you to play the whole

video once so that all of it is in the cache. Book VI
Chapter 1

Storing your files

When you finish testing the movie, you see a skin SWF file stored with
the FLA file. It’'s automatically added when you finish importing the
video. Depending on the name of the skin you select, you find a differ-
ent filename describing the skin. (For example, you might find one named
SkinUnderAll.swt.) If you transfer your application to a Web host, be
sure to include the special skin SWF file or else your movie won’t work
correctly.
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Changing videos

After you create an application to play a progressive download, you may
want to play a different video. Rather than create a whole new application,
you can easily change the FLV or F4V video to be played. The following steps
show you how, using the PlayVvideol. fla you created in the preceding
sections:

1. Place the new video you want to play in the same folder as the
PlayVideol. fla file.

For this example, we use the file named marketing. f1v. This file as
well as PlayVideo. f1la are available for downloading from this book’s
companion Web site.

2. Open PlayVideol. fla and click the FLVPlayer component to select it.

3. Choose Window=>Component Inspector to open the Component
Inspector panel.
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. Click the Parameters tab and locate the

source parameter (see Figure 1-14). 3
When you’re working with the FLVPlayer [[Parameters | Bindings _Schema |
component, place the Component Narie Value
Inspector panel in the dock to ease :'J?D"Pm g
the workflow. Think of the Component cusPaints None
Inspector as your assistant prewid Nartey _
scaleMode maintainAspectRatio
producer. skin SkinUnderAll.swf
skinAutoHide false
. Click the magnifying glass icon to the oot T
° skinBackgroun " _
right of the source parameter (refer to in o I .
Figure 1-15). volume 1 X
The Content Path dialog box opens.
. Type the path to the FLV or F4V file you
want to stream, as shown in Figure 1-15,
and click OK.

COMPONENT INSPECTOR || bb [ ==

Figure 1-14: The Component
Inspector panel showing FLVPlayer
parameters.

Content Path

‘marketing.fiv p | &

"1 Match source dimensions

I{_ Cancel ) OK ‘)

Figure 1-15: Specify the FLV or F4V source file.

If you click the Browse folder icon in the Component Inspector to

locate your video file on your system, you assign an absolute address

to your video file. When you place your files that play the video on a
Web server, the server tries to find that absolute address and fails. The
safest approach is to place all the FLV and F4V files you plan to play in
the same folder as your SWF file that plays the video, and type the name
of the video you want to play in the Component Inspector’s source
window. You can organize your videos in a separate folder and use a rel-
ative address, such as videos/marketing. £1v, but don’t use absolute
addressing to your video files that target your computer.

. Press Ctrl+Enter (Windows) or 3+Return (Mac).

You see the new video, as shown in Figure 1-16.
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PlayVideol.swf

THL BIJOU THECATECR

Figure 1-16: Playing a different video in the same application.

Changing the appearance of the play controls

When you change a video, you may want to change other features as well,
such as how the play controls look. In fact, you can use different play con-
trols without having to change the whole page. Follow these steps:

1. Open PlayVideol.fla and save it as PlayVideoZ2.fla in the same
folder as PlayVideol. fla.

This step gives you access to the FLV and F4V files without having to
start over.

2. Click the video icon representing the FLVPlayer component.

3. Choose Window=>Component Inspector to open the Component
Inspector panel.

4. If it isn’t already selected, click the Parameters tab of the Component
Inspector (refer to Figure 1-14).

5. Click the skin parameter.
A magnifying glass icon appears in the second column.

6. Click the magnifying glass icon to open the Select Skin dialog box (see
Figure 1-17).

Book VI
Chapter 1
o
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£33
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Select Skin
——
( cancel )
- O
Minimum width: 155 No minimum height
skin: | SkinUnderPlaySeekMute.swf ] Color: [mA|
. I [#+53037 Alpha: [100% [ - |

Figure 1-17: The Select Skin dialog box.

7.

Choose an option from the Skin pull-down menu.

For this example, we chose SkinUnderPlaySeekMute. swf.

. Click the Color box to open the color swatches and then choose a

color.
For this example, we chose dark brown, as shown in Figure 1-18.

Your color choices come from the color palette used for this design.
In this way, you can change the play controls yet stay within the color
scheme. (Go nuts, if you want, and make your own color scheme to
choose colors from.)

. Click OK to close the Select Skin dialog box.
10.

Test your movie by choosing Control->Test from the menu bar (or by
pressing Ctrl+Enter [Windows] or 8+Return [Mac]).

Voila! The new play controls are different but still fit the overall look, as
shown in Figure 1-18.
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PlayVideo2.swf

TUL BIJOU THECATER

Book VI
Chapter 1

Figure 1-18: Player with new skin.
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Streaming Uideo: Leaving the Socket Wide Open

The best way to deliver video on the Web is with streaming video. When
you use the Web, as soon as the Web page you've requested has arrived,
the Web connection between your browser and server is closed. Even with
sophisticated animation and pages that appear to be interactive, chances
are that you no longer have a Web connection.

Rather than deliver sound and video by opening and closing the connection
to the server, you can send streaming data by using open socket technology.
When you use this technology, after a connection is established, that con-
nection is maintained until the connection is closed by the client or is auto-
matically closed by an event, such as a recorded video coming to an end.
(For more on this topic, see Chapter 5 of this minibook.)

The following advantages of streaming technology make it quite popular:

1 The stream begins playing almost immediately.

1 Recorded video can be scrubbed ahead as soon as the video begins
playing.
1~ Streaming video provides smoother transmission of video and sound.

1 Audio (voice, music, sound effects, and so on) can be streamed without
video.

1~ Other types of media, such as text, can be streamed as well.

1~ Streaming allows for live interaction over the Internet. (Your mother-in-
law gets to visit remotely!)
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HTTP and RTMP: A tale of two protocols

For the Internet to work, a protocol has to be in place so that a client (a com-
puter hooked up to the Internet) can get stuff from a Web server (a remote
system with lots of stuff on it). The general protocol for this purpose is
HTTP (Hypertext Transfer Protocol). A request from the client is sent to the
server, creating a connection between the server and client. After everything
is delivered to the client computer, the connection is closed. That system
makes a lot of sense; the alternative would be keeping all connections open,
which would mean that only a few people could use the Internet at the same
time.

But what happens when you need a continuous stream of data moving over
the Internet, as in a two-way videoconference? If the connection is going to
have to be open and closed while the conference is in session, the results
are jerky and unintelligible. So Macromedia (now Adobe) came up with
RTMP (Real Time Messaging Protocol), which uses the open socket tech-
nology mentioned in the preceding section. When the connection between
the streaming server and the client is kept open, streaming media over the
Internet is much smoother. For this reason, most companies that have media
to stream (such as movie studios) use RTMP for streaming instead of HTTP.

A machine that’s dedicated to server software is what most people
imagine when they think about a server. Actually, servers can be hardware
or software — or both.

If you have a Macintosh computer, you have Apache Web Server built
in. Likewise, in certain Windows configurations, you can enable Internet
Information Services (IIS), which is also a Web server.

In the next section, you see how your computer can be a client, a Web
server, and a streaming server at the same time. (Your computer can do
more multitasking than a soccer mom.)

Enter Flash Media Server

In Chapter 5, you create an actual streaming-video project by using Flash
Media Server. For now, we just provide a brief overview of how the program
works. Fortunately, a good deal of what you may already know from reading
this book applies to streaming video.

First, look at Figure 1-19, which illustrates the streaming-media process.
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Web Server
N\

Step 1: Web server sends
SWF (compiled Flash) to

the client
Step 2: Client plays SWF

using Flash Player
(browser plug-in) Webcam

Client
Computer

Client receives video
stream from recording
or live stream

Flash Media Server
NN\ Client sends video

Step 3: FMS sends stream from camera

and receives data
stream

Figure 1-19: HTTP and RTMP data transfer.

The process begins with an SWF file sent from the Web server to the client. The
client plays the SWF file on a browser with a Flash Player plug-in. Then the SWF
file contacts Flash Media Server and makes a connection that allows streaming.

As you see in the illustration, the client is streaming back and forth between
the media server, not the Web server. It sends out an audio/video stream
from its own camera and microphone, and receives the same back from the
media server. All the while, the connection between the media server and
the client remains open.

This chapter is an orientation to video and Flash that gets you started and
shows different ways to display video with Flash. But as they say in the
movies, “You ain’t seen nothin’ yet!”

Book VI
Chapter 1
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Chapter 2: From Camera to
Desktop: Getting Uideo
Ready for Prime Time

In This Chapter

1 Choosing the right Webcam or digital video camera
v~ Finding free video-recording resources

1~ Seeing how to use some popular video programs

f you've worked with just about any kind of graphics on computers,
you’re aware that images can be saved in JPEG, PNG, or GIF format for
use on the Web. The same is true of video files that contain both audio and
video (A/V) elements; these files are saved in such formats as
WMV, MOV, AIFF, and AVI. As you see in Chapter 1 of this
minibook, the formats that Flash video uses for progres-
sive downloads and streaming are FLV and F4V.

In this chapter, you see some fundamental ways to
generate different kinds of video files for the Web. 7
Additionally, you see several kinds of cameras and . ; ‘ (o';
microphones that you can use to make videos. g L Logitech

Whatcha Gonna Do? Video
Camera or Webcam

The first question you have to ask yourself is what you
plan to do with video on the Web. If your goal is to have

video chats or to make fun little videos to share with your

friends, all you need is a Webcam. The quality of Webcams varies
significantly, but even the least expensive can get the job done for simple
video projects.

If you plan to be the next Steven Spielberg, producing everything from movie
trailers to your own dramas (or to become a YouTube star), you need a video
camera. Video cameras typically have better lenses, more flexibility, and
better control options than Webcams. Digital video cameras are relatively
inexpensive, but you can get professional-level, high-definition (HD) digital
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video cameras to get top-quality results. The sky’s the limit when it comes to
the price of video cameras. (Lucky you!)

If you plan to do a lot of A/V chatting and you want to make videos in loca-
tions away from your computer, you're well advised to get both a Webcam
and a digital video camera. You can use digital video cameras for video
chats, but they don’t work very well for this purpose because they gobble up
a lot of bandwidth.

Choosing a Webcam

Before you go out and buy a Webcam, check your computer; it may have a
built-in Webcam already. Many recent laptop and iMac computers do. Check
to see whether the top of your screen has a little square window with a small
lens inside. Both the Dell laptop and the iMac we use have built-in Webcams,
and if we hadn’t known where to look, we might have overlooked the cam-
eras. (They’ve been watching us!)

The decision about which Webcam to buy is based on a few key factors:

1~ Resolution: The camera’s resolution refers to the size of the screen (in
pixels) that the camera can handle. For video chats, 320 x 240 resolution
generally is all you need, but you can find Webcams with resolution up
to 1600 x 1200 pixels. Also look for the number of megapixels that the
camera handles (generally, between 1.2 and 2).

You have to be careful in comparison shopping, because cameras
often have two ratings: one for still photos and another for video. The
Creative Live! Cam Optia AF, for example, has a rating of 8 megapixels
for still images and 2 megapixels for video.

1 Lens: You need to consider factors including focal length, iris, and lens
construction. Price also is a factor: Cheaper lenses generally result in
lower quality.

One of the best lenses we found is the Carl Zeiss Tessar optical system
used in the Logitech QuickCam Pro 9000 camera (see Figure 2-1).

1~ Light sensitivity: The more light a camera requires, the less light sensi-
tivity it has. This fact is a two-edged sword. If you have bad lighting in
your environment, light sensitivity is important, but often, good light
sensitivity results in a lower-quality picture. It’s better to improve your
lighting than the lighting sensitivity of your camera. (Well, if you live in a
bat cave, you may need good light sensitivity.)

1~ Autofocus: This feature automatically keeps the focus on the central
figure in the video — generally, you. This important feature is built into
the Apple iSight, Logitech QuickCam Pro 9000, and Creative Live! Cam
Optia AF cameras, among others.
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Figure 2-1: Logitech 9000 Webcam.

Autofocus is very handy, but face-following is not. Face-following means
that the camera follows you as you move around. The results aren’t
always what you expect. Sometimes, the camera chooses to follow an
unintended object or to overtrack (track beyond the point where you
stop). On the other hand, zooming and panning features are very handy
for framing a shot just the way you want.

Frames per second (fps): Generally, you should look for a camera that
operates at 15 or 30 fps. Higher resolutions tend to get lower fps. The
same camera can have 30 fps at 320 x 240 resolution but only 15 fps at
640 x 480, for example.

Bandwidth use: This information is difficult to find, because it generally
isn’t published. Creative Labs has an excellent reputation for producing
Webcams that sip bandwidth, but at the cost of some picture quality.

Built-in microphone: This feature can be handy — and also a problem.
Depending on how far the camera is from your mouth, you need to con-
sider whether you’d rather have a remote mike.

Software: Some cameras come with software that you can use to create
videos and special effects.

Driver compatibility: You can find yourself in a real nightmare if your
camera is incompatible with your computer. You need software drivers
that work with your operating system; they may work with Windows XP
but not Windows Vista, for example, and may not work with a Macintosh
at all. Also check the manufacturer’s Web site for the most recent driver
updates.
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IEEE versus USB

When IEEE 1394 Webcams came out, they were  an IEEE 1394 port on your computer, be aware
the best ones available. Nowadays, almost all  that it probably doesn't have software that's
new Webcams use USB instead, so we don't compatible with your computer — especially
cover IEEE 1394 cameras in this chapter. if you have a newer operating system, such as

If you dig up one of these cameras online, how- el Vit ot L W2 L e,

ever, and expect it to work because you have

Choosing a video camera

From the get-go, you should know that a digital video camera is going to use
more bandwidth than a Webcam. You’re not likely to be using the camera for
chat sessions, though, so you shouldn’t have to worry about it.

Choosing a digital video camera involves all the same considerations as
choosing a Webcam (see the preceding section), as well as the following key

factors:

1~ Compatibility: Most older digital video cameras that you can purchase
inexpensively at places like eBay are strictly IEEE 1394. Be sure that your
computer has an IEEE 1394 port (called a FireWire port on a Macintosh).
Newer digital video cameras have both USB 2 and IEEE 1394 connec-
tions. Also make sure that the camera has compatible software (see the
nearby sidebar “IEEE versus USB” for details).

 High definition: Now that Flash can convert your video to H.264 format,
you can stream HD video in F4V files. If you need HD for your video proj-
ects, you pay more for the camera, but you get high quality.

You can get an inexpensive digital video camera or a professional-level one.
The process for getting video files from the camera to your computer is the
same for all digital video cameras.

Free Resources for Creating Uideos

When you buy almost any new computer these days, you find some kind of
video recording program included. Computers that use the Windows oper-
ating system (both Windows XP and Windows Vista) have Windows Movie
Maker, and Apple Macintosh computers that run Mac OS X include iMovie.

In addition to the free software included with your computer, you can use
free software from Adobe to create videos right on your desktop. Adobe
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Flash Media Live Encoder 2.5 takes any video source from a Windows com-
puter and converts it to FLV or F4V files; download it at www.adobe . com/
products/flashmediaserver/flashmediaencoder. For playing back
FLV and F4V files, you can get Adobe Media Player for both Windows and
Macintosh at www.adobe.com/products/mediaplayer.

A final source of free software for creating video files is the software that
comes with certain Webcams. Logitech, for example, supplies software for
creating, editing, and adding special effects to videos created with its cam-
eras. Likewise, Creative Labs provides software that you can use to create
and edit videos.

The following sections discuss a few of these resources in more detail.

Windows Movie Maker

If you have a Windows computer and a digital video camera, get out your
director’s chair and listen up. Windows Movie Maker works only with a digi-
tal video camera, so if you have a built-in or external Webcam but no digital
video camera, skip this section.

Windows Movie Maker is a simple-to-use program that captures video
directly from your digital video camera or from a storage device in your
camera (a digital tape, card, or minidisc) and then stores that video in a
WMV file where you specify. To use the program, follow these steps:

1. Connect your digital video camera to your computer, turn it on, and
prepare it to record.

Don’t forget to remove the lens cap. If you see a dark space where your
smiling face should be, check the lens cap first. Also make sure that your
camera isn’t set for playback.

2. Launch Windows Movie Maker and click Capture from Video Device.

The Video Capture Wizard opens, and you should see the name of your
digital video camera (Canon DV Device, Sony DV Device, or a similar
name).

3. Select the icon for your camera and click Next.

4. Enter a filename, select a place to save your captured video, and click
Next.

For this example, we chose to name the file megahit.

You can accept the default storage folder (My Videos) or browse to
another folder where you want to store files for later conversion to FLV
or F4V format.

5. Select Best Quality for Playback on My Computer (Recommended),
and click Next.
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The wizard’s Capture Video page opens. You should see your face (or
whatever the camera is pointing at) in the Preview window, as shown in
Figure 2-2.

Video Capture Wizard: Canon DV Device

B
Capture Video [
Click, the Start Capture button to begin capturing your video. *r'ou can caplure one of more

video clips.

Steps: Preview:

L. Start Capture
2. Stop Capture

3. To capture another video dlip,
repeat steps 1 and 2,

Video captured:  0:00:00
Size of videafile: O KB

Estimated disk space available:
10,66 GB remaining on drive C:

Create dips when wizard finishes
[] Mute speakers

[ Capture time limit (hbzmm}: | 200 _‘

I < Back “ Finish ]I Cancel ]

Figure 2-2: Previewing a camera setup in Windows Movie Maker.

6. Click the Start Capture button; then recite a poem, greet a friend, or
say something clever.

As you record, the Capture Video page provides two vital pieces of infor-
mation: the amount of space the video is consuming per minute (about
14MB) and the amount of space left on your hard drive to store it. These
displays are subtle reminders that videos take lots of memory and can
quickly eat up the remaining space on your hard drive.

7. After no more than a minute, click the Stop Capture button.
The recording stops.
8. Click the Finish button.

A little window displays a progress bar, and then you see a video icon
with the name of your movie. To close the wizard and exit Windows
Moviemaker, just click the X in the upper-right corner of the screen.

At this point, you've created a video file. You should be able to find it
wherever you chose to store it in Step 4. Double-click its icon to play it in
Windows Media Player.

In Chapter 3, you see how to use Flash to convert this file to play on the Web.
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Adobe Flash Media Live Encoder (Windows )

If you have a Windows computer, you can download Adobe Flash Media Live
Encoder and use it with any camera you have connected to your system,
including your built-in Webcam. (Get Adobe Flash Media Live Encoder 2.5 or
later for the examples in this book.) This program may seem a bit technical
when you first open it, but it’s easy to use.

Thanks to confusing naming policies, the Adobe Media Encoder CS4 that
comes with Flash CS4 is not the same thing as (or even similar to) Adobe Flash
Media Live Encoder. The former — which is intended solely for converting
non-FLV or non-F4V files to FLV or F4V files — is covered in Chapter 3.

Take a quick look at Figure 2-3. Notice that the picture isn’t as good as the
one shown in Figure 2-2, earlier in this chapter. That’s because it was shot
on an inexpensive built-in Webcam instead of a digital video camera. Adobe
Flash Media Live Encoder does many things (some of which we discuss in
detail in Chapter 4), but for now, all you want to do is create a simple video
saved in either FLV or F4V format, using either a Webcam or a video camera.

™ Adobe Flash Media Encoder 2.5
File Ip

Laptop Integrated Webcam ! Microphene Array (SigmaTel Hig » ./

FzEa T 7 sitRate (I « : Mp3 v [Mono v

22050 > Hz

portableBuilt in.fav

Figure 2-3: AWebcam recording in Adobe Flash Media Live Encoder.
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To use Adobe Flash Media Live Encoder for recording, follow these steps:

1.

Connect your camera to your computer, turn it on, and prepare it to
record.

2. Launch Adobe Flash Media Live Encoder.

. In the lower-left pane of the encoder window, choose your camera

from the Device pull-down menu.

In Figure 2-3, for example, the selected camera is Laptop Integrated
Webcam.

4. Choose H.264 from the Format pull-down menu.

5. Choose 320x240 from the Size pull-down menu.

6. In the lower-right pane of the encoder window, select the Save to File

check box.

. In the Save to File text box, type a filename.

For this example, we named the file portableBuilt_in. f4v.

Whenever you choose the H.264 format, the file extension is . f4v; any
other format uses the . £1v extension.

At this point, you needn’t worry about any of the other settings in the
encoder window.

8. Click the green Start button to begin recording.

9. When you’re finished, click the red Stop button.

10.

Retrieve the F4V file and play it in Adobe Media Player, as shown in
Figure 2-4.

Figure 2-4: Playing an F4V file in Adobe Media Player.
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The best feature of Adobe Flash Media Live Encoder is that it saves your file
in a format that Flash can read for progressive download or streaming video.
(For details on both progressive download and streaming video, see Chapter

1 and Chapter 5 of this minibook.)

Webcam software

To give you an idea of the software that comes with a Webcam, this sec-

tion looks at Logitech’s QuickCapture. The camera in question, a Logitech
Orbit, has a zoom-and-pan feature so that you can center the subject without
having to move either the camera or the computer. The files are saved in
Windows Media Video format (. wmv), and all you need to do to create them
is plug in the camera and click the Record button.

Use the Webcam Settings window to set the pan, tilt, zoom, brightness, con-
trast, color intensity, and white balance, as shown in Figure 2-5.

@ QuickCam® ?1l=

QuickCapture

Select Image Size
(e-mail size) 320x240 4

=

Record Video

B >

Take Photo

X

2 QuickCam®

2

Webcam Settings

Gallery ¥

4 lam |y

2

L, [ '5\

N
3

Pan and Tilt Zoom

Face Tracking
® orf

O Follow me

\.‘IJD m

S
Contrast

- E +*
Color Intensity

- ﬁ +
White Balance  [¥] Auto

— —| — +
) Low Light Boost

[_] Color Boost

Return to Default Settings

al

Figure 2-5: Recording with Logitech QuickCapture.

You can also choose Low Light Boost and Color Boost options. A Face
Tracking (face-following) option is available as well, but as we note earlier in
this chapter, we tend to keep this feature turned off because it causes more
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problems than it solves. Even on the best Webcams, the feature never seems
to work as intended.

Finally, compare the images shown in Figure 2-4 and Figure 2-5. You can see
the differences in quality. Both images were taken with a Webcam, but the
details and quality of the image shown in Figure 2-5 are much better. These
examples give you an idea of the quality range available in Webcams.

You can take advantage of the zoom, pan, and tilt features of the QuickCapture
software and at the same time save your files in FLV or F4V format. First,
open the software, and set the zoom, pan, and tilt just the way you want.
Then close the software, open Adobe Flash Media Live Encoder, and record
in the format you want to use.

iMovie (Macintosh)

If you have a recent Macintosh running Mac OS X, you're blessed with an
excellent yet simple tool for making all the videos you want: iMovie. You can
record using either a Webcam (most likely, a built-in iSight) or a digital video
camera. The iSight has excellent quality and autofocus capability, whether
it’s the built-in version at the top of the screen or the external version con-
nected by a cable.

Recording a video
To record a video in iMovie, follow these steps:

1. If you’re using an external Webcam, connect it to your computer; turn
it on; and prepare it for shooting video.

If you have a built-in iSight Webcam, the camera is ready to go when you
need it; you don’t need to connect it.

2. Launch iMovie (or iMovie HD).

3. Choose Create New Project.
The Create Project dialog box opens.

4. Type a filename in the Project text box.
For this example, we used MacMovie.

5. From the Where pull-down menu, choose where you want to save the
project.

For this exercise, we chose Movies to save to the Movies folder.
6. Choose a format from the Video Format pull-down menu.

If you're using an iSight camera, choose iSight; if not, choose the format
that applies to your camera.
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7. Click OK.

The project window opens. Centered below the video window are the
play controls; to the left of the play controls, you see a selector switch
between a camera icon (Camera mode) and a scissors icon (Edit mode)

(see Figure 2-6).

00313 |
"'
Clip 01 ]
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Drag clips here to build your project.

(GO

140 GB available = {7 0KB

Camera | Edit

Selector switch

Figure 2-6: Recording with iMovie.

8. Drag the selector switch left, to the camera icon.

At this point, you should see the camera feed from either your external
camera or your iSight camera in the video window. A Record button is
superimposed on the image at the bottom-center of the video window
pointed out in Figure 2-6.

9. Click the Record button to begin recording.

As soon as you click the button, you see a thumbnail image (a clip) in
one of the cells to the right of the video window. Here’s another chance
to make a screen test for YouTube, so get your groove on.
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10. After about 30 seconds, click the Record button again to stop
recording.

You can record longer, if you like, but even a short recording takes up a

lot of hard disk space.

11. Drag the selector switch to the scissors icon (Edit mode). (See
Figure 2-6.)

Just to the left of the camera and scissors icons are two other icons: a
frame of film (Clip Viewer) and a clock (Timeline Viewer). In Figure 2-6,
the clock icon is selected.

12. Click the film frame icon to open Clip Viewer.

13. Drag the movie clip from Step 9 to the area at the bottom of the
window that reads Drag clips here to build your project,
as shown in Figure 2-6.

You see the thumbnail of your video in the Clip Viewer, as shown in
Figure 2-7, when the move is completed.

Editdummy (iSight}

CENCEE

S

204 —

e[ 100 [0

“Clip 02" |0:14:06 of 0:14:06 total

140 GB available | §f 27 M8 |

i

Playhead

Clip dragged to Timeline

Selector in Edit mode Timeline

Figure 2-7: Playing a recorded movie.
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The big guns: Truly powerful video editors

If you want to create some memorable videos
using complex editing, special effects, and any-
thing else George Lucas or Steven Spielberg
could dream up, you have lots of choices. Three
of our favorites are the following:

+~ Adobe Premiere Pro (Windows and
Macintosh): With Adobe Premiere Pro (www .
adobe . com), you can work with most
video formats, including HD format. The
program offers a wide variety of special
effects, titles, transitions, and up to 4000
x 4000 resolution. Premiere Pro integrates
easily with three other Adobe products:
After Effects, Photoshop, and Soundbooth.
The latest version features Ultra 2 chroma
keying. Premiere Elements (Windows only)
is a scaled-down version, available at a
considerable saving.

+~ Final Cut Pro (Mac 0S X): If you have your
heart set on entering a film in the Sundance
Film Festival, you may want to take a look

at Final Cut Pro (www . apple. com). Used
by many independent filmmakers, this video
editor can edit a wide range of video for-
mats, including HD, and has its own spe-
cial effects, transitions, and other editing
essentials. It integrates well with Apple’s
Soundtrack and LiveType software. To use
all its features, be prepared to spend some
time learning how to use it. If your budget is
limited, try Final Cut Express HD for consid-
erably less money.

Vegas Pro (Windows): Sony’s Vegas Pro
(www . sonycreativesoftware.com/
products/vegasfamily.asp) also
has a large following. It's best known for its
intuitive interface and ability to handle up to
64-bit channels. Like the other professional
editing programs in this list, it can integrate
multiple channels of video and audio to
create professionally produced and scored
digital videos.

14. Click the clock icon to open the Timeline Viewer.

You see the video timeline at the bottom of the project window, as

shown in Figure 2-7.

15. Choose Filer>Save Project (or press $8+S).

16. Choose File=>Export.
The Export dialog box opens.

17. Choose Full Quality from the Compress Movie pull-down menu, and

click the Share button.

Testing your video

To test your video file, navigate to the folder where you saved it in Step 5 in

the preceding section (the file has a .mov extension), and double-click the
file to play it in QuickTime Player. You should get excellent results.
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For the test file in Figure 2-6, earlier in this chapter, we used a Canon G2 DV
camera, which approaches professional quality. But you can get excellent
results from an iSight Webcam too.

Now that you know several ways to capture video as digital files, the next
step is modifying those files so that they can be played on the Web — and
in such a way that the viewer’s experience is the one you want. Chapter 3 in
this minibook provides the details.



Chapter 3: Getting Uideo
Files Ready for Flash

In This Chapter

1 Completing preproduction

»» Knowing what can be converted

1~ Converting files with Adobe Media Encoder CS4
~ Cropping videos

1~ Adjusting file settings

1~ Cueing videos

Before you can play a video with Flash CS4, you need to convert all
those MOV, WMV, AVI, and other non-Flash-formatted files

to FLV or F4V files. The FLV files are standard Flash video
files using the VP6 compression format. The new F4V
files are based on a standard with a better video qual-
ity: H.264. Included with Flash CS4 is Adobe Media
Encoder CS4, with which you can easily convert
video files to FLV or F4V file format. The encoder
also allows you to set different parameters and
even crop the video, so you can do a little last-
minute editing with it.

In this chapter, we look at the different things

you can do before you convert your video file into
an FLV or F4V file. We take a look at how the file
conversion process works, how to select a video file
type, and how to determine which options you have.
Films have to be edited, special effects added, and boo-
boos removed. You might want to make your video just a little
longer or shorter as well. These processes need to be handled before
conversion to FLV or F4V files because the main tools for editing such as
Adobe Premiere, Adobe After Effects, Apple Final Cut, and even Microsoft
Movie Maker cannot edit files converted for running in Flash CS4. So before
you get to the point where you cannot edit your FLV or F4V file, you need to
do your preconversion work.
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Managing Postproduction before Conversion

In show biz, the term postproduction refers to everything you do to a video
after you have it in the can (the can being an old-fashioned reference to
those metal cases that hold film). Included in postproduction are simple
steps like cutting out those parts of your video that you don’t like. You can
easily do this kind of simple editing with an application such as Windows
Movie Maker or iMovie. More complex editing includes chroma keying
(electronically cutting out a key color and replacing it with a different back-
ground), using a high-end editing program like Adobe Premiere Pro or Final
Cut Pro.

Figure 3-1 shows a video in Premiere Pro, with the image on the left featuring
a blue chroma screen in the background and the image on the right show-
ing a studio background. The video is the same, but postproduction work
changes the image significantly.

Edt Project Clp Sequence Marker Title Window Help

L I 3

ik

-

f ik

Figure 3-1: Complete all preproduction tasks, such as changing a background, before converting a file.
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é."\‘\ You can’t do this kind of editing during or after the conversion process. You

must do all your postproduction work before using Adobe Media Encoder to
convert the video to a Flash file.

Choosing File Types for Conversion

The number of video file formats seems to grow every day, with new ones
being developed or old ones being discovered. We have personally tested
the following file types by successfully converting them into FLV or F4V files
and running them in a Flash application:

Book VI
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You're likely to find more formats that work and others that don’t. The basic &

test of a file format you can convert is to try dragging a file in that format
into Adobe Media Encoder. If the process doesn’t work, you see a message
such as the one shown in Figure 3-2.

' The file fUsers/billsanders/Desktop/temphide/AIO Book/AlIO-video/Ch02/
=

Web/LogitechOrbit.wmv could not be imported.

0K,
l

Figure 3-2: Video file refused by Adobe Media Encoder.

If you look carefully at the figure, you see that a WMV file is being refused.
Although Adobe Media Encoder accepts WMV files, sometimes, an individual
file that you try to encode has been corrupted. Being corrupted does not mean
that the file received a bribe, but that something wrong with it disallows
encoding — missing or added code, for example. Also, the Mac version of
Adobe Media Encoder doesn’t convert WMV files under any circumstances.

Converting Files with Default Options

After your video file is all edited and ready to go, you're ready to convert
it. In this section, we show you how to convert files with standard output
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options; later in this chapter, in the section “Customizing Conversions,” we
show you how to customize your output.

The companion Web site provides two very big AVI video files (each larger
than 100MB): movU. avi and movUF . avi. They are from the same source,
but one has been changed so that it has a different background. You can use
them to complete the following exercise, if you want.

To convert AVl files to F4V files, follow these steps:

1. Place the AVI files on the desktop.
This step makes them handy for dragging into the converter.

2. Open Adobe Media Encoder CS4 by double-clicking on the icon.
A big gray window opens on-screen.

3. Drag the two AVI files into the encoder window.

You have to wait a few seconds for the files to show up on-screen. When
they’re ready, you see their names and locations in the Source Name
column of the encoder window, as in the example shown in Figure 3-3.

Adobe Media Encoder . (= [ ] [

File Edit Help

coding, drag video files into the c
Fon
movUF.avi ¥ FLV | Fav aiting

\movU.avi ¥ ALV |Fv Waiting

Figure 3-3: Two AVl files loaded in Adobe Media Encoder.

If you have your video files scattered hither and yon on your computer,
you can click the Add button in the encoder and browse for the files
instead of using the drag-and-drop technique.

4. From the Preset pull-down menu, choose F4V - Same As Source (Flash
9.2 and Higher).

Figure 3-4 shows the selection being made.

Because Flash Player is free, most users update to the latest version.
Some users, however, simply keep their old players. How can you tell
whether viewers have older players? You receive e-mail complaining
that they can’t see your movie! (This technique is adopted from the
method of locating land mines by stomping on the ground.) If your pri-
mary audience is likely to have older versions of Adobe Flash Player,
choose one of the formats for older Flash players: FLV — Same As Source
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(Flash 7 and Higher), for example, accommodates any player from ver-
sion 7 to version 10.

F4V - 1080p Source, Half Size (Flash 9.2 and Higher)
F4V - 1080p Source, Quarter Size (Flash 9.2 and Higher)
F4V - 720p Source, Half Size (Flash 8.2 and Higher)
F4V - 720p Source, Quarter Size (Flash 9.2 and Higher)
F4V - HD 1080p (Flash 9.2 and Higher)
F4V - HD 720p (Flash 9.2 and Higher)
F4V - NTSC Source, Web Large (Flash 9.2 and Higher)
F4V - PAL Source, Web Large (Flash 9.2 and Higher)

+ FAV - Same As Source (Flash 9.2 and Higher)
F4V - Web Medium (Flash 9.2 and Higher)
F4V - Web Modem (Flash 9.2 and Higher)
F4V - Web Small (Flash 9.2 and Higher) Book VI
F4V - Widescrean Source, Web Large (Flash 9.2 and Higher)
FaV - Widescreen Source, Web Medium (Flash 9.2 and Higher)
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FLV = NTSC Source, Web Large (Flash 8 and Higher)
FLV - PAL Source, Web Large (Flash 8 and Higher)
FLV - Same As Source (Flash 7 and Higher)

FLV - Same As Source (Flash 8 and Higher)

FLV = Web Medium (Flash 8 and Higher)

FLV = Web Small (Flash & and Higher)

FLV - Widescreen Source, Web Large (Flash 8 and Higher)
FLV - Widescreen Source, Web Medium (Flash 8 and Higher)

Edit Export Settings...

ysey{ 1o} Apeay
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Figure 3-4: Setting the compression type.

5. Click the Start Queue button and wait while both files are compressed.

As the conversion process is taking place, the lower-right corner of the
encoder window shows the part of the video that is being compressed.

When the compression process is complete, a green check appears in
the file’s Status column.

In the example shown in Figure 3-5, you see that the first of the two files
is finished, but the second one is still in progress.

Notice what happened to the size of the video file. Right-click the F4V
file icon and choose Properties from the shortcut menu (Windows) or
Ctrl+click the icon and choose Get Info from the shortcut menu (Mac).
You see that the new video is highly compressed. If the original AVI files
were 102MB, for example, the F4V files are about 3.8MB. (That would

be similar to a 200-pound person going on a diet and weighing only 7.6
pounds when he finished!)

6. Test the file in Adobe Media Player.
You shouldn’t see any difference between running it as an F4V file and
running it as an AVI file.

Figure 3-6 shows an F4V file playing in Adobe Media Player. This video is
ready to be sent over the Internet as a progressive download or streamed.
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Figure 3-6: An AVl video playing in F4V format.
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Customizing Conversions
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When you pull a file into Adobe Media Encoder for conversion, you can
make choices from the Format and Preset pull-down menus to customize
the process:

» Format: The Format pull-down menu provides two choices: FLV | F4V
(H.264) and H.264. We don’t deal with the H.264 format outside the F4V
format, so for the rest of this minibook, you can leave the Format menu
set to FLV | F4V (H.264).

1~ Preset: In general, when dealing with FLV/F4V files, you can simply make
any choice from the Preset pull-down menu. In this minibook, for the
most part, we discuss presets for Flash Player 9.2 or later.

Choosing a compression codec

Each of the three main FLV formats uses one of three codecs. A codec (short
for coder-decoder) is the compression format used to shrink your file. In the
section “Converting Files with Default Options,” earlier in this chapter, a
codec reduces an AVI file to about 4 percent of its original size.

In addition to compressing a file, a good codec optimizes the file’s quality —
both video and audio.

Flash has had three different codecs since the introduction of streaming
video, and you can choose any of them from the Preset pull-down menu in
Adobe Media Encoder:

» FLV (Sorenson Spark): Used in Flash 7 presets
» FLV (On2 VP6): Used in Flash 8 presets
 F4V (MainConcept H.264 Video): Used in Flash 9.2 presets

As a rule of thumb, use the newest format because of the increasing quality
of audio and video. With larger video formats, you see the greatest differ-
ence in quality.

Managing bandwidth

Each preset has several options, and in preparing videos for the Web, you
need to consider bandwidth above all else when deciding which option to
choose. Bandwidth is the amount of stuff you have to port over the Internet
to display your video.

Larger formats have more content; smaller ones have less. If your video uses
too much bandwidth, you can run into nasty problems because your video
can freeze, lose frames, or seemingly become separated from the audio.
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The presets are not necessarily set up to optimize bandwidth, so in looking
closely at the settings, you need to ask, “How will this affect the amount of
bandwidth required and the experience the user has?”

Your original video file is preserved so that you can use it often to try out
different settings when you convert it to a FLV or F4V file. You can save
bandwidth by using mono audio rather than stereo, lowering the audio qual-
ity (lower kHz values), reducing the video window size, and adjusting several
other settings discussed later in this chapter. As a rule of thumb, lower qual-
ity and smaller size take up less bandwidth.

Trimming Your Uideo: A Little Nip and Tuck

A\

When you make a video, the ideal is to do as much editing in the camera as
possible, which means that you should plan all your shots so that you don’t
have to do too many cut-and-paste operations in the editing stages. When
you’re preparing a video for conversion to FLV or F4V format, you should do
your editing first, but Adobe Media Encoder allows you to do a little editing
in the encoder window.

To trim a bit off the end of a video in the encoder, follow these steps:

1. Open Adobe Media Encoder by double-clicking its icon.
2. Drag a video into the encoder window.
We chose movUF . avi in the example.
3. Make a choice from the Preset pull-down menu.
We chose F4V - Same As Source (Flash 9.0.r115 and Higher).
4. Double-click the name in the Preset column.
The Export Settings window opens, as